Guía del usuario Cancelar

Secuencias de comandos

  1. Guía del usuario de After Effects
  2. Versiones beta
    1. Descripción general del programa beta
    2. Comunidad beta de After Effects
  3. Introducción
    1. Introducción a After Effects
    2. Novedades de After Effects 
    3. Notas de la versión | After Effects
    4. Requisitos del sistema para After Effects
    5. Métodos abreviados de teclado en After Effects
    6. Formatos de archivo admitidos | After Effects
    7. Recomendaciones de hardware
    8. After Effects para Apple Silicon
    9. Planificación y configuración
  4. Espacios de trabajo
    1. Elementos generales de la interfaz de usuario
    2. Familiarización con la interfaz de After Effects
    3. Flujos de trabajo
    4. Espacios de trabajo, paneles y visores
  5. Proyectos y composiciones
    1. Proyectos
    2. Conceptos básicos sobre composiciones
    3. Precomposición, anidamiento y preprocesamiento
    4. Ver información de rendimiento detallada con el Perfilador de composición
    5. Procesador de composición de Cinema 4D
  6. Importación de material de archivo
    1. Preparación e importación de imágenes fijas
    2. Importación desde After Effects y Adobe Premiere Pro
    3. Importación e interpretación de vídeo y de audio
    4. Preparación e importación de archivos de imagen 3D
    5. Importación e interpretación de elementos de material de archivo
    6. Uso de elementos de material de archivo
    7. Detección de puntos de edición con Detección de edición de escena
    8. Metadatos XMP
  7. Texto y gráficos
    1. Texto
      1. Formato de caracteres y el panel Carácter
      2. Efectos de texto
      3. Creación y edición de capas de texto
      4. Aplicación de formato a párrafos y el panel Párrafo
      5. Extrusión de capas de texto y formas
      6. Animación del texto
      7. Ejemplos y recursos para animación de texto
      8. Plantillas de texto interactivo
    2. Gráficos animados
      1. Trabajar con plantillas de gráficos animados en After Effects
      2. Uso de expresiones para crear listas desplegables en plantillas de gráficos animados
      3. Trabajo con propiedades esenciales para crear plantillas de gráficos animados
      4. Reemplazo de imágenes y vídeos en plantillas de gráficos animados y propiedades esenciales
      5. Anime de forma más rápida y sencilla utilizando el panel Propiedades
  8. Dibujo, pintura y trazados
    1. Descripción general de las capas de forma, trazados y gráficos vectoriales
    2. Herramientas de pintura: Pincel, Tampón de clonar y Borrador
    3. Estrechar trazos de forma
    4. Atributos de forma, operaciones de pintura y operaciones de trazado para capas de forma
    5. Uso del efecto de forma Desplazar trazados para modificar formas
    6. Creación de formas
    7. Creación de máscaras
    8. Elimine objetos de sus vídeos desde el panel Relleno según el contenido
    9. Pincel tipo rotoscopia y Perfeccionar mate
  9. Capas, marcadores y cámara
    1. Selección y organización de capas
    2. Modos de fusión y estilos de capas
    3. Capas 3D
    4. Propiedades de capa
    5. Creación de capas
    6. Administración de capas
    7. Marcadores de capa y marcadores de composición
    8. Cámaras, luces y puntos de interés
  10. Animación, fotogramas clave, seguimiento del movimiento y efecto de clave
    1. Animación
      1. Conceptos básicos sobre animaciones
      2. Animación con herramientas de marioneta
      3. Administración y animación de trazados de formas y máscaras
      4. Animación de formas de Sketch y Capture con After Effects
      5. Herramientas de animación varias
      6. Trabajo con animación basada en datos
    2. Fotograma clave
      1. Interpolación de fotogramas clave
      2. Ajuste, selección y eliminación de fotogramas clave
      3. Edición, desplazamiento y copia de fotogramas clave
    3. Seguimiento de movimiento
      1. Seguimiento y estabilización del movimiento
      2. Seguimiento de caras
      3. Seguimiento de máscara
      4. Referencia de máscara
      5. Velocidad
      6. Ampliación del tiempo y reasignación del tiempo
      7. Unidades de visualización de tiempo y código de tiempo
    4. Incrustación
      1. Incrustación
      2. Efectos de incrustación
  11. Transparencia y composición
    1. Descripción general y recursos sobre composición y transparencia
    2. Canales alfa y mates
    3. Mates de seguimiento y mates móviles
  12. Ajuste del color
    1. Conceptos básicos sobre colores
    2. Gestión de color
    3. Efectos de corrección de color
    4. Gestión de color de OpenColorIO y ACE
  13. Ajustes preestablecidos de animación y efectos
    1. Información general de efectos y ajustes preestablecidos de animación
    2. Lista de efectos
    3. Administrador de efectos
    4. Efectos de simulación
    5. Efectos de Estilizar
    6. Efectos de audio
    7. Efectos de distorsión
    8. Efectos de perspectiva
    9. Efectos de canal
    10. Efectos de generación
    11. Efectos de transición
    12. El efecto Reparación de obturación de desplazamiento
    13. Efectos de desenfoque y enfoque
    14. Efectos de canal 3D
    15. Efectos de utilidad
    16. Efectos mate
    17. Efectos Ruido y Granulado
    18. Efecto Mejora de conservación de detalles
    19. Efectos obsoletos
  14. Expresiones y automatización
    1. Expresiones
      1. Conceptos básicos sobre expresiones
      2. Comprensión del lenguaje de expresión
      3. Uso de los controles de expresión
      4. Diferencias de sintaxis entre los motores de expresiones de JavaScript y ExtendScript heredado
      5. Edición de expresiones
      6. Errores de expresiones
      7. Uso del editor de expresiones
      8. Uso de expresiones para editar y acceder a las propiedades de texto
      9. Referencia del lenguaje de expresión
      10. Ejemplos de expresiones
    2. Automatización
      1. Automatización
      2. Scripts
  15. Vídeo inmersivo, RV y 3D
    1. Construcción de entornos de VR en After Effects
    2. Aplicar efectos de vídeo envolvente
    3. Herramientas de composición para vídeos de VR/360
    4. Procesador 3D avanzado
    5. Importación y adición de modelos 3D a la composición
    6. Importación de modelos 3D desde las Bibliotecas Creative Cloud
    7. Iluminación basada en imágenes
    8. Extracción y animación de luces y cámaras a partir de modelos 3D
    9. Seguimiento del movimiento de la cámara 3D
    10. Proyección y aceptación de sombras
    11. Animaciones de modelos 3D incrustadas
    12. Captura de sombras
    13. Extracción de datos de profundidad 3D
    14. Modificación de las propiedades de materiales de una capa 3D
    15. Trabajo en espacios de diseño 3D
    16. Herramientas de transformación Gizmo 3D
    17. Haga más cosas con la animación 3D
    18. Previsualización de los cambios en diseños 3D en tiempo real con el motor Mercury 3D
    19. Adición de diseño interactivo a los gráficos 
  16. Vistas y previsualizaciones
    1. Previsualización
    2. Previsualización de vídeo con Mercury Transmit
    3. Modificación y utilización de vistas
  17. Procesamiento y exportación
    1. Principios básicos del procesamiento y la exportación
    2. Codificación H.264 en After Effects
    3. Exportación de un proyecto de After Effects como un proyecto de Adobe Premiere Pro
    4. Conversión de películas
    5. Procesamiento de varios fotogramas
    6. Procesamiento automático y en red
    7. Procesamiento y exportación de imágenes fijas y secuencias de imágenes fijas
    8. Uso del códec de GoPro CineForm en After Effects
  18. Uso de otras aplicaciones
    1. Dynamic Link y After Effects
    2. Uso de After Effects y otras aplicaciones
    3. Sincronización de la configuración en After Effects
    4. Bibliotecas Creative Cloud en After Effects
    5. Plugins
    6. CINEMA 4D y Cineware
  19. Colaboración: Frame.io y Team Projects
    1. Colaboración en Premiere Pro y After Effects
    2. Frame.io
      1. Instalar y activar Frame.io
      2. Utilizar Frame.io con Premiere Pro y After Effects
      3. Preguntas frecuentes
    3. Team Projects
      1. Introducción a Team Projects
      2. Creación de un proyecto de equipo
      3. Colaboración con Team Projects
  20. Memoria, almacenamiento y rendimiento
    1. Memoria y almacenamiento
    2. Cómo maneja After Effects los problemas de poca memoria durante la previsualización
    3. Mejora del rendimiento
    4. Preferencias
    5. Requisitos de la GPU y del controlador de la GPU para After Effects
  21. Base de conocimiento
    1. Problemas conocidos
    2. Problemas solucionados
    3. Preguntas frecuentes
    4. After Effects y macOS Ventura
    5. Cómo maneja After Effects los problemas de poca memoria durante la previsualización

Una secuencia de comandos (o "guión" en Mac OS) es un conjunto de comandos que indican a una aplicación que realice una serie de operaciones. En la mayoría de aplicaciones de Adobe se pueden utilizar secuencias de comandos para automatizar tareas repetitivas, realizar cálculos complejos o incluso utilizar alguna funcionalidad no expuesta directamente a través de la interfaz gráfica de usuario. Por ejemplo, puede configurar After Effects para que reordene las capas de una composición, para que busque y reemplace texto de origen en capas de texto o para que envíe un mensaje de correo electrónico cuando finalice el procesamiento.

Los scripts de After Effects utilizan el lenguaje Adobe ExtendScript, que es una extensión de JavaScript. Los archivos ExtendScript tienen la extensión de nombre de archivo .jsx o jsxbin.

Para obtener una descripción de las funcionalidades de generación de scripts disponibles con After Effects, consulte la Guía de scripts de After Effects en el Centro de desarrolladores de After Effects.

Carga y ejecución de scripts

Cuando se inicia After Effects, carga secuencias de comandos de la carpeta Scripts. De forma predeterminada, la carpeta Scripts se encuentra en las siguientes ubicaciones para After Effects:

  • Windows: Archivos de programa\Adobe\Adobe After Effects <version>\Support Files

  • macOS: Aplicaciones/Adobe After Effects <version>

Varios scripts se suministran con After Effects y se instalan automáticamente en la carpeta Scripts. y todas las secuencias de comandos cargadas están disponibles en el menú Archivo > Scripts.

Nota:
  • Si edita un script mientras se está ejecutando After Effects, debe guardar los cambios para que puedan aplicarse.
  • Si coloca una secuencia de comandos en la carpeta Scripts mientras se ejecuta After Effects, debe reiniciar After Effects para que la secuencia de comandos aparezca en el menú Scripts, aunque puede ejecutar inmediatamente la nueva secuencia mediante el uso del comando Ejecutar archivo de secuencias de comandos.

Las secuencias de comandos de la carpeta Paneles ScriptUI están disponibles en la parte inferior del menú Ventana. Si una secuencia de comandos se ha escrito para proporcionar una interfaz de usuario en un panel acoplable, la secuencia se debe situar en la carpeta ScriptUI. Los Paneles de ScriptUI funcionan de forma similar a los paneles predeterminados de la interfaz de usuario de After Effects.

Nota:

De forma predeterminada, los scripts no pueden escribir archivos ni enviar o recibir comunicaciones a través de una red. Para permitir que las secuencias de comandos puedan escribir archivos y comunicarse a través de una red,

  • Windows: Seleccione Editar > Preferencias > Secuencias de comandos y expresiones > seleccione Permitir que las secuencias de comandos puedan escribir archivos y acceder a la red.
  • macOS: seleccione After Effects > Preferencias > Secuencias de comandos y expresiones > seleccione Permitir que las secuencias de comandos puedan escribir archivos y acceder a la red.
  • Para ejecutar una secuencia de comandos cargada, elija Archivo > Secuencias de comandos > [nombre de la secuencia de comandos].

  • Para ejecutar una secuencia de comandos no cargada, elija Archivo > Secuencias de comandos > Ejecutar archivo de secuencias de comandos, localice y seleccione una secuencia de comandos y haga clic en Abrir.

  • Para detener una secuencia de comandos en ejecución, presione Esc.

  • Para ejecutar una secuencia de comandos desde una línea de comando, llame al archivo afterfx.exe desde la línea de comando. Use el definidor -r y la ruta completa de la secuencia de comandos para ejecutarla como argumentos. Este comando no abre una nueva instancia de la aplicación After Effects; ejecuta la secuencia de comandos en la instancia existente.

    Ejemplo (Windows): afterfx -r c:\script_path\example_script.jsx

Nota:

Puede usar esta técnica de línea de comando (junto con el software que acompaña al teclado personalizable) para vincular la invocación de una secuencia de comandos a un método abreviado de teclado.

Puede ver la lista de los diez scripts ejecutados más recientemente en After Effects. Para ver la lista, seleccione Archivo > Secuencias de comandos > Archivos de secuencias de comandos recientes.

Para volver a ejecutar cualquiera de las 10 secuencias de comando de ejecución más recientes,

  • macOS: Cmd + Opción + Mayús + D
  • Windows: Ctrl+Alt + Mayús + D
Nota:

En el sitio web AE Scripts, Lloyd Alvarez ofrece una sugerencia sobre cómo ejecutar scripts de .jsxbin si no tiene acceso a la carpeta Scripts o Paneles ScriptUI.

Scripts incluidos con After Effects

After Effects ofrece varios scripts preprogramadas para ayudarle a llevar a cabo tareas comunes y para que le sirvan de referencia a la hora de modificar y crear los suyos.

Sugerencia:

Ejecute la secuencia de comando de muestra Demo Palette.jsx para hacerse una idea del tipo de operaciones que se pueden hacer con las secuencias de comandos.

Escritura y modificación de scripts

Puede escribir sus propias secuencias de comandos para utilizarlas en After Effects empleando el editor de secuencias de comandos, que forma parte de ExtendScript Toolkit. ExtendScript Toolkit le ofrece una práctica interfaz para crear, depurar y comprobar sus propias secuencias de comandos. A veces, solo hay que hacer una ligera modificación en una secuencia de comandos existente para que esta haga lo que quiere; este tipo de ligeras modificaciones se pueden realizar normalmente sin necesidad de tener un conocimiento exhaustivo de los lenguajes de programación informática y secuencias de comando.

Para iniciar el editor de secuencias de comandos, elija Archivo > Secuencias de comandos > Abrir el Editor de secuencias de comandos.

Consulte la guía de scripts de After Effects para obtener más información.

Acceso a scripts

Acceso a scripts de plantillas de gráficos animados

Las secuencias de comando pueden añadir propiedades al panel de Gráficos esenciales y exportar una plantilla de gráficos animados mediante los siguientes métodos de secuencias de comandos:

  • Método Property canAddToMotionGraphicsTemplate ()
app.project.item(index).layer(index).propertySpec.canAddToMotionGraphicsTemplate(comp) 

Compruebe si la propiedad se puede añadir al Panel de gráficos esenciales para la composición especificada. Indica “verdadero” si la propiedad se puede añadir y “falso” en caso contrario. Si la propiedad no se puede añadir, puede que sea porque no es del tipo de propiedad compatible o porque ya se ha añadido a dicha composición. After Effects muestra un cuadro de diálogo de advertencia.

Tipos de propiedad admitidos:

  • Casilla de verificación
  • Color
  • Regulador numérico (propiedad numérica de un solo valor), como Transformar > Opacidad o el efecto de control de expresión del Control deslizante
  • Texto de origen

Parámetros:

comp

La composición en la que desea probar la adición de la propiedad, compItem.

Valor devuelto: booleano.


  • Método Property addToMotionGraphicsTemplate ()
app.project.item(index).layer(index).propertySpec.addToMotionGraphicsTemplate(comp)

Añada la propiedad al panel de Gráficos esenciales para la composición especificada. Indica “verdadero” si la propiedad se ha añadido correctamente y “falso” en caso contrario. Si la propiedad no se añade, puede que sea porque no es del tipo de propiedad compatible o porque ya se ha añadido a dicha composición. After Effects mostrará un diálogo de advertencia. Use el método canAddToMotionGraphicsTemplate() para comprobar si la propiedad se puede añadir a una plantilla de gráficos animados.

Parámetros:

comp

La composición en la que desea probar la adición de la propiedad, compItem.

Valor devuelto: booleano.


  • Atributo motionGraphicsTemplateName de CompItem 
app.project.item(index).motionGraphicsTemplateName

Lea o escriba la propiedad del nombre en el panel de Gráficos esenciales de la composición. El nombre del panel de Gráficos esenciales se usa para el nombre del archivo de una plantilla exportada de gráficos en movimiento, por ejemplo, My Template.mogrt. En el siguiente ejemplo se establece el nombre de la composición activa y, a continuación, se devuelve como alerta:  

app.project.activeItem.motionGraphicsTemplateName = &quot;Mi plantilla&quot;;
alert(app.project.activeItem.motionGraphicsTemplateName);

Tipo: cadena; de lectura/escritura.


  • Método exportAsMotionGraphicsTemplate() de CompItem
app.project.item(index).exportAsMotionGraphicsTemplate(doOverWriteFileIfExisting, file_path)

Exportar la composición como una plantilla de gráficos animados. Indica “verdadero” si la plantilla de gráficos en movimiento se ha exportado correctamente y “falso” en caso contrario. El nombre del panel de Gráficos esenciales se usa para el nombre del archivo de una plantilla de gráficos en movimiento, por ejemplo, My Template.mogrt. Utilice el atributo motionGraphicsTemplateName para establecer el nombre. Opcionalmente, especifique la ruta de la carpeta en la que se ha guardado el archivo de la plantilla de gráficos en movimiento. Si no se especifica, el archivo se guardará en la carpeta de gráficos esenciales del usuario actual:

  • macOS: /Users//Library/Application Support/Adobe/Common/Essential Graphics/
  • Windows: C:\Users\\AppData\Roaming\Adobe\Common\Essential Graphics\

Si el proyecto se ha modificado desde la última vez que se guardó, After Effects pregunta al usuario si desea guardarlo. Para evitar esto, utilice el método save() del proyecto antes de exportar la plantilla de gráficos animados.

Parámetros:

doOverWriteFileIfExisting

Si desea sobrescribir un archivo existente del mismo nombre, booleano. Obligatorio.

file_path

Ruta de la carpeta donde se guardará el archivo. Opcional.

Valor devuelto : booleano.


  • Método CompItem openInEssentialGraphics()
app.project.item(index).openInEssentialGraphics() 

Dónde encontrar scripts adicionales útiles

Busque scripts, proyectos y otros elementos útiles en el sitio web de Adobe Add-ons.

En el foro de AE Enhancers se incluyen scripts de ejemplo e información útil acerca de la creación de estos (así como ajustes preestablecidos de animación y expresiones) en After Effects.

 Adobe

Obtén ayuda de forma más rápida y sencilla

¿Nuevo usuario?

Adobe MAX 2024

Adobe MAX
La conferencia de creatividad

Del 14 al 16 de octubre en Miami Beach y en línea

Adobe MAX

La conferencia de creatividad

Del 14 al 16 de octubre en Miami Beach y en línea

Adobe MAX 2024

Adobe MAX
La conferencia de creatividad

Del 14 al 16 de octubre en Miami Beach y en línea

Adobe MAX

La conferencia de creatividad

Del 14 al 16 de octubre en Miami Beach y en línea