Dynamic Link y After Effects

Acerca de Dynamic Link

Anteriormente, para compartir recursos de medios entre aplicaciones de postproducción era necesario procesar y exportar el trabajo desde una aplicación antes de importarlo en otra. Se trataba de un flujo de trabajo poco eficaz y en el que se perdía mucho tiempo. Si deseaba hacer cambios en el recurso original, era preciso volver a procesar y exportar el recurso. Múltiples versiones procesadas y exportadas de un recurso consumen espacio del disco y pueden generar dificultades para gestionar los archivos.

Dynamic Link ofrece una alternativa a este flujo de trabajo. Se pueden crear vínculos dinámicos entre After Effects y Adobe Premiere Pro. Crear un vínculo dinámico es tan sencillo como importar cualquier otro tipo de recurso. Los recursos con vínculos dinámicos aparecen con iconos únicos y colores de etiquetas que ayudan a identificarlos. Los vínculos dinámicos se guardan en proyectos generados por dichas aplicaciones.

Creación y vinculación de composiciones de After Effects con Dynamic Link

Se pueden crear nuevas composiciones de After Effects y vincularlas de forma dinámica desde Adobe Premiere Pro. Asimismo, puede vincularlas dinámicamente a composiciones existentes de After Effects desde Adobe Premiere Pro.

Creación de una composición a partir de clips en Adobe Premiere Pro

Puede sustituir los clips seleccionados en Adobe Premiere Pro con una composición de After Effects enlazada dinámicamente basada en esos clips. La nueva composición hereda los ajustes de la secuencia de Adobe Premiere Pro.

  1. Abra Premiere Pro y seleccione los clips que desee reemplazar.

  2. Haga clic con el botón secundario en cualquiera de los clips seleccionados.
  3. Seleccione Reemplazar con composición de After Effects.

    Se abre After Effects (si no estaba ya abierto) y se crea una nueva composición enlazada.

Creación de una composición enlazada dinámicamente desde Adobe Premiere Pro

Al crear una nueva composición vinculada dinámicamente desde Adobe Premiere Pro, se inicia After Effects. A continuación, After Effects crea un proyecto y una composición con las dimensiones, la proporción de píxeles, la velocidad de fotogramas y la frecuencia de muestreo de audio del proyecto original. (Si After Effects ya se está ejecutando, crea una nueva composición en el proyecto actual.) El nombre de la nueva composición está basado en el nombre del proyecto de Adobe Premiere Pro, seguido de Comp. enlazada [x].

  1. En Adobe Premiere Pro, seleccione Archivo > Adobe Dynamic Link > Nueva composición de After Effects. En la versión de 2014 de Premiere Pro se pueden importar composiciones con el Navegador de medios. Consulte las siguientes secciones en Premiere Pro para obtener más información:

  2. Si aparece el cuadro de diálogo Guardar como de After Effects, introduzca un nombre y una ubicación para el proyecto de After Effects, y haga clic en Guardar.

    Nota:

    Al crear una composición vinculada dinámicamente en After Effects, la duración de la composición se fija en 30 segundos. Para modificar la duración, seleccione la composición en After Effects y elija Composición > Ajustes de composición. Haga clic en la pestaña Básico y especifique un nuevo valor para Duración.

Para obtener resultados óptimos, haga que los ajustes de composición (como las dimensiones, la proporción de aspecto de píxeles y la velocidad de fotogramas) coincidan con los de Adobe Premiere Pro.

  1. Realice una de las acciones siguientes:
    • En Adobe Premiere Pro, seleccione Archivo > Adobe Dynamic Link > Importar composición de After Effects. Seleccione un archivo de proyecto de After Effects (.aep) y, a continuación, elija una o más composiciones.

    • En Adobe Premiere Pro, seleccione un archivo de proyecto de After Effects y haga clic en Abrir. A continuación, seleccione una composición en el cuadro de diálogo que aparece y haga clic en Aceptar.

    • Arrastre una o más composiciones del panel Proyecto de After Effects al panel Proyecto de Adobe Premiere Pro.

    • Arrastre un archivo de proyecto de After Effects al panel Proyecto de Premiere Pro. Si el archivo de proyecto de After Effects contiene varias composiciones, se abre el cuadro de diálogo Importar composición.

Nota:

Puede enlazar una sola composición de After Effects en un solo proyecto de Adobe Premiere Pro varias veces.

Modificación de una composición de Dynamic Link en After Effects

En Adobe Premiere Pro, utilice el comando Editar original para modificar una composición vinculada de After Effects. Una vez que la composición esté abierta en After Effects, puede cambiarla sin tener que volver a usar el comando Editar original.

  1. Seleccione la composición de After Effects en Adobe Premiere Pro, o bien elija un clip enlazado en la línea de tiempo y haga clic en Editar > Editar original.

  2. Cambie la composición en After Effects. A continuación, vuelva a Adobe Premiere Pro para ver los cambios.

Los cambios realizados en After Effects aparecerán en Adobe Premiere Pro. Adobe Premiere Pro deja de utilizar los archivos de previsualización procesados para el clip antes de los cambios.

Nota:

Puede cambiar el nombre de la composición en After Effects después de crear un vínculo dinámico a esta desde Adobe Premiere Pro. Adobe Premiere Pro no actualizará el nombre de la composición vinculada en el panel Proyecto. Sin embargo, Adobe Premiere Pro conserva el vínculo dinámico.

Eliminación de una composición o un clip enlazado dinámicamente

Se puede eliminar una composición enlazada de un proyecto de Adobe Premiere Pro en cualquier momento, aunque se esté utilizando la composición.

Los clips enlazados desde la línea de tiempo se pueden eliminar en cualquier momento de una secuencia o línea de tiempo de Adobe Premiere Pro.

  1. En Adobe Premiere Pro, seleccione la composición o el clip enlazados y pulse la tecla Suprimir.

Creación de una secuencia enlazada en Adobe Premiere Pro con Dynamic Link

Al crear una secuencia de Adobe Premiere Pro en After Effects se inicia Adobe Premiere Pro. A continuación, Adobe Premiere Pro crea un proyecto y una secuencia con las dimensiones, la proporción de píxeles, la frecuencia de fotogramas y la velocidad de muestreo de audio del proyecto original. (Si Adobe Premiere Pro ya está en ejecución, crea una secuencia en el proyecto actual).

  1. En After Effects, seleccione Archivo > Adobe Dynamic Link > Nueva secuencia de Premiere Pro.

Para obtener mejores resultados, haga coincidir los ajustes de la secuencia y del proyecto en Adobe Premiere Pro (como las dimensiones, la proporción de píxeles y la velocidad de fotogramas) con los del proyecto de After Effects.

Realice una de las acciones siguientes:

  • En After Effects, seleccione Archivo > Adobe Dynamic Link > Importar secuencia de Premiere Pro . Elija un proyecto de Adobe Premiere Pro y, a continuación, una o más secuencias.

  • Arrastre una o varias secuencias desde el panel Proyecto de Adobe Premiere Pro al de Proyecto de After Effects.

Rendimiento de Dynamic Link

Un clip vinculado puede hacer referencia a una composición de origen compleja. Las acciones que se llevan a cabo en la composición de origen requieren tiempo de procesamiento adicional según la complejidad. After Effects aplica las acciones y coloca los datos finales a disposición de Adobe Premiere Pro con la caché de rendimiento global y las funciones de la caché de disco persistente. Estas funciones mejoran el rendimiento de After Effects con los fotogramas almacenados en caché cuando Premiere Pro los solicita.

Para reducir los retardos en la reproducción, siga uno de estos procedimientos:

  • Pase la composición enlazada a sin conexión.

  • Inhabilite un clip enlazado para que no haga referencia a una composición temporalmente.

  • Sustituya la composición enlazada dinámicamente por el archivo procesado mediante la función Procesar y reemplazar de Premiere Pro (Clip > Procesar y reemplazar).    

Si suele trabajar con composiciones de origen complejas, añada más RAM a su ordenador o actualícelo con un procesador más rápido.

Nota:

Una composición de After Effects enlazada no será compatible con el multiprocesamiento de Procesar varios fotogramas simultáneamente. Consulte Mejorar el rendimiento optimizando la configuración de memoria, caché y multiprocesamiento.

Exportación a Adobe Media Encoder

Para codificar composiciones de After Effects, es necesario agregarlas a la cola de codificación de Adobe Media Encoder y, a continuación, seleccionar los ajustes preestablecidos de codificación o crear sus propios ajustes personalizados para procesamiento. En After Effects, puede agregar una composición a la cola de Media Encoder con una de las siguientes opciones:

  • Archivo > Exportar > Añadir a la cola de Media Encoder
  • Composición > Añadir a la cola de Media Encoder

Cuando agrega una composición o un proyecto a la cola de Adobe Media Encoder, After Effects ejecuta Adobe Media Encoder con las composiciones de la cola.

En los siguientes artículos se explica el proceso de codificación:

Logotipo de Adobe

Inicia sesión en tu cuenta