Discover the ease of editing clips in Premiere Pro: how you can quickly set In and Out points, trim clips in the Timeline, work with audio waveforms, and more.

Work with In and Out points

Setting a clip’s In and Out points is a process called marking. You define the first frame you want to include in a sequence by marking that frame as the clip’s In point. Then you define the last frame you want to include by marking it as the Out point. In a typical workflow, you mark In and Out points for a clip in the Source Monitor.

Adjusting a clip's In and Out points after it is already edited into a sequence is called trimming. Typically, you trim clips to adjust how they play back in a sequence. For example, as you view the edit, you want to cut to the incoming clip a little sooner than you originally planned while marking clips. To fix that problem, trim the clip using trimming tools in Premiere Pro.

You can trim clips by dragging the edge of a clip. A clip's "edge" is a clip’s In or Out point, or edit point. Several specialized tools and techniques allow you to trim an edit point. These tools and techniques allow you to trim more easily and accurately, reducing the number of steps involved and maintaining the integrity of the sequence.

You can perform trimming tasks to selected edit points of a clip, or selected edit points from multiple clips. There are new icons for the tools, and when selecting edits with trim tools, the edit point is highlighted with a color related to the trim you perform.

You can use keyboard shortcuts on selected edit points to trim clips in the timeline. Trimming in Premiere Pro has a keyboard driven workflow, as there are keyboard shortcuts for every trimming task. See Timeline trimming.

You can use Trim Mode to help you dynamically trim edit points using buttons, or keyboard shortcuts. You can use the J-K-L keys to dynamically trim clips. See Work in Trim Mode.

There are many keyboard shortcuts available for the job of trimming, however, a number of them aren't set by default. Go to Edit > Keyboard Shortcuts (Windows) or Premiere Pro > Keyboard Shortcuts (Mac OS) to set trimming shortcuts.

Working with audio clips in the Source Monitor

You can work with audio clips, and audio from audio and video clips in the Source Monitor. You can view audio waveforms, scrub audio waveforms, and zoom in and out on audio waveforms.

View audio waveforms

When opening an audio clip in the Source Monitor, audio waveforms appear automatically. When opening an audio and video clip in the Source Monitor, you can also view audio waveforms.

To view audio waveforms in an audio and video clip, choose Audio Waveforms from the monitor's panel menu.

You can view the audio waveforms for clips containing multiple audio channels when opening them in the Source Monitor.

Scrub the audio waveform in the Source Monitor

  • In the Source Monitor, drag to the left or right anywhere on the waveform.

    The playhead appears where you click and the audio clip is played, forward or backward, at the speed at which you drag across, or scrub, the clip.

Zoom in or out on an audio waveform in the Source Monitor

You can zoom into an audio waveform in the Source Monitor to better identify locations for markers, In points, or Out points.

  1. Double-click an audio clip in the Project panel to open it in the Source Monitor.
  2. To zoom in horizontally, drag either end of the zoom scrolling bar that runs below the time bar in the Source Monitor.

    The waveform of all channels, and the time bar, will expand or contract horizontally.

  3. To zoom in vertically, do one of the following:
    • To zoom in on a single channel, drag either end of the vertical zoom bar that runs next to the decibel ruler on the right side of the Source Monitor.
    • To zoom in on all channels simultaneously, Shift-drag either end of the vertical zoom bar that runs next to the decibel ruler on the right side of the Source Monitor.

    The waveform of one or all channels, and the decibel ruler, will expand or contract vertically.

Note:

In Apple MacBook Pro computers, you can move two fingers on the trackpad vertically or horizontally on the zoom scroll bar to zoom in and zoom out on audio waveforms. To scrub audio, move two fingers vertically or horizontally anywhere in the Source Monitor except the zoom scroll bar.

Return to default vertical zoom level

  • Double-click the vertical zoom bar.

Return to previous vertical zoom level

  • After returning to the default zoom level, double-click the vertical zoom bar.

Working with clips in the Source Monitor

The Source Monitor panel holds versatile tools, and methods for working with clips. You can use tools and techniques to set, move, or remove In and Out points, cue the playhead to any of these points, or preview the frames at their locations.

Open a clip in the Source Monitor

  • To open a clip in the Source Monitor, do one of the following:
    • Double-click the clip in the Project panel.
    • Double-click the clip in a Timeline panel.

Open and view recent clips from the Source Monitor

You can load more than one clip at a time in the Source Monitor. However, you can view only one clip at a time. Recently loaded clips are available from a menu at the top of the Source Monitor.

  1. In the Source Monitor tab, click the downward-pointing triangle to open the tab menu.
  2. Select the name of the clip you want to view.

    Note:

    You can assign keyboard shortcuts for selecting and closing clips in the Source Monitor.

Set In points and Out points in the Source Monitor

  • To set an In Point or Out point in the Source Monitor, do any of the following:
    • To mark an In point, drag the playhead to the frame you want. Then click the Mark In Point button , or press the I key.
    • To mark an Out point, drag the playhead to the frame you want. Then click the Mark Out Point button , or press the O key.

Note:

After you mark In and Out points, you can always change your mind before you edit the clip into the sequence. Drag the In or Out points to a new position in the time ruler. You can also drag the playhead to a new frame and use the Mark In or Mark Out buttons to set new In or Out points.

Move In point and Out point together

  • Do one of the following:
    • For a video or audio clip, in the Source Monitor time ruler, drag the In/Out Grip (textured area at the center of the shaded span between the In and Out points). Make sure that you drag the textured area; otherwise, you simply cue the playhead.
    • For an audio clip, you can also drag the In/Out Grip, or the gray area between the In point and Out point above the waveform to the left or right.

The In and Out points move together, keeping the duration between them constant.

Note:

This technique also works with sequence In and Out points using the Program Monitor or a Timeline panel.

Adjusting edit points in the Source Monitor

Sometimes, adjusting In and Out points after a clip is in the Timeline is necessary. If you open a clip from the Timeline into the Source Monitor, you can drag the In/Out Grip in the Source Monitor to set new locations for the In and Out points. This technique is useful for using a different section of a clip in the Timeline. In fact, it is one way to perform a Slip edit.

Note:

Viewing in and out frames this way works only with clips that you’ve opened in the Source Monitor from a sequence.

  1. Set the In and Out points in the Source Monitor.

  2. Edit the clip into the Timeline.

  3. Double click the clip to load it into the Source Monitor.

  4. Drag the In/Out Grip (textured area at the center of the shaded span between the In and Out points), as you did in the section, Move In point and Out point together.

Cue to an In point or Out point

You use the Source Monitor to cue a frame for a clip and the Program Monitor to cue the current frame for a sequence.

  • Do one of the following:
    • To cue the current time to an In point, click the Go To In Point button .
    • To cue the current time to an Out point, click the Go To Out Point button .

Cue to the previous or next edit

You can use the Down Arrow key for the Go To Next Edit Point command and the Up Arrow key for the Go To Previous Edit Point command. This command works across all tracks, selected or not.

Note:

You can also use buttons to go to the next edit in any of the targeted tracks in the Timeline, click the Go To Next Edit Point button  and, to go to the previous edit in any of the targeted tracks, click the Go To Previous Edit Point button .

The Go To Next Edit Point and Go To Previous Edit Point buttons are not available by default, however, they can be placed alongside the other playback controls with the button editor.

Remove source clip In point or Out point

  • Double-click a clip in the Project panel to open it in the Source Monitor.

Note:

Timeline clip instances are not source clips. It is not possible to remove In points or Out points from timeline clips which have been loaded in the Source monitor.

  • Choose from the following three commands:
    • Marker > Clear In
    • Marker > Clear Out
    • Marker > Clear In and Out

Note:

You can also Alt-click (Windows), or Option-click (Mac OS) the Mark In button or the Mark Out button in the Source Monitor to clear an In or Out.

Timeline trimming

For quickly trimming clips, do so in the Timeline. You can use a combination of trim tools and keyboard shortcuts to select and adjust edit points.

You can select edit points and adjust them using the mouse, keyboard shortcuts, or the numeric keypad.


Selecting edit points

Before you can use timeline trimming techniques in Premiere Pro, it is important to select edit points for clips in the Timeline first. You can select edit points with the mouse, or by using keyboard shortcuts.

Selecting edit points with the mouse

Clicking with the mouse to select an edit point in the Timeline uses the location of the mouse cursor, the active trim tool, and the modifier keys.

Note:

Dragging, as opposed to clicking and releasing the mouse to select an edit point, both selects an edit point and performs the trim.

  • Selection tool: Clicking the edit point with the Selection tool chooses a Trim In or Trim Out edit point selection, depending on which side of the edit point you click. If you Ctrl-click (Windows) or Command-click (Mac OS) on the edit point with the Selection tool, the cursor displays a Ripple Edit or Rolling Edit tool. Moving the Trim In or Trim Out points is called a regular edit.
  • Ripple Edit tool: Clicking the edit point with the Ripple Edit tool chooses a Ripple In or Ripple Out edit point selection, depending on the side of the edit point you click. If you use Ctrl-click (Windows) or Command-click (Mac OS) on the edit point with the Ripple Edit tool, the cursor shows the Ripple Edit or Rolling Edit tool and chooses Trim Out, Rolling, or Trim In depending on which side of the edit point you click.
  • Rolling Edit tool: Clicking the edit point with the Rolling Edit tool selects both sides of the edit point. If the Ctrl-click (Windows) or Command-click (Mac OS) modifier is held with the Rolling Edit tool, the cursor shows the Ripple Edit or Rolling Edit tool and chooses Ripple Out, Rolling, or Ripple In, depending on which side of the edit point you click.
Edit cursors for the various edit types
Edit cursors for the various edit types

A. Regular Edit cursor B. Regular Edit cursor C. Ripple Edit cursor D. Ripple Edit Cursor E. Rolling Edit Cursor 

Note:

Track targeting does not affect selection of edit points when using the mouse.

Using modifier keys with trim tools

  • Use the Alt (Windows) or Option (Mac OS) modifier key to override normal linked­‐clip selection of associated edit points on other tracks, and only select the edit point that is clicked. This technique is useful for setting up a split edit (L or J‐cut).
  • Use the Shift modifier key to add or remove other edit points to the current selection.
    You can combine both the Alt (Windows) or Option (Mac OS) key and Shift to ignore linked clip selection while adding or removing other edit points from the current selection.
  • Choose Edit > Preferences > Trim (Windows), or Premiere Pro > Preferences > Trim (Mac OS), to set the Allow Selection tool to choose Rolling and Ripple trims without modifier key. This changes the way that the Ctrl-click (Windows) or Command-click (Mac OS) modifier key works with the Selection tool. If the preference is checked, then the use of the modifier key is inverted.

Trimming in Timeline gaps

You can select the edit point of an empty gap between clips and use timeline trimming commands.

  • Regular Trim: This technique works the same as selecting the clip side of the edit point for the opposite direction. For example, selecting a Trim Out on the right side of an empty gap is equivalent to selecting the Trim In of the adjacent clip.
  • Rolling Trim: If one side of the edit point is an empty gap then it behaves the same as a regular trim.
  • Ripple Trim: Trimming the gap would move the edit point and shift all trailing clips. Trimming the gap includes the adjacent clip, in a different position but with its In point remaining the same.

Note: Selecting the Shift clips that overlap trim point during ripple trimming check box in the Preferences dialog box (Edit > Preferences > Trim) shifts the overlapping track items during a ripple delete.

Trim type context menu

You can also select an edit point (or change the trim type of an existing edit point) by right-­‐clicking at an edit point and choosing from a context menu that appears. The menu contains the following items:

  • Ripple Trim In
  • Ripple Trim Out
  • Rolling Edit
  • Trim In
  • Trim Out
  • Apply Default Transitions

Select multiple edit points

Multiple selection of edit points is possible, including more than one per track. Use the Shift key with any trim tool to select additional edit points.

You can also drag to select multiple edit points. To select multiple edit points, drag a marquee around a group of clips. A Ripple Out trim type is always chosen, but can be changed after the selection is made with a keyboard shortcut (Shift-T (Windows), or Ctrl-T (Mac OS).), or select Ripple Trim In from the context menu.

You cannot drag a marquee around the first edits in the timeline with the Ripple Edit tool, however, you can with the Rolling Edit tool, and then switch the trim function with the keyboard shortcut (Shift-T (Windows), or Ctrl-T (Mac OS).).

You can select more than one edit point per track, choosing all the edit points within the marquee selection box. Use the Shift modifier key to add or remove other edit points to the selection. The Program Monitor switches to trim mode automatically as soon as the marquee selection is complete.

Note:

To select multiple edit points at the very beginning of a sequence as a Ripple In edit, drag a marquee around the clips with the Rolling Edit tool, and then press Shift+T (Windows), or Ctrl+T (Mac OS) to toggle to a Ripple In edit selection.

If there are other edit points selected besides the one that you click, then they all change their type to the selected type. The Apply Default Transitions menu item applies the current default video or audio transition to each of the currently selected edit point locations.

Keyboard shortcuts for edit point selection

There are keyboard shortcuts for selecting edit points that use the playhead position and track targets.

Note:

Unlike selecting with the mouse, edit points on linked clips are not automatically selected unless the associated tracks are also targeted.

Select Nearest Edit Point

There are 5 "Select Nearest Edit Point" shortcuts you can assign in the Keyboard Shortcuts dialog box, one for each type of trim:

  • Select Nearest Edit Point as Ripple In
  • Select Nearest Edit Point as Ripple Out
  • Select Nearest Edit Point as Trim In
  • Select Nearest Edit Point as Trim Out
  • Select Nearest Edit Point as Rolling

If the playhead is not already at an edit point, it is moved to the nearest edit point either forward or backward. Then the edit points at the playhead on all targeted tracks are added to the current edit point selection, using the type of trim for the particular shortcut. You can use the menu item (or shortcut) for Deselect All to deselect edit points before using these shortcuts to start a new selection.

Go to Next Edit Point and Go to Previous Edit Point

Moves the playhead to the closest next or previous edit point on the targeted tracks. They maintain edit point selection at the playhead on targeted tracks, using the same type of trim as the previous selection. When there is no active edit point selection, these shortcuts only move the playhead.

In trim mode, you can move to the next and previous edit points with the same shortcuts without leaving trim mode and edit points remain selected.

Go to Next Edit Point on Any Track and Go to Previous Edit Point on Any Track

Moves the playhead to another selected edit point, except that all tracks are considered, not only targeted tracks. The playhead is moved, but edit points do not move. This shortcut exits trim mode.

Toggle Trim Type

Cycles between the types of trims in the current edit point selection. Using the keyboard shortcut Shift+T (Windows), or Ctrl+T (Mac OS), the cycling order is Ripple Out, Ripple In, Trim Out, Trim In, and rolling. The trim type is changed from the current type to the next type in the order, wrapping back to Ripple Out from Rolling.

Performing a Timeline trim

Trims can be performed in the Timeline three different ways:

  • The edit points can be dragged with the mouse to a new position in time.
  • Keyboard shortcuts can be used to trim all selected edit points to the right or the left by one or more frames.
  • Type frame amounts the numeric keypad with "+" and "‐" and the Enter key to trim all the selected edit points forward, or backward.

Note:

When using the numeric keypad to type a number of frames to trim, you do not need to type the "+" sign when entering positive numbers.

The keyboard shortcuts and the +/‐ keypad entry can also be used in the Program Monitor in trim mode. In addition, there are several buttons and other user interface elements such as the video displays in the Program Monitor that can be used to perform a trim during trim mode. See Working in trim mode.

You can only trim a clip longer until you encounter another clip in the same track, and you cannot perform a trim beyond the duration of the media in the clip. When trimming multiple tracks, you can trim until either you encounter another clip in the same track, or you reach the duration of the shortest clip in the group.

Performing ripple trims can cause clips on different tracks to get out­‐of‐sync. Toggle Sync Lock or Toggle Track Lock on tracks to limit which tracks shift during a ripple trim. Out‐of‐sync indicators draw in the visible part of a clip in the Timeline, not just at the head of the clip. That way, if you zoom in or scrolling so that the head isn't visible, you can still see that a clip is out‐of-sync with its linked parts.

Trim by dragging with the mouse

After selecting one or more edit points, you can simply drag the edit point selection in the Timeline to perform a trim. While dragging, the cursor changes to the appropriate trim type based on the edit point that is clicked to start the drag.

When dragging an edit point with the mouse in the Timeline, the trim snaps to other edit points, markers, and the playhead if the Snap button is on. There is also an existing keyboard shortcut to toggle snapping on or off that can be used during dragging.

Trim with keyboard shortcuts

The following keyboard shortcuts perform a trim whenever there is an active edit point selection, even if you are not in trim mode. If the full amount of the trim cannot be performed, the allowable amount is used and a tool tip indicates that the trim is blocked or limited by media or minimum duration.

Trim Backward and Trim Forward

Moves the edit points by one frame in the specified direction (left for backward, and right for forward).

Trim Backward Many and Trim Forward Many

Moves the edit points by five frames, or some other number of frames which is settable in the large trim offset preference. To change the large trim offset, choose Edit > Preferences > Trim (Windows), or Premiere Pro > Preferences > Trim (Mac OS), and then enter a new amount of frames for large trim offset.

Extend Selected Edit to Playhead

Moves the selected edit point which is nearest the playhead to the position of the playhead, much like a rolling edit.

Note:

The existing Extend Previous Edit to Playhead and Extend Next Edit to Playhead are still available, since they operate on clips on targeted tracks without needing an active edit point selection.

Ripple Trim Previous Edit to Playhead and Ripple Trim Next Edit to Playhead

Ripple trims the previous or next edit point to the Playhead. You do not need to select an edit point to perform a ripple trim to playhead edit. Like the Extract command, a ripple trim to playhead edit does not affect clips on other tracks that are locked or not sync-locked, but all other tracks will have the region ripple-deleted. Sequence In and Out points are not affected.

Note:

A ripple trim to the playhead at the beginning or ending of a clip is sometimes called "Top and Tail" in editing terminology.

Trim with numeric keypad entry

You can specify a numeric offset using the numeric keypad whenever there is an active edit point selection, even if you are not in trim mode. When the Timeline is active, the current timecode indicator on the left becomes a text box that shows the numbers that are typed on the numeric keypad. The "+" key moves the trim forward to the right, increasing in time (you can omit the "+" key, and type a number). The "­‐" key moves the trim backward to the left, decreasing in time. The numeric offset is typically a small number of frames, so any number from 1 to 99 is treated as frames. If you want to specify a timecode, then use the numeric period key "." to separate the minute:second:frame parts for timecode entry. Press the numeric keypad Enter key to perform the trim using all of the currently selected edit points.

When the Program Monitor is in trim mode, then you can also use the numeric keypad to perform a trim when the Program Monitor is active.

Trim with the selection tool

You can change a clip’s In point or Out point by dragging its edit point with the selection tool in a Timeline panel. As you drag, the current In or Out point appears in the Program Monitor. A tool tip displays the number of frames that you are trimming: a negative value if you are dragging the edge toward the beginning of the sequence and a positive number if you are dragging toward the end of the sequence. You cannot trim past the original In and Out points of the source footage.

  • Click the selection tool  and do one of the following:
    • To edit the In point, drag the left edge of the clip once the Trim-in icon appears.
    • To edit the Out point, drag the right edge of the clip once the Trim-out icon appears.

    Note:

    Press Ctrl (Windows) or Command (Mac OS) using the Selection tool to switch to the Ripple Edit tool.

    Note:

    To trim only one track of a linked clip, press Alt (Windows) or Option (Mac OS) as you click with a Trim icon. You do not need to hold down the Alt (Windows) or Option (Mac OS) key once you initiate the trim.

Trim with the playhead

You can trim a clip in a sequence to the location of the playhead. However, set up these keyboard shortcuts to do so first:

  • Trim In Point To Playhead
  • Trim Out Point To Playhead
  • Select Nearest Edit Point as Trim In
  • Select Nearest Edit Point as Trim Out

To set keyboard commands for trimming, see Customize or load keyboard shortcuts.

Making ripple and rolling edits in the Timeline

In Premiere Pro, you can perform a ripple or rolling edit directly on the tracks in the Timeline, using Trim mode, or the Trim Monitor.

About ripple and rolling edits

When you want to adjust the cut, or edit point, between two clips, use variations of simple trimming known as ripple edits and rolling edits. By using specialized tools, make adjustments in a single action that would otherwise require multiple steps to accomplish. When you perform ripple and rolling edits with trim tools, the affected frames appear in the Program Monitor side by side. Keyboard shortcuts are available for ripple and rolling edits. Furthermore, the edit point is selected when you click it with a Ripple Edit or Rolling Edit tool.

Program Monitor and Timeline during a rolling edit
Program Monitor and Timeline during a rolling edit

Rolling edit

A rolling edit trims an adjacent Out point and In point simultaneously and by the same number of frames. This action effectively moves the edit point between clips, preserving other clips’ positions in time and maintaining the total duration of the sequence. Pressing Alt (Windows) or Option (Mac OS) when you begin to perform a rolling edit overrides video and audio linking, allowing you to create a split edit (L-cut or J-cut).

Rolling edit
In this rolling edit, the edit point is moved earlier in time—shortening the previous clip, lengthening the next clip, and maintaining the program duration.

Ripple edit

A ripple edit trims a clip and shifts subsequent clips in the track by the amount you trim. Shortening a clip by ripple editing shifts all clips after the cut back in time; conversely, extending a clip shifts the clips that follow the cut forward in time. When you’re making a ripple edit, empty space on one side of the cut is treated as a clip and shifts in time just as a clip would be. Pressing Alt (Windows) or Option (Mac OS) when you begin to perform a ripple edit ignores the link between video and audio.

Make a rolling edit using the Rolling Edit tool

  1. Select the Rolling Edit tool .
  2. In a Timeline panel, drag left or right from the edge of the clip you want to change. The same number of frames added to the clip are trimmed from the adjacent clip. Alt-drag (Windows) or Option-drag (Mac OS) to affect only the video or audio portion of a linked clip.

Make rolling edits (extend edits) with the playhead

You can move the In point or Out point of a clip in a sequence to the playhead, without leaving gaps in the sequence. This type of editing is sometimes called extending an edit, or using extend edit commands.

Make a rolling (extend) edit to the playhead

Do the following:

  1. Click a track header to target the track containing the clip you want to trim.
  2. Drag the playhead to the location in the sequence to which you want to extend the clip In point or Out point.
  3. Click the Rolling Edit tool, and then select the edit point.
  4. Choose Sequence > Extend Selected Edit to Playhead, or press E.

Note:

If there is not enough media to extend to the playhead, Premiere Pro extends the clip to the end of the available media.

Make a ripple edit using the Ripple Edit tool

  1. Select the Ripple Edit tool .
  2. In a Timeline panel, position the pointer over the In or Out point of the clip you want to change until the Ripple-in icon or the Ripple-out icon appears, and drag left or right. Subsequent clips in the track shift in time to compensate for the edit, but their durations remain unchanged. Alt-drag (Windows) or Option-drag (Mac OS) to affect only the video or audio portion of a linked clip.

    Note:

    When using the Selection tool, you can toggle from the Trim-in or Trim-out icon to a Ripple edit icon by pressing the Ctrl (Windows) or Command (Mac OS) key. Release Ctrl (Windows) or Command (Mac OS) to revert to the Selection tool.

Make slip and slide edits

Just as ripple and rolling edits allow you to adjust a cut between two clips, slip and slide edits are useful when you want to adjust two cuts in a sequence of three clips. When you use the Slip or Slide tool, the Program Monitor displays the four frames involved in the edit side by side, except when editing audio only.

Program Monitor and Timeline during a slide edit
Program Monitor and Timeline during a slide edit

Though Slip and Slide tools are typically employed on the center of three adjacent clips, each tool functions normally even if the clip is adjacent to a clip on one side and blank space on the other.

Make a slip edit

A slip edit shifts a clip’s In and Out points forward or backward by the same number of frames in a single action. By dragging with the Slip tool, you can change a clip’s starting and ending frames without changing its duration or affecting adjacent clips.

Slip edit
In this slip edit, a clip is dragged left, moving its source In and Out points later in time.

  1. Select the Slip tool .
  2. Position the pointer on the clip you want to adjust, and drag left to move the In and Out points later in the clip, or drag right to move the In and Out points earlier in the clip.

    Premiere Pro updates the source In and Out points for the clip, displaying the result in the Program Monitor and maintaining the clip and sequence duration.

Slip a clip with keyboard shortcuts

You can use keyboard shortcuts to slip a clip in a Timeline. To slip a clip using keyboard shortcuts, select a clip (or multiple clips), and then do the following:

  • To slip clip selection left five frames:
    • Press Ctrl+Alt+Shift+Left (Windows).
    • Press Option+Shift+Command+Left (Mac OS).
  • To slip clip selection left one frame:
    • Press Alt+Shift+Left (Windows).
    • Press Option+Command+Left (Mac OS).
  • To slip clip selection right five frames:
    • Press Ctrl+Alt+Shift+Right (Windows).
    • Press Option+Shift+Command+Right (Mac OS).
  • To slip clip selection right one frame:
    • Press Alt+Shift+Right (Windows).
    • Press Option+Command+Right (Mac OS).

Note:

When performing a slip edit with keyboard shortcuts, it is helpful to have the playhead placed on the clip you are slipping so that you can see the slip edit being performed. You can use this method to align a video action with an audio cue.

Make a slide edit

A slide edit shifts a clip in time while trimming adjacent clips to compensate for the move. As you drag a clip left or right with the Slide tool, the Out point of the preceding clip and the In point of the following clip are trimmed by the number of frames you move the clip. The clip’s In and Out points (and hence, its duration) remain unchanged.

Slide edit
In this slide edit, a clip is dragged left so that it starts earlier in the sequence, shortening the preceding clip and lengthening the following clip.

  1. Select the Slide tool .
  2. Position the pointer on the clip you want to adjust, and drag left to move the Out point of the preceding clip and the In point of the following clip earlier in time, or drag right to move the Out point of the preceding clip and the In point of the following clip later in time.

    When you release the mouse, Premiere Pro updates the In and Out points for the adjacent clips, displaying the result in the Program Monitor and maintaining the clip and sequence duration. The only change to the clip you moved is its position in the sequence.

Slide a clip with keyboard shortcuts

You can use keyboard shortcuts to slide a clip in a Timeline. To slide a clip using keyboard shortcuts, select a clip (or multiple clips), and then do the following:

  • To slide clip selection left five frames:
    • Press Alt+Shift+, (Windows).
    • Press Option+Shift+, (Mac OS).
  • To slide clip selection left one frame:
    • Press Alt+, (Windows).
    • Press Option+, (Mac OS).
  • To slide clip selection right five frames:
    • Press Alt+Shift+. (Windows).
    • Press Option+Shift+. (Mac OS).
  • To slide clip selection right one frame:
    • Press Alt+. (Windows)
    • Press Option+. (Mac OS).

Nudging clips

You can move clips forward or backward in the Timeline by one frame at a time, or by a large frame offset. This command is called "nudging". When you are nudging a clip (or multiple clips), you are moving it forward, or backward in the timeline. When the clips being nudged are next to another clip, it overwrites clips as you nudge.

To nudge clips, select a clip (or multiple clips), and then do the following:

  • To nudge the clip selection 5 frames to the left:
    • Press Alt+Shift+Left (Windows).
    • Press Command+Shift+Left (Mac OS).
  • To nudge the clip selection 1 frame to the left:
    • Press Alt+Left (Windows).
    • Press Command+Left (Mac OS).
  • To nudge a clip 5 frames to the right:
    • Press Alt+Shift+Right (Windows).
    • Press Command+Shift+Right (Mac OS).
  • To nudge clip selection one frame to the right:
    • Press Alt+Right (Windows).
    • Press Command+Right (Mac OS).

Making split edits

You can create a split edit by unlinking the video from the audio in adjoining clips in a sequence, and then trimming audio separately from video so that the video of one overlaps the audio of the other. Typically, a rolling edit (or extend edit) is used for this task.

Pressing Alt (Windows) or Option (Mac OS) when you begin to perform a rolling edit temporarily unlinks video and audio, allowing you to more easily create a split edit (L-cut or J-cut).

Work in trim mode

Trim mode is the state where the Program Monitor is in a special trim mode configuration. Certain keyboard shortcuts, button clicks, and J-­K‐L playback perform a trim operation, like a ripple or rolling edit. These behaviors are all part of dynamic trimming. Timeline trimming serves many purposes, and you can trim in it dynamically, but trim mode is ideal for fine-tuning an edit. While working in trim mode, you trim by adding or subtracting frames from the edit point as the edit plays back in a loop in dynamic fashion.

Note:

It is not necessary to loop playback in trim mode to refine edit. Some editors prefer to pause playback, and then click buttons, (or use J-K-L keyboard shortcuts), and then begin looping again.

Note:

Editors use trim mode for such tasks as, refining dialogue, pacing a chase scene, or creating split edits.

Trim mode interface

The Program Monitor automatically switches some of its buttons and the user interface to show a simplified 2-up display when in trim mode. It switches back to the standard Program Monitor configuration when exiting trim mode.

Within the Program Monitor, the video plays in a 2-up configuration, temporarily expanding and covering both left and right sides with a single video view. The trim buttons and shift counters are placed directly below the video. All of the sequence's video tracks are composited together and the audio heard during playback is all of the sequence's audio tracks mixed together. The playhead loops in the Timeline during playback so that you can see the range of time that is being played.

Trim mode interface
A. Outgoing edit point B. Outshift counter C. Trim backward many D. Trim backward E. Add default transition  F. Trim forward  G. Trim forward many  H. Inshift counter I. Trim type Indicator J. Incoming edit point 

Entering trim mode

Prior to entering trim mode, a good strategy is to select one or more edit points with a trim tool in the Timeline. These selected edits remain intact once you enter trim mode. You can also enter trim mode without selecting edits ahead of time.

To enter trim mode, do one of the following:

  • Choose Sequence > Trim Edit (or press the T key).

If there is an active edit point selection, the playhead moves to the nearest selected edit point. If there is no edit point selected, then the playhead automatically moves to the nearest edit point on the targeted tracks. Edit points are selected on the targeted tracks with the trim type set to a rolling edit regardless of the currently active tool. If the Program Monitor is already in trim mode, then press the T key to toggle out of trim mode.

  • Double‐click an edit point with the Selection, Ripple Edit, or Rolling Edit tools in the Timeline.
  • Shift-select, or marquee­‐select one or more edit points with the Ripple Edit, or Rolling Edit tools, moving the playhead to the nearest selected edit point and setting the Program Monitor to trim mode with the tool's trim type.

You can now trim clips in trim mode. To begin trimming, see Reviewing trims.

Note:

When double-­clicking an edit point that has already been selected, be sure to use the same tool and same modifier keys that you used to initially select the edit point, since the first click reselects the edit point based on the standard selection rules. The Program Monitor appears in trim mode automatically.

In the Timeline, you can select additional edit points within the same sequence and remain in trim mode. You can also make changes in the Timeline such as zooming in/out, scrolling, or changing track height, and remain in trim mode. If you are already in trim mode, you can use the keyboard shortcuts for Go to Next Edit Point and Go to Previous Edit Point and select new edit points and remain in trim mode. If you are not in trim mode, then these shortcuts move the playhead rather than select edit points.

To exit trim mode, see Exit trim mode.

Reviewing trims

To review the currently applied trims while the edit point selection is still active and you are in trim mode, press the Play button, or the Spacebar. The playback loops around the current edit point selection, playing from a specified pre­rolling time before the first edit point and ending a specified postrolling time after the last edit point. The prerolling and postrolling settings are set in Edit > Preferences > Playback (Windows), or Premiere Pro > Preferences > Playback (Mac OS).

To stop playback, press the Play button or keyboard shortcut again, and the playhead is moved to the selected edit point nearest wherever you stop.

J-K-L dynamic trim

When in trim mode, you can use combinations of the three shuttle keyboard shortcuts (J-K-L) to play the clips and perform a trim based on the location of the playhead when playback stops. For details about using keyboard shortcuts for shuttling, see Using the J, K, and L keys to shuttle video.

The type of the edit point at the playhead is used to determine which side is played. For Ripple Out or Trim Out, the left side view is played. For Ripple In or Trim In, the right side view is played. For a rolling edit, both sides are played.

If you reach the media limit of the trim (no more heads or tails), playback pauses but the trim is not performed until you explicitly stop playback with the Shuttle Stop shortcut. This technique allows you to play back or single­‐step or shuttle in the opposite direction until you find the exact frame for the trim.

Note:

You can dynamically trim footage one frame at a time using J-K-L shortcuts. First select the edit point, then press the K key, and then tap either the J, or the L keys.

Refining Trims in trim mode

While playing in trim mode using Play (which begins playback in a loop), you can make further refinements to the selected edit points using buttons or keyboard shortcuts. Each time the loop plays back footage, you can modify the trim by clicking buttons, or pressing shortcuts. Each trim you perform is immediately committed to the sequence. The edits update in the Timeline, although the resulting change only appears in the Program Monitor on the next loop. Continue to adjust and review the edit until you are satisfied with the trim. 

Move on to trimming the next edit point by using the Go to Next Edit Point or Go to Previous Edit Point shortcuts (the Up Arrow, and Down Arrow keys), or stop playback, if you have finished.

Use the following techniques to refine your trim:

  • Use the Trim Forward and Trim Backward buttons to trim by one frame at a time. The keyboard shortcuts for trimming forward or backward by one frame at a time are as follows:
    • Press Ctrl+Left to trim backward. Press Ctrl+Right to trim forward (Windows).
    • Press Option+Left, to trim backward. Press Option+Right to trim forward (Mac OS).
  • Use the Trim Forward Many and Trim Backward Many buttons to trim by multiple frames at a time. The keyboard shortcuts for trimming forward or backward by multiple frames at a time are as follows:
    • Press Ctrl+Shift+Left to trim backward. Press Ctrl+Shift+Right to trim forward (Windows).
    • Press Option+Shift+Left, to trim backward. Press Option+Shift+Right to trim forward (Mac OS).
  • Use the numeric keypad "+" or "‐" offset entry to trim by the specified numeric offset.
  • Use the Apply Default Transitions to Selection button to add the default audio and video transitions to the edit point.
  • Use the Edit > Undo and Redo menu commands or shortcuts to change the trims during playback.

Note:

A typical editing workflow would be to first assemble the sequence using insert and overwrite edits. Then, refine your trims by moving from one edit to the next in trim mode, using shortcuts.

Trim tools in trim mode

Within the trim mode interface, and when playback is paused, use any trim tool, including the Selection tool, to drag across a clip to trim. If you drag over either clip, a ripple trim is performed. If you drag between the two clips, a rolling trim is performed. If you drag the Selection tool with the Ctrl key (Windows), or Command key (Mac OS) held down on the outgoing clip, a regular trim is performed on that side of the edit. If you drag with the same modifier key held down on the incoming clip, a regular trim is performed on that side of the edit.

The behavior of dragging across clips in trim mode on the edit point is the same as it is with the trim tools in the Timeline. Dragging to the left trims backwards, and dragging to the right trims forward.

Exit trim mode

Trim mode requires that at least one edit point is selected and that the playhead is positioned at one of the selected edit points. Any action that clears the edit point selection or moves the playhead away from an edit point exits trim mode.

To exit trim mode, do one of the following:

  • Click the Timeline.
  • Use the Sequence > Trim Edit menu command, or press the T key.
  • Close the Program Monitor with a menu item, keyboard shortcut, or workspace panel operation.
  • Scrub the playhead, or use any other Timeline or Program Monitor navigation command that moves off a selected edit point such as Step Forward or Step Backward.
  • Select or drag clips, or select or change any other object in the Timeline.
  • Switch focus to another sequence.

Keyboard shortcuts for trim mode

  • The Play/Stop Toggle keyboard shortcut starts or stops the playback. It is available when you are in trim mode, and defaults to the Spacebar key.
  • Use the Trim Forward and Trim Backward shortcuts to trim by one frame at a time.
  • Use the Trim Forward Many and Trim Backward Many shortcuts to trim by the Large Trim Offset frames at a time (the default is set to five frames). The Large Trim Offset value can be changed in Edit > Preferences > Trim (Windows) or Premiere Pro > Preferences > Trim (Mac OS).

Trimming and the History panel

The History panel shows each trim adjustment as an individual entry, whether using the keyboard, clicking one of the buttons or using J‐K‐L shortcuts. Entering or exiting trim mode does not change the entries in the History panel, so you can still undo one or more of the trim adjustments that were made during any trim mode session.

Slip and slide edits in trim mode

Since more than one trim edit point can be selected on a single track, it is possible to set up slip and slide edits by choosing a pair of opposing ripple edit points on the same track. After the edit points are set up, you can use keyboard shortcuts to complete the trim either in the timeline, or trim mode. Edit points can be Shift-selected to slip and slide multiple clips at the same time, as well.

Slip edit in trim mode

For details about slip edits with the Slip tool, see Making a slip edit.

To slip an edit using keyboard shortcuts, do the following:

  1. Select the Ripple Edit tool.
  2. Click the edit points at the In and Out point of the clip. Choose a Ripple In, followed by Ripple Out.
  3. Enter trim mode by pressing T.
  4. Use keyboard shortcuts, or press buttons to perform a slip edit while looping playback.

You can also use this technique in the Timeline. Press the keyboard shortcuts for Trim Forward or Trim Backward, or use the numeric keypad.

Slide edit in trim mode

For details about slide edits with the Slide tool, see Making a slide edit.

To slide an edit in trim mode, do the following:

  1. Select the Ripple Edit tool.
  2. Click the edit points at the In and Out point of the clip. Choose a Ripple Out, followed by Ripple In.
  3. Enter trim mode by pressing T.
  4. Use keyboard shortcuts, or press buttons to perform a slide edit while looping playback.

You can also use this technique in the Timeline. Press the keyboard shortcuts for Trim Forward or Trim Backward, or use the numeric keypad.

Asymmetrical trimming

Asymmetrical trimming can be performed in both the Timeline and in trim mode. An asymmetrical trim is when a combination of Ripple In and Ripple Out edit points are selected on different tracks with one edit point selected per track. If there is more than one edit point selected per track, all edit points move in the same direction.

The duration of the trim is the same on all tracks for each asymmetrical trim operation, but the direction that each edit point trims left or right may be different.

  • The primary direction of the trim determines the primary edit point. The primary direction of trim is determined by clicking a tool, using a keyboard shortcut, or clicking a button, and is the same on all tracks for each edit point that matches the primary trim type.
  • The edit points that do not match the primary edit point type trim in the opposite direction. See Specifying Primary Direction for Asymmetrical Trims in the Timeline for details about how the primary edit point for an asymmetrical trim is determined.

Notice that the direction of the shifting of the trailing clips left or right are the same on all tracks, which help to keep all tracks in sync. This shifting is due to the fact that the tail of the trimmed clip moves in a different direction for a Ripple In versus a Ripple Out edit point.

For example, if you drag an edit point to the right by ten frames with the Ripple Edit tool, then ten frames are added to the other edit points that are set up as a Ripple Out points. Conversely, ten frames are subtracted from edit points set up as Ripple In points.

Note: These edit points do not actually move, but reveal more of the head material of the clip. Trailing clips on all tracks shift to the right by ten frames.

Combinations of Trim In and Trim Out trims are not considered asymmetrical even if the side of the edit point differs, since the movement of the edit point is always in the same direction and there is no shifting of trailing clips.

Specifying Primary Direction for Asymmetrical Trims in the Timeline

For asymmetrical trims using the mouse in the Timeline, the primary direction is applied to the edit point that is dragged. If you select an edit point, and then drag, it determines the direction and the primary trim type. For example, if you click the mouse to set up a Ripple In trim on Video 1 and drag to the left, then all the Ripple In edit points that are selected on any track trim to the left and all the Ripple Out edit points trim to the right.

When using keyboard shortcuts for timeline trimming, the primary trim type is used from the previous mouse drag or trim mode operation, if the edit point is still selected. If the edit point is no longer selected (or you never used the mouse or trim mode to trim with the primary type), then the edit point on the highest­‐numbered video track with a selected edit point, or the lowest­‐numbered audio track if only audio has selected edit points, is used as the primary type. Its direction is specified by the particular keyboard shortcut.

Work in the Trim Monitor

The Trim Monitor displays clip In and Out points at a cut so that you can see precisely which frames you are cutting. The left monitor shows the outgoing clip to the left of the edit point, and the right monitor shows the incoming clip to the right of it.

Open or close the Trim Monitor

  • To open the Trim Monitor, select Window > Trim Monitor.
  • To close the Trim Monitor, click the close box of the Trim Monitor.

Display the edit point you want to trim

  1. In the Trim Monitor, click the Select Video Or Audio Track button.

  2. Select the track you want to edit from the menu.

Preview the edit in the Trim Monitor

  • To preview the edit once, click the Play Edit button .
  • To preview the edit repeatedly, enable the Loop button and then click the Play Edit button.

Cancel an edit

  • Press Ctrl+Z (Windows) or Command+Z (Mac OS), or use the History palette.

Set trim preferences

You can set the number of frames that are trimmed when you use the Multiple-Frame Trim-in button or the Multiple-Frame Trim-out button .

  • Choose Edit > Preferences > Trim (Windows) or Premiere Pro > Preferences > Trim (Mac OS).

Make a rolling edit using the Trim Monitor

  1. In the Trim Monitor, click the Select Video Or Audio Track button and select the track you want to edit.

  2. Click in the Sync Lock box in the header of any track you want to shift when the rolling edit is made.

  3. In a Timeline, place the playhead at the edit point. This will display the edit point in the Trim Monitor.

  4. Do any of the following:

    • Position the pointer between the video images so that it changes into the Rolling Edit tool ; then drag left or right.
    • Drag the center timecode display left or right.
    • Drag the center jog disk left or right.
    • Click the timecode display between the views, type a valid timecode number to trim the edges of both clips to that frame, and press Enter (Windows) or Return (Mac OS).
    • Select the boxed number above the center jog disk, type a negative number to trim both clips left or type a positive number to trim both clips right, and press Enter (Windows) or Return (Mac OS).
    • Click the button that corresponds with the number of frames you want to edit. The –1 and –5 buttons trim both clips left; +1 and +5 trim both clips right.

    Note:

    The large trim offset number is 5 frames by default, but you can set it to any number by specifying a number in the trim preferences. Choose Edit > Preferences > Trim (Windows) or Premiere Pro > Preferences > Trim (Mac OS).

Make a ripple edit using the Trim Monitor

  1. In the Trim Monitor, click the Select Video Or Audio Track button and select the track you want to edit.

  2. Click in the Sync Lock box in the header of any track you want to shift when the ripple edit is made.

  3. In a Timeline, place the playhead at the edit point. This will display the edit point in the Trim Monitor.

  4. Do any of the following:

    • Position the pointer in the left or right image so that it becomes the Trim-out icon or Trim-in icon respectively, and drag left or right to ripple-edit the corresponding clip.
    • Drag the timecode display under the left or right image to trim the corresponding clip.
    • Drag the left or right jog disk to trim the corresponding clip.
    • Drag the Outgoing Out Point icon in the left view’s time ruler, or drag the Incoming In Point icon in the right view’s time ruler.
    • Drag the Out Shift or In Shift timecode number left or right to ripple-edit the corresponding clip.
    • Click the left clip’s timecode display (for the left clip’s Out point) or the right clip’s timecode display (for the right clip’s In point), type a valid timecode number to trim the corresponding clip to that frame, and press Enter (Windows) or Return (Mac OS).
    • Click the Out Shift display (for the left clip’s Out point) or the In Shift display (for the right clip’s In point), type a negative number (to trim left) or a positive number (to trim right), and press Enter (Windows) or Return (Mac OS).

Note:

The Trim Monitor is available in Window > Trim Monitor, but it does not work with selected edit points in the Timeline. The Trim Monitor is still useful for audio waveform trimming, and provides a method for trimming and monitoring a single track. However, Premiere Pro Trim Mode is a better environment to trim than using the Trim Monitor.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy