Adobe Photoshop başlatılırken oluşan Generator hatasını düzeltme

Son güncelleme: 2 Kas 2026

Güvenlik ayarlarını kontrol ederek, çakışan eklentileri kaldırarak ve günlükleri inceleyerek Adobe Photoshop'taki Generator hatasının nasıl düzeltileceğini öğrenin.

Generator, Photoshop ile Generator eklentileri arasındaki iletişimi yöneten bir Node.js uygulamasıdır. Farklı Dışa Aktar ve Görüntü Öğeleri için varlık oluşturma mantığını sağlar.

Photoshop başlatıldığında veya Dosya > Dışa Aktar > Farklı Dışa Aktar seçildiğinde bir iletişim kutusu açılır ve şu ifade görüntülenir: "Generator ile ilgili bir sorun var. Lütfen Photoshop’tan çıkın ve yeniden deneyin. Sorun devam ederse üçüncü taraf eklentileri kaldırın veya Photoshop'u yeniden yüklemeyi deneyin."

Aşağıdaki çözümleri sırayla deneyin.

Güvenlik yazılımı Generator'ı engelliyor

Güvenlik veya antivirüs yazılımı, 8010 bağlantı noktasında Generator'dan gelen iletişimi engelleyebilir veya node işleminin çalışmasını önleyebilir.

Güvenlik veya antivirüs ayarlarını açın.

Photoshop'u izin verilen uygulamalar listesine ekleyin.

Oluşturucu için 8010 bağlantı noktasının açık olduğundan emin olun.

Windows'ta, node.exe dosyasını C:\Program Files\Adobe\Adobe Photoshop <sürüm>\node.exe konumundaki izin verilen uygulamalar listesine ekleyin.

macOS'ta, /Applications/Adobe Photoshop <sürüm>/Adobe Photoshop <sürüm>.app/Contents/MacOS/node konumundaki node işlemine izin verin.

Windows'ta, Photoshop'un denetimli klasörlere erişmesine izin verin.

Photoshop'u yeniden başlatın, ardından Generator'ı test etmek için Dosya > Dışa Aktar > Farklı Dışa Aktar öğesini seçin.

Üçüncü taraf bir eklenti, Oluşturucu ile çakışıyor

Photoshop Generator klasöründeki üçüncü taraf eklentiler, kullanılan sürümle uyumsuz olabilir veya varsayılan Görüntü Öğeleri eklentisiyle çakışabilir.

Windows: C:\Program Files\Adobe\Adobe Photoshop <version>\Plug-ins\Generator

macOS: /Applications/Adobe Photoshop <version>/Plug-ins/Generator

Masaüstünde Devre Dışı Generator Eklentileri adlı geçici bir klasör oluşturun.

Üçüncü taraf eklenti klasörlerini geçici klasöre taşıyın. Varsayılan Image Assets eklentisini Generator klasöründe bırakın.

Photoshop'u başlatın ve Dosya > Dışa Aktar > Farklı Dışa Aktar öğesini seçin.

Hata ortadan kalkarsa eklentileri birer birer geri ekleyin ve hata tekrar ortaya çıkana kadar her ekleme sonrasında Photoshop'u yeniden başlatın.

Varsayılan Görüntü Öğeleri eklentisini Generator klasöründe bırakın.Yalnızca ayrı olarak yüklenen eklentileri taşıyın.

Oluşturucu başlatılamıyor ve buna ihtiyaç yok

Farklı Dışa Aktar veya Görsel Varlıkları kullanılmıyorsa geçici bir çözüm olarak Generator’ü kapatın.

Photoshop uygulamasını başlatın.

Windows’ta Düzenle > Tercihler > Eklentiler seçeneğini belirleyin. macOS’ta Photoshop > Ayarlar > Eklentiler seçeneğini belirleyin.

Üreticiyi Etkinleştir seçimini kaldırın.

Tamam seçeneğini belirleyin, ardından Photoshop’u yeniden başlatın.

Dosya > Dışa Aktar > Farklı Dışa Aktar seçildiğinde Generator yeniden açılır. Farklı Dışa Aktar gerekiyorsa Generator’ü kapalı bırakmak yerine Generator hatasını çözün.

Generator günlüklerinde başlatma hataları görünüyor

Generator günlükleri, yüklenemeyen eklentiler veya Generator’ün başlamasını engelleyen sistem sorunları hakkında bilgiler içerebilir.

Windows’ta C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop <version>\Logs\Generator konumuna gidin.

macOS’ta /Users/<username>/Library/Logs/Adobe/Adobe Photoshop <version>/Generator konumuna gidin.

En son Generator günlüğünü açın ve hata iletilerini arayın.

Generator klasörü yoksa üst klasör için yazma iznine sahip olduğunuzu doğrulayın.

Ek yardım gerekirse tanılama günlüklerini toplamak için Adobe Log Collector Tool kullanın.

Windows AppData ve macOS Library klasörleri varsayılan olarak gizlidir. Windows’ta gizli dosya ve klasörleri gösterme yönergeleri, Windows günlüklerinin bulunmasına yardımcı olabilir.

Generator hataları Apple Silicon’da oluşuyor

Apple silicon bulunan bir Mac’te oluşturucu başarısız olmaya devam ederse Photoshop’u Rosetta ile çalıştırmak, soruna yerel mod uyumluluğunun neden olup olmadığını belirlemeye yardımcı olabilir.

Photoshop'tan çıkın.

Finder içinde Uygulamalar’ı açın ve Adobe Photoshop’u bulun.

Adobe Photoshop’u Control tuşuna basarak tıklayın, ardından Bilgi Ver seçeneğini belirleyin.

Rosetta kullanarak aç seçeneğini belirleyin, ardından Photoshop’u başlatın ve Generator’ü test edin.

Hata devam ederse yardım için Adobe Destek ile iletişime geçerken Generator günlüklerini paylaşın. Generator’le ilgili olmayan Farklı Dışa Aktar sorunları için dışa aktarma ve kaydetme işlemlerine yönelik sorun giderme kılavuzunu kullanın.