選取「檔案」>「自動化」>「產生器外掛程式」>「影像資產」。
- 新增功能
-
開始使用
- 技術要求和安裝
-
了解基本功能
- 桌面版 Adobe Photoshop 常見問答集
- 首頁畫面概觀
- 工作區概觀
- 存取「探索」面板
- 儲存自訂工作區
- 切換工作區
- 刪除工作區
- 固定或取消固定面板
- 堆疊浮動面板
- 使用「相關工作列」提升工作流程效率
- 重新排列文件視窗
- 新增和移除面板
- 移動面板
- 隱藏或顯示所有面板
- 還原工作區
- 展開或收合面板圖示
- 變更面板和工具提示中的文字大小
- 在數字欄位中使用簡單的數學運算
- 支援高密度顯示器和每個顯示器的縮放
- 排列與群組面板
- 在 Photoshop 中縮放影像
- 校準螢幕並建立螢幕描述檔
- Photoshop 中的 Creative Cloud Libraries
- 申請存取權以測試實驗性功能
- 導覽影像並管理版面檢視
- 設定工具列和面板
- 設定與偏好設定
- Photoshop 中的生成式 AI
-
建立、開啟及讀入影像
- 讀入檔案
- 建立影像
-
建立及管理圖層
- 開始使用圖層
- 轉換和操作圖層
- 色彩調整和填色圖層
- 套用圖層效果
- 智慧型物件
- 建立圖層構圖
- 版面與設計工具
-
裁切、調整大小,以及變形
- 調整大小和解析度
- 裁切和拉直
- 變形、操控和調整形狀
-
建立選取範圍
- 選取範圍入門
- 自動和基於顏色的選取
- 手繪選取
-
調整和修改選取範圍
- 移動選取範圍或選取範圍邊框
- 調整您的選取範圍和遮色片
- 「移動工具」中的暫留圖層邊界
- 拷貝及貼上選取範圍
- 在影像內建立多個選取範圍拷貝
- 將一個選取範圍貼至另一個選取範圍的內部或外部
- 刪除或剪下選取的像素
- 控制選取範圍的移動
- 隱藏或顯示選取範圍邊緣
- 反轉選取範圍
- 手動調整選取範圍
- 僅選取與其他選取範圍相交的區域
- 調整及柔化選取範圍邊緣
- 使用消除鋸齒選取像素
- 定義選取工具的羽化邊緣
- 沿著選取範圍邊框周圍建立選取範圍
- 展開或收縮選取範圍
- 清除以顏色為基礎的選取範圍內之零星像素
- 選取範圍周圍的外緣像素
- 減少選取範圍的外緣
- 移除選取範圍的色邊
- 使用選取範圍進行生成式編輯
- 在路徑和選取範圍之間轉換
- 選取影像中焦點清晰的區域和像素
- 建立遮色片
-
修復與潤飾
- 移除物件並填滿空間
- 修復和仿製
- 調整光源和色調
- 清理和還原影像
-
調整顏色
- 色彩描述檔
- 選擇顏色
- 色彩模式
- 顏色校正
- 選擇性顏色調整
- 顏色效果和技巧
- HDR 與管道操控
-
套用繪畫技巧
- 填滿物件、選取範圍和圖層
- 建立並填入圖樣
- 筆刷和預設
- 繪製形狀和路徑
-
文字和印刷樣式
- 開始使用文字
- 選取和管理字型
- 文字圖層與建立
- 路徑和形狀上的文字
- 字元與字符
- 國際文字和語言
- 使用「動態文字」
-
效果和濾鏡
- 開始使用濾鏡
- 智慧型濾鏡
- 模糊和銳利化濾鏡
- 藝術與風格化濾鏡
- Neural Filters
- 快速動作
- 使用格點和度量參考線
-
新增影片和動畫
- 建立動畫影格
- 使用主要影格
- 組織及管理視訊群組
-
自動執行工作
- 建立和記錄動作
- 批次處理檔案
- 自動化設定和預設集
- 透過範本和變數的
-
儲存和轉存
- 儲存檔案
- 將檔案轉存為不同格式
- 中繼資料、CSS 和 Content Credentials
- 列印
- 共用和共同作業
-
應用程式整合
- 存取 Adobe Express 範本
- 修飾 Firefly 生成的影像
- 將影像轉換為影片
- 在 Illustrator 中開啟 Photoshop 檔案
- 使用選用的擴充功能
- 安裝和管理 Marketplace 外掛程式
- 安裝 ScriptingListener 外掛程式
- 為「紋理化」篩選器安裝紋理
- 適用於 Photoshop 的 MATLAB 文件屬性
- 在 InDesign 中置入 Photoshop 檔案
- 延伸功能描述和相容性
- 設定 MATLAB,與 Photoshop 搭配使用
- 從 Photoshop 將影像共用至 Slack
- 將 Photoshop 作品共用至 Trello
- 在 InDesign 中疑難排解 Photoshop 檔案
- 儲存與管理雲端文件
- 邀請其他人編輯雲端文件中的影像
- 使雲端文件可以離線使用
- 使用「外掛程式市集」安裝和管理外掛程式
- 建立縮圖目錄
- 建立 PDF 簡報
- 將 Illustrator 藝術作品貼上為圖層
- 從 Illustrator 貼到 Photoshop 的限制
- 將 Adobe Illustrator 圖案貼入 Photoshop
- 在 Adobe Photoshop 中置入 Illustrator 檔案或 PDF
- 在 Adobe Illustrator 中使用 Photoshop 影像
- 在 InDesign 中使用 Photoshop 圖層構圖
- InDesign 中的 Photoshop 檔案行為
- Photoshop 雲端文件總覽
- Photoshop 外掛程式與擴充功能
-
疑難排解
- 工具和資源
- 效能與穩定性問題
- 檔案和格式問題
-
工具和功能問題
- 使用項目符號和編號時 Photoshop 當機
- 鍵盤快速鍵無法運作
- 使用 Illustrator 時的限制
- 解決影片轉譯問題
- Adobe Photoshop 中工具行為異常
- 工具列缺少工具
- 字型疑難排解
- 解決 Photoshop 雲端文件錯誤
- Adobe Photoshop 中的外掛程式當機與錯誤
- 擷取 Adobe Photoshop 輸入問題的診斷記錄
- 使用 Adobe Photoshop 指令碼時發生錯誤
- 使用濾鏡和效果時發生的問題
- Adobe Photoshop 當機、延遲或凍結
- 疑難排解 Windows 上的 Photoshop 小程式
- 素材庫資產無法完整更新
- 文字隨機變更或損毀
- Photoshop 中的外掛程式檔案夾位置
- Photoshop 在 Apple Silicon 上的限制
- 我的預設集、動作或增效模組消失
- 油畫篩選器呈灰色
- 「列印」對話方塊中的「列印設定」選項無法使用
- 動作消失
從圖層產生影像資產
使用產生器,透過在圖層名稱後面加上 .png 或 .jpg 等格式副檔名,自動建立檔案。
在圖層名稱後面加上副檔名,會觸發 Photoshop 的產生器,讓您每次儲存時自動建立影像檔案。這樣可以省去網頁、應用程式及需要多種格式或尺寸的多裝置專案中重複的匯出步驟。
當您需要以多種格式或解析度進行一致且可重複的匯出時,此工作流程最為實用,例如為回應式設計產生 @1x、@2x 和 @3x 版本。如需單次匯出或需要特定格式控制,請改用「檔案」>「匯出」>「匯出為」。
產生器會為您的資產建立專用資料夾,並在您操作時自動更新檔案。您可以從單一圖層產生多種格式、指定品質設定、將資產縮放為不同尺寸,並將輸出整理到子資料夾中,這些全都可以透過圖層命名慣例完成。
- 具有已命名圖層或圖層群組的 Photoshop 文件
- 已將文件儲存到已知位置 (否則資產會顯示在桌面上)
- 瞭解專案所需的輸出格式
啟用影像資產產生功能
在「圖層」面板中,找到您要匯出的圖層或群組。
在圖層名稱後面加上副檔名來重新命名圖層:.jpg、.png、.gif 或 .svg。例如,將「logo」重新命名為「logo.png」。
按 Ctrl + S (Windows) 或 Command + S (macOS) 儲存文件。
Photoshop 會在已儲存文件旁的子資料夾中建立影像檔案。如果您的文件尚未儲存,資產會顯示在桌面上的新資料夾中。產生器會保持運作中,對已啟用產生器的圖層所做的任何變更,都會觸發對應資產的自動更新。
圖層名稱不能包含 : (冒號) 或 * (星號),因為這些字元會阻止資產產生。
從一個圖層產生多種格式
單一圖層可以同時產生不同格式、尺寸和品質等級的資產。在圖層名稱中,使用逗號或加號分隔每個資產規格。
在「圖層」面板中選取圖層。
使用逗號分隔的格式重新命名圖層,例如:button.png, button.jpg90, 200% button@2x.png。
儲存文件。
Photoshop 會從相同的圖層內容產生三個不同的檔案,無需以不同格式手動匯出相同的圖形。
控制不同螢幕的資產品質與縮放比例
在「圖層」面板中選取圖層。
在檔案名稱中加入品質或大小參數。例如:「button.jpg90」會將 JPEG 品質設為 90%,或「200% logo@2x.png」會將資產大小加倍。
若需要多種解析度,請使用逗號分隔每個規格:「icon.png, 200% icon@2x.png, 300% icon@3x.png」。
儲存文件以產生所有變化版本。
品質後置詞可控制 JPG 檔案的壓縮比 (1 至 100),以及 PNG 檔案的位元深度 (8、24 或 32)。大小前置詞可接受百分比進行相對縮放,或接受絕對像素尺寸。您可以混合使用單位,例如「10in x 5cm banner.jpg」,並省略其中一個尺寸以按比例縮放:「1080 x icon.png」會將寬度設為 1080 像素,同時維持外觀比例。
使用 @2x 和 @3x 命名慣例,可自動產生適用於回應式網頁專案和行動應用程式的 Retina 與高 DPI 版本。
相對縮放範例:
200% logo.png 會將資產大小加倍
50% thumbnail.jpg 會將資產縮小為一半
絕對尺寸範例:
300 x 200 hero.png 會建立 300×200 像素的影像
10in x 5cm banner.jpg 混合使用單位 (寬 10 英吋,高 5 公分)
1080 x icon.png 會將寬度設為 1080 像素,高度則按比例縮放
指定像素尺寸時,請直接輸入數字,不需加上單位標示。請使用「300 x 200」,而非「300px x 200px」。
將資產整理至子資料夾
預設情況下,所有產生的資產都會儲存在 PSD 檔案旁的單一檔案夾中。在檔案名稱前加入子檔案夾名稱,可指示產生器自動建立並使用該子檔案夾。這樣可讓相關資產保持整理狀態,而不需要手動管理檔案夾。
使用正斜線在圖層名稱中加入子檔案夾路徑:subfolder/filename.png 或 icons/logo.svg。您可以巢狀多個層級:assets/icons/logo.png。
將資產匯出至特定資料夾
使用檔案名稱中的子檔案夾路徑來重新命名圖層。例如:mobile/button.png, desktop/button.png。
儲存文件。
Photoshop 會自動建立檔案夾結構,並將每個資產放置在指定的位置。將子檔案夾與大小前置詞和品質設定結合使用,可完全控制資產組織:mobile/200% button@2x.png, desktop/button.jpg90。
設定文件層級的預設值
建立特殊圖層,以設定套用至所有生成資產的基準線設定。這樣可避免在個體圖層名稱中重複指定參數。
建立一個空圖層,並以「default」開頭命名,後面接上您偏好的設定。常見的設定包括「default 200%」可將所有資產縮放為 200%、「default assets/」可將所有內容儲存到 assets 子檔案夾,或「default @2x」可在所有檔案名稱加上 @2x 後置詞。
您可以合併多個預設值:「default 200% retina/ @2x」會將所有資產縮放為 200%、儲存到 retina 子檔案夾,並在檔案名稱加上 @2x 後置詞。個體圖層設定會覆蓋文件預設值,如果您的預設值指定「default 200%」,但圖層名稱包含「50% thumbnail.png」,則該圖層會以 50% 生成。
使用雲端文件
雲端文件會將生成的資產儲存在本機,而非直接與 PSD 檔案放在一起。Photoshop 會維持此分隔,以區分本機內容和雲端同步內容。
雲端文件的資產會顯示在以下位置:
- Windows:C:\Usersusername>\Documents\Adobe\Photoshop Cloud Associates
- macOS:/Users//Documents/Adobe/Photoshop Cloud Associates
每個雲端文件都會在此目錄中建立自己的子資料夾。系統會在您工作時自動生成資產,但這些資產會保留在您的本機電腦上,直到您在 Creative Cloud 中明確共用或同步它們為止。
停用資產產生
影像資產生成功能一旦啟用,便會針對該文件保持運作,並在各工作階段中持續有效。此功能會在您每次儲存時自動重新生成資產,對於複雜的文件,可能會降低效能。
若要關閉目前文件的生成功能,請取消選取 檔案 > 自動 > 產生器外掛程式 > 影像資產。這樣會停止自動建立資產,但會保留任何現有的資產和圖層命名。
若要在所有文件中全域關閉產生器,請選取 編輯 > 偏好設定 > 外掛程式,取消選取 啟用產生器,然後選取 確定。這樣會完全關閉產生器功能,直到您在偏好設定中重新啟用為止。