了解如何將文件、工作區域和圖層轉存為不同的格式和大小。

將檔案轉存為不同格式

您可以使用「快速轉存為」「轉存為」選項,將 Photoshop 文件、工作區域、圖層和圖層群組轉存為 PNG、JPG、GIF 和 SVG 檔案格式。

在 Photoshop 中轉存文件、工作區域和圖層

快速轉存為

如果您想要根據「快速轉存偏好設定」中已指定的設定快速轉存工作時,請使用「快速轉存為」選項。

若要存取「快速轉存為」選項,請執行下列任一項作業:

  • 導覽至「檔案 > 轉存 > 快速轉存為 [影像格式]」。
  • 前往「圖層」面板。選取要轉存的圖層、圖層群組或工作區域。以滑鼠右鍵按一下您的選取項目,然後從內容選單中選擇 「快速轉存為 [影像格式] 」。

快速轉存偏好設定

依預設,「快速轉存」會將資產產生為具有透明度的 PNG,並且每次都提示您選取轉存位置。

若要變更「快速轉存」設定,請執行下列任一項作業:

  • 前往 「編輯 > 偏好設定」 
  • 選取「檔案 > 轉存 > 轉存偏好設定」
將 PSD 快速轉存為影像
在 Photoshop 中設定轉存偏好設定

您可以在「偏好設定」對話框中指定下列選項:

快速轉存格式:選取要轉存的影像檔案格式 (PNG、JPG、GIF SVG)。您可以進一步設定格式特定例如針對 PNG,您可以指定想要轉存啟用「透明」 (32 位元) 的資產,或者轉存「較小的檔案」(8 位元)。針對 JPG,您可以設定轉存品質。 

快速轉存位置:選擇此選項來選取使用「快速轉存」轉存影像的位置。選取下列其中一個選項:

  • 每次詢問轉存目的位置: 提示您在每次轉存資產時選取位置。
  • 轉存檔案至目前文件旁的資產資料夾:在包含來源 Photoshop 文件的資料夾內,將影像資產置入命名為資產的子資料夾。

快速轉存中繼資料:使用此選項將中繼資料 (版權與聯絡資訊) 包含在 轉存資產中。

快速轉存色域:選擇是否要將資產轉換為 sRGB 色域。

轉存為位置:請參閱轉存為

轉存為

您每次將圖層、圖層群組、工作區域或 Photoshop 文件轉存為影像時,請使用「轉存為」選項來微調您的轉存設定。每個選取的圖層、圖層群組或工作區域會轉存為個別的影像資產。

若要使用「轉存為」對話框,請執行下列任一操作:

  • 導覽至「檔案 > 轉存 > 轉存為」,轉存目前的 Photoshop 文件。如果文件包含工作區域,則其中的所有工作區域都會透過此對話框轉存。
  • 前往「圖層」面板。選取要轉存的圖層、圖層群組或工作區域。以滑鼠右鍵按一下您的選取項目,然後從內容選單中選取「轉存為」

轉存為對話框設定和位置偏好設定

您可以在「轉存為」對話框中設定下列選項:

格式:選擇 PNG、 JPG、 GIF或 SVG。

格式特定的設定:針對 PNG,請指定想要轉存啟用 「透明」 (32 位元) 的資產,或者轉存較小的影像 (8 位元)。針對 JPEG,請指定所需的影像品質 (0-100%)。依預設,GIF 影像是透明的。轉存 PNG 資產時,請記得:

  • 選取「透明」時會產生 32 位元的 PNG 資產
  • 選取「較小的檔案」時會產生 8 位元的 PNG 資產
  • 若無選取上述兩個選項,則會產生 24 位元 PNG 資產。

大小:指定影像資產的寬度和高度。預設會同時鎖定寬度和高度。變更寬度時會按比例自動變更高度。如果想要指定已轉存資產的版面邊界,請參閱版面尺寸

縮放:選擇所轉存影像的應有大小。此選項適合用來轉存較大或較小解析度的資產。變更尺度會影響影像大小。

重新取樣: 選擇重新取樣方法。重新取樣是指您在變更影像的像素尺寸或解析度時 (通常是在重新調整影像的大小時),對影像資料的數量所做的變更。

  • 縱橫增值法: 依周圍像素的平均顏色值增加像素。此方法會產生中等品質結果。
  • 環迴增值法:這是一種比較慢但較準確的方法,以檢查周圍像素的值為基礎。環迴增值法採用複雜的計算,相較於縱橫增值法或最接近像素重新取樣方法,會產生較平滑的色調漸層。
  • 環迴增值法 (更平滑): 適合用來根據「環迴增值法」內插補點放大影像,但依設計是要產生更平滑的結果。
  • 環迴增值法 (更銳利): 適合用來根據「環迴增值法」內插補點縮減影像大小,同時強化銳利度。這個方法可以在重新取樣時,保留影像的細節。如果「環迴增值法 (更銳利)」使影像的某些區域過度銳利化,請試著使用「環迴增值法」。
  • 環迴增值法 (自動): 會自動選擇適用於影像的環迴增值取樣方法。
  • 最接近像素: 複製影像中像素的較快速、但比較不準確的方法。此方法適用於所含邊緣未消除鋸齒的插圖。它會保留硬邊,而產生較小的檔案。但是,這個方法也可能產生鋸齒效果。縮放影像時,或在選取範圍上執行多重操作時,此情況會變得明顯。
  • 保留細節:在重新調整像大小的同時,此方法會將主要重點放在保留影像細節和銳利度上。

畫布大小:如果您的資產需要佔有一定寬度和高度,請將這些值指定為「畫布大小」。「轉存為」對話框會更新預視,以將這些邊界內的影像置中。此選項適合用在下列幾種情況:

  • 您要轉存有各種大小的圖示,並且要置中在 50x50 px 的方框內。
  • 您要轉存小於或大於必要尺寸的橫幅影像。

如果影像大於畫布大小,則會裁剪為畫布所設定的寬度和高度值。您可以按一下「重設」,將值回復為「影像大小」中的設定值。

中繼資料:指定要將中繼資料 (版權與聯絡資訊) 內嵌至轉存資產。

色域:指定下列選項:

  • 是否要將轉存資產轉換為 sRGB 色域。此選項預設為選取。
  • 是否要將色彩描述檔嵌入轉存資產。

若要變更「轉存為」位置偏好設定,請執行下列任一操作:

  • 前往「編輯 > 偏好設定」
  • 選取「檔案 > 轉存 > 轉存偏好設定」

「偏好設定」對話框中,選擇「轉存為位置」底下的選項。

  • 將資產轉存至目前文件的位置。
  • 將資產轉存至上次指定的位置

將檔案轉存為不同大小

您可使用「轉存為」對話框,將圖層、工作區域或文件轉存各種大小的資產。

若要執行此動作,請依照下列步驟操作:

  1. 「轉存為」對話框的左邊窗格中,選取一個相對資產的大小 (例如 1.25x
  2. 選擇以相對資產大小轉存的資產字尾。(例如,@1,25x)。字尾可協助您輕鬆管理轉存的資產。
  3. 按一下 ' + ' 圖示可為轉存的資產新增更多大小和尾碼。

您選擇的縮放選項已套用至您選取的所有圖層或工作區域。

將資產轉存為不同大小
使用「轉存為」對話框將檔案轉存為不同大小

將圖層轉存成檔案

您可以使用各種格式,包括 PSD、BMP、JPEG、PDF、Targa 和 TIFF 等,將圖層轉存為個別的檔案。Photoshop 會在儲存圖層時自動命名。也可以藉由設定選項控制檔案名稱產生的方式。

若要將圖層轉存成檔案,請執行下列動作:

  1. 選擇「檔案 > 轉存 > 將圖層轉存成檔案」
  2. 「將圖層轉存成檔案」對話框的「目的地」區域中,按一下「瀏覽」,選取轉存檔案的目的地。根據預設,產生的檔案會儲存在與來源檔相同的檔案夾中。
  3. 「檔案名稱字首」文字方塊中輸入名稱,為檔案指定共同名稱。
  4. 如果您只想轉存已在「圖層」面板中啟動可見度的圖層,請選取「僅限可見圖層」選項。如果不想轉存所有圖層,請使用這個選項,並將不想轉存的圖層的可見度關閉。
  5. 「檔案類型」選單中選擇檔案格式。然後視需要設定選項。
  6. 若要將使用中色域描述檔嵌入轉存檔案中,請選取「包含 ICC 描述檔」選項。這是色彩管理工作流程的重要步驟。
  7. 按一下「執行」
將圖層轉存成檔案
將圖層轉存成檔案

將工作區域轉存為檔案

您可以將工作區域轉存為個別檔案。請依照下列步驟操作:

  1. 在 Photoshop 中,選取「檔案 > 轉存 > 工作區域轉存檔案」
  2. 「工作區域轉存檔案」對話框中,執行下列動作:
    • 選擇要儲存所產生檔案的目的地。
    • 指定檔案名稱字首。
    • 指定僅要轉存工作區域內容,或是要包含重疊區域。
    • 指定要轉存所有工作區域,或是僅轉存目前選取的工作區域。
    • 指定是否也要將工作區域背景與工作區域一同轉存。
    • 選擇想要轉存的檔案類型。您可以選擇轉存為 BMP、JPEG、PDF、PSD、Targa、TIFF、PNG-8 或 PNG-24。
    • 指定已選取之檔案類型的轉存選項。
      • 指定是否也要將工作區域名稱與轉存的工作區域一同轉存。選取這項設定時,您也可以指定自訂字體、字體大小、字體顏色和版面延伸色彩。
  3. 按一下「執行」。Photoshop 隨即以選定格式將工作區域轉存為檔案。
將工作區域轉存為檔案
將工作區域轉存為檔案

將工作區域轉存為 PDF

您可以將工作區域轉存為 PDF 文件。請依照下列步驟操作:

  1. 在 Photoshop 中,選取「檔案 > 轉存 > 工作區域轉存 PDF」
  2. 「工作區域轉存檔案」對話框中,執行下列動作:
    • 選擇要儲存所產生 PDF 文件的目的地/位置。
    • 指定所產生 PDF 文件的檔案名稱字首。例如:Campaign_insurance
    • 指定僅轉存工作區域中的內容,或是轉存與工作區域重疊之區域中的內容。
    • 指定要轉存所有工作區域,或是僅轉存目前選取的工作區域。
    • 指定是否也要將工作區域背景與工作區域一同轉存。
    • 指定要在目前文件中,產生一份所有工作區域的 PDF,或是依每個工作區域各產生一份 PDF 文件。如果選擇產生多份 PDF 文件,則所有的文件皆會採用您稍早指定的檔案名稱字首。
    • 指定轉存 PDF 文件的編碼:ZIPJPEG。如果選擇 JPEG,也請指定「品質」設定 (0-12)。
    • 指定是否要在轉存的 PDF 文件中包含國際色彩協會 (ICC) 描述檔。ICC 描述檔包含描述色彩輸入或輸出裝置的資料。
    • 指定是否也要將工作區域名稱與轉存的工作區域一同轉存。選取這項設定時,您也可以指定自訂字體、字體大小、字體顏色和版面延伸色彩。
  3. 按一下「執行」。Photoshop 隨即產生 PDF 文件。
將工作區域轉存為 PDF
將工作區域轉存為 PDF

常見問題

哪個色域最適合轉存我的 Photoshop 文件?

為需要放在網路上的影像進行準備時,建議您採用 sRGB,因為它定義了用來檢視網頁影像之標準螢幕的色域。此外,當您在處理消費級數位相機所拍攝的影像時,也建議您選擇 sRGB,因為此類相機多半採用 sRGB 做為預設色域。 

若要進一步瞭解色域和設定,請參閱顏色設定

什麼是轉存切片?

切片可將影像分割成幾個較小的影像,這些小片段可以利用 HTML 表格或 CSS 圖層在網頁上重新組合。藉由分割影像,您可以指定不同的 URL 連結以建立網頁導覽,或使用個別的最佳化設定來最佳化影像的各個片段。您可以使用「儲存為網頁用 (舊版)」選項轉存及最佳化切片的影像。Photoshop 會將每一個切片儲存為個別檔案,並產生所需的 HTML 或 CSS 程式碼以顯示切片的影像。

若要進一步瞭解,請參閱切片網頁

我可以使用「儲存為網頁用」轉存我的 Photoshop 文件嗎?

是。您仍可使用「儲存為網頁用 (舊版)」選項來轉存您的資產。若要使用舊版轉存選項轉存文件,請選取「檔案 > 轉存 > 儲存為網頁用 (舊版)」

若要進一步瞭解,請參閱 Photoshop 中的儲存為網頁用。 

常見錯誤與限制

錯誤:Adobe 儲存為網頁用

當您在 macOS 10.15.x 上使用 Photoshop 並選取 「檔案 > 轉存 > 儲存為網頁用」時, 您會收到錯誤訊息 表示「Adobe 儲存為網頁用錯誤:無法完成此操作。發生不明錯誤。」

若要瞭解因應措施,請參閱 Photoshop 和 macOS Catalina (10.15)

錯誤:演算視訊已啟動,但始終沒有完成

當您選取「檔案 > 轉存 > 演算視訊...」時,程序始終沒有完成。 

若要瞭解因應措施,請參閱 Photoshop 和 macOS Catalina (10.15)

錯誤:啟動 Photoshop 時發生「產生器出現問題」

「產生器出現問題,請結束 Photoshop 並再試一次。如果問題還是沒有解決,請移除任何協力廠商增效模組,或嘗試重新安裝 Photoshop。」上述錯誤可能在啟動 Photoshop 或使用產生器相關功能時發生。 

若要瞭解因應措施,請參閱啟動 Photoshop 時發生「產生器出現問題」錯誤

錯誤:圖層空白

空白或無法顯示影像的圖層,無法顯示在「轉存為」對話框中。這些圖層可為「剪裁遮色片」、「調整圖層」,或僅為不含像素的圖層。

錯誤:影像位於文件邊界外

「轉存」操作無法演算影像,因為會溢出畫布。移動影像以符合畫布範圍

SVG 轉存限制

  • 文字無法如預期演算。為了獲得最佳真實度,請先將文字圖層轉換為形狀再轉存為 SVG。
  • 圖層遮色片和剪裁遮色片無法如預期演算。請改為使用向量圖遮色片,不要使用 SVG 轉存。
  • 背景圖層轉存至 SVG 時會變成透明。請在「圖層」面板中複製背景圖層,該背景圖層即可顯示在轉存的 SVG 影像中。