Creare, aprire, modificare, salvare e ripristinare file in Dreamweaver. Creare modelli e aprire i file correlati.

Dreamweaver offre un ambiente flessibile in cui lavorare a più tipi di documenti Web. Oltre ai documenti HTML, potete creare e aprire un'ampia gamma di documenti basati su testo, ad esempio JavaScript, PHP e CSS (Cascading Style Sheets).

Dreamweaver fornisce diverse opzioni per creare un nuovo documento. Potete scegliere una delle opzioni seguenti:

  • Un nuovo documento o modello vuoto

  • Un documento basato su uno dei layout di pagina predefiniti forniti con Dreamweaver, tra cui oltre 30 layout di pagina basati su CSS

  • Un documento partendo da uno dei modelli esistenti

    Potete anche impostare le preferenze dei documenti. Ad esempio, se normalmente lavorate con un solo tipo di documento, potete impostarlo come tipo di documento predefinito per la creazione di nuove pagine.

    Nella vista Progettazione o Codice, potete definire con facilità le proprietà dei documenti, come i tag meta, il titolo del documento, i colori di sfondo e molte altre proprietà della pagina.

Tipi di file di Dreamweaver

In Dreamweaver è possibile lavorare con vari tipi di file. Il tipo di file fondamentale utilizzato è il file HTML. I file HTML, o Hypertext Markup Language, includono il linguaggio basato sui tag responsabile della visualizzazione di una pagina Web in un browser. Potete salvare i file HTML con estensione .html o .htm. Per impostazione predefinita, Dreamweaver salva i file utilizzando l'estensione .html.

Dreamweaver permette di creare e modificare pagine Web basate sul linguaggio HTML5. Sono anche disponibili dei layout di esempio per realizzare pagine HTML5 da zero.

Alcuni dei tipi di file più comuni che potete utilizzare in Dreamweaver sono indicati di seguito:

CSS

I file CSS (Cascading Style Sheet) hanno l'estensione .css. Sono utilizzati per formattare i contenuti HTML e controllare il posizionamento dei vari elementi di una pagina.

GIF

I file GIF (Graphics Interchange Format) hanno l'estensione .gif. Il formato GIF è un formato per la grafica Web molto diffuso per sequenze animate, immagini con aree trasparenti e animazioni. I file GIF contengono un massimo di 256 colori.

JPEG

I file JPEG (Joint Photographic Experts Group, dal nome dell'organizzazione che ha creato questo formato) hanno l'estensione .jpg e generalmente rappresentano immagini fotografiche o a elevati contenuti cromatici. Il formato JPEG è la scelta ottimale per le fotografie digitali o scansionate, le immagini che utilizzano texture, le immagini con transizioni di colori sfumati o qualsiasi immagine che richieda più di 256 colori.

XML

I file XML (Extensible Markup Language) hanno l'estensione .xml. Includono dati in forma non elaborata che possono essere formattati tramite il linguaggio XSL (Extensible Stylesheet Language).

Finestra di dialogo Nuovo documento

La finestra di dialogo Nuovo documento visualizza tutti i tipi di file supportati, compresi PHP, XML e SVG.

Da questa finestra di dialogo potete inoltre accedere a layout, modelli e framework predefiniti.

Nota:

tutti i layout campione presentati sono creati per supportare i siti Web reattivi e sono conformi allo standard HTML 5.

Creare un layout HTML utilizzando una pagina vuota

Potete creare pagine contenenti un layout CSS predefinito, oppure creare pagine completamente vuote in cui utilizzare un layout personalizzato.

  1. Selezionate File > Nuovo.

  2. Nella categoria Nuovo documento, selezionate il tipo di pagina che desiderate creare dalla colonna Tipo di documento. Ad esempio, selezionate HTML per creare una pagina HTML semplice.

  3. Selezionate un tipo di documento dal menu a comparsa DocType. Nella maggior parte dei casi, potete utilizzare la selezione predefinita, HTML5..

  4. Selezionate altre opzioni in base al tipo di pagina che desiderate creare.

    • Nessuna: selezionate questa opzione per creare una pagina Web semplice senza utilizzare nessun framework.
    • Bootstrap: i modelli Bootstrap sono layout predefiniti che utilizzando il framework Bootstrap. Selezionate questa opzione per creare pagine Web reattive utilizzando il framework Bootstrap.

    Nota:

    se prevedete di creare pagine Web reattive, selezionate il framework Bootstrap.

  5. Se non utilizzate un framework, allora:

    • Titolo del documento: immettete in questo campo il titolo del documento; Dreamweaver lo aggiungerà automaticamente alla sezione <head> del documento.
    • Tipo di documento: selezionate un tipo di documento dal menu a comparsa DocType. Nella maggior parte dei casi, potete utilizzare la selezione predefinita, HTML5.

    Selezionate una delle definizioni di tipo di documento XHTML dal menu Tipo di documento per fare in modo che le pagine siano conformi alle specifiche XHTML. Ad esempio, potete rendere un documento HTML compatibile con la specifica XHTML selezionando XHTML 1.0 Transitional o XHTML 1.0 Strict dal menu. Il linguaggio XHTML (Extensible Hypertext Markup Language) è una riformulazione del linguaggio HTML come applicazione XML. In generale, il linguaggio XHTML offre i vantaggi del linguaggio XML, garantendo una compatibilità dei documenti Web sia con versioni successive che precedenti.

    Nota:

    per ulteriori informazioni su XHTML, consultate il sito Web del World Wide Web Consortium (W3C), che contiene le specifiche di XHTML 1.1 - Module-Based XHTML (www.w3.org/TR/xhtml11/) e XHTML 1.0 (www.w3c.org/TR/xhtml1/), oltre ai siti di convalida XHTML per i file basati su Web (http://validator.w3.org/) e i file locali (http://validator.w3.org/file-upload.html).

    • Associa CSS: associate un layout CSS esistente alla pagina. A questo scopo, fate clic sull'icona Associa foglio di stile  accanto al riquadro Associa file CSS e selezionate un foglio di stile CSS.
    Creare una nuova pagina HTML senza utilizzare a un framework
    Creare una nuova pagina HTML senza utilizzare a un framework

    Per creare una nuova pagina basata sulla composizione Photoshop, selezionate Usa Extract per creare la pagina dalle composizioni in Photoshop. 

    La selezione di questa opzione consente di aprire il pannello Extract in cui potete caricare un file PSD e iniziare a creare la pagina HTML.

  6. Per creare una pagina Web reattiva utilizzando il framework Bootstrap, allora:

    • CSS Bootstrap: scegliete di creare un nuovo CSS Bootstrap, oppure utilizzate un file CSS esistente. Se utilizzate un file CSS esistente, inserite il percorso del file. Verificate che il file CSS sia all'interno della cartella principale del sito.
    • Associa CSS: associate un layout CSS esistente alla pagina. A questo scopo, fate clic sull'icona Associa foglio di stile  accanto al riquadro Associa file CSS e selezionate un foglio di stile CSS.
    • Includi un layout predefinito: selezionate questa opzione se disponete già di un layout. Fate clic su Personalizza per modificare i valori della griglia e dei punti di interruzione.
    Creare una nuova pagina HTML con il framework Bootstrap
    Creare una nuova pagina HTML con il framework Bootstrap

    Per creare una nuova pagina basata sulla composizione Photoshop, selezionate Usa Extract per creare la pagina dalle composizioni in Photoshop. 

    La selezione di questa opzione consente di aprire il pannello Extract in cui potete caricare un file PSD e iniziare a creare la pagina HTML.

  7. Fate clic su Preferenze per impostare le preferenze predefinite per i documenti, quali il tipo di documento, la codifica e l'estensione dei file.

  8. Fate clic sul pulsante Crea.

  9. Salvate il nuovo documento (File > Salva).

  10. Nella finestra di dialogo visualizzata, scorrere fino alla cartella nella quale desiderate salvare il file.

    Nota:

    è opportuno salvare il file in un sito Dreamweaver.

  11. Nella casella Nome file, digitate il nome del file.

    Evitate di inserire spazi e caratteri speciali nel nome dei file e delle cartelle e di iniziare un nome file con un numerale. In particolare, non utilizzate caratteri speciali (ad esempio é, ç o ¥) o segni di interpunzione (come punto e virgola, barre o punti) nei nomi dei file che prevedete di caricare sul server remoto, poiché molti server cambiano questi caratteri al momento del caricamento, causando l'interruzione dei collegamenti ai file.

Creare un modello vuoto

La finestra di dialogo Nuovo documento può essere utilizzata per creare modelli di Dreamweaver. Per impostazione predefinita, i modelli vengono salvati nella cartella Templates del sito.

Nota:

se non create prima un sito, non sarà possibile creare un modello. Per informazioni sui siti e su come creare un sito, consultate Siti di Dreamweaver.

  1. Selezionate File > Nuovo.

  2. Nella finestra di dialogo Nuovo documento, selezionate la categoria Modelli sito.

  3. Selezionate un tipo di documento dal menu a comparsa DocType. Nella maggior parte dei casi, può essere necessario lasciare selezionata l'impostazione predefinita, XHTML 1.0 Transitional.

    Selezionate una delle definizioni di tipo di documento XHTML dal menu DocType (DTD) per fare in modo che le pagine siano conformi alle specifiche XHTML. Ad esempio, potete rendere un documento HTML compatibile con la specifica XHTML selezionando XHTML 1.0 Transitional o XHTML 1.0 Strict dal menu. Il linguaggio XHTML (Extensible Hypertext Markup Language) è una riformulazione del linguaggio HTML come applicazione XML. In generale, il linguaggio XHTML offre i vantaggi del linguaggio XML, garantendo una compatibilità dei documenti Web sia con versioni successive che precedenti.

    Nota:

    per ulteriori informazioni su XHTML, consultate il sito Web del World Wide Web Consortium (W3C), che contiene le specifiche di XHTML 1.1 - Module-Based XHTML (www.w3.org/TR/xhtml11/) e XHTML 1.0 (www.w3c.org/TR/xhtml1/), oltre ai siti di convalida XHTML per i file basati su Web (http://validator.w3.org/) e i file locali (http://validator.w3.org/file-upload.html).

  4. Selezionate Aggiorna la pagina quando il modello cambia per aggiornare automaticamente la pagina quando modificate il modello.

  5. Fate clic sul pulsante Crea.

  6. Salvate il nuovo documento (File > Salva). Qualora al modello non siano ancora state aggiunte aree modificabili, verrà visualizzata una finestra di dialogo che indica che all'interno del documento non sono presenti aree modificabili. Per chiudere la finestra di dialogo, fate clic su OK.

  7. Nella finestra di dialogo Salva con nome, selezionate un sito in cui salvare il modello.
  8. Nella casella Nome file, digitate il nome del nuovo modello. Non è necessario aggiungere l'estensione del file al nome del modello. Quando fate clic su Salva, l'estensione .dwt viene aggiunta automaticamente al nome del nuovo modello, il quale viene salvato nella cartella Templates del sito.

    Evitate di inserire spazi e caratteri speciali nel nome dei file e delle cartelle e di iniziare un nome file con un numerale. In particolare, non utilizzate caratteri speciali (ad esempio é, ç o ¥) o segni di interpunzione (come punto e virgola, barre o punti) nei nomi dei file che prevedete di caricare sul server remoto, poiché molti server cambiano questi caratteri al momento del caricamento, causando l'interruzione dei collegamenti ai file.

Creare una pagina basata su un modello

Potete selezionare, visualizzare in anteprima e creare un nuovo documento utilizzando uno dei modelli esistenti o i modelli per iniziare di Dreamweaver. Potete utilizzare la finestra di dialogo Nuovo documento per selezionare un modello da uno qualsiasi dei siti definiti in Dreamweaver, oppure utilizzare il pannello Risorse per creare un nuovo documento da un modello esistente.

Creare un documento in base a un modello

  1. Selezionate File > Nuovo.

  2. Nella finestra di dialogo Nuovo documento, selezionate la categoria Pagina da modello.

  3. Nella colonna Sito, selezionate il sito Dreamweaver contenente il modello che desiderate utilizzare, quindi selezionate un modello dall'elenco a destra.

  4. Deselezionate l'opzione Aggiorna la pagina quando il modello cambia se non desiderate aggiornare la pagina corrente ogni volta che vengono effettuate modifiche nel modello su cui essa è basata.

  5. Fate clic su Preferenze per impostare le preferenze predefinite per i documenti, quali il tipo di documento, la codifica e l'estensione dei file.

  6. Fate clic su Scarica altro contenuto per aprire Dreamweaver Exchange, dove potete scaricare altro contenuto relativo alle strutture di pagina.

  7. Fate clic su Crea e salvate il documento (File > Salva).

Creare un documento in base a un modello nel pannello Risorse

  1. Se non è già aperto, aprite il pannello Risorse (Finestra > Risorse).

  2. Nel pannello Risorse, fate clic sull'icona Modelli a sinistra per visualizzare l'elenco dei modelli del sito corrente.

    Nota:

    Se il modello che desiderate applicare è appena stato creato, potrebbe essere necessario fare clic sul pulsante Aggiorna per visualizzarlo.

  3. Fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) sul modello che desiderate applicare, quindi selezionate Nuovo da modello.

    Il documento viene aperto nella finestra del documento.

  4. Salvate il documento.

Creare una pagina basata su un modello per iniziare di Dreamweaver

Dreamweaver viene fornito con vari file per iniziare professionali per applicazioni per dispositivi mobili. Questi file di esempio possono essere impiegati come punto di partenza per la creazione di pagine da inserire nei propri siti.

Quando create un documento basato su un modello per iniziare, Dreamweaver crea una copia del file per non sovrascriverlo.

Potete visualizzare in anteprima un file di esempio e leggere una breve descrizione di un elemento di struttura del documento nella finestra di dialogo Nuovo documento.

  1. Selezionate File > Nuovo.

  2. Nella finestra di dialogo Nuovo documento, selezionate la categoria Modelli per iniziare.

    Modelli per iniziare in Dreamweaver
    Modelli per iniziare in Dreamweaver

    Potete visualizzare i dettagli della pagina di esempio e la visualizzazione a destra del pannello durante la selezione delle diverse opzioni.

  3. Fate clic sul pulsante Crea.

    Il nuovo documento e i file correlati si aprono nella finestra Documento.

  4. Salvate il documento (File > Salva).

Creare nuovi file di codice per linguaggi di codifica diversi

In Dreamweaver potete creare file di codice per diversi linguaggi di codifica.

Per ulteriori informazioni sul supporto per la codifica in Dreamweaver, consultate Codice in Dreamweaver.

Per creare un nuovo file di codice in Dreamweaver, attenetevi alle seguenti istruzioni:

  1. Selezionate File > Nuovo documento.

  2. Da Tipo di documento, selezionate il file di codice da creare.

  3. Selezionate il tipo di documento da creare nella colonna Tipo di documento (ad esempio, un file PHP).

    Creazione di una nuova pagina PHP
    Creazione di una nuova pagina PHP

  4. A seconda del tipo di file selezionato, saranno disponibili altre opzioni durante la creazione del documento. 

    Ad esempio, se state creando un file PHP, potete selezionare le opzioni DocType e alcune opzioni CSS.

  5. Fate clic sul pulsante Crea. Salvate quindi il documento (File > Salva).

Salvare e ripristinare i documenti

Potete salvare un documento utilizzando la sua posizione e il suo nome corrente oppure salvare una copia di un documento utilizzando una posizione e un nome diversi.

Nota:

quando assegnate un nome a un file, evitate l'uso di spazi e caratteri speciali nei nomi di file e di cartella. In particolare, non utilizzate caratteri speciali (ad esempio é, ç o ¥) o segni di interpunzione (come punto e virgola, barre o punti) nei nomi dei file che prevedete di caricare sul server remoto, poiché molti server cambiano questi caratteri al momento del caricamento, causando l'interruzione dei collegamenti ai file. Inoltre, evitate di iniziare un nome di file con un carattere numerico.

Salvare un documento

  1. Effettuate una delle operazioni seguenti:
    • Per sovrascrivere la versione corrente sul disco e salvare le modifiche apportate, selezionate File > Salva.
    • Per salvare il file in una cartella diversa o utilizzare un nome diverso, selezionate File > Salva con nome.
  2. Nella finestra di dialogo Salva con nome visualizzata, scorrete fino alla cartella nella quale desiderate salvare il file.
  3. Nella casella di testo Nome file, digitate un nome per il file.

  4. Fate clic su Salva per salvare il file.

Salvare tutti i documenti aperti

  1. Selezionate File > Salva tutto.

  2. In presenza di documenti aperti non salvati, per ognuno viene visualizzata la finestra di dialogo Salva con nome.

    Nella finestra di dialogo visualizzata, scorrere fino alla cartella nella quale desiderate salvare il file.

  3. Nella casella Nome file, digitate un nome per il file e fate clic su Salva.

Ripristinare l'ultima versione salvata di un documento

  1. Selezionate File > Ripristina.

    Una finestra di dialogo chiede se desiderate annullare le modifiche apportate e ripristinare la versione salvata precedentemente.

  2. Fate clic su per ripristinare la versione precedente oppure su No per conservare le modifiche.

    Nota:

    se salvate un documento e successivamente chiudete Dreamweaver, non potete ripristinare la versione precedente del documento quando riavviate Dreamweaver.

Impostare il tipo di documento e della codifica preferenze

Se la maggior parte delle pagine del sito appartiene a un determinato tipo di file, ad esempio HTML, PHP o JavaScript, potete impostare le preferenze del documento in modo che vengano creati nuovi documenti di quello specifico tipo di file.

  1. Selezionate Modifica > Preferenze (Windows) o Dreamweaver > Preferenze (Macintosh).

    Nota:

    potete inoltre fare clic sul pulsante Preferenze nella finestra di dialogo Nuovo documento per impostare le preferenze di un nuovo documento quando create un nuovo documento.

  2. Fate clic su Nuovo documento dall'elenco Categoria a sinistra.

  3. Impostate o modificate le preferenze in base alle vostre necessità e fate clic su OK per salvarle.

    Documento predefinito

    Selezionate un tipo di documento che verrà utilizzato per le nuove pagine create.

    Estensione predefinita

    Specificate l'estensione di file preferita (.htm o .html) per le nuove pagine HTML che create.

    Nota: questa opzione è disabilitata per gli altri tipi di file.

    Tipo di documento predefinito (DTD)

    Selezionate uno dei DTD (Document Type Definition) XHTML per fare in modo che le pagine siano conformi alle specifiche XHTML. Ad esempio, potete rendere un documento HTML compatibile con la specifica XHTML selezionando XHTML 1.0 Transitional o XHTML 1.0 Strict dal menu.

    Codifica predefinita

    Indica il tipo di codifica da utilizzare quando si crea una nuova pagina o quando si apre un documento che non specifica alcun tipo di codifica.

    Se selezionate Unicode (UTF-8) come codifica dei documenti, la codifica delle entità non è necessaria in quanto UTF-8 può rappresentare tutti i caratteri senza problemi. Se selezionate un'altra codifica per i documenti, la codifica delle entità può essere necessaria per rappresentare determinati caratteri. Per ulteriori informazioni sulle entità caratteri, consultate www.w3.org/TR/REC-html40/sgml/entities.html.

    Se selezionate Unicode (UTF-8) come codifica predefinita, potete includere un BOM (Byte Order Mark) nel documento selezionando l'opzione Includi firma Unicode (BOM).

    Una firma BOM contiene da 2 a 4 byte inseriti all'inizio di un file di testo e identifica il file come Unicode, definendo anche l'ordine dei byte successivi. Poiché il formato UTF-8 non prevede un ordine byte, l'aggiunta di una firma BOM UTF-8 è opzionale, mentre è obbligatoria per UTF-16 e UTF-32.

    Modulo di normalizzazione Unicode

    Selezionate una di queste opzioni se avete selezionato anche l'opzione Unicode (UTF-8) come codifica predefinita.

    Esistono quattro moduli di normalizzazione Unicode, il più importante dei quali è il modulo C perché è il più utilizzato nel Modello caratteri del World Wide Web. Adobe mette a disposizione anche gli altri tre moduli di normalizzazione Unicode, per completezza.

    Mostra finestra di dialogo Nuovo documento se viene premuto Ctrl+N

    Deselezionate questa opzione (che in Macintosh si chiama Mostra finestra di dialogo Nuovo documento se viene premuto Comando+N) per creare automaticamente, ogni volta che utilizzate questa combinazione di tasti, un nuovo documento del tipo predefinito.

    In Unicode, alcuni caratteri sono visivamente simili ma possono essere memorizzati nel documento in modi diversi. Ad esempio, la “ë” (e con umlaut) può essere rappresentata come carattere singolo (“e-umlaut”) o come carattere doppio (“e Latin standard” + “umlaut combinato”). Un carattere combinato Unicode è un carattere che viene utilizzato in coppia con il carattere precedente, in modo che, ad esempio, l'umlaut appaia sopra la “e Latin”. Entrambi i formati producono lo stesso risultato visivo, ma i dati salvati nel file sono diversi.

    Il processo di normalizzazione assicura che tutti i caratteri che possono essere memorizzati in formati diversi vengano salvati nello stesso formato, ad esempio, che tutti i caratteri “ë” di un documento vengano salvati come “e-umlaut” oppure come “e” + “umlaut combinato”, ma non in entrambi i formati.

    Per ulteriori informazioni sulla normalizzazione Unicode e sui formati specifici che possono essere utilizzati, visitate il sito Web Unicode all'indirizzo www.unicode.org/reports/tr15.

Aprire e modificare documenti esistenti

Potete aprire una pagina Web esistente o un documento di testo, anche se non è stato creato in Dreamweaver, e modificarlo in vista Progettazione o in vista Codice.

Se il documento che si apre è un file di Microsoft Word che è stato salvato come documento HTML, occorre utilizzare il comando Strumenti > Ottimizza HTML di Word per eliminare i tag estranei inseriti nei file HTML da Word.

Per ottimizzare i file HTML o XHTML che non sono stati creati con Microsoft Word, utilizzate il comando Strumenti > Ottimizza HTML. Per ulteriori informazioni, consultate Ottimizzare il codice HTML di Microsoft Word.

Inoltre, potete aprire i file di testo non HTML, come i file JavaScript, i file XML, i fogli di stile CSS o i file di testo salvati con programmi di elaborazione o editor di testi.

  1. Selezionate File > Apri.

    Nota:

    potete anche utilizzare il pannello File per aprire i file.

  2. Scorrete fino al file da aprire e selezionatelo.

    Nota:

    se l'operazione non è già stata eseguita, è opportuno organizzare i file da aprire e modificare in un sito Dreamweaver, invece di aprirli da un'altra posizione. Per ulteriori informazioni sui siti Dreamweaver, consultate Siti di Dreamweaver.

  3. Fate clic su Apri.

    Il documento viene aperto nella finestra del documento. Per impostazione predefinita, i file JavaScript, di testo e i fogli di stile CSS vengono visualizzati nella vista Codice. Potete aggiornare il documento mentre lavorate con Dreamweaver e salvare le modifiche apportate ai file.

Dreamweaver consente di visualizzare file correlati al documento principale, senza perdere lo stato attivo del documento principale. Se, ad esempio, al documento principale sono collegati file CSS e JavaScript, Dreamweaver consente di visualizzare e modificare questi file correlati nella finestra del documento mantenendo visibile il documento principale.

Per informazioni sui file correlati dinamici, consultate Aprire i file correlati dinamicamente.

Nota:

quando lavorate con file HTML e desiderate apportare modifiche rapide ai file CSS, JavaScript o PHP correlati senza dover accedere a tale file, potete utilizzare Modifica rapida. Per ulteriori informazioni, consultate Modifica rapida.

Per impostazione predefinita, Dreamweaver visualizza i nomi di tutti i file correlati a un documento principale in una barra degli strumenti File correlati posta sotto il titolo del documento principale. L'ordine dei pulsanti nella barra degli strumenti corrisponde all'ordine dei collegamenti dei file correlati presenti nel documento principale.

Nota:

se un file correlato è assente, Dreamweaver visualizzerà comunque il pulsante corrispondente nella barra degli strumenti File correlati. Se tuttavia fate clic su quel pulsante, non verrà visualizzato alcun file.

Dreamweaver supporta i seguenti tipi di file correlati:

  • File di script client-side
  • Server Side Include
  • Fogli di stile CSS esterni (inclusi i fogli di stile nidificati)

Effettuate una delle operazioni seguenti:

  • Nella barra degli strumenti File correlati presente nella parte superiore del documento, fate clic sul nome del file correlato che desiderate aprire.

  • Nella barra degli strumenti File correlati, fate clic con il pulsante destro del mouse sul nome del file correlato che desiderate aprire e selezionate Apri come file separato dal menu di scelta rapida. Quando aprite un file correlato con questo metodo, il documento principale non rimane visibile contemporaneamente.

  1. Posizionate il punto di inserimento su una riga o in un'area interessata da un file correlato.

  2. Attendete la visualizzazione dell'indicatore di Navigazione codice, quindi fate clic sull'indicatore per aprire Navigazione codice.

  3. Posizionate il cursore sugli elementi presenti in Navigazione codice per visualizzare ulteriori informazioni. Se, ad esempio, desiderate modificare una particolare proprietà di colore CSS, ma non conoscete la regola che contiene tale proprietà, potete individuarla passando il cursore sopra le regole disponibili in Navigazione codice.

  4. Fate clic sull'elemento a cui siete interessati per aprire il file correlato corrispondente.

Ritornare al codice di origine del documento principale

  1. Fate clic sul pulsante Codice di origine nella barra degli strumenti File correlati.

Quando aprite un file correlato dalla vista Progettazione o dalle viste Codice e Progettazione (vista combinata), il file correlato viene visualizzato nella vista Dividi.

Potete selezionare Visualizza > Dividi e scegliere tra le diverse opzioni della vista Dividi per personalizzarla.

Se desiderate visualizzare i file correlati solo nella vista codice, nella parte superiore della barra degli strumenti selezionate Codice.

Nota:

la vista Codice standard non consente di visualizzare i documenti correlati contemporaneamente al codice di origine del documento principale.

Nota:

il termine “Vista Codice” nell'opzione di visualizzazione si riferisce al codice di origine del documento principale. Se, ad esempio, selezionate Visualizza > Vista Codice in alto, il codice di origine del documento principale viene visualizzato nella metà superiore della finestra del documento. Se selezionate Visualizza > Vista Codice a sinistra, il codice di origine del documento principale viene visualizzato nel lato sinistro della finestra del documento.

Per impostazione predefinita, quando aprite un file HTML, Dreamweaver visualizza i file correlati in schede separate. Questa funzionalità può essere disabilitata nel pannello Preferenze.

  1. Selezionate Modifica > Preferenze (Windows) o Dreamweaver > Preferenze (Macintosh).

  2. Nella categoria Generale, deselezionate Attiva file correlati.

La funzione File correlati dinamicamente estende la funzionalità della funzione File correlati consentendovi di vedere i file correlati delle pagine dinamiche nella barra degli strumenti File correlati. Specificamente, la funzione File correlati dinamicamente permette di visualizzare le numerose include dinamiche che sono necessarie per generare il codice runtime per i più diffusi framework CMS (Content Management System) PHP open source, quali WordPress, Drupal e Joomla!

Per utilizzare la funzione File correlati dinamicamente dovete avere accesso a un server applicazioni PHM locale o remoto sul quale sia in esecuzione WordPress, Drupal o Joomla! Uno dei metodi più comuni per eseguire il testing delle pagine prevede la configurazione di un server applicazioni PHP localhost e il test locale delle pagine.

Prima di testare le pagine, dovete effettuare le operazioni seguenti:

  • Configurate un sito Dreamweaver, compilando la casella di testo URL web della finestra di dialogo Configurazione sito.

  • Configurate un server applicazioni PHP.

    Nota: il server deve essere già in esecuzione affinché possiate lavorare con i file correlati dinamicamente in Dreamweaver.

  • Installate WordPress, Drupal o Joomla! sul server applicazioni. Per ulteriori informazioni, consultate:

  • In Dreamweaver, definite una cartella locale per il download e la modifica dei file CMS.

  • Definite la posizione dei file WordPress, Drupal o Joomla installati come cartella remota e di prova.

  • Scaricate (get) i file CMS dalla cartella remota.

Quando aprite una pagina associata a file correlati dinamicamente, Dreamweaver è in grado di individuare automaticamente i file, oppure potete individuarli manualmente (facendo clic su un collegamento nella barra Informazioni sopra la pagina). L'impostazione predefinita prevede l'individuazione manuale.

  1. Scegliete Modifica > Preferenze (Windows) o Dreamweaver > Preferenze (Mac OS).

  2. Nella categoria Generali, verificate che l'opzione Attiva file correlati sia selezionata.

  3. Selezionate Manualmente o Automaticamente dal menu a comparsa File correlati dinamicamente. Potete anche scegliere di selezionare Disabilitato per disattivare completamente l'individuazione dei file correlati dinamicamente.

  1. Aprite una pagina alla quale sono associati dei file correlati dinamicamente, ad esempio la pagina index.php nella cartella principale di un sitoWordPress, Drupal o Joomla!.

  2. Se l'individuazione dei file correlati dinamicamente è impostata su Manualmente (impostazione predefinita), fate clic sul collegamento Individua nella barra Informazioni visualizzata sopra la pagina nella finestra del documento.

    Se invece l'individuazione è impostata su Automaticamente, nella barra degli strumenti File correlati viene visualizzato l'elenco dei file correlati dinamicamente.

L'ordine dei file correlati e correlati dinamicamente all'interno nella barra degli strumenti File correlati è il seguente:

  • File correlati statici (file che non richiedono alcun tipo di elaborazione dinamica)
  • File correlati esterni (file .css e .js) associati a file di include server con percorso dinamico
  • File di include server con percorso dinamico (file .php, .inc e .module)

Poiché spesso i file correlati e i file correlati dinamicamente sono presenti in numero elevato, Dreamweaver permette di filtrarli in modo da individuare con precisione quelli sui quali volete lavorare.

  1. Aprite una pagina alla quale sono associati dei file correlati.

  2. Individuate i file correlati dinamicamente, se necessario.

  3. Fate clic su sull'icona Filtra file correlati sul lato destro della barra degli strumenti File correlati.

  4. Selezionate i tipi di file che volete visualizzare nella barra degli strumenti File correlati. Per impostazione predefinita, Dreamweaver seleziona tutti i file correlati.

  5. Per creare un filtro personalizzato, fate clic sull'icona Filtra file correlati e scegliete Filtro personalizzato.

    La finestra di dialogo Filtro personalizzato permette di filtrare solo nomi di file esatti (style.css), estensioni di file (.php) o espressioni con caratteri jolly contenenti asterischi (*menu*). Potete filtrare più espressioni con caratteri jolly separandole con il carattere di punto e virgola (ad esempio: style.css;*.js;*tpl.php).

Nota:

una volta chiuso il file, le impostazioni del filtro non vengono salvate.

Ottimizzare il codice HTML di Microsoft Word

Potete aprire documenti salvati in Microsoft Word (Microsoft Word 97 e versioni successive) come file HTML e utilizzare il comando Ottimizza HTML di Word per eliminare il codice HTML estraneo generato da Word.

Il codice eliminato da Dreamweaver è costituito principalmente da elementi per la formattazione e la visualizzazione dei documenti in Word e non è attualmente necessario per la visualizzazione dei file HTML.

Conservate una copia del documento Word (.doc) originale, poiché dopo aver ottimizzato il file HTML l'apertura del documento HTML in Word potrebbe non essere più possibile.

Nota:

per ottimizzare i file HTML o XHTML che non sono stati creati con Microsoft Word, utilizzate il comando Strumenti > Ottimizza HTML.

  1. Salvate il documento Microsoft Word come file HTML.

    Nota:

    in Windows, chiudete il file in Word per evitare una violazione di condivisione.

  2. Aprite il file HTML in Dreamweaver.

    Per visualizzare il codice HTML generato da Word, passate alla vista Codice (Visualizza > Codice).

  3. Selezionate Strumenti > Ottimizza HTML di Word.

    Nota:

    se Dreamweaver non è in grado di determinare quale versione di Word è stata utilizzata per salvare il file, selezionate la versione corretta nell'apposito menu a comparsa.

  4. Selezionate (o deselezionate) le opzioni di ottimizzazione. Le preferenze specificate vengono salvate come impostazioni di ottimizzazione predefinite.

    Dreamweaver applica al documento HTML le impostazioni di ottimizzazione e viene visualizzato un registro con le modifiche, a meno non abbiate deselezionato l'opzione corrispondente nella finestra di dialogo.

    Opzioni di ottimizzazione del codice HTML di Microsoft Word
    Opzioni di ottimizzazione del codice HTML di Microsoft Word

    Elimina tag specifici di Word

    Consente di eliminare tutti i tag specifici di Microsoft Word, compreso il codice XML dei tag HTML, i tag meta e link personalizzati dell'intestazione del documento, i tag XML di Word, i tag condizionali e il loro contenuto, nonché i paragrafi vuoti e i margini dagli stili. Ognuno dei tipi di tag citati può essere selezionato individualmente utilizzando la scheda Avanzate.

    Ottimizza CSS

    Elimina tutti gli stili CSS specifici di Word, compresi gli stili CSS in linea se possibile (quando lo stile principale è contraddistinto dalle stesse proprietà), gli attributi di stile che iniziano per “mso”, le dichiarazioni di stile non CSS, gli attributi di stile CSS contenuti nelle tabelle e tutte le definizioni di stile non utilizzate nell'intestazione. Questa opzione può essere ulteriormente personalizzata utilizzando la scheda Avanzate.

    Ottimizza tag <font>

    Rimuove i tag HTML, convertendo il testo principale predefinito alla dimensione HTML 2.

    Correggi tag nidificati in modo errato

    Rimuove i tag dei caratteri inseriti da Word all'esterno dei tag di paragrafo e di intestazione (a livello di blocco).

    Applica formattazione di origine

    Applica al documento le opzioni di formattazione dell'origine specificate nelle preferenze Formato HTML e nel file SourceFormat.txt.

    Mostra registro al termine

    Visualizza una finestra di avvertimento che segnala le modifiche apportate al documento al termine del processo di ottimizzazione.

  5. Fate clic su OK oppure fate clic sulla scheda Avanzate per personalizzare ulteriormente le opzioni Elimina tag specifici di Word e Ottimizza CSS, quindi fate clic su OK.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online