Inserire e modificare oggetti multimediali nelle pagine web di Dreamweaver, utilizzare Design Notes e altro ancora.

In un documento Dreamweaver, oltre ai file SWF e FLV, potete inserire altri oggetti audio o video. Se avete inserito attributi di accessibilità con un oggetto multimediale, potete impostare tali attributi e modificarne i valori nel codice HTML.

  1. Nella finestra del documento, spostate il cursore nella posizione in cui desiderate inserire l'oggetto.
  2. Inserite l'oggetto effettuando una delle seguenti operazioni:
    • Nella categoria HTML del pannello Inserisci, selezionate l'icona relativa al tipo di oggetto che desiderate inserire.

    • Selezionate l'oggetto appropriato dal sottomenu Inserisci > HTML.

    • Viene visualizzata una finestra di dialogo che consente di selezionare un file di origine e specificare alcuni parametri dell'oggetto multimediale.

    Nota:

    per disattivare la visualizzazione di tali finestre, selezionate Modifica > Preferenze > Generali (Windows) o Dreamweaver > Preferenze > Generali (Macintosh) e deselezionate l'opzione Mostra finestra di dialogo per inserimento oggetti. Per ignorare la preferenza impostata per la visualizzazione delle finestre di dialogo, tenete premuto il tasto Ctrl (Windows) oppure Opzione (Macintosh) durante l'operazione di inserimento. 

  3. Impostate le opzioni della finestra di dialogo Seleziona file e fate clic su OK.

    Nota:

    la finestra di dialogo Attributi di accessibilità viene visualizzata se avete specificato di visualizzare gli attributi durante l'inserimento di oggetti multimediali nella finestra di dialogo Modifica > Preferenze.

  4. Impostate gli attributi di accessibilità.

    Nota:

    è anche possibile modificare gli attributi di un oggetto multimediale selezionando l'oggetto e modificando il codice HTML in vista Codice, oppure facendo clic con il pulsante destro del mouse (Windows) o tenendo premuto il tasto Ctrl (Macintosh) e selezionando Modifica codice tag.

    Titolo

    Inserite un titolo per l'oggetto multimediale.

    Chiave di accesso

    Nella casella di testo, inserite un equivalente da tastiera (una lettera) per selezionare l'oggetto nel browser. Questo consente a un visitatore del sito di utilizzare il tasto Ctrl (Windows) con la chiave di accesso per accedere all'oggetto. Se ad esempio inserite B come Chiave di accesso, utilizzate la combinazione Ctrl+B per selezionare l'oggetto nel browser.

    Indice tabulazione

    Inserite un numero per l'ordine di tabulazione dell'oggetto. L'impostazione dell'ordine delle tabulazioni risulta utile quando la pagina contiene più collegamenti e oggetti modulo che consentono all'utente di utilizzare il tasto Tab per passare da un oggetto all'altro secondo un ordine preciso. Se impostate l'ordine di tabulazione di un oggetto, accertatevi di averne applicato uno a ciascun oggetto.

  5. Fate clic su OK per inserire l'oggetto multimediale.

    Nota:

    se fate clic su Annulla, nel documento viene visualizzato un segnaposto dell'oggetto multimediale ma Dreamweaver non associa i relativi tag o attributi di accessibilità.

    Per specificare il file di origine o per impostare le dimensioni e gli altri parametri e attributi, usate la finestra di ispezione Proprietà per ogni singolo oggetto. Potete modificare gli attributi di accessibilità di un oggetto.

Avviare un editor esterno per file multimediali

Potete avviare un editor esterno da Dreamweaver per modificare la maggior parte dei file multimediali. È possibile specificare l'editor che Dreamweaver deve avviare per modificare il file.

  1. Accertatevi che il tipo di file multimediale sia associato a un editor sul sistema.

    Per verificare a quale editor è associato il tipo di file, selezionate Modifica > Preferenze in Dreamweaver e selezionate Tipi di file/editor dall'elenco Categoria. Fate clic sull'estensione del file nella colonna Estensioni per visualizzare l'editor o gli editor associati nella colonna Editor. Potete cambiare l'editor associato a un tipo di file.

  2. Fate doppio clic sul file multimediale nel pannello File per aprirlo nell'editor esterno.

    L'editor che viene avviato quando si fa doppio clic sul file nel pannello File viene definito editor principale. Se, ad esempio, fate doppio clic su un file di immagine, Dreamweaver apre il file nell'editor di immagini esterno principale, ad esempio Adobe Fireworks.

  3. Se non desiderate utilizzare l'editor esterno principale per modificare il file, potete utilizzare un altro editor sul sistema effettuando una delle seguenti operazioni:
    • Nel pannello File, fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) sul nome file e selezionate Apri con dal menu di scelta rapida.

    • Nella vista Progettazione, fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) sull'elemento multimediale all'interno della pagina corrente, quindi selezionate Modifica con dal menu di scelta rapida.

Specificare l'editor da avviare da Dreamweaver

È possibile specificare l'editor che Dreamweaver deve avviare per modificare un tipo di file e aggiungere o eliminare i tipi di file riconosciuti da Dreamweaver .

Specificare esplicitamente gli editor esterni da avviare per un determinato tipo di file

  1. Selezionate Modifica > Preferenze e selezionate Tipi di file/editor dall'elenco Categoria.

    Le estensioni dei nomi di file (come .gif, .wav e .mpg) sono elencate a sinistra sotto Estensioni. Gli editor associati a un'estensione selezionata sono elencati a destra sotto Editor.

  2. Selezionate l'estensione del file nell'elenco Estensioni ed effettuate una delle seguenti operazioni:
    • Per associare un nuovo editor al tipo di file, fate clic sul pulsante più (+) sopra l'elenco Editor e impostate la finestra di dialogo che viene visualizzata.

      Ad esempio, selezionate l'icona dell'applicazione affinché Acrobat la associ al tipo di file.

    • Per definire l'editor principale di un tipo di file, ossia l'editor che viene aperto quando fate doppio clic sul tipo di file nel pannello File, selezionate l'editor nell'elenco Editor e fate clic su Rendi principale.

    • Per eliminare l'associazione tra un editor e un tipo di file, selezionate l'editor nell'elenco Editor e fate clic sul pulsante meno (-) sopra l'elenco Editor.

Aggiungere un nuovo tipo di file e l'editor associato

  1. Fate clic sul pulsante più (+) sopra l'elenco Estensioni e inserite un'estensione di file (compreso il punto all'inizio dell'estensione) oppure varie estensioni correlate, separate da spazi.

    Ad esempio, potete inserire .xml .xsl se desiderate associarli a un editor XML installato sul sistema.

  2. Selezionate un editor per il tipo di file facendo clic sul pulsante (+) sopra l'elenco Editor e impostate la finestra di dialogo che viene visualizzata.

Rimuovere un tipo di file

  1. Selezionate il tipo di file nell'elenco Estensioni e fate clic sul pulsante meno (-) sopra l'elenco Estensioni.

    Nota:

    l'operazione di eliminazione non può essere annullata, quindi assicuratevi di aver scelto il tipo di file corretto.

Usare le Design Notes con gli oggetti multimediali

Come per altri oggetti in Dreamweaver, è possibile aggiungere le Design Notes a un oggetto multimediale. Le Design Notes sono delle note associate a un file particolare che vengono memorizzate in un file separato. Le Design Notes consentono di tenere traccia di informazioni aggiuntive sui file associate ai documenti, come i nomi dei file di origine delle immagini e i commenti sullo stato del file.

  1. Fate clic con il pulsante destro (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) sull'oggetto nella finestra del documento.

    Nota:

    per aggiungere le Design Notes a un oggetto, dovete aver già definito un sito.

  2. Dal menu di scelta rapida, selezionate Design Notes.
  3. Inserite le informazioni desiderate nella Design Note.

    Nota:

    un modo alternativo per aggiungere una Design Note a un oggetto multimediale consiste nel selezionare il file nel pannello File, aprire il menu di scelta rapida e scegliere Design Notes.

Aggiungere video (non FLV)

Potete aggiungere oggetti video alla pagina Web con varie procedure e utilizzando vari formati. Gli oggetti video possono essere scaricati sul computer dell'utente o sottoposti a streaming, in modo che vengano eseguiti durante lo scaricamento.

  1. Posizionate il video nella cartella del sito.

    I video brevi sono spesso in formato AVI o MPEG.

  2. Create un collegamento al video o incorporarlo nella pagina.

    Per creare un collegamento al video, inserite il testo per il collegamento, ad esempio “Scarica video”, selezionate il testo e fate clic sull'icona della cartella nella finestra di ispezione Proprietà. Individuate il file video e selezionatelo.

    Nota:

    è necessario che l'utente scarichi un'applicazione dedicata (un plugin) per visualizzare i formati di streaming più comuni come RealMedia, QuickTime e Windows Media.

Inserire il contenuto per un plugin

Potete ad esempio creare un filmato QuickTime come contenuto per un plugin del browser e successivamente utilizzare Dreamweaver per inserire tale contenuto in un documento HTML. RealPlayer e QuickTime sono tra i plugin più diffusi, mentre i file di contenuto possono essere file MP3 o filmati QuickTime.

Potete visualizzare l'anteprima dei filmati e delle animazioni basati sui plugin del browser direttamente nella vista Progettazione della finestra del documento. Potete eseguire contemporaneamente tutti gli elementi multimediali per verificare l'aspetto che avrà la pagina oppure eseguire singolarmente ciascun elemento per accertarvi di aver incorporato l'elemento corretto.

Nota:

non è possibile visualizzare l'anteprima dei filmati e delle animazioni basati sui controlli ActiveX.

Dopo aver inserito il contenuto per un plugin, potete impostarne i parametri utilizzando la finestra di ispezione Proprietà. Per visualizzare le seguenti proprietà nella finestra di ispezione Proprietà, selezionate un oggetto plugin.

Quando viene aperta, la finestra di ispezione Proprietà visualizza le proprietà utilizzate più di frequente. Per vedere tutte le proprietà, fate clic sulla freccia di espansione nell'angolo inferiore destro della finestra.

Inserire contenuto per un plugin e impostarne le proprietà

  1. Nella vista Progettazione della finestra del documento, spostate il punto di inserimento nella posizione in cui desiderate inserire il contenuto, quindi effettuate una delle seguenti operazioni:
    • Nella categoria Comune del pannello Inserisci, fate clic sul pulsante Oggetto multimediale e selezionate l'icona Plugin  dal menu.

    • Selezionate Inserisci > Oggetto multimediale > Plugin.

  2. Nella finestra di dialogo che viene visualizzata, selezionate un file di contenuto per un plugin e fate clic su OK.
  3. Impostate le opzioni del plugin nella finestra di ispezione Proprietà.

    Nome

    Specifica il nome che identifica il plugin per gli script. Inserite un nome nella casella di testo senza nome visualizzata in alto a sinistra (finestra di ispezione Proprietà).

    Larg. e Alt.

    Specificano la larghezza e l'altezza dell'oggetto in pixel nella pagina.

    Orig.

    Specifica il file di dati di origine. Fate clic sull'icona della cartella per individuare il file oppure digitatene il percorso.

    URL

    Specifica l'URL dell'attributo pluginspace. Inserite l'URL completo del sito in cui gli utenti possono scaricare il plugin. Se l'utente che visualizza la pagina non dispone del plugin, il browser cerca di scaricarlo da questo URL.

    Allinea

    Determina il tipo di allineamento dell'oggetto rispetto alla pagina.

    Spazio V e Spazio O

    Specificare i pixel in bianco che devono rimanere al di sopra e al di sotto o a destra e a sinistra del plugin.

    Bordo

    Specifica la larghezza del bordo visualizzato attorno al plugin.

    Parametri

    Apre una finestra di dialogo che consente di inserire parametri aggiuntivi per il plugin. Numerosi plugin supportano parametri speciali.

    Per vedere gli attributi assegnati al plugin selezionato, fate clic sul pulsante Attributo. All'interno della finestra di dialogo visualizzata potete modificare, aggiungere ed eliminare gli attributi (come, ad esempio, larghezza e altezza).

Riprodurre il contenuto del plugin nella finestra del documento

  1. Inserite uno o più elementi multimediali utilizzando uno dei metodi descritti nella sezione precedente.
  2. Effettuate una delle operazioni seguenti:
    • Selezionate uno degli oggetti multimediali inseriti e scegliete Visualizza > Plugin > Esegui oppure fate clic sul pulsante Riproduci della finestra di ispezione Proprietà.

    • Per eseguire tutti gli elementi multimediali della pagina selezionata che utilizzano un plugin, selezionate Visualizza > Plugin > Esegui tutto.

    Nota:

    il comando Esegui tutto si riferisce solamente al documento corrente e non, ad esempio, ad altri documenti di un set di frame.

Interrompere il contenuto del plugin

  1. Selezionate un oggetto multimediale e scegliete Visualizza > Plugin >Interrompi oppure fate clic sul pulsante Interrompi nella finestra di ispezione Proprietà.

    Potete anche selezionare Visualizza > Plugin > Interrompi tutto per interrompere la riproduzione di tutti i contenuti di plugin.

Risoluzione dei problemi dei plugin

Se non riuscite a riprodurre un contenuto di plugin nella finestra del documento, effettuate le seguenti operazioni:

  • Verificate che sul computer in uso sia stato installato il plugin necessario e che la versione del plugin sia compatibile con il contenuto.

  • Aprite il file Configuration/Plugins/UnsupportedPlugins.txt in un editor di testo e verificate se il plugin fa parte dell'elenco. Questo file elenca tutti i plugin che creano problemi in Dreamweaver e che non sono di conseguenza supportati. Se un plugin specifico produce effetti indesiderati in Dreamweaver, è opportuno aggiungerlo a questo file.

  • Verificate di avere una quantità di memoria sufficiente. Alcuni plugin necessitano di 2-5 MB di memoria aggiuntiva per funzionare.

Utilizzo dei comportamenti per controllare gli oggetti multimediali

Potete aggiungere dei comportamenti alla pagina per avviare o interrompere l'esecuzione di vari oggetti multimediali.

Controlla Shockwave o Flash

Riprodurre, interrompere e riavvolgere un filmato Shockwave o un file SWF.

Riproduci suono

Consente di riprodurre un file audio; ad esempio, potete attivare un effetto sonoro ogni volta che un utente porta il cursore sopra un collegamento.

Controlla plugin

Consente di verificare se i visitatori del sito hanno installato il plugin richiesto e di indirizzarli a URL diversi a seconda che il plugin sia presente o meno. Questo comportamento vale solamente per i plugin, non per i controlli ActiveX.

Utilizzare i parametri per controllare gli oggetti multimediali

Definite i parametri speciali per controllare i file SWF e i plugin. I parametri vengono utilizzati con i tag object, embed e applet. I parametri impostano attributi specifici per i diversi tipi di oggetti. Ad esempio, un file SWF può utilizzare un parametro di qualità <paramname="quality"value="best"> per il tag object. La finestra di dialogo Parametro può essere aperta dalla finestra di ispezione Proprietà. Per informazioni sui parametri da impostare, consultate la documentazione relativa all'oggetto utilizzato.

Nota:

non esiste uno standard riconosciuto per l'identificazione dei file di dati dei controlli ActiveX. Per informazioni sul parametro da impostare, consultate la documentazione relativa al controllo ActiveX utilizzato.

Inserire un nome e di un valore per un parametro

  1. Selezionate un oggetto al quale possono essere associati dei parametri nella finestra del documento.

  2. Se non è già aperta, aprite la finestra di ispezione Proprietà e fate clic sul pulsante Parametri nella parte inferiore della finestra di ispezione Proprietà. Verificate che la finestra di ispezione Proprietà sia aperta.

  3. Fate clic sul pulsante più (+) e inserite il nome del parametro e il relativo valore nelle apposite colonne.

Rimuovere un parametro

  1. Selezionate un parametro e premete il pulsante meno (–).

Riordinare i parametri

  1. Selezionate un parametro e utilizzate i pulsanti freccia su e giù.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online