Guida utente Annulla

Eseguire trasformazioni XSL server-side in Dreamweaver

  1. Guida utente di Dreamweaver
  2. Introduzione
    1. Nozioni di base sul design responsive
    2. Novità di Dreamweaver
    3. Sviluppo Web con Dreamweaver - Panoramica
    4. Dreamweaver / Domande frequenti
    5. Scelte rapide da tastiera
    6. Requisiti di sistema di Dreamweaver
    7. Riepilogo delle funzioni
  3. Dreamweaver e Creative Cloud
    1. Sincronizzare le impostazioni di Dreamweaver con Creative Cloud
    2. Creative Cloud Libraries in Dreamweaver
    3. Utilizzare i file Photoshop in Dreamweaver
    4. Operazioni con Adobe Animate e Dreamweaver
    5. Estrarre file SVG ottimizzati per il Web da Libraries
  4. Aree di lavoro e viste di Dreamweaver
    1. Area di lavoro di Dreamweaver
    2. Ottimizzare l'area di lavoro di Dreamweaver per lo sviluppo visivo
    3. Eseguire ricerche nei file in base al nome file o al contenuto | Mac OS
  5. Configurare i siti
    1. Siti di Dreamweaver
    2. Configurare una versione locale del sito
    3. Collegamento a un server di pubblicazione
    4. Configurare un server di prova
    5. Importare ed esportare le impostazioni di un sito Dreamweaver
    6. Passaggio di siti Web esistenti da un server remoto alla cartella principale del sito locale
    7. Funzioni di accessibilità in Dreamweaver
    8. Impostazioni avanzate
    9. Impostazione delle preferenze del sito per il trasferimento dei file
    10. Specificare le Impostazioni del server proxy in Dreamweaver
    11. Sincronizzare le impostazioni di Dreamweaver con Creative Cloud
    12. Utilizzo di Git in Dreamweaver
  6. Gestire i file
    1. Creare e aprire file
    2. Gestire file e cartelle
    3. Scaricamento e caricamento dei file da e verso il server
    4. Depositare e ritirare i file
    5. Sincronizzare i file
    6. Confrontare file per verificare le differenze
    7. Applicare la maschera file a file e cartelle del sito Dreamweaver
    8. Attivare le Design Notes per i siti di Dreamweaver
    9. Impedire un potenziale attacco exploit del Gatekeeper
  7. Layout e progettazione
    1. Usare i riferimenti visivi per il layout
    2. Informazioni sull'utilizzo di CSS per creare il layout della pagina
    3. Progettazione di siti Web reattivi con Bootstrap
    4. Creazione e utilizzo di media query in Dreamweaver
    5. Presentare il contenuto mediante le tabelle
    6. Colori
    7. Responsive design con i layout a griglia fluida
    8. Extract in Dreamweaver
  8. CSS
    1. Nozioni sui fogli di stile CSS
    2. Creazione del layout delle pagine con CSS Designer
    3. Utilizzare i preprocessori CSS in Dreamweaver
    4. Impostare le preferenze di stile CSS in Dreamweaver
    5. Spostare le regole CSS in Dreamweaver
    6. Convertire CSS in linea in una regola CSS in Dreamweaver
    7. Utilizzare i tag div
    8. Applicare sfumature allo sfondo
    9. Creare e modificare effetti di transizione CSS3 in Dreamweaver
    10. Formattazione del codice
  9. Contenuto e risorse delle pagine
    1. Impostare le proprietà di pagina
    2. Impostare le proprietà dei collegamenti CSS e le proprietà dei collegamenti CSS
    3. Lavorare con il testo
    4. Ricercare e sostituire testo, tag e attributi
    5. Pannello DOM
    6. Modifica nella vista Dal vivo
    7. Codifica dei documenti in Dreamweaver
    8. Selezionare e visualizzare gli elementi nella finestra del documento
    9. Definire le proprietà del testo nella finestra di ispezione Proprietà
    10. Eseguire il controllo ortografico di una pagina Web
    11. Utilizzo dei filetti orizzontali in Dreamweaver
    12. Aggiungere e modificare le combinazioni di caratteri in Dreamweaver
    13. Operazioni con le risorse
    14. Inserire e aggiornare le date in Dreamweaver
    15. Creare e gestire le risorse preferite in Dreamweaver
    16. Inserire e modificare le immagini in Dreamweaver
    17. Aggiungere oggetti multimediali
    18. Aggiunta di video in Dreamweaver
    19. Inserire video HTML5
    20. Inserire file SWF
    21. Aggiungere effetti audio
    22. Inserire l'audio HTML5 in Dreamweaver
    23. Operazioni con le voci di libreria
    24. Utilizzare testo in arabo e in ebraico in Dreamweaver
  10. Collegamenti e navigazione
    1. Informazioni sui collegamenti e sulla navigazione
    2. Collegamenti
    3. Mappe immagine
    4. Risoluzione dei problemi di collegamenti
  11. Widget ed effetti jQuery
    1. Utilizzare i widget jQuery UI e Mobile in Dreamweaver
    2. Usare effetti jQuery in Dreamweaver
  12. Programmazione dei siti Web
    1. Programmazione in Dreamweaver
    2. Ambiente di codifica in Dreamweaver
    3. Impostare le preferenze di codifica
    4. Personalizzare la colorazione del codice
    5. Scrivere e modificare codice
    6. Suggerimenti sul codice e completamento del codice
    7. Comprimere ed espandere codice
    8. Riutilizzo del codice con gli snippet
    9. Comando Lint
    10. Ottimizzare il codice
    11. Modificare il codice nella vista Progettazione.
    12. Utilizzo del contenuto dell'intestazione delle pagine
    13. Inserimento di server-side include in Dreamweaver
    14. Uso delle librerie di tag in Dreamweaver
    15. Importazione di tag personalizzati in Dreamweaver
    16. Utilizzare i comportamenti JavaScript (istruzioni generali)
    17. Applicare comportamenti JavaScript incorporati
    18. Informazioni su XML e XSLT
    19. Eseguire trasformazioni XSL server-side in Dreamweaver
    20. Esecuzione di trasformazioni XSL client-side in Dreamweaver
    21. Aggiungere entità di carattere per XSLT in Dreamweaver
    22. Formattazione del codice
  13. Flussi di lavoro di interazione con altri prodotti
    1. Installazione e uso delle estensioni in Dreamweaver
    2. Aggiornamenti in app in Dreamweaver
    3. Inserire documenti Microsoft Office in Dreamweaver (solo Windows)
    4. Operazioni con Fireworks e Dreamweaver
    5. Modificare il contenuto nei siti Dreamweaver mediante Contribute
    6. Integrazione tra Dreamweaver e Business Catalyst
    7. Creare campagne e-mail personalizzate
  14. Modelli
    1. Informazioni sui modelli di Dreamweaver
    2. Riconoscere i modelli e i documenti basati sui modelli
    3. Creare un modello di Dreamweaver
    4. Creare aree modificabili nei modelli
    5. Creare aree e tabelle ripetute nei modelli in Dreamweaver
    6. Usare le aree opzionali nei modelli
    7. Definire attributi di tag modificabili in Dreamweaver
    8. Creare modelli nidificati in Dreamweaver
    9. Modificare, aggiornare ed eliminare modelli
    10. Esportare e importare contenuti xml in Dreamweaver
    11. Applicare o rimuovere un modello da un documento esistente
    12. Modificare il contenuto nei modelli di Dreamweaver
    13. Regole di sintassi per i tag di modello in Dreamweaver
    14. Impostare le preferenze di evidenziazione per le aree dei modelli
    15. Vantaggi dell'uso dei modelli in Dreamweaver
  15. Dispositivi mobili e multischermo
    1. Creare media query
    2. Cambiamento dell'orientamento della pagina per i dispositivi mobili
    3. Creare web app per dispositivi mobili utilizzando Dreamweaver
  16. Siti, pagine e moduli Web dinamici
    1. Applicazioni Web
    2. Configurare il computer per lo sviluppo di applicazioni
    3. Risoluzione dei problemi relativi alle connessioni di database
    4. Rimozione di script di connessione in Dreamweaver
    5. Progettare pagine dinamiche
    6. Panoramica sulle origini di contenuto dinamico
    7. Definire le origini di contenuto dinamico
    8. Aggiungere contenuto dinamico alle pagine
    9. Modifica del contenuto dinamico in Dreamweaver
    10. Visualizzare i record di database
    11. Fornire dati dal vivo e risoluzione dei problemi in Dreamweaver
    12. Aggiungere comportamenti server personalizzati in Dreamweaver
    13. Creazione di moduli con Dreamweaver
    14. Usare moduli per raccogliere informazioni dagli utenti
    15. Creare e attivare i moduli ColdFusion in Dreamweaver
    16. Creare moduli Web
    17. Supporto HTML5 avanzato per gli elementi modulo
    18. Sviluppare un modulo con Dreamweaver
  17. Sviluppo visivo delle applicazioni
    1. Creare pagine principali e di dettaglio in Dreamweaver
    2. Creare pagine di ricerca e di risultati
    3. Creare una pagina di inserimento record
    4. Costruire una pagine di aggiornamento record in Dreamweaver
    5. Costruzione di pagine di eliminazione record in Dreamweaver
    6. Utilizzare comandi ASP per modificare un database in Dreamweaver
    7. Creare una pagina di registrazione
    8. Creare una pagina di login
    9. Creare una pagina accessibile solo agli utenti autorizzati
    10. Protezione delle cartelle in ColdFusion utilizzando Dreamweaver
    11. Utilizzo di componenti ColdFusion in Dreamweaver
  18. Verifica, anteprima e pubblicazione dei siti Web
    1. Anteprima delle pagine
    2. Visualizzare in anteprima pagine web di Dreamweaver su più dispositivi
    3. Verificare il sito Dreamweaver

 

Eseguire trasformazioni XSL server-side in Dreamweaver. Creare pagine XSLT e convertire HTML in pagine XSLT.

Nota:

l'interfaccia utente di Dreamweaver CC e versioni successive è stata semplificata. Di conseguenza, potreste non trovare alcune delle opzioni descritte in questo articolo in Dreamweaver CC e versioni successive. Per ulteriori informazioni, consultate questo articolo.

Flusso di lavoro per l'esecuzione di trasformazioni XSL server-side

Potete eseguire trasformazioni XSL server-side nel server. Prima di creare pagine che visualizzano dati XML, leggere le informazioni sulle trasformazioni XSL server-side e client-side e sull'uso di XML e XSL con le pagine Web.

Nota:

è necessario che il server sia correttamente configurato per effettuare trasformazioni server-side. Per altre informazioni, consultate l'amministratore del server.

Quello che segue è il flusso di lavoro per l'esecuzione di trasformazioni XSL server-side (ciascun passaggio è descritto in altri argomenti):

1.Creare un sito Dreamweaver.

2.Scegliere una tecnologia server e impostare un server applicazioni.

3.Eseguire un test del server applicazioni.

Create ad esempio una pagina che richieda un'elaborazione e assicuratevi che il server applicazioni la esegua.

4.Creare un frammento o una pagina XSLT oppure convertire una pagina HTML in una pagina XSLT.

  • Nel sito Dreamweaver, create un frammento XSLT o una pagina XSLT intera.

  • Convertire una pagina HTML esistente in una pagina XSLT intera.

5.Collegare un'origine dati XML alla pagina.

6.Visualizzare i dati XML associando i dati al frammento XSLT oppure alla pagina XSLT intera.

7.Se necessario, aggiungere un oggetto XSLT Area ripetuta alla tabella o alla riga della tabella contenente i segnaposto per dati XML.

8.Inserire i riferimenti.

  • Per inserire un riferimento al frammento XSLT nella vostra pagina dinamica, utilizzate il comportamento server Trasformazione XSL.

  • Per inserire un riferimento alla pagina XSLT intera nella pagina dinamica, eliminate tutto il codice HTML da una pagina dinamica, quindi utilizzate il comportamento server Trasformazione XSL.

9.Inviare la pagina e il frammento.

Inviate sia la pagina dinamica sia il frammento XSLT (o la pagina XSLT intera) al vostro server applicazioni. Se state utilizzando un file XML locale, è necessario inviare anche quello.

10.Visualizzare la pagina dinamica in un browser.

Quando effettuate questa operazione, il server applicazioni trasforma i dati XML, li inserisce nella pagina dinamica e li visualizza nel browser.

Creare una pagina XSLT

Le pagine XSLT consentono di visualizzare dati XML nelle pagine Web. Potete creare una pagina XSLT intera, ovvero una pagina XSLT che contiene un tag <body> e un tag <head>, oppure un frammento XSLT. Quando si crea un frammento XSLT, viene creato un file indipendente che non contiene i tag body e head; è una semplice sequenza di codice che in seguito viene inserita in una pagina dinamica.

Nota:

se partite da una pagina XSLT esistente, dovete collegare un'origine dati XML.

  1. Selezionate File > Nuovo.
  2. Nella categoria Pagina vuota della finestra di dialogo Nuovo documento, selezionate una delle seguenti voci dalla colonna Tipo di pagina:
    • Selezionate XSLT (pagina intera) per creare una pagina XSLT intera.

    • Selezionate XSLT (frammento) per creare un frammento XSLT.

  3. Fate clic su Crea ed effettuate una delle azioni seguenti nella finestra di dialogo Individua origine XML:
    • Selezionate Associa un file locale, fate clic sul pulsante Sfoglia, individuate un file XML locale sul computer e fate clic su OK.
    • Selezionate Associa un file remoto, inserite l'URL di un file XML su Internet (ad esempio da un feed RSS) e fate clic su OK.
    Nota:

    fate clic sul pulsante Annulla per generare una nuova pagina XSLT con nessuna origine dati XML collegata.

    Il pannello Associazioni viene compilato con lo schema dell'origine dati XML

    Pannello Associazioni

    Nella tabella seguente vengono illustrati i vari elementi dello schema che potrebbe venire visualizzato:

    Elemento

    Rappresenta

    Dettagli

    <>

    Elementi XML necessari non ripetuti

    Elemento che viene visualizzato solo una volta all'interno del nodo di origine

    <>+

    Elemento XML ripetuto

    Elemento che viene visualizzato una o più volte all'interno del nodo di origine

    <>+

    Elemento XML facoltativo

    Elemento che viene visualizzato zero o più volte all'interno del nodo di origine

    Elemento nodo in carattere grassetto

    Elemento di contesto corrente

    Normalmente l'elemento ripetuto quando il punto di inserimento è all'interno di un'area ripetuta

    @

    Attributo XML

     

     

  4. Salvate la nuova pagina (File > Salva) con l'estensione .xsl o .xslt (l'estensione predefinita è .xsl).

Convertire pagine HTML in pagine XSLT

Potete convertire pagine HTML esistenti in pagine XSLT. Ad esempio, se avete una pagina statica predefinita alla quale desiderate aggiungere dati XML, potete convertire la pagina in una pagina XSLT, anziché creare una pagina XSLT e quindi progettarla da zero.

  1. Aprite la pagina HTML da convertire.
  2. Selezionate File > Converti > XSLT 1.0.

    Una copia della pagina viene aperta nella finestra del documento. La nuova pagina è un foglio di stile XSL, salvato con l'estensione .xsl.

Collegare origini dati XML

Se partite da una pagina XSLT esistente o non collegate un'origine dati XML quando create una nuova pagina XSLT con Dreamweaver, dovete collegare un'origine dati XML per mezzo del pannello Associazioni.

  1. Nel pannello Associazioni (Finestra > Associazioni), fate clic sul collegamento XML.
    Nel pannello Associazioni, fate clic su XML

    Nota:

    per aggiungere un'origine dati XML potete anche fare clic sul collegamento Origine nell'angolo superiore destro del pannello Associazioni.

  2. Effettuate una delle operazioni seguenti:
    • Selezionate Associa un file locale, fate clic sul pulsante Sfoglia, individuate un file XML locale sul computer e fate clic su OK.

    • Selezionate Associa un file remoto e inserite l'URL di un file XML su Internet (ad esempio proveniente da un feed RSS).

  3. Fate clic su OK per chiudere la finestra di dialogo Individua origine XML.

    Il pannello Associazioni viene compilato con lo schema dell'origine dati XML.

Visualizzare i dati XML nelle pagine XSLT

Una volta creata una pagina XSLT e collegata un'origine dati XML, potete associare i dati alla pagina. A tale scopo, aggiungete un segnaposto dati XML alla pagina e utilizzate Creazione espressioni XPath oppure la finestra di ispezione Proprietà per formattare i dati selezionati che verranno visualizzati sulla pagina.

  1. Aprite una pagina XSLT con un'origine dati XML collegata.
  2. (Opzionale) Selezionate Inserisci > Tabella per aggiungere una tabella alla pagina. L'uso di una tabella facilita l'organizzazione dei dati XML.
    Nota:

    nella maggior parte dei casi, è utile usare l'oggetto XSLT Area ripetuta per visualizzare elementi XML ripetuti in una pagina. In tali casi può essere opportuno creare una tabella a riga singola con una o più colonne, oppure una tabella a due righe se si vuole includere un'intestazione.

  3. Nel pannello Associazioni, selezionate un elemento XML e trascinatelo nel punto della pagina dove desiderate inserire i dati.
    Selezionate un elemento XML nel pannello Associazioni

    Nella pagina viene visualizzato un segnaposto per dati XML, evidenziato e racchiuso tra parentesi graffe. Viene utilizzata la sintassi XPath (linguaggio XML Path) per descrivere la struttura gerarchica dello schema XML. Ad esempio, se trascinate l'elemento di livello inferiore title sulla pagina e a tale elemento corrispondono gli elementi di livello superiore rss, channel e item, la sintassi del segnaposto di contenuto dinamico sarà {rss/channel/item/title}.

    Fate doppio clic sul segnaposto dati XML nella pagina per aprire Creazione espressioni XPath. Creazione espressioni XPath consente di formattare i dati selezionati oppure selezionare altri elementi dallo schema XML.

  4. (Opzionale) Applicate gli stili ai dati XML: selezionate un segnaposto per dati XML e applicate ad esso degli stili come a qualsiasi altro contenuto utilizzando la finestra di ispezione Proprietà o il pannello Stili CSS. In alternativa, potete utilizzare i fogli di stile Fase di progettazione per applicare gli stili a frammenti XSLT. Ognuno di questi metodi presenta vantaggi e limitazioni.
  5. Visualizzare l'anteprima del lavoro in un browser (File > Anteprima nel browser).
    Nota:

    quando usate il comando Anteprima nel browser per visualizzare l'anteprima del lavoro, Dreamweaver esegue una trasformazione XSL interna senza ricorrere a un server applicazioni.

Visualizzare gli elementi XML ripetuti

L'oggetto XSLT Area ripetuta consente di visualizzare gli elementi ripetuti di un'origine dati XML all'interno di una pagina Web. Ad esempio, se si visualizzano titoli di articoli e descrizioni provenienti da un feed di notizie e quest'ultimo contiene dai dieci ai venti articoli, ogni titolo e descrizione nel file XML è un elemento di livello inferiore di un elemento ripetuto.

Nella vista Progettazione, qualsiasi area contenente un segnaposto per dati XML può essere convertita in un'area ripetuta. Tuttavia, le aree più comuni sono le tabelle, le righe di tabella o una serie di righe di tabella.

  1. Nella vista Progettazione, selezionate un'area contenente uno o più segnaposti per dati XML.

    Potete selezionare qualsiasi oggetto, come una tabella, una riga di tabella o addirittura un paragrafo di testo.

    Vista Progettazione

    Nota:

    per selezionare un'area della pagina con precisione, potete utilizzare il selettore di tag presente nell'angolo inferiore sinistro della finestra del documento. Ad esempio, se l'area è in una tabella, fate clic all'interno della tabella nella pagina, quindi sul tag nel selettore di tag.

  2. Effettuate una delle operazioni seguenti:
    • Selezionate Inserisci > Oggetti XSLT > Area ripetuta.

    • Nella categoria XSLT del pannello Inserisci, fate clic sul pulsante Area ripetuta.

  3. In Creazione espressioni XPath selezionate l'elemento ripetuto indicato da un piccolo segno più.
    Creazione espressioni XPath

  4. Fate clic su OK.

    Nella finestra del documento viene visualizzato un sottile contorno tratteggiato grigio attorno all'area ripetuta. Quando visualizzate l'anteprima del lavoro in un browser (File > Anteprima nel browser), il contorno grigio scompare e la selezione si espande per visualizzare nel file XML gli elementi ripetuti specificati.

    Quando aggiungete un oggetto XSLT Area ripetuta alla pagina, il segnaposto dati XML viene troncato nella finestra del documento. Questo perché Dreamweaver aggiorna l'XPath per il segnaposto dati XML, in modo che sia relativo al percorso dell'elemento ripetuto.

Impostare le proprietà dell'area ripetuta (XSL)

Nella finestra di ispezione Proprietà potete selezionare un diverso nodo XML per creare l'area ripetuta.

  1. Nella casella Selezione, inserite un nuovo nodo, quindi premete l'icona del fulmine e selezionate il nodo nella struttura schema XML visualizzata.

Modificare un oggetto XSLT Area ripetuta

Dopo aver aggiunto un oggetto XSLT Area ripetuta a un'area, potete modificarlo mediante la finestra di ispezione Proprietà.

  1. Selezionate l'oggetto facendo clic sul contorno grigio che circonda l'area ripetuta.
  2. Nella finestra di ispezione Proprietà (Finestra > Proprietà), fate clic sull'icona dinamica accanto al campo di testo Seleziona.
  3. In Creazione espressioni XPath, apportate le modifiche desiderate e fate clic su OK.

Inserire frammenti XSLT nelle pagine dinamiche

Una volta creato un frammento XSLT, potete inserirlo in una pagina Web dinamica utilizzando il comportamento server Trasformazione XSL. Quando aggiungete il comportamento server alla pagina e visualizzate la pagina in un browser, un server applicazioni esegue una trasformazione che determina la visualizzazione dei dati XML contenuti nel frammento XSLT selezionato. Dreamweaver supporta le trasformazioni XSL per le pagine ColdFusion, ASP o PHP.

Nota:

se desiderate inserire il contenuto di una pagina XSLT intera in una pagina dinamica, la procedura è identica. Prima di utilizzare il comportamento server Trasformazione XSL per inserire la pagina XSLT intera, eliminare tutto il codice HTML dalla pagina dinamica.

  1. Aprite una pagina ColdFusion, ASP o PHP esistente.
  2. Nella vista Progettazione, spostate il punto di inserimento nella posizione in cui desiderate inserire il frammento XSLT.
    Nota:

    quando inserite frammenti XSLT, dovete sempre fare clic sul pulsante Mostra viste Codice e Progettazione dopo aver collocato il punto di inserimento sulla pagina in modo da poter verificare che il punto di inserimento sia nella posizione corretta. In caso contrario, potrebbe essere necessario fare clic in un altro punto della vista Codice per collocare il punto di inserimento nella posizione desiderata.

  3. Aprite il pannello Comportamenti server (Finestra > Comportamenti server), fate clic sul pulsante più (+) e selezionate Trasformazione XSLT.
    Pannello Comportamenti server

  4. Nella finestra di dialogo Trasformazione XSL, fate clic sul pulsante Sfoglia e individuate il file che contiene il frammento XSLT o una pagina XSLT intera.

    Dreamweaver compila automaticamente il campo di testo successivo con il percorso o l'URL del file XML associato al segmento specificato. Per cambiarlo, fate clic sul pulsante Sfoglia e individuate un altro file.

  5. (Opzionale) Fate clic sul pulsante più (+) per aggiungere un parametro XSLT.
  6. Fate clic su OK per inserire un riferimento al frammento XSLT nella pagina. Il frammento non è modificabile direttamente. Potete tuttavia fare doppio clic sul frammento per aprirne il file di origine e modificarlo.

    Viene inoltre creata nella cartella principale del sito una cartella denominata includes/MM_XSL Transform/ che contiene un file di libreria runtime. Il server applicazioni utilizza le funzioni definite in questo file per eseguire la trasformazione.

  7. Caricate la pagina dinamica sul server (Sito > Carica) e fate clic su Sì per includere i file dipendenti. Il file contenente il frammento XSLT, il file dei dati XML e la libreria runtime generata da Dreamweaver devono trovarsi tutti sullo stesso server per consentire una corretta visualizzazione della pagina. Se è stato selezionato un file XML remoto come origine dei dati, tale file deve trovarsi in un'altra posizione su Internet.

Eliminare frammenti XSLT dalle pagine dinamiche

Potete rimuovere un frammento XSLT da una pagina eliminando il comportamento server Trasformazione XSL utilizzato per inserirlo. L'eliminazione del comportamento server determina solo la rimozione del frammento XSLT, non dei file XML, XSLT o di libreria runtime associati.

  1. Nel pannello Comportamenti server (Finestra > Comportamenti server), selezionate il comportamento Trasformazione XSL da eliminare.
  2. Fate clic sul pulsante meno (-).
    Nota:

    è necessario eliminare i comportamenti server sempre in questo modo. L'eliminazione manuale del codice generato rimuove solo parzialmente il comportamento server, anche se questo non compare più nel pannello Comportamenti server.

Modificare i comportamenti server di Trasformazione XSL

Una volta aggiunto un frammento XSLT a una pagina Web dinamica, potete modificare il comportamento server di Trasformazione XSLT in qualsiasi momento.

  1. Nel pannello Comportamenti server (Finestra > Comportamenti server), fate doppio clic sul comportamento server Trasformazione XSL da modificare.
  2. Apportate le modifiche, quindi fate clic su OK.

Creare un collegamento dinamico

All'interno della pagina XSLT potete creare un collegamento dinamico con uno specifico URL da attivare quando l'utente fa clic su una o più parole specificate nei dati XML. Per ulteriori informazioni, vedete gli errata corrige di Dreamweaver in www.adobe.com/go/dw_documentation_it.

Applicazione di stili a frammenti XSLT

Quando create una pagina XSLT intera (ovvero, una pagina XSLT che include i tag <body> e <head>), potete visualizzare i dati XML nella pagina e quindi formattarli come qualsiasi contenuto utilizzando la finestra di ispezione Proprietà o il pannello Stili CSS. Quando si crea un frammento XSLT per l'inserimento in una pagina dinamica (ad esempio, un frammento da inserire in una pagina ASP, PHP o ColdFusion), tuttavia la riproduzione degli stili nel frammento e nella pagina dinamica si complica. Sebbene si lavori su un frammento XSLT separatamente dalla pagina dinamica, è importante ricordare che il frammento è pensato per essere utilizzato nella pagina dinamica e che l'output del frammento XSLT risiede all'interno del tag <body> della pagina dinamica. A fronte di questo flusso di lavoro, è importante assicurarsi di non includere elementi <head> (come definizioni di stile o collegamenti a fogli di stile esterni) nei frammenti XSLT. In tal caso infatti il server applicazioni collocherebbe questi elementi nell'area <body> della pagina dinamica, generando tag non validi.

Supponete ad esempio di creare un frammento XSLT per l'inserimento in un pagina dinamica e di voler formattare il frammento tramite lo stesso foglio di stile esterno della pagina dinamica. Se collegate lo stesso foglio di stile al frammento, la pagina HTML risultante includerà un collegamento duplicato al foglio di stile (uno nella sezione <head> della pagina dinamica e un altro nella sezione <body> della pagina, dove viene visualizzato il contenuto del frammento XSLT). È invece consigliabile utilizzare i fogli di stile Fase di progettazione per fare riferimento al foglio di stile esterno.

Per formattare il contenuto di frammenti XSLT, utilizzate il flusso di lavoro seguente:

  • Innanzitutto, collegate un foglio di stile esterno alla pagina dinamica. (Questa è una procedura ottimale per l'applicazione degli stili al contenuto di qualsiasi pagina Web.)

  • Quindi, collegate lo stesso foglio di stile esterno per il frammento XSLT come foglio di stile Fase di progettazione. Come dice il nome, i fogli di stile Fase di progettazione sono disponibili solo nella vista Progettazione di Dreamweaver.

    Una volta completati i passaggi precedenti, potete creare nuovi stili nel frammento XSLT utilizzando lo stesso foglio di stile collegato alla pagina dinamica. Otterrete un output HTML più pulito (in quanto il riferimento al foglio di stile è valido solo mentre si lavora in Dreamweaver) e il frammento verrà comunque visualizzato negli stili corretti in vista Progettazione. Inoltre, tutti gli stili vengono applicati al frammento e alla pagina dinamica quando visualizzate la pagina dinamica in vista Progettazione o un'anteprima della pagina dinamica in un browser.

Nota:

se visualizzate un'anteprima del frammento XSLT in un browser, il browser non mostra gli stili. Per vedere il frammento XSLT nel contesto della pagina dinamica, è necessario visualizzare l'anteprima della pagina dinamica nel browser.

Utilizzare i parametri con le trasformazioni XSL

Potete definire i parametri per la trasformazione XSL quando aggiungete il comportamento server Trasformazione XSLT a una pagina Web. Un parametro controlla il modo in cui i dati XML vengono elaborati e visualizzati. Ad esempio, potete utilizzare un parametro per identificare ed elencare un articolo specifico da un feed di notizie. Quando la pagina viene caricata in un browser, viene visualizzato solo l'articolo specificato dal parametro.

Aggiungere un parametro XSLT a una trasformazione XSL

  1. Aprite la finestra di dialogo Trasformazione XSL. Potete farlo tramite doppio clic su un comportamento server Trasformazione XSL nel pannello Comportamenti server (Finestra > Comportamenti server) oppure aggiungendo un nuovo comportamento server Trasformazione XSL.
  2. Nella finestra di dialogo Trasformazione XSL, fate clic sul pulsante più (+) accanto ai parametri XSLT.
    Finestra di dialogo Trasformazione XSL

  3. Nella finestra di dialogo Aggiungi parametri inserite un nome per il parametro nella casella Nome. Il nome può includere solo caratteri alfanumerici; non può includere spazi.
  4. Effettuate una delle operazioni seguenti:
    • Se desiderate utilizzare un valore statico, inseritelo nella casella Valore.

    • Se desiderate utilizzare un valore dinamico, fate clic sull'icona relativa accanto alla casella Valore, impostate la finestra di dialogo Dati dinamici e fate clic su OK. Per ulteriori informazioni, fate clic sul pulsante Aiuto nella finestra di dialogo Dati dinamici.

  5. Nella casella Valore predefinito, inserite il valore che desiderate venga utilizzato dal parametro se la pagina non riceve valori di runtime e fate clic su OK.

Modificare un parametro XSLT

  1. Aprite la finestra di dialogo Trasformazione XSL. Potete farlo tramite doppio clic su un comportamento server Trasformazione XSL nel pannello Comportamenti server (Finestra > Comportamenti server) oppure aggiungendo un nuovo comportamento server Trasformazione XSL.
  2. Selezionate un parametro dall'elenco Parametri XSLT.
  3. Fate clic sul pulsante Modifica.
  4. Apportate le modifiche, quindi fate clic su OK.

Eliminare un parametro XSLT

  1. Aprite la finestra di dialogo Trasformazione XSL. Potete farlo tramite doppio clic su un comportamento server Trasformazione XSL nel pannello Comportamenti server (Finestra > Comportamenti server) oppure aggiungendo un nuovo comportamento server Trasformazione XSL.
  2. Selezionate un parametro dall'elenco Parametri XSLT.
  3. Fate clic sul pulsante meno (-).

Creare e modificare aree XSLT condizionali

In una pagina XSLT, potete creare aree condizionali semplici o multiple. Potete selezionare un elemento nella vista Progettazione e applicare un'area condizionale alla selezione, oppure inserire un'area condizionale in corrispondenza del punto di inserimento nel documento.

Ad esempio, se desiderate visualizzare le parole “Non disponibile” accanto al prezzo di un articolo quando questo non è disponibile, digitate le parole “Non disponibile” nella pagina, selezionatele e quindi applicate un'area condizionale al testo selezionato. In Dreamweaver la selezione viene circondata da tag <xsl:if> e nella pagina viene visualizzate solo la parola "Non disponibile" quando i dati corrispondono alle condizioni dell'espressione condizionale.

Applicare un'area XSLT condizionale

Potete scrivere un'espressione condizionale semplice da inserire nella pagina XSLT. Se il contenuto è selezionato quando aprite la finestra di dialogo Area condizionale, verrà inserito in un blocco <xsl:if>. In caso contrario, il blocco <xsl:if> viene aggiunto nel punto di inserimento nella pagina. Si consiglia di utilizzare la finestra di dialogo per creare e quindi personalizzare l'espressione nella vista Codice.

L'elemento <xsl:if> è simile all'istruzione if di altri linguaggi. Questo elemento fornisce un modo per verificare una condizione e procedere in base al risultato ottenuto. L'elemento <xsl:if> consente di verificare un'espressione per un singolo valore true o false.

  1. Selezionate Inserisci > Oggetti XSLT > Area condizionale o fate clic sull'icona Area condizionale nella categoria XSLT del pannello Inserisci.
  2. Nella finestra di dialogo Area condizionale, inserite l'espressione condizionale da utilizzare per l'area.

    Nell'esempio seguente si vuole eseguire un test per verificare se il valore dell'attributo @available del nodo del contesto è true.

    Finestra di dialogo Area condizionale

  3. Fate clic su OK.

    Il codice seguente viene inserito nella pagina XSLT:

    <xsl:if test="@available=&apos;true&apos;"> 
        Content goes here 
    </xsl:if>
    Nota:

    è necessario inserire i valori di stringa come true tra virgolette. Dreamweaver codifica le virgolette (&apos;) in modo che vengano inserite come caratteri XHTML validi.

    Oltre a verificare i nodi in relazione ai valori, potete utilizzare le funzioni XSLT supportate in qualsiasi istruzione condizionale. La condizione viene verificata per il nodo corrente all'interno del file XML. Nell'esempio seguente si vuole eseguire un test per verificare l'ultimo nodo nel set di risultati.

    Test per verificare l'ultimo nodo nel set di risultati

    Per maggiori informazioni ed esempi sulla scrittura di espressioni condizionali, vedete la sezione <xsl:if> nel pannello Riferimenti (Aiuto > Riferimenti).

Applicare aree XSLT condizionali multiple

Potete scrivere un'espressione condizionale semplice da inserire nella pagina XSLT. Se il contenuto è selezionato quando aprite la finestra di dialogo Area condizionale, verrà inserito in un blocco <xsl:choose>. Se il contenuto non è selezionato, il blocco <xsl:choose> viene aggiunto nel punto di inserimento nella pagina. Si consiglia di utilizzare la finestra di dialogo per creare e quindi personalizzare l'espressione nella vista Codice.

L'elemento <xsl:choose> è simile all'istruzione case di altri linguaggi. Questo elemento fornisce un modo per verificare una condizione e procedere in base al risultato ottenuto. L'elemento <xsl:choose> consente di verificare condizioni multiple.

  1. Selezionate Inserisci > Oggetti XSLT > Area condizionale multipla o fate clic sull'icona Area condizionale multipla nella categoria XSLT del pannello Inserisci.
  2. Nella finestra di dialogo Area condizionale multipla, inserite la prima condizione.

    Nell'esempio seguente si vuole eseguire un test per verificare se il sottoelemento price del nodo del contesto è minore di 5.

    Finestra di dialogo Area condizionale multipla

  3. Fate clic su OK.

    Nell'esempio, il codice seguente viene inserito nella pagina XSLT:

    <xsl:choose> 
        <xsl:when test="price&lt;5"> 
            Content goes here 
        </xsl:when> 
        <xsl:otherwise> 
            Content goes here 
        </xsl:otherwise> 
    </xsl:choose>
  4. Per inserire un'altra condizione, posizionate il punto di inserimento nella vista Codice tra le coppie di tag <xsl:when> o appena prima del tag <xsl:otherwise>, quindi inserite un'area condizionale (Inserisci > Oggetti XSLT > Area condizionale).

    Una volta specificata la condizione e fatto clic su OK, un altro tag <xsl:when> viene inserito nel blocco <xsl:choose>.

    Per maggiori informazioni ed esempi sulla scrittura di espressioni condizionali, vedete la sezione <xsl:choose> nel pannello Riferimenti (Aiuto > Riferimenti).

Proprietà dell'area condizionale (If)

Questa finestra di ispezione Proprietà consente di modificare la condizione utilizzata in un'area condizionale nella pagina XSL. L'area condizionale consente di verificare la condizione e procedere in base al risultato ottenuto.

  1. Nella casella Prova, inserite una nuova condizione, quindi premete Invio.

Proprietà dell'area condizionale (When)

Questa finestra di ispezione Proprietà consente di modificare la condizione utilizzata in un'area condizionale multipla nella pagina XSL. L'area condizionale multipla consente di verificare la condizione e procedere in base al risultato ottenuto.

  1. Nella casella Prova, inserite una nuova condizione, quindi premete Invio.

Inserire commenti XSL

Potete aggiungere tag di commento XSL a un documento oppure inserire una selezione tra tag di commenti XSL.

Aggiungere tag di commento XSL a un documento

  1. Effettuate una delle operazioni seguenti:
    • Nella vista Progettazione selezionate Inserisci > Oggetti XSLT > Commento XSL, digitate il contenuto del commento (o lasciate vuota la casella) e fate clic su OK.

    • Nella vista Codice, selezionate Inserisci > Oggetti XSLT > Commento XSL.

    Nota:

    potete anche fare clic sull'icona Commento XSL nella categoria XSLT del pannello Inserisci.

Inserire una selezione tra tag di commento XSL

  1. Passate alla vista Codice (Visualizza > Codice).
  2. Selezionate il codice da commentare.
  3. Nella barra degli strumenti Codifica, fate clic sul pulsante Applica commento e selezionate Applica commento <xsl:comment></xsl:comment>.

Usare Creazione espressioni XPath per aggiungere espressioni per i dati XML

XPath (XML Path Language) è una sintassi non XML che consente di gestire singole sezioni di un documento XML. Viene utilizzata prevalentemente come linguaggio di query per i dati XML, nello stesso modo in cui il linguaggio SQL viene usato per interrogare i database. Per ulteriori informazioni su XPath, vedete la specifica di tale linguaggio nel sito Web di W3C all'indirizzo www.w3.org/TR/xpath.

Creazione espressioni XPath è una funzione di Dreamweaver che consente di creare semplici espressioni XPath per identificare nodi specifici di dati e per le aree ripetute. Il vantaggio di utilizzare questo metodo, anziché trascinare i valori dalla struttura dello schema XML, consiste nella possibilità di formattare il valore visualizzato. Il contesto corrente viene identificato in base alla posizione del punto di inserimento all'interno del file XSL al momento dell'apertura della finestra di dialogo Creazione espressioni XPath. Il contesto corrente viene visualizzato in grassetto nella struttura dello schema XML. Quando effettuate le selezioni in questa finestra di dialogo, vengono generate le istruzioni XPath corrette relative al contesto corrente. Viene così semplificato il processo di scrittura di espressioni XPath corrette per principianti e utenti avanzati.

Nota:

questa funzione è progettata per facilitare l'utente nella creazione di espressioni XPath semplici per identificare un nodo specifico o per le aree ripetute. Non consente di modificare le espressioni manualmente. Per creare espressioni complesse, utilizzate la finestra di dialogo Creazione espressioni XPath per iniziare e quindi personalizzate le espressioni nella vista Codice o mediante la finestra di ispezione Proprietà.

Create un'espressione XPath per identificare un nodo specifico

  1. Fate doppio clic sul segnaposto dati XML nella pagina per aprire Creazione espressioni XPath.
  2. Nella finestra di dialogo Creazione espressioni XPath (Testo dinamico), selezionate un nodo nella struttura dello schema XML.

    L'espressione XPath corretta viene scritta nella casella Espressione per identificare il nodo.

    Nota:

    se selezionate un nodo diverso nella struttura dello schema XML, l'espressione viene modificata in modo da riflettere la selezione.

    Nell'esempio seguente si vuole visualizzare il sottoelemento price del nodo item:

    Finestra di dialogo Creazione espressioni XPATH (testo dinamico)

    Questa selezione inserirà il codice seguente nella pagina XSLT:

    <xsl:value-of select="price"/>
  3. (Facoltativo) Selezionate un'opzione di formattazione dal menu a comparsa Formato.

    La formattazione di una selezione è utile quando il valore del nodo restituisce un numero. Dreamweaver fornisce un elenco predefinito di funzioni di formattazione. Per un elenco completo delle funzioni di formattazione e degli esempi disponibili, vedete il pannello Riferimenti.

    Nell'esempio seguente, si desidera formattare il sottoelemento price come una valuta con due cifre decimali:

    Formattazione del sottoelemento price come una valuta con due cifre decimali

    Queste opzioni inseriscono il seguente codice nella pagina XSLT:< xsl: value-di select="format-number(provider/store/items/item/price,'$#.00')" / >

    <xsl:value-of select="format-number(provider/store/items/item/price,'$#.00')"/>
  4. Fate clic su OK.
  5. Per visualizzare il valore di ogni nodo nel file XML, applicate un'area ripetuta all'elemento contenente il testo dinamico (ad esempio, una riga di tabella HTML o un paragrafo).

    Per maggiori informazioni ed esempi sulla selezione di nodi per restituire un valore, vedete la sezione <xsl:value-of/> nel pannello Riferimenti.

Selezionare un nodo da ripetere

Potete selezionare un nodo da ripetere o, facoltativamente, per filtrare i risultati. Nella finestra di dialogo Creazione espressioni XPath, è stato scelto di includere il contenuto in un blocco <xsl:for-each>. In caso contrario, il blocco <xsl:for-each> sarà immesso in corrispondenza del punto di inserimento del cursore.

  1. Fate doppio clic sul segnaposto dati XML nella pagina per aprire Creazione espressioni XPath.
  2. Nella finestra di dialogo Creazione espressioni XPath (Area ripetuta), selezionate l'elemento da ripetere nella struttura dello schema XML.

    L'espressione XPath corretta viene scritta nella casella Espressione per identificare il nodo.

    Nota:

    gli elementi ripetuti vengono identificati dal simbolo più (+) nella struttura dello schema XML.

    Nell'esempio seguente, si desidera ripetere ogni nodo item all'interno del file XML.

    Finestra di dialogo Creazione espressioni XPATH (Area ripetuta)

    Quando fate clic su OK, il codice seguente viene inserito nella pagina XSLT:

    <xsl:for-each select="provider/store/items/item"> 
     Content goes here 
    </xsl:for-each>

    In alcuni casi, potrebbe essere necessario utilizzare un sottoinsieme di nodi ripetuti, ad esempio solo elementi in cui un attributo abbia un valore specifico. In questo caso, è necessario creare un filtro.

Filtrare i dati da ripetere

Utilizzate un filtro per identificare i nodi ripetuti che presentano valori di attributi specifici.

  1. Nella struttura dello schema XML, selezionate un nodo da ripetere.
  2. Fate clic sul pulsante di espansione Crea filtro.
  3. Fate clic sul pulsante più (+) per creare un filtro vuoto.
  4. Inserite il criterio di filtro nei campi seguenti:

    Filtra per

    Specifica il nodo ripetuto che include i dati in base ai quali desiderate applicare il filtro. Il menu a comparsa fornisce un elenco di nodi padre per il nodo selezionato nella struttura dello schema XML.

    Posizione

    Specifica l'attributo o il sottoelemento del nodo Filtra per che verrà utilizzato per limitare i risultati. Potete selezionare un attributo o sottoelemento dal menu a comparsa oppure inserire una espressione XPath personalizzata in questo campo per identificare gli elementi di livello inferiore nei livelli più interni della struttura dello schema.

    Operatore

    Specifica l'operatore di confronto da utilizzare nell'espressione di filtro.

    Valore

    Specifica il valore da verificare nel nodo Filtra per. Inserite il valore. Se i parametri dinamici sono definiti per la pagina XSLT, potete selezionarne uno dal menu a comparsa.

  5. Per specificare un altro filtro, fate clic di nuovo sul pulsante più (+).

    Le selezioni effettuate nei menu a comparsa vengono applicate istantaneamente all'espressione XPath visualizzata nella casella Espressione.

    Nell'esempio che segue si desidera limitare il set di risultati ai nodi item in cui il valore dell'attributo @available è true.

    Limitare il set di risultati ai nodi di item in cui il valore dell'attributo @available è true

    Quando si fa clic su OK, nella pagina XSLT viene inserito il seguente codice:< xsl: for-each select="provider/store/items/item[@available = & amp; apos; true & amp; apos;]" > Inserire qui il contenuto

    <xsl:for-each select="provider/store/items/item[@available = &apos;true&apos;]"> 
          Content goes here 
    </xsl:for-each>
    Nota:

    è necessario inserire i valori di stringa come true tra virgolette. Dreamweaver codifica le virgolette (&apos;) in modo che vengano inserite come caratteri XHTML validi.

    Potete creare filtri più complessi che consentano di specificare nodi principali come parte dei criteri di filtro. Nell'esempio seguente si desidera limitare il set di risultati ai nodi item in cui il valore dell'attributo 2id di store è uguale a 1 e il nodo price di item è maggiore di 5.

    Limitare il set di risultati ai nodi di item in cui il valore dell'attributo @id di store è uguale a 1 e il nodo price di item è maggiore di 5.

    Quando si fa clic su OK, nella pagina XSLT viene inserito il seguente codice:<xsl:for-each select="provider/store[@id = 1]/items/item[price &gt; 5]"> Inserire qui il contenuto

    Per maggiori informazioni ed esempi di aree ripetute, vedete la sezione <xsl:for-each> nel pannello Riferimento.

    <xsl:for-each select="provider/store[@id = 1]/items/item[price &gt; 5]"> 
        Content goes here 
    </xsl:for-each>
Logo Adobe

Accedi al tuo account