Ottimizzare il codice in Dreamweaver, verificare la compatibilità con i browser, convalidare documenti XML e rendere le pagine conformi a XHTML.

Ottimizzare il codice

Potete rimuovere automaticamente i tag vuoti, combinare i tag font nidificati e migliorare e correggere il codice HTML o XHTML scritto in maniera disordinata o illeggibile.

Per informazioni su come ottimizzare il codice HTML generato da un documento Microsoft Word, vedete Aprire e modificare documenti esistenti.

  1. In un documento aperto, selezionare Strumenti > Ottimizza HTML.

  2. Nella finestra di dialogo visualizzata, selezionate le opzioni desiderate, quindi fate clic su OK.

    Nota:

    a seconda delle dimensioni del documento e del numero di opzioni selezionate, il processo di ottimizzazione può richiedere diversi secondi.

    Elimina tag contenitori vuoti

    Elimina i tag che non hanno un contenuto. Ad esempio, <b></b> e <font color="#FF0000"></font> sono tag vuoti, ma il tag <b> in <b>testo</b> non lo è.

    Elimina tag nidificati superflui

    Elimina tutti i tag superflui individuati nel documento. Ad esempio, nel codice <b>Questo è quello che volevo <b>realmente</b> dire</b>, i tag b che racchiudono la parola realmente sono superflui e vengono quindi eliminati.

    Elimina commenti HTML non di Dreamweaver

    Elimina tutti i commenti che non sono stati inseriti da Dreamweaver. Ad esempio, <!‑‑begin body text--> verrebbe rimosso, al contrario di <!--TemplateBeginEditable name="doctitle"--> che è un commento di Dreamweaver che segna l'inizio di un'area modificabile all'interno di un modello.

    Elimina codice speciale Dreamweaver

    Elimina i commenti che Dreamweaver aggiunge al codice per consentire l'aggiornamento automatico dei documenti quando vengono aggiornati i modelli e le voci di libreria. Se selezionate questa opzione quando ottimizzate il codice di un documento basato su un modello, il documento viene scollegato dal modello. Per ulteriori informazioni, vedete Dissociare un documento da un modello.

    Elimina tag specifico/i

    Elimina i tag specificati dall'utente nella casella di testo adiacente. Utilizzate questa opzione per eliminare dei tag personalizzati inseriti da altri editor visivi e altri tag che desiderate escludere dal vostro sito (ad esempio blink). Per separare più tag, usare delle virgole (ad esempio font,blink).

    Combina tag di <font> nidificati quando possibile

    Raggruppa due o più tag font quando sono applicati alla stessa sezione di testo. Ad esempio, la serie di tag <font size="7"><font color="#FF0000">big red</font></font> diventa <font size="7" color="#FF0000">big red</font>.

    Mostra registro al termine

    Visualizza una finestra di avvertimento che segnala le modifiche apportate al documento al termine del processo di ottimizzazione.

Verificare il bilanciamento di tag e parentesi

Potete eseguire un controllo per assicurarvi che i tag e le parentesi tonde (( )), graffe ({ }) e quadre ([ ]) nella pagina siano bilanciate. Per bilanciamento si intende che qualsiasi tag e parentesi tonda, graffa o quadra di apertura abbia il corrispondente tag o parentesi di chiusura e viceversa.

Verificare il bilanciamento dei tag

  1. Aprite il documento nella vista Codice.
  2. Posizionate il punto di inserimento nel codice nidificato che desiderate controllare.
  3. Selezionate Modifica > Seleziona tag superiore.

    I tag di chiusura corrispondenti, e il relativo contenuto, vengono selezionati nel codice. Se continuate a selezionare Modifica > Seleziona tag superiore e i tag sono bilanciati, alla fine Dreamweaver seleziona i tag html e /html più esterni.

Verificare il bilanciamento di parentesi tonde, graffe o quadre

  1. Aprite il documento nella vista Codice.
  2. Posizionate il punto di inserimento nel codice che desiderate controllare.
  3. Selezionate Modifica > Codice > Bilancia parentesi.

    Tutto il codice compreso tra le parentesi tonde, graffe o quadre viene selezionato. Se scegliete nuovamente Modifica > Codice > Bilancia parentesi, tutto il codice compreso tra le parentesi della selezione viene selezionato.

Verificare la compatibilità con i browser

La funzione Verifica compatibilità browser (VCB) aiuta a localizzare eventuali combinazioni di codice HTML e CSS in grado di attivare bug di rendering in taluni browser. Questa funzione verifica inoltre il codice del documento per individuare eventuali proprietà o valori CSS non supportati dai browser di destinazione.

Convalidare documenti XML

Potete impostare le preferenze della funzione di convalida, i problemi specifici da controllare e i tipi di errori per i quali la funzione Convalida deve generare un rapporto.

  1. Effettuate una delle operazioni seguenti:
    • Per un file XML o XHTML, selezionate File > Convalida > Come XML.

    • La scheda Convalida del pannello Risultati visualizza il messaggio “Non sono stati trovati errori o avvertenze” oppure un elenco degli errori di sintassi rilevati.

  2. Fate doppio clic su un messaggio di errore per evidenziare l'errore nel documento.
  3. Per salvare il rapporto come file XML, fate clic sul pulsante Salva rapporto.
  4. Per visualizzare il rapporto nel browser principale per stamparlo, fate clic sul pulsante Sfoglia rapporto.

Convalidare documenti tramite Convalida W3C

Dreamweaver consente di creare pagine Web conformi agli standard utilizzando il supporto incorporate per Convalida W3C. Convalida W3C effettua la convalida di documenti HTML e XML per la conformità agli standard HTML, XHTML o XML. Potete convalidare sia documenti aperti che file pubblicati su un server dal vivo.

Usate il rapporto generato dopo la convalida per correggere gli errori nel file.

Nota:

nelle preferenze di Dreamweaver, potete specificare il modulo di analisi con cui convalidare i documenti. Questa preferenza è utilizzata come impostazione di riserva nei casi in cui il DOCTYPE non possa essere rilevato automaticamente.

Convalidare un documento aperto

  1. Selezionate Finestra > Risultati > Convalida per aprire il pannello Convalida. Questo pannello visualizza i risultati della convalida.

  2. Selezionate File > Convalida > Documento corrente (W3C).

Convalidare un documento dal vivo

Per i documenti dal vivo, Dreamweaver convalida il codice ricevuto dal browser. Questo codice viene visualizzato quando fate clic con il pulsante destro del mouse nel browser e scegliete l'opzione per visualizzare il codice di origine. La convalida dei documenti è particolarmente utile per convalidare pagine dinamiche tramite PHP, JSP e così via.

L'opzione Convalida documento dal vivo è abilitata solo quando l'URL della pagina da convalidare inizia con http.

  1. Selezionate Finestra > Risultati > Convalida per aprire il pannello Convalida. Questo pannello visualizza i risultati della convalida.

  2. Fate clic su Vista Dal vivo.

  3. Selezionate File > Convalida > Documento dal vivo (W3C).

Per i documenti dal vivo, quando fate doppio clic su un errore nel pannello Convalida W3C, viene aperta una finestra separata. La finestra visualizza il codice generato dal browser e la riga con l'errore è evidenziata.

Personalizzare le impostazioni di convalida

  1. Selezionate Finestra > Risultati > Convalida per aprire il pannello Convalida.

  2. Nel pannello Convalida W3C fate clic sull'icona Convalida W3C (Esegui). Selezionate Impostazioni.

  3. Selezionate un DOCTYPE per la convalida se per il documento non è già stato specificato esplicitamente un DOCTYPE.

  4. Se non desiderate visualizzare errori e avvisi, deselezionate le opzioni.

  5. Fate clic su Gestione se desiderate eliminare tutti gli avvisi o gli errori nascosti tramite il pannello Convalida W3C. Se rimuovete avvisi ed errori, non verranno visualizzati quando selezionate Mostra tutto nel pannello Convalida W3C.

  6. Selezionate Non mostrare la finestra Notifica convalida W3C se non desiderate che questa finestra venga visualizzata quando iniziate la convalida.

Utilizzo dei rapporti di convalida

Al termine della convalida, i rapporti di convalida vengono visualizzati nel pannello Convalida W3C.

  • Per ulteriori informazioni sull'errore o sull'avviso, selezionatelo nel pannello Convalida W3C. Fate clic su Altre informazioni.

  • Per salvare il rapporto come file XML, fate clic su Salva rapporto.

  • Per visualizzare l'intero rapporto in HTML, fate clic su Sfoglia rapporto. Il rapporto HTML fornisce un elenco completo degli errore e avvisi unitamente a un riepilogo.

  • Per passare alla posizione nel codice che contiene l'errore, selezionare l'errore nel pannello Convalida W3C. Fate clic sul pulsante Opzioni e selezionate Vai alla riga.

  • Per nascondere errori/avvisi, selezionate l'errore o l'avviso desiderato. Fate clic sul pulsante Opzioni e selezionate Nascondi errore.

  • Per visualizzare tutti gli errori e gli avvisi, inclusi gli errori nascosti, fate clic sul pulsante Opzioni. Selezionate Mostra tutto. Gli eventuali errori e avvisi nascosti che avete eliminato nella finestra di dialogo Preferenze non vengono elencati.

  • Per cancellare tutti i risultati nel pannello Convalida W3C, fate clic sul pulsante Opzioni. Selezionate Cancella risultati.

Impostare le preferenze della funzione Convalida

Oltre alla Convalida W3C standard, Dreamweaver supporta ancora i moduli di convalida del codice esterni installati come estensioni. Quando installate un'estensione di convalida esterna, Dreamweaver ne elenca le preferenze nella categoria Convalida W3C della finestra di dialogo Preferenze.

  1. Selezionate Modifica > Preferenze (Windows) o Dreamweaver > Preferenze (Macintosh).
  2. Selezionate W3C Validator dall'elenco Categoria visualizzato sulla sinistra.

  3. Selezionate le librerie di tag da convalidare.

    Non potete selezionare più versioni della stessa libreria di tag o linguaggio; ad esempio, se selezionato HTML 4.01, non potete selezionare anche HTML 5. Selezionate la versione più recente con cui convalidare. Ad esempio, se un documento contiene del codice HTML 4.01 valido, sarà anche codice HTML 5 valido.

  4. Selezionate le opzioni Visualizza per specificare i tipi di errori e le avvertenze da includere nel rapporto della funzione Convalida.
  5. Fate clic su Applica per rendere effettive le modifiche, quindi fate clic su Chiudi per chiudere la finestra di dialogo Preferenze.

Creare pagine conformi a XHTML

Quando create una pagina, potete renderla conforme al linguaggio XHTML. Potete anche rendere un documento HTML esistente conforme al linguaggio XHTML.

Creare documenti conformi a XHTML

  1. Selezionate File > Nuovo.
  2. Selezionate una categoria e un tipo di pagina da creare.
  3. Selezionate uno dei file DTD (Document Type Definition, definizione tipo di documento) XHTML dal menu a comparsa DocType all'estrema destra della finestra di dialogo, quindi fate clic su Crea.

    Ad esempio, potete rendere un documento HTML conforme alla specifica XHTML selezionando XHTML 1.0 Transitional o XHTML 1.0 Strict dal menu a comparsa.

    Nota:

    non tutti i tipi di documento possono essere resi conformi a XHTML.

Creare documenti conformi a XHTML per impostazione predefinita

  1. Selezionate Modifica > Preferenze o Dreamweaver > Preferenze (Mac OS X) e selezionate la categoria Nuovo documento.
  2. Selezionate un documento predefinito e uno dei file DTD XHTML dal menu a comparsa Tipo di documento predefinito (DTD), quindi fate clic su OK.

    Ad esempio, potete rendere un documento HTML conforme alla specifica XHTML selezionando XHTML 1.0 Transitional o XHTML 1.0 Strict dal menu a comparsa.

Rendere un documento HTML preesistente conforme a XHTML

  1. Aprite un documento, quindi effettuate una delle seguenti operazioni:

    • Per un documento senza frame, selezionate File > Converti, quindi selezionate una delle DTD XHTML.

      Ad esempio, potete rendere un documento HTML conforme alla specifica XHTML selezionando XHTML 1.0 Transitional o XHTML 1.0 Strict dal menu a comparsa.

    • Per un documento con frame, selezionate un frame e File > Converti, quindi selezionate una delle DTD XHTML.

  2. Per convertire l'intero documento, ripetete questo passaggio per ogni frame e per il documento del set di frame.

Nota:

non potete convertire un'occorrenza di un modello perché deve essere nello stesso linguaggio del modello sui cui è basata. Ad esempio, un documento basato su un modello XHTML sarà sempre in XHTML e un documento basato su un documento modello HTML non compatibile con XHTML sarà sempre in HTML e non potrà essere convertito in XHTML o in qualsiasi altro linguaggio.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online