Depositate e ritirate i file nei server locale e remoto utilizzando il sistema di deposito/ritiro, WebDAV o Subversion di Dreamweaver.

Se lavorate in team, potete depositare e ritirare i file tra i siti locali e remoti. Se siete l'unica persona che lavora sul sito remoto, potete utilizzare i comandi Scarica e Carica per trasferire i file senza depositarli o ritirarli.

Nota:

con un server di prova potete utilizzare la funzionalità di caricamento e scaricamento, ma non la funzionalità di deposito e ritiro.

Ritirare un file equivale a segnalare agli altri utenti che il file non è disponibile. Quando un file viene ritirato, nel pannello File viene visualizzato il nome dell'utente che lo ha ritirato con un segno di spunta rosso (se l'autore del ritiro è un membro del team) o verde (se è l'utente stesso) accanto all'icona del file.

Quando viene depositato, un file torna a essere disponibile per gli altri utenti, che possono quindi ritirarlo e modificarlo. Quando depositate un file dopo averlo modificato, la versione locale del file diventa di sola lettura e il nome del file viene affiancato da un simbolo di lucchetto nel pannello File, per impedire che venga modificato.

Dreamweaver non imposta come file di sola lettura le copie dei file ritirati che rimangono sul server. Se trasferite file con un'applicazione diversa da Dreamweaver, potete sovrascrivere inavvertitamente i file ritirati. Tuttavia, per evitare inconvenienti di questo tipo, nelle applicazioni diverse da Dreamweaver, la dicitura LCK viene visualizzata accanto al nome del file ritirato nella struttura gerarchica dei file.

Configurare il sistema di deposito/ritiro

Per poter utilizzare il sistema di deposito/ritiro, è necessario prima associare il sito locale a un server remoto.

  1. Selezionate Sito > Gestisci siti.
  2. Selezionate un sito e fate clic su Modifica.
  3. Nella finestra di dialogo Configurazione sito, selezionate la categoria Server ed effettuate una delle seguenti operazioni:
    • Fate clic sul pulsante Aggiungi nuovo server per aggiungere un nuovo server.

    • Selezionate un server esistente e fate clic sul pulsante Modifica server esistente.

  4. Specificate le opzioni Generali necessarie, quindi fate clic sul pulsante Avanzate.
  5. Se lavorate in team (oppure se lavorate da soli su più computer), selezionate Abilita ritiro file. Deselezionate questa opzione se volete disabilitare la funzione di deposito e ritiro dei file per il sito Web.

    Questa opzione è utile per segnalare ad altri utenti che un file è stato ritirato ed è in corso di modifica, oppure per ricordarsi che su un altro computer potrebbe trovarsi una versione più recente di un determinato file.

    Se non appaiono le opzioni di deposito/ritiro, il server remoto non è stato configurato.

  6. Selezionate l'opzione Ritira i file all'apertura se desiderate che i file vengano automaticamente ritirati quando li aprite mediante doppio clic nel pannello File.

    Se si apre il file con File > Apri, il file non viene ritirato anche se l'opzione è selezionata.

  7. Impostate le opzioni rimanenti:

    Nome per ritiro

    Questo nome apparirà nel pannello File accanto ai file che risultano ritirati, in modo che gli altri utenti possano sapere da chi è stato ritirato un file di cui hanno bisogno.

    Nota:

    se lavorate da soli su vari computer, è opportuno utilizzare un nome per il ritiro diverso per ogni sistema (ad esempio, EnricoS-MacCasa ed EnricoS-PCUfficio), in modo che, qualora dimentichiate di depositare un file ritirato, possiate sempre sapere dove si trova l'ultima versione.

    Indirizzo e-mail

    Se inserite un indirizzo e-mail, al momento del ritiro del file il vostro nome viene visualizzato nel pannello File sotto forma di collegamento (testo blu e sottolineato) accanto al file. Se un membro del team fa clic sul collegamento, viene aperto il programma di posta elettronica predefinito con un nuovo messaggio, in cui sono specificati l'indirizzo e-mail dell'utente e il nome del file e del sito nell'oggetto del messaggio.

Depositare e ritirare i file in una cartella remota

Dopo avere impostato il sistema di deposito e ritiro, potete depositare e ritirare i file da/su un server remoto utilizzando il pannello File oppure tramite la finestra del documento.

Ritirare i file mediante il pannello File

  1. Nel pannello File (Finestra > File), selezionate i file da ritirare dal server remoto.

    Nota:

    potete selezionare file nella vista locale o remota, non nella vista server di prova.

    Un segno di spunta rosso indica un file ritirato da un altro membro del team e l'icona di un lucchetto indica che il file è di sola lettura (Windows) o protetto (Macintosh).

  2. Per ritirare il o i file, effettuate una delle seguenti operazioni:
    • Fate clic sul pulsante Ritira nella barra degli strumenti del pannello File.

    • Fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh), quindi selezionate Ritira dal menu di scelta rapida.

  3. Nella finestra di dialogo File dipendenti, fate clic su Sì per scaricare i file dipendenti insieme ai file selezionati, oppure su No per non scaricare tali file. L'impostazione predefinita prevede che i file dipendenti non vengano scaricati. Per impostare questa opzione, selezionate Modifica > Preferenze > Sito.

    Nota:

    solitamente, è consigliabile scaricare i file dipendenti quando si ritira un nuovo file, ma se le ultime versioni dei file dipendenti si trovano già sul disco locale, non è necessario scaricarli di nuovo.

    L'icona del file locale viene affiancata da un segno di spunta verde, che indica un file ritirato dall'utente.

    Nota:

    ritirando il file attualmente attivo, la versione aperta del file viene sovrascritta dalla nuova versione ritirata.

Depositare i file mediante il pannello File

  1. Nel pannello File (Finestra > File), selezionate uno o più file nuovi o già ritirati.

    Nota:

    potete selezionare file nella vista locale o remota ma non nella vista server di prova.

  2. Per depositare il o i file, effettuate una delle seguenti operazioni:
    • Fate clic sul pulsante Deposita nella barra degli strumenti del pannello File.

    • Fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) e scegliete Deposita dal menu di scelta rapida.

  3. Fate clic su Sì per caricare i file dipendenti insieme ai file selezionati, oppure fate clic su No per non caricare tali file. L'impostazione predefinita prevede che i file dipendenti non vengano caricati. Per impostare questa opzione, selezionate Modifica > Preferenze > Sito.

    Nota:

    solitamente, è consigliabile caricare i file dipendenti quando si deposita un nuovo file, ma se le ultime versioni dei file dipendenti si trovano già sul server remoto, non è necessario caricarli di nuovo.

    L'icona del file locale viene affiancata da un simbolo di lucchetto, che indica che il file è ora di sola lettura.

    Nota:

    se depositate il file attualmente attivo, è possibile che il file venga automaticamente salvato prima di essere depositato, in base alle opzioni impostate nelle preferenze.

Depositare un file aperto dalla finestra del documento

  1. Assicuratevi che il file da depositare sia aperto nella finestra del documento.

    Nota:

    potete depositare un solo file aperto alla volta.

  2. Effettuate una delle operazioni seguenti:
    • Selezionate Sito > Deposita.

    • Fate clic sull'icona Gestione file nella barra degli strumenti della finestra del documento, quindi selezionate Deposita dal menu.

      se il file corrente non fa parte del sito attivo nel pannello File, Dreamweaver tenta di determinare il sito di appartenenza del file corrente. Se il file corrente appartiene a un sito diverso da quello attivo nel pannello File, Dreamweaver apre tale sito ed esegue l'operazione di deposito.

    Nota:

    se depositate il file attualmente attivo, è possibile che il file venga automaticamente salvato prima di essere depositato, in base alle opzioni impostate nelle preferenze.  

Annullare il ritiro di un file

Se ritirate un file e poi decidete di non modificarlo (oppure decidete di annullare le modifiche apportate), potete annullare l'operazione di ritiro e ripristinare lo stato originale del documento.

Per annullare il ritiro di un file, effettuate una delle seguenti operazioni:

  • Aprite il file nella finestra del documento, quindi selezionate Sito > Annulla ritiro.

  • Nel pannello File (Finestra > File), fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh), quindi selezionate Annulla ritiro.

    La copia locale del file diventa di sola lettura e le eventuali modifiche vengono annullate.

Usare WebDAV per depositare e ritirare i file

Dreamweaver è in grado di connettersi a un server che utilizza WebDAV (Web-based Distributed Authoring and Versioning), una serie di estensioni del protocollo HTTP che consentono agli utenti di modificare e gestire i file sui server Web remoti in modo collaborativo. Per ulteriori informazioni, vedete www.webdav.org.

  1. Se non lo avete già fatto, definite un sito Dreamweaver che specifichi la cartella locale utilizzata per archiviare i file del progetto.
  2. Selezionate Sito > Gestisci siti, quindi fate doppio clic sul sito nell'elenco.
  3. Nella finestra di dialogo Configurazione sito, selezionate la categoria Server ed effettuate una delle seguenti operazioni:
    • Fate clic sul pulsante Aggiungi nuovo server per aggiungere un nuovo server.

    • Selezionate un server esistente e fate clic sul pulsante Modifica server esistente.

  4. Nella schermata Generali, selezionate WebDAV dal menu a comparsa Connetti tramite, quindi compilate le altre opzioni della schermata in base alle esigenze.
  5. Fate clic sul pulsante Avanzate.
  6. Selezionate l'opzione Abilita ritiro file e inserite le informazioni seguenti:
    • Nella casella Nome per ritiro, specificate un nome per identificarsi agli altri membri del team.

    • Nella casella Indirizzo e-mail, inserite il proprio indirizzo e-mail.

      Il nome e gli indirizzi e-mail vengono utilizzati per identificare il proprietario dei file sul server WebDAV e vengono visualizzati nel pannello File come informazioni per contattare l'utente.

  7. Fate clic su Salva.

    Dreamweaver configura il sito per l'accesso WebDAV. Quando utilizza il comando Deposita o Ritira per qualunque file del sito, il file viene trasferito mediante WebDAV.

    Nota:

    WebDAV potrebbe non essere in grado di ritirare correttamente i file con contenuto dinamico, ad esempio con tag PHP o con server-side include, perché il comando HTTP GET ne esegue il rendering al momento del ritiro.

Utilizzare Subversion (SVN) per scaricare e depositare file

Nota:

Il supporto Subversion (SVN) è stato rimosso in Dreamweaver CC 2017 e versioni successive.

Dreamweaver è in grado di connettersi a un server che utilizza Subversion (SVN), un sistema di controllo delle versioni che consente agli utenti di modificare e gestire i file sui server Web remoti in modo collaborativo. Dreamweaver non è un client SVN completo, tuttavia consente agli utenti di scaricare le versioni più recenti dei file, apportare le modifiche e applicare i file.

Nota:

Dreamweaver CS5 usa la libreria client Subversion 1.6.6, mentre Dreamweaver CS5.5 usa la libreria client 1.6.9. Le versioni successive della libreria client Subversion non sono compatibili con le versioni precedenti. Attenzione: se eseguite l'aggiornamento di un'applicazione client di terzi (ad esempio TortoiseSVN) per garantire il funzionamento con una versione successiva di Subversion, l'applicazione Subversion aggiornata esegue l'aggiornamento dei metadati Subversion locali; di conseguenza, Dreamweaver non sarà più in grado di comunicare con Subversion. Questo problema non riguarda gli aggiornamenti apportati al server Subversion, in quanto essi sono compatibili con le versioni precedenti. Se effettuate l'aggiornamento a un'altra applicazione client che funziona con Subversion 1.7 o versioni successive, dovrete verificare se Adobe ha reso disponibili degli aggiornamenti per poter continuare a utilizzare Subversion con Dreamweaver. Per ulteriori informazioni su questo argomento, vedete www.adobe.com/go/dw_svn_en.

Adobe suggerisce di utilizzare uno strumento di confronto di file di terze parti durante il lavoro con file con il controllo delle versioni di SVN. Confrontando i file per verificare le differenze, potete notare il tipo esatto di modifiche apportate ai file da altri utenti. Per ulteriori informazioni sugli strumenti di confronto di file, mediante un motore di ricerca Web, come Google Search, cercate strumenti di tipo “file comparison” o “diff”. Con Dreamweaver potete utilizzare la maggior parte degli strumenti di terze parti.

Per una panoramica video sull'utilizzo di SVN e Dreamweaver, vedetewww.adobe.com/go/lrvid4049_dw.

Impostare una connessione SVN

Per poter utilizzare Subversion (SVN) come sistema di controllo delle versioni con Dreamweaver, dovete impostare una connessione a un server SVN. Per impostare una connessione a un server SVN, utilizzate la categoria Controllo versioni della finestra di dialogo Definizione del sito.

Il server SVN è un archivio di file da cui voi e gli altri utenti potete scaricare e applicare i file. Presenta delle differenze rispetto ai server remoti normalmente utilizzati con Dreamweaver. Quando utilizza SVN, il server remoto resta il server in linea per le pagine Web e la funzione del server SVN consiste nella memorizzazione dei file per i quali desiderate mantenere il controllo versione. Il normale flusso di lavoro consiste nello scaricare e applicare i file da e verso il server SVN e di pubblicarli sul server remoto da Dreamweaver. La configurazione del server remoto è completamente autonoma da quella del server SVN.

Prima di iniziare la configurazione è necessario avere accesso a un server SVN e a un archivio SVN. Per ulteriori informazioni su SVN, vedete il sito Web di Subversion all'indirizzo http://subversion.apache.org/.

Per impostare la connessione a SVN, procedete nel modo seguente:

  1. Scegliete Siti > Gestisci siti, selezionate il sito per il quale configurare il controllo delle versioni e fate clic sul pulsante Modifica.

    Nota:

    se non avete ancora configurato le cartelle locali e remote per un sito di Dreamweaver, prima di procedere dovete almeno impostare un sito locale. Il sito remoto non è necessario in questa fase, ma occorrerà configurarlo prima di pubblicare i file sul Web. Per ulteriori informazioni, vedete Operazioni con Dreamweaver.

  2. Nella finestra di dialogo Configurazione sito, selezionate la categoria Controllo versioni.

  3. Dal menu a comparsa Accesso, selezionate Subversion.

  4. Impostate le opzioni di accesso nel modo seguente:

    • Selezionate un protocollo dal menu a comparsa Protocollo. I protocolli disponibili sono HTTP, HTTPS, SVN e SVN+SSH.

    Nota:

    l'uso del protocollo SVN+SSH richiede una configurazione speciale. Per ulteriori informazioni, vedete www.adobe.com/go/learn_dw_svn_ssh_en.

    • Inserite l'indirizzo del server SVN nella casella di testo Indirizzo server (in genere nel formato nomeserver.dominio.com).

    • Inserite il percorso dell'archivio presente nel server SVN nella casella di testo Percorso archivio (in genere un percorso di tipo /svn/directory_principale; la denominazione della cartella principale dell'archivio SVN spetta all'amministratore del server).

    • Facoltativamente, per utilizzare una porta del server diversa da quella predefinita, selezionate Non predefinita e digitate il numero di porta nella casella di testo.

    • Inserite il nome utente e la password per il server SVN.

  5. Fate clic su Prova per verificare la connessione, oppure su OK per chiudere la finestra di dialogo. Quindi fate clic su Fine per chiudere la finestra di dialogo Gestisci siti.

Quando viene stabilita la connessione con il server, l'archivio SVN è disponibile per la visualizzazione nel pannello File. Per visualizzarlo, selezionate Vista archivio dal menu a comparsa Vista, oppure fate clic sul pulsante File di archivio nel pannello File espanso.

Scaricare la versione più recente dei file

Quando scaricate la versione più recente di un file dall'archivio SVN, Dreamweaver unisce i contenuti di tale file con i contenuti della copia locale corrispondente. In altre parole, se un altro utente ha aggiornato il file dopo l'ultima volta che lo avete applicato, gli aggiornamenti vengono uniti nella versione locale del file presente sul computer. Se il file ancora non esiste sul disco rigido locale, Dreamweaver si limita a scaricare il file.

Nota:

quando scaricate file per la prima volta dall'archivio, è consigliabile lavorare con una directory locale vuota o che non contenga file con lo stesso nome dei file presenti nell'archivio. Con Dreamweaver non è possibile caricare i file dell'archivio sull'unità locale al primo tentativo se questa unità contiene file con nomi corrispondenti a quelli dei file presenti nell'archivio remoto.

  1. Assicuratevi di avere configurato correttamente una connessione SVN.

  2. Effettuate una delle operazioni seguenti:

    • Per visualizzare la versione locale dei file SVN nel pannello File, selezionate Vista locale dal menu a comparsa Vista. Se state lavorando nel pannello File espanso, la Vista locale viene visualizzata automaticamente. Fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) sul file o sulla cartella che vi interessa, quindi selezionate Controllo versioni > Scarica versioni più recenti.

    • Visualizzate i file dell'archivio SVN selezionando Vista archivio dal menu a comparsa Vista nel pannello File, o facendo clic sul pulsante File di archivio nel pannello File espanso. Fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) sul file o sulla cartella che vi interessa, quindi selezionate Scarica ultime versioni.

Nota:

potete inoltre fare clic con il pulsante destro del mouse su un file e scegliere Ritira dal menu di scelta rapida o selezionare il file e fare clic sul pulsante Ritira per ottenere la versione più recente. Tuttavia, poiché SVN non supporta un flusso di lavoro per il ritiro dei file, questa azione non esegue il ritiro del file nel modo consueto.

Applicare i file

  1. Assicuratevi di avere configurato correttamente una connessione SVN.

  2. Effettuate una delle operazioni seguenti:

    • Per visualizzare la versione locale dei file SVN nel pannello File, selezionate Vista locale dal menu a comparsa Vista. Se state lavorando nel pannello File espanso, la Vista locale viene visualizzata automaticamente. Quindi selezionate il file da applicare e fate clic su Deposita.

    • Visualizzate i file dell'archivio SVN selezionando Vista archivio dal menu a comparsa Vista nel pannello File, o facendo clic sul pulsante File di archivio nel pannello File espanso. Quindi fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) sul file da applicare e selezionate Deposita.

  3. Verificate le azioni nella finestra di dialogo Applica, apportate le eventuali modifiche necessarie e fate clic su OK.

    Potete modificare le azioni selezionando il file di cui modificare l'azione e facendo clic sui pulsanti situati nella parte inferiore della finestra di dialogo Applica. Sono disponibili due opzioni: Applica e Ignora.

Nota:

il segno di spunta verde sopra un file nel pannello File indica un file modificato non ancora applicato all'archivio.

Aggiornare lo stato dei file o delle cartelle nell'archivio

Potete aggiornare lo stato SVN di un file o una cartella singola. In seguito a questa operazione la visualizzazione generale non viene aggiornata.

  1. Assicuratevi di avere configurato correttamente una connessione SVN.

  2. Visualizzate i file dell'archivio SVN selezionando Vista archivio dal menu a comparsa Vista nel pannello File, o facendo clic sul pulsante File di archivio nel pannello File espanso.

  3. Fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) su una cartello o un file dell'archivio e selezionate Stato aggiornamento.

Aggiornare lo stato di file o cartelle locali

Potete aggiornare lo stato SVN di un file o una cartella singola. In seguito a questa operazione la visualizzazione generale non viene aggiornata.

  1. Assicuratevi di avere configurato correttamente una connessione SVN.

  2. Per visualizzare la versione locale dei file SVN nel pannello File, selezionate Vista locale dal menu a comparsa Vista. Se state lavorando nel pannello File espanso, la Vista locale viene visualizzata automaticamente.

  3. Fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) su una cartello o un file del pannello File e selezionate Stato aggiornamento.

Visualizzare le revisioni di un file

  1. Assicuratevi di avere configurato correttamente una connessione SVN.

  2. Effettuate una delle operazioni seguenti:

    • Per visualizzare la versione locale dei file SVN nel pannello File, selezionate Vista locale dal menu a comparsa Vista. Se state lavorando nel pannello File espanso, la Vista locale viene visualizzata automaticamente. Quindi fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) sul file di cui volete visualizzare le revisioni e selezionate Controllo versioni > Mostra revisioni.

    • Visualizzate i file dell'archivio SVN selezionando Vista archivio dal menu a comparsa Vista nel pannello File, o facendo clic sul pulsante File di archivio nel pannello File espanso. Quindi fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) sul file di cui visualizzare le revisioni e selezionate Mostra revisioni.

  3. Nella finestra di dialogo Cronologia revisioni, selezionate la revisione o le revisioni che interessano ed effettuate una delle seguenti operazioni:

    • Fate clic su Confronta con locale per confrontare la revisione selezionata con la versione locale del file.

    Nota:

    per poter confrontare file è necessario installare uno strumento di confronto di file di terze parti. Per ulteriori informazioni sugli strumenti di confronto di file, mediante un motore di ricerca Web, come Google Search, cercate strumenti di tipo “file comparison” o “diff”. Con Dreamweaver potete utilizzare la maggior parte degli strumenti di terze parti.

    • Fate clic su Confronta per confrontare due revisioni selezionate. Per selezionare più revisioni, fate clic tenendo premuto il tasto Ctrl.

    • Per visualizzare la revisione selezionata, fate clic su Visualizza. Questa azione non comporta la sovrascrittura della copia locale corrente dello stesso file. Potete salvare la revisione selezionata sul disco rigido locale analogamente a quanto avviene per qualsiasi altro file.

    • Fate clic su Promuovi per rendere la revisione selezionata la revisione più recente contenuta nell'archivio.

Bloccare e sbloccare i file

Bloccando un file nell'archivio SVN potete comunicare agli altri utenti che state lavorando sul file. Il file può essere modificato da altri utenti localmente, ma essi non saranno in grado di applicarlo fino a quando non lo sbloccherete. Quando bloccate un file dell'archivio, sul nome del file viene visualizzata un'icona che raffigura un lucchetto aperto. Gli altri utenti visualizzano invece l'icona di un lucchetto chiuso.

  1. Assicuratevi di avere configurato correttamente una connessione SVN.

  2. Effettuate una delle operazioni seguenti:

    • Visualizzate i file dell'archivio SVN selezionando Vista archivio dal menu a comparsa Vista nel pannello File, o facendo clic sul pulsante File di archivio nel pannello File espanso. Quindi fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) sul file o sulla cartella che vi interessa e selezionate Blocca o Sblocca.

    • Per visualizzare la versione locale dei file SVN nel pannello File, selezionate Vista locale dal menu a comparsa Vista. Se state lavorando nel pannello File espanso, la Vista locale viene visualizzata automaticamente. Quindi fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) sul file o sulla cartella che vi interessa e selezionate Blocca o Sblocca.

Aggiungere un nuovo file all'archivio

Il segno più di colore blu sopra un file nel pannello File indica un file non ancora presente nell'archivio.

  1. Assicuratevi di avere configurato correttamente una connessione SVN.

  2. Nel pannello File, selezionate il file da aggiungere all'archivio e fate clic su Deposita.

  3. Accertatevi che il file sia selezionato per l'applicazione nella finestra di dialogo Applica e fate clic su OK.

Spostare, copiare, eliminare o ripristinare file

  • Per spostare un file, trascinatelo sulla cartella di destinazione nel vostro sito locale.

    Quando spostate un file, Dreamweaver marca il file nella nuova posizione con un contrassegno "Aggiungi con cronologia" e il file nella vecchia posizione con un contrassegno "Elimina". Quando confermate le modifiche ai file (commit), il file nella vecchia posizione viene eliminato.

  • Per copiare un file, selezionatelo, copiatelo (Modifica > Copia) e incollatelo (Modifica > Incolla) nella nuova posizione.

    Quando copiate e incollate un file, Dreamweaver marca il file nella nuova posizione con un contrassegno "Aggiungi con cronologia".

  • Per eliminare un file, selezionatelo e premete Canc.

    Dreamweaver vi permette di scegliere se eliminare solo la versione locale del file oppure sia quella locale che la versione presente sul server SVN. Se scegliete di eliminare solo la versione locale, il file sul server SVN rimane inalterato. Se invece scegliete di eliminare anche la versione presente sul server SVN, la versione locale viene marcata con un contrassegno "Elimina" e dovete confermare l'operazione (commit) affinché il file venga effettivamente eliminato.

  • Per ripristinare un file copiato o spostato riportandolo nella posizione originale, fate clic sul file con il pulsante destro e selezionate Controllo versioni > Ripristina.

Risolvere i conflitti tra file

Se il file entra in conflitto con un altro file presente nel server, potete modificarlo e quindi contrassegnarlo come risolto. Se ad esempio tentate di depositare un file che causa un conflitto con le modifiche di un altro utente, non sarà possibile depositarlo con SVN. Potete scaricare la versione più recente del file dall'archivio, apportare manualmente modifiche alla copia di lavoro in uso e quindi contrassegnare il file come risolto per poterlo applicare.

  1. Assicuratevi di avere configurato correttamente una connessione SVN.

  2. Per visualizzare la versione locale dei file SVN nel pannello File, selezionate Vista locale dal menu a comparsa Vista. Se state lavorando nel pannello File espanso, la Vista locale viene visualizzata automaticamente.

  3. Fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) sul file che desiderate risolvere, quindi selezionate Controllo versioni > Indica come risolto.

Operazioni non in linea

Può risultare passare alla modalità non in linea per evitare l'accesso all'archivio durante le altre attività di trasferimento file. Dreamweaver si ricollega all'archivio SVN non appena richiamate un'attività che richiede una connessione (Scarica ultime versioni, Applica ecc.).

  1. Assicuratevi di avere configurato correttamente una connessione SVN.

  2. Per visualizzare la versione locale dei file SVN nel pannello File, selezionate Vista locale dal menu a comparsa Vista. Se state lavorando nel pannello File espanso, la Vista locale viene visualizzata automaticamente.

  3. Fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) su qualsiasi file o cartella nel pannello File, quindi selezionate Controllo versioni > Vai offline.

Ottimizzare un sito SVN locale

Questo comando consente di rimuovere blocchi su file per potere riprendere operazioni con completate. È consigliabile utilizzarlo per rimuovere blocchi precedenti in caso di errori che indicano che la copia di lavoro è bloccata.

  1. Assicuratevi di avere configurato correttamente una connessione SVN.

  2. Per visualizzare la versione locale dei file SVN nel pannello File, selezionate Vista locale dal menu a comparsa Vista. Se state lavorando nel pannello File espanso, la Vista locale viene visualizzata automaticamente.

  3. Fate clic con il pulsante destro del mouse (Windows) o fate clic tenendo premuto il tasto Ctrl (Macintosh) sul file che desiderate ottimizzare, quindi selezionate Controllo versioni > Ottimizza.

Spostamento di file e cartelle nei siti controllati di Subversion

Quando spostate le versioni locali dei file in un sito controllato da Subversion, correte il rischio di creare problemi agli altri utenti che stanno eventualmente eseguendo la sincronizzazione con l'archivio SVN. Ad esempio, se spostate un file localmente e non lo applicate all'archivio per qualche ora, un altro utente potrebbe tentare di scaricare la versione più recente del file dalla posizione non aggiornata del file. Pertanto, è consigliabile applicare sempre i file nel server SVN immediatamente dopo averli spostati localmente.

I file e le cartelle rimangono sul server SVN finché non vengono eliminati manualmente. Di conseguenza, anche se spostate un file in una cartella locale diversa e lo applicate, la vecchia versione del file rimane nella posizione precedente sul server. Per evitare confusione, eliminate le copie non aggiornate dei file e delle cartelle spostate.

Quando spostate un file localmente e lo applicate al server SVN, la cronologia delle versioni del file viene persa.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online