Apart from the features listed in What's New in Premiere Pro CC June 2013 (version 7.0), Adobe® Premiere® Pro CC includes many other useful features.

Here is a list of the new features in Premiere Pro CC, categorized by work area:

Editing and Timeline-related

Add or delete a track using context menu commands

You can add or delete a single track with a context menu command. Right-click (Windows) or Control-click (Mac OS) in the track header area and select Add Track or Delete Track. This command is in addition to the previous commands Add Tracks and Delete Tracks, which opens a dialog box for adding and deleting multiple tracks.

Toggle tool tips on or off

A Show Tool Tips preference is available in the General Preferences dialog box to turn tool tips on or off.

Command to enable or disable video preview through Mercury Transmit

You can assign a keyboard shortcut to toggle video preview through Mercury Transmit on and off. To do so, select Edit > Keyboard Shortcuts. In the Keyboards Shortcuts dialog box, select Enable Transmit, and assign a keyboard shortcut.

Double-click to expand or collapse tracks in the Timeline

Double-click in the empty area to the right of the Timeline track header buttons. You can increase the size of this target by dragging the header divider to the right.

New Timeline Track Height presets

New Timeline Track Height presets are now available from the Presets browser.

Automatically import an exported frame or movie into a project

The Import Into Project option lets you automatically import an exported frame or movie back into the current open project. The following export options are supported:

  • Still frame export
  • Direct export
  • Queued export (using Adobe Media Encoder)

Video tutorial: Import directly into the Project panel

Video tutorial: Import directly into the Project panel
Learn how you can use the Import into Project option to export media assets or clips and sequences to a hard drive and have them show up immediately in the Project panel.
Jeff Sengstack

Media Browser browses through Premiere Pro project files

Use the Media Browser to browse through your Premiere Pro project file (.prproj), and access all the bins, sequences, and clips contained in the project. You can also hover-scrub the clips, and import a bin, clip, or sequence.

Copy command enhanced to operate on a range in a sequence

The existing Copy command (Edit > Copy, Ctrl+C (Windows), Command+C (Mac OS)) is enhanced when used in the Timeline panel. If there are no clips or keyframes selected, and an In Point or Out Point is set, then the range of time between the In point and Out point is copied to the clipboard.

Customizable number of Undo levels

In the History panel's pop-up menu, you can choose a custom number of Undo steps, from 10 to 100.

Keyboard shortcuts to move clips in the Program Monitor (modifying Position property)

When you are in direct-manipulation mode in the Program Monitor (the mode in which you can drag the clip to position it spatially), you can use the arrow keys to modify the clip's Position property. Each press of an arrow key moves the clip 1 pixel in the corresponding direction. Holding Shift makes each press of an arrow key move the clip 10 pixels.

Hard and soft subclips are now available

Hard subclips prevent accidental trimming into media outside the subclip boundaries. Soft subclips allow trimming to any portion of the original master clip's media.

Earlier, subclips had “hard” in- and out-points, limiting flexibility when you needed more head or tail frames for video cross-dissolves or audio crossfades. You can now create subclips with “soft” edits in Premiere Pro, meaning you are no longer limited to the original in- and out-points in the subclips.

For more information, see this video:

Video: Create soft subclips with flexible edit points

Video: Create soft subclips with flexible edit points
Jeff Sengstack

Customizable Timeline

The Timeline is customizable, including show/hide markers, effects, through edits and duplicate frame markers.

Out-of-sync indicators for audio and video

Out-of-sync indicators now appear for audio and video when they are unlinked and moved out of sync

Insert and Overwrite sequences as nests or individual clips

You can now insert or overwrite sequences as nests or individual clips.

Marker search

You can now search markers in the Marker panel. Go to Next/Previous clip marker in the Timeline. The Next/Previous Marker commands now navigate to both sequence and clip markers in the Timeline.

Set Marker duration

To quickly set the Marker duration, Alt-click (Win) or Option-click (Mac) a Marker icon in the Source Monitor, Program Monitor, or Timeline. A duration of one frame is set. You can adjust the frame duration by clicking and dragging the handles on either sides of the frame.

Setting Marker duration in the Program Monitor
Setting Marker duration in the Program Monitor

Transitions and effects

Clip Name Effect

The new Clip Name effect renders the clip name in the program, with position, size, and transparency as specified in the effect's controls. This effect is GPU-accelerated.

GPU-accelerated Wipe and Slide transitions

The Wipe and Slide video transitions are accelerated by the GPU when you are using a GPU video card that Premiere Pro CC uses for CUDA or OpenCL processing.

Render Selection command to render selected clips

Select Sequence > Render Selection to render a preview file for the duration between the In point of the first selected clip to the Out point of the last selected clip.

Trim transitions symmetrically

Dragging the edge of a transition now trims it symmetrically on each side of the cut point. To trim only one side, hold down the Shift key as you drag.

New Edge Feather effect during Crop

The Crop function in the Effects Control panel (Window > Effect Controls) now has an Edge Feather feature that provides a feathered edge effect to the cropped video. From the Effect Controls panel, click the Edge Feather button under Crop and enter a value for the feather effect.

The edges of the cropped video display a feather effect:

Edge Feather Crop Effect
Before and After applying Edge Feather Crop effect

Audio

Switch between video and audio waveforms in the Source Monitor

To view the audio waveform for your clip in the Source Monitor panel, click the Drag Audio Only button at the bottom. Click the Drag Video Only button to switch back to the video view.

Context menu command for showing audio time units

Right-click (Windows) or Control-click (Mac OS) in a time ruler and select Show Audio Time Units to enable or disable display of audio time units.

Commands for increasing and decreasing clip volume

The following commands have entries in the Keyboard Shortcuts dialog box:

  • Increase Clip Volume (by 1 dB)
  • Increase Clip Volume Many (by 6 dB)
  • Decrease Clip Volume (by 1 dB)
  • Decrease Clip Volume Many (by 6 dB)

New Rectified audio waveform

The new Rectified Audio Waveform feature provides you another way of viewing an audio waveform:

Rectified audio waveform and Standard audio waveform
Rectified audio waveform and Standard audio waveform

The Rectified Audio Waveform option is turned on by default. You can turn it off by deselecting Rectified Audio Waveforms in the Timeline panel's pop-up menu.

Rectified Audio Waveform
Rectified Audio Waveform option in the Timeline pop-up menu

 

Other enhancements

  • Audio output mapping preferences for Mercury Transmit
  • Audio waveforms generated for nested sequences
  • Keyboard shortcuts to change pan values
  • Ability to open an audio plug-in effect dialog from clips in a sequence
  • Ability to toggle audio on and off during scrubbing

Exporting

Smart rendering improvements

Export performance for QuickTime files such as Pro-Res 422 has been accelerated.

QuickTime audio export with individual tracks

When exporting multi-channel master sequences, the Export Media dialog's Audio Channel setting changes to a pop-up menu that allows you to select audio channels to be included in the export.

16-bit DPX support

16-bit DPX support has been added to Premiere Pro CC.

Project Management

Custom location for Auto-save folder

In the Scratch Disks tab of the Project Settings dialog box and New Project dialog box, there is a Project Auto Save control. You can use this control to specify the location of the Auto-save folder. The default setting is Same As Project.

Preference to skip the Welcome screen when launching Premiere Pro

In the General preferences category, you can select Show Welcome Screen or Open Most Recent from the At Startup pop-up menu. If the preference is set to Open Most Recent, the last project in use is reopened. If the last project in use cannot be located (for example, because it's been deleted), then the Welcome screen is opened.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy