Update to Premiere Pro CC available

For more information, see the New features summary.

This document describes the new and changed features in the June 2013 release of Premiere Pro CC.


IMPORTANT: Apart from the features listed in this article, the Premiere Pro CC June release includes several useful features that help you be more productive when using Premiere Pro. For more information, see New features in Premiere Pro CC June 2013 (version 7.0).

Premiere Pro CC new features overview

Premiere Pro CC new features overview
Watch Al Mooney take you on a tour of the new features of this release.
Al Mooney

Sync Settings using Adobe Creative Cloud

The new Sync Settings feature enables users to sync their preferences, presets, and settings to the Creative Cloud.

If you use Premiere Pro on multiple machines, the Sync Settings feature makes it easy for you to keep those settings synchronized across the machines. The syncing happens via your Adobe Creative Cloud account. All the settings are uploaded to your Creative Cloud account, which can be downloaded and applied on the other machine.

For more information, see Sync settings in Premiere Pro CC.

Adobe Anywhere integration

Adobe Anywhere lets video teams effectively collaborate and access shared media across standard networks. You can you use local or remote networks to simultaneously access, stream, and work with remotely stored media. Heavy file transfers, duplicate media, and proxy files are not required.

To use Adobe Anywhere in Premiere Pro, select File > Adobe Anywhere > Sign In. Enter the required information in the Adobe Anywhere Sign In dialog box.

For more information, read about Adobe Anywhere for Video, or watch this video:

Adobe Anywhere: An Introduction

Adobe Anywhere: An Introduction
Learn how Adobe Anywhere works in this short explainer video.
Adobe TV

User Interface improvements

High-resolution viewing and improved overall user experience

Premiere Pro now provides HiDPI support for an enhanced viewing experience with a high-resolution user interface. HiDPI displays are available on the newest monitors like Apple’s Retina Mac computers, including the new MacBook Pro models.

Other improvements to the user interface include:

  • Improved title and action-safe guides
  • Switching between video and audio waveforms with one click
  • Toggling tool tips on and off
Enhanced viewing experience with HiDPI support
Enhanced viewing experience with HiDPI support

A. View video or audio in one-click B. Enhanced titling and action-safe guides 

Redesigned Timeline with customizable track headers

Premiere Pro now has a redesigned Timeline panel that is customizable, letting you choose what to display, and lets you have immediate access to controls.

You can now work more quickly and efficiently with track controls for volume and pan, recording, and audio metering.

Redesigned Premiere Pro Timeline
Redesigned Timeline

The track headers in the Timeline panel are now customizable, allowing you to determine which controls are displayed. Since the controls are different for the video and audio tracks, there are separate Button Editors for each track type.

Right-click a video or audio track and select Customize. Then drag-and-drop buttons as required. For example, you can select the Track Meter control and drag it into your audio track.

You can easily edit source sequences into other sequences without nesting. You can also copy effects from one clip to another with enhanced paste attributes.

Relinking offline media

You can often move, rename, or transcode files to different formats. Premiere Pro helps you locate and relink such files with the new Link Media dialog box.

Locating missing media
A. Locate missing media 

When you open a project containing offline media, the Link Media dialog provides information like filename, last known path, and metadata properties. Using all this information, Premiere Pro lets you quickly locate and relink the media, bringing them back online for use in your project.

For more information, see Relinking offline media.

Duplicate frame detection

Premiere Pro identifies clips that are used in a timeline more than once in the same sequence by displaying duplicate frame markers. A duplicate frame marker is a colored stripe indicator that runs across the bottom of a clip for each duplicated frame.

To turn on duplicate frame markers, Click Timeline Display Settings, and select Show Duplicate Frame Markers.

Show duplicate frame markers
Show duplicate frame markers


Premiere Pro assigns a color automatically to each master clip that has a duplicate clip. Up to ten different colors are assigned. After ten colors are used, the tenth color is reused.

For example, say, you've used multiple cameras to shoot a sporting event. You may use different shots of the crowd all through the show. If you use the same crowd shot more than once, then duplicate frame detection alerts you to the duplicate clip by displaying a colored stripe across it.


Duplicate frame markers are not available for still images and time remapping.

Video: Detect duplicate frames automatically

Video: Detect duplicate frames automatically
Learn more about how the Duplicate Frame detector uses a color code to identify clips or frames used more than once in a project.
Jeff Sengstack

Closed Captioning

You can now work with closed caption text within Premiere Pro without the need for separate Closed Captioning authoring software.

Closed Captioning tools in Premiere Pro
Closed Captioning tools in Premiere Pro

A. Display closed captions with content B. See captions on the Timeline 

You can import Closed Caption text, link it to the appropriate clips, edit the text, and adjust durations in the timeline from within Premiere Pro. When you're done, export your sequence to tape, or to Adobe Media Encoder, with embedded closed captions or as a separate Sidecar file.

For more information about working with closed captions in Premiere Pro, see Closed Captioning.

Editing finesse enhancements

Video: Editing finesse enhancements in Premiere Pro CC

Video: Editing finesse enhancements in Premiere Pro CC
Learn more about the editing finesse enhancements that include a redesigned Timeline, intuitive track targeting, and dozens of new shortcuts.
Al Mooney

Auto-sync multiple camera angles

The new Multicamera mode displays the multicamera editing interface inside the Program Monitor. You can create ready-to-edit sequence from clips shot from different angles with multiple cameras or from different takes of a particular scene.

You can use the Create Multi-Camera Source Sequence option to combine clips that have common In or Out points or overlapping timecode into a multicamera sequence. You can create a multicamera source sequence from a bin of clips. When creating a multicamera sequence, there is now an Offset Audio By control, with a range of -100 to +100 frames.

For more information, see Create multi-camera source sequence.

Create Multi-Camera Source Sequence
Use the Create Multi-Camera Source Sequence option to automatically match multiple camera angles

Auto-sync clips using audio waveforms

Premiere Pro also lets you can merge clips by using audio waveforms. You can use audio recorded from a second source to automatically sync and create multicamera and merged clips using audio waveforms.

Video: Merge clips automatically using audio waveforms

Video: Merge clips automatically using audio waveforms
Learn to use Premiere Pro's audio waveform auto-sync feature to automatically align and merge clips in Project panel, in the timeline, and when setting up a multicam project.
Jeff Sengstack

Source Patching and Track Targeting

Source patching and track targeting has been redesigned for faster and more efficient editing. You can now patch sources for insert and overwrite editing, or targeting tracks for Copy/Paste, Match Frame, and other edit operations in just a single click.

You can create presets for common patching scenarios, letting you reconfigure the Timeline with a single command.

For more information, see Source patching and track targeting.

Edit unnested sequences into destination sequences

You can now edit source sequences into other sequences, keeping the original source clips and track layout intact. This feature lets you use segments of other sequences containing individual source clips, edit points, transitions, and effects, much like copy/paste.

A "Nest Source Sequence" toggle command lets you toggle between nested and unnested behavior. The "Nest Source Sequence" toggle command is available from the Timeline header's source indicators context menu.

For more information, see Edit from sequences loaded into the Source monitor.

Join Through Edits

You can now join through edits in your clips using the new Join Through Edits feature.

In the Timeline panel, select the edit points in your clip that you want to join. Then, right-click (Win) or Ctrl-click (Mac) the selected edit points and select Join Through Edits from the context menu.

Through edit indicators are displayed on extraneous edits that do not cause a break in the original frame sequence of the clip. When you use Join Through Edits for a through edit, Premiere Pro heals the cut and recreates a longer clip from the contiguous parts.

Snapping Razor tool

You can now snap the playhead to items when you drag it over the Timeline. When snapping is enabled, the Razor tool is selected, and the cursor snaps to any snapping target including the playhead.

To use the multi-razor tool over all tracks, press the Shift key. To ignore track items, press the Alt key (Windows) or Option (Mac OS).

New Snap Playhead preference

Snap Playhead In Timeline When Snap Is Enabled is a new preference option that controls the behavior of the playhead when scrubbing. When you select this preference, the playhead snaps to every edit point.

This preference option is available under the General preferences category in the Preferences dialog box.

Naming nested sequences

When you create a nested sequence with the Timeline's Nest command, the Nested Sequence Name dialog box appears. You can enter a name of your choice for the nested sequence.

To use the Nested Sequence command, right-click (Win) or Ctrl-click (Mac) a clip in the Timeline panel and choose Nest from the context menu.

Trim-to-zero duration

Trim a clip to zero duration using the keyboard or mouse. For more information, see this video tutorial by Josh Weiss.

Enhanced Paste attributes

The Paste Attributes dialog box lets you easily add and move audio and visual effects across multiple clips.

Video Attributes

After copying a clip containing effects, the dialog box lets you select which effect you want to paste into the destination clip selected in the Timeline.

If the video or audio clips have any additional user-applied effects, these effects are also available for selection. You can select a group of effects or specific effects.

For more information, see this video tutorial.

Playhead moves to edit point after a ripple-delete

When you ripple-delete clips in the Timeline panel, the playhead automatically moves to the beginning of the edit point, instead of remaining in place. You can immediately replace the edit without having to first reposition the playhead.

Audio enhancements

Video: Audio enhancements in Premiere Pro CC

Video: Audio enhancements in Premiere Pro CC
Learn more about the new Audio Clip Mixer, improved multicam editing, sync footage using audio waveforms, and more.
Al Mooney

Renamed Audio Mixer panel

The Audio Mixer panel is now renamed the Audio Track Mixer. This name change helps you distinguish the Audio Track Mixer from the new Audio Clip Mixer panel.

Audio Track Mixer
Audio Track Mixer

The pop-up menu in the Audio Track mixer is redesigned to display the audio plug-ins in categorized subfolders for a faster selection.

Enhanced Timeline track header

A horizontal Audio meter is now available in the audio track headers.

Audio Meter
Audio Meter

Two new controls are available in the Timeline's customizable track header area to adjust the pan and track volume for audio tracks.

Multiple stereo assignments for tracks to multichannel masters

You can now assign a mono or standard track to multiple pairs of channels in a multichannel master. In the panner assignment dialog, set the stereo channel pairs you want to assign to a track.

New Clip Mixer panel

The Audio Clip Mixer lets you monitor and adjust the volume and pan of clips in sequence when the Timeline panel is in focus. Similarly, when the Source Monitor panel is in focus, the Audio Clip Mixer lets you monitor clips in the Source Monitor.

Audio Clip Mixer
Audio Clip Mixer

To access the Audio Clip Mixer, choose Window > Audio Clip Mixer from the main menu.

For more information, see Monitor clip volume and pan using Clip Mixer.

Audio waveform changes

Audio waveforms now appear similar to the waveforms in Adobe Audition. In addition, Audio waveforms now appear in nested sequences. You can return to standard audio waveforms in the panel menu.

You can also use a label color for your audio waveforms. In the Timeline panel, select Audio Waveforms Use Label Color.

New Audio Plug-ins manager and audio plug-ins

The Audio Plug-ins manager is available to work with your audio effects. You can access the Audio Plug-In Manager menu from the Audio Track Mixer and Effects panels. You can also access the  Audio Plug-In Manager from the Audio Preferences dialog.

Premiere Pro now supports third-party VST3 plug-ins. On the Mac, you can also use Audio Units (AU) plug-ins.

Multi-channel QuickTime export

When exporting multi-channel master sequences, the Export Media dialog's Audio Channel setting changes to a pop-up menu. This menu lets you select the channels to be included in the export.

Control surface support

Premiere Pro now lets you interactively mix audio with control surfaces that use the EUCON and Mackie protocols. You can also use third-party tablet-based controllers that support these protocols.

To connect your controller to Premiere Pro, select Control Surface in the Preferences dialog box. Choose the controller protocol from the Device Class menu.

Use the faders, knobs, and buttons on these devices to control Track Mixer faders and parameters, such as track pan and balance. You can connect supported devices, such as Avid MC Artist and Mackie XT and assume control of the Track Mixer.

For more information, see Control surface support.

Color-related enhancements

Integration of Lumetri Deep Color Engine

Premiere Pro now includes the Lumetri Deep Color Engine. You can instantly apply SpeedGrade .look files and pre-made Lookup Tables (LUTs) to your sequences from within Premiere Pro.

Use the new integrated Looks browser in the Effects panel to apply preset color grading effects, or to locate exported .looks from SpeedGrade or LUTs from other systems.

For more information, see Apply SpeedGrade color-correction within Premiere Pro.

The Looks Browser in Premiere Pro
The Looks Browser integrated in Premiere Pro

Extending the power of Adobe Premiere Pro

Adobe Story panel

The new Adobe Story panel in Premiere Pro lets you import scripts created in Adobe Story, along with associated metadata to guide your editing.

You can quickly navigate to specific scenes, locations, dialogue, and characters as you work. You can use Speech To Text search to find the clips you need and edit to the script within the Premiere Pro editing environment.

For more information, see Script-based video editing with Adobe Story.

Adobe Exchange panel

The Adobe Exchange panel integrated with Premiere Pro lets you easily browse, install, and find support for the latest plug-ins and extensions.

Select Window > Extensions > Adobe Exchange to open the Adobe Exchange panel. You can find both free and paid extensions.


New and changed keyboard shortcuts

Select next and previous clips in a sequence

The Select Next Clip and Select Previous Clip keyboard shortcuts let you quickly navigate relative to the current clip selection and select an adjacent clip in the sequence.

Select clips under playhead or within In-Out range

To provide two slightly different keyboard-driven workflows, there are two new keyboard shortcuts for selecting clips in the sequence: Select Clip at Playhead and Select In to Out.

Move selected clips to different tracks

Use the Nudge Clip Selection Up and Nudge Clip Selection Down keyboard shortcuts to move selected clips up or down to different tracks.

For the complete list of available keyboard shortcuts, see Keyboard shortcuts in Premiere Pro CC.

Other changes

GPU processing changes

You can now enable OpenCL or CUDA processing on any card that meets minimum requirements (1-GB RAM, basic shader tests).

CUDA support for NVIDIA Kepler 2000 and 4000 Dual GPU support for NVIDIA cards for export performance enhancement are now available.

OpenCL processing is now available on Windows for cards that meet the basic requirements.

Support for mezzanine codecs, native formats

Industry-standard mezzanine codecs and native video formats, such as the following, are now available within Premiere Pro:

  • Native MXF-wrapped DNxHD
  • Apple ProRes (decode only on Windows)
  • Sony XAVC
  • Panasonic AVCi200

Enhanced import/export workflows for Avid and Final Cut Pro projects

You now have an enhanced and improved workflow when importing or exporting Avid or Final Cut Pro projects. You can import AAF projects with much higher fidelity, and with support
for more video formats, including DNxHD.

Expanded format support

Expanded format support
Watch Rich Harrington demonstrate Premiere Pro's expanded format support.
Rich Harrington

Export to Tape (Serial Device)

When a serial device is connected, you can export your edited sequence onto videotape directly from your computer, for example, to create a master tape. To do so, select File > Export > Tape (Serial Device).


The Export to Tape (Serial Device) feature requires a third-party SDI tape export solution. Premiere cannot natively export to tape using Serial Device control.

For information about the many other new features, see New features in Premiere Pro CC.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy