Update to Premiere Pro CC available

For more information, see the New features summary.


This document describes the new and changed features in the Premiere Pro CC October 2013 release:

Video: New features overview by Al Mooney

Video: New features overview by Al Mooney
Al Mooney

Direct-Link workflow between Premiere Pro and SpeedGrade

The new Direct-Link feature provides a tighter and more efficient workflow between Premiere Pro and SpeedGrade.

Using Direct Link, you can send or open a Premiere Pro project directly in SpeedGrade, apply color grading, and send it back to Premiere Pro. The Direct-Link workflow eliminates the need to export and import projects, deal with interchange formats, or any kind of file conversions.

For more details, see Direct-Link workflow between Premiere Pro and SpeedGrade.

Editing finesse enhancements

Render multiple sequences

This feature was voted the Just Do It (JDI) feature at IBC 2013. See this video for more information about JDI features.

Premiere Pro now lets you render multiple sequences at once instead of doing it one at a time. In the Project panel, select the sequences that you want to render, and select Sequence > Render Effects In Work Area.

For more information about how to render a sequence, see Rendering and previewing sequences.

Ripple Sequence Markers

In earlier versions of Premiere Pro, sequence markers were fixed on your timeline. When you deleted a part of a clip and closed the gap using ripple-delete, or inserted a clip using insert-edit, your markers wouldn't move with the clip.

Premiere Pro now lets you use Ripple Sequence Markers to let your markers ripple upstream or downstream when cutting or trimming in your timeline. For example, after an insert-edit, any sequence markers after the insertion point ripple downstream. Similarly, after a ripple-delete, any sequence markers after the last deleted frame ripple upstream.

To turn on or off Ripple Sequence Markers, select Marker > Ripple Sequence Markers.  

Improvements to sequence markers

The following improvements have been made to sequence markers:

  • In previous versions of Premiere Pro, when you clicked a marker, the playhead automatically jumped to a marker's location. Premiere Pro now lets you move the playhead to a different location on the Timeline, and then drag the marker to snap to it.
  • While dragging a marker in the Timeline, you can watch a preview of the clip in the Program Monitor to show where you are dragging the marker to.

Back button added to Media Browser

The Media Browser provides a Back button that lets you quickly go to the previous directory that you browsed through.

You can click the Back button several times to easily navigate through a complex directory structure.

Premiere Pro Media Browser

Sequences displayed as thumbnails in Icon view

Premiere Pro now displays sequences as thumbnails in the Icon view. Earlier, to view a sequence, you opened the sequence in the Timeline or in the Source Monitor.

Like for other media, the Hover Scrub feature is available even for sequences displayed in the Icon view. That is, when you place your cursor over a sequence icon, the clip plays backwards or forwards as you drag your mouse.

Sequences as thumbnails in Icon view

End Of Media Indicator

When the playhead goes past the last frame of media on the Timeline and there is no clip after that, a black frame appears along the right edge of the last frame of a clip or sequence.

The End Of Media Indicator is always turned on, and appears for media clips in the Program Monitor, Source Monitor, and the video area of the Project panel.

End of Media indicator
A. End of Media indicator 

Add Edit command overrides track targeting

When you use the Add Edit command, the command overrides track targeting and applies the command to all selected clips under the playhead. With this enhancement, you don't have to target each track individually to get the desired result.

Edit-to-Tape dialog supports J, K, L keyboard playback shortcuts

Premiere Pro now supports J, K, and L playback keyboard shortcuts in the Edit To Tape dialog.

Select File > Export > Tape (Serial Device) to open the Edit To Tape dialog. You can press the J, K, and L keys to control the playback. J rewinds the playback, L fast forwards it, and K pauses it. The speed of forward or reverse increases each time you press J or L.   

Increased playback speed for J, K, L keyboard shortcuts

J, K, L playback keyboard shortcuts now provide faster speeds of 1x, 2x, 4x, 8x, 16x, and up to 32x.

Note:

Playback performance may vary depending on hardware, video frame resolutions, and video codecs.

Set negative speed values for reverse playback

To play clips backward, you can now enter negative speed values in the Clip Speed/Duration dialog.

  1. In a Timeline panel or Project panel, select one or more clips.
  2. Right-click (Windows) or Control-click (Mac OS) the clip, and select Speed/Duration.
  3. In the Clip Speed/Duration dialog box, enter a negative speed value. For example "-50".

When you enter a negative speed value, the Reverse Speed checkbox gets selected automatically.

Channel layout selection during QuickTime export

While exporting QuickTime movies with sound media, Premiere Pro lets you select 5.1 or 8 audio channel layouts contained in the QuickTime movies.

  1. In the Export Settings dialog, select the Audio tab.
  2. Under Channel Layout, the channel order metadata is displayed. You can select the channel layouts that you want to export.

Note:

To be able to select the channel layouts to export, ensure that you set Audio Codec to Uncompressed, and Audio Track Layout to 5.1 or 8 channels. Otherwise, the Channel Layout shows as "Unlabeled".

New metadata columns

Premiere Pro now lets you display two new columns of metadata in the Project panel:  

  • Sound TimeCode 
  • Sound Roll

To display these columns, open the Metadata Display dialog by selecting Metadata Display from the Project panel menu. Select the check boxes next to Sound Roll and Sound TimeCode.   

Video: Top features in Premiere Pro CC October 2013 release

Video: Top features in Premiere Pro CC October 2013 release
Josh Weiss

Transitions and effects

New options for Clip Name effect

The Clip Name effect now provides different options to label clips and display them on screen. You can display the sequence name, project name, or filename by selecting from these options:

  • Sequence Item Name
  • Project Item Name
  • File Name
Display Sequence Item Name

Timecode effect enhancements

The Timecode effect automatically matches the Time Display parameter (or timebase) to the source clip.

Copy and paste transitions to multiple edit points

You can add a transition quickly to several edit points within your sequence by copying and pasting the transition. This feature is helpful if you’ve changed a transition’s default settings and want to use the modified transition again.  

  1. With the transition selected in the Timeline, copy the transition by selecting Edit > Copy or the keyboard shortcut Ctrl+C (Win) or Cmd+C (Mac).
  2. Select multiple edit points in the sequence by dragging a marquee around the edit points, or by using the Shift key with any trim tool.
  3. Paste the transitions by selecting Edit > Paste, or by using the keyboard shortcut Ctrl+V (Win) or Cmd+V (Mac).

Some important points:

  • If you paste a transition without selecting edit points, the transitions are pasted to edit points at or near the playhead, without overriding track targeting.
  • If a selected edit point already has a transition, and:
    • if the pasted transition is different from the existing one, then the transition type changes but preserves the existing transition's duration and alignment. For example, pasting a Cross Dissolve transition over a Barn Door transition.
    • if the pasted transition is the same as the existing transition, then the duration and alignment are changed. For example, both are Cross Dissolve transitions.
  • A copied transition’s alignment is preserved if it's set to one of the presets, but not if it has a custom setting.

Individual Reset buttons for Effect parameters

You can now reset specific parameter values of an effect without resetting the other parameter values.

In the Effects panel, each parameter value has a Reset Parameter button that you can use to reset the parameter to the default value.

To reset all the parameter values in an Effect, click the Reset Effect button next to the effect name.

Reset parameter values
A. Reset Effect B. Reset Parameter 

Metadata display in Monitor Overlays

Premiere Pro lets you display metadata of your choice as overlays in the Program monitor and Source Monitor.

You can display the following metadata as overlays:

  • Source clip timecode
  • Edit point indicators
  • Media Limit indicators
  • Marker comments
  • Other metadata, like clip name, multi-camera angle, and sequence timecode

You can turn overlays on or off by selecting Overlays from the pop-up menu in the Program Monitor or Source Monitor. The Overlay Settings dialog lets you specify the display of overlays, which you can customize and apply as overlay presets.

For more information on using overlays, see Monitor Overlays.

Closed Captioning enhancements

Include embedded captions on project import

If your project contains files with embedded closed captions, Premiere Pro imports the closed caption data into the project. To detect and import embedded closed caption data in an embedded closed caption file, select the preference to import the closed caption data into your project. In the Preferences dialog, under Media, select the Include Captions On Import check box.

One-time scanning of embedded Closed Caption data  

When working with closed captions, Premiere Pro optimizes performance by scanning the media file for closed caption data only for the first time you open that file. Premiere Pro does not rescan for closed caption data when you open that file later.

Note:

For QuickTime movie files (.MOV) with embedded closed captions, Premiere Pro rescans the file every time you open the file.

Support for captions in MXF files

Premiere Pro supports reading and writing captions for MXF OP1a files. The captions are read from and written to the SMPTE 436M ancillary data track in the MXF OP1a file.

Support for CEA-708 captions

Premiere Pro supports importing and exporting CEA-708 captions. CEA-708 closed caption files can be exported as a Sidecar file with a .mcc or .xml filename format. Or you can embed the CEA-708 captions within the SMPTE 436M ancillary data track in MXF OP1a files.

Enhanced support for embedded captions in QuickTime Movies

Earlier, support for reading embedded captions in QuickTime movies was limited based on the video codec. For example, MPEG-2 and H.264 video codecs were not supported. Now, Premiere Pro reads captions in QuickTime movies regardless of the video codec used.

Support for DFXP files

Premiere Pro now lets you import caption files with a *.dfxp filename extension.

Note:

DFXP caption files are XML-based files. So besides viewing the captions in the Captions panel, they are also viewable from a text editor.

 

For more information on using Closed captions, see Closed Captioning workflow in Premiere Pro.

Multi-Camera workflow improvements

Multi-Camera improvements in Premiere Pro CC

Multi-Camera improvements in Premiere Pro CC
Discover new features that make multi-camera editing easier than ever with Adobe Premiere Pro CC
Maxim Jago

Display camera angles as track names or clip names

When creating a multi-camera source sequence, you can display the camera names as clip names or track names. These options are available in addition to the default option of enumerated camera names like camera 1, camera 2, and so on.

The options are available in the Create Multi-Camera Source Sequence dialog box under Camera Names.

Multi-Camera Source Sequence options

Depending on the Camera Names option that you select, the camera angles are displayed as track names, clip names, or camera numbers in the Source Monitor. To view the multi-camera sequence in the Source monitor, right-click the sequence and select Multi-camera.

Camera angles displayed as clip names in the Source Monitor
Camera angles displayed as clip names in the Source Monitor

Organize and select camera angles to view in monitor's multi-camera mode

Premiere Pro lets you organize and select the angles to view in the Source Monitor's multi-camera mode.  

From the Source monitor's pop-up menu, select Edit Cameras.

In the Edit Cameras dialog box, all the clips are listed in the original order that they were arranged in the sequence tracks. You can drag-and-drop the clips to change the sequence order. You can also enable or disable the clips by selecting or deselecting them.

Multi-Camera Viewing Mode displays full playback on the Program monitor

The Program monitor's Multi-Camera Viewing Mode now displays a fully composited output like the regular playback mode. The Multi-Camera mode can display any applied effects during playback.

Quick multi-camera editing based on sync timecode

Premiere Pro lets you perform quick multi-camera edits based on sync timecode.

Press the modifier key Ctrl (Win) or Cmd (Mac) while switching source clips to match frame to the timecode at the current playhead position.

Import Multiclip sequences from Final Cut Pro

You can export a Multiclip project from Final Cut Pro, and import the Final Cut Pro project XML files into Premiere Pro. In Premiere Pro, the Multiclips sequences appear as multi-camera sequences with all the Final Cut Pro project settings intact.


For more information on the mult-camera workflow, see Multi-Camera editing workflow.

Support for new camera formats

File formats supported for import

Premiere Pro supports importing the following new camera formats:

  • Apple ProRes 64-bit
  • Blackmagic Cinema DNG
  • Native MJPEGs (1DC)
  • RED DRAGON with ROCKET-X
  • Panasonic AVC Ultra Long GOP (Group of Pictures)
  • Phantom Cine
  • Sony RAW (F65, F55, F5, FS700)
  • Sony XAVC Long GOP  

Some important points:

  • You can import uncompressed Cinema DNG files from Blackmagic Cinema Cameras directly into Premiere Pro. You can select multiple Cinema DNG files as one clip and import them as unified A/V clips.
  • Once you import the Cinema DNG files into Premiere Pro, you can use the Media browser to view thumbnails, scrub, or hover-scrub the files.
  • You can also open the DNG files in the Source monitor. Or browse through the DNG files in Windows Explorer (Windows) or Finder (Mac OS).

File formats supported for export

Premiere Pro supports exporting the following new camera formats:

  • Panasonic AVCI-100 50p, 60p
  • Panasonic AVCI-200
  • Sony XAVC Intra

Support for 64-bit QuickTime export

Premiere Pro supports the following new video and audio codecs that let you export QuickTime movies in a 64-bit process.

Video codecs

Apple ProRes codecs (Mac OS 10.8 and later only)

  • Apple ProRes 422, 422 (HQ), 422 (LT), 422 (Proxy), 4444

DV codecs

  • DV/NTSC 24p
  • DV25 NTSC, PAL
  • DV50 NTSC, PAL
  • DVCPRO HD 1080i50, 1080i60, 1080p25, 1080p30, 720p50, 720p60

YUV codecs

  • Uncompressed YUV 10 bit 4:2:2, 8 bit 4:2:2

Apple None codecs

  • Uncompressed RGB 8 bit, 24 bit, 32 bit

Audio codecs

Uncompressed

Note:

Important notes:

  • If a movie uses an unsupported combination of audio and video codecs, the QuickTime 64-bit export reverts to a QuickTime 32-bit export. Examples of unsupported combinations could be a supported video codec and an unsupported audio codec, or a supported audio codec and an unsupported video codec.
  • On Windows, even if QuickTime for Windows is not installed, you can export QuickTime movies in a 64-bit process for the supported codecs.

New and changed preferences

Preference to change trim type

Premiere Pro provides you with an option to change the trim type of a previously selected edit point.

In the Preferences dialog box, under Trim, select Allow Current Tool To Change Trim Type Of Previously Selected Edit Point.

When you select this preference, clicking an edit point that's already selected changes the trim type to that of the current tool. You can also change the trim type at any edit point irrespective of whether the cursor is positioned over the edit point or not. This preference is selected by default.

Note:

If you deselect the preference, you cannot change the trim type of an edit point that's already selected unless you press the Alt/Opt (Mac) or Shift (Win) modifier keys.  

New and changed keyboard shortcuts

New keyboard shortcut to open General Preferences dialog

(Mac only) The keyboard shortcut "Cmd + ," can now open the Preferences dialog, focusing on the General preference category.  

Other enhancements

Improved performance for MJPEG files

Premiere Pro shows improved performance while playing MJPEG (Motion JPEG) movie files from the Canon EOS 1DC camera.

Support for QuickTime Reference legacy file format

Premiere Pro can now import QuickTime reference movies in MPEG 422 file format.  


Enhanced BlackMagic Cinema Camera support

You can import CinemaDNG footage from BlackMagic Cinema Cameras directly into Premiere Pro. Based on the footage metadata, Premiere Pro applies a neutral color tone curve to the imported CinemaDNG footage by default. You can then apply a range of adjustments within Premiere Pro to modify the color appearance.

Adobe After Effects and Adobe SpeedGrade import footage from BlackMagic Cinema Cameras differently than Premiere Pro. For example, when you import CinemaDNG footage directly into SpeedGrade, no tone curve is applied. SpeedGrade preserves the unmodified raw pixel values of the footage, letting you modify the exposure and apply color balance as required. When you import CinemaDNG footage directly into After Effects, a default color tone curve is applied to optimize the raw color appearance of the CinemaDNG footage.

When you use the CinemaDNG footage in a cross-product workflow, the footage is handled identically to Premiere Pro. For example, when you use the Direct Link between Premiere Pro and SpeedGrade, or open a Premiere Pro project in SpeedGrade, the neutral color tone that Premiere Pro applies is preserved in SpeedGrade. Similarly, when you use the Dynamic Link between Premiere Pro and After Effects, Premiere Pro’s neutral color tone is preserved in After Effects.

Note:

From either After Effects or Premiere Pro, when you copy and paste CinemaDNG footage to the other’s Project panel, the footage may appear different in each application.

 

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy