O Animate oferece vários métodos através dos quais você pode incorporar vídeo ao seu documento do Animate e reproduzi-lo para os usuários.

Antes de começar

Antes de começar a trabalhar com vídeo no Animate, é importante compreender as seguintes informações:

  • O Animate pode reproduzir somente alguns formatos de vídeo específicos.

    Esses formatos incluem vídeo FLV, F4V e MPEG. Para obter instruções sobre como converter vídeo em outros formatos, consulte Criar vídeo para uso no Animate.

  • Use um aplicativo Adobe Media Encoder separado (incluído com o Animate) para converter outros formatos de vídeo para F4V. Para obter instruções, consulte Criar vídeo para uso no Animate.

  • Há diferentes maneiras de adicionar vídeo ao Animate, cada uma com vantagens em diferentes situações. Consulte a seguir a lista desses métodos.

  • O Animate inclui um Assistente de importação de vídeo que é aberto quando você escolhe Arquivo > Importar > Importar vídeo.

  • Usar o componente FLVPlayback é a maneira mais simples de reproduzir rapidamente o vídeo em um arquivo do Animate.

    Para obter instruções, consulte Download progressivo de vídeo usando um servidor Web.

Métodos para usar vídeos no Animate

Você pode usar vídeos no Animate de diferentes maneiras:

  • Download progressivo de um servidor Web

    Este método mantém o arquivo de vídeo externo ao arquivo do Animate e do arquivo SWF resultante. Isso mantém o tamanho do arquivo SWF pequeno. Este é o método mais comum de se usar vídeo no Animate.

  • Fluxo de vídeo usando o Media Server.

    Este método também mantém o arquivo de vídeo externo ao seu arquivo no Animate. O Servidor de fluxo de mídia Adobe proporciona proteção segura do conteúdo de seu vídeo, além de uma experiência tranquila de reprodução de fluxo.

  • Incorporar dados de vídeo diretamente a um arquivo do Animate

    Este método resulta em arquivos do Animate muito grandes, por isso ele é recomendado somente para clipes de vídeo curtos. Para obter instruções, consulte Incorporação de vídeos vídeo a um arquivo do Animate.

Download progressivo de vídeo usando um servidor Web

O download progressivo permite usar o componente FLVPlayback ou o ActionScript que você grava para carregar arquivos FLV ou F4V externos em um arquivo SWF, e reproduzi-los em tempo de execução.

Como o arquivo de vídeo é mantido externo ao outro conteúdo do Animate, é relativamente fácil atualizar o conteúdo de vídeo sem tornar a publicar o arquivo SWF.

O download progressivo oferece as seguintes vantagens em relação à incorporação de vídeo na Linha do tempo:

  • Durante a criação, você pode publicar apenas seu arquivo SWF para visualizar ou testar uma parte ou todo o conteúdo do Animate. Os resultados são tempos de visualização mais rápidos e tempo de resposta mais rápido em experimentação iterativa.

  • Durante a reprodução, o vídeo é iniciado assim que o primeiro segmento de vídeo é baixado e armazenado em cache na unidade de disco do computador local.

  • No tempo de execução, os arquivos de vídeo são carregados pelo Flash Player da unidade de disco do computador local para o arquivo SWF, sem limitações no tamanho nem na duração do arquivo de vídeo. Não há problemas de sincronização de áudio nem restrições de memória.

  • A velocidade de exibição de quadros do arquivo de vídeo pode ser diferente da taxa de quadros do arquivo SWF, permitindo maior flexibilidade na autorização do conteúdo do Animate.

Importação de vídeo para download progressivo

Você pode importar um arquivo de vídeo armazenado localmente no seu computador e, em seguida, transferir o arquivo de vídeo para um servidor depois de importá-lo para o seu arquivo FLA. No Animate, quando você importa um vídeo para download progressivo, adiciona somente uma referência ao arquivo de vídeo. O Animate usa a referência para localizar o arquivo de vídeo no computador local ou em um servidor Web.

Também é possível importar um arquivo de vídeo que já foi transferido a um servidor de Web padrão, um Adobe Media Server (AMS), ou um Flash Video Streaming Service (FVSS).

  1. Selecione Arquivo > Importar > Importar vídeo para importar o clipe de vídeo no documento atual do Animate.

  2. Selecione o clipe de vídeo a ser importado. Você pode selecionar um clipe de vídeo localizado no seu computador local ou inserir o URL de um vídeo já carregado em um servidor da Web ou no Adobe Media Server.

    • Para importar vídeos armazenados em seu computador local, selecione 'Carregar vídeo externo com o componente de reprodução'.

    • Para importar vídeos já implantados em um servidor da Web, no Adobe Media Server ou no Flash Video Streaming Service, selecione "Já implantado em um servidor Web", no Flash Video Streaming Service ou no Fluxo do Adobe Media Server, e insira o URL do clipe de vídeo.

      Observação: a URL para um clipe de vídeo localizado em um servidor da Web usará o protocolo de comunicação http. O URL para um clipe de vídeo localizado em um Adobe Media Server ou o Flash Streaming Service vai usar o protocolo de comunicação RTMP.

  3. Selecione uma capa para o clipe de vídeo. É possível escolher:

    • Não use uma capa com o componente FLVPlayback selecionando Nenhum.

    • Selecione uma das capas predefinidas do componente FLVPlayback. O Animate copia a capa na mesma pasta como o arquivo FLA.

      Observação: as capas do componente FLVPlayback são um pouco diferentes. Isso varia se você está criando um documento do Animate baseado no AS2 ou no AS3.

       

    • Selecione uma capa personalizada criada por você digitando a URL da capa no servidor Web.

      Observação: se optar por usar uma capa personalizada convocada de um local remoto, a visualização ao vivo não estará disponível para o vídeo no Palco.

       

  4. O Assistente para Importação de Vídeo cria um componente de vídeo FLVPlayback no Palco que você pode usar para testar a reprodução do vídeo localmente. Ao terminar de criar seu documento do Animate, se quiser implantar o arquivo SWF e o clipe de vídeo, envie os seguintes ativos para o servidor Web ou o Adobe Media Server que hospeda seu vídeo:

    • Se estiver usando uma cópia local do clipe de vídeo, envie o clipe (que fica na mesma pasta do clipe de vídeo de origem selecionado com a extensão .flv)

      Observação: o Animate utiliza um caminho relativo para apontar para o arquivo FLV ou F4V (relativo ao arquivo SWF), permitindo que você use localmente a mesma estrutura de diretório usada no servidor. Se o vídeo foi anteriormente implantado no FMS ou no FVSS que está hospedando o vídeo, ignore esta etapa.

    • A capa de vídeo (se escolher usar uma capa)

      Para usar uma capa pré-definida, o Animate a copia na mesma pasta do arquivo FLA.

    • O componente FLVPlayback

      Para editar o campo URL do componente FLVPlayback para o campo do servidor Web ou do Adobe Media Server para o qual você está enviando o vídeo, use o Inspetor de componentes (Windows > Inspetor de componentes) para editar o parâmetro contentPath.

Fluxo de vídeo usando o Media Server

O Adobe Media Server envia o fluxo de mídia em tempo real para o Flash Player e o AIR. O Adobe Media Server utiliza a detecção de largura de banda para distribuir conteúdo de vídeo ou áudio com base na largura de banda disponível do usuário.

O fluxo de vídeo com o Adobe Media Server oferece as seguintes vantagens em relação ao vídeo incorporado e ao download progressivo:

  • A reprodução de vídeo é iniciada com mais rapidez do que outros métodos de incorporação de vídeo.

  • O fluxo utiliza menos memória e espaço em disco do cliente, porque não é necessário que os clientes baixem o arquivo inteiro.

  • Os recursos de rede são utilizados de maneira mais eficiente, porque apenas as partes exibidas do vídeo são enviadas ao cliente.

  • A distribuição de mídia é mais segura, porque a mídia não é salva no cache do cliente durante o fluxo.

  • O fluxo de vídeo oferece melhor capacidade de controle, relatório e registro.

  • O fluxo permite distribuir apresentações de vídeo e áudio ao vivo, ou capturar vídeo de uma Webcam ou de uma câmera de vídeo digital.

  • O Adobe Media Server permite o fluxo de várias maneiras e com vários usuários para aplicativos de bate-papo em vídeo, mensagens em vídeo e videoconferência.

  • Usando scripts do lado do servidor para controlar fluxos de áudio e vídeo, é possível criar listas de reprodução do lado do servidor, fluxos sincronizados e opções de distribuição mais inteligentes com base na velocidade de conexão do cliente.

Para saber mais sobre o Adobe Media Server, consulte: www.adobe.com/go/flash_media_server_br.

Para saber mais sobre o Flash Video Streaming Service, consulte www.adobe.com/go/learn_fvss_br.

Incorporação de arquivo de vídeo em um arquivo do Animate

Ao incorporar um arquivo de vídeo, todos os dados do arquivo de vídeo são adicionados ao arquivo do Animate. Isso gera um arquivo do Animate muito maior e um arquivo SWF subsequente. O vídeo é colocado na Linha do tempo, onde é possível visualizar os quadros de vídeo individuais representados nos quadros da Linha do tempo. Como cada quadro de vídeo é representado por um quadro na linha do tempo, a taxa de quadros do clipe e o arquivo SWF devem ter a mesma velocidade. Se você usar taxas de quadros diferentes para o arquivo SWF e o clipe de vídeo incorporado, a reprodução de vídeo não será uniforme.

Observação: para usar taxas de quadros variáveis, faça a transmissão do vídeo usando o download progressivo ou o Adobe Media Server. Quando os arquivos de vídeo são importados com qualquer um desses métodos, os arquivos FLV ou F4V ficam independentes e são executados em uma taxa de quadros separada de todas as outras taxas de quadros da linha do tempo, incluída no arquivo SWF.

 

O vídeo incorporado funciona melhor para clipes de vídeo menores, com um tempo de reprodução de menos de 10 segundos. Se estiver usando clipes de vídeo com tempos de reprodução maiores, considere o uso de vídeo com download progressivo ou fluxo de vídeo usando o Adobe Media Server.

As limitações do vídeo incorporado incluem:

  • Podem ocorrer problemas se os arquivos SWF resultantes se tornarem muito grandes. O Flash Player reserva muita memória durante o download e a tentativa de reproduzir grandes arquivos SWF com vídeo incorporado, o que pode causar falhas no Flash Player.

  • Os arquivos de vídeo maiores (mais de 10 segundos de duração) têm frequentemente problemas entre as partes de áudio e vídeo de um clipe de vídeo. Com o passar do tempo, a faixa de áudio começa a ser reproduzida fora de sincronismo com o vídeo, resultando em uma experiência de visualização insatisfatória.

  • Para reproduzir um vídeo incorporado em um arquivo SWF, todo o arquivo de vídeo deve ser baixado antes o início da reprodução do vídeo. Se um arquivo de vídeo muito grande for incorporado, talvez demore muito tempo para baixar o arquivo SWF e iniciar a reprodução do arquivo de vídeo.

  • Após a importação de um clipe de vídeo, não é possível editá-lo. Em vez disso, é possível reeditar e reimportar o arquivo de vídeo.

  • Ao publicar seu arquivo SWF pela Web, o vídeo inteiro deverá ser baixado no computador do visualizador antes do início da reprodução do vídeo.

  • No tempo de execução, o vídeo inteiro deve caber na memória local do computador de reprodução.

  • A extensão de um arquivo de vídeo importado não pode exceder 16000 quadros.

  • As taxas de quadros do vídeo e da Linha do tempo do Animate devem ser as mesmas. Defina a taxa de quadros de seu arquivo do Animate para coincidir com a do vídeo incorporado.

É possível visualizar quadros de um vídeo incorporado arrastando o indicador de reprodução junto com a Linha do tempo (depuração). Observe que a trilha sonora do vídeo não é executada durante a depuração. Para visualizar o vídeo com o som, use o comando Testar filme.

Incorporação de vídeo em um arquivo do Animate

  1. Selecione Arquivo > Importar > Importar vídeo para importar o clipe de vídeo no documento atual do Animate.

  2. Selecione uma das seguintes opções:

    Carregar vídeo externo com componente de reprodução: importa o vídeo e cria uma instância do componente FLVPlayback para controlar a reprodução de vídeo.

    Incorporar FLV em SWF e reproduzir na linha do tempo: incorpora o FLV do documento do Animate e o insere na linha do tempo.

    Incorporar vídeos H.264 na linha do tempo: incorpora vídeos H.264 ao documento do Animate. Ao importar um vídeo utilizando esta opção, é possível inseri-lo no palco para ser utilizado como um guia para a animação no tempo de criação. Os quadros do vídeo são renderizados no palco enquanto você apaga ou reproduz a linha do tempo. O áudio dos quadros relevantes também será reproduzido.

    Observação:

    • Ao tentar publicar o arquivo com conteúdo de vídeo H264 em uma camada que não é uma camada guia nem uma camada oculta, uma mensagem de aviso aparece informando que a plataforma na qual você está publicando não comporta a incorporação de vídeos H.264.
  3. Clique em Navegar e selecione o arquivo de vídeo no computador e clique em Avançar.

    Opcional: se você tem o Adobe Media Encoder instalado no computador e deseja converter o vídeo em outro formato com AME, clique em Converter vídeo.

  4. Selecione o tipo de símbolo para o qual o vídeo será incorporado.

    Vídeo incorporado

    Se você estiver utilizando o clipe de vídeo para reprodução linear na Linha do tempo, a importação do vídeo para a Linha do tempo é o método mais adequado.

    Clipe de filme

    Uma prática recomendada é colocar o vídeo dentro de uma ocorrência de clipe de vídeo, pois oferece maior controle sobre o conteúdo. A Linha do tempo de vídeo é reproduzida independentemente da Linha do tempo principal. Não é necessário estender a Linha do tempo principal em muitos quadros para acomodar o vídeo, que pode dificultar o trabalho com o arquivo FLA.

    Gráfico

    Ao incorporar um clipe de vídeo como um símbolo gráfico, você não pode interagir com o vídeo usando o ActionScript (normalmente, utilize símbolos gráficos para imagens estáticas e para criar partes reutilizáveis de animação, que são vinculadas à Linha do tempo principal).

  5. Importe o clipe de vídeo diretamente para o Palco (e a Linha do tempo) ou como um item de biblioteca.

    Por padrão, o Animate coloca o vídeo importado no Palco. Para importar apenas para a biblioteca, cancele a seleção de Colocar ocorrência no palco.

    Se estiver criando uma apresentação de vídeo simples, com narração linear e pouca ou nenhuma interação, aceite a configuração padrão e importe o vídeo para o Palco. Para criar uma apresentação mais dinâmica, trabalhar com vários clipes de vídeo ou adicionar transições dinâmicas ou outros elementos usando o ActionScript, importe o vídeo para a biblioteca. Depois que um clipe de vídeo estiver na biblioteca, personalize-o convertendo o clipe em um objeto MovieClip, que pode ser controlado mais facilmente com o ActionScript.

    Por padrão, o Animate expande a Linha do tempo para acomodar a duração da reprodução do clipe de vídeo que está sendo incorporado.

    Se o arquivo de vídeo contém áudio que você não deseja importar, desmarque Incluir áudio.  

  6. Clique em Avançar. Leia as mensagens de confirmação e clique em Concluir.

    O Assistente de Importação de Vídeo incorpora o vídeo no arquivo SWF. O vídeo é exibido no Palco ou na biblioteca, dependendo das opções de incorporação escolhidas.

  7. No Inspetor de propriedades (Janela > Propriedades), atribua um nome de ocorrência ao clipe de vídeo e faça quaisquer modificações nas propriedades do clipe de vídeo.

Importar arquivos de vídeo para a biblioteca

Para importar vídeos FLV, F4V ou H.264, use os comandos Importar > Importar vídeo ou Importar para biblioteca.

Para criar seu próprio player de vídeo, que carrega dinamicamente arquivos FLV ou F4V de uma fonte externa, coloque o vídeo dentro de um símbolo de clipe de vídeo. Ao carregar os arquivos FLV ou F4V dinamicamente, ajuste as dimensões do clipe de filme para coincidir com a dimensão real do arquivo de vídeo e ajuste a escala do vídeo dimensionando o clipe de filme.

Observação:

Uma prática recomendada é colocar o vídeo dentro de uma ocorrência de clipe de vídeo, que oferece maior controle sobre o conteúdo. A Linha do tempo de vídeo é reproduzida independentemente da Linha do tempo principal. Não é necessário estender a Linha do tempo principal em muitos quadros para acomodar o vídeo, que pode dificultar o trabalho com o arquivo FLA.

  • Para importar um arquivo de vídeo FLV, SWF ou H.264 para a biblioteca, execute um destes procedimentos:

    • Selecione Arquivo > Importar > Importar para biblioteca.

    • Selecione qualquer clipe de vídeo existente no painel Biblioteca e selecione Propriedades, no menu do painel Biblioteca. Clique em Importar. Localize o arquivo a ser importado e clique em Abrir.

Alterar as propriedades de um clipe de vídeo

É possível alterar propriedades de uma ocorrência de um clipe de vídeo incorporado no Palco, atribuir um nome de ocorrência à ocorrência e alterar as respectivas largura, altura e posição no Palco, por meio do Inspetor de propriedades. É possível também trocar uma ocorrência de um clipe de vídeo, isto é, atribuir um símbolo diferente a uma ocorrência de um clipe de vídeo. Atribuir um símbolo diferente a uma ocorrência exibe uma ocorrência diferente no Palco, mas deixa inalteradas todas as outras propriedades de ocorrência, como as dimensões e o ponto de registro.

Na caixa de diálogo Propriedades de vídeo, é possível:

  • Exibir informações sobre um clipe de vídeo importado, incluindo o nome, o caminho, a data de criação, as dimensões em pixels, o comprimento e o tamanho do arquivo

  • Alterar o nome do clipe de vídeo

  • Atualizar o clipe de vídeo, se ele for modificado em um editor externo

  • Importar um arquivo FLV ou F4V para substituir o clipe selecionado

  • Exportar um clipe de vídeo como um arquivo FLV ou F4V

Alterar propriedades da ocorrência de vídeo no Inspetor de propriedades

  1. Selecione uma ocorrência de um clipe de vídeo incorporado ou vinculado no Palco.
  2. Selecione Janela > Propriedades, e siga um destes procedimentos:
    • Digite um nome de ocorrência no campo de texto Nome, no lado esquerdo do Inspetor de propriedades.

    • Digite valores para L e A para alterar as dimensões da ocorrência de vídeo.

    • Digite valores para X e Y para alterar a posição do canto superior esquerdo da ocorrência no Palco.

    • Clique em Trocar. Selecione um clipe de vídeo para substituir o clipe atribuído atualmente à ocorrência.

      Observação: só é possível trocar um clipe de vídeo incorporado por outro clipe incorporado, e um clipe vinculado por outro clipe vinculado.

Exibir propriedades de clipes de vídeo na caixa de diálogo Propriedades de vídeo

  1. Selecione um clipe de vídeo no painel Biblioteca.
  2. Selecione Propriedades no menu do painel Biblioteca ou clique no botão Propriedades, localizado na parte inferior do painel Biblioteca. A caixa de diálogo Propriedades de vídeo é exibida.

Atribuir um novo nome a um video, atualizá-lo ou substituí-lo

  1. Selecione o clipe de vídeo no painel Biblioteca e Propriedades, no menu do painel Biblioteca.
  2. Siga um destes procedimentos:

    • Para atribuir um novo nome, digite o nome no campo de texto Nome.

    • Para atualizar um vídeo, navegue até o arquivo de vídeo atualizado e clique em Abrir.

    • Para substituir um vídeo, clique em Importar, navegue até o arquivo FLV, F4V ou H.264 a fim de substituir o clipe atual e clique em Abrir.

Controlar reprodução de vídeo usando a Linha do tempo

Para controlar a reprodução de um arquivo de vídeo incorporado, controle a Linha do tempo que contém o vídeo. Por exemplo, para pausar uma reprodução de vídeo na Linha do tempo principal, chame uma ação parar(), direcionada a essa Linha do tempo. Da mesma forma, é possível controlar um objeto de vídeo em um símbolo de clipe de vídeo controlando a reprodução da Linha do tempo desse símbolo.

É possível aplicar as seguintes ações aos objetos de vídeo importados em clipes de vídeo: goTo, play, stop, toggleHighQuality, stopAllSounds, getURL, FScommand, loadMovie, unloadMovie, ifFrameLoaded e onMouseEvent. Para aplicar ações a um objeto Vídeo, converta primeiro o objeto Vídeo em um clipe de vídeo.

Para mostrar um fluxo de vídeo ao vivo em um câmera, use o ActionScript. Primeiro, para colocar um objeto Vídeo no Palco, selecione Novo vídeo, no menu do painel Biblioteca. Para anexar o fluxo de vídeo ao objeto Vídeo, use Vídeo.anexarVídeo .

Consulte também Vídeo e anexarVídeo (método Vídeo.anexarVídeo) na Referência de linguagem do ActionScript 2.0, e fl.vídeo na Referência de linguagem do ActionScript 3.0.

Atualização de um vídeo incorporado após editar seu arquivo de origem

  1. Selecione o clipe de vídeo no painel Biblioteca.
  2. Selecione Propriedades e clique em Atualizar.

    O clipe de vídeo incorporado é atualizado com o arquivo editado. As configurações de compactação que você selecionou ao importar pela primeira vez o vídeo são reaplicadas ao clipe atualizado.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online