Criar e organizar camadas

As camadas permitem organizar a arte-final do documento. É possível desenhar e editar objetos em uma camada, sem afetar os objetos em outra camada. Em áreas do Palco sem nada em uma camada, é possível visualizar por meio dessa camada as camadas abaixo.

Para desenhar, pintar ou modificar uma camada ou pasta, selecione a camada na Linha do tempo para torná-la ativa. Um ícone de caneta, ao lado do nome de uma camada ou pasta na Linha do tempo, indica que a camada ou pasta está ativa. Apenas uma camada pode ficar ativa por vez (embora mais de uma camada possa ser selecionada por vez).

Quando você cria um documento do Animate CC (anteriormente, Flash Professional CC), ele contém apenas uma camada. Para organizar a arte-final, a animação e outros elementos no documento, adicione mais camadas. Também é possível ocultar, bloquear ou reorganizar as camadas. O número de camadas que podem ser criadas é limitado apenas pela memória do computador. As camadas não aumentam o tamanho do arquivo SWF publicado. Apenas os objetos colocados em camadas são adicionados ao tamanho do arquivo.

Para organizar e gerenciar as camadas, crie pastas de camada e coloque as camadas nessas pastas. É possível expandir ou contrair as pastas de camada na Linha do tempo, sem afetar o que é visualizado no palco. Use camadas ou pastas separadas para arquivos de som, ActionScript, rótulos e comentários de quadros. Usar camadas separadas ajuda a localizar esses itens rapidamente para editá-los.

Para criar efeitos sofisticados, use camadas de guias especiais para facilitar o desenho e a edição e para criar camadas de máscara.

Há cinco tipos de camadas que você pode usar no Animate:

  • Camadas normais contêm a maior parte da ilustração de um arquivo fla.

  • As camadas de máscara contêm objetos usados como máscaras para ocultar partes selecionadas de camadas abaixo delas. Para obter mais informações, consulte Uso de camadas de máscara.

  • Camadas com máscara são camadas abaixo de uma camada de máscara que você associa à camada de máscara. Apenas a parte da camada de máscara não coberta pela máscara estará visível. Para obter mais informações, consulte Uso de camadas de máscara.

  • As camadas de guia contêm traçados que podem ser usados para guiar a organização de objetos em outras camadas. Além disso, é possível guiar o movimento de animações de interpolação clássica em outras camadas. Para obter mais informações, consulte Camadas de guia e Criar interpolação de movimento clássica ao longo de um caminho.

  • Camadas com guia são camadas associadas a uma camada de guia. Os objetos na camada com guia podem ser organizados ou animados ao longo dos traçados na camada de guia. Camadas com guia podem conter arte-final estática e interpolações clássicas, mas não interpolações de movimento.

  • As camadas de interpolação de movimento contêm objetos animados com interpolações de movimento. Para obter mais informações, consulte Noções de Animação Interpolada.

  • As camadas de armadura contêm objetos com bones cinemáticos invertidas anexadas. Para obter mais informações, consulte Uso da Ferramenta bone para a animação cinemática inversa.

Camadas normais, de máscara, com máscara e com guia podem conter interpolações de movimento ou de bones de cinemática inversa. Quando esses itens estão presentes em uma dessas camadas, existem limitações para os tipos de conteúdo que podem ser adicionados à camada. Para obter mais informações, consulte Interpolações de movimento e Uso da Ferramenta bone para a animação cinemática inversa.

Criar uma camada

Quando você cria uma camada, ela é exibida acima da camada selecionada. A camada recém-adicionada torna-se a camada ativa.

  1. Siga um destes procedimentos:
    • Clique no botão Nova camada  na parte inferior da Linha do tempo.

    • Selecione Inserir > Linha do tempo > Camada.

    • Clique com o botão direito (Windows) ou com a tecla Ctrl pressionada (Macintosh) em um nome de camada na linha do tempo e selecione Inserir camada, no menu de contexto.

Criar uma pasta de camadas

  1. Siga um destes procedimentos:
    • Selecione uma camada ou pasta na Linha do tempo e selecione Inserir > Linha do tempo > Pasta de camada.

    • Clique com o botão direito (Windows) ou com a tecla Ctrl pressionada (Macintosh) em um nome de camada na Linha do tempo e selecione Inserir camada, no menu de contexto. A nova pasta é exibida acima da camada ou pasta selecionada.

    • Clique no ícone Nova pasta  na parte inferior da Linha do tempo. A nova pasta é exibida acima da camada ou pasta selecionada.

Organizar camadas e pastas de camadas

Para organizar o documento, reorganize as camadas e pastas na Linha do tempo.

As pastas de camadas organizam o fluxo de trabalho permitindo posicionar camadas em uma estrutura em árvore. Para visualizar as camadas contidas em uma pasta sem afetar as camadas visíveis no Palco, expanda ou contraia a pasta. As pastas podem conter camadas e outras pastas, permitindo organizar as camadas de maneira muito semelhante à organização de arquivos no computador.

Os controles de camada na Linha do tempo afetam todas as camadas em uma pasta. Por exemplo, bloquear uma pasta de camadas bloqueia todas as camadas nessa pasta.

  • Para mover uma camada ou pasta de camadas para uma pasta de camadas, arraste o nome da camada ou da pasta de camadas até o nome da pasta de camadas de destino.
  • Para alterar a ordem das camadas ou das pastas, arraste uma ou mais camadas ou pastas na Linha do tempo até a posição desejada.
  • Para expandir ou contrair uma pasta, clique no triângulo azul à esquerda do nome da pasta.
  • Para expandir ou recolher todas as pastas, clique com o botão direito (Windows) ou clique com a tecla Ctrl (Macintosh) pressionada e selecione Expandir todas as pastas ou Contrair todas as pastas.

Renomear uma camada ou uma pasta

Por padrão, o Animate atribui nomes em novas camadas pela ordem em que são criadas: Camada 1, Camada 2 e assim por diante. Para refletir melhor o conteúdo, renomeie as camadas.

  1. Siga um destes procedimentos:
    • Clique duas vezes no nome da camada ou pasta na Linha do tempo e digite um novo nome.

    • Clique com o botão direito (Windows) ou com a tecla Ctrl pressionada (Macintosh) no nome da camada ou da pasta e selecione Propriedades no menu de contexto. Digite o novo nome na caixa Nome e clique em OK.

    • Selecione a camada ou pasta na Linha do tempo e selecione Modificar > Linha do tempo > Propriedades da camada. Digite o novo nome na caixa Nome e clique em OK.

Selecionar uma camada ou uma pasta

  1. Siga um destes procedimentos:
    • Clique no nome de uma camada ou pasta na Linha do tempo.

    • Clique em qualquer quadro na Linha do tempo da camada a ser selecionada.

    • Selecione um objeto no Palco, que esteja localizado na camada a ser selecionada.

    • Para selecionar camadas ou pastas adjacentes, clique com a tecla Shift pressionada em seus nomes na Linha do tempo.

    • Para selecionar camadas ou pastas não contíguas, clique com a tecla Ctrl (Windows) ou a tecla Command (Macintosh) pressionada em seus nomes na Linha do tempo.

Copiar quadros de uma única camada

  1. Selecionar um intervalo de quadros em uma camada. Para selecionar toda a camada, clique no nome da camada na Linha do tempo.
  2. Selecione Editar > Linha do tempo > Copiar quadros.

  3. Clique no quadro no qual deseja iniciar a colagem e selecione Editar > Linha do tempo > Colar quadros. Para substituir o número exato de quadros copiados na linha do tempo de destino, use a opção Colar e substituir quadros.

    Overwrite_frames_process_1
    Colar e substituir fluxo de trabalho de quadros

    A. Selecione quadros e copie. B. Clique com o botão direito do mouse no quadro que deseja colar e selecione Colar e substituir quadros. C. Os quadros colados substituirão o número exato de quadros na linha do tempo. 

Copiar quadros de uma pasta de camadas

  1. Para selecionar a pasta inteira, recolha a pasta (clique no triângulo à esquerda do nome da pasta na linha do tempo) e clique no nome da pasta. 

  2. Selecione Editar > Linha do tempo > Copiar quadros.

  3. Para criar uma pasta, selecione Inserir > Linha do tempo > Pasta de camadas.

  4. Clique na nova pasta e selecione Editar > Linha do tempo > Colar quadros.

Excluir uma camada ou uma pasta

  1. Para selecionar a camada ou pasta, clique em seu nome na Linha do tempo ou em qualquer quadro na camada.
  2. Siga um destes procedimentos:
    • Clique no botão Excluir camada na Linha do tempo.

    • Arraste a camada ou pasta para o botão Excluir camada.

    • Clique com o botão direito (Windows) ou com a tecla Ctrl pressionada (Macintosh) no nome da camada ou da pasta e selecione Excluir camada no menu de contexto.

    Observação:

    Quando uma pasta de camadas é excluída, todas as camadas incluídas e seus conteúdos também serão excluídos.

Bloquear ou desbloquear uma ou mais camadas ou pastas

  • Para bloquear uma camada ou pasta, clique na coluna Bloquear, à direita do nome. Para desbloquear a camada ou pasta, clique na coluna Bloquear novamente.

  • Para bloquear todas as camadas e pastas, clique no ícone de cadeado. Para desbloquear todas as camadas e pastas, clique nesse ícone novamente.

  • Para bloquear ou desbloquear várias camadas ou pastas, arraste pela coluna Bloquear.

  • Para bloquear todas as outras camadas ou pastas, use a tecla Alt (Windows) ou Option (Macintosh) na coluna de bloqueio. Para desbloquear todas as camadas ou pastas, use a tecla Alt ou Option (Macintosh) na coluna de bloqueio novamente.

Copiar e colar camadas (CS5.5 apenas)

É possível copiar camadas inteiras e pastas de camadas na linha do tempo e colá-las na mesma linha do tempo ou em linhas do tempo distintas. Qualquer tipo de camada pode ser copiado.

Ao copiar e colar camadas, o bone da pasta de camadas das camadas copiadas é mantido.

  1. Selecione uma ou mais camadas na linha do tempo clicando no nome da camada. Pressione Shift e clique para selecionar camadas contínuas. Clique com a tecla Control (Windows) ou Command (Macintosh) pressionada para selecionar camadas não contínuas.

  2. Selecione Editar > Linha do tempo > Copiar camadas ou Recortar camadas. Também é possível clicar com o botão direito do mouse nas camadas e escolher Copiar camadas ou Recortar camadas no menu de contexto.

  3. Na linha do tempo que receberá a colagem, selecione a camada imediatamente abaixo da qual você desejar inserir as camadas a serem coladas.

  4. Selecione Editar > Linha do tempo > Colar camadas.

As camadas são exigidas na Linha do Tempo acima da camada que você selecionou. Se uma pasta de camadas tiver sido selecionada, as camadas coladas serão exibidas dentro da pasta.

Para adicionar uma camada em uma camada de máscara ou guia, primeiro selecione a camada sob a máscara ou sob a guia e cole a camada desejada. Não é possível colar uma máscara, uma guia ou uma pasta de camadas sob uma camada de máscara ou de guia.

Também é possível duplicar as camadas selecionando as camadas e escolhendo Editar > Linha do tempo > Duplicar camadas. As novas camadas terão a palavra “cópia” adicionada aos respectivos nomes.

Configuração de Propriedades para várias camadas

  1. No Animate CC, crie um arquivo FLA ou abra um arquivo existente.

  2. Selecione as camadas cujas propriedades deseja modificar, clique com o botão direito e selecione Propriedades.

  3. Na caixa de diálogo Propriedades da camada, modifique as propriedades.

  4. Clique em OK.

Mostrar ou ocultar uma camada ou uma pasta

Um X vermelho ao lado do nome de uma camada ou pasta na Linha do tempo indica que a camada ou pasta está oculta. Em Configurações de publicação, escolha se as camadas ocultas são incluídas durante a publicação de um arquivo SWF.

  • Para ocultar uma camada ou pasta, clique na coluna Olho, à direita do nome da camada ou da pasta na Linha do tempo. Para mostrar a camada ou pasta, clique nela novamente.

  • Para ocultar todas as camadas e pastas na Linha do tempo, clique no ícone de olho. Para mostrar todas as camadas e pastas, clique no ícone novamente.

  • Para mostrar ou ocultar várias camadas ou pastas, arraste pela coluna do ícone Olho.

  • Para ocultar todas as camadas e pastas diferentes da camada atual ou a pasta, clique com a tecla Alt (Windows) ou Option (Macintosh) pressionada na coluna de ícone de olho. Para mostrar todas as camadas e pastas, clique com a tecla Alt ou Option pressionada novamente.

Exibir o conteúdo de uma camada como contorno

Para distinguir a qual camada um objeto pertence, exiba todos os objetos em uma camada como contornos coloridos.

  • Para exibir todos os objetos nessa camada como contorno, clique na coluna Contorno, à direita do nome da camada. Para desativar a exibição do contorno, clique na coluna novamente.

  • Para exibir objetos em todas as camadas como contornos, clique no ícone de contorno. Para desativar a exibição do contorno em todas as camadas, clique no ícone novamente.

  • Para exibir os objetos como contornos em todas as camadas diferentes da camada atual, clique com a tecla Alt (Windows) ou Option (Macintosh) pressionada na coluna de Contorno. Para desativar a exibição do contorno para todas as camadas, clique com a tecla Alt ou Option pressionada novamente.

Observação:

Os caminhos de movimento na camada também usam a cor de contorno da camada.

Alterar a cor de contorno de uma camada

  1. Siga um destes procedimentos:
    • Clique duas vezes no ícone da camada (o ícone à esquerda do nome da camada) na Linha do tempo.

    • Clique com o botão direito (Windows) ou com a tecla Ctrl pressionada (Macintosh) no nome da camada e selecione Propriedades no menu de contexto.

    • Selecione a camada na Linha do tempo e selecione Modificar > Linha do tempo > Propriedades da camada.

  2. Na caixa de diálogo Propriedades da camada, clique na paleta Cor de contorno, selecione uma nova cor e clique em OK.

Exibir camadas e pastas de camadas

Mostrar ou ocultar uma camada ou uma pasta

Um X vermelho ao lado do nome de uma camada ou pasta na Linha do tempo indica que a camada ou pasta está oculta. Em Configurações de publicação, escolha se as camadas ocultas são incluídas durante a publicação de um arquivo SWF.

  • Para ocultar uma camada ou pasta, clique na coluna Olho, à direita do nome da camada ou da pasta na Linha do tempo. Para mostrar a camada ou pasta, clique nela novamente.

  • Para ocultar todas as camadas e pastas na Linha do tempo, clique no ícone de olho. Para mostrar todas as camadas e pastas, clique no ícone novamente.

  • Para mostrar ou ocultar várias camadas ou pastas, arraste pela coluna do ícone Olho.

  • Para ocultar todas as camadas e pastas diferentes da camada atual ou a pasta, clique com a tecla Alt (Windows) ou Option (Macintosh) pressionada na coluna de ícone de olho. Para mostrar todas as camadas e pastas, clique com a tecla Alt ou Option pressionada novamente.

Exibir o conteúdo de uma camada como contorno

Para distinguir a qual camada um objeto pertence, exiba todos os objetos em uma camada como contornos coloridos.

  • Para exibir todos os objetos nessa camada como contorno, clique na coluna Contorno, à direita do nome da camada. Para desativar a exibição do contorno, clique na coluna novamente.

  • Para exibir objetos em todas as camadas como contornos, clique no ícone de contorno. Para desativar a exibição do contorno em todas as camadas, clique no ícone novamente.

  • Para exibir os objetos em todas as camadas diferentes da camada atual, clique com a tecla Alt (Windows) ou Option (Macintosh) pressionada na coluna de contorno. Para desativar a exibição do contorno para todas as camadas, clique com a tecla Alt ou Option pressionada novamente.

Alterar a cor de contorno de uma camada

  1. Siga um destes procedimentos:
    • Clique duas vezes no ícone da camada (o ícone à esquerda do nome da camada) na Linha do tempo.

    • Clique com o botão direito (Windows) ou com a tecla Ctrl pressionada (Macintosh) no nome da camada e selecione Propriedades no menu de contexto.

    • Selecione a camada na Linha do tempo e selecione Modificar > Linha do tempo > Propriedades da camada.

  2. Na caixa de diálogo Propriedades da camada, clique na paleta Cor de contorno, selecione uma nova cor e clique em OK.

Observação:

Os caminhos de movimento na camada também usam a cor de contorno da camada.

Ajustar a transparência da camada

  1. No Animate CC, crie um arquivo FLA ou abra um existente.

  2. Pressione Shift e clique na coluna do ícone Olho na Linha do tempo para ajustar a visibilidade para transparente.

    Observação:

    Pressionar a tecla Shift e clicar não surtirá efeito sobre as camadas ocultas.

    Ajustar a transparência da camada
    Ajustar a transparência da camada
  3. Use qualquer uma das opções a seguir para definir a transparência da camada:

    • Clique com o botão direito do mouse em qualquer camada e selecione Propriedades no menu de contexto. Na caixa de diálogo Propriedades da camada, selecione Visibilidade > Transparência.
    • Clique com o botão direito do mouse em qualquer camada e selecione Exibir outros transparentes.
    Propriedades da camada
    Propriedades da camada
  4. Clique em OK.

Observação:

A transparência de camada não tem efeito sobre camadas ocultas. 

Usar camadas avançadas

No Animate CC, com o modo de Camadas avançadas, todas as camadas na linha de tempo são publicadas como símbolos. O modo de camadas avançadas permite que você acesse os seguintes recursos:

O modo de Camadas avançadas está habilitado por padrão. Você pode habilitar ou desabilitar as Camadas avançadas usando a configuração Modificar > Documento. Depois de aplicar as alterações, clique em Tornar padrão para preservar as configurações atuais para os documentos subsequentes e em todas as sessões do Animate. 

Modo de camadas avançadas
Modo de camadas avançadas

Ao acessar esses símbolos usando scripts no Animate, você tem que acioná-las usando camada como um objeto. Por exemplo, quando você não estiver usando camadas avançadas, poderá acessar diretamente um símbolo usando um script semelhante ao seguinte exemplo: 

getchildbyname("symbol1");

Mas, ao usar camadas avançadas, você poderá acessar o símbolo somente com uma camada usando um script semelhante ao seguinte exemplo:

Layer=getchildbyname("L1");

Layer.getchildbyname("symbol1");

Um exemplo de código para acessar símbolos usando camadas avançadas para o tipo de documento AS3: 

Var Layer:MovieClip =MovieClip(getchildbyname("L1"));
Layer.getchildbyname("symbol1");

Um exemplo de código para acessar símbolos usando camadas avançadas para o tipo de documento HTML5 Canvas: 

Layer=this.getchildbyname("L1");
Layer.getchildbyname("symbol1");

A ilustração a seguir descreve como acessar um símbolo usando scripts com camadas avançadas e sem camadas avançadas. 

Ilustração sobre como acessar símbolos com e sem camadas avançadas
Ilustração sobre como acessar símbolos com e sem camadas avançadas

Observação:

O tamanho de seus projetos de animação publicados pode aumentar quando você usa camadas avançadas no Animate. Se você encontrar algum problema ao acessar os recursos de profundidade da câmera ou de camada, verifique se as camadas avançadas estão ATIVADAS. Se estiverem desativadas, habilite-as para obter o comportamento esperado. 

Aplicação de efeitos de camada

Os filtros e os efeitos de cor costumavam ser aplicáveis somente a clipe de filme. Com as camadas avançadas, filtros e efeito de cor agora podem ser aplicados a quadros específicos, que por sua vez aplicam-se a todo o seu conteúdo incluindo formas, objeto de desenho, símbolos gráficos e assim por diante. Os efeitos de camada também podem ser interpolados usando as interpolações clássica, de forma e IK entre os quadros.

Você pode aplicar efeitos de camada em um quadro individual ou em vários quadros, ao selecionar os quadros desejados. Também é possível aplicar efeitos de camada em todos os quadros da camada, selecionando a camada inteira. Os efeitos de camada também podem ser aplicados na linha de tempo do símbolo como clipe de filme e símbolo gráfico e em todas as cenas.

Observação:

Efeitos de camada podem ser aplicados somente quando o modo de camadas avançadas está ATIVADO. Talvez seja necessário habilitar de modo explícito o modo de Camadas avançadas para que arquivos usem essa funcionalidade.

Uso de filtros para quadros

Para adicionar filtros em um quadro específico, primeiro selecione o quadro. O painel Inspetor de propriedades carrega as propriedades específicas do quadro. Clique no ícone + na lista suspensa Filtros.

Filtros de quadro
Filtros de quadro

Quando você adiciona filtros em quadros, o Inspetor de propriedades aparece conforme mostrado na seguinte captura de tela. 

Você pode definir as propriedades de cada um dos filtros conforme desejar e aplicá-los ao nível do quadro. A interpolação é aplicável a todos os filtros de quadro. 

Propriedades de filtros de quadro no Inspetor de propriedades
Propriedades de filtros de quadro no Inspetor de propriedades

Observação:

Os efeitos de camada são compatíveis somente com o tipo de documento do ActionScript 3. A interpolação de movimento e as camada da câmera não são compatíveis com efeitos de camada. 

Uso de efeitos de cor

Para aplicar o efeito de cor em quadro específico, primeiro selecione o quadro. O painel Inspetor de propriedades carrega as propriedades específicas do quadro. Escolha qualquer propriedade de cores desejada no painel do Inspetor de propriedades.

Efeitos de cor
Efeitos de cor

Aplicação de profundidade da camada

Como um Animador, é possível inserir as camadas em diferentes planos de animação 2D para criar a ilusão de profundidade. 

Você pode alterar dinamicamente as profundidades de camadas por meio do painel Profundidade da camada. Para abrir o painel de profundidade da camada, clique em Janela > Profundidade da camada.

Profundidade de camada que representa cada camada
Profundidade de camada que representa cada camada

Observação:

Você pode definir os valores mínimo e máximo de profundidade da camada entre -5000 e 10000.

Conforme ilustrado na captura de tela acima, os valores de profundidade de camada são exibidos ao lado do nome de cada camada para um determinado quadro.

  • Passe o mouse sobre cada valor, clique e arraste o controle deslizante para a esquerda ou direita.
  • Para diminuir a profundidade, arraste o controle deslizante para a esquerda. Para aumentar a profundidade, arraste o controle deslizante para direita.  
  • Você pode usar valores negativos menores para representar objetos que estão mais próximos e valores positivos maiores para representar objetos distantes.

É possível interpolar os valores de profundidade de camada em qualquer uma das extensões de interpolação para a sua animação. 

Cada camada é representada com linhas coloridas exclusivas no painel de profundidade da camada. É possível exibir as cores que representam cada uma das camadas na linha do tempo. 

Você também pode aumentar ou diminuir a profundidade de objetos em cada camada ao mover as linhas multicoloridas para cima ou para baixo.

  • Para diminuir a profundidade de objetos em uma camada, clique e arraste a linha para cima.
  • Para aumentar a profundidade de objetos em uma camada, clique e arraste a linha para baixo.

Uma ilustração que descreve animações com e sem a profundidade da camada:

Conteúdo sem profundidade de camada
Conteúdo sem profundidade de camada
Conteúdo com profundidade de camada
Conteúdo com profundidade de camada

Uma ilustração que descreve uma animação enquanto a profundidade da camada é aplicada:

Você pode usar a câmera em camadas multiplano para criar um efeito de paralaxe ou para aplicar zoom no conteúdo de um plano. Você também pode bloquear a câmera em uma camada específica ou aplicar efeitos da câmera no tempo de execução usando APIs interativas. Para obter mais informações, consulte Criação do efeito paralaxe com a profundidade da câmera e da camada.

Observação:

A profundidade da camada é aplicável somente na linha de tempo principal.

Manter tamanho para a profundidade da camada

Você pode alterar a profundidade da camada de objetos sem afetar o tamanho e a posição de objetos. Para usar o recurso de manter tamanho, clique no botão Manter tamanho no canto superior direito do painel Profundidade da camada.

Você pode usar a opção de manter tamanho de duas maneiras:

  • Clique no botão Manter tamanho e modifique a profundidade da camada desejada. O botão Manter tamanho é alternado automaticamente.
  • Pressione e segure a tecla Alt para habilitar temporariamente a opção Manter tamanho ao arrastar os valores de profundidade da camada.
Manter tamanho para a profundidade da camada
Manter tamanho para a profundidade da camada

Aplicar a profundidade da camada no tempo de execução

Você também pode inserir a câmera em objetos em tempo de execução e aplicar efeitos usando APIs da câmera. Para obter mais informações, consulte Usar a câmera interativa em tempo de execução

API de profundidade da camada para AS3

Você pode controlar as camadas no tempo de execução usando as APIs. Por exemplo, no tempo de execução em que deseja inserir uma camada extra na animação ou diminuir a profundidade de uma das camadas na animação. 

Método Protótipo Exemplo Descrição
setLayerZDepth fl.Layer.setLayerZDepth(timeline,
layerName,zDepth)
fl.Layer.setLayerZDepth("layerName", 100); Defina o valor de profundidade Z de uma camada específica.
getLayerZDepth fl.Layer.getLayerZDepth(layerName) : zDepth fl.Layer.getLayerZDepth("layerName"); Retorna o valor de profundidade Z de uma camada específica.
addNewLayer fl.Layer.addNewLayer(layerName,
zDepth=0)
fl.Layer.addNewLayer("layerName",-80); Adicione uma nova camada à linha do tempo e defina a profundidade Z.
removeLayer fl.Layer.removeLayer(layerName) fl.Layer.removeLayer("layerName"); Remova uma camada da linha do tempo.

API de profundidade da camada para HTML Canvas

Método Protótipo Exemplo Descrição
setLayerZDepth AdobeAn.Layer.setLayerZDepth(layerName,
zDepth)
console.log(fl.Layer.setLayerZDepth
("layerName", 100));
Defina o valor de profundidade Z de uma camada específica.
getLayerZDepth AdobeAn.Layer.getLayerZDepth(layerName)
:zDepth
console.log(fl.Layer.getLayerZDepth
("layerName"));
Retorna o valor de profundidade Z de uma camada específica.

Recurso de camada pai

O Anime permite configurar uma camada como pai de outra. O recurso pai da camada é uma maneira fácil de permitir que uma camada/objeto de sua animação controle outra camada/objeto. Como designer da animação ou um designer de jogo, você pode acelerar o tempo de animação, pois é possível controlar movimentos de diferentes partes de um personagem com mais facilidade.

A exibição do recurso pai da camada exige que as Camadas avançadas sejam ativadas. Por padrão, Camadas avançadas está ativada para novos arquivos. Você pode ativar a exibição do recurso pai da camada clicando no ícone de símbolo da hierarquia no canto superior direito da linha de tempo. 

Mostrar recurso de camada pai
Mostrar recurso de camada pai

Observação:

O recurso pai para objetos distorcidos funciona somente quando o ponto de transformação do objeto de camada filho estiver no objeto de camada pai.

Camadas pai e filho

Na visualização de recurso pai, ao arrastar a camada 1 para a camada 2, a camada 1 se torna o filho do pai que é a camada 2. O objeto na camada filho herda a posição e a rotação do objeto na camada pai independentemente de carregar suas próprias propriedades. Portanto, quando você move ou gerencie o pai, o filho também move ou gira junto com o pai. Você pode criar várias relação entre pai-filho para criar uma hierarquia.

Camadas de recurso pai

Você pode conectar uma camada a outra clicando na alça de camada (cabeçalho da cor) e arrastando-a sobre a outra camada. Como alternativa, você pode clicar em qualquer lugar no espaço retangular horizontal adjacente ao nome da camada e arrastar sobre a outra camada. Além disso, é possível usar o clique simples em qualquer camada e escolher a camada pai correspondente na lista pop-up. 

Uma linha pontilhada aparece adjacente ao cabeçalho da cor da camada assim que você clicar e tentar arrastar a linha. Uma conexão entre pai e filho é estabelecida entre as duas camadas assim que você usa a ação de clicar e arrastar.

Definir camada pai
Definir camada pai

O cabeçalho de cor à esquerda na hierarquia da exibição do recurso pai da camada representa o pai. A hierarquia pai-filho se move da esquerda para a direita.

Para remover a conexão, clique no cabeçalho de cor de qualquer camada e arraste e solte a linha pontilhada. Como alternativa, você pode clicar no espaço horizontal e clicar em Remover o pai, conforme mostrado na captura de tela abaixo. 

Remover o item pai
Remover o item pai

Nas capturas de tela abaixo, você pode ver as visualizações de hierarquia antes e depois, além das posições das camadas quando você usa o recurso pai da camada.

Antes e depois de aplicar o recurso de camada pai
Antes e depois de aplicar o recurso de camada pai

Uma ilustração de amostra que representa o uso do recurso pai de camada para partes do corpo humano é mostrado abaixo.

Ilustração de amostra de partes do corpo com o recurso de camada pai
Ilustração de amostra de partes do corpo com o recurso de camada pai

Na ilustração acima,

  • Tronco é o pai de todas as partes do corpo.
  • Legs_thigh é o pai de várias partes de uma perna como Tênis, Leg_lower e Tornozelo.
  • Cabeça é um filho do pai, Pescoço, e o Tronco é o pai do Pescoço. Assim, sempre que você arrastar o pescoço para longe do corpo, a parte principal também se move junto com ele.

Observação:

O recurso pai é uma propriedade de quadro que você precisa para se ajustar a cada quadro principal na camada filho. Em um quadro principal, você pode quebrar ou reatribuir como pai a camada filho a outra camada pai.

Um tutorial sobre o recurso de camada pai

Um tutorial sobre o recurso de camada pai
Saiba mais sobre como criar uma hierarquia de pai-filho entre camadas e manipule suas composições com facilidade.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online