Guia do Usuário Cancelar

Trabalho com bibliotecas no Animate

  1. Guia do Usuário do Adobe Animate
  2. Introdução ao Animate
    1. Novidades no Animate
    2. Glossário visual
    3. Requisitos de sistema do Animate
    4. Atalhos de teclado do Animate
    5. Trabalhar com vários tipos de arquivo no Animate
  3. Animação
    1. Noções básicas de animação no Animate
    2. Como usar quadros e quadros-chave no Animate
    3. Animação quadro a quadro no Animate
    4. Como trabalhar com animação de interpolação clássica no Animate
    5. Ferramenta Pincel
    6. Guia de movimento
    7. Interpolação de movimento e ActionScript 3.0
    8. Sobre a animação com interpolação de movimento
    9. Animações de interpolação de movimento
    10. Criação de uma animação de interpolação de movimento
    11. Utilização dos quadros-chave de propriedade
    12. Animação de posição com uma interpolação
    13. Editar interpolações de movimento usando o Motion Editor
    14. Edição do caminho de movimento de uma animação de interpolação
    15. Manipulação de interpolações de movimento
    16. Adição de atenuações personalizadas
    17. Criação e aplicação das predefinições de movimento
    18. Configuração de extensões de interpolação de animação
    19. Trabalhar com interpolações de movimento salvas como arquivos XML
    20. Interpolações de movimento e interpolações clássicas
    21. Interpolação de formas
    22. Uso da animação da ferramenta Bone no Animate
    23. Trabalhar com manipulação de caracteres no Animate
    24. Como usar camadas de máscara no Adobe Animate
    25. Como trabalhar com cenas no Animate
  4. Interatividade
    1. Como criar botões com o Animate
    2. Converter projetos do Animate em outros formatos de tipo de documento
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Adicionar interatividade com snippets de código no Animate
    5. Criar componentes HTML5 personalizados
    6. Uso de componentes do HTML5 Canvas
    7. Criação de componentes personalizados: exemplos
    8. Snippets de código para componentes personalizados
    9. Práticas recomendadas - Publicidade com o Animate
    10. Criação e publicação de Realidade virtual
  5. Fluxo de trabalho e espaço de trabalho
    1. Criação e gerenciamento de pincéis
    2. Uso de Google Fonts em documentos HTML5 Canvas
    3. Uso das Bibliotecas da Creative Cloud e do Adobe Animate
    4. Uso dos painéis Palco e Ferramentas do Animate
    5. Fluxo e espaço de trabalho do Animate
    6. Uso de fontes da Web em documentos HTML5 Canvas
    7. Linhas de tempo e ActionScript
    8. Trabalhar com múltiplas linhas de tempo
    9. Definir preferências
    10. Uso de painéis de criação do Animate
    11. Criar camadas na linha do tempo com o Animate
    12. Exportar animações para aplicativos móveis e mecanismos de jogo
    13. Mover e copiar objetos
    14. Modelos
    15. Localização e substituição no Animate
    16. Desfazer, refazer e o painel de Histórico
    17. Atalhos de teclado
    18. Como usar a linha do tempo no Animate
    19. Criação de extensões HTML
    20. Opções de otimização para imagens e GIFs animados
    21. Configurações de exportação para imagens e GIFs
    22. Painel Ativos no Animate
  6. Multimídia e vídeo
    1. Transformação e combinação de objetos gráficos no Animate
    2. Criar e trabalhar com instâncias do símbolo no Animate
    3. Traçado de imagem
    4. Como usar som no Adobe Animate
    5. Exportação de arquivos SVG
    6. Criação de arquivos de vídeo para uso no Animate
    7. Como adicionar vídeos no Animate
    8. Trabalhar com pontos de sinalização de vídeo
    9. Desenhar e criar objetos com o Animate
    10. Remodelação de linhas e formas
    11. Traçados, preenchimentos e gradientes com o Animate CC
    12. Trabalhar com o Adobe Premiere Pro e o After Effects
    13. Painéis de cor no Animate CC
    14. Abrir arquivos do Flash CS6 com o Animate
    15. Trabalho com texto clássico no Animate
    16. Aplicação de ilustração final no Animate
    17. Bitmaps importados no Animate
    18. Gráficos em 3D
    19. Trabalhar com símbolos no Animate
    20. Desenhar linhas e formas com o Adobe Animate
    21. Trabalho com bibliotecas no Animate
    22. Exportação de sons
    23. Seleção de objetos no Animate CC
    24. Trabalho com arquivos AI do Illustrator no Animate
    25. Aplicação de padrões com a ferramenta Pincel de borrifar
    26. Aplicação de modos de mesclagem
    27. Organização de objetos
    28. Automação de tarefas com o menu Comandos
    29. Texto multilíngue
    30. Uso de câmera no Animate
    31. Uso do Animate com o Adobe Scout
    32. Trabalhar com arquivos Fireworks
    33. Filtros gráficos
    34. Som e ActionScript
    35. Preferências de desenho
    36. Desenho com a ferramenta Caneta
  7. Plataformas
    1. Converter projetos do Animate em outros formatos de tipo de documento
    2. Suporte da plataforma personalizada
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Criação e publicação de um documento WebGL
    5. Compactação de aplicativos no AIR para iOS
    6. Publicação de AIR em aplicativos Android
    7. Publicação no Adobe AIR para desktop
    8. Configurações de publicação do ActionScript
    9. Práticas recomendadas - Organização do ActionScript em um aplicativo
    10. Como usar ActionScript com o Animate
    11. Práticas recomendadas - Diretrizes de acessibilidade
    12. Acessibilidade no espaço de trabalho do Animate
    13. Programação e gerenciamento de scripts
    14. Ativação do suporte para plataformas personalizadas
    15. Visão geral do suporte da plataforma personalizada
    16. Criação de conteúdo acessível
    17. Trabalhar com plug-ins personalizados de suporte da plataforma
    18. Depuração do ActionScript 3.0
    19. Ativação do suporte para plataformas personalizadas
  8. Publicação e exportação
    1. Exportação de arquivos do Animate CC
    2. Publicação OAM
    3. Exportação de arquivos SVG
    4. Exportar gráficos e vídeos com o Animate
    5. Publicação de documentos AS3
    6. Exportar animações para aplicativos móveis e mecanismos de jogo
    7. Exportação de sons
    8. Exportação de arquivos de vídeo QuickTime
    9. Controle de reprodução de vídeo externo com o ActionScript
    10. Práticas recomendadas - Dicas para a criação de conteúdo em dispositivos móveis
    11. Práticas recomendadas - Convenções de vídeo
    12. Práticas recomendadas - Diretrizes de criação de aplicativos SWF
    13. Práticas recomendadas - Estruturação de arquivos FLA
    14. Práticas recomendadas para otimizar arquivos FLA para o Animate
    15. Configurações de publicação do ActionScript
    16. Especificar configurações de publicação para o Animate
    17. Exportação de arquivos projetores
    18. Exportar imagens e GIFs animados
    19. Modelos de publicação HTML
    20. Trabalhar com o Adobe Premiere Pro e o After Effects
    21. Compartilhar e publicar animações rapidamente

Trabalhar com bibliotecas

A biblioteca em um documento do Animate armazena ativos de mídia criados no ambiente de autoria do Animate ou importados para serem usados no documento. É possível criar arte-final vetorial ou texto diretamente no Animate, importar arte-final vetorial, bitmaps, vídeo e som e criar símbolos. Um símbolo é um gráfico, um botão, um clipe de filme ou texto que pode ser criado uma vez e reutilizado várias vezes. Você pode também usar o ActionScript para adicionar conteúdo de mídia a um documento dinamicamente.

A biblioteca pode também conter qualquer componente adicionado ao seu documento. Componentes podem ser clipes compilados ou componentes baseados em MovieClip.

É possível abrir a biblioteca de qualquer documento do Animate enquanto estiver trabalhando nele para disponibilizar os itens de biblioteca de um arquivo para o documento atual. Você pode pesquisar os símbolos na biblioteca pelos nomes ou os nomes do vínculo de ActionScript.

É possível criar bibliotecas permanentes em seu aplicativo do Animate que ficam disponíveis sempre que você inicia o Animate. O Animate pode também incluir várias bibliotecas de amostra que contêm botões, gráficos, clipes de filme e sons.

Você pode exportar os ativos da biblioteca como um arquivo SWF para um URL para criar uma biblioteca compartilhada de tempo de execução. Isso permite que você vincule aos ativos da biblioteca documentos do Animate que importam símbolos usando o compartilhamento do tempo de execução.

O painel Biblioteca (Janela > Biblioteca) exibe uma lista de rolagem com os nomes de todos os itens na biblioteca, o que permite que você visualize e organize esses elementos conforme trabalha. Um ícone próximo ao nome do item no painel Biblioteca indica o tipo de arquivo do item.

Observação:

Arrastar dados do Palco para o painel Biblioteca para convertê-los em símbolos é um recurso obsoleto e não funcionará com o Animate.

Arrastar objetos para o Palco entre dois documentos não encaixados é um recurso obsoleto e não funcionará com o Animate.

Abrir uma biblioteca em outro arquivo do Animate

  1. No documento atual, selecione Arquivo > Importar > Abrir biblioteca externa.
  2. Navegue até o arquivo do Animate cuja biblioteca você deseja abrir e clique em Abrir.

    A biblioteca do arquivo selecionado abre em um documento atual, com o nome do arquivo no topo do painel Biblioteca. Para usar os itens da biblioteca do arquivo selecionado no documento atual, arraste os itens para o painel Biblioteca do documento atual ou para o Palco.

Redimensionar o painel Biblioteca

  1. Siga um destes procedimentos:
    • Arraste o canto inferior direito do painel.

    • Clique no botão Estado amplo para ampliar o painel Biblioteca para que ele mostre todas as colunas.

    • Clique no botão Estado estreito para reduzir a largura do painel Biblioteca.

Alterar a largura das colunas

  1. Posicione o ponteiro entre os cabeçalhos da coluna e arraste para redimensionar.

Trabalho com pastas no painel Biblioteca

É possível organizar os itens no painel Biblioteca usando pastas. Ao criar um novo símbolo, ele é armazenado na pasta selecionada. Se nenhuma pasta for selecionada, o símbolo será armazenado na raiz da biblioteca.

O Animate também importa os arquivos GIF animados de forma organizada ao colocá-las em uma pasta separada na pasta de raiz da biblioteca e nomeando todos os bitmaps associados sequencialmente. 

Criar uma nova pasta

  1. Clique no botão Nova pasta na parte inferior do painel Biblioteca.

Abrir ou fechar uma pasta

  1. Clique duas vezes na pasta ou Selecione a pasta e selecione Expandir pasta ou Contrair pasta no menu Painel do painel Biblioteca.

Abrir ou fechar todas as pastas

  1. Selecione Expandir todas as pastas ou Contrair todas as pastas no menu Painel do painel Biblioteca.

Mover um item entre as pastas

  1. Arraste o item de uma pasta para outra.

    Se existir um item com o mesmo nome no novo local, o Animate solicita que você o substitua pelo item que você está movendo.

Classificação de itens no painel Biblioteca

As colunas no painel Biblioteca listam o nome de um item, seu tipo, o número de vezes em que ele é usado no arquivo, seu status de ligação e identificador (se o item estiver associado a uma biblioteca compartilhada ou for exportado para o ActionScript) e a data de sua última modificação.

Você pode classificar os itens no painel Biblioteca em ordem alfanumérica por qualquer coluna. Os itens ficam classificados nas pastas.

A biblioteca do Animate organiza os arquivos GIF animados importados em uma pasta separada sob a pasta raiz da biblioteca e nomeia todos os bitmaps associados sequencialmente. 

  1. Clique no cabeçalho da coluna para classificar por essa coluna. Clique no botão triângulo à direita dos cabeçalhos da coluna para inverter a ordem de classificação.

Conflitos entre ativos da biblioteca

Se você importar ou copiar um ativo da biblioteca para um documento que já contém um recurso diferente com o mesmo nome, escolha se o item existente deve ser substituído pelo novo item. Essa opção está disponível em todos os métodos para importar ou copiar ativos da biblioteca.

A caixa de diálogo Resolver itens da biblioteca é exibida quando você tenta colocar itens que entram em conflito com itens existentes no documento. O conflito ocorre quando você copia um item do documento de origem já existente no documento de destino e os itens têm datas de modificação diferentes. Evite conflitos de nome, organizando os ativos dentro de pastas na biblioteca de seu documento. A caixa de diálogo também é exibida quando você cola um símbolo ou componente no palco do documento e já tem uma cópia do símbolo ou componente com uma data de modificação diferente do símbolo que está sendo colado.

Se você optar por não substituir os itens existentes, o Animate tentará usar o item existente, em vez do item conflitante que está sendo colado. Por exemplo, se você copia um símbolo com o nome Símbolo 1 e colar a cópia no palco de um documento que já contém um símbolo chamado Símbolo 1, o Animate cria uma ocorrência do Símbolo 1 existente.

Se você optar por substituir os itens existentes, o Animate vai substituí-los (e todas as ocorrências respectivas) pelos novos itens do mesmo nome. Se você cancelar a operação Importar ou Copiar, a operação será cancelada em todos os itens (não apenas nos itens em conflito no documento de destino).

Apenas tipos idênticos de itens da biblioteca podem ser substituídos entre si. Ou seja, você não pode substituir um som com nome de Teste por um bitmap chamado Teste. Em tais casos, os novos itens são adicionados à biblioteca com a palavra Cópia anexada ao nome.

Observação:

A substituição de itens da biblioteca com o uso desse método não é reversível. Salve um backup do arquivo FLA antes de realizar operações complexas de colagem que são resolvidas substituindo os itens conflitantes da biblioteca.

Se a caixa de diálogo Resolver conflito da biblioteca for exibida durante a importação ou cópia de ativos da biblioteca em um documento, resolva o conflito de nome.

Resolver conflitos de nome entre ativos da biblioteca

  1. Execute um dos seguintes procedimentos na caixa de diálogo Resolver conflito da biblioteca:

    • Para preservar os ativos existentes no documento de destino, clique em Não substituir itens existentes.

    • Para substituir os ativos existentes e as respectivas ocorrências pelos novos itens de mesmo nome, clique em Substituir itens existentes.

Trabalho com itens da biblioteca

Ao selecionar um item no painel Biblioteca, uma visualização em miniatura do item é exibida no topo do painel Biblioteca. Se o item selecionado for animado ou for um arquivo de som, é possível usar o botão Play na janela de visualização da biblioteca ou Controlador para visualizar o item.

Pesquisar itens de biblioteca por nome de vínculo

Você pode pesquisar símbolos do painel de pesquisa da biblioteca por seus nomes ou pelos nomes de vínculo de ActionScript.

  • Para pesquisar o item de biblioteca, digite as primeiras letras do nome do símbolo ou o nome do vínculo de ActionScript do item de biblioteca. Enquanto você digita, a lista dos símbolos correspondentes aparece no painel da biblioteca.

Usar um item da biblioteca no documento atual

  1. Arraste o item do painel Biblioteca para o Palco.

    O item é adicionado à camada atual.

Converter um objeto no Palco em um símbolo na biblioteca

  1. Selecione o objeto no palco, clique com o botão direito e selecione Converter em símbolo.

Usar um item da biblioteca do documento atual em outro documento

  1. Arraste o item do painel Biblioteca ou Palco para o painel Biblioteca ou Palco de outro documento.

Copiar itens da biblioteca de um documento diferente

  1. Selecione o documento que contém os itens da biblioteca.
  2. Selecione os itens da biblioteca no painel Biblioteca.
  3. Selecione Editar > Copiar.
  4. Selecione o documento no qual você deseja copiar os itens da biblioteca.
  5. Selecione o painel Biblioteca do documento.
  6. Selecione Editar > Colar.

Edição de um item de biblioteca

  1. Selecione o item no painel Biblioteca.
  2. Selecione uma das opções a seguir no menu Painel do painel Biblioteca:
    • Para editar um item no Animate, selecione Editar.

    • Para editar um item em outro aplicativo, selecione Editar com e depois selecione um aplicativo externo.

Observação:

Ao iniciar um editor externo compatível, o Animate abre o documento importado original.

Renomeação de um item de biblioteca

Alterar o nome do item da biblioteca de um arquivo importado não altera o nome do arquivo.

  1. Siga um destes procedimentos:
    • Clique duas vezes no nome do item.

    • Selecione o item e selecione Renomear no menu Painel do painel Biblioteca.

    • Clique com o botão direito (Windows) ou clique com a tecla Control pressionada (Macintosh) no item e selecione Renomear no menu de contexto.

  2. Digite o novo nome na caixa.

Exclusão de um item da biblioteca

Ao excluir um item da Biblioteca, todas as ocorrências desse item no documento também são excluídas.

  1. Selecione o item e clique no ícone Lixeira na parte inferior do painel Biblioteca.

Localização de itens não usados da biblioteca

Para organizar seu documento, é possível localizar os itens não usados na biblioteca e excluí-los.

Observação:

Não é necessário excluir itens não usados da biblioteca para reduzir o tamanho do arquivo do documento do Animate. Os itens não usados da biblioteca não são incluídos no arquivo SWF. Entretanto, os itens vinculados para exportação são incluídos no arquivo SWF.

  1. Siga um destes procedimentos:
    • Selecione os itens não usados no menu Painel do painel Biblioteca.

    • Classifique os itens da biblioteca pela coluna Contagem de uso, que indica se um item está em uso.

Atualização dos arquivos importados na biblioteca

Se você usar um editor externo para modificar os arquivos importados para o Animate, como bitmaps ou arquivos de som, será possível atualizar os arquivos no Animate sem importá-los novamente. Também é possível atualizar símbolos importados de documentos externos do Animate. Atualizar um arquivo importado substitui seu conteúdo pelo conteúdo do arquivo externo.

Observação: você pode encontrar os arquivos GIF animados importados em uma pasta separada sob a pasta raiz da biblioteca com todos os bitmaps associados nomeados com base na sequência. 

  1. Selecione o arquivo importado no painel Biblioteca.
  2. Selecione Atualizar no menu Painel do painel Biblioteca.

Copiar ativos da biblioteca entre documentos

É possível copiar os ativos da biblioteca de um documento de origem para um documento de destino de várias maneiras: É possível compartilhar símbolos entre documentos como ativos de biblioteca compartilhada durante a criação ou em tempo de execução.

Se você tentar copiar ativos com o mesmo nome de ativos já existentes no documento de destino, a caixa de diálogo Resolver conflito da biblioteca permitirá escolher entre sobrescrever os ativos existentes ou preservá-los e adicionar os novos ativos com nomes modificados. Organize ativos da biblioteca em pastas para minimizar conflitos de nome ao copiar ativos entre documentos.

Copiar um ativo da biblioteca pelo método copiar e colar

  1. Selecione o ativo do palco no documento de origem.

  2. Selecione Editar > Copiar.

  3. Torne o documento de destino o documento ativo.

  4. Para colar o ativo no centro do quadro de colagem visível, coloque o ponteiro no palco e selecione Editar > Colar no centro. Para colocar o ativo no mesmo local do documento de origem, selecione Editar > Colar no local.

Copiar um ativo da biblioteca pelo método arrastar

  1. Com o documento de destino aberto, selecione o ativo no painel Biblioteca no documento de origem e arraste o ativo para dentro do painel Biblioteca no documento de destino.

Copiar um ativo da biblioteca, abrindo a biblioteca do documento de origem a partir do documento de destino

  1. Com o documento de destino ativo, selecione Arquivo > Importar > Abrir biblioteca externa.

  2. Selecione o documento de origem e clique em Abrir.

  3. Arraste o ativo da biblioteca do documento de origem para o palco ou para dentro da biblioteca do documento de destino.

Logotipo da Adobe

Fazer logon em sua conta