Guia do Usuário Cancelar

Desfazer, refazer e o painel de Histórico

  1. Guia do Usuário do Adobe Animate
  2. Introdução ao Animate
    1. Novidades no Animate
    2. Glossário visual
    3. Requisitos de sistema do Animate
    4. Atalhos de teclado do Animate
    5. Trabalhar com vários tipos de arquivo no Animate
  3. Animação
    1. Noções básicas de animação no Animate
    2. Como usar quadros e quadros-chave no Animate
    3. Animação quadro a quadro no Animate
    4. Como trabalhar com animação de interpolação clássica no Animate
    5. Ferramenta Pincel
    6. Guia de movimento
    7. Interpolação de movimento e ActionScript 3.0
    8. Sobre a animação com interpolação de movimento
    9. Animações de interpolação de movimento
    10. Criação de uma animação de interpolação de movimento
    11. Utilização dos quadros-chave de propriedade
    12. Animação de posição com uma interpolação
    13. Editar interpolações de movimento usando o Motion Editor
    14. Edição do caminho de movimento de uma animação de interpolação
    15. Manipulação de interpolações de movimento
    16. Adição de atenuações personalizadas
    17. Criação e aplicação das predefinições de movimento
    18. Configuração de extensões de interpolação de animação
    19. Trabalhar com interpolações de movimento salvas como arquivos XML
    20. Interpolações de movimento e interpolações clássicas
    21. Interpolação de formas
    22. Uso da animação da ferramenta Bone no Animate
    23. Trabalhar com manipulação de caracteres no Animate
    24. Como usar camadas de máscara no Adobe Animate
    25. Como trabalhar com cenas no Animate
  4. Interatividade
    1. Como criar botões com o Animate
    2. Converter projetos do Animate em outros formatos de tipo de documento
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Adicionar interatividade com snippets de código no Animate
    5. Criar componentes HTML5 personalizados
    6. Uso de componentes do HTML5 Canvas
    7. Criação de componentes personalizados: exemplos
    8. Snippets de código para componentes personalizados
    9. Práticas recomendadas - Publicidade com o Animate
    10. Criação e publicação de Realidade virtual
  5. Fluxo de trabalho e espaço de trabalho
    1. Criação e gerenciamento de pincéis
    2. Uso de Google Fonts em documentos HTML5 Canvas
    3. Uso das Bibliotecas da Creative Cloud e do Adobe Animate
    4. Uso dos painéis Palco e Ferramentas do Animate
    5. Fluxo e espaço de trabalho do Animate
    6. Uso de fontes da Web em documentos HTML5 Canvas
    7. Linhas de tempo e ActionScript
    8. Trabalhar com múltiplas linhas de tempo
    9. Definir preferências
    10. Uso de painéis de criação do Animate
    11. Criar camadas na linha do tempo com o Animate
    12. Exportar animações para aplicativos móveis e mecanismos de jogo
    13. Mover e copiar objetos
    14. Modelos
    15. Localização e substituição no Animate
    16. Desfazer, refazer e o painel de Histórico
    17. Atalhos de teclado
    18. Como usar a linha do tempo no Animate
    19. Criação de extensões HTML
    20. Opções de otimização para imagens e GIFs animados
    21. Configurações de exportação para imagens e GIFs
    22. Painel Ativos no Animate
  6. Multimídia e vídeo
    1. Transformação e combinação de objetos gráficos no Animate
    2. Criar e trabalhar com instâncias do símbolo no Animate
    3. Traçado de imagem
    4. Como usar som no Adobe Animate
    5. Exportação de arquivos SVG
    6. Criação de arquivos de vídeo para uso no Animate
    7. Como adicionar vídeos no Animate
    8. Trabalhar com pontos de sinalização de vídeo
    9. Desenhar e criar objetos com o Animate
    10. Remodelação de linhas e formas
    11. Traçados, preenchimentos e gradientes com o Animate CC
    12. Trabalhar com o Adobe Premiere Pro e o After Effects
    13. Painéis de cor no Animate CC
    14. Abrir arquivos do Flash CS6 com o Animate
    15. Trabalho com texto clássico no Animate
    16. Aplicação de ilustração final no Animate
    17. Bitmaps importados no Animate
    18. Gráficos em 3D
    19. Trabalhar com símbolos no Animate
    20. Desenhar linhas e formas com o Adobe Animate
    21. Trabalho com bibliotecas no Animate
    22. Exportação de sons
    23. Seleção de objetos no Animate CC
    24. Trabalho com arquivos AI do Illustrator no Animate
    25. Aplicação de padrões com a ferramenta Pincel de borrifar
    26. Aplicação de modos de mesclagem
    27. Organização de objetos
    28. Automação de tarefas com o menu Comandos
    29. Texto multilíngue
    30. Uso de câmera no Animate
    31. Uso do Animate com o Adobe Scout
    32. Trabalhar com arquivos Fireworks
    33. Filtros gráficos
    34. Som e ActionScript
    35. Preferências de desenho
    36. Desenho com a ferramenta Caneta
  7. Plataformas
    1. Converter projetos do Animate em outros formatos de tipo de documento
    2. Suporte da plataforma personalizada
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Criação e publicação de um documento WebGL
    5. Compactação de aplicativos no AIR para iOS
    6. Publicação de AIR em aplicativos Android
    7. Publicação no Adobe AIR para desktop
    8. Configurações de publicação do ActionScript
    9. Práticas recomendadas - Organização do ActionScript em um aplicativo
    10. Como usar ActionScript com o Animate
    11. Práticas recomendadas - Diretrizes de acessibilidade
    12. Acessibilidade no espaço de trabalho do Animate
    13. Programação e gerenciamento de scripts
    14. Ativação do suporte para plataformas personalizadas
    15. Visão geral do suporte da plataforma personalizada
    16. Criação de conteúdo acessível
    17. Trabalhar com plug-ins personalizados de suporte da plataforma
    18. Depuração do ActionScript 3.0
    19. Ativação do suporte para plataformas personalizadas
  8. Publicação e exportação
    1. Exportação de arquivos do Animate CC
    2. Publicação OAM
    3. Exportação de arquivos SVG
    4. Exportar gráficos e vídeos com o Animate
    5. Publicação de documentos AS3
    6. Exportar animações para aplicativos móveis e mecanismos de jogo
    7. Exportação de sons
    8. Exportação de arquivos de vídeo QuickTime
    9. Controle de reprodução de vídeo externo com o ActionScript
    10. Práticas recomendadas - Dicas para a criação de conteúdo em dispositivos móveis
    11. Práticas recomendadas - Convenções de vídeo
    12. Práticas recomendadas - Diretrizes de criação de aplicativos SWF
    13. Práticas recomendadas - Estruturação de arquivos FLA
    14. Práticas recomendadas para otimizar arquivos FLA para o Animate
    15. Configurações de publicação do ActionScript
    16. Especificar configurações de publicação para o Animate
    17. Exportação de arquivos projetores
    18. Exportar imagens e GIFs animados
    19. Modelos de publicação HTML
    20. Trabalhar com o Adobe Premiere Pro e o After Effects
    21. Compartilhar e publicar animações rapidamente

Comandos Desfazer, Refazer e Repetir

Para desfazer ou refazer ações em objetos individuais ou em todos os objetos no documento atual, especifique comandos Desfazer e Refazer em nível de objeto ou em nível de documento (Editar > Desfazer ou Editar > Refazer). O comportamento padrão é Desfazer e Refazer em nível de documento.

Para escolher as opções Desfazer em nível de objeto ou Desfazer em nível de documento, faça o seguinte:

  1. No Animate CC, selecione Editar > Preferências.
  2. Na guia Geral, selecione Desfazer em nível de objeto no menu suspenso.

Observe que não é possível desfazer algumas ações durante o uso de Desfazer em nível de objeto. Entre elas, estão entrar e sair do modo de edição; selecionar, editar e mover itens de biblioteca; e criar, excluir e mover cenas.

Para reaplicar uma etapa ao mesmo objeto ou a um objeto diferente, use o comando Repetir. Por exemplo, se você mover uma forma nomeada como forma_A, selecione Editar > Repetir para mover a forma novamente, ou selecione outra forma, forma_B, e selecione Editar > Repetir para mover a segunda forma igualmente.

Por padrão, o Animate oferece suporte a 100 níveis de desfazer para o comando de menu Desfazer. Selecione o número de níveis de desfazer e refazer, de 2 a 300, nas Preferências do Animate.

Por padrão, quando uma etapa é desfeita usando Editar > Desfazer ou o painel Histórico, o tamanho do arquivo do documento não é alterado, mesmo se um item for excluído do documento. Por exemplo, se você importar um arquivo de vídeo para um documento, e desfizer a importação, o tamanho do arquivo do documento ainda incluirá o tamanho do arquivo de vídeo. Quaisquer itens excluídos de um documento durante a execução de um comando Desfazer são preservados para que seja possível restaurar os itens com o comando Refazer.

Uso do painel Histórico

O painel Histórico (Janela > Histórico) mostra uma lista das etapas que você realizou no documento ativo, desde que o criou ou abriu, até um número máximo especificado de etapas. (O painel Histórico não mostra as etapas realizadas em outros documentos.) O controle deslizante no painel Histórico aponta inicialmente para a última etapa realizada.

  • Para desfazer ou refazer etapas individuais ou várias etapas de uma vez, use o painel Histórico. Aplique as etapas do painel Histórico ao mesmo objeto ou a um objeto diferente no documento. No entanto, não é possível reorganizar a ordem de etapas no painel Histórico. O painel Histórico é um registro de etapas, na ordem na qual foram realizados.

    observação:Se você desfizer uma etapa ou uma série de etapas e, em seguida, fizer uma nova ação no documento, não será mais possível desfazer as etapas no painel Histórico; elas desaparecem do painel.

  • Por padrão, o Animate oferece suporte a 100 níveis de desfazer para o painel Histórico. Selecione o número de níveis de desfazer e refazer, de 2 a 300, nas Preferências do Animate.

  • Para apagar a lista do histórico para o documento atual, limpe o painel Histórico. Depois de limpar a lista do histórico, não é possível desfazer as etapas que foram limpas. Limpar a lista do histórico não desfaz etapas; ela remove o registro dessas etapas da memória do documento atual.

Fechar um documento limpa seu histórico. Para usar as etapas de um documento após o fechamento do documento, copie as etapas com o comando Copiar etapas ou salve as etapas como um comando.

Desfazer etapas com o painel Histórico

Quando uma etapa é desfeita, ela fica esmaecida no painel Histórico.

  • Para desfazer a última etapa realizada, arraste o controle deslizante do painel Histórico uma etapa acima na lista.

  • Para desfazer várias etapas de uma vez, arraste o controle deslizante de modo que ele aponte para qualquer etapa, ou clique no lado esquerdo da etapa, ao longo do caminho do controle deslizante. Esse controle deslizante rola automaticamente até essa etapa, desfazendo todas as etapas subsequentes durante a rolagem.

observação:Rolar até uma etapa (e selecionar as etapas subsequentes) é diferente de selecionar uma etapa individual. Para rolar até uma etapa, clique no lado esquerdo da etapa.

Reproduzir etapas com o painel Histórico

Quando você reproduz etapas com o painel Histórico, as etapas reproduzidas são as etapas selecionadas (realçadas) no painel Histórico, e não necessariamente a etapa atual indicada pelo controle deslizante.

Aplique as etapas no painel Histórico a qualquer objeto selecionado no documento.

Reproduzir uma etapa

  1. No painel Histórico, selecione uma etapa e clique no botão Reproduzir.

Reproduzir uma série de etapas adjacentes

  1. Selecione as etapas no painel Histórico seguindo um destes procedimentos:
    • Arraste de uma etapa para outra. (Não arraste o controle deslizante;arraste do rótulo de texto de uma etapa para o rótulo de texto de outra etapa.)

    • Selecione a primeira etapa e, em seguida, clique com a tecla Shift pressionada na última etapa; ou selecione a última etapa e clique com a tecla Shift pressionada na primeira etapa.

  2. Clique em Reproduzir. As etapas são reproduzidas em ordem, e uma nova etapa, rotulada Reproduzir etapas, é exibida no painel Histórico.

Reproduzir etapas não adjacentes

  1. Selecione uma etapa no painel Histórico e clique com a tecla Ctrl pressionada (Windows) ou com a tecla Command (Macintosh) pressionada em outras etapas. Para cancelar a seleção de uma etapa, clique com a tecla Ctrl ou a tecla Command pressionada.
  2. Clique em Reproduzir.

Copiar e colar etapas entre documentos

Cada documento aberto tem seu próprio histórico de etapas. Para copiar etapas de um documento e colá-las em outro documento, use o comando Copiar etapas no menu de opções do painel Histórico. Se você copiar etapas em um editor de texto, elas serão coladas como código JavaScript™.

  1. No documento que contém as etapas a serem reutilizadas, selecione as etapas no painel Histórico.
  2. No menu de opções do painel Histórico, selecione Copiar etapas.
  3. Abra o documento no qual as etapas serão coladas.
  4. Selecione um objeto ao qual as etapas serão aplicadas.
  5. Selecione Editar > Colar para colar as etapas. As etapas são reproduzidas conforme são coladas no painel Histórico do documento. O painel Histórico mostra as etapas como se fossem apenas uma, denominada Colar etapas.
Logotipo da Adobe

Fazer logon em sua conta