Criação de extensões HTML

  1. Guia do Usuário do Adobe Animate
  2. Introdução ao Animate
    1. Novidades no Animate
    2. Glossário visual
    3. Requisitos de sistema do Animate
    4. Atalhos de teclado do Animate
    5. Trabalhar com vários tipos de arquivo no Animate
  3. Animação
    1. Noções básicas de animação no Animate
    2. Como usar quadros e quadros-chave no Animate
    3. Animação quadro a quadro no Animate
    4. Como trabalhar com animação de interpolação clássica no Animate
    5. Ferramenta Pincel
    6. Guia de movimento
    7. Interpolação de movimento e ActionScript 3.0
    8. Sobre a animação com interpolação de movimento
    9. Animações de interpolação de movimento
    10. Criação de uma animação de interpolação de movimento
    11. Utilização dos quadros-chave de propriedade
    12. Animação de posição com uma interpolação
    13. Editar interpolações de movimento usando o Motion Editor
    14. Edição do caminho de movimento de uma animação de interpolação
    15. Manipulação de interpolações de movimento
    16. Adição de atenuações personalizadas
    17. Criação e aplicação das predefinições de movimento
    18. Configuração de extensões de interpolação de animação
    19. Trabalhar com interpolações de movimento salvas como arquivos XML
    20. Interpolações de movimento e interpolações clássicas
    21. Interpolação de formas
    22. Uso da animação da ferramenta Bone no Animate
    23. Trabalhar com manipulação de caracteres no Animate
    24. Como usar camadas de máscara no Adobe Animate
    25. Como trabalhar com cenas no Animate
  4. Interatividade
    1. Como criar botões com o Animate
    2. Converter projetos do Animate em outros formatos de tipo de documento
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Adicionar interatividade com snippets de código no Animate
    5. Criar componentes HTML5 personalizados
    6. Uso de componentes do HTML5 Canvas
    7. Criação de componentes personalizados: exemplos
    8. Snippets de código para componentes personalizados
    9. Práticas recomendadas - Publicidade com o Animate
    10. Criação e publicação de Realidade virtual
  5. Fluxo de trabalho e espaço de trabalho
    1. Criação e gerenciamento de pincéis
    2. Uso de Google Fonts em documentos HTML5 Canvas
    3. Uso das Bibliotecas da Creative Cloud e do Adobe Animate
    4. Uso dos painéis Palco e Ferramentas do Animate
    5. Fluxo e espaço de trabalho do Animate
    6. Uso de fontes da Web em documentos HTML5 Canvas
    7. Linhas de tempo e ActionScript
    8. Trabalhar com múltiplas linhas de tempo
    9. Definir preferências
    10. Uso de painéis de criação do Animate
    11. Criar camadas na linha do tempo com o Animate
    12. Exportar animações para aplicativos móveis e mecanismos de jogo
    13. Mover e copiar objetos
    14. Modelos
    15. Localização e substituição no Animate
    16. Desfazer, refazer e o painel de Histórico
    17. Atalhos de teclado
    18. Como usar a linha do tempo no Animate
    19. Criação de extensões HTML
    20. Opções de otimização para imagens e GIFs animados
    21. Configurações de exportação para imagens e GIFs
    22. Painel Ativos no Animate
  6. Multimídia e vídeo
    1. Transformação e combinação de objetos gráficos no Animate
    2. Criar e trabalhar com instâncias do símbolo no Animate
    3. Traçado de imagem
    4. Como usar som no Adobe Animate
    5. Exportação de arquivos SVG
    6. Criação de arquivos de vídeo para uso no Animate
    7. Como adicionar vídeos no Animate
    8. Trabalhar com pontos de sinalização de vídeo
    9. Desenhar e criar objetos com o Animate
    10. Remodelação de linhas e formas
    11. Traçados, preenchimentos e gradientes com o Animate CC
    12. Trabalhar com o Adobe Premiere Pro e o After Effects
    13. Painéis de cor no Animate CC
    14. Abrir arquivos do Flash CS6 com o Animate
    15. Trabalho com texto clássico no Animate
    16. Aplicação de ilustração final no Animate
    17. Bitmaps importados no Animate
    18. Gráficos em 3D
    19. Trabalhar com símbolos no Animate
    20. Desenhar linhas e formas com o Adobe Animate
    21. Trabalho com bibliotecas no Animate
    22. Exportação de sons
    23. Seleção de objetos no Animate CC
    24. Trabalho com arquivos AI do Illustrator no Animate
    25. Aplicação de padrões com a ferramenta Pincel de borrifar
    26. Aplicação de modos de mesclagem
    27. Organização de objetos
    28. Automação de tarefas com o menu Comandos
    29. Texto multilíngue
    30. Uso de câmera no Animate
    31. Uso do Animate com o Adobe Scout
    32. Trabalhar com arquivos Fireworks
    33. Filtros gráficos
    34. Som e ActionScript
    35. Preferências de desenho
    36. Desenho com a ferramenta Caneta
  7. Plataformas
    1. Converter projetos do Animate em outros formatos de tipo de documento
    2. Suporte da plataforma personalizada
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Criação e publicação de um documento WebGL
    5. Compactação de aplicativos no AIR para iOS
    6. Publicação de AIR em aplicativos Android
    7. Publicação no Adobe AIR para desktop
    8. Configurações de publicação do ActionScript
    9. Práticas recomendadas - Organização do ActionScript em um aplicativo
    10. Como usar ActionScript com o Animate
    11. Práticas recomendadas - Diretrizes de acessibilidade
    12. Acessibilidade no espaço de trabalho do Animate
    13. Programação e gerenciamento de scripts
    14. Ativação do suporte para plataformas personalizadas
    15. Visão geral do suporte da plataforma personalizada
    16. Criação de conteúdo acessível
    17. Trabalhar com plug-ins personalizados de suporte da plataforma
    18. Depuração do ActionScript 3.0
    19. Ativação do suporte para plataformas personalizadas
  8. Publicação e exportação
    1. Exportação de arquivos do Animate CC
    2. Publicação OAM
    3. Exportação de arquivos SVG
    4. Exportar gráficos e vídeos com o Animate
    5. Publicação de documentos AS3
    6. Exportar animações para aplicativos móveis e mecanismos de jogo
    7. Exportação de sons
    8. Exportação de arquivos de vídeo QuickTime
    9. Controle de reprodução de vídeo externo com o ActionScript
    10. Práticas recomendadas - Dicas para a criação de conteúdo em dispositivos móveis
    11. Práticas recomendadas - Convenções de vídeo
    12. Práticas recomendadas - Diretrizes de criação de aplicativos SWF
    13. Práticas recomendadas - Estruturação de arquivos FLA
    14. Práticas recomendadas para otimizar arquivos FLA para o Animate
    15. Configurações de publicação do ActionScript
    16. Especificar configurações de publicação para o Animate
    17. Exportação de arquivos projetores
    18. Exportar imagens e GIFs animados
    19. Modelos de publicação HTML
    20. Trabalhar com o Adobe Premiere Pro e o After Effects
    21. Compartilhar e publicar animações rapidamente

O Animate pode ser estendido usando extensões HTML. O Adobe Extension Builder 3 permite que você crie extensões HTML para o Animate. Antes, somente era possível fazer isso usando extensões SWF. No entanto, o Adobe Extension Builder 3 permite que você crie extensões HTML para aplicativos da Creative Cloud. Para começar, é preciso baixar e instalar o Eclipse e o Extension Builder 3.0. Para obter mais informações, visite este link.

Criação de uma extensão HTML

Para criar uma extensão HTML, faça o seguinte.

  1. Inicie o Eclipse. 
  2. No assistente de Novo projeto, crie um novo Projeto de extensão de aplicativo. Forneça um nome significativo para o projeto e clique em Next (Avançar).
  3. No painel Novo projeto de extensão de aplicativo Adobe, escolha Adobe Animate. Clique em Avançar.
  4. Configure sua extensão usando as opções disponíveis:
    1. Bundle ID (ID de compactação) identifica especificamente sua extensão.
    2. Menu name (Nome do menu) é o nome de exibição de sua extensão. O Nome do menu aparece no menu Janela> Extensões no Animate.
    3. Detalhes da janela use essas opções para personalizar o tipo e o tamanho da janela de extensão.

      Clique em Avançar.
  5. É possível personalizar ainda mais as bibliotecas de referência de sua extensão nas próximas telas:
    1. Biblioteca de interfaces CEP fornece funções para interagir com o aplicativo host. A opção é selecionada por padrão.
    2. Estruturas são para bibliotecas Javascript comuns, como a jQuery.
    3. Serviços inclui o Kit de ferramentas de comunicação de IPC da Adobe, que possibilita a comunicação entre aplicativos da Adobe, extensões e aplicativos externos. Ele fornece um protocolo para envio de mensagens pelo Gerenciador de serviços CEP, que atua como um hub para as comunicações da Creative Cloud.

      Clique em Concluir para criar um novo projeto do Eclipse.

Depuração de extensão no Animate 

É possível executar a extensão diretamente no Eclipse:

  1. Clique com o botão direito do mouse no projeto e selecione Executar como > Adobe Flash Extension. Isso inicia o Animate.
  2. No Animate, selecione o item de menu Janela > Extensões . Isso abre o painel de extensões.

Exportar sua extensão

Para distribuir sua extensão, é necessário exportá-la como um pacote ZXP. O pacote ZXP é baixado e executado pelo Adobe Extension Manager em aplicativos da Creative Cloud:

  1. No Eclipse, alterne para a exibição do Script Explorer para clicar com o botão direito do mouse em seu projeto e selecionar Export (Exportar) > Adobe Extension Builder 3 > Application Extension (Extensão de aplicativo). Isso exibe o assistente de exportação.
  2. É necessário ter um certificado para assinar o pacote de extensão. Navegue até um certificado existente ou clique em Create (Criar) para criar um novo.
  3. Clique em Finish (Concluir).
  4. Quando a exportação for concluída, você encontrará o pacote ZXP para sua extensão na pasta do projeto, pronto para a distribuição.

Observação: para efetuar a instalação, você deverá acessar o arquivo <extension>\.staged-extension\CSXS\manifest.xml e atualizar a tag do host para definir a versão mínima do Animate para 13.0.

Instalação da extensão no Animate 

Você pode instalar extensões HTML no Animate usando o Adobe Extension Manager. Extensões HTML podem ajudá-lo a ampliar as funcionalidades e os recursos do Animate. Para instalar extensões, consulte este link.

Adição de interatividade às extensões HTML

Você pode construir uma extensão HTML para interagir com o Animate. Basta adicionar controles, definir comportamentos e obter informações sobre o ambiente (que inclui o Animate e o sistema operacional) do host. Isso pode ser feito de duas maneiras:

  1. Usando a biblioteca de interfaces CEP: a biblioteca de interfaces CEP oferece APIs que ajudam a obter informações sobre o ambiente do host e fornece um script eval que permite a execução de JSFLs. Para saber mais sobre a biblioteca de interfaces CEP, vá até Ajuda > Conteúdo da ajuda > Adobe Extension Builder > Referências no Eclipse.
  2. Usando o JSFL: scripts JSFL podem ser executados com uma API de script eval da biblioteca de interfaces CEP. Para saber mais sobre JSFLs, consulte este link.

    Além de JSFLs, a infraestrutura do CEP dentro do Animate também exibe os seguintes eventos, que podem ser usados somente nos painéis HTML.
    • com.adobe.events.flash.documentChanged é disparado devido a uma alteração no documento que se encontra ativo.
    • com.adobe.events.flash.timelineChanged é disparado no momento em que é feita alguma alteração na linha do tempo do documento que se encontra ativo.
    • com.adobe.events.flash.documentSaved é disparado no momento em que o arquivo que se encontra ativo é salvo.
    • com.adobe.events.flash.documentOpened é disparado quando um novo documento é aberto.
    • com.adobe.events.flash.documentClosed é disparado ao fechar o documento que se encontra ativo.
    • com.adobe.events.flash.documentNew é disparado ao criar um novo documento.
    • com.adobe.events.flash.layerChanged é disparado quando uma nova camada é selecionada.
    • com.adobe.events.flash.frameChanged é disparado quando um novo quadro é selecionado.
    • com.adobe.events.flash.selectionChanged é disparado quando outro objeto é selecionado no palco.
    • com.adobe.events.flash.mouseMove é disparado ao mover o mouse no palco.

Exemplo

csinterface.addEventListener("com.adobe.events.flash.selectionChanged", CallbackFunction)

No trecho de código acima:

  • csinterface: objeto da biblioteca de interfaces CEP.
  • com.adobe.events.flash.selectionChanged: evento que dispara uma alteração na seleção de um objeto. Você também pode usar qualquer um dos eventos mencionados acima.
  • CallbackFunction: método que detecta o evento disparado.
Logotipo da Adobe

Fazer logon em sua conta