Guia do Usuário Cancelar

Como trabalhar com animação de interpolação clássica no Animate

  1. Guia do Usuário do Adobe Animate
  2. Introdução ao Animate
    1. Novidades no Animate
    2. Glossário visual
    3. Requisitos de sistema do Animate
    4. Atalhos de teclado do Animate
    5. Trabalhar com vários tipos de arquivo no Animate
  3. Animação
    1. Noções básicas de animação no Animate
    2. Como usar quadros e quadros-chave no Animate
    3. Animação quadro a quadro no Animate
    4. Como trabalhar com animação de interpolação clássica no Animate
    5. Ferramenta Pincel
    6. Guia de movimento
    7. Interpolação de movimento e ActionScript 3.0
    8. Sobre a animação com interpolação de movimento
    9. Animações de interpolação de movimento
    10. Criação de uma animação de interpolação de movimento
    11. Utilização dos quadros-chave de propriedade
    12. Animação de posição com uma interpolação
    13. Editar interpolações de movimento usando o Motion Editor
    14. Edição do caminho de movimento de uma animação de interpolação
    15. Manipulação de interpolações de movimento
    16. Adição de atenuações personalizadas
    17. Criação e aplicação das predefinições de movimento
    18. Configuração de extensões de interpolação de animação
    19. Trabalhar com interpolações de movimento salvas como arquivos XML
    20. Interpolações de movimento e interpolações clássicas
    21. Interpolação de formas
    22. Uso da animação da ferramenta Bone no Animate
    23. Trabalhar com manipulação de caracteres no Animate
    24. Como usar camadas de máscara no Adobe Animate
    25. Como trabalhar com cenas no Animate
  4. Interatividade
    1. Como criar botões com o Animate
    2. Converter projetos do Animate em outros formatos de tipo de documento
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Adicionar interatividade com snippets de código no Animate
    5. Criar componentes HTML5 personalizados
    6. Uso de componentes do HTML5 Canvas
    7. Criação de componentes personalizados: exemplos
    8. Snippets de código para componentes personalizados
    9. Práticas recomendadas - Publicidade com o Animate
    10. Criação e publicação de Realidade virtual
  5. Fluxo de trabalho e espaço de trabalho
    1. Criação e gerenciamento de pincéis
    2. Uso de Google Fonts em documentos HTML5 Canvas
    3. Uso das Bibliotecas da Creative Cloud e do Adobe Animate
    4. Uso dos painéis Palco e Ferramentas do Animate
    5. Fluxo e espaço de trabalho do Animate
    6. Uso de fontes da Web em documentos HTML5 Canvas
    7. Linhas de tempo e ActionScript
    8. Trabalhar com múltiplas linhas de tempo
    9. Definir preferências
    10. Uso de painéis de criação do Animate
    11. Criar camadas na linha do tempo com o Animate
    12. Exportar animações para aplicativos móveis e mecanismos de jogo
    13. Mover e copiar objetos
    14. Modelos
    15. Localização e substituição no Animate
    16. Desfazer, refazer e o painel de Histórico
    17. Atalhos de teclado
    18. Como usar a linha do tempo no Animate
    19. Criação de extensões HTML
    20. Opções de otimização para imagens e GIFs animados
    21. Configurações de exportação para imagens e GIFs
    22. Painel Ativos no Animate
  6. Multimídia e vídeo
    1. Transformação e combinação de objetos gráficos no Animate
    2. Criar e trabalhar com instâncias do símbolo no Animate
    3. Traçado de imagem
    4. Como usar som no Adobe Animate
    5. Exportação de arquivos SVG
    6. Criação de arquivos de vídeo para uso no Animate
    7. Como adicionar vídeos no Animate
    8. Trabalhar com pontos de sinalização de vídeo
    9. Desenhar e criar objetos com o Animate
    10. Remodelação de linhas e formas
    11. Traçados, preenchimentos e gradientes com o Animate CC
    12. Trabalhar com o Adobe Premiere Pro e o After Effects
    13. Painéis de cor no Animate CC
    14. Abrir arquivos do Flash CS6 com o Animate
    15. Trabalho com texto clássico no Animate
    16. Aplicação de ilustração final no Animate
    17. Bitmaps importados no Animate
    18. Gráficos em 3D
    19. Trabalhar com símbolos no Animate
    20. Desenhar linhas e formas com o Adobe Animate
    21. Trabalho com bibliotecas no Animate
    22. Exportação de sons
    23. Seleção de objetos no Animate CC
    24. Trabalho com arquivos AI do Illustrator no Animate
    25. Aplicação de padrões com a ferramenta Pincel de borrifar
    26. Aplicação de modos de mesclagem
    27. Organização de objetos
    28. Automação de tarefas com o menu Comandos
    29. Texto multilíngue
    30. Uso de câmera no Animate
    31. Uso do Animate com o Adobe Scout
    32. Trabalhar com arquivos Fireworks
    33. Filtros gráficos
    34. Som e ActionScript
    35. Preferências de desenho
    36. Desenho com a ferramenta Caneta
  7. Plataformas
    1. Converter projetos do Animate em outros formatos de tipo de documento
    2. Suporte da plataforma personalizada
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Criação e publicação de um documento WebGL
    5. Compactação de aplicativos no AIR para iOS
    6. Publicação de AIR em aplicativos Android
    7. Publicação no Adobe AIR para desktop
    8. Configurações de publicação do ActionScript
    9. Práticas recomendadas - Organização do ActionScript em um aplicativo
    10. Como usar ActionScript com o Animate
    11. Práticas recomendadas - Diretrizes de acessibilidade
    12. Acessibilidade no espaço de trabalho do Animate
    13. Programação e gerenciamento de scripts
    14. Ativação do suporte para plataformas personalizadas
    15. Visão geral do suporte da plataforma personalizada
    16. Criação de conteúdo acessível
    17. Trabalhar com plug-ins personalizados de suporte da plataforma
    18. Depuração do ActionScript 3.0
    19. Ativação do suporte para plataformas personalizadas
  8. Publicação e exportação
    1. Exportação de arquivos do Animate CC
    2. Publicação OAM
    3. Exportação de arquivos SVG
    4. Exportar gráficos e vídeos com o Animate
    5. Publicação de documentos AS3
    6. Exportar animações para aplicativos móveis e mecanismos de jogo
    7. Exportação de sons
    8. Exportação de arquivos de vídeo QuickTime
    9. Controle de reprodução de vídeo externo com o ActionScript
    10. Práticas recomendadas - Dicas para a criação de conteúdo em dispositivos móveis
    11. Práticas recomendadas - Convenções de vídeo
    12. Práticas recomendadas - Diretrizes de criação de aplicativos SWF
    13. Práticas recomendadas - Estruturação de arquivos FLA
    14. Práticas recomendadas para otimizar arquivos FLA para o Animate
    15. Configurações de publicação do ActionScript
    16. Especificar configurações de publicação para o Animate
    17. Exportação de arquivos projetores
    18. Exportar imagens e GIFs animados
    19. Modelos de publicação HTML
    20. Trabalhar com o Adobe Premiere Pro e o After Effects
    21. Compartilhar e publicar animações rapidamente

As Interpolações clássicas são um modo antigo de criar animações no Animate. Essas interpolações são semelhantes às novas interpolações de movimento, porém mais complicadas de criar e menos flexíveis. Entretanto, as interpolações clássicas proporcionam mais tipos de controle sobre a animação do que as interpolações de movimento. A maioria dos usuários vai escolher trabalhar com interpolações de movimento mais recentes, mas outros ainda vão querer usar as clássicas. Para obter mais informações sobre as diferenças, consulte Diferenças entre interpolações de movimento e interpolações clássicas.

Antes de começar:

Antes de trabalhar com interpolações clássicas, tenha em mente os seguintes pontos:

  • As interpolações clássicas são o modo mais antigo de criar uma animação interpolada no Animate. A forma mais nova e fácil é usar interpolações de movimento. Consulte Animação de interpolação de movimento.

  • Você não pode interpolar propriedades 3D com interpolações clássicas.

Para ver exemplos de animação de interpolação clássica, consulte a página de exemplos do Animate no endereço www.adobe.com/go/learn_fl_samples_br. Estão disponíveis os seguintes exemplos:

  • Sombra Projetada Animada: faça download e descompacte o arquivo ZIP de exemplo, e vá até a pasta Graphics\AnimatedDropShadow para acessar o exemplo.

  • Animação e Gradientes: faça download e descompacte o arquivo ZIP de exemplo, e vá até a pasta Graphics\AnimationAndGradients para acessar o exemplo.

 Como a maioria das ações no Animate, a animação não exige nenhum ActionScript. Contudo, você pode criar a animação com o ActionScript se quiser.

Criar e editar quadros-chave para animação de interpolação clássica

As alterações em uma animação de interpolações clássicas são definidas em um quadro-chave. Por outro lado, na animação interpolada, você define os quadros-chave em pontos significativos da animação e o Animate cria o conteúdo dos quadros entre eles. Os quadros interpolados de uma animação aparecem em azul claro, com uma seta entre os quadros-chave. Como os documentos do Animate salvam as formas em todos os quadros-chave, crie-os apenas naqueles pontos em que alguma coisa muda na arte.

Os quadros-chave são indicados na Linha do tempo: um círculo sólido representa um quadro-chave com conteúdo e um círculo vazio antes do quadro representa um quadro-chave vazio. Os quadros subsequentes acrescentados à mesma camada têm o mesmo conteúdo que o quadro-chave.

Somente quadros-chave podem ser editados em interpolações clássicas. Você pode visualizar os quadros interpolados, mas não pode editá-los diretamente. Para editar os quadros interpolados, altere um dos quadros-chave definidos, ou insira um novo quadro-chave entre os quadros-chave de início e fim da interpolação. Para adicionar itens ao quadro-chave atual, arraste os itens do painel Biblioteca para o Palco.

Para exibir e editar mais de um quadro por vez, consulte Use as sequências em papel transparente.

 Este tópico aborda a criação de quadros-chave para interpolações clássicas mais antigas. Para mais informações sobre quadros-chave de propriedade para as interpolações de movimento mais recentes, consulte Criar animação de interpolação.

Criar quadros-chave

  1. Siga um destes procedimentos:
    • Selecione um quadro na Linha do tempo e selecione Inserir > Linha do tempo > Quadro-chave.

    • Clique com o botão direito (no Windows) ou clique com o botão Control (no Macintosh) no quadro-chave na Linha do tempo e selecione Inserir quadro-chave.

Inserir quadros na linha do tempo

  • Para inserir um novo quadro, selecione Inserir > Linha do tempo > Quadro.

  • Para criar um quadro-chave, selecione Inserir > Linha do tempo > Quadro-chave ou clique com o botão direito (Windows) ou com a tecla Control pressionada (Macintosh) no quadro para inserir o quadro-chave. Selecione Inserir quadro-chave.

  • Para criar um quadro-chave em branco, selecione Inserir > Linha do tempo > Quadro-chave em branco ou clique com o botão direito (Windows) ou com a tecla Control pressionada (Macintosh) no quadro para inserir o quadro-chave. Selecione Inserir quadro-chave em branco.

Excluir ou modificar um quadro ou quadro-chave

  • Para excluir um quadro, quadro-chave ou sequência de quadros, selecione-os e clique com o botão direito (no Windows) ou com o botão Control (no Macintosh) e selecione Remover quadros. Os quadros circundantes permanecem inalterados.

  • Para mover um quadro-chave ou sequência de quadros e seu conteúdo, selecione-os e arraste-os para o local desejado.

  • Para estender a duração de um quadro-chave, pressione Alt (no Windows) ou Option (no Macintosh) e arraste-o até o quadro final da nova sequência.

  • Para copiar e colar um quadro ou sequência de quadros, selecione-os e escolha Editar > Linha do tempo > Copiar quadros. Selecione um quadro ou uma sequência e selecione Editar > Linha do tempo > Colar quadros. Para colar e substituir o número exato de quadros copiados na linha do tempo de destino, use a opção Colar e substituir quadros.

  • Para converter um quadro-chave em um quadro, selecione o quadro-chave e depois Modificar > Linha do tempo > Limpar quadro-chave, ou clique com o botão direito (no Windows) ou com o botão Control (no Macintosh) no quadro-chave e selecione Limpar quadro-chave. O quadro-chave limpo e todos os quadros até o quadro-chave subsequente são substituídos pelo conteúdo do quadro que precede o quadro-chave limpo.

  • Para copiar um quadro-chave ou sequência de quadros arrastando, selecione-os, pressione a tecla Alt (no Windows) ou a tecla Option (no Macintosh) e arraste-os até o novo local.

  • Para alterar a extensão de uma sequência interpolada, arraste o quadro-chave de início e fim para a direita ou para a esquerda.

  • Para adicionar um item de biblioteca ao quadro-chave atual, arraste o item do painel da Biblioteca para o Palco.

  • Para inverter uma sequência de animação, selecione os quadros apropriados em uma ou mais camadas e selecione Modificar > Linha do tempo > Inverter quadros. Os quadros-chave devem estar no começo e no final da sequência.

Adicionar animação de interpolação clássica em uma ocorrência, um grupo ou texto

 Este tópico aborda a criação de interpolações clássicas mais antigas. Para mais informações sobre como criar as interpolações de movimento mais recentes, consulte Criar animação de interpolação.

Para interpolar alterações em propriedades de ocorrências, grupos e tipo, é possível usar uma interpolação clássica. O Animate pode interpolar a posição, o tamanho, a rotação e a inclinação de ocorrências, grupos e textos. Além disso, o Animate pode interpolar a cor de ocorrências e do texto, criando alterações graduais de cor ou fazendo a ocorrência aparecer ou desaparecer.

Para interpolar a cor dos grupos ou do texto, transforme-os em símbolos. Antes de animar caracteres individuais em um bloco de texto separadamente, coloque cada caractere em um bloco de texto separado.

Se você aplicar uma interpolação clássica e alterar o número de quadros entre os dois quadros-chave, o Animate interpola automaticamente os quadros outra vez. Ou, se você mover o grupo ou símbolo em um dos dois quadros-chave, o Animate irá interpolar automaticamente os quadros outra vez.

 

Criar uma animação de interpolação de movimento

  1. Para tornar uma camada como uma camada ativa, clique no nome da camada e selecione um quadro-chave vazio na camada, para começar. Esse quadro será o primeiro quadro da interpolação clássica.

  2. Para adicionar conteúdo ao primeiro quadro da interpolação clássica, execute um dos seguintes procedimentos:
    • Crie um objeto gráfico com a ferramenta Caneta, Oval, Retângulo, Lápis ou Pincel e depois converta-o para um símbolo.

    • Crie uma ocorrência, grupo ou bloco de texto no Palco.

    • Arraste uma ocorrência de um símbolo do painel Biblioteca.

     Para criar uma interpolação, você deve ter apenas um item na camada.

  3. Crie um segundo quadro-chave onde você deseja que a animação termine, e deixe o novo quadro-chave selecionado.
  4. Para modificar o item no quadro final, realize um dos procedimentos a seguir:
    • Mova o item para a nova posição.

    • Modifique o tamanho, a rotação ou a inclinação do item.

    • Modifique a cor do item (apenas em ocorrência ou bloco de texto). Para interpolar a cor dos elementos que não sejam ocorrências ou blocos de texto, use a interpolação de forma.

  5. Para criar a interpolação clássica, siga um destes procedimentos:
    • Clique em um quadro na extensão de quadros da interpolação e selecione Inserir > Interpolação clássica.

    • Clique com o botão direito do mouse (Windows) ou clique mantendo a tecla Control pressionada (Macintosh) em cada quadro selecionado e selecione Criar interpolação clássica no menu de contexto.

    Se você criou um objeto gráfico na etapa 2, o Animate converterá automaticamente o objeto em um símbolo e o denominará tween1.

  6. Para interpolar o tamanho do item selecionado, selecione a escala na seção de interpolação do Inspetor de propriedades. Como pré-requisito, você altera o tamanho do item na etapa 4.

  7. Para produzir um movimento mais realista, aplique uma atenuação à interpolação clássica. Para aplicar a atenuação a uma interpolação clássica, use o campo Atenuação na seção Interpolação do Inspetor de propriedades. Use a caixa de diálogo Atenuação personalizada para controlar a velocidade da interpolação clássica com mais precisão.

    Para definir a taxa de alteração entre os quadros interpolados, arraste o valor do campo Atenuação ou insira um valor.

    • Para começar a interpolação clássica lentamente e acelerá-la até o final da animação, insira um valor negativo entre -1 e -100.

    • Para começar a interpolação clássica rapidamente e desacelerá-la até o final da animação, insira um valor positivo entre 1 e 100.

    • Para produzir uma alteração de velocidade mais complexa dentro da extensão de quadros da interpolação, clique no botão Editar ao lado do campo atenuação. Abre a caixa de diálogo Atenuação personalizada.

      Por padrão, a taxa de alteração entre os quadros interpolados é constante. A atenuação cria uma aparência mais natural de aceleração ou desaceleração ajustando gradualmente a taxa de mudança.

  8. Para girar o item selecionado durante a interpolação, selecione uma opção do menu Girar no Inspetor de propriedades:
    • Para impedir a rotação, selecione Nenhum (a configuração padrão).

    • Para girar o objeto uma vez na direção que exige o menor movimento, selecione Automático.

    • Para girar o objeto conforme indicado e depois inserir o número de rotações, selecione sentido horário ou sentido anti-horário.

     A rotação na etapa 8 será acrescentada a qualquer rotação que você tenha aplicado ao quadro final na etapa 4.

  9. Se estiver usando um caminho de movimento, selecione Orientar para o caminho, no Inspetor de propriedades, para orientar a linha de base do elemento interpolado para o caminho de movimento.
  10. Para sincronizar a animação das ocorrências do símbolo gráfico com a Linha do tempo principal, selecione a opção Sincronizar no Inspetor de propriedades.

     As opções Sincronizar símbolos e sincronizar recalculam o número de quadros em uma interpolação para corresponder ao número de quadros alocados a ela. Use a opção Sincronizar se os quadros em uma sequência de animação não forem um múltiplo par do número de quadros na instância gráfica.

  11. Se você estiver usando um caminho de movimento, selecione Ajustar para segurar o elemento interpolado ao caminho de movimento através do seu ponto de registro.

Dê vida aos personagens usando a Interpolação clássica

Os personagens ganham vida por meio da Interpolação clássica. Deseja dar vida a suas animações? Assista ao tutorial no fim deste exemplo e siga estas etapas:

  1. Selecione o objeto e clique em Modificar.

  2. Selecione Converter em símbolo... e escolha as seguintes opções:

    • Nome: insira o nome do símbolo.
    • Digite: selecione Gráfico na lista suspensa.
  3. Clique em OK e selecione a Ferramenta de transformação livre.

  4. Arraste o ponto branco no centro para inclinar o objeto.

  5. Clique com o botão direito do mouse no quadro e selecione Criar interpolação clássica.

Como dar vida aos seus personagens usando a Interpolação clássica

Assista ao vídeo para saber como criar movimento para animação.

Trabalhar com interpolações clássicas salvas como arquivos XML

O Animate permite que você trabalhe com interpolações clássicas como arquivos XML. O Animate permite de forma nativa que você aplique os seguintes comandos em qualquer interpolação clássica:

  • Copiar movimento como XML

  • Exportar movimento como XML

  • Importar movimento como XML

Copiar movimento como XML

Permite que você copie as propriedades de movimento aplicadas a qualquer objeto no palco em determinado quadro. 

  1. Crie uma interpolação clássica.

  2. Selecione qualquer quadro chave na linha do tempo.

  3. Vá até Comandos > Copiar movimento como XML.

As propriedades de Movimento são copiadas para a área de transferência como dados XML. Em seguida, você pode usar qualquer editor de texto para trabalhar com o arquivo XML.

Exportar movimento como XML

Permite que você exporte propriedades de movimento aplicadas a qualquer objeto no palco para um arquivo XML que pode ser salvo.

 

  1. Crie uma interpolação clássica. 

  2. Vá até Comandos > Exportar movimento como XML.

  3. Navegue até um local adequado onde você deseja salvar o arquivo.

  4. Forneça um nome para o arquivo XML e clique em Salvar.

    A interpolação clássica é exportada como um arquivo XML no local especificado.

Importar movimento como XML

Permite que você importe um arquivo XML existente que tem propriedades de movimento definidas.

  1. Selecione um objeto no palco.

  2. Vá até Comandos > Importar movimento como XML.

  3. Navegue até o local e selecione o arquivo XML. Clique em OK.

  4. Na caixa de diálogo Colar movimento especial, selecione as propriedades que deseja aplicar no objeto selecionado.

  5. Clique em OK.

Criar uma camada de guia de movimento

Para controlar o movimento de objetos em uma animação com interpolação clássica, crie uma camada de guia de movimento.

Não é possível arrastar uma camada de interpolação de movimento ou uma camada de pose de cinemática inversa em uma camada de guia.

  1. Arrastar uma camada normal para uma camada de guia. Essa ação converte a camada de guia em uma camada de guia de movimento e vincula a camada normal à nova camada de guia de movimento.

     Para impedir a conversão acidental de uma camada de guia, coloque todas as camadas de guia na parte inferior da ordem de camadas.

Criar animação de interpolação clássica ao longo de um caminho

 Este tópico aborda o trabalho com interpolações mais antigas. Para mais informações sobre como usar as novas interpolações de movimento com caminhos de movimento, consulte Editar o caminho de movimento de uma interpolação de animação.

As camadas da guia de movimento permitem desenhar caminhos ao longo dos quais podem ser animadas as ocorrências interpoladas, os grupos ou blocos de texto. Você pode vincular múltiplas camadas a uma camada de guia de movimento para fazer com que vários objetos sigam o mesmo caminho. Uma camada normal que é vinculada a uma camada de guia de movimento torna-se uma camada guiada.

Caminho do movimento
Neste exemplo, dois objetos em camadas separadas são vinculados ao mesmo caminho de movimento.

Criar um caminho de movimento para uma animação interpolada clássica

  1. Crie uma sequência de animação interpolada clássica.

    Se você selecionar Orientar para o caminho no Inspetor de propriedades, a linha de base do elemento interpolado será orientada para o caminho de movimento. Se você selecionar Encaixar, o ponto de registro do elemento interpolado se ajusta ao caminho de movimento.

  2. Clique com o botão direito do mouse (Windows) ou clique com a tecla Control pressionada (Macintosh) no nome da camada que contém a interpolação clássica e selecione Adicionar guia de movimento clássico.

    O Animate adiciona uma camada de guia de movimento sob a camada de interpolação clássica e recua o nome da camada de interpolação clássica. Representa que a camada de interpolação clássica está ligada à camada de guia de movimento.

     Se você já tiver uma camada de guia na linha do tempo, é possível arrastar uma camada que contém a interpolação clássica para baixo da camada de guia. Essa ação converte a camada de guia em uma guia de movimento e a vincula à interpolação clássica.

    Camada de guia de movimento
    Uma camada de guia de movimento acima da camada que contém a interpolação clássica.

  3. Para adicionar um caminho à camada de guia de movimento, selecione a camada de guia de movimento e use a ferramenta de caneta, lápis, linha, círculo, retângulo ou pincel.

    Também é possível copiar um traçado na camada de guia de movimento.

  4. Arraste o objeto que estiver interpolando para encaixá-lo no início do primeiro quadro ou no fim do último quadro.

    Gráfico encaixado no início do traçado de uma guia
    Gráfico de um carro encaixado no início do traçado de uma guia.

     Para obter melhores resultados de encaixe, arraste o símbolo por seu ponto de transformação.

  5. Para ocultar a camada de guia de movimento e o caminho, clique na coluna de ícone de olho na camada de guia de movimento. Se você ocultar, apenas o movimento do objeto estará visível enquanto trabalha. 

    O grupo ou o símbolo segue o caminho de movimento quando você reproduz a animação.

Para saber mais sobre o guia de animação com base no contorno da largura da variável e na cor do contorno da variável, consulte Guia de animação

  1. Siga um destes procedimentos:
    • Arraste uma camada existente abaixo da camada da guia de movimento. A camada é recuada abaixo da camada da guia de movimento. Todos os objetos nesta camada automaticamente se ajustam ao caminho de movimento.

    • Crie uma camada abaixo da camada da guia de movimento. Os objetos que você interpola nesta camada são automaticamente interpolados ao longo do caminho de movimento.

    • Selecione uma camada abaixo da camada da guia de movimento. Selecione Modificar > Linha do tempo > Propriedades da camada e selecione Guia.

  1. Para desvinculá-las, selecione a camada e siga um destes procedimentos:

    • Arraste a camada acima da camada da guia de movimento.

    • Selecione Modificar > Linha do tempo > Propriedades da camada e selecione Normal como tipo de camada.

Colar propriedades de animações de interpolação clássica

 Este tópico aborda a colagem de propriedades de interpolações clássicas mais antigas. Para mais informações sobre como colar propriedades das interpolações de movimento mais recentes, consulte Copiar e colar propriedades de interpolação de movimento.

O comando Colar movimento permite copiar uma interpolação clássica, e colar apenas as propriedades específicas a serem aplicadas em outro objeto.

  1. Selecione os quadros na Linha do tempo que contêm a interpolação clássica a ser copiada. Os quadros que você seleciona devem estar na mesma camada. No entanto, a seleção não precisa se restringir a uma única interpolação clássica; ela pode transpor uma interpolação, quadros vazios, ou duas ou mais interpolações.
  2. Selecione Editar > Linha do tempo > Copiar movimento.

  3. Para receber a interpolação clássica copiada, selecione a instância do símbolo.

  4. Selecione Editar > Linha do tempo > Colar movimento especial. Selecione as propriedades específicas da interpolação clássica para colar na ocorrência do símbolo. As propriedades de interpolação clássica são as seguintes:

    Posição X

    Até que distância um objeto se move na direção x.

    Posição Y

    Até que distância um objeto se move na direção y.

    Escala horizontal

    A relação entre o tamanho atual do objeto e seu tamanho natural na direção horizontal (X).

    Escala vertical

    Especifica a relação entre o tamanho atual do objeto e seu tamanho natural na direção vertical (Y).

    Girar e inclinar

    A rotação e a inclinação do objeto. Essas propriedades devem ser aplicadas conjuntamente a um objeto. A inclinação é uma medida de rotação em graus e, quando você gira e inclina, cada propriedade afeta a outra.

    Cor

    Todos os valores de cor, como Tonalidade, Brilho e Alfa, são aplicados ao objeto.

    Filtros

    Todos os valores e alterações de filtro para o intervalo selecionado. Caso sejam aplicados filtros a um objeto, o filtro é colado com todos os valores intactos, e seu estado (ativado ou desativado) também se aplica ao novo objeto.

    Modo de mesclagem

    Aplica o modo de mesclagem do objeto.

    Substituir propriedades da escala de destino

    Quando está desmarcada, especifica que todas as propriedades sejam coladas em relação ao objeto de destino. Quando marcada, essa opção substitui as propriedades de escala do destino.

    Substituir propriedades de rotação de destino e inclinação

    Quando está desmarcada, especifica que todas as propriedades sejam coladas em relação ao objeto de destino. Quando marcada, as propriedades coladas substituem as propriedades existentes de rotação e escala do objeto.

    As informações necessárias de quadros, interpolação e símbolo são inseridas para corresponder à interpolação original copiada.

    Para copiar a interpolação clássica de um símbolo para o painel Ações ou usá-la em outro projeto como ActionScript, use o comando Copiar movimento como ActionScript 3.0.

Criar predefinições de atenuação

As predefinições de atenuação são atenuações pré-configuradas que podem ser aplicadas a um objeto no palco.

Um conjunto de predefinições de atenuação geralmente utilizadas está disponível para a interpolação Clássica. É possível selecionar a predefinição de uma lista de predefinições de atenuação e aplicá-la à propriedade selecionada.

  1. Clique na camada que contém uma interpolação na linha do tempo do Animate.

  2. Para abrir as propriedades de interpolação, clique na categoria Interpolação no painel de propriedades. É possível acessar a atenuação de propriedade inteligente usando o menu suspenso Tipos de atenuação.

    É possível aplicar predefinições de atenuação através das propriedades para interpolações clássicas. No painel de propriedades, é fornecida uma opção para escolher a atenuação de propriedade inteligente. Você pode selecionar Cada propriedades separadamente para aplicar diferentes predefinições de atenuação a cada propriedade. 

    predefinições de propriedade inteligente
    predefinições de propriedade inteligente

    Você pode selecionar predefinições de atenuação exclusivas para as propriedades de posição, rotação, escala, cor e filtro de uma interpolação clássica. 

    Posição Especifica as configurações de atenuação para a posição de um objeto animado no Palco. 

    Rotação Especifica as configurações de atenuação para a rotação de um objeto animado no palco.  

    Escala Especifica as configurações de atenuação para a escala de um objeto animado no palco. 

    Cor Especifica as configurações de atenuação para as transições de cor aplicadas a um objeto animado no palco. 

    Filtros Especifique as configurações de atenuação para os filtros aplicados a um objeto animado no palco. 

  3. Como alternativa, se quiser ter alguma atenuação em todas as propriedades da interpolação, escolha a opção Todas as propriedades juntas. Selecione a predefinição de atenuação de sua escolha na caixa de diálogo pop-up de tipos de atenuação e clique duas vezes na predefinição de atenuação a ser aplicada. 

    Se escolher aplicar a atenuação clássica, também é possível aumentar ou diminuir a intensidade da atenuação ao mover o controle deslizante. 

    Lista de predefinições de atenuação
    Lista de predefinições de atenuação

  4. Clique no ícone Editar ao lado do campo Atenuação para aplicar uma atenuação personalizada. 

Se você usa o tipo de documento do HTML5 Canvas, é possível obter um arquivo de saída js otimizado para predefinições de atenuação. O HTML5 Canvas usa as funções de atenuação da Interpolação JS ao criar uma saída. 

Aplicar atenuação personalizada à animação de interpolação clássica

 Este tópico aborda como atenuar interpolações clássicas mais antigas. Para mais informações sobre como adicionar atenuação às interpolações de movimento mais recentes, consulte Adicionar atenuação a animações de interpolação.

A caixa de diálogo Atenuação personalizada exibe um gráfico que representa a variação do movimento ao longo do tempo. O eixo horizontal representa os quadros, e o eixo vertical representa a percentagem da mudança. O primeiro quadro-chave é representado como 0%, e o último é representado como 100%.

A inclinação da curva do gráfico representa a taxa de mudança do objeto. Quando a curva for horizontal (sem inclinação), a velocidade é zero; quando a curva for vertical, ocorre uma taxa instantânea de mudança.

Salvar atenuações personalizadas

É possível salvar as atenuações personalizadas com o clicar de um botão e reusá-las ao escolher a atenuação personalizada na lista de personalizações. Clique no botão Salvar e aplicar no modo de edição após fazer as alterações. Na captura de tela abaixo, é possível encontrar a predefinição de uma atenuação personalizada com o nome MyEase1

 Você pode reutilizar as predefinições de atenuação personalizadas somente dentro de um mesmo tipo de documento.

É possível usar atenuações predefinidas em vários conjuntos da linha do tempo ao selecionar os conjuntos correspondentes e aplicar a atenuação.

Mais controles para a caixa de diálogo CustomEase

Botões Reproduzir e Parar

Permitem visualizar uma animação no Palco usando todas as curvas atuais de velocidade definidas na caixa de diálogo Atenuação personalizada.

Excluir

Exclui a atenuação personalizada atual. 

Salvar e aplicar

Salva e aplica as alterações feitas nas predefinições de atenuação. 

Botão Redefinir

Permite redefinir a velocidade para a curva linear padrão.

Posição do ponto de controle selecionado

No canto inferior direito da caixa de diálogo, um valor numérico exibe o quadro-chave e a posição do ponto de controle selecionado. Caso não seja selecionado um ponto de controle, não aparece nenhum valor.

Para adicionar um ponto de controle à linha, clique na linha diagonal uma vez. Para obter um grau preciso de controle sobre o movimento de um objeto, arraste as posições dos pontos de controle.

Usando os indicadores de quadro (representados por alças quadradas), clique no ponto em que você deseja que um objeto aumente a velocidade ou diminua. Quando se clica na alça quadrada de um ponto de controle, esse ponto de controle é selecionado, sendo exibidos os pontos tangentes nos dois lados dele. Os círculos vazios representam pontos tangentes. Para posicioná-los, arraste o ponto de controle ou seus pontos tangentes com o mouse ou use as teclas de seta do teclado.

Dica: por padrão, os pontos de controle se ajustam a uma grade. Você pode desativar o ajuste pressionando a tecla X enquanto arrasta o ponto de controle.

Ao clicar em uma área da curva distante dos pontos de controle, é acrescentado um ponto de controle à curva naquele ponto. Essa ação não altera a forma da curva. Quando se clica longe da curva e dos pontos de controle, o ponto de controle atualmente selecionado é desmarcado.

Adicionar uma atenuação personalizada

  1. Selecione uma camada na Linha do tempo que tenha uma interpolação clássica a ela aplicada.

  2. Clique no botão Editar próximo ao controle deslizante Atenuação no Inspetor de propriedades do quadro.
  3. Para adicionar um ponto de controle, clique com o botão Ctrl (no Windows) ou Command (Macintosh) na linha diagonal.
  4. Para aumentar a velocidade do objeto, arraste o ponto de controle para cima; para diminuir a velocidade do objeto, arraste-o para baixo.
  5. Para ajustar mais a curva de atenuação, e refinar o valor de atenuação da interpolação, arraste as alças do vértice.
  6. Para ver a animação no palco, clique no botão reproduzir no canto inferior esquerdo.

  7. Ajuste os controles até atingir o efeito desejado.

 Se você usar a caixa de diálogo Atenuação personalizada, o campo de edição mostrará --. Se você usa Editar ou o controle deslizante pop-up, o gráfico Atenuação personalizada será ajustado para a curva equivalente. Além disso, a caixa de seleção Usar uma configuração para todas as propriedades estará marcada.

Copiar e colar uma curva de atenuação

  • Para copiar a curva atual de atenuação, pressione Ctrl+C (Windows) ou Command+C (Macintosh).

  • Para colar a curva copiada em outra curva de atenuação, pressione Ctrl+V (Windows) ou Command+V (Macintosh).

    Você pode copiar e colar a curva de atenuação. A curva copiada permanece disponível até você sair do aplicativo Animate.

Curvas de atenuação não suportadas

Certos tipos de curvas de atenuação não recebem suporte. Nenhuma parte do gráfico pode representar uma curva não linear (como um círculo).

A caixa de diálogo Atenuação personalizada impede automaticamente que se mova um ponto de controle ou uma alça tangente para uma posição que geraria uma curva inválida:

  • Todos os pontos devem existir no gráfico. Os pontos de controle não podem ser movidos além dos limites do gráfico.

  • Todos os segmentos da curva devem existir no gráfico. A forma da curva é achatada para impedir que ela se estenda além dos limites do gráfico.

Logotipo da Adobe

Fazer logon em sua conta