Trabalhar com símbolos no Animate

  1. Guia do Usuário do Adobe Animate
  2. Introdução ao Animate
    1. Novidades no Animate
    2. Glossário visual
    3. Requisitos de sistema do Animate
    4. Atalhos de teclado do Animate
    5. Trabalhar com vários tipos de arquivo no Animate
  3. Animação
    1. Noções básicas de animação no Animate
    2. Como usar quadros e quadros-chave no Animate
    3. Animação quadro a quadro no Animate
    4. Como trabalhar com animação de interpolação clássica no Animate
    5. Ferramenta Pincel
    6. Guia de movimento
    7. Interpolação de movimento e ActionScript 3.0
    8. Sobre a animação com interpolação de movimento
    9. Animações de interpolação de movimento
    10. Criação de uma animação de interpolação de movimento
    11. Utilização dos quadros-chave de propriedade
    12. Animação de posição com uma interpolação
    13. Editar interpolações de movimento usando o Motion Editor
    14. Edição do caminho de movimento de uma animação de interpolação
    15. Manipulação de interpolações de movimento
    16. Adição de atenuações personalizadas
    17. Criação e aplicação das predefinições de movimento
    18. Configuração de extensões de interpolação de animação
    19. Trabalhar com interpolações de movimento salvas como arquivos XML
    20. Interpolações de movimento e interpolações clássicas
    21. Interpolação de formas
    22. Uso da animação da ferramenta Bone no Animate
    23. Trabalhar com manipulação de caracteres no Animate
    24. Como usar camadas de máscara no Adobe Animate
    25. Como trabalhar com cenas no Animate
  4. Interatividade
    1. Como criar botões com o Animate
    2. Converter projetos do Animate em outros formatos de tipo de documento
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Adicionar interatividade com snippets de código no Animate
    5. Criar componentes HTML5 personalizados
    6. Uso de componentes do HTML5 Canvas
    7. Criação de componentes personalizados: exemplos
    8. Snippets de código para componentes personalizados
    9. Práticas recomendadas - Publicidade com o Animate
    10. Criação e publicação de Realidade virtual
  5. Fluxo de trabalho e espaço de trabalho
    1. Criação e gerenciamento de pincéis
    2. Uso de Google Fonts em documentos HTML5 Canvas
    3. Uso das Bibliotecas da Creative Cloud e do Adobe Animate
    4. Uso dos painéis Palco e Ferramentas do Animate
    5. Fluxo e espaço de trabalho do Animate
    6. Uso de fontes da Web em documentos HTML5 Canvas
    7. Linhas de tempo e ActionScript
    8. Trabalhar com múltiplas linhas de tempo
    9. Definir preferências
    10. Uso de painéis de criação do Animate
    11. Criar camadas na linha do tempo com o Animate
    12. Exportar animações para aplicativos móveis e mecanismos de jogo
    13. Mover e copiar objetos
    14. Modelos
    15. Localização e substituição no Animate
    16. Desfazer, refazer e o painel de Histórico
    17. Atalhos de teclado
    18. Como usar a linha do tempo no Animate
    19. Criação de extensões HTML
    20. Opções de otimização para imagens e GIFs animados
    21. Configurações de exportação para imagens e GIFs
    22. Painel Ativos no Animate
  6. Multimídia e vídeo
    1. Transformação e combinação de objetos gráficos no Animate
    2. Criar e trabalhar com instâncias do símbolo no Animate
    3. Traçado de imagem
    4. Como usar som no Adobe Animate
    5. Exportação de arquivos SVG
    6. Criação de arquivos de vídeo para uso no Animate
    7. Como adicionar vídeos no Animate
    8. Trabalhar com pontos de sinalização de vídeo
    9. Desenhar e criar objetos com o Animate
    10. Remodelação de linhas e formas
    11. Traçados, preenchimentos e gradientes com o Animate CC
    12. Trabalhar com o Adobe Premiere Pro e o After Effects
    13. Painéis de cor no Animate CC
    14. Abrir arquivos do Flash CS6 com o Animate
    15. Trabalho com texto clássico no Animate
    16. Aplicação de ilustração final no Animate
    17. Bitmaps importados no Animate
    18. Gráficos em 3D
    19. Trabalhar com símbolos no Animate
    20. Desenhar linhas e formas com o Adobe Animate
    21. Trabalho com bibliotecas no Animate
    22. Exportação de sons
    23. Seleção de objetos no Animate CC
    24. Trabalho com arquivos AI do Illustrator no Animate
    25. Aplicação de padrões com a ferramenta Pincel de borrifar
    26. Aplicação de modos de mesclagem
    27. Organização de objetos
    28. Automação de tarefas com o menu Comandos
    29. Texto multilíngue
    30. Uso de câmera no Animate
    31. Uso do Animate com o Adobe Scout
    32. Trabalhar com arquivos Fireworks
    33. Filtros gráficos
    34. Som e ActionScript
    35. Preferências de desenho
    36. Desenho com a ferramenta Caneta
  7. Plataformas
    1. Converter projetos do Animate em outros formatos de tipo de documento
    2. Suporte da plataforma personalizada
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Criação e publicação de um documento WebGL
    5. Compactação de aplicativos no AIR para iOS
    6. Publicação de AIR em aplicativos Android
    7. Publicação no Adobe AIR para desktop
    8. Configurações de publicação do ActionScript
    9. Práticas recomendadas - Organização do ActionScript em um aplicativo
    10. Como usar ActionScript com o Animate
    11. Práticas recomendadas - Diretrizes de acessibilidade
    12. Acessibilidade no espaço de trabalho do Animate
    13. Programação e gerenciamento de scripts
    14. Ativação do suporte para plataformas personalizadas
    15. Visão geral do suporte da plataforma personalizada
    16. Criação de conteúdo acessível
    17. Trabalhar com plug-ins personalizados de suporte da plataforma
    18. Depuração do ActionScript 3.0
    19. Ativação do suporte para plataformas personalizadas
  8. Publicação e exportação
    1. Exportação de arquivos do Animate CC
    2. Publicação OAM
    3. Exportação de arquivos SVG
    4. Exportar gráficos e vídeos com o Animate
    5. Publicação de documentos AS3
    6. Exportar animações para aplicativos móveis e mecanismos de jogo
    7. Exportação de sons
    8. Exportação de arquivos de vídeo QuickTime
    9. Controle de reprodução de vídeo externo com o ActionScript
    10. Práticas recomendadas - Dicas para a criação de conteúdo em dispositivos móveis
    11. Práticas recomendadas - Convenções de vídeo
    12. Práticas recomendadas - Diretrizes de criação de aplicativos SWF
    13. Práticas recomendadas - Estruturação de arquivos FLA
    14. Práticas recomendadas para otimizar arquivos FLA para o Animate
    15. Configurações de publicação do ActionScript
    16. Especificar configurações de publicação para o Animate
    17. Exportação de arquivos projetores
    18. Exportar imagens e GIFs animados
    19. Modelos de publicação HTML
    20. Trabalhar com o Adobe Premiere Pro e o After Effects
    21. Compartilhar e publicar animações rapidamente

Sobre símbolos

Um símboloé um gráfico, botão ou clipe de filme que você cria uma vez no ambiente de criação do Animate (anteriormente Flash Professional CC) ou usando as classes SimpleButton (AS 3.0) e MovieClip. Você pode usar novamente o símbolo em todo o documento ou em outros documentos.

O símbolo pode incluir arte-final importada de outro aplicativo. Todo símbolo criado se torna automaticamente parte da biblioteca do documento atual.

A ocorrência é uma cópia de um símbolo localizado no Palco ou aninhado dentro de outro símbolo. A ocorrência pode ser diferente do respectivo símbolo-pai em termos de cor, tamanho e função. A edição de um símbolo atualiza todas as ocorrências do símbolo, mas a aplicação de efeitos à ocorrência de um símbolo atualiza apenas a ocorrência.

O uso de símbolos nos documentos reduz significativamente o tamanho do arquivo. Salvar diversas ocorrências de um símbolo requer menos espaço de armazenamento do que salvar várias cópias do conteúdo do símbolo. Por exemplo, você pode reduzir o tamanho de arquivo de seus documentos, convertendo gráficos estáticos, tais como imagens de plano de fundo, em símbolos, que então podem ser reutilizados. O uso de símbolos também pode acelerar a reprodução de arquivos SWF, pois o símbolo só precisa ser baixado uma vez para o Flash® Player.

Compartilhe símbolos entre documentos como recursos de biblioteca compartilhada durante a criação ou em tempo de execução. Para compartilhar recursos em tempo de execução, você pode vincular recursos de um documento de origem a qualquer quantidade de documentos de destino, sem a necessidade de importar esses recursos no documento de destino. Para compartilhar recursos durante a criação, você pode atualizar ou substituir um símbolo por qualquer outro símbolo existente na sua rede local.

Se você importar recursos da biblioteca com o mesmo nome de recursos já existentes na biblioteca, será possível resolver os conflitos de nomes sem sobrescrever acidentalmente os recursos existentes.

Outras instruções introdutórias sobre símbolos estão disponíveis nos seguintes recursos:

Tipos de símbolos

Cada símbolo possui uma Linha do tempo e um Palco exclusivos e completos, com camadas. Você pode adicionar quadros, quadros-chave e camadas à Linha do tempo de um símbolo, da mesma forma que na Linha do tempo principal. Ao criar um símbolo você seleciona o seu tipo.

  • Use símbolos gráficos  para imagens estáticas e para criar partes reutilizáveis de animação vinculadas à Linha do tempo principal. Os símbolos gráficos operam em sincronização com a Linha do tempo principal. Em uma sequência de animação de símbolo gráfico, os controles e sons interativos não funcionam. Os símbolos gráficos adicionam menos tamanho ao arquivo FLA do que botões ou clipes de filme, pois não possuem Linha do tempo.

  • Use símbolos de botão  para criar botões interativos que respondam a cliques do mouse, rolagens ou outras ações. Defina os gráficos associados a vários estados do botão e, em seguida, atribua ações à ocorrência do botão. Para obter mais informações, consulte Manipulação de eventos no Guia do desenvolvedor do ActionScript 3.0.

  • Use símbolos de clipe de filme  para criar partes reutilizáveis de animação. Os clipes de filme têm a sua própria Linha do tempo com vários quadros, independente da Linha do tempo principal: imagine-os como aninhados dentro de uma Linha do tempo principal que pode conter controles e sons interativos e até outras ocorrências de clipe de filme. Você também pode criar botões animados, colocando ocorrências de clipe de filme dentro da Linha do tempo de um símbolo de botão. Além disso, os clipes de filme são compatíveis com o ActionScript®.

  • Use símbolos de fonte para exportar uma fonte e usá-la em outros documentos do Animate.

    O Animate fornece componentes incorporados (clipes de filme com parâmetros definidos) que podem ser utilizados nos seus documentos para adicionar elementos à interface do usuário, como botões, caixas de seleção ou barras de rolagem. Para obter mais informações, consulte Sobre os componentes do ActionScript 3.0 no Uso dos componentes do ActionScript 3.0.

    Observação: para visualizar a animação em ocorrências de componente e dimensionamento de 9 fatias de clipes de vídeo no ambiente de criação do Animate, selecione Controlar > Ativar visualização ao vivo.

Criação de símbolos

Você pode criar um símbolo a partir de objetos selecionados no Palco, criar um símbolo vazio e então construir ou importar o conteúdo no modo de edição de símbolo, ou criar símbolos fonte no Animate. Os símbolos possuem todas as funcionalidades que o Animate pode criar, incluindo animação.

A utilização de símbolos que contêm animação permite criar aplicações do Animate com bastante movimento, ao mesmo tempo que minimiza o tamanho do arquivo. Considere a criação de animação em um símbolo que possua uma ação cíclica ou repetitiva, por exemplo, o movimento das asas de um pássaro para cima e para baixo.

Para adicionar símbolos ao documento, use os recursos da biblioteca compartilhada durante a criação ou em tempo de execução.

Conversão de elementos selecionados em um símbolo

  1. Selecione um elemento ou diversos elementos no palco. Siga um destes procedimentos:
    • Selecione Modificar > Converter em símbolo.

    • Arraste a seleção para o painel Biblioteca.

    • Clique com o botão direito (Windows) ou Ctrl+clique (Macintosh) e selecione Converter em símbolo, no menu de contexto.

  2. Na caixa de diálogo Converter em símbolo, digite o nome do símbolo e selecione o comportamento.
  3. Clique na grade de registro para posicionar o ponto de registro do símbolo.
  4. Clique em OK.

    O Animate adiciona o símbolo à biblioteca. A seleção no palco se torna uma ocorrência do símbolo. Após criar um símbolo, você poderá editá-lo no modo de edição de símbolo, selecionando Editar > Editar símbolos, ou no contexto do palco, selecionando Editar > Editar no local. Você também pode alterar o ponto de registro do símbolo.

Criar um símbolo vazio

  1. Siga um destes procedimentos:
    • Selecione Inserir > Novo símbolo.

    • Clique no botão Novo símbolo na esquerda inferior do painel Biblioteca.

    • Selecione Novo símbolo, no menu do painel Biblioteca, no canto superior direito do painel Biblioteca.

  2. Na caixa de diálogo Criar novo símbolo, digite o nome do símbolo e selecione o comportamento.
  3. Clique em OK.

    O Animate adiciona o símbolo à biblioteca e alterna para o modo de edição de símbolo. Neste modo, o nome do símbolo é exibido acima do canto superior esquerdo do Palco, e uma cruz indica o ponto de registro do símbolo.

  4. Para criar o conteúdo do símbolo, use a Linha do tempo, desenhe com as ferramentas de desenho, importe a mídia, ou crie ocorrências de outros símbolos.
  5. Para retornar ao modo de edição de documento, siga um destes procedimentos:
    • Clique no botão Voltar.

    • Selecione Editar > Editar documento.

    • Clique no nome da cena, na barra Edição.

      Ao criar um símbolo, o ponto de registro é colocado no centro da janela no modo de edição de símbolo. Você pode colocar o conteúdo do símbolo na janela em relação ao ponto de registro. Para alterar o ponto de registro, quando editar um símbolo, mova o conteúdo do símbolo em relação ao ponto de registro.

  6. Na seção Ligação ActionScript, é possível escolher exportar para o ActionScript clicando na caixa de seleção Exportar para ActionScript. A classe e classe base usadas são automaticamente exibidas (é possível renomear as classes). O Animate busca por definições da classe em um arquivo AS externo ou em um arquivo SWC vinculado. Se as definições da classe não forem encontradas nesses lugares, o Animate automaticamente cria os arquivos de classe. Para obter mais informações, consulte este artigo.

(somente para Animate ) Troca de vários símbolos

A opção Trocar símbolo permite que você troque símbolos por símbolos ou bitmaps selecionados.

  1. Em seu documento do Animate, selecione vários símbolos no palco.

  2. No painel Propriedades, clique em TROCAR.
  3. Na caixa de diálogo Trocar símbolo, selecione o símbolo pelo qual você deseja substituir todos os símbolos/bitmap selecionados.
  4. Clique em OK.

Converta a animação do palco em um clipe de filme símbolo

Para reutilizar uma sequência animada do Palco, ou manipular a sequência como uma ocorrência, selecione e salve a sequência como um símbolo de clipe de filme.

  1. Na linha do tempo principal, selecione cada quadro de cada camada da animação no palco que deseja usar. Para obter informações sobre seleção de quadros, consulte Inserir quadros na linha do tempo.
  2. Para copiar os quadros, escolha uma destas opções:
    • Clique com o botão direito (Windows) ou Ctrl+clique (Macintosh) em cada quadro selecionado e selecione Copiar quadros, no menu de contexto. Para excluir a sequência após convertê-la em um clipe de filme, selecione Recortar.

    • Selecione Editar > Linha do tempo > Copiar quadros. Para excluir a sequência após convertê-la em um clipe de filme, selecione Recortar quadros.

  3. Desfaça a sua seleção e certifique-se de que nada esteja selecionado no palco. Selecione Inserir > Novo símbolo.
  4. Atribua um nome ao símbolo. Em Tipo, selecione Clipe de filme e, em seguida, clique em OK.
  5. Na Linha do tempo, clique em Quadro 1 ou Camada 1 e selecione Editar > Linha do tempo > Colar quadros.

    Esta ação cola os quadros, e quaisquer camadas ou nomes de camadas, que você copia da Linha do tempo principal, na Linha do tempo desse símbolo de clipe de filme. Qualquer animação, botão ou interatividade dos quadros copiados se torna uma animação independente (um símbolo de clipe de filme) que pode ser reutilizada.

  6. Para retornar ao modo de edição de documento, siga um destes procedimentos:
    • Clique no botão Voltar.

    • Selecione Editar > Editar documento.

    • Clique no nome da cena, na barra Edição, acima do palco.

Duplicação de símbolos

A duplicação permite utilizar um símbolo para criar outro.

Para criar versões do símbolo com aspectos diferentes, use também ocorrências.

Duplicação de símbolo usando o painel Biblioteca

  1. Selecione um símbolo no painel Biblioteca e siga um destes procedimentos:
    • Clique com o botão direito (Windows) ou Ctrl+clique (Macintosh) e selecione Duplicar no menu de contexto.

    • Selecione Duplicar, no menu do painel Biblioteca.

Duplicação de símbolo selecionando uma ocorrência

  1. Selecione uma ocorrência do símbolo no palco.
  2. Selecione Modificar > Símbolo > Duplicar símbolo.

    O símbolo é duplicado e a ocorrência é substituída por uma ocorrência do símbolo duplicado.

Editar símbolos

Ao editar um símbolo, o Animate atualiza todas as ocorrências dele no documento. Edite o símbolo das seguintes maneiras:

  • Em contexto com os outros objetos no palco, usando o comando Editar no local. Os outros objetos ficam esmaecidos para se diferenciar do símbolo que está sendo editado. O nome do símbolo que você está editando é exibido na barra Edição, na parte superior do palco, à direita do nome da cena atual.

  • Em uma janela separada, usando o comando Editar em nova janela. A edição do símbolo em uma janela separada permite visualizar ao mesmo tempo o símbolo e a Linha do tempo principal. O nome do símbolo que você está editando é exibido na barra de Edição na parte superior do palco.

    Edite o símbolo alterando a janela de exibição palco para exibição apenas do símbolo, usando o modo de edição de símbolo. O nome do símbolo que você está editando é exibido na barra Edição, na parte superior do palco, à direita do nome da cena atual.

    Ao editar um símbolo, o Animate atualiza todas as ocorrências dele em todo o documento para refletir suas edições. Durante a edição do símbolo, use qualquer ferramenta de desenho, importe a mídia ou crie ocorrências de outros símbolos.

  • Altere o ponto de registro do símbolo (o ponto identificado pelas coordenadas 0,0) usando qualquer método de edição de símbolo.

 

Edição de símbolo no local

  1. Siga um destes procedimentos:
    • Clique duas vezes em uma ocorrência do símbolo no palco.

    • Selecione a ocorrência do símbolo no palco e clique com o botão direito (Windows) ou Ctrl+clique (Macintosh) e selecione Editar no local.

    • Selecione uma ocorrência do símbolo no palco e, em seguida, Editar > Editar no local.

  2. Edite o símbolo.
  3. Para sair do modo de edição no local e retornar ao modo de edição de documento, siga um destes procedimentos:
    • Clique no botão Voltar.

    • Selecione o nome da cena atual no menu Cena da barra Edição.

    • Selecione Editar > Editar documento.

    • Clique duas vezes fora do conteúdo do símbolo.

Editar símbolo em uma nova janela

  1. Selecione a ocorrência do símbolo no palco e clique com o botão direito (Windows) ou Ctrl+clique (Macintosh) e selecione Editar em nova janela.
  2. Edite o símbolo.
  3. Clique na caixa Fechar, no canto superior direito (Windows) ou no canto superior esquerdo (Macintosh) para fechar a nova janela, e clique na janela do documento principal para voltar a editar o documento principal.

Editar um símbolo no modo de edição de símbolo

  1. Escolha uma destas opções para selecionar o símbolo:
    • Clique duas vezes no ícone do símbolo no painel Biblioteca.

    • Selecione a ocorrência do símbolo no palco e clique com o botão direito (Windows) ou Ctrl+clique (Macintosh) e selecione Editar no menu de contexto.

    • Selecione uma ocorrência do símbolo no palco e, em seguida, Editar > Editar símbolos.

    • Selecione o símbolo no painel Biblioteca e Editar no menu do painel Biblioteca, ou clique com o botão direito (Windows) ou Ctrl+clique (Macintosh) no símbolo do painel Biblioteca e selecione Editar.

  2. Edite o símbolo.
  3. Para sair do modo de edição de símbolo e voltar a editar o documento, siga um destes procedimentos:
    • Clique no botão Voltar, à esquerda da barra de edição, na parte superior do palco.

    • Selecione Editar > Editar documento.

    • Clique no nome da cena na barra Edição, na parte superior do palco.

    • Clique duas vezes fora do conteúdo do símbolo.

Logotipo da Adobe

Fazer logon em sua conta