Guia do Usuário Cancelar

Como criar botões com o Animate

  1. Guia do Usuário do Adobe Animate
  2. Introdução ao Animate
    1. Novidades no Animate
    2. Glossário visual
    3. Requisitos de sistema do Animate
    4. Atalhos de teclado do Animate
    5. Trabalhar com vários tipos de arquivo no Animate
  3. Animação
    1. Noções básicas de animação no Animate
    2. Como usar quadros e quadros-chave no Animate
    3. Animação quadro a quadro no Animate
    4. Como trabalhar com animação de interpolação clássica no Animate
    5. Ferramenta Pincel
    6. Guia de movimento
    7. Interpolação de movimento e ActionScript 3.0
    8. Sobre a animação com interpolação de movimento
    9. Animações de interpolação de movimento
    10. Criação de uma animação de interpolação de movimento
    11. Utilização dos quadros-chave de propriedade
    12. Animação de posição com uma interpolação
    13. Editar interpolações de movimento usando o Motion Editor
    14. Edição do caminho de movimento de uma animação de interpolação
    15. Manipulação de interpolações de movimento
    16. Adição de atenuações personalizadas
    17. Criação e aplicação das predefinições de movimento
    18. Configuração de extensões de interpolação de animação
    19. Trabalhar com interpolações de movimento salvas como arquivos XML
    20. Interpolações de movimento e interpolações clássicas
    21. Interpolação de formas
    22. Uso da animação da ferramenta Bone no Animate
    23. Trabalhar com manipulação de caracteres no Animate
    24. Como usar camadas de máscara no Adobe Animate
    25. Como trabalhar com cenas no Animate
  4. Interatividade
    1. Como criar botões com o Animate
    2. Converter projetos do Animate em outros formatos de tipo de documento
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Adicionar interatividade com snippets de código no Animate
    5. Criar componentes HTML5 personalizados
    6. Uso de componentes do HTML5 Canvas
    7. Criação de componentes personalizados: exemplos
    8. Snippets de código para componentes personalizados
    9. Práticas recomendadas - Publicidade com o Animate
    10. Criação e publicação de Realidade virtual
  5. Fluxo de trabalho e espaço de trabalho
    1. Criação e gerenciamento de pincéis
    2. Uso de Google Fonts em documentos HTML5 Canvas
    3. Uso das Bibliotecas da Creative Cloud e do Adobe Animate
    4. Uso dos painéis Palco e Ferramentas do Animate
    5. Fluxo e espaço de trabalho do Animate
    6. Uso de fontes da Web em documentos HTML5 Canvas
    7. Linhas de tempo e ActionScript
    8. Trabalhar com múltiplas linhas de tempo
    9. Definir preferências
    10. Uso de painéis de criação do Animate
    11. Criar camadas na linha do tempo com o Animate
    12. Exportar animações para aplicativos móveis e mecanismos de jogo
    13. Mover e copiar objetos
    14. Modelos
    15. Localização e substituição no Animate
    16. Desfazer, refazer e o painel de Histórico
    17. Atalhos de teclado
    18. Como usar a linha do tempo no Animate
    19. Criação de extensões HTML
    20. Opções de otimização para imagens e GIFs animados
    21. Configurações de exportação para imagens e GIFs
    22. Painel Ativos no Animate
  6. Multimídia e vídeo
    1. Transformação e combinação de objetos gráficos no Animate
    2. Criar e trabalhar com instâncias do símbolo no Animate
    3. Traçado de imagem
    4. Como usar som no Adobe Animate
    5. Exportação de arquivos SVG
    6. Criação de arquivos de vídeo para uso no Animate
    7. Como adicionar vídeos no Animate
    8. Trabalhar com pontos de sinalização de vídeo
    9. Desenhar e criar objetos com o Animate
    10. Remodelação de linhas e formas
    11. Traçados, preenchimentos e gradientes com o Animate CC
    12. Trabalhar com o Adobe Premiere Pro e o After Effects
    13. Painéis de cor no Animate CC
    14. Abrir arquivos do Flash CS6 com o Animate
    15. Trabalho com texto clássico no Animate
    16. Aplicação de ilustração final no Animate
    17. Bitmaps importados no Animate
    18. Gráficos em 3D
    19. Trabalhar com símbolos no Animate
    20. Desenhar linhas e formas com o Adobe Animate
    21. Trabalho com bibliotecas no Animate
    22. Exportação de sons
    23. Seleção de objetos no Animate CC
    24. Trabalho com arquivos AI do Illustrator no Animate
    25. Aplicação de padrões com a ferramenta Pincel de borrifar
    26. Aplicação de modos de mesclagem
    27. Organização de objetos
    28. Automação de tarefas com o menu Comandos
    29. Texto multilíngue
    30. Uso de câmera no Animate
    31. Uso do Animate com o Adobe Scout
    32. Trabalhar com arquivos Fireworks
    33. Filtros gráficos
    34. Som e ActionScript
    35. Preferências de desenho
    36. Desenho com a ferramenta Caneta
  7. Plataformas
    1. Converter projetos do Animate em outros formatos de tipo de documento
    2. Suporte da plataforma personalizada
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Criação e publicação de um documento WebGL
    5. Compactação de aplicativos no AIR para iOS
    6. Publicação de AIR em aplicativos Android
    7. Publicação no Adobe AIR para desktop
    8. Configurações de publicação do ActionScript
    9. Práticas recomendadas - Organização do ActionScript em um aplicativo
    10. Como usar ActionScript com o Animate
    11. Práticas recomendadas - Diretrizes de acessibilidade
    12. Acessibilidade no espaço de trabalho do Animate
    13. Programação e gerenciamento de scripts
    14. Ativação do suporte para plataformas personalizadas
    15. Visão geral do suporte da plataforma personalizada
    16. Criação de conteúdo acessível
    17. Trabalhar com plug-ins personalizados de suporte da plataforma
    18. Depuração do ActionScript 3.0
    19. Ativação do suporte para plataformas personalizadas
  8. Publicação e exportação
    1. Exportação de arquivos do Animate CC
    2. Publicação OAM
    3. Exportação de arquivos SVG
    4. Exportar gráficos e vídeos com o Animate
    5. Publicação de documentos AS3
    6. Exportar animações para aplicativos móveis e mecanismos de jogo
    7. Exportação de sons
    8. Exportação de arquivos de vídeo QuickTime
    9. Controle de reprodução de vídeo externo com o ActionScript
    10. Práticas recomendadas - Dicas para a criação de conteúdo em dispositivos móveis
    11. Práticas recomendadas - Convenções de vídeo
    12. Práticas recomendadas - Diretrizes de criação de aplicativos SWF
    13. Práticas recomendadas - Estruturação de arquivos FLA
    14. Práticas recomendadas para otimizar arquivos FLA para o Animate
    15. Configurações de publicação do ActionScript
    16. Especificar configurações de publicação para o Animate
    17. Exportação de arquivos projetores
    18. Exportar imagens e GIFs animados
    19. Modelos de publicação HTML
    20. Trabalhar com o Adobe Premiere Pro e o After Effects
    21. Compartilhar e publicar animações rapidamente

Etapas básicas para a criação de botões

  1. Decida que tipo de botão melhor se adequa às suas necessidades.

    Símbolo de botão

    A maioria das pessoas escolhe símbolos de botão pela sua flexibilidade. Os símbolos de botão contêm uma linha do tempo interna especializada para estados de botões. Você pode criar facilmente os estados Para cima, Para baixo e Sobre diferentes visualmente. Os símbolos de botão também mudam o seu estado automaticamente conforme reagem às ações do usuário.

    Botão de clipe de filme

    Você pode usar um símbolo de clipe de filme para criar efeitos sofisticados de botão. Os símbolos de clipe de filme contêm quase todo tipo de conteúdo, inclusive animação. No entanto, os símbolos de clipe de filme não possuem os estados incorporados de Para cima, Para baixo e Sobre. Você mesmo cria esses estados usando ActionScript. Uma desvantagem é que os arquivos de clipe de filme são maiores que os arquivos de botão. 

    Componente de botão ActionScript

    Use um componente de botão se você requer apenas um botão padrão ou uma alternância e você não quer personalizá-lo extensivamente. Os componentes de botão ActionScript 2.0 e 3.0 vêm com um código incorporado que permite mudanças de estado. Portanto você não tem que definir a aparencia e o comportamento dos estados de botão. Simplesmente arraste o componente para o Palco.

    • Os componentes de botão ActionScript 3.0 permitem alguma personalização. Você pode ligar o botão a outros componentes, e compartilhar e exibir os dados do aplicativo. Eles possuem recursos incorporados, tais como suporte à acessibilidade. Os componentes Botão, Radiobutton e CheckBox estão disponíveis. 

    • Os componentes de botão do ActionScript 2.0 não são personalizáveis. O componente permite mudanças de estado.

  2. Definição dos estados dos seus botões.

    Quadro Para Cima

    A aparência do botão quando o usuário não está interagindo com ele.

    Quadro Sobre

    A aparência do botão quando o usuário está para selecioná-lo.

    Quadro Para Baixo

    A aparência do botão quando o usuário o seleciona.

    Quadro Ocorrência

    A área que responde aos cliques do usuário. Definir este quadro Ocorrência é opcional. Se o seu botão é pequeno, ou se sua área gráfica não é contígua, pode ser útil definir este quadro.

    • O conteúdo do quadro Ocorrência não é visível no Palco durante a reprodução.

    • O gráfico para o quadro Ocorrência é uma área sólida grande o suficiente para abranger todos os elementos gráficos dos quadros Para cima, Para baixo e Sobre.

    • Se você não especifica um quadro Ocorrência, a imagem de estado Para Cima é usada.

      Você pode fazer um botão que responda quando uma área diferente do palco é clicada ou rolada (também chamada de rolagem separada) Coloque o gráfico do quadro Ocorrência em um local diferente do que outros gráficos do quadro do botão.

  3. Associe uma ação com o botão.

    Para fazer algo acontecer quando o usuário seleciona um botão, você adiciona um código ActionScript à Linha do Tempo. Insira o código ActionScript nos mesmos quadros que os botões. O painel de Snippets de Código tem código ActionScript 3.0 pré-gravado para muitos usos comuns do botão. Consulte Adicionar interatividade com snippets de código

    Observação:

    O ActionScript 2.0 não é compatível com o ActionScript 3.0. Se sua versão do Animate usa ActionScript 3.0, você não pode colocar código ActionScript 2.0 no seu botão (e vice-versa). Antes de colar o ActionScript de uma outra origem em seus botões, verifique se a versão é compatível.

Criar um botão com o símbolo de um botão

Para fazer um botão ficar interativo, coloque uma ocorrência do símbolo de botão no Palco e atribua ações à ocorrência. Atribua as ações à linha do tempo raiz do arquivo Flash. Não adicione ações à linha do tempo do símbolo de botão. Para adicionar ações à linha do tempo do botão, use um botão de clipe de filme em seu lugar.

  1. Selecione Editar > Desmarcar tudo, ou clique em uma área vazia do Palco para garantir que nada seja selecionado no Palco.

  2. Selecione Inserir > Novo símbolo.

  3. Na caixa de diálogo Criar novo símbolo, digite um nome. Em Tipo de símbolo, selecione Botão.

    O Animate alterna para o modo de edição de símbolo. A Linha do tempo é alterada para exibir quatro quadros consecutivos rotulados Para cima, Sobre, Para baixo e Ocorrência. O primeiro quadro, Para cima, é um quadro-chave em branco.

  4. Para criar a imagem do botão do estado Para cima, selecione o quadro Para cima na Linha do tempo. Em seguida, use as ferramentas de desenho, importe um gráfico ou coloque uma ocorrência de outro símbolo no Palco.

    Você pode usar os símbolos gráficos ou os símbolos de clipe de filme dentro de um botão, mas não pode usar outro símbolo de botão.

  5. Na Linha do tempo, clique no quadro Sobre e, em seguida, selecione Inserir > Linha do tempo > Quadro-chave.

    O Animate insere um quadro-chave que duplica o conteúdo do quadro Para cima precedente.

  6. Com o quadro Sobre ainda selecionado, altere ou edite a imagem do botão no Palco para criar a aparência que deseja para o estado Sobre.

  7. Repita as etapas 5 e 6 para o quadro Para baixo e o para o quadro Ocorrência opcional.

  8. Para atribuir um som ao estado de um botão, selecione esse quadro de estado na Linha do tempo e selecione Janela > Propriedades. Em seguida, selecione um som do menu Som no Inspetor de propriedades. Apenas os sons que você já importou aparecerão no menu Som.

  9. Quando terminar, selecione Editar > Editar documento. O Animate levará você de volta à linha do tempo principal do seu arquivo FLA. Para criar uma ocorrência do botão que você criou no Palco, arraste o símbolo do botão do painel Biblioteca para o Palco.

  10. Para testar a funcionalidade de um botão, use o comando Controle > Testar . Você também pode visualizar os estados do símbolo de um botão no Palco escolhendo Controlar > Ativar botões simples. Este comando permite ver os estados para cima, sobre e para baixo de um símbolo de botão sem usar Controle > Testar.

Ativar, editar e testar símbolos de botões

Por padrão, o Animate mantém os símbolos de botão desativados ao criá-los. Selecione e então ative um botão para vê-lo responder a eventos do mouse. A prática recomendada é desativar os botões enquanto trabalha e ativá-los para rapidamente testar seu comportamento.

  • Para selecionar um botão, use a ferramenta Selecionar para arrastar um retângulo de seleção ao redor do botão.

  • Para ativar ou desativar botões no Palco, escolha Controlar > Ativar botões simples. Este comando alterna entre os dois estados.

  • Use as teclas de seta para mover um botão.

  • Use o Inspetor de propriedades para editar um botão. Se não estiver visível, selecione Janela > Propriedades.

  • Para testar o botão no ambiente de criação, selecione Controlar > Ativar botões simples.

  • Para testar o botão no Flash Player, selecione Controlar > Testar filme [ou Testar Cena] > Testar. Este método é o único para testar botões de clipe de filme.

  • Para testar o botão no painel Visualização da biblioteca, selecione o botão na Biblioteca e clique em Reproduzir.

Solução de problemas de botões

Use estes recursos para solucionar problemas comuns com os botões:

Outros recursos de botão

Os TechNotes a seguir contêm instruções para alguns cenários de botões específicos:

Logotipo da Adobe

Fazer logon em sua conta