Transformação e combinação de objetos gráficos no Animate

  1. Guia do Usuário do Adobe Animate
  2. Introdução ao Animate
    1. Novidades no Animate
    2. Glossário visual
    3. Requisitos de sistema do Animate
    4. Atalhos de teclado do Animate
    5. Trabalhar com vários tipos de arquivo no Animate
  3. Animação
    1. Noções básicas de animação no Animate
    2. Como usar quadros e quadros-chave no Animate
    3. Animação quadro a quadro no Animate
    4. Como trabalhar com animação de interpolação clássica no Animate
    5. Ferramenta Pincel
    6. Guia de movimento
    7. Interpolação de movimento e ActionScript 3.0
    8. Sobre a animação com interpolação de movimento
    9. Animações de interpolação de movimento
    10. Criação de uma animação de interpolação de movimento
    11. Utilização dos quadros-chave de propriedade
    12. Animação de posição com uma interpolação
    13. Editar interpolações de movimento usando o Motion Editor
    14. Edição do caminho de movimento de uma animação de interpolação
    15. Manipulação de interpolações de movimento
    16. Adição de atenuações personalizadas
    17. Criação e aplicação das predefinições de movimento
    18. Configuração de extensões de interpolação de animação
    19. Trabalhar com interpolações de movimento salvas como arquivos XML
    20. Interpolações de movimento e interpolações clássicas
    21. Interpolação de formas
    22. Uso da animação da ferramenta Bone no Animate
    23. Trabalhar com manipulação de caracteres no Animate
    24. Como usar camadas de máscara no Adobe Animate
    25. Como trabalhar com cenas no Animate
  4. Interatividade
    1. Como criar botões com o Animate
    2. Converter projetos do Animate em outros formatos de tipo de documento
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Adicionar interatividade com snippets de código no Animate
    5. Criar componentes HTML5 personalizados
    6. Uso de componentes do HTML5 Canvas
    7. Criação de componentes personalizados: exemplos
    8. Snippets de código para componentes personalizados
    9. Práticas recomendadas - Publicidade com o Animate
    10. Criação e publicação de Realidade virtual
  5. Fluxo de trabalho e espaço de trabalho
    1. Criação e gerenciamento de pincéis
    2. Uso de Google Fonts em documentos HTML5 Canvas
    3. Uso das Bibliotecas da Creative Cloud e do Adobe Animate
    4. Uso dos painéis Palco e Ferramentas do Animate
    5. Fluxo e espaço de trabalho do Animate
    6. Uso de fontes da Web em documentos HTML5 Canvas
    7. Linhas de tempo e ActionScript
    8. Trabalhar com múltiplas linhas de tempo
    9. Definir preferências
    10. Uso de painéis de criação do Animate
    11. Criar camadas na linha do tempo com o Animate
    12. Exportar animações para aplicativos móveis e mecanismos de jogo
    13. Mover e copiar objetos
    14. Modelos
    15. Localização e substituição no Animate
    16. Desfazer, refazer e o painel de Histórico
    17. Atalhos de teclado
    18. Como usar a linha do tempo no Animate
    19. Criação de extensões HTML
    20. Opções de otimização para imagens e GIFs animados
    21. Configurações de exportação para imagens e GIFs
    22. Painel Ativos no Animate
  6. Multimídia e vídeo
    1. Transformação e combinação de objetos gráficos no Animate
    2. Criar e trabalhar com instâncias do símbolo no Animate
    3. Traçado de imagem
    4. Como usar som no Adobe Animate
    5. Exportação de arquivos SVG
    6. Criação de arquivos de vídeo para uso no Animate
    7. Como adicionar vídeos no Animate
    8. Trabalhar com pontos de sinalização de vídeo
    9. Desenhar e criar objetos com o Animate
    10. Remodelação de linhas e formas
    11. Traçados, preenchimentos e gradientes com o Animate CC
    12. Trabalhar com o Adobe Premiere Pro e o After Effects
    13. Painéis de cor no Animate CC
    14. Abrir arquivos do Flash CS6 com o Animate
    15. Trabalho com texto clássico no Animate
    16. Aplicação de ilustração final no Animate
    17. Bitmaps importados no Animate
    18. Gráficos em 3D
    19. Trabalhar com símbolos no Animate
    20. Desenhar linhas e formas com o Adobe Animate
    21. Trabalho com bibliotecas no Animate
    22. Exportação de sons
    23. Seleção de objetos no Animate CC
    24. Trabalho com arquivos AI do Illustrator no Animate
    25. Aplicação de padrões com a ferramenta Pincel de borrifar
    26. Aplicação de modos de mesclagem
    27. Organização de objetos
    28. Automação de tarefas com o menu Comandos
    29. Texto multilíngue
    30. Uso de câmera no Animate
    31. Uso do Animate com o Adobe Scout
    32. Trabalhar com arquivos Fireworks
    33. Filtros gráficos
    34. Som e ActionScript
    35. Preferências de desenho
    36. Desenho com a ferramenta Caneta
  7. Plataformas
    1. Converter projetos do Animate em outros formatos de tipo de documento
    2. Suporte da plataforma personalizada
    3. Criação e publicação de documentos HTML5 Canvas no Animate
    4. Criação e publicação de um documento WebGL
    5. Compactação de aplicativos no AIR para iOS
    6. Publicação de AIR em aplicativos Android
    7. Publicação no Adobe AIR para desktop
    8. Configurações de publicação do ActionScript
    9. Práticas recomendadas - Organização do ActionScript em um aplicativo
    10. Como usar ActionScript com o Animate
    11. Práticas recomendadas - Diretrizes de acessibilidade
    12. Acessibilidade no espaço de trabalho do Animate
    13. Programação e gerenciamento de scripts
    14. Ativação do suporte para plataformas personalizadas
    15. Visão geral do suporte da plataforma personalizada
    16. Criação de conteúdo acessível
    17. Trabalhar com plug-ins personalizados de suporte da plataforma
    18. Depuração do ActionScript 3.0
    19. Ativação do suporte para plataformas personalizadas
  8. Publicação e exportação
    1. Exportação de arquivos do Animate CC
    2. Publicação OAM
    3. Exportação de arquivos SVG
    4. Exportar gráficos e vídeos com o Animate
    5. Publicação de documentos AS3
    6. Exportar animações para aplicativos móveis e mecanismos de jogo
    7. Exportação de sons
    8. Exportação de arquivos de vídeo QuickTime
    9. Controle de reprodução de vídeo externo com o ActionScript
    10. Práticas recomendadas - Dicas para a criação de conteúdo em dispositivos móveis
    11. Práticas recomendadas - Convenções de vídeo
    12. Práticas recomendadas - Diretrizes de criação de aplicativos SWF
    13. Práticas recomendadas - Estruturação de arquivos FLA
    14. Práticas recomendadas para otimizar arquivos FLA para o Animate
    15. Configurações de publicação do ActionScript
    16. Especificar configurações de publicação para o Animate
    17. Exportação de arquivos projetores
    18. Exportar imagens e GIFs animados
    19. Modelos de publicação HTML
    20. Trabalhar com o Adobe Premiere Pro e o After Effects
    21. Compartilhar e publicar animações rapidamente

Transformação de objetos

Você pode transformar objetos gráficos, grupos, blocos de texto e ocorrências usando a ferramenta Transformação livre ou as opções no menu Modificar > Transformar. Dependendo do tipo de elemento que você selecionar, você pode transformar, girar, inclinar, dimensionar ou distorcer o elemento. Você pode alterar ou adicionar a uma seleção durante uma operação de transformação.

Quando você transformar um objeto, grupo, caixa de texto ou ocorrência, o Inspetor de propriedades desse item exibe todas as alterações feitas às dimensões ou posição do item.

Uma caixa delimitadora aparece durante as operações de transformação que incluem a ação de arrastar. A caixa delimitadora é retangular (a menos que tenha sido modificada com o comando Distorcer ou o Modificador de envelope) com bordas inicialmente alinhadas paralelamente às bordas do Palco. Alças de transformação encontram-se em cada canto e no meio de cada lado. Conforme você arrasta, a caixa delimitadora visualiza as transformações.

Mova, realinhe, altere e trace o ponto de transformação

Durante uma transformação, o ponto de transformação aparece no centro de um elemento selecionado. O ponto de transformação é inicialmente alinhado com o ponto central do objeto. Você pode mover o ponto de transformação, retorná-lo a sua posição padrão e mover o ponto de origem padrão.

Para dimensionar, inclinar ou girar os objetos gráficos, grupos e blocos de texto, o ponto oposto ao ponto que você arrasta é o ponto de origem padrão. Por exemplo, o ponto de transformação é o ponto de origem por padrão. Você pode mover o ponto de origem padrão para uma transformação.

  1. Selecione a ferramenta Transformação livre ou um dos comandos em Modificar > Transformar.

    Uma vez que você tiver iniciado uma transformação, você pode controlar o local do ponto de transformação no painel Informações e no Inspetor de propriedades.

  2. Siga um destes procedimentos:
    • Para mover o ponto de transformação, arraste-o para dentro do objeto gráfico selecionado.

    • Para realinhar o ponto de transformação com o centro do elemento, clique duas vezes no ponto de transformação.

    • Para mudar o ponto de origem de uma transformação de dimensão ou inclinação, mantenha pressionada a tecla Alt (Windows) ou a tecla Option (Macintosh) enquanto arrasta o ponto de controle do objeto escolhido durante a transformação.

    • No Painel Informações, é possível alternar para exibir os pontos de registro e de transformação. O botão aparece como para indicar que as coordenadas do ponto de registro são exibidas. Ao clicar no mesmo botão, ele muda para , para indicar que as coordenadas de Transformação são exibidas.

    Grades de coordenadas; Painel Informações com o botão Registro/Ponto de transformação no modo de transformação e com as coordenadas x e y da seleção do ponto de transformação visíveis.

Use a ferramenta Transformação livre

Você pode realizar transformações individuais ou combinar várias transformações, tais como mover, girar, dimensionar, inclinar e distorcer.

Observação:

A ferramenta Transformação livre não pode transformar símbolos, bitmaps, objetos de vídeo, sons, gradientes ou texto. Se uma seleção múltipla contiver qualquer um desses itens, somente os objetos de forma serão distorcidos. Para transformar um bloco de texto, primeiro converta os caracteres em objetos de forma.

  1. Selecione um objeto gráfico, grupo, ocorrência ou bloco de texto no Palco.
  2. Clique na ferramenta Transformação livre  .

    Mover o ponteiro sobre e ao redor da seleção faz com que o ponteiro mude para indicar qual função de transformação está disponível.

  3. Para transformar a seleção, arraste as alças:
    • Para mover a seleção, posicione o ponteiro sobre o objeto na caixa delimitadora e arraste o objeto para uma nova posição. Não arraste o ponto de transformação.

    • Para definir o centro de rotação ou dimensionamento, arraste o ponto de transformação para um novo local.

    • Para girar a seleção, posicione o ponteiro perto da parte de fora da alça do canto e arraste. A seleção gira em torno do ponto de transformação. Arraste com a tecla Shift pressionada para girar em incrementos de 45°.

    • Para girar ao redor do canto oposto, arraste com a tecla Alt pressionada (Windows) ou arraste com a tecla Option pressionada (Macintosh).

    • Para dimensionar a seleção, arraste uma alça do canto diagonalmente para dimensioná-la em duas dimensões. Arraste com a tecla Shift pressionada para redimensionar proporcionalmente.

    • Para dimensionar somente na respectiva direção, arraste uma alça do canto ou uma alça lateral horizontal ou verticalmente.

    • Para inclinar a seleção, posicione o ponteiro no contorno entre as alças de transformação e arraste.

    • Para distorcer as formas, pressione Control (Windows) ou Command (Macintosh) e arraste uma alça do canto ou uma alça lateral.

    • Para estreitar o objeto (mover o canto selecionado e o canto adjacente em distâncias iguais de suas origens), clique com as teclas Shift+Control pressionadas para arrastar (Windows) ou clique com as teclas Shift+Command pressionadas para arrastar (Macintosh) uma alça do canto.

  4. Para finalizar a transformação, clique fora do item selecionado.

Distorcer objetos

Ao aplicar uma transformação de Distorção em um objeto selecionado, arrastar uma alça do canto ou uma alça da borda na caixa delimitadora move o canto ou a borda e realinha as bordas adjacentes. Para restringir a distorção, pressione Shift e arraste um ponto de canto, movendo-o junto com o respectivo canto a uma distância igual e na direção oposta. O canto adjacente é o canto no mesmo eixo que a direção que você arrasta. Arraste um ponto central em uma borda para mover a borda inteira, usando Ctrl+clique (Windows) ou Command+Clique (Macintosh).

Você pode distorcer objetos gráficos usando o comando Distorcer. Você também pode distorcer objetos ao executar uma transformação livre neles.

Observação:

O comando Distorcer não pode modificar símbolos, primitivas de forma, bitmaps, objetos de vídeo, sons, gradientes, grupos de objeto ou texto. Se uma seleção múltipla contiver qualquer um desses itens, somente os objetos de forma serão distorcidos. Para modificar texto, primeiro converta os caracteres em objetos de forma.

  1. Selecione o(s) objeto(s) gráfico(s) no Palco.
  2. Selecione Modificar > Transformar > Distorcer.

  3. Coloque o ponteiro em uma das alças de transformação e arraste.
  4. Para finalizar a transformação, clique fora do(s) objeto(s) selecionado(s).

Modificar formas com o modificador de Envelope

O modificador de Envelope permite que você deforme e distorça objetos. Um envelope é uma caixa delimitadora que contém um ou mais objetos. As alterações feitas em uma forma de envelope afetam a forma dos objetos no envelope. Você edita a forma de um envelope ajustando seus pontos e alças tangentes.

Observação:

O modificador de Envelope não pode modificar símbolos, bitmaps, objetos de vídeo, sons, gradientes, grupos de objetos ou texto. Se uma seleção múltipla contiver qualquer um desses itens, somente os objetos de forma serão distorcidos. Para modificar texto, primeiro converta os caracteres em objetos de forma.

  1. Selecione uma forma no Palco.
  2. Selecione Modificar > Transformar > Envelope.

  3. Arraste os pontos e as alças da tangente para modificar o envelope.

Dimensionar objetos

Dimensionar um objeto amplia ou reduz o objeto horizontalmente, verticalmente ou ambos.

  1. Selecione o(s) objeto(s) gráfico(s) no Palco.

  2. Selecione Modificar > Transformar > Dimensionar.

  3. Siga um destes procedimentos:
    • Para dimensionar o objeto horizontal e verticalmente, arraste uma das alças do canto. As proporções são mantidas conforme você dimensiona. Arraste com a tecla Shift pressionada para dimensionar desproporcionalmente.

    • Para dimensionar o objeto horizontal ou verticalmente, arraste uma alça do centro.

  4. Para finalizar a transformação, clique fora do(s) objeto(s) selecionado(s).

    Observação:

    Ao aumentar o tamanho de certos itens, os itens perto das bordas da caixa delimitadora devem ser movidos para fora do Palco. Se esse problema ocorrer, selecione Exibir > Área de transferência para ver os elementos que encontram-se além das bordas do Palco.

Girar e inclinar objetos

Girar um objeto o vira em torno de seu ponto de transformação. O ponto de transformação é alinhado com o ponto de registro, que é predefinido para o centro do objeto, mas você pode mover o ponto arrastando-o.

É possível girar um objeto através de um dos seguintes métodos:

  • Arrastando com a ferramenta Transformação livre  (você pode inclinar e dimensionar o objeto na mesma operação).

  • Especificando um ângulo no painel Transformar (você pode dimensionar o objeto na mesma operação).

Girar e inclinar objetos arrastando-os

  1. Selecione o(s) objeto(s) no Palco.
  2. Selecione Modificar > Transformar > Girar e inclinar.

  3. Siga um destes procedimentos:
    • Arraste uma alça de canto para girar o objeto.

    • Arraste uma alça central para inclinar o objeto.

  4. Para finalizar a transformação, clique fora do(s) objeto(s) selecionado(s).

Girar objetos em 90°

  1. Selecione o(s) objeto(s).
  2. Selecione Modificar > Transformar > Girar 90° horário para girar no sentido horário ou Girar 90° anti-horário para girar no sentido anti-horário.

Inclinar objetos

Inclinar um objeto transforma-o obliquamente ao longo de um ou ambos os eixos. Você pode inclinar um objeto arrastando-o ou digitando um valor no painel Transformar.

  1. Selecione o(s) objeto(s).
  2. Selecione Janela > Transformar.

  3. Clique em Inclinar.
  4. Digite os ângulos dos valores horizontal e vertical.

Virar objetos

Você pode virar objetos em seu eixo vertical ou horizontal sem mover sua posição relativa no Palco.

  1. Selecione o objeto.
  2. Selecione Modificar > Transformar > Girar vertical ou Girar horizontal.

Restaurar objetos transformados

Quando você usa a ferramenta Transformação livre ou o painel Transformar para dimensionar, girar e inclinar ocorrências e grupos, o Animate salva o tamanho original e os valores de rotação com o objeto. Isso permite que você remova as transformações aplicadas e restaure os valores originais.

Você pode desfazer apenas a transformação mais recente ao selecionar Editar > Desfazer. Você pode remover todas as transformações clicando no botão 'Remover transformação' do painel, antes de cancelar a seleção do objeto. Depois de cancelar a seleção do objeto, os valores originais são perdidos e a transformação não pode ser removida.

Restaurar um objeto transformado para seus estado original

  1. Verifique se o objeto transformado ainda está selecionado.

  2. Siga um destes procedimentos:
    • Clique no botão Remover transformação  no painel Transformar

    • Selecione Modificar > Transformar > Remover transformação

Modelagem de ativos para conteúdo de vetor e raster

Uma nova ferramenta de distorção de ativo foi introduzida no Animate 19.0. Você pode usar a ferramenta de distorção de ativo para criar alças de distorção em formas, objetos de desenho e bitmaps no Animate. Ao arrastar as alças de distorção com uma ferramenta de distorção de ativo, você pode deformar, formas, objetos desenhados e bitmaps. 

Ferramenta Distorção de ativo
Ferramenta Distorção de ativo

Usando as alças de distorção que são exibidas nos objetos, você pode modificar a forma ou distorcer áreas específicas do objeto enquanto deixa outras áreas intactas. Todos os objetos selecionados são agrupados ao criar a primeira alça de distorção. Ao inserir um quadro-chave, as alças de distorção do quadro-chave anterior são copiadas para o novo quadro-chave.

Alguns estilos de cursor exibidos ao passar o mouse sobre objetos com a ferramenta de distorção de ativo estão exibidos abaixo para referência.

Esse cursor é exibido quando a ferramenta de distorção de ativo não é suportada em um objeto.

- Esse cursor indica que você pode usar a ferramenta de distorção de ativo para criar alças de distorção em um objeto.

- Esse cursor indica que você pode clicar na alça de distorção para alterar a forma de um objeto.

Cursor moveto

Esse cursor indica que você pode girar o objeto.

Uso da ferramenta de distorção de ativo

  1. Para começar, crie uma forma ou importe uma imagem de bitmap para o palco. 

  2. Clique na ferramenta de distorção do ativo na barra de ferramentas.

  3. Ao passar o mouse sobre uma forma ou objeto de desenho, um símbolo  é exibido. Clique nele para adicionar alças de distorção. 

    Passar o mouse sobre uma forma ou um objeto de desenho
    Passar o mouse sobre uma forma ou um objeto de desenho

  4. Alças de distorção de ativo são exibidas como círculos sólidos pequenos na forma/objeto de desenho. Use quantas alças precisar para distorcer a forma apropriadamente. Use a tecla Delete no teclado para excluir uma alça de distorção de marionete.

    Alças de distorção de ativo
    Alças de distorção de ativo

  5. Shift + Clique nas alças de distorção de marionete para selecionar várias alças. Você pode arrastar as alças usando a ferramenta distorção de ativo para alterar a forma conforme necessário.

    Deformação de formas usando alças
    Deformação de formas usando alças

    Deformação de bitmaps usando alças

  6. Escolha um dos dois modos associados com as alças de distorção.

        a.     Modo gratuito: este modo permite mais graus de liberdade em torno da alça durante a deformação. Uma alça nesse modo é desenhada como um contínuo-círculo branco.

        b.   Modo protegido: este modo permite menos graus de liberdade em torno da alça durante a deformação. Uma alça nesse modo é desenhada como um contínuo-círculo preto.

    Para alternar entre os dois modos, use Alt + clique nas alças de distorção. 

Um tutorial sobre distorções de ativo

Saiba como usar a distorção de ativo no Animate.

Edição de uma forma de base

Forma base é a forma antes de aplicar distorção. A deformação de ativo funciona em malhas posicionadas sobre a forma de base. Também é possível alterar a forma base alternando para a ferramenta de seleção e clicando duas vezes na forma distorcida. As modificações feitas na forma base são aplicadas a todas as instâncias distorcidas da forma. Esse recurso é compatível somente com formas de vetor.

Propriedades da forma de distorção de ativo
Propriedades da forma de distorção de ativo

Ferramenta Distorção de ativo de interpolação

Você pode usar a interpolação clássica com a ferramenta de Distorção de ativo. Por exemplo, você pode aplicar Interpolação clássica para interpolar poses da marionete. 

Clique aqui para saber mais sobre a interpolação clássica. 

Observação:

Para interpolar as poses, use o mesmo conjunto de alças da forma.

Combinação de objetos

Para criar novas formas com a combinação ou alteração de objetos existentes, use os comandos Combinar Objetos no menu Modificar (Modificar > Combinar objetos). Às vezes, a ordem empilhada dos objetos selecionados determina como a operação funciona.

Cada comando aplica-se a tipos específicos de objetos gráficos, que estão indicados abaixo. Uma forma de mesclagem é uma forma desenhada com uma ferramenta definida para o modo Mesclar desenho. Um objeto de desenho é uma forma desenhada com uma ferramenta definida para o modo Desenho de objeto.

Os comandos Combinar objetos são:

União

Une duas ou mais formas de mesclagem ou objetos de desenho. O resultado é uma única forma do modo Desenho de objeto, formada por todas as partes visíveis nas formas, antes que sejam unidas. As partes invisíveis e superpostas das formas são excluídas.

 

Observação:

Diferentemente de quando você usa o comando Agrupar (Modificar > Agrupar), não se pode separar as formas unidas com o uso do comando União.

Interseção

Cria um objeto com a interseção de dois ou mais objetos de desenho. A forma Desenho de objeto resultante é formada pelas partes superpostas das formas combinadas. Qualquer parte não superposta da forma é excluída. A forma resultante usa o preenchimento e o traçado da primeira forma da pilha.

Perfuração

Remove partes do objeto de desenho selecionado, definido pelas partes sobrepostas de outro objeto de desenho selecionado, posicionado à sua frente. Qualquer parte de um objeto de desenho sobreposto pelo primeiro objeto é excluída e o primeiro objeto é totalmente excluído. Os objetos resultantes permanecem separados e não são combinados em um único objeto (diferentemente dos comandos União e Interseção, que unem os objetos).

Corte

Usa o contorno de um objeto de desenho para cortar outro objeto de desenho. O primeiro objeto, ou o da frente, define a forma da área recortada. Qualquer parte de um objeto de desenho subjacente que está sobreposta ao primeiro objeto permanece, enquanto todas as outras partes dos objetos subjacentes são excluídas e o primeiro objeto é totalmente excluído. Os objetos resultantes permanecem separados e não são combinados em um único objeto (diferentemente dos comandos União e Interseção, que unem os objetos).

Logotipo da Adobe

Fazer logon em sua conta