Création de masques

Vous pouvez créer un ou plusieurs masques pour chaque calque d’une composition en suivant l’une des méthodes ci-dessous :

Lorsque vous créez des masques sur un calque, leur nom s’affiche dans le panneau Montage, dans l’ordre de création de ces masques. Pour organiser vos masques et faciliter leur identification, renommez-les.

Remarque :

Pour renommer un masque, sélectionnez-le et appuyez sur la touche Entrée (Windows) ou Retour (Mac OS), ou cliquez sur le nom du masque avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Mac OS), puis choisissez Renommer.

Lorsque vous créez des masques supplémentaires pour un calque dans le panneau Calque, assurez-vous que le menu contextuel Cible de ce même panneau indique bien Sans. Dans le cas contraire, vous remplaceriez le masque ciblé au lieu d’en créer un nouveau. Vous pouvez aussi verrouiller un masque afin d’empêcher sa modification.

Options de menu à sélectionner pour définir un masque à cibler dans le panneau Calque
Options de menu à sélectionner pour définir un masque à cibler dans le panneau Calque

A. Menu Afficher B. Menu Cible 

Lorsque vous créez ou modifiez des masques, pensez à consulter le panneau Info. Vous y trouverez divers renseignements, notamment le nom du masque et le nombre de sommets qu’il contient.

Remarque :

Pour créer un masque que vous pouvez déplacer indépendamment du calque principal qu’il masque, procédez comme suit :

  1. Créez le masque sur un calque blanc uni distinct, puis utilisez ce calque uni comme cache par approche pour le calque principal.
  2. Ensuite, avec la fonction de lien de parenté, définissez le calque uni comme enfant du calque principal, de sorte que le masque se déplace en même temps que le calque principal, comme s’il y était appliqué directement. Dans la mesure où le calque uni est un calque enfant, il est également possible de l’animer indépendamment de son parent.
  3. Vous pouvez utiliser le suivi de mouvement pour que le calque uni (et par conséquent, le masque) suive les objets mobiles du calque principal (voir les sections Conversion d’un calque en cache par approche et Calques parents et enfants).

Création d’un masque rectangulaire ou elliptique de manière numérique

  1. Sélectionnez un calque dans le panneau Composition ou affichez un calque dans le panneau Calque.
  2. Sélectionnez Calque > Masque > Nouveau masque. Un nouveau masque apparaît dans le panneau Composition ou Calque. Ses poignées sont positionnées le long du contour extérieur du cadre.
  3. Sélectionnez Calque > Masque > Forme du masque.
  4. Sélectionnez Rétablir, puis choisissez Rectangle ou Ellipse dans le menu Forme et précisez la taille et l’emplacement du cadre de sélection du masque.

Création d’un masque à partir de valeurs de couche à l’aide de la commande Tracé automatique

  1. Vous pouvez transformer la couche alpha, rouge, bleue, verte ou de luminance d’un calque en un ou plusieurs masques à l’aide de la commande Tracé automatique.
  2. La commande Tracé automatique crée autant de masques Bézier que nécessaire pour encadrer les valeurs de couches spécifiées dans le calque.
  3. Elle crée aussi des masques avec le moins de sommets possible tout en respectant les paramètres que vous choisissez.
  4. Vous pouvez modifier un masque créé avec la commande Tracé automatique comme tout autre masque, et vous pouvez lier son tracé à d’autres types de tracé, comme des tracés de forme sur un calque de formes, à l’aide d’expressions.

Lorsque vous appliquez le tracé automatique, les calques affectés prennent automatiquement la valeur Qualité optimale afin de garantir une plus grande précision.

Remarque :

Pour réduire le nombre de masques créés par la commande Tracé automatique, appliquez un effet de masquage au calque pour isoler le sujet avant d’utiliser le tracé automatique.

  1. Dans le panneau Montage, utilisez l’une des méthodes suivantes :
    • Pour créer des images clés de masque sur une seule image, faites glisser le repère de l’instant courant sur l’image souhaitée.
    • Pour créer des images clés de masque sur une série d’images, définissez une zone de travail englobant la série entière.
  2. Sélectionnez un ou plusieurs calques.
  3. Sélectionnez Calque > Tracé automatique.
  4. Sélectionnez l’une des options suivantes :

    Image actuelle

    Crée des images clés de masque sur l’image actuelle uniquement.

    Zone de travail

    Crée des images clés de masque pour les images de la zone de travail.

  5. Définissez l’une des options suivantes :

    Inverser

    Inverse le calque d’entrée avant de rechercher les contours.

    Flou

    Applique un flou à l’image d’origine avant de générer le tracé final. Sélectionnez cette option pour réduire le nombre de petits artefacts et lisser les contours du tracé final. Désélectionnez cette option pour tracer de près les détails dans une image à fort contraste. Spécifiez le rayon, en pixels, de la zone d’application du flou. Plus les valeurs sont élevées, plus le flou appliqué sera important.

    Tolérance

    Spécifie, en pixels, l’écart autorisé du tracé par rapport aux contours de la couche.

    Seuil

    Spécifie, en pourcentage, la valeur que doit prendre la couche d’un pixel pour que ce pixel soit considéré comme faisant partie d’un contour. Les valeurs supérieures à ce seuil sont mappées en blanc et deviennent opaques ; les valeurs inférieures à ce seuil sont mappées en noir et deviennent transparentes.

    Zone minimale

    Spécifie la plus petite zone de l’image d’origine qui sera tracée. Par exemple, une valeur de 4 supprime les zones inférieures à 2 pixels de large sur 2 pixels de haut du tracé final.

    Arrondi de la courbe

    Spécifie l’arrondi de la courbe du masque au niveau des sommets. Entrez une valeur plus élevée pour obtenir une courbe plus lisse.

    Appliquer au nouveau calque

    Applique le masque à un nouveau solide de taille égale à celle du calque sélectionné. Ce paramètre est automatiquement sélectionné pour les calques dont l’option Condenser transform. est activée ; cela crée un nouveau calque dont la taille est identique à celle de la composition contenant le calque.

    Prévisualisation

    Cette option permet de prévisualiser les résultats du masque et des diverses options de la commande Tracé automatique.

Création de formes et de calques de forme

Pour créer un calque de forme, utilisez le panneau Composition et un outil de forme ou l’outil Plume. Vous pouvez ensuite ajouter des attributs de forme aux formes existantes ou créer de nouvelles formes dans ce calque. Par défaut, si vous dessinez dans le panneau Composition alors qu’un calque de forme est sélectionné, vous créez une nouvelle forme dans ce calque, placée au-dessus des formes ou du groupe de formes sélectionné(es). Si vous dessinez dans le panneau Composition à l’aide d’un outil de forme ou de l’outil Plume alors qu’un calque d’image autre qu’un calque de forme est sélectionné, vous créez un masque.

Remarque :

Appuyez sur la touche F2 pour désélectionner tous les calques avant de dessiner dans le panneau Composition pour créer un nouveau calque de forme.

Vous pouvez créer des formes et des calques de forme en appliquant l’une des méthodes suivantes :

Dans la plupart des cas, une nouvelle forme possède un fond et un contour correspondant aux paramètres Fond et Contour du panneau Outils sélectionnés au moment du dessin de la forme. Vous pouvez utiliser les mêmes options du panneau Outils pour modifier ces attributs pour une forme sélectionnée une fois qu’elle a été dessinée. Les formes créées à partir de texte reprennent les fonds et les contours du texte original.

Remarque :

pour dessiner un masque sur un calque de forme, cliquez sur le bouton L’outil crée des masques de calque du panneau Outils avec un outil de forme ou l’outil Plume actif. Pour plus d’informations sur la création de masques, voir Création de masques.

Conversion d’un métrage d’illustrations vectorielles en forme | CC, CS6

Dans les versions précédentes d’After Effects, vous pouviez importer un fichier Illustrator (.ai), EPS (.eps) ou PDF (.pdf), mais vous ne pouviez pas le modifier. Vous pouvez maintenant créer un calque de forme à partir d’un calque de métrage d’illustrations vectorielles, puis le modifier.

Vous pouvez, en outre, extruder l’illustration (des logos extrudés, par exemple) grâce aux fonctionnalités de biseautage et d’extrusion d’objets d’After Effects (voir Extrusion de calques de forme et de texte).

Pour convertir un calque de métrage d’illustrations vectorielles en calques de forme :

  • Sélectionnez Calque > Créer des formes à partir du calque vectoriel. Un calque de forme correspondant s’affiche au-dessus du calque de métrage (l’audio du calque de métrage étant désactivé).

    Les problèmes suivants sont connus :

    • Pour l’heure, toutes les fonctions des fichiers Illustrator ne sont pas conservées. En voici quelques exemples : opacité, images et dégradés.
    • Les formes converties ignorent les remplacements PAR spécifiés dans la boîte de dialogue Interpréter un métrage.
    • Les dégradés et les types non pris en charge peuvent s’afficher en tant que formes grises à 50 %.
    • Il se peut que l’importation des fichiers comprenant des milliers de tracés s’effectue lentement et sans commentaires.
    • La commande de menu fonctionne sur un seul calque sélectionné à la fois.
    • Si vous importez un fichier Illustrator sous la forme d’une composition (c’est-à-dire, de plusieurs calques), vous ne pouvez pas convertir tous ces calques en un seul passage. Toutefois, vous pouvez importer le fichier sous la forme d’un métrage, puis utiliser la commande pour convertir le calque de métrage unique en formes.

Cette vidéo de Todd Kopriva et video2brain explique comment convertir rapidement des images vectorielles d’Illustrator en calques de forme et comment animer les tracés dans After Effects CS6. Ce processus est beaucoup plus simple que dans les versions précédentes d’After Effects.

Création d’une forme ou d’un masque par glissement à l’aide des outils de forme

Les outils de forme sont les suivants : Rectangle , Rectangle arrondi , Ellipse , Polygone et Etoile

Remarque :

Pour activer les outils de forme et les passer en revue, appuyez sur la touche Q.

Un polygone est une étoile démunie de la propriété Rayon interne ou Arrondi interne, c’est pourquoi le nom de la forme créée pour un polygone ou une étoile est identique : polyétoile.

Vous pouvez créer un masque en faisant glisser un outil de forme sur un calque sélectionné dans le panneau Composition ou Calque. Vous pouvez créer une forme en faisant glisser un outil de forme sur un calque de forme sélectionné dans le panneau Composition. Si vous faites glisser un outil de forme dans le panneau Composition et qu’aucun calque n’est sélectionné, vous créez une forme sur un nouveau calque de forme.

Remarque :

pour dessiner un masque sur un calque de forme, cliquez sur le bouton L’outil crée des masques de calque du panneau Outils avec un outil de forme actif.

Lorsque vous créez une forme en faisant glisser un outil de forme dans le panneau Composition, vous créez un tracé paramétrique. Si vous préférez créer une courbe de Bézier, appuyez sur la touche Alt (Windows) ou Option (Mac OS) avant de cliquer pour commencer le dessin. Vous pouvez relâcher la touche avant la fin de l’opération de glissement. Tous les tracés de masque sont des courbes de Bézier. (voir À propos des formes et des calques de forme).

L’opération de glissement débute lorsque vous cliquez dans le panneau Composition ou Calque pour commencer le dessin et se termine lorsque vous relâchez le bouton de la souris. En appuyant sur les touches de modification à différents moments au cours d’une opération de glissement, vous obtenez des résultats différents :

  • Pour repositionner une forme ou un masque pendant que vous dessinez, maintenez la barre d’espacement enfoncée ou appuyez sur le bouton central de la souris tout en la faisant glisser.

  • Pour mettre à l’échelle un cercle, une ellipse, un carré, un carré arrondi, un rectangle ou un rectangle arrondi autour de son centre pendant que vous dessinez, maintenez la touche Ctrl (Windows) ou Commande (Mac OS) enfoncée après que vous avez commencé à faire glisser la souris. Maintenez la touche enfoncée tant que vous n’avez pas relâché le bouton de la souris pour terminer le dessin.

  • Pour annuler le dessin, appuyez sur Echap.

Remarque :

chaque outil de forme conserve les paramètres de l’opération de dessin la plus récente réalisée avec cet outil. Par exemple, si vous dessinez une étoile et que vous définissez le nombre de points sur 10, la prochaine étoile que vous dessinerez aura elle aussi 10 points. Pour réinitialiser les paramètres d’un outil et créer une forme avec les paramètres par défaut, cliquez deux fois sur l’outil souhaité dans le panneau Outils (voir Création d’une forme ou d’un masque de la taille du calque).

Dessin de rectangles, de rectangles arrondis, de carrés et de carrés arrondis

  1. Sélectionnez l’outil Rectangle ou Rectangle arrondi , puis utilisez l’une des méthodes suivantes :
    • Pour dessiner un rectangle ou un rectangle arrondi, faites glisser la souris en diagonale.
    • Pour dessiner un carré ou un carré arrondi, faites glisser la souris en diagonale tout en appuyant sur la touche Maj.
  2. (Facultatif) Si vous dessinez un rectangle arrondi ou un carré arrondi, procédez comme suit avant de relâcher le bouton de la souris :
    • Pour augmenter ou réduire l’arrondi, appuyez sur la touche Flèche haut ou Flèche bas, ou faites rouler la molette de la souris.
    • Pour définir l’arrondi de la courbe sur la valeur minimum ou maximum, appuyez sur la touche Flèche gauche ou Flèche droite.
  3. Relâchez le bouton de la souris pour terminer le dessin. Si vous dessinez un carré ou un carré arrondi, relâchez la touche Maj après avoir relâché le bouton de la souris.

Remarque :

les carrés sont créés pour être de forme carrée en fonction du format des pixels de la composition. Si le format des pixels de la composition n’est pas défini sur 1, les carrés n’apparaîtront carrés dans le panneau Composition que si le bouton Activer/désactiver la correction du format des pixels est sélectionné en bas du panneau Composition.

Dessin d’ellipses et de cercles

  1. Sélectionnez l’outil Ellipse , puis utilisez l’une des méthodes suivantes :
    • Pour dessiner une ellipse, faites glisser la souris en diagonale.
    • Pour dessiner un cercle, faites glisser la souris en diagonale tout en appuyant sur la touche Maj.
  2. Relâchez le bouton de la souris pour terminer le dessin. Si vous dessinez un cercle, relâchez la touche Maj après avoir relâché le bouton de la souris.

Remarque :

les cercles sont créés pour être de forme circulaire en fonction du format des pixels de la composition. Si le format des pixels de la composition n’est pas défini sur 1, les cercles n’apparaîtront circulaires dans le panneau Composition que si le bouton Activer/désactiver la correction du format des pixels est sélectionné en bas du panneau Composition.

Dessin de polygones et d’étoiles

  1. Sélectionnez l’outil Polygone ou Etoile , puis utilisez l’une des méthodes suivantes :
    • Faites glisser la souris pour mettre à l’échelle et faire pivoter le polygone ou l’étoile à mesure que vous dessinez.
    • Faites glisser la souris tout en appuyant sur la touche Maj pour mettre à l’échelle le polygone ou l’étoile à mesure que vous dessinez, pour éviter tout mouvement de rotation.
  2. (Facultatif) Procédez de la manière suivante avant de relâcher le bouton de la souris :
    • Pour ajouter ou supprimer des points, appuyez sur la touche Flèche haut ou Flèche bas, ou faites rouler la molette de la souris.
    • Pour augmenter ou réduire l’arrondi externe, appuyez sur la touche Flèche gauche ou Flèche droite.
    • Pour maintenir le rayon interne d’une étoile sur une valeur constante alors que vous déplacez la souris pour augmenter le rayon externe, appuyez sur la touche Ctrl (Windows) ou Commande (Mac OS).
    • Pour augmenter ou réduire l’arrondi interne d’une étoile, appuyez sur la touche Pg. préc ou Pg. suiv.
  3. Relâchez le bouton de la souris pour terminer le dessin. Si vous appuyez sur la touche Maj en faisant glisser la souris afin d’éviter toute rotation, veillez à relâcher la touche Maj après avoir relâché la souris.

Création d’une forme ou d’un masque Bézier à l’aide de l’outil Plume

Vous pouvez créer un masque de Bézier en utilisant l’outil Plume sur un calque sélectionné dans le panneau Composition ou Calque. Vous pouvez créer une forme dotée d’un tracé de Bézier en utilisant l’outil Plume sur un calque de forme sélectionné dans le panneau Composition. Si vous dessinez à l’aide de l’outil Plume dans le panneau Composition et qu’aucun calque n’est sélectionné, vous créez une forme sur un nouveau calque de forme.

La création d’un tracé de RotoBézier est similaire à la création d’un tracé de Bézier manuel. La principale différence réside dans le fait que les lignes directrices des sommets et la courbure des segments de tracé sont automatiquement calculées.

Création d’un tracé de Bézier manuel à l’aide de l’outil Plume

  1. Après avoir sélectionné l’outil Plume et désélectionné l’option RotoBézier dans le panneau Outils, cliquez dans le panneau Composition là où vous souhaitez placer le premier sommet.
  2. Cliquez à l’endroit où vous souhaitez placer le sommet suivant. Pour créer un segment incurvé, faites glisser la poignée de la ligne directrice pour créer la courbe requise.

    Remarque :

    Pour repositionner un sommet après avoir cliqué pour le placer mais avant d’avoir relâché le bouton de la souris, appuyez sur la barre d’espacement tout en faisant glisser la souris.

    Le dernier sommet que vous ajoutez apparaît sous la forme d’un carré plein, ce qui indique qu’il est sélectionné. Les sommets précédemment ajoutés deviennent vides et désélectionnés à mesure que vous ajoutez d’autres sommets.

  3. Répétez l’étape 2 jusqu’à ce que vous soyez prêt à terminer le tracé.
  4. Pour compléter le tracé, utilisez l’une des méthodes suivantes :
    • Pour fermer le tracé, placez le pointeur au-dessus du premier sommet et lorsqu’une icône en forme de cercle fermé s’affiche à côté du pointeur , cliquez sur le sommet.

    Remarque :

    vous pouvez également fermer un tracé en cliquant deux fois sur le dernier sommet ou en sélectionnant Calque > Tracé de masque et de forme > Fermé.

    • Pour laisser le tracé ouvert, activez un autre outil ou appuyez sur la touche F2 pour désélectionner le tracé.

Dessin de segments droits sur un tracé de Bézier manuel à l’aide de l’outil Plume

La ligne droite est le tracé le plus simple à réaliser avec l’outil Plume. Il suffit de cliquer avec l’outil Plume pour créer deux sommets. Si vous continuez à cliquer, vous créez un tracé composé de segments rectilignes s’articulant autour de coins.

Pour obtenir des segments droits, cliquez sur le document à l’aide de l’outil Plume
Pour obtenir des segments droits, cliquez sur le document à l’aide de l’outil Plume.

  1. Placez l’outil Plume à l’endroit où vous voulez que le segment droit commence, puis cliquez pour placer un sommet (sans faire glisser la souris).
  2. Cliquez de nouveau à l’endroit où vous voulez que se termine le segment. (Cliquez tout en appuyant sur la touche Maj pour définir l’angle situé entre les segments, au niveau du coin, sur un multiple entier de 45°.)
  3. Continuez de cliquer pour définir les sommets des autres segments droits.

Dessin de segments incurvés sur un tracé de Bézier manuel à l’aide de l’outil Plume

Pour créer un segment de tracé incurvé, faites glisser les lignes directrices. La longueur et la direction des lignes directrices déterminent la forme de la courbe.

Remarque :

Appuyez sur la touche Maj tout en faisant glisser la souris pour définir l’angle des lignes directrices sur des multiples entiers de 45°. Appuyez sur la touche Alt (Windows) ou Option (Mac OS) en faisant glisser la souris pour modifier la ligne directrice d’éloignement.

  1. Placez l’outil Plume à l’endroit où doit commencer la courbe et maintenez le bouton de la souris enfoncé.

    Un sommet apparaît et le pointeur de l’outil Plume prend la forme d’une pointe de flèche.

  2. Faites glisser la souris pour modifier la longueur et la direction des deux lignes directrices d’un sommet, puis relâchez le bouton de la souris.
    Formation du premier sommet d’un tracé incurvé
    Formation du premier sommet d’un tracé incurvé

    A. Placement de l’outil Plume B. Début du glissement (avec maintien du bouton de la souris enfoncé) C. Glissement pour prolonger les lignes directrices 
  3. Placez l’outil Plume à l’endroit où la courbe doit se terminer, puis utilisez l’une des méthodes suivantes :
    • Pour créer une courbe en forme de C, faites glisser la souris dans la direction opposée à celle de la ligne directrice précédente, puis relâchez le bouton de la souris.
    Formation du deuxième sommet d’un tracé incurvé
    Formation du deuxième sommet d’un tracé incurvé

    A. Début du glissement B. Traçage à l’opposé de la ligne directrice précédente, créant ainsi une courbe en forme de C. C. Résultat après relâchement du bouton de la souris 
    • Pour créer une courbe de forme sinusoïdale, faites glisser la souris dans la même direction que celle de la ligne précédente et relâchez le bouton de la souris.
    Formation d’une courbe en S
    Formation d’une courbe en S

    A. Début du glissement B. Déplacement dans la même direction que celle de la ligne directrice précédente, créant ainsi une sinusoïde C. Résultat après relâchement du bouton de la souris 
  4. Continuez à faire glisser l’outil Plume vers d’autres endroits pour créer une série de courbes lisses.

Création d’une forme ou d’un masque de la taille du calque

  1. Sélectionnez la destination du nouveau masque ou de la nouvelle forme :
    • Pour créer une forme sur un calque de forme existant, sélectionnez-le.
    • Pour créer une forme sur un nouveau calque de forme avec les dimensions de la composition, désélectionnez tous les calques en appuyant sur F2.
    • Pour créer un masque, sélectionnez un calque dans le panneau Montage, Calque ou Composition. Pour dessiner un masque sur un calque de forme, sélectionnez L’outil crée un masque dans le panneau Outils avec un outil de forme actif.
    • Pour remplacer un tracé de masque, sélectionnez le masque dans le panneau Montage, Calque ou Composition.
    • Pour remplacer un tracé de forme, sélectionnez-le (et non le groupe) dans le panneau Composition ou Montage.
  2. Dans le panneau Outils, double-cliquez sur l’outil Rectangle , Rectangle arrondi , Ellipse , Polygone ou Etoile .

Création de formes ou de masques à partir de caractères de texte

La commande Créer des formes à partir du texte permet d’extraire les silhouettes de chaque caractère, de créer des formes à partir des silhouettes et de les placer sur un nouveau calque de forme. Vous pouvez ensuite utiliser ces formes comme toute autre forme.

La commande Créer des masques à partir du texte permet d’extraire les silhouettes de chaque caractère, de créer des masques à partir des silhouettes et de les placer sur un nouveau calque uni. Vous pouvez ensuite utiliser ces masques comme tout autre masque.

Remarque :

Certaines familles de police, comme Webdings, incluent des caractères qui représentent des images graphiques plutôt que du texte. La conversion de texte de ces familles de police peut être un bon moyen de se familiariser avec des éléments graphiques simples dans les calques de forme.

Création de formes à partir de texte

  1. Sélectionnez le texte à convertir en formes :
    • Pour créer des formes pour tous les caractères d’un calque de texte, sélectionnez le calque de texte dans le panneau Montage ou Composition.
    • Pour créer des formes pour des caractères particuliers, sélectionnez les caractères en question dans le panneau Composition.
  2. Utilisez l’une des méthodes suivantes :
    • Sélectionnez Calque > Créer des formes à partir du texte.
    • Cliquez sur le calque ou le texte avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Mac OS), puis choisissez Créer des formes à partir du texte dans le menu contextuel.

Le bouton d’option Vidéo du calque de texte est désactivé.

Le nouveau calque de forme est créé en haut de l’ordre d’empilement des calques. Le nouveau calque contient un groupe de formes pour chaque caractère sélectionné, ainsi que des propriétés de fond et de contour correspondant à celles du texte.

Pour les caractères constitués de tracés complexes, comme les lettres i et e, plusieurs tracés sont créés, puis combinés par l’opération Fusionner les tracés.

Les effets, masques, styles de calque, images clés et expressions des propriétés du groupe de propriétés Transformer du calque de texte sont copiés dans le nouveau calque de forme ou calque de couleur unie.

Création de masques à partir de texte

  1. Sélectionnez le texte à convertir en masques :
    • Pour créer des masques pour tous les caractères d’un calque de texte, sélectionnez le calque de texte dans le panneau Montage ou Composition.
    • Pour créer des masques pour des caractères particuliers, sélectionnez les caractères en question dans le panneau Composition.
  2. Utilisez l’une des méthodes suivantes :
    • Sélectionnez Calque > Créer des masques à partir du texte.
    • Cliquez sur le calque ou le texte avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Mac OS), puis choisissez Créer des masques à partir du texte dans le menu contextuel.

Le bouton d’option Vidéo du calque de texte est désactivé.

Le nouveau calque de couleur unie est créé tout en haut de l’ordre d’empilement des calques.

Pour les caractères constitués de tracés complexes, comme les lettres i et e, plusieurs masques sont créés puis combinés à l’aide du mode de masque Soustraction.

Copie d’un tracé depuis Illustrator, Photoshop ou Fireworks

Vous pouvez copier un tracé depuis Illustrator, Photoshop ou Fireworks et le coller dans After Effects en tant que tracé de masque ou tracé de forme.

pour que les données copiées à partir d’Illustrator soient compatibles avec After Effects, il faut que l’option AICB de la zone Fichiers et presse-papiers de la boîte de dialogue des préférences d’Adobe Illustrator soit sélectionnée.

Pour qu’un tracé importé depuis Photoshop soit redimensionné correctement, la résolution du document Photoshop doit être de 72 ppp. Il s’agit du paramètre de résolution des documents créés dans Photoshop à l’aide d’un paramètre prédéfini Film et vidéo.

Remarque : vous pouvez également utiliser la copie d’un tracé Illustrator, Photoshop ou Fireworks comme trajectoire dans After Effects. Voir la section Création d’une trajectoire à partir d’un tracé de masque, de forme ou de peinture pour en savoir plus.

Tracé dessiné dans Adobe Illustrator (gauche) et collé dans After Effects sous forme de masque (droite)
Tracé dessiné dans Adobe Illustrator (gauche) et collé dans After Effects sous forme de masque (droite)

  1. Dans Illustrator, Photoshop ou Fireworks, sélectionnez un tracé complet, puis choisissez Edition > Copier.
  2. Dans After Effects, pour désigner la cible de l’opération de collage, utilisez l’une des méthodes suivantes :
    • Pour créer un nouveau masque, sélectionnez un calque.
    • Pour remplacer un tracé de masque ou de forme existant, sélectionnez ses propriétés.

    Remarque :

    pour coller un tracé comme un tracé de forme, vous devez sélectionner la propriété Tracé d’une forme se trouvant déjà dans un calque de forme. Cette sélection indique à After Effects la cible de l’opération de collage. Si la cible n’est pas désignée ainsi, After Effects suppose que la cible est le calque tout entier. Un nouveau masque est donc tracé. En l’absence d’une propriété Tracé (cela peut être le cas lorsque le calque de forme est vide), vous pouvez dessiner un tracé de pseudo-élément à l’aide de l’outil Plume, puis y coller le tracé depuis Illustrator.

  3. Choisissez Edition > Coller.

    Si vous collez plusieurs tracés dans un tracé de forme, le premier y est inclus. Les autres sont collés dans de nouveaux tracés de masque. Ceci est dû au fait qu’aucune cible n’est clairement définie pour les tracés autres que le premier. Ils sont donc ajoutés dans le calque entier comme des masques.

Dans cette vidéo sur le site Web de Creative COW, Andrew Devis explique comment utiliser les tracés d’Illustrator comme des trajectoires dans After Effects.

Création d’un masque ou d’une forme à partir d’une trajectoire

Vous pouvez copier des images clés de position, des images clés de point d’ancrage ou les images clés de position d’un point de contrôle, puis les coller dans un tracé de masque ou de forme sélectionné. Lorsque vous créez un tracé de masque ou de forme à partir de trajectoires, prenez soin de copier les images clés à partir d’une seule propriété Position ; ne copiez en aucun cas les images clés d’une autre propriété.

Remarque :

Tracez une trajectoire avec la fonction Dessin de trajectoire, puis collez-la dans un tracé de masque ou un tracé de forme.

Création d’un masque ou d’une forme à partir d’une trajectoire
La trajectoire de la navette spatiale (en haut) est copiée sur le calque d’arrière-plan (en bas à gauche) et utilisée par l’effet Vegas (en bas à droite).

Remarque :

lors d’une copie entre un tracé de masque et une trajectoire, gardez à l’esprit que les valeurs du tracé de masque sont exprimées dans le système de coordonnées du calque (espace calque), tandis que celles de la trajectoire le sont dans le système de coordonnées de la composition (espace composition). Si le tracé collé est décalé en raison de cette différence de système de coordonnées, vous devrez le replacer après le collage (voir Systèmes de coordonnées : espace de la composition et espace du calque).

Création d’un tracé de masque à partir d’une trajectoire

  1. Dans le panneau Montage, cliquez sur le nom de la propriété Position ou Point d’ancrage à partir de laquelle vous voulez copier la trajectoire. (Ceci sélectionne toutes les images clés. Pour sélectionner seulement une partie des images clés d’une trajectoire, maintenez la touche Maj enfoncée et cliquez sur celles qui vous intéressent).
  2. Choisissez Edition > Copier.
  3. Pour créer un nouveau masque, sélectionnez le calque dans lequel créer le masque, puis choisissez Calque > Masque > Nouveau masque.
  4. Dans le panneau Montage, cliquez sur le nom de la propriété Tracé du masque associée au masque dans lequel coller les images clés de la trajectoire.
  5. Choisissez Edition > Coller.
    Sélection et copie d’images clés de position
    Sélection et copie d’images clés de position (gauche) ; puis collage de ces dernières dans la propriété Forme du masque sélectionnée (droite)

Création d’un tracé de forme à partir d’une trajectoire

  1. Dans le panneau Montage, cliquez sur le nom de la propriété Position ou Point d’ancrage à partir de laquelle vous voulez copier la trajectoire. (Ceci sélectionne toutes les images clés. Pour sélectionner seulement une partie des images clés d’une trajectoire, maintenez la touche Maj enfoncée et cliquez sur celles qui vous intéressent).
  2. Choisissez Edition > Copier.
  3. Pour créer un nouveau calque de forme, appuyez sur la touche F2 pour désélectionner tous les calques, puis cliquez dans le panneau Composition avec l’outil Plume pour créer un tracé Bézier ne comportant qu’un seul point.
  4. Pour faire apparaître la propriété Tracé de la forme, appuyez sur SS. Cliquez sur le nom de la propriété Tracé dans laquelle coller les images clés de la trajectoire.
  5. Choisissez Edition > Coller.

Duplication d’un groupe de formes pendant la transformation

Lorsqu’un groupe de formes est sélectionné en mode de sélection de groupe, vous pouvez le dupliquer pendant les opérations de déplacement, rotation ou mise à l’échelle dans le panneau Composition.

  • Maintenez la touche Alt (Windows) ou Option (Mac OS) enfoncée pendant que vous faites glisser la souris pour transformer le groupe.

    Le pointeur prend la forme d’un pointeur de duplication ( ou ) pendant que vous appuyez sur la touche et placez le pointeur à côté de la zone de transformation du groupe.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne