A propos de l’interpolation spatiale et temporelle des images clés

Cliquez avec le bouton droit de la souris (Windows) ou cliquez sur l’élément tout en maintenant la touche Contrôle enfoncée (Mac OS) dans le panneau Projet. L’interpolation est le processus de remplissage des données inconnues entre deux valeurs connues. La définition d’images clés permet de spécifier les valeurs d’une propriété à certains moments clés. After Effects interpole les valeurs de la propriété pour chaque temps entre les images clés.

Comme l’interpolation génère les valeurs des propriétés entre les images clés, l’interpolation est parfois appelée tweening. L’interpolation entre images clés peut être utilisée pour animer un mouvement, des effets, des niveaux sonores, des ajustements d’image, la transparence, des modifications de couleur et de nombreux autres éléments visuels et audio.

Après avoir créé des images clés et des trajectoires pour faire évoluer des valeurs dans le temps, vous pouvez réaliser un réglage plus précis de la manière dont ces changements se produisent. After Effects propose plusieurs modes d’interpolation offrant tous leur propre mode de calcul des valeurs intermédiaires.

L’interpolation temporelle correspond à l’interpolation des valeurs dans le temps, tandis que l’interpolation spatiale fait référence à leur interpolation dans l’espace. Certaines propriétés (Opacité, par exemple) possèdent uniquement un composant temporel. D’autres (c’est le cas notamment de Position) possèdent également des composants spatiaux.

Interpolation temporelle et graphique de valeurs

A l’aide du graphique de valeurs de l’éditeur de graphiques, vous pouvez ajuster avec précision les images clés d’une propriété temporelle que vous avez créées pour votre animation. Le graphique de valeurs affiche les valeurs x en rouge, les valeurs y en vert et les valeurs z (3D uniquement) en bleu. Le graphique de valeurs fournit des informations complètes sur la valeur des images clés à tout moment d’une composition et vous permet de la contrôler. En outre, le panneau Info affiche la méthode d’interpolation temporelle de l’image clé sélectionnée.

Interpolation spatiale et trajectoire

Lorsque vous appliquez ou modifiez l’interpolation spatiale pour une propriété, par exemple Position, vous réglez la trajectoire dans le panneau Composition. Les différentes images clés de la trajectoire fournissent des informations concernant le type d’interpolation à tout moment. Le panneau Info affiche la méthode d’interpolation spatiale de l’image clé sélectionnée.

Lorsque vous créez des modifications spatiales dans un calque, After Effects utilise Bézier auto comme méthode d’interpolation spatiale par défaut.

Remarque :

Pour définir une interpolation linéaire par défaut, sélectionnez Edition > Préférences > Général (Windows) ou After Effects > Préférences > Général (Mac OS), et choisissez Interpolation spatiale par défaut sur linéaire. La modification de la préférence n’a aucune incidence sur les images clés existantes, ni sur les nouvelles images clés, sur les propriétés pour lesquelles il existe déjà des images clés.

Interpolation sous forme de trajectoire : Linéaire, Bézier, Bézier continue, Bézier auto et Maintenir
Interpolation sous forme de trajectoire 

A. Linéaire B. Bézier auto C. Bézier continue D. Bézier E. Maintenir 

dans certains cas, l’interpolation spatiale Bézier auto pour les images clés de position peut engendrer un mouvement de va-et-vient indésirable (boomerang) entre deux images clés de valeurs identiques. Dans ce cas, vous pouvez modifier l’image clé précédente pour utiliser l’interpolation par paliers (de maintien) ou modifier les deux images clés pour utiliser une interpolation linéaire.

Ressources en ligne concernant l’interpolation d’images clés

Aharon Rabinowitz propose, sur le site Web Creative COW, un didacticiel vidéo en deux parties qui décrit le problème de mouvement boomerang (ainsi que sa solution) qui se produit lorsque l’interpolation spatiale Bézier auto est définie, par inadvertance, pour des images clés de même valeur :

Antony Bolante fournit des informations et des illustrations sur l’interpolation des images clés dans un article disponible sur le site Web Presse de Peachpit.

Méthodes d’interpolation entre les images clés

En mode d’affichage des bandes de durée des calques, l’apparence de l’icône d’une image clé varie en fonction de la méthode d’interpolation sélectionnée pour l’intervalle entre les images clés. Lorsqu’une moitié de l’icône est grise , cela signifie qu’aucune image clé n’est adjacente de ce côté, ou que l’interpolation Maintenir de l’image clé précédente a priorité sur son interpolation.

Par défaut, une image clé utilise une seule méthode d’interpolation. Cependant, vous pouvez appliquer deux méthodes : la méthode d’approche, qui s’applique à la valeur de la propriété au moment où l’instant courant s’approche d’une image clé ; la méthode d’éloignement, qui s’applique à la valeur de la propriété quand l’instant courant quitte une image clé. Lorsque vous définissez des méthodes d’interpolation d’approche et d’éloignement différentes, l’icône de l’image clé est modifiée en conséquence en mode d’affichage de la bande de durée des calques. L’icône est alors constituée de la moitié gauche de l’icône de l’interpolation d’approche et de la moitié droite de l’icône de l’interpolation d’éloignement.

Remarque :

Pour alterner entre les icônes d’images clés et les indices d’images clés, choisissez Utiliser les icônes d’images clés ou Utiliser les indices d’images clés dans le menu du panneau Montage.

Icônes d’images clés dans le panneau Montage en mode d’affichage des bandes de durée des calques : Linéaire, Linéaire (approche), Maintien (éloignement), Bézier auto, Bézier continue ou Bézier, Linéaire (approche), Bézier (éloignement)
Exemples d’icônes d’image clé dans le panneau Montage en mode d’affichage des bandes de durée des calques 

A. Linéaire B. Linéaire (approche), Maintien (éloignement) C. Bézier auto D. Bézier continue ou Bézier E. Linéaire (approche), Bézier (éloignement) 

Toutes les méthodes d’interpolation utilisées par After Effects reposent sur la méthode d’interpolation Bézier, qui fournit des poignées directrices vous permettant de contrôler les transitions entre les images clés. Les méthodes d’interpolation n’utilisant pas de poignées directrices sont des versions limitées de l’interpolation Bézier et sont utiles pour certaines tâches.

Pour en savoir plus sur la manière dont les différentes méthodes d’interpolation agissent sur les propriétés temporelles, faites des essais en définissant au moins trois images clés avec des valeurs différentes pour une propriété temporelle de calque, telle que Opacité, et changez de méthodes d’interpolation à mesure que vous visualisez le graphique de valeurs dans l’éditeur de graphiques du panneau Montage.

Pour en savoir plus sur la manière dont les différentes méthodes d’interpolation affectent une trajectoire, faites des essais en définissant trois images clés pour une propriété spatiale, telle que Position, avec des valeurs différentes sur une trajectoire et changez de méthodes d’interpolation tout en visualisant la trajectoire dans le panneau Composition.

Remarque :

pour modifier les méthodes d’interpolation, cliquez avec le bouton droit de la souris sur une image clé, choisissez Interpolation d’une image clé dans le menu qui s’affiche, puis sélectionnez une option dans le menu Interpolation temporelle.

Pour clarifier les exemples dans les descriptions suivantes, le résultat de chaque méthode d’interpolation est décrit comme si cette dernière avait été appliquée à toutes les images clés de la propriété de calque. Dans la pratique, vous pouvez appliquer n’importe quelle méthode d’interpolation disponible à une image clé quelconque.

Aucune interpolation

L’état Aucune interpolation est obtenu lorsqu’une propriété de calque n’a aucune image clé, lorsque l’icône chronomètre est désactivée et que l’icône du pointeur apparaît sous le repère d’instant courant dans le panneau Montage. Dans cet état, lorsque vous définissez la valeur d’une propriété de calque, cette dernière est maintenue pendant toute la durée du calque, à moins qu’elle ne soit désactivée par une expression. Par défaut, aucune interpolation n’est appliquée à une propriété de calque. Si une propriété de calque contient des images clés, il y a automatiquement un type ou un autre d’interpolation en cours d’utilisation.

Interpolation linéaire

L’interpolation linéaire crée un taux de changement uniforme entre les images clés, ce qui a pour effet de donner un aspect mécanique aux animations. After Effects interpole les valeurs entre deux images clés adjacentes aussi directement que possible, sans tenir compte de la valeur des autres images clés.

Si vous appliquez une interpolation linéaire à toutes les images clés d’une propriété temporelle de calque, le changement commence instantanément à la première image clé et se poursuit jusqu’à la prochaine image clé à une vitesse constante. A la seconde image clé, le taux de changement passe aussitôt au taux défini entre la seconde et la troisième image clé. Lorsque le calque atteint la valeur de l’image clé finale, le changement s’interrompt instantanément. Dans le graphique de valeurs, le segment reliant deux images clés avec l’interpolation linéaire apparaît comme une ligne droite.

Interpolation Bézier

L’interpolation Bézier permet le contrôle le plus précis dans la mesure où vous ajustez manuellement la forme des segments du graphique de valeurs ou de la trajectoire de part et d’autre de l’image clé. Contrairement à Bézier auto ou Bézier continue, les deux poignées directrices d’une image clé Bézier fonctionnent indépendamment l’une de l’autre dans le graphique de valeurs et la trajectoire.

Si vous appliquez l’interpolation Bézier à toutes les images clés d’une propriété, After Effects crée une transition fluide entre les images clés. La position initiale des poignées directrices est calculée à l’aide de la même méthode que celle utilisée pour l’interpolation Bézier auto. After Effects conserve la position des poignées directrices existantes pendant la modification de la valeur d’une image clé Bézier.

Contrairement à d’autres méthodes d’interpolation, l’interpolation Bézier vous permet de créer n’importe quelle combinaison de courbes et de lignes droites le long d’une trajectoire. Etant donné que les deux poignées directrices Bézier agissent indépendamment l’une de l’autre, une trajectoire incurvée peut soudain se transformer en angle au niveau d’une image clé Bézier. L’interpolation spatiale Bézier est idéale pour dessiner une trajectoire qui suit une forme complexe, telle qu’une route sur une carte ou le contour d’un logo.

Les poignées directrices existantes restent en place lorsque vous déplacez une image clé de trajectoire. L’interpolation temporelle appliquée à chaque image clé contrôle la vitesse de déplacement le long du parcours.

Interpolation Bézier auto

L’interpolation Bézier auto crée un taux de changement fluide au niveau d’une image clé. Vous pouvez utiliser l’interpolation spatiale Bézier auto pour créer le parcours d’une voiture avançant sur une route sinueuse.

Quand vous modifiez la valeur d’une image clé Bézier auto , les positions des poignées directrices Bézier auto changent automatiquement pour conserver une transition fluide entre les images clés. Ces réglages automatiques modifient la forme des segments du graphique de valeurs ou de la trajectoire de part et d’autre de l’image clé. Si l’image clé précédente et/ou suivante utilise également l’interpolation Bézier auto, la forme du segment issu du côté non adjacent de l’image clé précédente ou suivante change aussi. Si vous ajustez manuellement une poignée directrice Bézier auto, vous la convertissez en image clé Bézier continue .

Bézier auto est la méthode d’interpolation spatiale par défaut.

Interpolation Bézier continue

Tout comme l’interpolation Bézier auto, l’interpolation Bézier continue crée un taux de changement fluide au niveau d’une image clé. Cependant, vous définissez la position des poignées directrices Bézier continue manuellement. Les réglages que vous effectuez modifient la forme des segments du graphique de valeurs ou de la trajectoire de part et d’autre de l’image clé.

Si vous appliquez l’interpolation Bézier continue à toutes les images clés d’une propriété, After Effects ajuste les valeurs de chaque image clé afin de créer des transitions fluides. After Effects conserve ces transitions fluides pendant le déplacement d’une image clé Bézier continue sur la trajectoire ou le graphique de valeurs.

Interpolation Maintenir

L’interpolation Maintenir est disponible uniquement en tant que méthode d’interpolation temporelle. Utilisez cette méthode pour faire varier la valeur d’une propriété de calque dans le temps, mais sans transition progressive. Cette méthode est utile pour les effets de stroboscope ou lorsque vous souhaitez faire apparaître ou disparaître un calque brusquement.

Si vous appliquez l’interpolation temporelle Maintenir à toutes les images clés d’une propriété de calque, la valeur de la première image clé reste stable jusqu’à la seconde image clé, où la valeur change immédiatement. Dans le graphique de valeurs, le segment de graphique suivant une image clé Maintenir apparaît sous la forme d’une ligne droite horizontale.

Bien que l’interpolation Maintenir soit uniquement disponible en tant que méthode temporelle d’interpolation, les images clés de la trajectoire sont visibles mais ne sont pas reliées par des points de position de calque. Par exemple, si vous animez la propriété Position d’un calque à l’aide de l’interpolation Maintenir, le calque reste à la valeur de position de l’image clé précédente jusqu’à ce que le repère d’instant courant atteigne l’image clé suivante, à laquelle le calque disparaît et apparaît à la nouvelle position.

Vous pouvez très facilement figer l’image active pour toute la durée du calque en utilisant la commande Geler l’image. Pour figer une image, placez le repère d’instant sur l’image visée. Sélectionnez le calque si ce n’est déjà fait et choisissez Calque > Temps > Geler l’image. Le remappage temporel est activé et une image clé Maintenir est placée à la position du repère d’instant courant pour figer l’image.

Remarque :

si vous aviez précédemment activé le remappage temporel sur le calque, toutes les images clés créées sont supprimées dès l’application de la commande Geler l’image.

Vous pouvez utiliser l’interpolation Maintenir uniquement pour une interpolation temporelle d’éloignement (pour les images situées après une image clé). Si vous créez une image clé après une image clé de type interpolation Maintenir, la nouvelle image clé utilise l’interpolation Maintenir d’approche.  

Remarque :

Pour appliquer ou supprimer l’interpolation Maintenir en tant qu’interpolation d’éloignement pour une image clé, sélectionnez l’image clé dans le panneau Montage et choisissez Animation > Maintien des images clés.

Application et modification des méthodes d’interpolation des images clés

Vous pouvez appliquer et modifier la méthode d’interpolation de n’importe quelle image clé. Vous pouvez appliquer des modifications à l’aide de la boîte de dialogue Interpolation d’images clés ou directement sur une image clé en mode d’affichage de la bande de durée du calque, sur une trajectoire ou dans l’éditeur de graphiques. Vous pouvez également modifier le type d’interpolation qu’After Effects utilise par défaut pour les propriétés spatiales.

Pour en savoir plus sur l’utilisation des options Lissage de vitesse afin de lisser automatiquement la vitesse entre des images clés, voir Contrôle de la vitesse entre les images clés.

Remplacement de la méthode d’interpolation dans la boîte de dialogue Interpolation d’images clés

La boîte de dialogue Interpolation d’images clés fournit des options permettant de définir l’interpolation temporelle et spatiale, ainsi que les paramètres d’itinérance pour les propriétés spatiales uniquement.

  1. En mode d’affichage de la bande de durée du calque ou dans l’éditeur de graphiques, sélectionnez les images clés à modifier.
  2. Sélectionnez Animation > Interpolation d’images clés.
  3. Pour le champ Interpolation temporelle, sélectionnez l’une des options suivantes :

    Param. actuels

    Conserve les valeurs d’interpolation déjà appliquées aux images clés sélectionnées. Choisissez cette option si vous avez sélectionné plusieurs images ou des images clés ajustées manuellement, et que vous ne souhaitez pas modifier les paramètres existants.

    Linéaire, Bézier, Bézier continue, Bézier auto et Maintenir

    Applique une méthode d’interpolation temporelle avec les valeurs par défaut.

  4. Si vous avez sélectionné des images clés d’une propriété spatiale de calque, sélectionnez l’une des options suivantes pour le champ Interpolation spatiale :

    Param. actuels

    Conserve les paramètres d’interpolation déjà appliqués aux images clés sélectionnées.

    Linéaire, Bézier, Bézier continue et Bézier auto

    Applique une méthode d’interpolation spatiale avec les valeurs par défaut.

  5. Si vous avez sélectionné des images clés d’une propriété spatiale de calque, utilisez le menu Itinérant pour choisir la manière dont une image clé détermine sa position dans le temps, puis cliquez sur OK.

    Param. actuels

    Conserve la méthode actuellement appliquée de positionnement des images clés sélectionnées dans le temps.

    Déplacement dans le temps

    Lisse le taux de changement le long des images clés sélectionnées en faisant automatiquement varier leur position dans le temps, en fonction de la position des images clés venant immédiatement avant et après la sélection.

    Verrouillage temporel

    Maintient les images clés sélectionnées à leur position actuelle dans le temps. Elles restent en place jusqu’à ce que vous les déplaciez manuellement.

    Pour en savoir plus sur le lissage du taux de changement le long des images clés sélectionnées, voir Lissage de mouvement avec des images clés itinérantes.

Changement de la méthode d’interpolation à l’aide de l’outil Sélection en mode d’affichage des bandes de durée des calques

  1. A l’aide de l’outil Sélection, procédez de l’une des façons suivantes :
    • Si l’image clé utilise l’interpolation linéaire, maintenez la touche Ctrl (Windows) ou Commande (Mac OS) enfoncée et cliquez sur l’image clé pour basculer en mode Bézier auto .

    • Si l’image clé utilise l’interpolation Bézier, Bézier continue ou Bézier auto, maintenez la touche Ctrl (Windows) ou Commande (Mac OS) enfoncée et cliquez sur l’image clé pour basculer en mode Linéaire.

Changement de la méthode d’interpolation dans l’éditeur de graphiques

  • Cliquez sur l’image clé avec l’outil Conversion de sommet pour alterner entre l’interpolation linéaire et Bézier auto.
  • Sélectionnez une ou plusieurs images clés et cliquez sur le bouton Maintenir, Linéaire ou Bézier auto situé dans la partie inférieure de l’écran pour changer de méthode d’interpolation.
Boutons d’interpolation dans l’éditeur de graphiques : Convertir les images sélectionnées à mettre en attente, Convertir les images clés sélectionnées en images linéaires, Convertir les images clés sélectionnées en Bézier auto
Boutons d’interpolation dans l’éditeur de graphiques

A. Convertir les images sélectionnées à mettre en attente B. Convertir les images clés sélectionnées en images linéaires C. Convertir les images clés sélectionnées en Bézier auto 

Modification de poignées directrices Bézier dans l’éditeur de graphiques

Dans l’éditeur de graphiques, les images clés utilisant l’interpolation Bézier sont équipées de poignées directrices. Vous pouvez rétracter, étendre ou faire tourner les poignées directrices pour affiner la courbe d’interpolation Bézier dans un graphique de valeurs. Vous pouvez rétracter ou étendre les poignées de direction pour ajuster la courbe dans un graphique de vitesse.

Par défaut, lorsqu’une poignée de direction est rétractée ou étendue, la poignée opposée sur l’image clé est modifiée simultanément. La disjonction des poignées directrices permet aux deux poignées directrices d’une image clé de réagir de manière indépendante.

  • Pour rétracter ou étendre une poignée directrice, faites-la glisser vers le centre ou hors du centre de son image clé avec l’outil Sélection.
  • Pour disjoindre les poignées directrices, cliquez sur une image clé avec l’outil Sélection tout en maintenant la touche Alt (Windows) ou Option (Mac OS) enfoncée. Vous pouvez également faire glisser la souris en dehors d’une image clé tout en maintenant la touche Alt (Windows) ou Option (Mac OS) enfoncée pour tracer de nouvelles poignées, que des poignées soient déjà présentes ou non.
  • Pour manipuler simultanément les poignées directrices de deux images clés voisines, faites glisser le segment du graphique de valeurs entre ces deux images clés.
Extension d’une poignée de direction Bézier dans le graphique de vitesse
Extension d’une poignée de direction Bézier dans le graphique de vitesse

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne