À propos des images vectorielles et pixellisées

Les images vectorielles sont composées de lignes et de courbes définies par des objets mathématiques appelés vecteurs. Ceux-ci décrivent une image suivant ses caractéristiques géométriques. Les tracés de masque, les formes des calques de forme, ainsi que le texte des calques de texte sont des exemples d’images vectorielles contenues dans After Effects.

Les images pixellisées (parfois appelées images bitmap) utilisent une grille rectangulaire de couleurs (pixels) pour représenter les images. Chaque pixel possède un emplacement et une valeur de couleur spécifiques. Les métrages vidéo, les séquences d’image transférées depuis un film, et bien d’autres types d’images importés dans After Effects sont des images pixellisées.

Les images vectorielles permettent de conserver des contours nets sans perte de détail en cas de redimensionnement, car elles sont indépendantes de toute résolution. Cette caractéristique les rend particulièrement adaptées aux éléments visuels, comme les logos, qui seront utilisés en diverses tailles.

Exemple d’image vectorielle dans différentes échelles d’affichage
Exemple d’image vectorielle dans différentes échelles d’affichage

Chaque image pixellisée est composée d’un nombre fixe de pixels, ce qui la rend indépendante de toute résolution. Les images pixellisées peuvent perdre des détails et apparaître crénelées si elles sont agrandies.

Exemple d’image pixellisée dans différentes échelles d’affichage
Exemple d’image pixellisée dans différentes échelles d’affichage

Certaines images sont créées sous la forme d’images vectorielles dans d’autres applications, puis converties en pixels (pixellisées) une fois importées dans After Effects. Si un calque est continuellement pixellisé, After Effects reconvertit les images vectorielles en pixels lorsque le calque est redimensionné, en conservant des contours nets. Les images vectorielles provenant des fichiers SWF, PDF, EPS et Illustrator peuvent être pixellisées de façon continue.

Le didacticiel vidéo d’Aharon Rabinowitz intitulé « What are Raster and Vector Graphics? », extrait de la série Multimedia 101 du site Web Creative COW, présente de manière générale les images pixellisées et les images vectorielles.

À propos des tracés

Plusieurs fonctionnalités d’After Effects (y compris les masques, les formes, les tracés de peinture et les trajectoires) reposent sur le concept du tracé. Plusieurs outils et techniques de création et de modification de ces différents types de tracés se recoupent. Toutefois, chaque type de tracé possède des caractéristiques qui lui sont propres.

Un tracé est constitué de segments et de sommets. Les segments sont des lignes ou des courbes reliant des sommets. Les sommets délimitent le début et la fin d’un segment. Dans certaines applications Adobe, on parle de point d’ancrage et de point de tracé pour désigner un sommet.

Modifiez la forme d’un tracé en déplaçant ses sommets, les poignées de direction à l’extrémité des lignes de direction (ou tangentes) de chaque sommet, ou le segment de tracé lui-même.

Lorsqu’un tracé s’éloigne d’un sommet, l’angle et la longueur de la ligne directrice d’éloignement de ce sommet déterminent la forme du tracé. A mesure que le tracé se rapproche du sommet suivant, la forme de ce tracé est de moins en moins influencée par la ligne directrice d’éloignement du sommet précédent et dépend de plus en plus de la ligne directrice d’approche du sommet suivant.

Composants d’un tracé
Composants d’un tracé

A. Sommet sélectionné B. Sommet sélectionné C. Sommet désélectionné D. Segment de tracé incurvé E. Ligne de direction (tangente) F. Poignée de direction 

Les tracés peuvent comporter deux types de sommets : les points d’angle et les points d’inflexion. Au niveau d’un point d’inflexion, les segments du tracé sont reliés par une courbe lisse : les lignes directrices d’approche et d’éloignement sont situées sur la même ligne. Au niveau d’un point d’angle, un tracé change abruptement de direction : les lignes directrices d’approche et d’éloignement sont situées sur des lignes différentes. Lorsque vous dessinez un tracé, vous pouvez mélanger à votre guise les sommets et les points d’inflexion. Vous pouvez toujours transformer un point d’angle en point d’inflexion, et inversement.

Points d’un tracé
Points d’un tracé

A. Quatre sommets B. Quatre points d’inflexion C. Combinaison de sommets et de points d’inflexion 

Lorsque vous déplacez une ligne directrice d’un point d’inflexion, les courbes des deux côtés du point s’ajustent simultanément. En revanche, lorsque vous placez une ligne directrice sur un point d’angle, seule la courbe située du même côté du point que la ligne directrice est ajustée.

Réglage des lignes directrices d’un point d’inflexion (gauche) et d’un point d’angle (droite)
Réglage des lignes directrices d’un point d’inflexion (gauche) et d’un point d’angle (droite)

Un tracé peut être ouvert ou fermé. Un tracé ouvert a un point de début différent de son point de fin. Par exemple, une ligne droite est un tracé ouvert. Un tracé fermé est continu et n’a ni début ni fin. Par exemple, un cercle est un tracé fermé.

Vous pouvez dessiner des tracés de formes géométriques courantes (polygones, ellipses et étoiles) avec les outils de forme ou vous pouvez utiliser l’outil Plume pour dessiner un tracé arbitraire. Les tracés dessinés à l’aide de l’outil Plume sont des tracés de Bézier ou de RotoBézier manuels. La principale différence entre les tracés de RotoBézier et de Bézier manuels est telle que les lignes directrices sont calculées automatiquement pour les tracés de RotoBézier, ce qui simplifie et accélère leur dessin.

Lorsque vous utilisez les outils de forme (Rectangle, Rectangle arrondi, Ellipse, Polygone ou Étoile) pour dessiner un tracé de forme sur un calque de forme, vous pouvez créer deux types de tracés : un tracé paramétrique ou une courbe de Bézier (voir À propos des formes et des calques de forme).

Vous pouvez lier des tracés de masque, de traits de peinture et de courbes de Bézier à l’aide d’expressions. Vous pouvez également réaliser des copies et des collages de tracés de masque, de traits de peinture, de courbes de Bézier, de trajectoires et de tracés entre les applications Adobe Illustrator, Photoshop et Adobe Fireworks. (voir Création de formes et de masques).

Pour les tracés de forme, vous pouvez utiliser l’opération Fusionner les tracés (similaire aux effets Pathfinder d’Adobe Illustrator) pour combiner plusieurs tracés en un seul (voir la section Options de fusion des tracés).

Si vous souhaitez qu’un texte ou effet épouse un tracé, il doit s’agir d’un tracé de masque.

Un tracé n’a pas d’aspect visuel à la sortie rendue. Il s’agit essentiellement d’un ensemble d’informations relatives au placement ou à la modification d’autres éléments visuels. Pour rendre un tracé visible, appliquez-lui un trait. Dans le cas d’un tracé de masque, vous pouvez appliquer l’effet Trait. Par défaut, un tracé de calque de forme est créé avec un groupe (attribut) de propriétés de trait après le groupe de propriétés de tracé dans le panneau Montage.

Une couleur ou un dégradé appliqué à la zone contenue dans les limites d’un tracé est appelé remplissage (ou fond).

Remarque :

pour préciser la taille des poignées directrices Bézier et des sommets des masques et formes, choisissez Edition > Préférences > Général (Windows) ou After Effects > Préférences > Général (Mac OS), puis modifiez la valeur Taille de point du tracé.

À propos des formes et des calques de forme

Les calques de forme contiennent des images vectorielles appelées formes. Par défaut, une forme est constituée d’un tracé, d’un contour et d’un fond. Voir À propos des tracés et Contours et fonds pour les formes.

Pour créer des calques de forme, utilisez le panneau Composition et les outils de forme ou l’outil Plume (voir Création de formes et de masques).

Il existe deux sortes de tracés de forme : les tracés paramétriques et les courbes de Bézier. Les tracés paramétriques sont définis de façon numérique par des propriétés que vous pouvez modifier et animer une fois le dessin terminé, dans le panneau Montage. Les courbes de Bézier sont définies par un ensemble de sommets (points de tracés) et de segments modifiables dans le panneau Composition. Vous pouvez utiliser les courbes de Bézier de la même manière que les tracés de masque. Tous les tracés de masque sont des courbes de Bézier.

Vous pouvez modifier un tracé de forme en lui appliquant des opérations de tracé, telles que Tremblement des tracés et Contraction et dilatation. Pour appliquer un contour à un tracé ou remplir la zone définie par un tracé avec une couleur, utilisez les opérations de peinture (voir Attributs de forme, opérations de peinture et opérations de tracé pour les calques de forme).

Les tracés de forme, opérations de peinture et opérations de tracé destinés aux formes sont appelés attributs de forme. Pour ajouter des attributs de forme, utilisez le menu Ajouter du panneau Outils ou du panneau Montage. Chaque attribut de forme est représenté par un groupe de propriétés dans le panneau Montage avec les propriétés que vous pouvez animer, comme pour les autres propriétés de calque (voir la section À propos de l’animation, des images clés et des expressions).

Le codage des bits de couleur d’un calque de forme est identique à celui du projet dans son ensemble : 8, 16 ou 32 bpc. Reportez-vous à la section Codage des couleurs et couleur HDR (High Dynamic Range).

Les calques de forme ne sont pas basés sur des métrages. Les calques non basés sur des métrages sont parfois appelés calques synthétiques. Les calques de texte sont également des calques synthétiques et sont eux aussi composés d’images vectorielles. C’est pourquoi la plupart des règles et instructions qui s’appliquent aux calques de texte s’appliquent aussi aux calques de forme. Par exemple, il est impossible d’ouvrir un calque de forme ou un calque de texte dans un panneau Calque.

Remarque :

Vous pouvez enregistrer vos formes préférées en tant qu’animations prédéfinies (voir la section Enregistrement d’une animation prédéfinie).

Ressources en ligne sur les calques de forme

Pour visionner un didacticiel vidéo sur la création de calques de forme à partir de calques vectoriels, rendez-vous sur la page des didacticiels de formation.

Trish et Chris Meyer abordent le concept des calques de forme dans un extrait (PDF) du chapitre « Shape Layers » (Calques de forme) de leur livre Creating Motion Graphics with After Effects (5th Edition)

Chris Zwar a développé une animation qui crée un réticule à l’aide d’un calque de forme unique, assorti d’un large éventail de propriétés personnalisées qui facilitent sensiblement le contrôle et la modification de l’animation du réticule. Cette animation est disponible sur son site Web.

Groupes et ordre de rendu des formes et attributs de formes

Bien qu’une forme soit constituée, par défaut, d’un seul tracé, d’un seul contour et d’un seul fond organisés en haut en bas dans le panneau Montage, la puissance et la flexibilité des calques de forme proviennent essentiellement de votre habileté à ajouter et à réorganiser les attributs de forme afin de créer des formes composées plus complexes.

Vous pouvez associer les formes ou les attributs de forme présents au même niveau de regroupement dans un calque de forme.

Un groupe est un ensemble d’attributs de forme : tracés, fonds, contours, opérations de tracé et autres groupes. Chaque groupe possède son propre mode de fusion et son propre jeu de propriétés de transformation. En assemblant les formes en groupes, vous pouvez travailler simultanément sur plusieurs formes. Par exemple, vous pouvez toutes les mettre à la même échelle ou leur appliquer le même contour. En outre, vous pouvez placer des formes individuelles ou des attributs de formes individuelles dans un groupe pour isoler les transformations. Par exemple, vous pouvez mettre à l’échelle un tracé mais pas son contour en plaçant le tracé dans un groupe individuel.

Lorsque vous ajoutez un attribut de forme à l’aide du menu Ajouter du panneau Outils ou du panneau Montage, il est ajouté au groupe sélectionné. Vous pouvez déplacer les groupes et les attributs afin de les réorganiser dans le panneau Montage. En réorganisant et en associant les formes et les attributs de forme, vous pouvez influencer leur ordre de rendu par rapport aux autres formes et attributs de forme.

Groupes et ordre de rendu des formes et attributs de formes
A. Deux formes dans un groupe B. Deux tracés dans une forme complexe C. Cercle avec application de tremblements de tracé D. Un contour appliqué à tous les tracés qui le précèdent E. Tracé d’une étoile dans un groupe individuel F. Un fond appliqué à tous les tracés qui le précèdent G. Un tracé muni de deux contours 

Ordre de rendu des formes situées sur un calque de forme

Les règles de rendu d’un calque de forme sont similaires à celles du rendu d’une composition contenant des compositions imbriquées :

  • Dans un groupe, la forme au bas de l’ordre d’empilement du panneau Montage est rendue en premier.

  • Toutes les opérations de tracé d’un groupe sont réalisées avant les opérations de peinture. Ceci signifie, par exemple, que le contour suit les distorsions du tracé appliquées par l’opération Tremblement des tracés. Dans un groupe, les opérations de tracé sont effectuées de haut en bas (voir Altération des formes à l’aide d’opérations de tracé).

  • Les opérations de peinture d’un groupe sont effectuées de bas en haut dans l’ordre d’empilement du panneau Montage. Ceci signifie, par exemple, qu’un contour est rendu au-dessus (devant) d’un contour qui apparaît après lui dans le panneau Montage. Pour remplacer ce comportement par défaut pour un fond ou un contour spécifique, choisissez Au-dessus du précédent dans le même groupe comme propriété composite du fond ou du contour dans le panneau Montage (voir Contours et fonds pour les formes.)

Les opérations de tracé et de peinture s’appliquent à tous les tracés du même groupe situés au-dessus.

Propriétés de transformation des groupes de formes et des tracés de forme

Chaque groupe possède son propre groupe de propriétés Transformer. Ce groupe de propriétés Transformer est représenté dans le panneau Montage par un groupe de propriétés appelé Transformer : [nom du groupe] et dans le panneau Composition par une zone en pointillé munie de poignées. Vous pouvez placer un tracé dans un groupe individuel et transformer uniquement ce tracé à l’aide de son nouveau groupe de propriétés Transformer.

L’ajout d’un groupe de propriétés Transformer supplémentaire pour un tracé unique peut être utile, par exemple, pour créer un mouvement complexe, tel qu’une rotation autour d’un point d’ancrage subissant également un mouvement de révolution le long d’une orbite. Les transformations appliquées à un groupe influencent toutes les formes de ce groupe ; le comportement est identique à celui du calque parent (voir la section Calques parents et enfants).

Chaque tracé de forme est également doté de propriétés intrinsèques qui influencent la position et la forme du tracé. Pour les tracés de forme paramétrique, ces propriétés (comme la position et la taille) sont des paramètres visibles dans le panneau Montage. Pour les courbes de Bézier, ces propriétés sont définies pour chaque sommet, mais sont contenues dans la propriété Tracé. Lorsque vous modifiez une courbe de Bézier au moyen d’un cadre de sélection à transformation libre, vous modifiez ces propriétés intrinsèques pour les sommets qui constituent le tracé (voir À propos des formes et des calques de forme).

Association de formes ou d’attributs de forme

  • Sélectionnez un(e) ou plusieurs formes ou attributs, puis Utilisez l’une des méthodes suivantes :
    • Choisissez Calque > Associer les formes.
    • Appuyez sur Ctrl + G (Windows) ou sur Commande + G (Mac OS).

Lorsque vous associez des formes, le point d’ancrage du groupe est placé au centre du cadre de sélection du groupe.

Dissociation de formes ou d’attributs de forme

  • Sélectionnez un seul groupe, puis Utilisez l’une des méthodes suivantes :
    • Choisissez Calque > Dissocier les formes.
    • Appuyez sur les touches Ctrl + Maj + G (Windows) ou Commande + Maj + G (Mac OS).

Création d’un groupe de formes vide

  • Choisissez Groupe (vide) dans le menu Ajouter du panneau Outils ou Montage.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne