Vous pouvez améliorer les performances en optimisant votre système informatique, After Effects, votre projet et votre flux de production. Certaines des suggestions présentées ici améliorent les performances non pas en augmentant la vitesse de rendu, mais en réduisant la durée des autres opérations (l’ouverture d’un projet, par exemple).

Remarque :

La meilleure façon d’optimiser les performances globales consiste encore à planifier votre travail, à exécuter des tests préliminaires de votre flux de production et de votre structure de sortie, ainsi qu’à confirmer que le produit que vous livrez est conforme aux attentes et aux exigences de votre client (voir Planification de votre travail).

Pour visionner une série de didacticiels vidéo gratuits sur l’amélioration des performances avec After Effects et Adobe Premiere Pro, reportez-vous au site Web de video2Brain.

Pour obtenir des ressources supplémentaires sur l’optimisation des systèmes informatiques et d’After Effects, consultez cet article sur le site Web d’Adobe.

Sur le site Web After Effects Scripts, Lloyd Alvarez propose le script BG Renderer qui vous permet d’effectuer le rendu et l’exportation de compositions en arrière-plan, tout en continuant à travailler dans After Effects.

Optimisation des performances avant le lancement d’After Effects

  • Assurez-vous que la dernière version en date d’After Effects est installée, y compris les mises à jour disponibles. Pour rechercher et installer des mises à jour, sélectionnez Aide > Mises à jour.
  • Assurez-vous d’avoir installé les versions les plus récentes des pilotes et modules externes, plus particulièrement des pilotes de carte vidéo. Pour télécharger les mises à jour des pilotes et modules externes, rendez-vous sur le site Web de leurs éditeurs respectifs.
  • Assurez-vous que le système dispose d’une mémoire vive suffisante. Des performances optimales sont atteintes avec des systèmes informatiques disposant d’au moins 2 Go de RAM installée par cœur de processeur. Consultez la documentation accompagnant votre système d’exploitation et votre ordinateur pour connaître la quantité de mémoire vive installée et savoir comment en installer davantage.
  • Fermez les applications dont vous n’avez pas besoin dans l’immédiat. Si vous exécutez des applications autres que celles avec lesquelles After Effects partage un pool de mémoire et que vous n’allouez pas suffisamment de mémoire aux autres applications, les performances risquent d’être considérablement amoindries lorsque le système d’exploitation échange la mémoire vive sur le disque (voir Utilisation de la mémoire (RAM) dans After Effects 64 bits).

    Pour plus d’informations sur l’amélioration des performances en arrêtant les logiciels inutiles dans le cadre de votre travail, visionnez cette vidéo sur le site Web de video2Brain.

  • Arrêtez ou interrompez les opérations gourmandes en ressources dans les autres applications, telles que les prévisualisations vidéo dans Adobe Bridge.
  • Assurez-vous que votre système est équipé d’une carte graphique compatible OpenGL 2.0 (ou version supérieure). Bien qu’After Effects puisse fonctionner sans OpenGL, ce dernier accélère différents types de rendu, y compris le rendu à l’écran pour les prévisualisations. Voir Rendu avec OpenGL.
  • Dans la mesure du possible, conservez les fichiers de métrage sources de votre projet sur un disque local rapide. Si vos fichiers de métrage sources sont stockés sur un disque lent (ou accessibles par une connexion réseau ralentie), vos performances seront médiocres. Il est recommandé d’utiliser des disques locaux rapides pour les fichiers de métrage source et la sortie du rendu. Pour plus d’informations, visionnez cette vidéo sur le site Web de video2Brain.
  • L’idéal est de disposer d’un disque (ou d’une unité multidisque) rapide distinct pour affecter le dossier de cache disque. En raison de leur vitesse, les unités SSD sont, elles aussi, parfaitement adaptées à cette fonction.

Amélioration des performances en optimisant les paramètres de mémoire, de cache et de multitraitement

  • Allouez suffisamment de mémoire aux autres applications.
  • Activez la mise en mémoire cache des images sur le disque pour les prévisualisations en sélectionnant la préférence Activer le cache disque. Dans After Effects, affectez autant d’espace que possible au dossier Cache disque (sur un disque rapide distinct) afin de bénéficier de performances optimales (voir Cache disque).

Sur le site Web d’Adobe, Todd Kopriva fournit des informations sur les paramètres optimaux de mémoire et de processeur.

Pour plus de détails, voir Préférences de mémoire et de multitraitement.

Amélioration des performances à l’aide du Cache performances globales | CC, CS6

Importez des projets d’Adobe After Effects 5.5 ou versions antérieures dans After Effects CS afin de tirer parti du Cache performances globales. Pour de plus amples informations, reportez-vous à la section Cache disque.

Le cache persistant de disque améliore les performances en conservant les images stockées dans le cache disque d’une session à l’autre, ce qui se traduit par un rendu plus rapide lorsque vous travaillez sur un ou plusieurs autres projets susceptibles d’utiliser les mêmes images en cache.

Optimisation des performances en simplifiant le projet

Vous pouvez éviter qu’After Effects utilise de la mémoire et d’autres ressources pour le traitement d’éléments que vous ne manipulez pas actuellement en simplifiant et en divisant votre projet. Vous pouvez, de même, optimiser les performances globales de manière significative en déterminant quand After Effects effectue certains traitements. Vous pouvez, par exemple, éviter de répéter une action qui n’est requise qu’une seule fois, ou différer une action à un moment plus opportun.

  • Supprimez les éléments inutilisés du projet. Voir Suppression d’éléments d’un projet.
  • Divisez les projets complexes en projets plus simples et reconstituez-les avant le rendu du film finalisé. Pour recombiner les projets, importez-les tous dans un seul projet. Voir Importation d’un projet After Effects.
  • Avant d’effectuer le rendu, placez tous les fichiers sources du métrage sur un disque local rapide (pas sur celui sur lequel vous effectuez le rendu et vers lequel vous exportez des documents). L’option Rassemblement de fichiers vous permet d’effectuer facilement cette opération. Voir Rassemblement des fichiers dans un emplacement unique.
  • Effectuez le prérendu des compositions imbriquées. Effectuez le rendu d’une composition finalisée sous forme de film de sorte qu’After Effects n’effectue pas de rendu chaque fois que vous affichez la composition. Voir Prérendu d’une composition imbriquée.
  • Quand vous n’utilisez pas directement un élément source, remplacez-le par une doublure d’image fixe ou à faible résolution. Voir Pseudo-éléments et doublures.
  • Abaissez la résolution de la composition. Voir Résolution.
  • Isolez le calque en cours de manipulation à l’aide de l’option Solo. Voir Isolation d’un calque.

Pour plus d’informations sur l’amélioration des performances en isolant les éléments qui font l’objet de votre travail, visionnez cette vidéo sur le site Web de video2Brain.

Optimisation des performances en modifiant la sortie à l’écran

Vous pouvez optimiser les performances de nombreuses façons sans affecter la manière dont After Effects traite les données du projet, mais en affectant uniquement la manière dont la sortie s’affiche à l’écran tout au long de votre travail. Bien qu’il soit souvent utile de visualiser certains éléments et informations en cours de travail, After Effects utilise de la mémoire et des ressources processeur pour mettre à jour ces informations. Choisissez donc avec soin les éléments à afficher lors de votre travail. Vous souhaiterez visualiser différents aspects de votre projet aux différentes étapes du flux de production. Les suggestions suivantes, dans différentes combinaisons, peuvent s’avérer utiles.

  • Désactivez la gestion des couleurs d’affichage et la simulation de la sortie si cela n’est pas nécessaire. Voir Simulation de l’aspect des couleurs sur un autre périphérique de sortie. La vitesse et la qualité de la gestion des couleurs pour les prévisualisations sont contrôlées par les préférences Qualité du visualiseur. Voir Préférences de qualité du visualiseur.
  • Activez l’accélération matérielle des prévisualisations qui utilise GPU pour faciliter la prévisualisation à l’écran. Choisissez Edition > Préférences > Affichage (Windows) ou After Effects > Préférences > Affichage (Mac OS) et sélectionnez Accélération matérielle pour les panneaux Composition, Calque et Métrage.
  • Fermez les panneaux superflus. After Effects utilise de la mémoire et des ressources processeur pour mettre à jour les panneaux ouverts, ce qui peut ralentir les manipulations effectuées dans un autre panneau.
  • Créez une zone ciblée. Si vous n’utilisez qu’une petite partie de la composition, limitez le rendu à l’écran à cette portion de la composition lors des prévisualisations. Voir Zone ciblée.
  • Désélectionnez l’option Afficher les indicateurs du cache dans le menu du panneau Montage afin d’empêcher After Effects d’afficher des barres vertes et bleues dans l’échelle de temps pour indiquer les images mises en cache. Voir Caches : cache de RAM, cache de disque et cache de support.
  • Désélectionnez l’option Afficher l’avancement du rendu dans le panneau Info et organigramme pour empêcher l’affichage à l’écran des détails de chaque opération de rendu pour chaque image. Voir Préférences d’affichage.
  • Masquez l’option Détails du rendu en cours dans le panneau File d’attente de rendu en cliquant sur le triangle situé en regard de cette même option. Voir Informations relatives aux opérations de rendu en cours.
  • Appuyez sur la touche Verr. maj pour empêcher After Effects d’actualiser les panneaux Métrage, Calque ou Composition. Lorsque vous apportez une modification, au lieu de l’afficher, After Effects ajoute une barre rouge complétée d’un texte de rappel au bas du panneau. After Effects continue d’actualiser les options de panneaux telles que les trajectoires, les points d’ancrage et les contours de masque, au fur et à mesure que vous les déplacez. Appuyez de nouveau sur la touche Verr. maj pour rétablir les mises à jour de panneau et l’affichage de toutes les modifications apportées.

Remarque :

appuyez sur Verr. maj pour suspendre les mises à jour (désactive l’actualisation) de prévisualisations dans les visualiseurs pendant le rendu de la sortie finale, même si aucune barre rouge de rappel ne s’affiche.

  • Diminuez la qualité d’affichage d’un calque sur Ebauche. Voir la section Qualité d’image d’un calque et positionnement des sous-pixels.
  • Sélectionnez Ebauche 3D dans le menu du panneau Montage, qui désactive l’ensemble des lumières et ombres appliquées aux Calques 3D. Cette opération désactive également le flou de profondeur de champ pour un appareil photo.
  • Utilisez le mode Ébauche rapide pendant la mise en forme et la prévisualisation d’une composition 3D avec lancer de rayon en sélectionnant une option autre que « Désactivé » à partir du bouton Prévisualisations rapides.
  • Désélectionnez l’option Mise à jour automatique dans le menu du panneau Montage pour empêcher After Effects de mettre à jour les compositions de manière dynamique. Voir Modes de prévisualisation et préférences de prévisualisations rapides.
  • Affichez les signaux audio dans le panneau Montage uniquement si nécessaire. Voir Affichage des propriétés et des groupes dans le panneau Montage (raccourcis clavier).
  • Désactivez la correction du format des pixels en cliquant sur le bouton Activer/désactiver la correction du format des pixels au bas du panneau Composition, Calque ou Métrage. La vitesse et la qualité de la correction du format des pixels et d’autresmises à l’échelle des prévisualisationssont contrôlées par les préférences Qualité du visualiseur. Voir Préférences de qualité du visualiseur.
  • Désélectionnez l’option Miroir sur le moniteur de l’ordinateur lors de la prévisualisation d’une vidéo sur un moniteur vidéo externe (voir Prévisualisation sur un moniteur vidéo externe).
  • Masquez les contrôles de calque, tels que les masques, les axes de référence 3D et les poignées de calque. Voir Affichage ou masquage des options du calque dans le panneau Composition.
  • Diminuez l’agrandissement d’une composition. Lorsqu’After Effects affiche les panneaux Composition, Calque et Métrage selon un agrandissement supérieur à 100 %, la vitesse de rafraîchissement de l’écran diminue (voir Zoom sur une image pour prévisualisation).
  • Définissez la valeur Résolution/Sous-échantillonnage de la composition sur Auto dans le panneau Composition, ce qui empêche un rendu inutile des rangées ou des colonnes de pixels qui ne sont pas dessinées à l’écran à des faibles niveaux de zoom. Voir Résolution.

Optimisation des performances lors de l’utilisation d’effets

Certains effets, tels que les flous et les déformations, nécessitent une grande quantité de mémoire et de ressources processeur. Vous pouvez optimiser les performances de manière significative en choisissant avec soin comment appliquer ces effets et à quel moment.

  • Appliquez en dernier les effets nécessitant beaucoup de mémoire et de ressources processeur. Animez les calques et réalisez les tâches nécessitant des prévisualisations en temps réel avant d’appliquer les effets gourmands en mémoire et ressources processeur (par exemple, les lueurs et les effets de flou) pour éviter un ralentissement.
  • Désactivez temporairement les effets afin d’accélérer la prévisualisation. Voir Suppression ou désactivation d’effets et d’animations prédéfinies.
  • Limitez le nombre de particules générées par les effets Particules. Voir Effets de simulation.
  • Plutôt qu’appliquer le même effet avec les mêmes paramètres à plusieurs calques, mieux vaut appliquer l’effet à un calque d’effets. Un effet appliqué à un calque d’effets est traité une seule fois, sur le composite de tous les calques situés en dessous (voir Création d’un calque d’effets).

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne