A propos des compositions

Une composition est la structure d’un film. Chaque composition dispose de son propre panneau Montage. Une composition type comprend plusieurs calques qui représentent des composants tels que métrages audio ou vidéo, texte animé et graphiques vectoriels, images fixes et lumières. Pour ajouter un métrage à une composition, vous devez créer un calque dont le métrage est la source. Vous pouvez ensuite organiser, dans l’espace et le temps, les calques de la composition et les combiner à l’aide des fonctions de transparence qui permettent de définir les éléments des calques sous-jacents visibles à travers les calques superposés (voir les sections Calques et propriétés et Transparence et montage).

Une composition dans After Effects est semblable à un clip vidéo dans Flash Professional ou une séquence dans Premiere Pro.

Le rendu d’une composition produit les images de la sortie finale d’un film, lequel est encodé et exporté dans une multitude de formats (voir Notions de base relatives au rendu et à l’exportation.)

Les projets les plus simples sont constitués d’une composition unique, tandis que les projets plus complexes font appel à des centaines de compositions qui permettent de disposer de nombreux métrages et effets.

Dans l’interface utilisateur d’After Effects, la forme abrégée comp est parfois utilisée à la place de composition.

Dans le panneau Projet, chaque composition est associée à une entrée. Cliquez deux fois sur l’entrée d’une composition dans le panneau Projet pour l’ouvrir dans son propre panneau Montage. Pour sélectionner une composition dans le panneau Projet, cliquez sur le panneau Composition ou Montage de la composition avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Mac OS), puis choisissez Afficher la composition dans le panneau projet, à partir du menu contextuel.

Depuis le panneau Composition, vous pouvez consulter l’aperçu d’une composition et animer son contenu manuellement. Le panneau Composition comprend la composition et une zone de tableau de montage située à l’extérieur du cadre. Cette caractéristique permet de déplacer des calques dans le cadre de la composition et hors du cadre. Les parties hors champ des calques (c’est à dire situées hors de la composition) s’affichent sous forme de silhouettes rectangulaires. Seule la zone située à l’intérieur de la composition est visible lors de l’affichage du rendu des prévisualisations et du résultat final.

Dans After Effects, le cadre de composition affiché dans le panneau Composition est semblable à l’espace d’affichage dans Flash Professional.

Dans le cas d’un projet complexe, il est parfois préférable d’imbriquer les compositions (les placer les unes à l’intérieur des autres) pour organiser le projet. Quel que soit le nombre de calques dont vous disposez, vous pouvez créer une composition en précomposant des calques. Après avoir modifié certains calques de la composition, vous pouvez les précomposer, puis effectuer un prérendu de la précomposition ; le rendu du film remplace alors la précomposition (voir Précomposition, imbrication et prérendu).

Vous pouvez parcourir la hiérarchie des compositions imbriquées à l’aide du navigateur de compositions et du mini-organigramme des compositions (voir Ouverture et navigation dans les compositions imbriquées).

Utilisez le panneau Organigramme pour afficher la structure d’un réseau de compositions ou d’une composition complexe.

Bouton Montage

 Cliquez sur ce bouton, au bas du panneau Composition, pour activer le panneau Montage de la composition en cours.

Remarque :

Appuyez sur la touche \ (barre oblique inverse) pour permuter entre les panneaux Composition et Montage de la composition active.

Bouton Composition

 Cliquez sur ce bouton, dans le coin supérieur droit du panneau Montage, pour activer le panneau Composition de la composition en cours.

Bouton Organigramme

 Cliquez sur ce bouton, au bas du panneau Composition, pour activer le panneau Organigramme de la composition en cours.

Didacticiels de formation

Reportez-vous aux didacticiels suivants pour approfondir vos connaissances sur les compositions :

Création d’une composition

Vous pouvez modifier les paramètres de la composition à tout moment. Cependant, il est préférable de spécifier les réglages tels que le format de l’image (rapport H/L) et les dimensions de l’image lors de la création de la composition, lorsque vous avez déjà une idée du résultat final. Si vous les modifiez à une étape ultérieure du workflow, vous risquez d’affecter le résultat final car After Effects effectue certains calculs à partir de ces réglages de composition.

Remarque :

vous pouvez passer outre certains réglages de composition lors du rendu final. Vous pouvez par exemple utiliser des dimensions d’image différentes pour un même film. Pour plus d’informations, voir Paramètres de rendu et Modules de sortie et paramètres des modules de sortie.

Si vous créez une composition sans modifier les réglages de la boîte de dialogue Paramètres de composition, la nouvelle composition utilise les derniers réglages définis.

Remarque :

Les nouvelles compositions n’héritent cependant pas des paramètres Préserver la cadence (compositions imbriquées ou en file d’attente de rendu) et Préserver la résolution (compositions imbriquées).

Sur son site Web redefinery, Jeff Almasol propose un script qui crée et enregistre un projet pour chacune des compositions sélectionnées dans le projet actuel. Si un dossier est sélectionné dans le panneau Projet lorsque vous créez une composition, la nouvelle composition est placée dans le dossier sélectionné.

Création d’une composition et définition manuelle des paramètres de composition

  • Sélectionnez Composition > Nouvelle composition ou appuyez sur les touches Ctrl + N (Windows) ou Commande + N (Mac OS).

Création d’une composition à partir d’un métrage unique

  • Faites glisser le métrage vers le bouton Créer une nouvelle composition au bas du panneau Projet ou choisissez Fichier > Nouvelle comp. à partir de la sélection.

    Les paramètres de composition, notamment les dimensions de l’image (largeur et hauteur) et le format des pixels, sont automatiquement définis en fonction des caractéristiques du métrage.

Création d’une composition unique à partir de plusieurs métrages

  1. Sélectionnez les métrages dans le panneau Projet.
  2. Faites glisser les éléments de métrage sélectionnés vers le bouton Créer une nouvelle composition situé au bas du panneau Projet, ou choisissez Fichier > Nouvelle composition à partir de la sélection.
  3. Sélectionnez l’option Composition unique et d’autres réglages dans la boîte de dialogue Création d’une nouvelle composition à partir de la sélection :

    Utiliser dimensions de

    Sélectionnez le métrage à partir duquel les réglages de la nouvelle composition sont définis, notamment les dimensions de l’image (largeur et hauteur) et le format des pixels.

    Durée des éléments fixes

    Durée des images fixes ajoutées.

    Ajouter à la file d’attente de rendu

    Pour placer la nouvelle composition dans la file d’attente de rendu.

    Calques de séquence, Recouvrement, Durée et Transition

    Disposez les calques sous forme de séquence, faites-les éventuellement se chevaucher dans le temps, définissez la durée des transitions et sélectionnez un type de transition.

Pour créer plusieurs compositions à partir de plusieurs métrages

  1. Sélectionnez les métrages dans le panneau Projet.
  2. Faites glisser les éléments de métrage sélectionnés vers le bouton Créer une nouvelle composition situé au bas du panneau Projet, ou choisissez Fichier > Nouvelle composition à partir de la sélection.
  3. Sélectionnez Plusieurs compositions et d’autres réglages dans la boîte de dialogue Création d’une nouvelle composition à partir de la sélection :

    Durée des éléments fixes

    Durée des compositions créées à partir d’images fixes.

    Ajouter à la file d’attente de rendu

    Pour placer les nouvelles compositions dans la file d’attente de rendu.

Duplication d’une composition

  1. Sélectionnez la composition dans le panneau Projet.
  2. Sélectionnez Edition > Dupliquer ou appuyez sur les touches Ctrl + D (Windows) ou Commande + D (Mac OS).

Panneau Montage

Chaque composition dispose de son propre panneau Montage. Le panneau Montage permet d’effectuer différentes opérations : animation des propriétés de calque, organisation des calques dans le temps et définition des modes de fusion. Dans l’empilement des calques du panneau Montage, le rendu des calques situés en bas se fait en premier, et, dans le cas de calques d’images 2D, ces calques sont les plus éloignés dans le panneau Composition et le composite final.

Remarque :

Pour passer au panneau Montage suivant, appuyez sur les touches Alt + Maj + point (.) (Windows) ou Option + Maj + point (.) (Mac OS). Pour passer au panneau Montage précédent, appuyez sur les touches Alt + Maj + virgule (,) (Windows) ou Option + Maj + virgule (,) (Mac OS).

Le repère d’instant courant (ligne rouge verticale du graphique temporel) indique l’instant présent de la composition. L’instant courant d’une composition apparaît également dans la zone d’affichage d’instant courant, située dans l’angle supérieur gauche du panneau Montage. Pour plus d’informations sur le déplacement du repère d’instant courant, voir Déplacement du repère d’instant courant.

A gauche du panneau Montage se trouvent des colonnes de commandes pour les calques. A droite du panneau Montage (graphique temporel) se trouvent une échelle de temps, des repères, des images clés, des expressions, des bandes de durée pour les calques (en mode d’affichage des bandes de durée) et l’éditeur de graphiques (en mode Editeur de graphiques).

Remarque :

Appuyez sur la touche \ (barre oblique inverse) pour permuter entre les panneaux Composition et Montage de la composition active.

Paramètres de composition

Vous pouvez saisir manuellement des paramètres de composition ou bien utiliser les paramètres de composition prédéfinis pour définir automatiquement les dimensions de l’image (largeur et hauteur), le format des pixels et la cadence des formats de sortie les plus courants. Vous pouvez également créer et enregistrer vos propres paramètres de composition prédéfinis pour les utiliser plus tard. Les paramètres de composition Résolution, Code temporel initial (ou 1ère image), Durée et Avancé ne peuvent pas être enregistrés avec les paramètres de composition prédéfinis.

Remarque :

la durée d’une composition ne peut dépasser trois heures. Vous pouvez utiliser des métrages de plus de trois heures, mais ils ne s’affichent pas correctement au-delà de trois heures. Les dimensions maximales d’une composition sont de 30 000 x 30 000 pixels. Une image de 30 000 x 30 000 pixels en mode 8 bpc occupe environ 3,5 Go ; selon votre système d’exploitation et la quantité de mémoire vive disponible, la taille maximale de votre composition peut être inférieure.

Utilisation des paramètres de composition

  • Pour ouvrir la boîte de dialogue Paramètres de composition, Utilisez l’une des méthodes suivantes :

    • Sélectionnez une composition dans le panneau Projet ou activez le panneau Montage ou Composition d’une composition, puis sélectionnez Composition > Paramètres de composition ou appuyez sur les touches Ctrl + K (Windows) ou Commande + K (Mac OS).

    • Cliquez sur une composition dans le panneau Projet ou le panneau Composition (mais pas sur un calque) avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Mac OS), puis choisissez Paramètres de composition dans le menu contextuel.

  • Pour enregistrer un paramètre prédéfini personnalisé d’une composition, définissez les options Largeur, Hauteur, Format des pixels et Images/s dans la boîte de dialogue Paramètres de composition, puis cliquez sur le bouton Enregistrer .

  • Pour supprimer un paramètre prédéfini d’une composition, choisissez-le dans le menu Paramètre prédéfini de la boîte de dialogue Paramètres de composition, puis cliquez sur le bouton Supprimer .

  • Pour rétablir les paramètres prédéfinis par défaut d’une composition, cliquez sur le bouton Supprimer ou Enregistrer dans la boîte de dialogue Paramètres de composition tout en maintenant la touche Alt (Windows) ou Option (Mac OS) enfoncée.

Remarque :

vous ne pouvez pas déplacer les paramètres de composition prédéfinis personnalisés d’un système à un autre, car ils sont incorporés dans le fichier de préférences.

  • Pour mettre à l’échelle l’ensemble d’une composition, choisissez Fichier > Scripts > Scale Composition.jsx.

Remarque :

Assurez-vous que tous les calques sont déverrouillés dans la composition sélectionnée, sinon le script va échouer.

Jeff Almasol propose, sur son site Web redefinery, un script pour définir la cadence d’images ainsi que la durée de la composition actuelle et de toutes les compositions qui y sont imbriquées.

Sur son site Web, Christopher Green propose un script (Selected_Comps_Changer.jsx) qui permet de modifier les paramètres des compositions sélectionnées dans le panneau Projet.

Paramètres de composition simples

Code temporel initial ou 1ère image

Code temporel ou numéro d’image attribué à la première image d’une composition. Cette valeur n’a aucun effet sur le rendu. Elle indique simplement où commence le décompte.

Couleur d’arrière-plan

Utilisez l’échantillon de couleur ou la pipette pour choisir la couleur d’arrière-plan de la composition (voir la section Sélection d’une couleur ou modification d’un dégradé).

Remarque : Lorsque vous imbriquez une composition dans une autre, la couleur d’arrière-plan de la composition réceptrice est conservée, alors que celle de la composition imbriquée devient transparente. Pour conserver la couleur d’arrière-plan de la composition imbriquée, créez un nouveau calque de couleur unie qui fera office de calque d’arrière-plan dans cette composition.

Pour plus de détails sur les paramètres de composition de base spécifiques non répertoriés ici, reportez-vous aux sections concernées :

Paramètres de composition avancés

Ancrage

Cliquez sur une flèche pour ancrer les calques dans un angle ou sur un bord de la composition pendant son redimensionnement.

Préserver la résolution (compositions imbriquées) et Préserver la cadence (compositions imbriquées ou en file d’attente de rendu)

Avec ces paramètres, la composition conserve sa résolution ou sa cadence, et n’hérite pas des paramètres de la composition contenante. Par exemple, si vous avez délibérément utilisé une cadence faible pour obtenir un résultat saccadé, animé à la main, mieux vaut conserver la cadence de cette composition après imbrication. De même, si une rotoscopie adopte une cadence ou une résolution différente, le résultat n’est pas garanti. Utilisez de préférence ce paramètre (l’effet Postérisation temporelle est moins efficace).

Paramètres de flou de mouvement

  • Angle obturateur : l’angle d’obturateur (mesuré en degrés) simule l’exposition autorisée par un obturateur en rotation. L’angle d’obturateur utilise la cadence du métrage pour déterminer l’exposition simulée qui affecte la quantité de flou de mouvement. Par exemple, un angle de 90 degrés (25 % de 360 degrés) pour un métrage de 24 i/s crée une exposition effective de 1/96 de seconde (25 % de 1/24 de seconde). Un angle de 1 degré produit un flou de mouvement quasi inexistant, tandis qu’un angle de 720 degrés produit un flou très élevé.
  • Phase d’obturateur : la phase d’obturateur est également mesurée en degrés. Elle définit un décalage qui détermine le moment d’ouverture de l’obturateur par rapport au début d’une image. Le réglage de cette valeur peut être utile si un objet présentant un flou de mouvement se retrouve derrière la position de l’objet sans flou de mouvement.
  • Échantillons par image : nombre minimum d’échantillons. Ce minimum est le nombre d’échantillons utilisés pour les images pour lesquelles After Effects ne parvient pas à déterminer un taux d’échantillonnage adapté, basé sur le mouvement d’un calque. Ce taux d’échantillonnage est utilisé pour les Calques 3D et les calques de forme.
  • Limite d’échantillons adaptés : nombre maximum d’échantillons.

Pour plus de détails sur les paramètres de composition avancés spécifiques non répertoriés ici, reportez-vous aux sections concernées :

Paramètres de rendu 3D

Vous pouvez utiliser les options de l’onglet Rendu 3D pour sélectionner le système de rendu 3D approprié pour votre composition. Les systèmes de rendu suivants vous sont proposés dans le menu Système de rendu :

  • 3D classique
  • CINEMA 4D
  • 3D avec lancer de rayon

La fonctionnalité 3D des systèmes de rendu CINEMA 4D et 3D avec lancer de rayon est quasiment identique à l’extrusion de calques de texte et de forme 3D et la courbure d’autres calques 3D (solides, métrages, etc.) dans les plans incurvés. Cependant, les résultats après rendu peuvent être différents, car ils produisent des résultats à l’aide de systèmes de rendu différents et prennent en charge différents jeux de fonctions. Par exemple, il existe des différences au niveau des options de surface d’un calque 3D, ainsi que d’autres comportements de calque. 

Le système de rendu CINEMA 4D effectue le rendu de calques 3D, y compris les formes et le texte extrudés, ainsi que les plans 2D courbes, pour faciliter l’animation de logos et de texte 3D à partir de zéro. Le système de rendu CINEMA 4D offre des performances bien plus élevées que le système de rendu 3D avec lancer de rayon utilisant uniquement le processeur.

Onglet Rendu 3D

Système de rendu 3D classique

3D classique est le système de rendu traditionnel utilisé par défaut. Les calques sont positionnés comme des plans dans l’espace 3D.

Options de rendu CINEMA 4D

Qualité : le niveau de qualité que vous définissez à l’aide du curseur affecte les paramètres qui déterminent la manière dont le système de rendu CINEMA 4D trace les calques 3D. Les paramètres de rendu résultants sont visibles dans les champs Options, Lissage et Réflectance. Le paramètre Qualité vous permet de combiner aisément, et de manière équilibrée, la vitesse de rendu et une qualité de rendu 3D acceptable sans comprendre, ni modifier les différents paramètres de qualité de rendu.

Les paramètres suivants sont modifiés lorsque vous réglez le curseur Qualité :

  • Seuil de lancer de rayon : cette valeur permet d’optimiser le temps de rendu.  
  • Profondeur de lancer de rayon : la profondeur de lancer de rayon détermine le nombre d’objets transparents (ou zones rendues invisibles à l’aide de la couche alpha) que le système de rendu peut pénétrer. 
  • Profondeur de réflexion : lorsqu’un rayon est envoyé sur la scène, il peut être réfléchi sur des surfaces réfléchissantes. Plus la profondeur de réflexion est élevée, plus le suivi des rayons est effectué en profondeur dans la scène et dans les résultats après rendu.
  • Profondeur d’ombre : la profondeur d’ombre se comporte de la même manière que la profondeur de réflexion. Le paramètre Profondeur d’ombre définit la profondeur d’ombre avec laquelle sont calculés les rayons d’ombre visibles. 

Lissage : « Géométrie » est le paramètre de lissage par défaut qui lisse tous les bords d’un objet (automatiquement avec des sous-pixels de 16x16).

Réflectance : « Échantillonnage de calques » est le paramètre de réflectance par défaut qui définit la qualité des réflexions de cache.

Lorsque vous sélectionnez CINEMA 4D dans la liste déroulante Système de rendu, la colonne « Activé » affiche les options 3D qui sont activées, tandis que la colonne « Désactivé » affiche les options 3D qui ne sont pas disponibles.

Options de rendu CINEMA 4D
Options de rendu CINEMA 4D

Pour choisir un niveau de qualité pour votre rendu 3D, cliquez sur le bouton Options après avoir sélectionné Cinema 4D comme système de rendu et définissez le niveau de qualité à l’aide du curseur Qualité. Vérifiez les changements au niveau des propriétés Options, Lissage et Réflectance. 

After Effects installe, par défaut, une version de CINEMA 4D Lite. Si vous disposez de la version complète de CINEMA 4D ou d’une version ultérieure de CINEMA 4D Lite, vous pouvez la sélectionner comme système de rendu et éditeur.

Pour sélectionner une autre installation CINEMA 4D, cliquez surChoisir l’installation et sélectionnez le chemin d’accès au programme d’installation dans les zones de rendu et de modification.

Options de rendu 3D avec lancer de rayon

Cliquez sur le bouton Options pour ouvrir la boîte de dialogue Options de rendu 3D avec lancer de rayon. Vous pouvez également cliquer sur le bouton Indicateur de rendu en cours tout en maintenant la touche Ctrl (Windows) ou Commande (Mac OS) enfoncée. Ce bouton se situe dans le coin supérieur droit du panneau Composition pour ouvrir la boîte de dialogue.

Les options suivantes sont disponibles :

  • Qualité du lancer de rayon : cliquez sur les paramètres de qualité du lancer de rayon afin de les modifier en fonction de votre workflow.
    • Des valeurs plus élevées pour la qualité du lancer de rayon réduisent le bruit, mais augmentent considérablement le temps nécessaire au rendu.
      La qualité du lancer de rayon détermine le nombre de rayons déclenchés par pixel (par exemple, une valeur de 4 déclenche 16 ou 4 x 4 rayons, tandis qu’une valeur de 8 déclenche 64 rayons).
    • Un nombre plus élevé produit un pixel plus précis, au détriment du temps de calcul.
    • Une valeur de 1 permet d’obtenir de meilleures performances. Cependant, il n’y aura aucun flou de réflexion (le résultat est toujours net, par exemple), aucune ombre adoucie, aucune profondeur de champ et aucun flou de mouvement.

L’augmentation de la valeur « Qualité du lancer de rayon » n’améliore pas la netteté. En revanche, elle réduit le bruit inhérent à l’échantillonnage de points. Utilisez la valeur la plus basse qui produit une quantité acceptable de bruit ou aucun bruit.

  • Filtre de lissage : contrôle la méthode de calcul de la moyenne du nombre de rayons déclenchés pour un pixel. « Aucun » déclenche tous les rayons dans les limites d’un pixel, tandis que les autres options élargissent partiellement la grille des rayons déclenchés sur les pixels adjacents afin de produire une meilleure moyenne. Les options Boîte, Tente et Cubique (qui est différent de « bicubique ») sont répertoriées en fonction du niveau de qualité.
    • Aucun
    • Boîte
    • Tente
    • Cubique

Le filtre de lissage contrôle le degré de flou. L’option « Aucun » donne le résultat le plus net, mais les bords du captage de projections peuvent présenter un effet de crénelage ; les options Flou encadré, Triangle et Cubique produisant les résultats les plus flous.

Remarque :

Les calques 3D avec lancer de rayon utilisent la qualité du lancer de rayon pour contrôler l’aspect de flou de mouvement.

Les calculs de la profondeur de champ en 3D avec lancer de rayon sont plus précises qu’en mode 3D classique (et, auparavant, en mode 3D avancé).

Vignettes des compositions

Vous pouvez choisir une image de la composition à afficher dans le panneau Projet sous forme de vignette (affiche). Par défaut, la vignette correspond à la première image de la composition (les parties transparentes apparaissent en noir).

  • Pour définir la vignette d’une composition, placez le repère d’instant courant sur l’image de votre choix dans le panneau Montage de la composition, puis choisissez Composition > Définir la postérisation temporelle.
  • Pour ajouter une grille de transparence à la vue des vignettes, choisissez la commande Grille de transparence des vignettes dans le menu du panneau Projet.
  • Pour masquer les vignettes dans le panneau Projet, sélectionnez Edition > Préférences > Affichage (Windows) ou After Effects > Préférences > Affichage (Mac OS) et choisissez l’option Désactiver les vignettes dans le panneau Projet.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne