Guide d'utilisation Annuler

Gestion et animation de tracés de forme et de masques

  1. Guide de lʼutilisateur dʼAfter Effects
  2. Versions Beta
    1. Présentation du programme Beta
    2. Accueil After Effects Beta
    3. Fonctionnalités de la version Beta
      1. Panneau Propriétés (Beta)
  3. Prise en main
    1. Prise en main dʼAfter Effects
    2. Nouveautés dʼAfter Effects
    3. Notes de mise à jour | After Effects
    4. Configuration requise pour After Effects
    5. Raccourcis clavier dans After Effects
    6. Formats de fichier pris en charge | After Effects
    7. Recommandations matérielles
    8. After Effects pour puce Apple
    9. Planification et configuration
    10. Configuration et installation
  4. Espaces de travail
    1. Eléments généraux de lʼinterface utilisateur
    2. Familiarisation avec lʼinterface dʼAfter Effects
    3. Workflows
    4. Espaces de travail, panneaux et visualiseurs
  5. Projets et compositions
    1. Projets
    2. Notions de base relatives aux compositions
    3. Précomposition, imbrication et prérendu
    4. Affichage dʼinformations détaillées sur les performances avec le Profileur de composition
    5. Moteur de rendu de composition CINEMA 4D
  6. Importation de métrage
    1. Préparation et importation dʼimages fixes
    2. Importation à partir dʼAfter Effects et dʼAdobe Premiere Pro
    3. Importation et interprétation vidéo et audio
    4. Préparation et importation de fichiers images 3D
    5. Importation et interprétation de métrages
    6. Utilisation des métrages
    7. Détecter les points de montage à l’aide de la détection de montage de scène
    8. Métadonnées XMP
  7. Texte et images
    1. Texte
      1. Mise en forme des caractères et panneau Caractère
      2. Effets de texte
      3. Création et modification des calques de texte
      4. Mise en forme des paragraphes et panneau Paragraphe
      5. Extrusion de calques de texte et de forme
      6. Animation de texte
      7. Exemples et ressources dʼanimation de texte
      8. Modèles Live Text
    2. Animations graphiques
      1. Utilisation de modèles dʼanimations graphiques dans After Effects
      2. Utilisation des expressions pour créer des listes déroulantes dans les modèles dʼanimations graphiques
      3. Utilisation des propriétés essentielles pour créer des modèles dʼanimations graphiques
      4. Remplacement d’images et de vidéos dans les modèles dʼanimations graphiques et les propriétés essentielles
  8. Dessin, peinture et tracés
    1. Présentation des calques de forme, des tracés et des images vectorielles
    2. Outils de peinture : Pinceau, Cloner et Gomme
    3. Comment effiler les contours de forme
    4. Attributs de forme, opérations de peinture et opérations de tracé pour les calques de forme
    5. Utilisation de lʼeffet de forme Décaler les tracés pour modifier des formes
    6. Création de formes
    7. Création de masques
    8. Suppression dʼobjets de vos vidéos avec le panneau Remplissage dʼaprès le contenu
    9. Roto-pinceau et Améliorer le cache
  9. Calques, marqueurs et caméra
    1. Sélection et disposition de calques
    2. Modes de fusion et styles de calques
    3. Calques 3D
    4. Propriétés du calque
    5. Création de calques
    6. Gestion des calques
    7. Repères de calque et repères de composition
    8. Caméras, lumières et points ciblés
  10. Animation, images clés, suivi de cible et incrustations
    1. Animation
      1. Principes de base de l’animation
      2. Animation avec les outils Marionnette
      3. Gestion et animation de tracés de forme et de masques
      4. Animation de formes Sketch et Capture à lʼaide dʼAfter Effects
      5. Outils dʼanimation divers
      6. Utilisation dʼanimations orientées données
    2. Image clé
      1. Interpolation des images clés
      2. Définition, sélection et suppression dʼimages clés
      3. Modification, déplacement et copie dʼimages clés
    3. Suivi de cible
      1. Suivi et stabilisation du mouvement
      2. Suivi du visage
      3. Suivi de masque
      4. Référence de masque
      5. Vitesse
      6. Extension temporelle et remappage temporel
      7. Code temporel et unités temporelles
    4. Masquage
      1. Incrustations
      2. Effets de masquage
  11. Transparence et montage
    1. Présentation et ressources du montage et de la transparence
    2. Couches alpha, masques et caches
  12. Réglage de la couleur
    1. Principes de base de la couleur
    2. Utilisation de lʼextension Thèmes Adobe Color
    3. Gestion des couleurs
    4. Effets de correction colorimétrique
  13. Effets et animations prédéfinies
    1. Présentation des effets et animations prédéfinies
    2. Liste dʼeffets
    3. Effets de simulation
    4. Effets esthétiques
    5. Effets audio
    6. Effets de déformation
    7. Effets de perspective
    8. Effets de couches
    9. Effets de rendu
    10. Effets de transition
    11. Effet Réparation dʼobturateur déroulant
    12. Effets de flou et de netteté
    13. Effets de couches 3D
    14. Effets Utilité
    15. Effets de cache
    16. Effets de bruit et de grain
    17. Effet Conservation des détails-Amélioration
    18. Effets obsolètes
  14. Expressions et automatisation
    1. Expression
      1. Principes de base des expressions
      2. Compréhension du langage dʼexpression
      3. Utilisation des options pour expressions
      4. Différences de syntaxe entre le moteur dʼexpressions JavaScript et lʼancien moteur dʼexpressions ExtendScript
      5. Modification des expressions
      6. Erreurs dans les expressions
      7. Utilisation de lʼéditeur dʼexpressions
      8. Utilisation d’expressions pour accéder aux propriétés du texte et les modifier
      9. Référence au langage dʼexpression
      10. Exemples dʼexpressions
    2. Automatisation
      1. Automatisation
      2. Scripts
  15. Vidéo immersive, VR et 3D
    1. Création dʼenvironnements VR dans After Effects
    2. Application d’effets de vidéo immersive
    3. Outils de composition pour les vidéos VR/360
    4. Suivi du mouvement de la caméra 3D
    5. Utilisation de lʼespace de conception 3D
    6. Widgets de transformation 3D
    7. En faire plus avec l’animation 3D
    8. Aperçu des modifications apportées aux conceptions 3D en temps réel avec le moteur en temps réel
    9. Ajout de Responsive Design à vos images
  16. Vues et prévisualisations
    1. Prévisualisation
    2. Prévisualisation vidéo à lʼaide de Mercury Transmit
    3. Modification et utilisation des vues
  17. Rendu et exportation
    1. Notions de base relatives au rendu et à lʼexportation
    2. Exportation dʼun projet After Effects en tant que projet Adobe Premiere Pro
    3. Conversion de films
    4. Rendu multi-images
    5. Rendu automatisé et rendu en réseau
    6. Rendu et exportation dʼimages fixes et de séquences dʼimages fixes
    7. Utilisation du codec GoPro CineForm dans After Effects
  18. Utilisation dʼautres applications
    1. Dynamic Link et After Effects
    2. Utilisation dʼAfter Effects et dʼautres applications
    3. Synchronisation des paramètres dans After Effects
    4. Bibliothèques Creative Cloud dans After Effects
    5. Plug-ins
    6. CINEMA 4D et Cineware
  19. Collaboration : Frame.io et Projets d’équipe
    1. Collaboration dans Premiere Pro et After Effects
    2. Frame.io
      1. Installation et activation de Frame.io
      2. Utilisation de Frame.io avec Premiere Pro et After Effects
      3. Foire aux questions
    3. Projets dʼéquipe
      1. Prise en main des projets d’équipe
      2. Créer un projet d’équipe
      3. Collaborer sur les projets d’équipe
  20. Mémoire, stockage et performances
    1. Mémoire et stockage
    2. Amélioration des performances
    3. Préférences
    4. Configuration requise du GPU et du pilote GPU pour After Effects

Vous pouvez animer des tracés de forme et de masques peu ou prou comme pour d’autres propriétés : définissez les images clés pour la propriété Tracé de masque ou Tracé, définissez des tracés à chaque image clé, puis After Effects se charge de l’interpolation entre les valeurs définies.

Présentation de la rotoscopie et ressources associées

La rotoscopie (ou simplement roto dans le langage courant) consiste à dessiner ou peindre sur les images d’un film, en se basant sur les éléments visuels de celui-ci. Effectuer un tracé autour d’un objet dans un film et utiliser ce tracé comme masque pour séparer l’objet de son arrière-plan représente une forme simple de rotoscopie. Cela vous permet de travailler séparément avec l’objet et l’arrière-plan et, partant, d’appliquer à l’objet des effets différents de son arrière-plan, voire de remplacer l’arrière-plan.

Remarque :

After Effects intègre les outils Roto-pinceau et Améliorer le contour, qui permettent d’accomplir en beaucoup moins de temps nombre des tâches réalisables avec la rotoscopie conventionnelle. Pour plus d’informations sur l’utilisation de l’outil Roto-pinceau, consultez la section Effets Roto-pinceau, Améliorer le contour et Améliorer le cache.

Remarque :

Si l’objet d’arrière-plan ou de premier plan est une couleur distincte et homogène, vous pouvez préférer le masquage colorimétrique à la rotoscopie pour supprimer l’arrière-plan ou l’objet. Si le masquage colorimétrique a été pris en compte lors du tournage du métrage, cette technique se révèle bien plus aisée que la rotoscopie (Consultez la section Présentation du masquage et workflow).

Dans After Effects, la rotoscopie consiste essentiellement à dessiner des masques, à animer le tracé du masque, puis à utiliser ces masques pour définir un cache. Bien d’autres tâches et techniques rendent cette tâche encore plus aisée ; citons, par exemple, l’application du suivi de cible sur l’objet avant de dessiner des masques, puis l’utilisation des données de suivi de cible pour faire en sorte que le masque ou le cache suive automatiquement l’objet.

Conseils relatifs à la rotoscopie

  • Immédiatement après avoir commencé à dessiner le masque, appuyez sur les touches Alt + Maj + C (Windows) ou Option + Maj + C (Mac OS) pour activer la génération automatique d’images clés et définir une image clé. Cela vous évitera de modifier un masque, image par image, pour vous rendre compte, après quelques minutes (voire plus), que vous avez perdu tout le travail effectué sur les images précédentes parce que vous avez oublié d’appuyer sur le chronomètre pour animer le tracé du masque.
  • Dessinez vos masques sur un calque blanc uni en désactivant l’option Video (œil), au-dessus du calque de métrage (verrouillé). Vous vous mettez ainsi à l’abri d’un déplacement accidentel du calque de métrage lors de la manipulation du masque. De plus, l’application de données de suivi au masque s’en trouve sensiblement facilitée. (Les données de suivi sont appliquées au calque uni invisible dans lequel figure le masque.) Cela signifie également que les images de prévisualisation mises en cache sont conservées lorsque vous manipulez le masque (Consultez les sections Activer/désactiver la visibilité ou l’influence d’un calque ou d’un groupe de propriétés et Verrouiller ou déverrouiller un calque).
  • Activez la préférence Conserver un compte de sommets constant. (Consultez la section Désigner le premier sommet d’un tracé de Bézier).
  • Dans la mesure du possible, transformez (par rotation, mise à l’échelle ou déplacement) le masque entier ou un sous-ensemble des sommets du masque au lieu de déplacer chaque sommet séparément. Non seulement cela garantit une efficacité accrue, mais cela permet d’éviter le bruit induit par un mouvement incohérent entre les images (Consultez la section Déplacer des sommets en mode de transformation libre).
  • Le suivi de cible manuel s’avère plus rapide que la rotoscopie manuelle. Plus vous vous appliquerez à obtenir des données de suivi de qualité pour les différentes parties de votre scène ou objet, moins vous perdrez de temps à dessiner et ajuster les masques (Consultez la section Suivre et stabiliser le mouvement).
  • Utilisez la fonction Contour progressif de masque à largeur variable afin de mieux contrôler le contour progressif des objets.

Afficher les tracés de masque et des formes

  • Pour afficher les tracés de masque des calques sélectionnés dans le panneau Montage, appuyez sur M.
  • Pour afficher les masques ou les formes sélectionnés dans le panneau Montage, appuyez sur SS (appuyez deux fois sur la touche S).
  • Pour afficher les tracés de masque et de forme dans le panneau Composition, cliquez sur le bouton Activer/désactiver la visibilité des masques et des tracés de la forme en bas de ce panneau.
  • Pour afficher les tracés de masque dans le panneau Calque, choisissez la commande Masques dans le menu Afficher du panneau Calque.
  • Pour masquer un tracé de masque tout en affichant les autres, verrouillez le masque en sélectionnant le bouton du cadenas  dans le panneau Montage, puis choisissez Calque > Masque > Masquer les masques verrouillés.
  • Pour isoler les masques sélectionnés et masquer les autres, sélectionnez Calque > Masque > Verrouiller les autres masques, puis Calque > Masque > Masquer les masques verrouillés.

Sélectionner des tracés de forme, des formes et des groupes de formes

Vous pouvez sélectionner des calques de forme et leurs composants à l’un des quatre niveaux de sélection, également appelés modes de sélection :

Mode de sélection de calque

Le calque de forme complet est sélectionné. Les transformations s’appliquent aux propriétés Transformer du calque, dans le groupe de propriétés Transformer situé au même niveau que le groupe de propriétés Contenu.

Mode de sélection de groupe

Un groupe de formes complet est sélectionné. Les transformations s’appliquent aux propriétés Transformer du groupe, dans le groupe de propriétés Transformer situé dans le groupe de formes du panneau Montage.

Mode de transformation libre

Plusieurs sommets d’un ou de plusieurs tracés de Bézier sont sélectionnés. Un cadre de sélection de transformation libre s’affiche autour des sommets dans le panneau Composition. En agissant sur ce cadre, vous pouvez déplacer plusieurs sommets avec une seule transformation. Les transformations s’appliquent aux sommets contenus dans la propriété Tracé du panneau Montage.

Mode d’édition du tracé

Seuls les sommets sont sélectionnés. Avec ce mode, vous pouvez réaliser des opérations d’édition du tracé, comme l’ajout de sommets à un tracé et le déplacement de sommets individuels.

Remarque :

Lorsqu’un outil de plume est actif, le mode d’édition du tracé est actif. Pour rester dans ce mode, sélectionnez l’outil Plume, appuyez sur la touche V ou Ctrl (Windows) ou Commande (Mac OS) pour activer temporairement l’outil Sélection.

Modes de sélection des formes situées sur des calques de forme

A. Sélection de calque B. Sélection de groupe C. Transformation libre D. Edition du tracé 

Pour plus d’informations sur la sélection des masques, consultez la section Sélectionner des masques, segments et sommets.

Remarque :

Appuyez sur les touches Ctrl + A (Windows) ou Commande + A (Mac OS) alors qu’un sommet de forme est actif pour sélectionner tous les sommets du tracé. Appuyez de nouveau pour sélectionner toutes les formes. Appuyez de nouveau pour sélectionner tous les calques.

Sélection d’un calque de forme

  • Cliquez sur le nom d’un calque ou sur la bande de durée du calque dans le panneau Montage.
  • À l’aide de l’outil Sélection, cliquez à l’intérieur des limites du calque dans le panneau Composition.
  • Pour désélectionner toutes les formes d’un calque en laissant le calque de forme sélectionné, cliquez à l’intérieur des limites du calque, mais à l’extérieur de tous les tracés de forme.

Sélectionner un groupe de formes en mode de sélection de groupe

  • À l’aide de l’outil Sélection, cliquez deux fois sur un membre du groupe dans le panneau Composition. À chaque double-clic, vous atteignez un niveau inférieur dans la hiérarchie du groupe.
  • Pour activer l’outil de sélection directe , maintenez la touche Ctrl (Windows) ou Commande (Mac OS) enfoncée pendant que l’outil Sélection est actif. Cliquez sur une forme du panneau Composition avec l’outil de sélection directe pour sélectionner directement le groupe de cette forme, quelle que soit sa position imbriquée dans la hiérarchie du groupe.
  • Pour sélectionner un groupe contenu dans le même groupe que le groupe déjà sélectionné, cliquez sur le groupe qui vous intéresse.
  • Pour ajouter un groupe à une sélection, cliquez dessus tout en appuyant sur Maj. Vous pouvez combiner la touche Maj avec un double-clic et l’outil de sélection directe pour ajouter à la sélection des groupes très imbriqués dans la hiérarchie.

Sélectionner des tracés et des sommets en mode d’édition du tracé

Remarque :

Pour préciser la taille des poignées directrices Bézier et des sommets des masques et formes, choisissez Édition > Préférences > Général (Windows) ou After Effects > Préférences > Général (Mac OS), puis modifiez la valeur Taille de point du tracé.

  • Pour sélectionner un sommet, cliquez dessus à l’aide de l’outil Sélection. Pour ajouter des sommets à la sélection, maintenez la touche Maj enfoncée et cliquez sur les sommets.
  • Pour sélectionner un segment de tracé, cliquez sur ce segment à l’aide de l’outil Sélection. Pour ajouter des segments à la sélection, maintenez la touche Maj enfoncée et cliquez sur les segments.
  • Pour sélectionner un tracé entier, maintenez la touche Alt (Windows) ou Option (Mac OS) enfoncée et cliquez sur un segment ou un sommet du tracé à l’aide de l’outil Sélection, ou sélectionnez une partie du tracé et appuyez sur les touches Ctrl + A (Windows) ou Commande + A (Mac OS).
  • Pour sélectionner des sommets par glissement, sélectionnez un tracé ou une partie d’un tracé pour activer le mode d’édition, puis faites glisser l’outil de sélection afin de dessiner un rectangle de sélection tout autour des sommets à sélectionner. Pour ajouter des sommets à la sélection, maintenez la touche Maj enfoncée et dessinez des rectangles de sélection supplémentaires.

Sélectionner tous les points d’un tracé et activer le mode de transformation libre

  • Cliquez deux fois sur un segment de tracé en mode d’édition du tracé ou en mode de sélection de groupe dans le cas d’une forme simple.
  • Sélectionnez la propriété Tracé dans le panneau Montage et appuyez sur les touches Ctrl + T (Windows) ou Commande + T (Mac OS).

Sélectionner des masques, segments et sommets

Contrairement aux calques, les masques peuvent avoir plusieurs niveaux de sélection. Vous pouvez sélectionner un masque sous la forme d’un tracé complet, ce qui convient dans le cas du déplacement ou du redimensionnement d’un masque. Cependant, si vous souhaitez modifier le tracé d’un masque, vous devez sélectionner au moins un point sur le masque. Les points sélectionnés apparaissent pleins et les points non sélectionnés, vides.

Remarque :

Pour préciser la taille des poignées directrices Bézier et des sommets des masques et formes, choisissez Édition > Préférences > Général (Windows) ou After Effects > Préférences > Général (Mac OS), puis modifiez la valeur Taille de point du tracé.

Sélectionner ou désélectionner des masques dans le panneau Calque ou Composition

  • Pour sélectionner un sommet sur un masque, cliquez sur ce sommet à l’aide de l’outil Sélection . Pour ajouter des sommets à la sélection, maintenez la touche Maj enfoncée et cliquez sur les sommets.
  • Pour sélectionner un segment de masque, cliquez sur ce segment à l’aide de l’outil Sélection. Pour ajouter des segments à la sélection, maintenez la touche Maj enfoncée et cliquez sur les segments.
  • Pour sélectionner un masque entier, maintenez la touche Alt (Windows) ou Option (Mac OS) enfoncée et cliquez sur un segment, un sommet ou une poignée d’un masque à l’aide de l’outil Sélection. Pour sélectionner une partie du masque, choisissez Édition > Sélectionner tout ou appuyez sur les touches Ctrl + A (Windows) ou Commande + A (Mac OS). Pour ajouter des masques à la sélection, maintenez les touches Alt + Maj (Windows) ou Option + Maj (Mac OS) enfoncées et cliquez sur les masques.
  • Pour sélectionner des masques par glissement, sélectionnez un masque ou une partie d’un masque pour activer le mode d’édition, puis faites glisser l’outil Sélection afin de dessiner un rectangle de sélection tout autour des sommets ou des masques que vous souhaitez sélectionner. Pour ajouter des masques ou des sommets à la sélection, maintenez la touche Maj enfoncée et dessinez des rectangles de sélection supplémentaires.
  • Pour sélectionner tous les masques d’un calque, sélectionnez un masque du calque, choisissez Édition > Sélectionner tout ou appuyez sur les touches Ctrl + A (Windows) ou Commande + A (Mac OS).
  • Pour désélectionner tous les masques, appuyez sur les touches Ctrl + Maj + A (Windows) ou Commande + Maj + A (Mac OS).
  • Pour sélectionner un masque adjacent sur un calque, appuyez sur les touches Alt + accent grave (`) (Windows) ou Option + accent grave (`) (Mac OS) pour sélectionner le masque suivant. Pour sélectionner le masque précédent, appuyez sur les touches Maj + Alt + accent grave (`) (Windows) ou Maj + Option + accent grave (`) (Mac OS).
  • Pour désélectionner un masque, cliquez sur un point quelconque en dehors du masque.
  • Pour supprimer un sommet ou un segment d’une sélection, maintenez la touche Maj enfoncée et cliquez sur le sommet ou le segment.
Remarque :

Pour utiliser l’outil Sélection quand l’outil Plume est sélectionné, maintenez la touche Ctrl (Windows) ou Commande (Mac OS) enfoncée.

Sélectionner des masques dans le panneau Montage

  1. Cliquez sur la flèche droite en regard du nom du calque pour le développer.
  2. Cliquez sur la flèche droite à côté de l’intitulé Masques pour le développer et ainsi afficher tous les masques contenus dans ce calque.
  3. Utilisez l’une des méthodes suivantes :
    • Pour sélectionner un masque, cliquez sur son nom.
    • Pour sélectionner des séries contiguës de masques, maintenez la touche Maj enfoncée et cliquez sur le nom du premier et du dernier masque de la série.
    • Pour sélectionner simultanément des masques non contigus, maintenez la touche Ctrl (Windows) ou Commande (Mac OS) enfoncée et cliquez sur le nom des masques à inclure.
Remarque :

vous pouvez uniquement sélectionner des masques entiers dans le panneau Montage. Pour sélectionner des sommets individuels sur un masque, utilisez le panneau Composition ou Calque.

Verrouiller ou déverrouiller des masques

Le verrouillage d’un masque vous empêche de le sélectionner dans les panneaux Montage, Composition et Calque ou de le définir comme cible dans le panneau Calque. Utilisez cette fonctionnalité si vous voulez éviter toute modification indésirable du masque.

  1. Dans le panneau Montage, développez le groupe de propriétés Masques.
  2. Dans la colonne Fonctions A/V, cliquez sur la case située sous l’icône de verrouillage , en regard du masque que vous souhaitez verrouiller ou déverrouiller. Un masque est verrouillé et ne peut pas être sélectionné lorsque son cadenas est activé (en d’autres termes, lorsque l’icône Cadenas apparaît dans la case).
Remarque :

Pour déverrouiller plusieurs masques simultanément, sélectionnez un ou plusieurs calques et choisissez Calque > Masque > Déverrouiller tous les masques.

Remarque :

Pour isoler les masques sélectionnés et masquer les autres, sélectionnez Calque > Masque > Verrouiller les autres masques, puis Calque > Masque > Masquer les masques verrouillés.

Déplacer des sommets en mode de transformation libre

Vous pouvez mettre à l’échelle un tracé de masque ou de forme entier (ou les sommets sélectionnés d’un ou plusieurs tracés) et le faire pivoter à l’aide de la commande Points de transformation libre. Lorsque vous utilisez cette commande, un cadre de sélection de transformation libre entoure les sommets sélectionnés et un point d’ancrage s’affiche au centre du cadre. Ce point représente le point d’ancrage de la transformation en cours. Vous pouvez mettre à l’échelle et faire pivoter les sommets sélectionnés en faisant glisser le cadre de sélection ou ses poignées. Vous pouvez également modifier le point de référence à partir duquel les sommets pivotent ou sont mis à l’échelle en déplaçant le point d’ancrage du cadre de sélection. Les poignées du cadre de sélection et le point d'ancrage de la transformation libre sont indépendants de ceux du calque.

Remarque :

Lorsque vous animez une rotation à l’aide de la commande Points de transformation libre, les sommets du masque sont interpolés en ligne droite d’image clé en image clé. C’est pourquoi le résultat obtenu peut être différent du résultat attendu.

  1. Affichez le calque contenant les tracés à transformer dans le panneau Composition ou Calque.
  2. À l’aide de l’outil Sélection, procédez de l’une des façons suivantes :
    • Pour transformer un certain nombre de sommets, sélectionnez les sommets en question et choisissez Calque > Tracé de masque et de forme > Points de transformation libre.
    • Pour transformer un tracé de masque ou de forme entier, sélectionnez-le dans le panneau Montage, puis choisissez Calque > Tracé de masque et de forme > Points de transformation libre.
  3. Pour déplacer le point d’ancrage du cadre de sélection, placez l’outil Sélection sur ce point  jusqu’à ce que l’outil se transforme en une icône de déplacement de point d’ancrage . Faites glisser la souris pour positionner le point d’ancrage.
  4. Effectuez les opérations suivantes :
    • Pour déplacer le tracé ou les sommets sélectionnés, placez le curseur à l’intérieur du cadre de sélection et faites glisser la souris.
    • Pour mettre à l’échelle le tracé ou les sommets sélectionnés, placez le pointeur sur une poignée du cadre de sélection et, lorsque le pointeur se transforme en une flèche droite bidirectionnelle , faites glisser la souris pour définir une nouvelle taille. Maintenez la touche Maj enfoncée et faites glisser la souris pour conserver l’échelle. Maintenez la touche Ctrl (Windows) ou Commande (Mac OS) enfoncée et faites glisser la souris pour redimensionner le cadre de sélection autour de son point d’ancrage.
    • Pour faire pivoter le tracé ou les sommets sélectionnés, placez le pointeur à la limite extérieure du cadre de sélection de transformation libre. Lorsque le pointeur se transforme en une flèche incurvée bidirectionnelle , faites glisser la souris pour effectuer la rotation.
  5. Pour quitter le mode de transformation libre, appuyez sur la touche Échap ou Entrée (Windows) ou sur la touche Retour (Mac OS).

Convertir un tracé de Bézier manuel en RotoBézier et inversement

Vous pouvez convertir n’importe quel tracé de masque de Bézier manuel ou tracé de forme de Bézier manuel en tracé de RotoBézier. Si le tracé de Bézier manuel possède des poignées directrices qui ont été ajustées, cette conversion modifie la forme du tracé, car After Effects calcule automatiquement la courbure des segments de RotoBézier.

La conversion d’un tracé de RotoBézier en tracé de Bézier manuel ne modifie pas la forme du tracé.

  1. Sélectionnez un masque dans le panneau Calque, Composition ou Montage ou sélectionnez un tracé de forme dans le panneau Composition ou Montage.
  2. Sélectionnez Calque > Tracé de masque et de forme > RotoBézier.

Modifier un tracé de masque ou un tracé de forme de Bézier

Vous pouvez modifier un masque de Bézier au moyen de l’outil Sélection et des outils de plume dans le panneau Calque ou Composition. Vous pouvez modifier un tracé de forme de Bézier au moyen de l’outil Sélection et des outils de plume dans le panneau Composition.

Les outils de plume (Ajouter un sommet, Supprimer un sommet et Conversion de sommet) sont regroupés avec l’outil Plume dans le panneau Outils. Pour les faire apparaître dans le panneau Outils, cliquez de façon prolongée sur l’outil Plume dans le panneau Outils.

Remarque :

Dans la plupart des cas, l’outil de plume approprié devient actif lorsque vous placez le pointeur de l’outil Plume dans un contexte particulier. Par exemple, l’outil Supprimer un sommet devient actif lorsque vous placez le pointeur de l’outil Plume sur un sommet existant. De la même manière, l’outil Ajouter un sommet devient actif lorsque vous placez le pointeur de l’outil Plume sur un segment de tracé. Pour activer ces outils manuellement et passer de l’un à l’autre, appuyez sur la touche G.

Lorsque vous modifiez un tracé, cliquez uniquement sur des sommets ou segments existants ; sinon, vous risquez de créer un nouveau tracé.

Déplacement, ajout ou suppression d’un sommet

  1. Utilisez l’une des méthodes suivantes :
    • Pour déplacer un sommet, faites-le glisser à l’aide de l’outil Sélection .
    Remarque :

    Pour passer temporairement de l’outil Plume à l’outil Sélection, appuyez sur la touche V ou Ctrl (Windows) ou Commande (Mac OS).

    • Pour ajouter un sommet à un masque, cliquez à l’aide de l’outil Ajouter un sommet  sur le segment reliant deux sommets existants.
    • Pour supprimer un sommet d’un masque, cliquez à l’aide de l’outil Supprimer un sommet  sur le sommet.

Modifier un segment de tracé

  1. À l’aide de l’outil Sélection, utilisez l’une des méthodes suivantes :
    • Faites glisser un sommet.
    • Faites glisser les poignées directrices issues d’un sommet arrondi adjacent.
    • Faites glisser un segment incurvé.
    Remarque :

    Le glissement d’un segment incurvé sur un masque RotoBézier déplace également les sommets.

Basculer entre un sommet en point d’inflexion et un sommet en point d’angle

  1. Cliquez sur le sommet à l’aide de l’outil Conversion de sommet .
    Remarque :

    Pour activer l’outil Conversion de sommet pendant que l’outil Plume est sélectionné, maintenez la touche Alt (Windows) ou Option (Mac OS) enfoncée.

Modifier la tension d’un masque RotoBézier

  1. Si vous souhaitez ajuster la tension de plusieurs sommets simultanément, commencez par les sélectionner.
  2. A l’aide de l’outil Conversion de sommet , faites glisser un sommet.
    Remarque :

    Pour activer l’outil Conversion de sommet pendant que l’outil Plume est sélectionné, maintenez la touche Alt (Windows) ou Option (Mac OS) enfoncée.

    Le pointeur d’ajustement de la tension  apparaît lorsque vous faites glisser un sommet du masque RotoBézier.

    Cliquez sur un sommet au lieu de le faire glisser pour le définir comme point d’angle (tension de 100 %) ; cliquez de nouveau pour le définir comme point d’inflexion (tension de 33 %). Faites glisser vers le haut ou vers la droite pour diminuer la tension de la sélection et augmenter ainsi la courbe des segments de tracé adjacents ; faites glisser vers le bas ou vers la gauche pour augmenter la tension de la sélection et réduire ainsi la courbe des segments de tracé adjacents.

    Remarque :

    Pour connaître la valeur de tension d’un sommet, consultez le panneau Info pendant que vous ajustez la tension.

Modification d’un tracé de masque à l’aide de valeurs numériques

  1. Sélectionnez le masque.
  2. Dans le panneau Montage, développez les propriétés Masque.
  3. En regard de la propriété Tracé du masque, cliquez sur le mot souligné, et indiquez les changements dans la boîte de dialogue Forme du masque.

Désigner le premier sommet pour un tracé de Bézier

Pour animer un tracé, After Effects désigne le sommet le plus haut au niveau de la première image clé comme étant le premier sommet et attribue un numéro à chacun des sommets suivants par ordre croissant, en partant du premier sommet. After Effects attribue ensuite les mêmes numéros aux sommets correspondants dans toutes les autres images clés. After Effects interpole le mouvement de chaque sommet depuis sa position initiale dans une image clé jusqu’à la position du sommet portant le même numéro à l’image clé suivante. À tout moment au cours d’une animation, vous pouvez désigner un autre sommet comme premier sommet. Cette action a pour effet d’entraîner la renumérotation des sommets du tracé par After Effects. La renumérotation des sommets modifie l’animation du tracé, car After Effects associe ensuite les nouveaux numéros des sommets aux anciens numéros des sommets correspondants toujours enregistrés dans les autres images clés.

Lorsque vous copiez un tracé fermé sur une trajectoire, le sommet désigné comme le premier sommet du tracé fermé fait office de début de trajectoire. Toutes les trajectoires sont des tracés ouverts.

Certaines opérations de tracé de forme, comme Réduire les tracés, utilisent également le premier sommet comme entrée pour déterminer la façon de modifier le tracé.

Remarque :

lorsque vous ajoutez un sommet à un tracé, le nouveau sommet apparaît par défaut sur le tracé pendant toute la durée du tracé, mais ne remodèle ce dernier qu’au moment où il a été ajouté. Lorsque vous supprimez un sommet d’un tracé à un instant donné, le sommet est supprimé du tracé pour toute la durée du tracé. Pour empêcher After Effects d’ajouter ou de supprimer des sommets pendant toute la durée du tracé, sélectionnez Edition > Préférences > Général (Windows) ou After Effects > Préférences > Général (Mac OS) et désactivez l’option Conserver un compte de sommets constant lors de la modification des masques.

Remarque : dans After Effects CC et CS6, l’option « Conserver un compte de sommets constant lors de la modification des masques » se nomme « Conserver un nombre constant de sommets et de contours progressifs lors de la modification des masques ».

  1. Créez un tracé animé.
  2. Dans le panneau Montage, déplacez le repère d’instant présent à l’endroit où vous souhaitez désigner un nouveau premier sommet.
  3. Sélectionnez le sommet à désigner comme premier sommet.
  4. Sélectionnez Calque > Tracé de masque et de forme > Définir le premier sommet.
    Remarque :

    Le sommet désigné comme premier sommet apparaît un peu plus grand que les autres sommets dans le panneau Composition.

Animer un tracé de masque à l’aide de la fonction Interpolation de masque avancée

La fonction Interpolation de masque avancée vous procure un niveau de contrôle élevé pour la création des images clés de tracé de masque et vous permet de créer des animations réalistes et fluides. Une fois que vous avez sélectionné des images clés de tracé de masque, la fonction Interpolation de masque avancée crée des images clés intermédiaires en fonction des paramètres que vous avez fournis. Le panneau Info affiche la progression de l’interpolation, ainsi que le nombre d’images clés créées.

  1. Sélectionnez Fenêtre > Interpolation de masque.
  2. Sélectionnez au minimum deux images clés de tracé de masque adjacentes.
  3. Définissez les options du panneau Interpolation de masque avancée, puis cliquez sur le bouton Appliquer.
    Remarque :

    Pour interrompre le processus d’interpolation, appuyez sur la touche Échap. Le panneau Info indique que le processus a été interrompu et fournit le nombre d’images clés créées.

    Cadence d’images clés

    Définit le nombre d’images clés créées par seconde par la fonction Interpolation de masque avancée entre les images clés sélectionnées. Par exemple, une valeur de 10 crée une nouvelle image clé tous les dixièmes de seconde. Sélectionnez l’option Automatique pour définir une cadence d’images clés équivalente à la cadence de la composition, qui apparaît entre parenthèses. Créez plus d’images clés pour une animation plus lisse et moins pour réduire le temps de rendu.

    Remarque :

    quelle que soit la cadence d’images clés que vous choisissez, le module Interpolation de masque avancée ajoute toujours des images clés à l’image consécutive à la première image clé de tracé de masque et à l’image précédant la seconde image clé de tracé de masque. Par exemple, si les images clés sont interpolées à 0 et à 1 seconde dans une composition de 30 i/s avec une cadence d’images clés de 10 images clés par seconde, les images clés du tracé de masque sont ajoutées aux numéros d’image suivants : 1, 3, 6, 9, 12, 15, 18, 21, 24, 27 et 29.

    Trames d’images clés

    Double la cadence d’images clés. Lorsque cette option est sélectionnée, et que la cadence d’images clés correspond à celle de la composition, une image clé est ajoutée à chaque trame vidéo. Sélectionnez cette option pour le masquage animé dans une vidéo entrelacée. Si cette option n’est pas sélectionnée, le masque peut glisser de l’objet que vous tentez de masquer. Pour plus d’informations sur les trames d’une vidéo entrelacée, reportez-vous à la section Vidéo entrelacée et séparation de trames.

    Tracés de sommets linéaires

    Spécifie que les sommets de la première image clé se déplacent le long d’un chemin droit vers les sommets correspondants de la seconde image clé. Ne cochez pas cette case si vous souhaitez interpoler certains sommets le long de chemins incurvés, lorsque l’interpolation fait intervenir des éléments en rotation, par exemple. Dans ce cas, le module Interpolation de masque avancée crée un chemin naturel pour le déplacement du masque.

    Résistance à la courbure

    Spécifie la tendance à la courbure du tracé du masque par rapport à l’étirement. Une valeur de 0 signifie qu’au fur et à mesure de l’animation du tracé du masque, ce dernier se plie davantage qu’il ne s’étire. Une valeur de 100 signifie que le tracé du masque a davantage tendance à s’étirer qu’à se courber.

    Qualité

    Indique le degré de précision de la correspondance entre les sommets d’une image clé à une autre. Une valeur de 0 signifie qu’un sommet particulier de la première image clé peut correspondre uniquement au sommet portant le même numéro dans la seconde image clé. Par exemple, le dixième sommet de la première image clé doit correspondre au dixième sommet de la deuxième image clé. Une valeur de 100 signifie qu’un sommet de la première image clé peut pratiquement correspondre à n’importe quel sommet de la deuxième image clé. Des valeurs plus élevées produisent généralement de meilleures interpolations. Cependant, elles augmentent le temps de traitement.

    Ajouter des sommets de tracé de masque

    Spécifie que le module ajoute des sommets pour améliorer la qualité des interpolations. En général, le module Interpolation de masque avancée fonctionne de manière optimale lorsque les tracés de masque possèdent des ensembles denses de sommets. En outre, un sommet sur le premier tracé du masque ne peut pas correspondre au milieu d’un segment de courbe ou de ligne droite sur le deuxième tracé du masque. Par conséquent, l’ajout de sommets avant la mise en correspondance est parfois nécessaire pour produire le résultat souhaité. Les images clés d’origine ne sont pas modifiées. Seules les nouvelles images clés du tracé de masque calculées par le module Interpolation de masque avancée sont dotées des sommets supplémentaires.

    La valeur que vous définissez détermine la valeur utilisée pour la subdivision des tracés d’entrée du masque. L’option Nombre de pixels entre les sommets indique la distance, en pixels, entre les sommets du tracé du masque du périmètre le plus grand après subdivision. L’option Nombre total de sommets indique le nombre de sommets souhaités sur les tracés du masque interpolés. L’option Proportion de la silhouette en pourcentage indique qu’un sommet est ajouté à chaque pourcentage indiqué de la longueur de silhouette du tracé du masque. Par exemple, une valeur de 5 signifie qu’un sommet est ajouté à chaque segment successif du paramètre qui représente 5 % du périmètre total. Si vous souhaitez utiliser uniquement les sommets présents à la première image, ne sélectionnez pas cette option.

    Remarque :

    le module Interpolation de masque avancée peut ajouter des sommets à des emplacements de sommet existants même si l’option Ajouter des sommets de tracé de masque n’est pas sélectionnée. Si deux sommets d’un même tracé de masque correspondent à un seul sommet sur l’autre, le sommet unique est dupliqué au même emplacement afin que le segment entre les deux sommets se transforme en un point correspondant à cet emplacement.

    Méthode de correspondance

    Spécifie l’algorithme utilisé pour faire correspondre les sommets d’un tracé de masque aux sommets d’un autre tracé de masque. Automatique : si l’une des deux images clés sélectionnées possède un segment incurvé, cette option permet d’appliquer l’algorithme conçu pour les courbes. Autrement, l’algorithme conçu pour les polylignes est utilisé. Courbe : cette option permet d’appliquer l’algorithme conçu pour les tracés de masque possédant des segments incurvés. Polyligne : option permet d’appliquer l’algorithme conçu pour les tracés de masque possédant des segments droits.

    Remarque :

    Les images clés de tracé de masque ajoutées par la fonction Interpolation de masque avancée sont des polylignes lorsque la méthode de correspondance des polylignes est utilisée, que les tracés d’entrée du masque contiennent des segments incurvés ou non.

    Correspondance de sommets 1:1

    Spécifie que le module crée un sommet sur un tracé de masque qui correspond au sommet portant le même numéro sur l’autre tracé de masque. À chaque tracé d’entrée de masque, le module fait correspondre les premiers sommets, les deuxièmes sommets, les troisièmes sommets, etc. Si les deux tracés ont un nombre de sommets différent, cette action peut produire des résultats inattendus.

    Correspondance premiers sommets

    Spécifie que le module fait correspondre les premiers sommets dans les deux images clés du tracé du masque. Si cette option n’est pas sélectionnée, le module recherche la meilleure correspondance du premier sommet entre les deux tracés d’entrée de masque.

    Remarque :

    Pour obtenir des résultats optimaux, vérifiez que les premiers sommets des tracés d’entrée du masque correspondent, puis sélectionnez l’option Correspondance premiers sommets.

Déplacer un masque ou un calque derrière un masque

Vous pouvez ajuster la zone visible au travers du masque en déplaçant le masque dans le panneau Calque ou Composition ou en déplaçant le calque situé derrière le masque dans le panneau Composition. Lorsque vous déplacez un masque, les valeurs Position du calque masqué restent constantes et le masque se déplace par rapport à d’autres objets dans le panneau Composition.

Lorsque vous utilisez l’outil Déplacement arrière (Point d’ancrage) pour déplacer un calque derrière un masque, la position du masque reste inchangée dans le panneau Composition, mais change dans le panneau Calque. Les valeurs Position du calque masqué changent par rapport à la composition. Lorsque le déplacement dépasse les limites de la zone du calque, les valeurs Forme du masque sur le calque changent également. L’outil Déplacement arrière (Point d’ancrage) vous fait gagner un temps considérable ; sans lui, vous devriez, en effet, modifier manuellement les propriétés Position et Forme du masque du calque. Vous pouvez animer un calque se déplaçant derrière un autre en définissant des images clés pour les propriétés Position et Tracé du masque du calque masqué.

Lorsque vous utilisez l’outil Déplacement arrière (Point d’ancrage) dans le panneau Composition, After Effects effectue automatiquement deux réglages. Dans le panneau Calque, le masque est déplacé par rapport à son calque (en haut), et il est déplacé par rapport à la composition dans le panneau Composition (en bas).

Déplacer un masque

  1. Sélectionnez le ou les masques que vous souhaitez déplacer.
  2. Dans le panneau Composition, faites glisser le ou les masques vers leur nouvel emplacement. Pour forcer le mouvement du ou des masques verticalement ou horizontalement, maintenez la touche Maj enfoncée une fois que vous avez commencé à faire glisser la souris.

Déplacement d’un calque derrière son masque

  1. Sélectionnez l’outil Déplacement arrière (Point d’ancrage) dans le panneau Outils.

  2. Cliquez à l’intérieur de la zone de masque dans le panneau Composition et faites glisser le calque vers son nouvel emplacement.

Suivi de visage et suivi de masque

Vous pouvez utiliser le suivi de masque pour convertir un masque afin qu’il suive le mouvement d’un ou de plusieurs objets dans une animation. Pour en savoir plus, consultez la section Suivi de masque.

Vous pouvez également utiliser le suivi de masque pour effectuer une détection et un suivi précis des visages humains. Pour en savoir plus, consultez la section Suivi du visage.

Accès des expressions à des points de tracé sur les masques, les formes de Bézier et les contours

Vous pouvez utiliser des expressions pour lire et écrire les coordonnées x et y de points de tracé, ou de sommets, pour les éléments suivants :

  • Masques de fusion
  • Formes de Bézier   
  • Contours sur les effets Peinture, Roto-pinceau et Améliorer le contour.

Les méthodes d’expression sont similaires à l’accès à des sommets de tracé via les scripts. La méthode d’expression est appelée points() et non pas sommets() par souci de familiarité.

Accéder aux méthodes d’expression

Pour accéder aux méthodes d’expression, procédez comme suit :

  1. Pour créer un calque solide, sélectionnez Calque > Solide.

  2. Une fois que vous avez créé un calque solide, créez un masque. Cliquez sur l’outil Forme, par exemple, un polygone, et créez un masque sur le calque solide.

  3. Dans le panneau Montage, ouvrez les propriétés Masque et faites un Alt + clic sur Tracé du masque.

  4. Le champ d’expression s’affiche. Dans le panneau Montage, cliquez sur le Menu langage d’expression et sélectionnez Propriété du tracé.

    Menu langage d’expression
    Menu langage d’expression

  5. Sélectionnez une méthode d’expression dans la liste des méthodes d’expression des points de tracé.

    Pour plus d’informations sur les méthodes d’expression, consultez la section Accès des expressions à des points de tracé sur les formes, masques et contours (référence de l’expression).

Vous trouverez ci-dessous des exemples de méthodes d’expression des objets de tracé suivants :

  • Tracés de masque de calque : layer("Dark Gray Solid 1").mask("Mask 1").path or .maskPath
  • Tracés de forme de Bézier : layer("Shape Layer 1").content("Shape 1").content("Path 1").path
  • Tracés de contour de l’effet Peinture : layer("Dark Gray Solid 1").effect("Paint").stroke("Brush 1").path
  • Tracés de l’effet Roto-pinceau/Améliorer contour : layer("Dark Gray Solid 1").effect("Roto Brush & Refine Edge").stroke("Foreground 1").path

Conseils pour utiliser ces méthodes d’expression :

  • Les valeurs des points et des tangentes sont renvoyées sous la forme d’un ensemble de tableaux de paires de nombres [x, y] correspondant aux coordonnées des sommets. Les valeurs des coordonnées sont arrondies à quatre décimales.
  • Les tableaux de points et de tangentes commencent par le premier sommet sur le tracé. Vous pouvez modifier le premier sommet des tracés de masque de calque et de forme de Bézier à l’aide de la commande Calque > Tracés de masque et de forme > Définir le premier sommet.
  • Les coordonnées des points de tracé du masque de calque sont déterminées en fonction de l’origine du calque dans son coin supérieur gauche.
  • Les coordonnées des points de tracé des formes de Bézier sont déterminées en fonction du point d’ancrage du groupe de formes du tracé, par exemple, « Transformation : Forme 1 > Point d’ancrage ».
  • Les coordonnées des points de tracé de l’effet Animer peinture sont relatives au début du contour ; le premier point étant [0,0].
  • La méthode toComp() ou d’autres méthodes de transformation de l’espace de calques peuvent être utiles pour convertir des coordonnées de différents calques en un espace commun ou simplement retourner les coordonnées relatives à l’espace de composition.
  • Étant donné que les tracés de forme de Bézier sont relatifs au point d’ancrage de leur groupe de formes local et non au calque, leurs valeurs peuvent être compensées depuis l’endroit où vous souhaitez qu’elles soient en réalité. Pour contourner cela, définissez toutes les propriétés Transformer du groupe de formes sur zéro. Gardez à l’esprit que la conversion d’une forme paramétrique en une forme de Bézier peut se répercuter sur la position du groupe de formes.
  • La méthode createPath() peut être une méthode points, tangentes et isClosed transmise du même tracé ou d’autres tracés. Vous pouvez transmettre ces méthodes sans les modifier pour dupliquer un tracé ou transformer les valeurs de points et de tangentes avant de les transmettre pour modifier ou animer le tracé.

Panneau Créer les nuls depuis les tracés

Créer les nuls depuis les tracés scriptUI vous permet de créer des animations intuitives dirigées par les expressions, sans qu’il faille les écrire manuellement. Vous pouvez associer directement des tracés à des formes, des formes à des solides, etc. Le panneau Créer les nuls depuis les tracés utilise l’accès des expressions à des points de tracé pour associer automatiquement les valeurs nulles, pour que vous n’ayez pas à écrire l’expression vous-même.

Le panneau crée des valeurs nulles pour chaque point sur un tracé de masque ou un tracé de forme de Bézier. Vous pouvez utiliser les boutons suivants du panneau pour déterminer le fonctionnement des valeurs nulles :

  • Les points suivent les valeurs nulles : le bouton crée des valeurs nulles qui contrôlent la position des points du tracé. Les points de tracé sont liés à des valeurs nulles et vous pouvez animer ces dernières pour diriger les points.
  • Les valeurs nulles suivent les points : le bouton crée des valeurs nulles qui sont contrôlées par la position des points du tracé. Les valeurs nulles sont liées à des points de tracé et vous pouvez animer ces derniers pour déplacer les valeurs nulles.
  • Tracer le chemin : le bouton crée une seule valeur nulle qui suit le tracé. La position de la valeur nulle est liée aux coordonnées du tracé. La rotation de la valeur nulle est définie automatiquement pour suivre le tracé. L’option Tracer le chemin contrôle le mouvement de la valeur nulle le long du tracé et détermine si la lecture s’effectue en boucle. Par défaut, les images clés sont définies pour dessiner le tracé en 1 seconde et la boucle est activée.

Utilisation du panneau

  1. Pour ouvrir le panneau, sélectionnez Fenêtres > Créer des valeurs nulles depuis Paths.jsx.

  2. Pour ajouter un masque de forme, sélectionnez Calque > Nouveau > Calque de forme. Ajoutez un masque de forme au calque.

    Remarque :

    Le panneau fonctionne avec des formes de Bézier. Dès lors, toutes les formes paramétriques, telles que le rectangle, l’ellipse et l’étoile, doivent être converties en formes de Bézier. Pour convertir une forme paramétrique en forme de Bézier, ouvrez le calque de forme, cliquez avec le bouton droit de la souris sur le tracé (par exemple, Rectangle 1) et sélectionnez ensuite Convertir en tracé de Bézier.

    Répétez l’étape 2 pour ajouter d’autres formes.

  3. Chaque masque et forme de Bézier comporte un tracé. Dans le panneau Montage, ouvrez les calques pour afficher les tracés. Si vous souhaitez que les valeurs nulles suivent des points du tracé, sélectionnez un tracé dans le panneau Montage et cliquez ensuite sur Les valeurs nulles suivent les points dans le panneau Créer les valeurs nulles depuis les tracés.

    Le script génère une valeur nulle pour chaque point du tracé. Vous pouvez supprimer toutes les valeurs nulles dont vous n’avez plus besoin.

    Remarque :

    Lorsque vous convertissez une forme paramétrique en forme de Bézier, After Effects ajuste la propriété Position de la forme. Cela entraîne un décalage lors du calcul de la position des valeurs nulles. Pour éviter ce problème, définissez la valeur de la propriété Transformer d’une forme, comme Transformer : Ellipse 1, sur zéro avant de créer des valeurs nulles.

  4. Si vous souhaitez que les points du tracé suivent les valeurs nulles, sélectionnez un tracé dans le panneau Montage. Cliquez ensuite sur Les points suivent les valeurs nulles dans le panneau Créer les valeurs nulles depuis les tracés.

  5. Une fois que vous avez créé des valeurs nulles pour tous les points du tracé, vous pouvez les lier les uns aux autres pour créer des animations. Les valeurs nulles créées avec le bouton Les points suivent les valeurs nulles et celles créées avec le bouton Les valeurs nulles suivent les points ont des couleurs différentes. Pour associer des valeurs nulles, sélectionnez une valeur nulle et maintenez la touche Maj enfoncée lorsque vous utilisez le sélecteur afin de choisir un calque parent et d’obtenir les coordonnées de la valeur nulle pour accéder directement au calque parent.

    Une fois que vous avez associé des valeurs nulles, affichez un aperçu de votre animation pour voir comment elle fonctionne.

Logo Adobe

Accéder à votre compte