Découvrez les nouvelles fonctionnalités et les améliorations de la version d’avril 2019 d’After Effects (version 16.1).
1_content

Réparation des vidéos lorsque vous supprimez des objets superflus de votre vidéo avec l’outil Remplissage d’après le contenu

Supprimez les objets superflus du métrage, tels que les micros, pancartes gênantes et personnes. Reposant sur Adobe Sensei, le remplissage d’après le contenu pour la vidéo permet d’effacer proprement les éléments superflus. De cette façon, vous économisez toutes les heures auparavant nécessaires pour effacer ou remplacer des objets, parfois image par image.

2_expression

Améliorations du modificateur d’expression

Le champ de modificateur d’expression du panneau Montage offre désormais une interface complète d’éditeur de code. Parcourez les expressions de manière visuelle avec des numéros de ligne, la mise en surbrillance des accolades correspondantes et la réduction du code. Personnalisez votre environnement de codage avec des thèmes de mise en surbrillance de la syntaxe. Identifiez et corrigez les problèmes avec les messages d’erreur en ligne et la mise en surbrillance des crochets correspondants.

3_performance_improvementcopy

Améliorations des performances

Prévisualisez votre travail rapidement au moyen de prévisualisations avec accélération matérielle à l’aide de Metal, OpenCL et CUDA. Profitez de délais de rendu plus courts en appliquant des effets GPU comme Contours bruts. Lorsque vous travaillez avec des Projets d’équipe, travaillez plus vite quand vous utilisez plusieurs éléments entre les membres de l’équipe.

4_guides_copy

Enregistrement des règles et repères à partager avec les éditeurs

Vous pouvez désormais charger et enregistrer des configurations de repères en vue de les réutiliser dans de nouveaux projets et de les partager avec les éditeurs Premiere Pro qui en ont besoin pour définir les paramètres de leur séquence.

5_font_1_

Synchronisation automatique des polices Adobe

Lorsque vous ouvrez dans After Effects un projet contenant une police manquante, si celle-ci est disponible sur Adobe Fonts dans le cadre de votre abonnement Creative Cloud, Creative Cloud synchronisera automatiquement la police.

6_video_audio

After Effects présente des améliorations de la prise en charge des formats Sony Camera Raw et RED, ainsi que du décodage HEVC avec accélération matérielle, dans le but de fournir de meilleures performances audio et vidéo.

7_pref

After Effects introduit de nouvelles préférences d’écran et de bouton d’accueil. Les préférences existantes associées aux scripts et expressions ont été déplacées du volet Préférences générales vers le nouveau panneau Scripts et expressions.

8_update_legacy

Un nouveau script Update Legacy Expressions.jsx est installé avec After Effects pour analyser la syntaxe héritée dans les expressions et la mettre à jour pour la rendre compatible avec le nouveau moteur d’expressions JavaScript.

9_frame_blending1

Lorsque vous activez ou désactivez la fusion d’images ou le flou de mouvement pour un calque, After Effects l’active ou le désactive automatiquement dans le panneau Montage.

10_scripting_changes

After Effects a ajouté plusieurs fonctionnalités de script aux fonctionnalités suivantes :

  • Noms et nombre des éléments du panneau Objets graphiques essentiels
  • Repères et règles
11_team_project

Grâce à une meilleure navigation de recherche et à la parité de l’IU de Projets d’équipe dans After Effects et Premiere Pro, vous pouvez gagner du temps et profiter de workflows dans Projets d’équipe.

12_more

Trouvez des informations sur les autres améliorations de cette version, telles que la commande Modifier l’original qui a été ajoutée au sous-menu Ouvrir du menu contextuel de calque.

Suppression des objets superflus de votre vidéo avec l’outil Remplissage d’après le contenu

Le remplissage d’après le contenu dans After Effects permet de réparer les trous créés dans la vidéo lors de la suppression de zones ou d’objets superflus. After Effects analyse les images au fil du temps pour remplir les pixels manquants en les extrayant d’autres images.

Supprimez les objets superflus d’un élément vidéo en créant un masque ou en découpant un objet et en cliquant sur Générer le calque de remplissage. Tirant parti d’une technologie de flux optique, After Effects référence les images avant, après ou à côté de l’objet et remplit le masque avec les pixels voisins ou les données d’image d’autres zones de la vidéo afin de donner l’apparence que l’objet n’était pas là en premier lieu.

Pour plus d’informations, voir Suppression d’objets de vos vidéos avec le remplissage d’après le contenu.

Améliorations du modificateur d’expression

Vous pouvez désormais écrire des expressions d’une manière plus rapide et facile. Le modificateur d’expression est un éditeur de code très complet qui offre la mise en surbrillance de la syntaxe, les numéros de ligne, de même que d’autres fonctionnalités comme la modification de la couleur du texte afin d’indiquer les effets ou les nombres, ou comme la modification de la taille de police pour une lisibilité accrue. En outre, il identifie automatiquement et instantanément les erreurs dans votre code de sorte que vous n’avez plus besoin de rechercher les erreurs vous-même. De plus, il remplit de façon automatique les expressions fréquemment utilisées. Grâce à ce nouvel éditeur, vous n’avez plus besoin d’utiliser un éditeur tiers pour écrire du code.

Pour plus d’informations, voir Améliorations du modificateur d’expression.

Améliorations des performances

Cette version présente les améliorations des performances suivantes :

After Effects utilise maintenant Metal, OpenCL ou CUDA au lieu d’OpenGL lorsque l’option Accélération matérielle pour les panneaux Composition, Calque et Métrage est activée dans Préférences > Affichage (préférence activée par défaut).

Lors de la lecture des prévisualisations, les zones de l’IU dans les panneaux Composition, Calque, Métrage et Montage s’actualisent moins souvent. Cela améliore les performances globales de lecture et résout des problèmes spécifiques où la lecture ne pouvait pas se produire en temps réel dans certaines situations.

Le rendu des effets suivants s’effectue désormais en utilisant le GPU de votre ordinateur lorsque l’option Paramètres du projet > Effets et rendu vidéo > Utiliser est définie sur Accélération GPU Mercury :

  • Correction colorimétrique
  • Contours bruts

Enregistrement des règles et repères à partager avec les éditeurs

Les lignes de repère dans les panneaux de visionneuse Composition, Calque et Métrage peuvent désormais être importées et exportées à l’aide des nouvelles commandes Importer les repères et Exporter les repères dans le menu Affichage.

Lorsque vous exportez des repères, l’application crée un fichier de modèle (.guides) pouvant être partagé ou importé dans différents projets ou dans une autre vue de composition, calque ou métrage. Un fichier de modèle de repères contient les données JSON qui enregistrent les attributs des repères. Lorsque vous effectuez une exportation, tous les repères dans la fenêtre active sont exportés.

Vous pouvez également importer des fichiers de repères créés par After Effects dans Premiere Pro 13.1 et inversement.

Synchronisation automatique des polices Adobe

Les abonnements Creative Cloud vous donnent accès à la bibliothèque Adobe Fonts complète. Les abonnements d’évaluation de Creative Cloud incluent la bibliothèque de base, qui comprend une sélection de polices pour le web et le bureau. Les polices tierces achetées sur Adobe Fonts ne sont pas automatiquement synchronisées.

Améliorations de la prise en charge de l’importation audio et vidéo

Améliorations de la prise en charge des formats Sony Camera Raw et RED

After Effects offre une meilleure prise en charge pour l’importation des fichiers vidéo aux formats Camera Raw suivants :

  • Les métrages RED (.r3d) peuvent désormais faire l’objet d’un dématriçage sur le GPU lorsque le projet est configuré pour utiliser l’accélération GPU Mercury (Metal) sous macOS. Auparavant, le dématriçage RED fonctionnait uniquement pour OpenCL et CUDA.
  • Les métrages Sony VENICE X-OCN (.mxf) enregistrés par des caméras VENICE avec la mise à jour de micrologiciel 2019 anticipée peuvent être importés.

Améliorations du décodage HEVC avec accélération matérielle

After Effects peut désormais décoder les métrages vidéo HEVC plus rapidement sous Windows. Le décodage avec accélération matérielle des métrages vidéo HEVC avec accélération matérielle sous Windows et macOS fonctionne maintenant également pour les fichiers HEVC de 10 bits par canal. Comme avec la prise en charge précédente des métrages H.264 ou HEVC de 8 bits par canal, le décodage avec accélération matérielle requiert Windows 10 ou macOS 10.13 et versions ultérieures ainsi qu’un processeur Intel avec Quick Sync Video.

Le décodage avec accélération matérielle des métrages vidéo HEVC et H.264 est activé par défaut. Pour désactiver le décodage avec accélération matérielle, ouvrez Préférences > Importer, puis désactivez l’option Activer le décodage matériel accéléré.

Modifications des préférences

Préférences de l’écran et du bouton d’accueil

Dans le panneau Préférences générales, l’option d’affichage de l’écran d’accueil lors du démarrage d’After Effects a été renommée Activer l’écran d’accueil. Elle reste activée par défaut. La désactivation de cette option masque désormais également le bouton Accueil dans le panneau Outils. Ces deux modifications prennent effet au prochain démarrage d’After Effects.

Scripts et expressions

Les préférences existantes suivantes associées aux scripts et expressions ont été déplacées du panneau Préférences générales vers le nouveau panneau Scripts et expressions :

  • Autoriser les scripts à écrire des fichiers et à accéder au réseau
  • Activer le débogage JavaScript
  • Écriture en anglais compact par l’icône de sélection d’expression
  • Afficher la bannière d’avertissement lorsque le projet contient des erreurs d’expression

Le panneau Scripts et expressions contient également des options associées exclusivement au nouveau modificateur d’expression. Pour plus d’informations, voir Améliorations du modificateur d’expression.

Script de mise à jour des expressions héritées

Un nouveau script, Update Legacy Expressions.jsx est installé avec After Effects. Il est disponible dans le menu Fichier > Scripts. Ce script recherche la syntaxe héritée dans les expressions et la met à jour pour la rendre compatible avec le moteur d’expressions JavaScript.

En particulier, ce script recherche dans les expressions des compositions, des calques ou des propriétés la syntaxe qui était fonctionnelle avec le moteur d’expressions ExtendScript hérité, mais qui n’est pas compatible avec le moteur d’expressions JavaScript et la modifie pour la rendre compatible :

  • Les instructions if…else sur une seule ligne sont modifiées pour inclure un saut de ligne avant l’instruction else.

  • Les blocs de fonction sont déplacés vers le haut de l’expression (la correspondance est effectuée par expression régulière).

  • Les références de forme courte « this layer » sont modifiées en thisLayer.
  • Les références array-index du texte source, par ex. sourceText[n], se voient ajouter le suffixe .value.
  • Les méthodes et les propriétés Snake_case sont remplacées par les équivalents en casse mixte (la correspondance est effectuée par des paires clé:valeur).

Activation et désactivation automatiques des options de composition de fusion d’images ou de flou de mouvement

Lorsque vous activez la fusion d’images ou le flou de mouvement pour un calque, les options de composition de fusion d’images et de flou de mouvement du panneau Montage sont désormais automatiquement activées (si elles étaient désactivées). Grâce à cette fonctionnalité, il n’est pas nécessaire de cliquer sur une deuxième option pour effectuer le rendu des prévisualisations de la fusion d’images ou du flou de mouvement. Vous pouvez toujours activer ou désactiver l’option de composition manuellement.

De même, lorsque vous désactivez la fusion d’images ou le flou de mouvement sur tous les calques, les options de compositions de fusion d’images et de flou de mouvement du panneau Montage sont désormais automatiquement désactivées (si elles étaient activées).

Pour restaurer le comportement précédent (les options de compositions ne sont pas automatiquement activées ni désactivées), désactivez la nouvelle option Activer automatiquement le rendu de la fusion d’images et du flou de mouvement dans Préférences > Prévisualisations.

Modifications des scripts

Cette version d’After Effects ajoute des capacités de script aux fonctionnalités suivantes :

  • Éléments et nombre du panneau Objets graphiques essentiels : vous pouvez désormais compter le nombre d’éléments dans le panneau Objets graphiques essentiels pour une composition donnée, obtenir ou définir les noms des éléments, ou définir le nom d’un élément lors de son ajout.
  • Repères et règles : vous pouvez à présent définir la visibilité des repères et des règles, ou activer ou désactiver le verrouillage et le magnétisme des repères dans les panneaux de visionneuses. Vous pouvez également ajouter, supprimer ou modifier la valeur des repères.

Améliorations des Projets d’équipe

  • La boîte de dialogue Gérer Projets d’équipe compte désormais un champ de recherche dans chacun des trois onglets.
  • Dans Premiere Pro, la commande Modifier l’original fonctionne désormais pour ouvrir une composition dans After Effects.
  • Dans Premiere Pro, la commande Fichier > Adobe Dynamic Link > Nouvelle composition After Effects fonctionne désormais pour créer une composition dans After Effects.

Autres fonctionnalités

  • Le sous-menu Faire apparaître a été ajouté au menu Calque. Ce menu est identique au sous-menu Faire apparaître du menu contextuel de calque (accessible en cliquant avec le bouton droit sur un calque dans le menu Montage). Désormais, vous pouvez également attribuer des raccourcis clavier aux commandes du sous-menu Faire apparaître, y compris Afficher la source du calque dans le projet.
  • La commande Modifier l’original a été ajoutée au sous-menu Ouvrir du menu contextuel de calque (accessible en cliquant avec le bouton droit sur un calque dans le menu Montage). Il s’agit de la même commande que dans le menu Modifier > Modifier l’original.
  • Dans l’effet Courbes, la courbe alpha est désormais représentée par un tracé discontinu au lieu d’un tracé plein de couleur noire, ce qui la fait ressortir davantage par rapport à la couleur d’arrière-plan de l’IU.
  • Plusieurs commandes dans le menu contextuel de calque de texte du menu Composition (accessible en cliquant avec le bouton droit sur un calque de texte avec l’outil Texte) fonctionnent maintenant lorsque plusieurs calques de texte sont sélectionnés : Convertir en texte de paragraphe ou Convertir en texte de point, Orientation horizontale ou verticale (tous les calques de texte sélectionnés doivent présenter la même orientation) et Afficher le texte source dans le montage.
  • Les fichiers JSX et JSXBIN peuvent désormais être sélectionnés en même temps dans les boîtes de dialogue Fichier > Scripts > Installer le fichier de script et Installer le panneau ScriptUI.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne