What's covered

  • Beginning and intermediate troubleshooting
  • Advanced troubleshooting

This document can help you resolve errors caused by damaged Adobe Illustrator files. A damaged Illustrator file may cause an error, such as "There is not enough memory to open the Illustration" or "Acrobat PDF File Format is having difficulties...," or cause other unexpected behavior (for example, crashes, objects failing to preview) when you modify, save, or print artwork in Illustrator.

To determine if a damaged file is the cause, create a new Illustrator file and perform the same tasks that caused the problem with the original file. If you cannot re-create the problem with the new file, the original file may be damaged.

An Illustrator file may become damaged because of low disk space, low system resources, or software conflicts. In addition, if the system returns an error, freezes, or crashes while an application is reading from or writing to disk, the open file can become damaged. Working with a file on a network or removable drive increases the likelihood of a communication error during the read/write process.

Beginning and intermediate troubleshooting

To repair a damaged file, create a backup copy of it on the local hard drive, and then complete one or more of the tasks in this section, in order.

1. Install the latest version of Illustrator.

Updates correct problems that are discovered after an application is released. By installing the latest update, you can minimize the possibility that the error is caused by a problem in the application itself. (To determine which version of Illustrator you're using, in Illustrator choose Help > About Illustrator.) The latest update for Illustrator is available from the Adobe website at www.adobe.com/support/downloads.

  • To locate an Authorized Reseller, visit the Adobe website at http://partners.adobe.com/resellerfinder/na/findreseller.jsp and choose your country or region from the menu at the top of the page.
  • To purchase an upgrade from Adobe, visit the Adobe Store at http://store.adobe.com/store and choose your country or region from the menu at the top of the page.
  • To contact Adobe Customer Service in your region for assistance, visit the Adobe website at www.adobe.com, select your region from the menu at the top of the page, and then click Contact Us

2. Copy the file to your hard drive.

If the file is on a network volume or removable disk (for example, diskette, Zip or Jaz disk), copy it to your hard drive and open it from there.

If you purchased Illustrator as part of the Adobe Creative Suite and need to store files on a network drive, install and configure the accompanying Version Cue software for saving files directly to a network. For more information on Version Cue, see the Adobe Creative Suite product page at www.adobe.com/products/creativesuite .

3. Place the damaged Illustrator file in a new Illustrator file.

Important: This solution doesn't work if you didn't select Create Compatible PDF File in the Illustrator Native Format Options dialog box when you saved the original file. On the Macintosh platform, the damaged Illustrator file may appear dimmed in the Place dialog box, but you will still be able to select it and place it in the new Illustrator file.

  1. In Illustrator, choose File > New.
  2. Select the appropriate size and color mode, and then click OK.
  3. Choose File > Place.
  4. In the Place dialog box, choose All Formats from the Files of Type pop-up menu (Windows) or choose All Documents from the Show pop-up menu (Mac OS), choose the damaged file, and then click Place.
  5. Name and save the file.

4. Copy artwork from a damaged file into a new file.

  1. Open the damaged file, and then choose Object > Path > Cleanup to remove unwanted items (for example, stray points, unpainted objects, empty text paths) from the artwork.
  2. If the original file contains multiple layers, choose Paste Remembers Layers from the Layers Panel pop-up menu to ensure the artwork appears on the same layers when you paste it into the new file.
  3. Using the Selection tool, drag a marquee around the artwork.
  4. Choose Edit > Copy.
  5. Choose File > New to create a new file.
  6. In the new file, choose Edit > Paste In Front to paste the artwork in the correct position on the page.
  7. Choose File > Save.

If the new file exhibits the same behavior, it may contain a damaged object. To determine whether an object is damaged, delete it from the new file, and then save and reopen the file and try to re-create the problem. Repeat for each object in the file.

When you can no longer re-create the problem, delete and re-create the damaged object in the original file:

  • If an Illustrator-drawn object is damaged, then re-create the object with the drawing tools in Illustrator.
  • If a linked image is damaged, then re-create the original image, and then replace it in your artwork.
  • If a text object is damaged, then convert the text object to outlines or change its font.

To quickly change all fonts in a document:

  1. Open the document in Illustrator and Choose Object > Unlock All.
  2. Choose Edit > Select All.
  3. Choose Type > Font, and select a font not currently used in the document.

Note: To prevent text objects from becoming damaged in the future, reinstall the problematic font from the original disk.

5. Delete unused swatches, custom colors, color groups, brushes, symbols, or styles.

Eliminate a problem caused by a damaged swatch, brush, symbol, or style by deleting unused swatches, custom colors, color groups (CS3 and later), brushes, symbols, or styles: Choose Select All Unused from the Swatches panel menu, from the Brushes panel menu, from the Symbols panel menu, and from the Styles panel menu, and then press Delete.

Advanced troubleshooting

The following elements can damage files: corrupt fonts, gradients, patterns, links, and objects (for example, text blocks, imported graphics, Illustrator-drawn graphics). If the tasks listed in the previous section don't resolve the problem, you may need to repair the file by using one of the following tasks.

Note: If you repair a damaged file using one of the following tasks, then you lose transparency and layer information.

6. Check for a damaged pattern, gradient, or custom color.

To determine if the problem is caused by a damaged pattern, gradient, or custom color:

  1. Choose Edit > Select All and change the fill and stroke to process black.
  2. Perform task 4 again to determine whether the problem occurs in a new file that does not contain the patterns, gradients, or spot colors. If the problem does not recur, re-create the pattern, gradient, or spot color in the original file.

7. Convert the file to an Adobe PDF file.

If the file is in EPS format, convert the file to PDF in Adobe Acrobat Distiller, and then open the PDF file in Illustrator.

8. Print the file to disk as a PostScript file.

Print the Illustrator file as a PostScript file, and then open the PostScript file in Illustrator.

Note: To perform this solution you must have a PostScript printer driver installed. For information on installing Postscript printers in Windows Vista and XP, please see the Windows Help Menus.

  1. Choose File > Print.
  2. Specify the desired print or output settings.
  3. Choose Adobe Postscript File from the Printer pop up menu, and then click Save.
  4. Type a filename that includes a .ps extension (for example, Filename.ps), and then click OK (Windows) or Save (Mac OS).
  5. Open the PostScript file in Illustrator.

9. Re-create the file in Illustrator.

Re-create the file in Illustrator after resaving or re-creating graphics, templates, and custom colors used in the original Illustrator file. Re-create all elements copied from other Illustrator files.

Additional Information

kb408008: Copy/Paste of artwork is very slow and/or includes large amounts of unused data, such as swatches (Illustrator CS4 and earlier)

311742: Creating Efficient Illustrator Files and Improving Print Performance

312896: Memory-Related PostScript Error ("VMerror," "limitcheck") Printing from Illustrator -- Troubleshooting Guide

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy