User Guide Cancel

Use objects as symbols for repeat use

  1. Illustrator User Guide
  2. Get to know Illustrator
    1. Introduction to Illustrator
      1. What's new in Illustrator
      2. Common questions
      3. Illustrator system requirements
      4. Illustrator for Apple silicon
    2. Workspace
      1. Workspace basics
      2. Learn faster with the Illustrator Discover panel
      3. Create documents
      4. Toolbar
      5. Default keyboard shortcuts
      6. Customize keyboard shortcuts
      7. Introduction to artboards
      8. Manage artboards
      9. Customize the workspace
      10. Properties panel
      11. Set preferences
      12. Touch Workspace
      13. Microsoft Surface Dial support in Illustrator
      14. Undo edits and manage design history
      15. Rotate view
      16. Rulers, grids, and guides
      17. Accessibility in Illustrator
      18. Safe Mode
      19. View artwork
      20. Use the Touch Bar with Illustrator
      21. Files and templates
    3. Tools in Illustrator
      1. Tools at a glance
      2. Select tools
        1. Selection
        2. Direct Selection
        3. Group Selection
        4. Magic Wand
        5. Lasso
        6. Artboard
      3. Navigate tools
        1. Hand
        2. Rotate View
        3. Zoom
      4. Paint tools
        1. Gradient
        2. Mesh
        3. Shape Builder
      5. Text tools
        1. Type
        2. Type on a Path
        3. Vertical Type
      6. Draw tools
        1. Pen
        2. Add Anchor Point
        3. Delete Anchor Point
        4. Anchor Point
        5. Curvature
        6. Line Segment
        7. Rectangle
        8. Rounded Rectangle
        9. Ellipse
        10. Polygon
        11. Star
        12. Paintbrush
        13. Blob Brush
        14. Pencil
        15. Shaper
        16. Slice
      7. Modify tools
        1. Rotate
        2. Reflect
        3. Scale
        4. Shear
        5. Width
        6. Free Transform
        7. Eyedropper
        8. Blend
        9. Eraser
        10. Scissors
        11. Dimension
    4. Generative AI (not available in mainland China)
      1. Generate a vector graphic using a text prompt
      2. Recolor your artwork using a text prompt
    5. Quick actions
      1. Retro text
      2. Neon glow text
      3. Old school text
      4. Recolor
      5. Convert sketch to vector
  3. Illustrator on the web (beta)
    1. Illustrator on the web (beta) overview
    2. Illustrator on the web (beta) FAQ
    3. Troubleshooting issues FAQ
    4. Keyboard shortcuts for Illustrator on the web (beta)
    5. Create and combine shapes on the web
    6. Add and edit text on the web
    7. Apply colors and gradients on the web
    8. Draw and edit paths on the web
    9. Work with cloud documents on the web
    10. Invite collaborators to edit on the web
  4. Illustrator on the iPad
    1. Introduction to Illustrator on the iPad
      1. Illustrator on the iPad overview
      2. Illustrator on the iPad FAQs
      3. System requirements | Illustrator on the iPad
      4. What you can or cannot do on Illustrator on the iPad
    2. Workspace
      1. Illustrator on the iPad workspace
      2. Touch shortcuts and gestures
      3. Keyboard shortcuts for Illustrator on the iPad
      4. Manage your app settings
    3. Documents
      1. Work with documents in Illustrator on the iPad
      2. Import Photoshop and Fresco documents
    4. Select and arrange objects
      1. Create repeat objects
      2. Blend objects
    5. Drawing
      1. Draw and edit paths
      2. Draw and edit shapes
    6. Type
      1. Work with type and fonts
      2. Create text designs along a path
      3. Add your own fonts
    7. Work with images
      1. Vectorize raster images
    8. Color
      1. Apply colors and gradients
  5. Cloud documents
    1. Basics
      1. Work with Illustrator cloud documents
      2. Share and collaborate on Illustrator cloud documents
      3. Share documents for review
      4. Upgrade cloud storage for Adobe Illustrator
      5. Illustrator cloud documents | Common questions
    2. Troubleshooting
      1. Troubleshoot create or save issues for Illustrator cloud documents
      2. Troubleshoot Illustrator cloud documents issues
  6. Add and edit content
    1. Drawing and dimensioning
      1. Drawing basics
      2. Edit paths
      3. Draw pixel-perfect art
      4. Draw with the Pen, Curvature, or Pencil tool
      5. Draw simple lines and shapes
      6. Draw rectangular and polar grids
      7. Draw and edit flares
      8. Image Trace
      9. Simplify a path
      10. Symbolism tools and symbol sets
      11. Adjust path segments
      12. Design a flower in 5 easy steps
      13. Create and edit a perspective grid
      14. Draw and modify objects on a perspective grid
      15. Use objects as symbols for repeat use
      16. Draw pixel-aligned paths for web workflows
      17. Measure and plot dimensions
    2. 3D objects and materials
      1. About 3D effects in Illustrator
      2. Create 3D graphics
      3. Map artwork over 3D objects
      4. Create 3D Text
      5. Create 3D objects
    3. Color
      1. About color
      2. Select colors
      3. Use and create swatches
      4. Adjust colors
      5. Use the Adobe Color Themes panel
      6. Color groups (harmonies)
      7. Color Themes panel
      8. Recolor your artwork
    4. Painting
      1. About painting
      2. Paint with fills and strokes
      3. Live Paint groups
      4. Gradients
      5. Brushes
      6. Transparency and blending modes
      7. Apply stroke on an object
      8. Create and edit patterns
      9. Meshes
      10. Patterns
    5. Select and arrange objects
      1. Select objects
      2. Layers
      3. Group and expand objects
      4. Move, align, and distribute objects
      5. Stack objects    
      6. Lock, hide, and delete objects
      7. Copy and duplicate objects
      8. Rotate and reflect objects
      9. Intertwine objects
      10. Create realistic art mockups
    6. Reshape objects
      1. Crop images
      2. Transform objects
      3. Combine objects
      4. Cut, divide, and trim objects
      5. Puppet Warp
      6. Scale, shear, and distort objects
      7. Blend objects
      8. Reshape using envelopes
      9. Reshape objects with effects
      10. Build new shapes with Shaper and Shape Builder tools
      11. Work with Live Corners
      12. Enhanced reshape workflows with touch support
      13. Edit clipping masks
      14. Live shapes
      15. Create shapes using the Shape Builder tool
      16. Global editing
    7. Type
      1. Add text and work with type objects
      2. Create bulleted and numbered lists
      3. Manage text area
      4. Fonts and typography
      5. Convert text within images into editable text
      6. Add basic formatting to text
      7. Add advanced formatting to text
      8. Import and export text
      9. Format paragraphs
      10. Special characters
      11. Create type on a path
      12. Character and paragraph styles
      13. Tabs
      14. Find missing fonts (Typekit workflow)
      15. Arabic and Hebrew type
      16. Fonts | FAQ and troubleshooting tips
      17. Create 3D text effect
      18. Creative typography designs
      19. Scale and rotate type
      20. Line and character spacing
      21. Hyphenation and line breaks
      22. Spelling and language dictionaries
      23. Format Asian characters
      24. Composers for Asian scripts
      25. Create text designs with blend objects
      26. Create a text poster using Image Trace
    8. Create special effects
      1. Work with effects
      2. Graphic styles
      3. Appearance attributes
      4. Create sketches and mosaics
      5. Drop shadows, glows, and feathering
      6. Summary of effects
    9. Web graphics
      1. Best practices for creating web graphics
      2. Graphs
      3. SVG
      4. Slices and image maps
  7. Import, export, and save
    1. Import
      1. Place multiple files
      2. Manage linked and embedded files
      3. Links information
      4. Unembed images
      5. Import artwork from Photoshop
      6. Import bitmap images
      7. Import Adobe PDF files
      8. Import EPS, DCS, and AutoCAD files
    2. Creative Cloud Libraries in Illustrator 
      1. Creative Cloud Libraries in Illustrator
    3. Save
      1. Save artwork
    4. Export
      1. Use Illustrator artwork in Photoshop
      2. Export artwork
      3. Collect assets and export in batches
      4. Package files
      5. Create Adobe PDF files
      6. Extract CSS | Illustrator CC
      7. Adobe PDF options
      8. Document info panel
  8. Printing
    1. Prepare for printing
      1. Set up documents for printing
      2. Change the page size and orientation
      3. Specify crop marks for trimming or aligning
      4. Get started with large canvas
    2. Printing
      1. Overprint
      2. Print with color management
      3. PostScript printing
      4. Print presets
      5. Printer's marks and bleeds
      6. Print and save transparent artwork
      7. Trapping
      8. Print color separations
      9. Print gradients, meshes, and color blends
      10. White Overprint
  9. Automate tasks
    1. Data merge using the Variables panel
    2. Automation with scripts
    3. Automation with actions
  10. Troubleshooting 
    1. Known issues
    2. Crash issues
    3. Recover files after crash
    4. File issues
    5. Supported file formats
    6. GPU device driver issues
    7. Wacom device issues
    8. DLL file issues
    9. Memory issues
    10. Preferences file issues
    11. Font issues
    12. Printer issues
    13. Share crash report with Adobe
    14. Improve Illustrator performance

Convert the objects you reuse in a document into symbols, and use a variety of preset symbols to save time and reduce file size.

Symbols allow you to create reusable graphic elements. You have the flexibility to create symbols from a wide range of objects, including shapes, paths, text, mesh objects, and even raster images.

Furthermore, dynamic symbols allow each symbol instance to have a unique appearance while sharing a common base shape. Changes made to the base shape are applied automatically to each instance while maintaining their unique appearance.

Adobe Illustrator deeplink

Try it in the app
You'll get a sample file to follow along with as you learn how to use the Symbols panel.

Explore the Symbols panel

Before starting with symbols, familiarize yourself with the Symbols panel (Window > Symbols). The Symbols panel lets you create and manage symbols in your document. The Symbols panel contains both preset symbols and any symbols you create. You can also add more symbols from libraries to the Symbols panel.

Use preset symbols from symbol libraries

After selecting Symbol Libraries Menu, Arrows symbol library is opened.
Add preset symbols from symbol libraries to the Symbols panel.

Symbol libraries are collections of preset symbols. To open a symbol library, select Symbol Libraries Menu on the Symbols panel, and then select a library from the list. To add a symbol from a library to the Symbols panel, select the symbol.

You can sort and view items in a symbol library like in the Symbols panel. However, you can’t add items to, delete items from, or edit the items in a symbol library. To automatically open a library when you start Illustrator, select Persistent from the library’s panel menu.

Create a custom symbol library

  1. Add all the required symbols from libraries to the Symbols panel. To add multiple symbols from a library to the Symbols panel, Shift-select the symbols and then select Add to Symbols from the library menu.

  2. From the Symbols panel, delete any symbols you don’t want in the new library. Select the unwanted symbols and then select Delete Symbol in the Symbols panel. 

    To delete all symbols not used in your document, select Select All Unused from the Symbols panel menu, and then select Delete Symbol.

  3. Select Save Symbol Library from the Symbols panel menu, and save the new library to the default Symbols folder. Once created, the library name automatically appears in the User Defined menu of the symbol libraries list.

  4. If you saved the new library to a folder other than the default Symbols folder, you can open it by selecting Other Library from the symbol libraries list. Once you open it, it appears in the symbol libraries list.

Import a symbol library from another document

  1. Select Other Library from the symbol libraries list.

  2. Select the file from which you want to import symbols, and then select Open.

    The library appears in the symbol libraries list.

Place a symbol in the artwork

  1. Select a symbol in the Symbols panel or a symbol library.

  2. Drag the symbol to the artboard where you want it to appear.

A symbol placed anywhere in your artwork is called a symbol instance.

Create a symbol

Drag an object to the Symbols panel to create a symbol.

  1. Select the object you want to use as a symbol.

  2. Drag the object to the Symbols panel. 

    By default, the selected object becomes an instance of the new symbol. If you don’t want the object to become an instance, press Shift as you drag the artwork.

  3. In the Symbol Options dialog box, do the following:

    If you don’t want the Symbol Options dialog to appear when you create a new symbol, press Alt (Windows) or Option (macOS) and drag the object on to the New Symbol   icon in the Symbols panel. Illustrator will use a default name for the symbol, such as New Symbol 1.

In the Symbols panel, dynamic symbols appear with a small plus symbol in their lower-right corner.

Current limitations

  • You cannot create a symbol from linked art or some groups such as groups of graphs.
  • When creating dynamic symbols, you can't include text, placed images, or mesh objects.

Edit or redefine a symbol

You can edit a symbol by modifying the symbol’s artwork or you can redefine the symbol by replacing it with new artwork. Editing or redefining a symbol changes its appearance in the Symbols panel, as well as all instances of the symbol on the artboard.

Edit a symbol

  1. Double-click an instance of the symbol and select Ok to open the symbol in isolation mode.

  2. Edit the object.

  3. Exit the isolation mode by selecting  in the upper-left corner of the workspace.

Redefine a symbol with another object

  1. Select the object that you want to use to redefine an existing symbol. Make sure to select an original object and not a symbol instance.

  2. In the Symbols panel, select the symbol you want to redefine, and then select Redefine Symbol from the panel menu.

The selected object automatically becomes an instance of the symbol. If you don’t want the selected object to become a symbol instance, press Shift as you select Redefine Symbol from the panel menu.

Transform and modify symbol instances

You can transform (move, scale, rotate, shear, or reflect) symbol instances the same way you can transform other objects. You can also perform any operation from the Transparency, Appearance, and Graphic Styles panels and apply any effect from the Effect menu. However, if you want to modify the individual components of a symbol instance, you must first expand it. When you expand a symbol instance, you break the link between the symbol and the symbol instance and convert the instance to a regular object. If you open a dynamic symbol in an older version of Illustrator, the symbol expands.

Expand and modify a symbol instance

After you expand and modify a symbol instance, you can redefine the original symbol in the Symbols panel. When you redefine a symbol, all existing symbol instances follow the new definition.

  1. Select the symbol instance.

  2. Select Break Link To Symbol in the Symbols panel to expand the symbol instance. The symbol instance turns into a regular object.

  3. Modify the object.

  4. Replace the parent symbol with the modified version or create a new symbol:

    • To replace the parent symbol with the modified version, Alt‑drag (Windows) or Option‑drag (macOS) the modified object on top of the parent symbol in the Symbols panel.

    • To create a new symbol, drag the modified object to the Symbols panel.

Use registration point as reference to transform symbol instances

A house with a registration point in its upper right.
Use registration point as reference to scale, move, rotate, or reflect symbol instances.

When you create a symbol, you can select one of the nine registration points as a reference to transform symbol instances. A registration point appears as a crosshair in isolation mode, and in normal mode when you select a symbol instance. In isolation mode, you can move the symbol relative to the registration point.

In the Transform panel menu (Window> Transform), select Use Registration Point for Symbol to enable transformations of symbol instances based on the specified registration point. If you don't select this option, transformations of symbol instances will be instead based on the regular Reference Point. Once enabled, you can view the coordinates of the registration point in the Transform panel when you select a symbol instance.

Use the Reset Transformation option to reset the transformations applied to a symbol.

Reset transformations

To reset any transformations (move, scale, rotate, shear, or reflect) to symbols, select the symbol and then select Reset in the Control panel.

Note:

When a symbol is placed in perspective, the options to replace a symbol instance with a different symbol, break the link with the parent symbol, and reset transformations are disabled.

Replace a symbol instance with a different symbol

  1. Select the symbol instance on the artboard.

  2. Select a new symbol from the Replace menu in the Control panel.

To select all symbol instances in a document, select a symbol in the Symbols panel, and then select Select All Instances from the panel menu.

Maintain proportions while scaling using 9-slice guides 

When you enable the 9-slice guides, four grid lines (two horizontal and two vertical) conceptually divide the symbol into nine sections. When you scale the symbol, the parts of the symbol that don't lie within the guides are not scaled.

Enable 9-slice guides

  1. Select the symbol in the Symbols panel and then select Symbol Options from the panel menu.

  2. In the Symbol Options dialog box, select Enable Guides For 9‑Slice Scaling.

Adjust the 9-slice scaling guides

  1. Double-click the symbol instance on the artboard to open the isolation mode.

  2. Move the pointer over any of the four guides. When the pointer changes to the move pointer, drag the guide.

  3. Exit the isolation mode by selecting  in the upper-left corner of the workspace.

Talk to us

If you have a question to ask or an idea to share, come and participate in Adobe Illustrator Community. We'd love to hear from you.

More like this

 Adobe

Get help faster and easier

New user?

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online