To organize and lay out your artwork, you use tools for selecting, positioning, and stacking objects precisely. You can measure and align objects; group objects so that they are treated as a single unit; and selectively isolate, lock, or hide objects.

Selection options and preferences

Options for selecting objects

Before you can modify an object, you need to distinguish it from the objects around it. You do that by selecting the object. Once you’ve selected an object, or a part of an object, you can edit it.

Illustrator provides the following selection methods and tools:

Isolation mode

Lets you quickly isolate a layer, sublayer, path, or group of objects, from all other art in your document. When in isolation mode, all nonisolated objects in the document appear dimmed and are not selectable or editable.

Layers panel

Lets you quickly and precisely select individual or multiple objects. You can select a single object (even if it’s in a group), all objects within a layer, and entire groups.

Selection tool

  Lets you select objects and groups by clicking or dragging over them. You can also select groups within groups and objects within groups.

Direct Selection tool

Lets you select individual anchor points or path segments by clicking on them, or select an entire path or group by selecting any other spot on the item. You can also select one or more objects in a group of objects.

note: When in outline mode, the Direct Selection tool may select imported graphics that are near the tool’s pointer. To avoid selecting unwanted graphics, lock or hide the graphics before making the selection.

Group Selection tool

Lets you select an object within a group, a single group within multiple groups, or a set of groups within the artwork. Each additional click adds all objects from the next group in the hierarchy.

Perspective Selection tool

Lets you bring objects and text in perspective, switch active planes, move objects in perspective, and move objects in perpendicular direction.

Lasso tool

Lets you select objects, anchor points, or path segments by dragging around all or part of the object.

Magic Wand tool

Lets you select objects of the same color, stroke weight, stroke color, opacity, or blending mode by clicking the object.

Live Paint Selection tool

Lets you select faces (areas enclosed by paths) and edges (portions of paths between intersections) of Live Paint groups.

Selection commands

(located in the Select menu) Let you quickly select or deselect all objects, and select objects based on their position relative to other objects. You can select all objects of a specific type or that share specific attributes, and save or load selections. You can also select all objects in the active artboard.

Note:

To temporarily activate the last-used selection tool (Selection tool, Direct-Selection tool, or Group Selection tool) when using another type of tool, hold down Ctrl (Windows) or Command (Mac OS).

Specify selection preferences

Selecting paths and points in complex images can be challenging. Using the Selection and Anchor Display preferences, you can specify the tolerance for pixel selection and choose other options that can make selection easier for a particular document.

  1. Choose Edit > Preferences > Selection & Anchor Display (Windows) or Illustrator > Preferences > Selection & Anchor Display (Mac OS).

  2. Specify any of the following Selection options:

    Tolerance

    Specifies the pixel range for selecting anchor points. Higher values increase the width of the area around an anchor point that you can click to select it.

    Object Selection By Path Only

    Specifies whether you can select a filled object by clicking anywhere in the object or whether you have to click a path.

    Snap To Point

    Snaps objects to anchor points and guides. Specify the distance between the object and anchor point or guide when the snap occurs.

Isolate artwork for editing

Isolation mode isolates objects so that you can easily select and edit particular objects or parts of objects. You can isolate any of the following: layers, sublayers, groups, symbols, clipping masks, compound paths, gradient meshes, and paths.

In Isolation mode, you can delete, replace, and add new art relative to the isolated art. As soon as you exit isolation mode, replaced or new art is added at the same location as the original isolated art. Isolation mode automatically locks all other objects so that only the objects in isolation mode are affected by the edits you make— you don’t need to worry about what layer an object is on, nor do you need to manually lock or hide the objects you don’t want affected by your edits.

Note:

When you edit a symbol’s definition, the symbol appears in isolation mode. (See Edit or redefine a symbol.)

Isolate Artwork
Isolating the butterfly group

When isolation mode is active, the isolated object appears in full color, while the rest of the artwork appears dimmed. The isolated object’s name and location (sometimes referred to as bread crumbs) appears in the isolation mode border, and the Layers panel displays only the artwork in the isolated sublayer or group. When you exit isolation mode, the other layers and groups reappear in the Layers panel.

You can view isolated objects in outline mode or preview mode.

See the video Use isolation mode to isolate artwork for editing.

Isolate a path, object, or group

  • Do one of the following:

    • Double-click the path or group using the Selection tool.

    • Select the group, object, or path and click the Isolate Selected Object button  in the Control panel.

    • Right-click (Windows) or Control-click (Mac OS) the group and choose Isolate Selected Group.

    • Right-click (Windows) or Control-click (Mac OS) the path and choose Isolate Selected Path.

    • Select the group, object, or path in the Layers panel and choose Enter Isolation Mode from the Layers panel menu or click the Isolate Selected Object button in the Control panel.

Isolate a path inside a group

  1. Select the path by using the Direct-Selection tool or by targeting it in the Layers panel.

  2. Click the Isolate Selected Object button  in the Control panel.

Isolate a layer or sublayer

  • Select the layer or sublayer in the Layers panel, and choose Enter Isolation Mode from the Layers panel menu.

Exit isolation mode

  • Do one of the following:

    • Press Esc.

    • Click the Exit Isolation Mode button  one or more times (if you’ve isolated a sublayer, one click takes you back a level, two clicks exits isolation mode).

    • Click anywhere in the isolation mode bar.

    • Click the Exit Isolation Mode button  in the Control panel.

    • Using the Selection tool, double-click outside of the isolated group.

    • Right-click (Windows) or Control-click (Mac OS) and choose Exit Isolation Mode.

Select behind objects

In Illustrator CS5, you can select objects that lie underneath other objects using Ctrl+click (Windows) or Command+click (Mac OS). The pointer changes to Select Behind on the first Ctrl+click (Windows) or Command+click (Mac OS). On subsequent usage of Ctrl+click (Windows) or Command+click (Mac OS), the selection iterates through the objects directly underneath the pointer position.

Note:

To enable or disable this option, click Edit > Preferences > Selection and Anchor Display (Windows) or Illustrator > Preferences > Selection and Anchor Display (Mac OS). Then select the Control Click to Select Object Behind (Windows) or Command Click to Select Objects Behind (Mac OS) check box in the Selection area.

Select the next object in the stacking order

You can select an object above or below a selected object in the stacking order. These commands do not work when in isolation mode.

  • To select the nearest object above or below the selected object, choose Select > Next Object Above or Select > Next Object Below.

Select objects using the Layers panel

  1. In the Layers panel, locate the object you want to select. You may have to click a toggle arrow to expand a layer or group, or scroll up or down in the panel to locate the object.

  2. Do any of the following:

    • To select individual objects, click in the object’s selection column (between the target button and the scroll bar). Shift-click to add or to remove objects from the selection.

    • To select all artwork in a layer or group, click in the layer’s or group’s selection column.

    • To select all artwork in a layer based on the currently selected artwork, choose Select > Object > All On Same Layers.

      Selection color boxes appear next to each selected item in the panel.

Select an object with the Selection, Lasso, or Magic Wand tool

Select objects with the Selection tool

  1. Select the Selection tool .

  2. Do either of the following:

    • Click an object.

    • Drag a marquee around part or all of one or more objects.

  3. To add or remove objects from the selection, hold down Shift and click or drag around the objects you want to add or remove.

    Tip: When the Selection tool is over an unselected object or group, it changes to . When it is over a selected object or group, the tool changes to  . When it is over an anchor point on an unselected object, a hollow square appears next to the arrow .

    Selecting objects
    Dragging over objects to select them

Select objects with the Lasso tool

  1. Select the Lasso tool .

  2. Drag around or across the objects.

Select objects with the Magic Wand tool

Use the Magic Wand tool to select all objects in a document with the same or similar fill attributes (such as color and pattern).

You can customize the Magic Wand tool to select objects based on stroke weight, stroke color, opacity, or blending mode. You can also change the tolerances used by the Magic Wand tool to identify similar objects.

Select objects based on fill color with the Magic Wand tool

  1. Select the Magic Wand tool .

  2. Do one of the following:

    • To create a new selection, click the object containing the attributes you want to select. All objects with the same attributes that were clicked are selected.

    • To add to the current selection, press Shift and click another object containing the attributes you want to add. All objects with the same attributes that were clicked are also selected.

    • To subtract from the current selection, press Alt (Windows) or Option (Mac OS) and click the object containing the attributes you want to subtract. All objects with the same attributes are removed from the selection.

Customize the Magic Wand tool

  1. Do one of the following to open the Magic Wand panel:

    • Double-click the Magic Wand tool in the Tools panel.

    • Choose Window > Magic Wand.

  2. To select objects according to their fill color, select Fill Color, and then enter a Tolerance value between 0 and 255 pixels for RGB or 0 and 100 pixels for CMYK.

    Low tolerance values select objects that are very similar to the object you click; higher tolerance values select objects with a broader range of the selected property.

  3. Choose Show Stroke Options from the Magic Wand panel menu, and do any of the following:

    • To select objects according to their stroke color, select Stroke Color, and then enter a Tolerance value between 0 and 255 pixels for RGB or 0 and 100 pixels for CMYK.

    • To select objects according to their stroke weight, select Stroke Weight, and then enter a Tolerance value between 0 and 1000 points.

  4. Choose Show Transparency Options from the Magic Wand panel menu and do any of the following:

    • To select objects according to their transparency or blending mode, select Opacity, and then enter a Tolerance value between 0 and 100%.

    • To select objects according to their blending mode, select Blending Mode.

Select filled objects

The Object Selection By Path Only preference determines whether you can select a filled object by clicking anywhere within the object’s area with the Selection or Direct Selection tools, or whether you must click a path segment or anchor point with these tools. By default, this preference is off. In some cases, you may want to turn the preference on—for example, when you work with overlapping filled objects and you want to easily select underlying objects.

Note:

The Object Selection By Path Only preference is not applicable when selecting unfilled objects or when viewing artwork as outlines. In these cases, you can never select an object by clicking inside the object’s path. (See View artwork as outlines.)

With Object Selection By Path Only deselected, clicking inside the object and dragging selects and moves an object.
With Object Selection By Path Only deselected, clicking inside the object and dragging selects and moves an object.

With Object Selection By Path Only selected, dragging with the Direct Selection tool selects points and segments within a marquee.
With Object Selection By Path Only selected, dragging with the Direct Selection tool selects points and segments within a marquee.

  • Choose Edit > Preferences > Selection & Anchor Display (Windows) or Illustrator > Preferences > Selection & Anchor Display (Mac OS), and select Object Selection By Path Only.

Select groups and objects in a group

Once objects are grouped, selecting any part of the group with the Selection tool or the Lasso tool selects the entire group. If you are unsure whether an object is a part of a group, select it with the Selection tool.

The Direct-Selection tool and Lasso tool let you select a single path or object that is part of one group or several groups. If you have groups of objects within other groups, you can select the next group in the grouping hierarchy by using the Group-Selection tool. Each successive click adds another subset of grouped objects to the selection.

Select one or more groups with the Selection tool

  1. Select the Selection tool .

  2. Do one of the following to any object that’s within the group:

    • Click the object.

    • Drag around part or all of the object.

  3. To add or remove a group to the selection, hold down Shift while clicking the group to add or remove.

Select objects and groups within groups with the Selection tool

  1. Select the Selection tool .

  2. Double-click a group. The group appears in isolation mode.

  3. Do any of the following:

    • Double-click to select further down into the group structure.

      Tip: Double-clicking is a handy way to select objects (as opposed to faces and edges) within a Live Paint group.

    • Click to select an object within the selected group.

    • Draw to add an object to the selected group.

  4. Double-click outside the group to deselect the group.

Select a single object within a group

  1. Do one of the following:

    • Select the Group Selection tool , and click the object.

    • Select the Lasso tool , and drag around or across the object’s path.

    • Select the Direct Selection tool , and click within the object, or drag a marquee around part or all of the object’s path.

  2. To add or remove an object or group to or from the selection (with any selection tool), hold down Shift and select the object to add or remove.

Select objects and groups with the Group Selection tool

  1. Select the Group Selection tool , and click an object that’s within the group you want to select. The object is selected.

  2. To select the object’s parent group, click the same object again.

  3. Click the same object again to select additional groups that are grouped with the selected group until you have selected everything you want to include in your selection.

    Group selection
    The first click with the Group Selection tool selects an object in a group (left); the second click selects the object’s group (right).

    Group selection
    The third click adds the next group to the selection (left); the fourth click adds the third group (right).

Select faces and edges in a Live Paint group

You select faces and edges of a Live Paint tool using the Live Paint Selection tool. If you want to select the entire Live Paint group, simply click it with the Selection tool.

  1. Select the Live Paint Selection tool .

  2. Move the tool over the Live Paint group until the face or edge you want to select is highlighted. (When the Live Paint Selection tool is over an edge, the tool changes to .)

  3. Do any of the following:

    • Click to select the highlighted face or edge.

    • Drag a marquee around multiple faces or edges. Any face or edge that is fully or partially enclosed by the marquee is included in the selection.

    • Double-click a face or edge to select all connected faces/edges of the same color (flood select).

    • Triple-click a face or edge to select all faces/edges of the same color (select same).

      Tip: If you have difficulty selecting a small face or edge, magnify the view or set the Live Paint Selection tool options to select only fills or strokes.

  4. To add or remove faces and edges from the selection, hold down Shift and click the faces/edges you want to add or remove.

    Note:

    To switch to the Eyedropper tool and sample fills and strokes, Alt‑click (Windows) or Option‑click (Mac OS) the fill and stroke you want.

Live Paint Selection tool options

You access the Live Paint selection tool options by double-clicking the tool in the Tools panel.

Select Fills

Selects the faces (the area within edges) of Live Paint groups.

Select Strokes

Selects the edges of Live Paint groups.

Highlight

Outlines the face or edge the cursor is currently over.

Color

Sets the color for the highlight. You can choose a color from the menu or click the paint swatch to specify a custom color.

Width

Specifies how thick to make the selection highlight.

Select objects by characteristic

You can select objects based on various groupings, including by formatting attribute, by layer, or by kind, such as brush strokes or clipping masks.

  1. To select all objects in a file, choose Select > All. (To deselect all objects, choose Select > Deselect.)

    Note:

    Using any selection tool, you can also deselect all objects by clicking or dragging at least 2 pixels away from any object.

  2. To select all objects with the same attributes, select one with the attribute you want, choose Select > Same, and then choose an attribute from the list: Blending Mode, Fill & Stroke, Fill Color, Opacity, Stroke Color, Stroke Weight, Style, Symbol Instance, or Link Block Series.

    Link Block Series automatically selects threaded text boxes. You can select one of the text boxes and then use this command to select all the other text boxes linked to that one. For more information see Threading text between objects.

    Note:

    You can also use the Magic Wand tool to select all objects with the same color, stroke weight, stroke color, opacity, or blending mode.

  3. To select all objects of a certain kind, deselect all artwork, choose Select > Object, and then choose an object type (Brush Strokes, Clipping Masks, Stray Points, or Text Objects).

Repeat, invert, or save a selection

Repeat or invert a selection

  • To repeat the last selection command used, choose Select > Reselect.

  • To select all unselected objects, and deselect all selected objects, choose Select > Inverse.

Save a selection

  1. Select one or more objects, and choose Select > Save Selection.

  2. In the Save Selection dialog box, type a name in the Name text box, and click OK.

    You can reload a saved selection by choosing the selection name from the bottom of the Select menu. You can also delete or rename a selection by choosing Select > Edit Selection.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy