Learn how you can migrate presets, actions, plug-ins, preferences, and settings while upgrading to a new version of Photoshop or installing Photoshop on a different computer.

Presets, settings, and actions

Presets are collections of items and values that are applied to artwork in Photoshop. You can save and load presets, or replace them with custom values at any time. Actions, brushes, and keyboard shortcuts are examples of presets. Photoshop comes with presets, but you can also create your own.

Settings are actual values that are currently loaded in Photoshop. They control various elements and tools in the application, such as your current brush and all its values.

Actions are series of tasks that you play back on a single file or a batch of files—menu commands, panel options, tool actions, and so on. For example, an action can change the size of an image, apply an effect to that image, and then saves the file in the desired format.

Migrate presets

You can migrate your custom preset collections, as well as some Photoshop presets, from one version of Photoshop to another on the same computer. The presets you can migrate include:

  • Actions
  • Brushes
  • Black and White (Adjustment)
  • Channel Mixer (Adjustment)
  • Color Range
  • Color Swatches
  • Contours
  • Curves (Adjustment)
  • Custom Shapes
  • Doutone (Mono, Duo, Tri, Quad)
  • Exposure (Adjustment)
  • Gradients
  • HDR Toning (Adjustment)
  • Hue and Saturation (Adjustment)
  • Keyboard Shortcuts
  • Levels (Adjustment)
  • Lighting Effects
  • Lights (3D)
  • Materials (3D)
  • Menu Customization
  • Patterns
  • Render Settings (3D)
  • Repousse (3D)
  • Selective Color (Adjustment)
  • Styles
  • Tools
  • Volumes (3D)

Migrate presets while updating Photoshop

By default, when you update to the latest version of Photoshop CC using the Creative Cloud desktop app, your presets, settings, and preferences are migrated from the earlier version of Photoshop. Also, when you launch Photoshop for the first time, you're prompted to migrate all available presets from the most recent version of Photoshop installed on your computer. 

Presets can be migrated from the latest version installed before Photoshop CC, going back to Photoshop CS3. To migrate from multiple versions of Photoshop, migrate presets sequentially from one version of Photoshop at a time.

Note:

You can, however, choose not to migrate them by deselecting Advanced Options > Import Previous Version Settings And Preferences on the confirmation screen that appears after you click Update in the Creative Cloud desktop app.

update_v1
The Creative Cloud desktop app
advanced-options
Advanced options available after you click Update in the Creative Cloud desktop app

Migrate presets after installing/updating Photoshop

If you chose not to migrate your presets when you updated Photoshop CC, or if you faced issues while migrating presets, you can select Edit > Presets > Migrate Presets to migrate presets, settings, and preferences later in Photoshop. Photoshop looks for an older version of Photoshop on the same system and prompts you to migrate presets.

Export and import presets

You can bring your presets from one computer to another, or to an offline computer, by manually exporting them and then importing. The Export/Import Presets is not restricted to computers running Photoshop as part of Creative Cloud.

SOURCE COMPUTER: On the computer that has the presets you want to migrate, do the following:

  1. Open Photoshop.
  2. Choose Edit > Presets > Export/Import Presets.
  3. Choose Export Presets.
  4. Select the desired presets and move them to the Presets To Export column.
  5. Click Export Presets.
  6. Select the folder to export your presets to. Choose a folder you can use to transfer the files using a USB drive, network, or an online sharing service.
  7. Click OK.

TARGET COMPUTER: On the computer receiving the imported settings, do the following:

  1. Choose Edit > Presets > Export/Import Presets.
  2. Select Import Presets.
  3. Select the presets you want to import, or click Add All.
  4. If you saved your presets to a folder that is not the default, choose Select Import Folder, and select the appropriate folder.
  5. Click Import Presets.

Save and load presets

You can move actions and presets across different versions of Photoshop on same or different desktops by saving them and loading them into the target application.

SOURCE COMPUTER: On the computer that has the presets you want to migrate, do the following:

  1. Open Photoshop.
  2. Choose Edit > Presets > Presets Manager.
  3. Choose the desired option from the Preset Type drop-down menu. For example, choose Brushes.
  4. Select the desired presets. For example, select the brushes that you want to migrate.
  5. Click Save Set and then, click Save. For a set of Brushes, then Photoshop creates a .ABR file at the following location by default:
  • (Windows) C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop CC*<version>\Presets\Brushes
  • (macOS) Applications/Adobe Photoshop <version>/Presets/Brushes

TARGET COMPUTER: On the computer receiving the imported settings, do the following:

  1. Choose Edit > Presets > Presets Manager.
  2. Click Load in the Presets Manager dialog box.
  3. Select the saved set you want to load.
  4. Click Load.

Migrate actions

Manually copy settings

Photoshop has a number of setting files that you can manually copy from one installation to another. These files include:

  • Actions Palette.psp
  • Brushes.psp
  • Contours.psp
  • CustomShapes.psp
  • Default Type Styles.psp
  • Gradients.psp
  • Patterns.psp
  • Styles.psp
  • Swatches.psp
  • ToolPresets.psp

To move these settings to a new installation, copy these files from the following path on the source installation to the same path on the target installation:

  • Mac: <Username>/Library/Preferences/Adobe Photoshop CC*<version> Settings
  • Windows: C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop CC*<version>\Adobe Photoshop CC*version Settings

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy