Create layers and groups

A new layer appears either above the selected layer or within the selected group in the Layers panel.

Create a new layer or group

  1. Do one of the following:

    • To create a new layer or group using default options, click the Create A New Layer button  or New Group button  in the Layers panel.

    • Choose Layer > New > Layer or choose Layer > New > Group.

    • Choose New Layer or New Group from the Layers panel menu.

    • Alt-click (Windows) or Option-click (Mac OS) the Create A New Layer button or New Group button in the Layers panel to display the New Layer dialog box and set layer options.

    • Ctrl-click (Windows) or Command-click (Mac OS) the Create A New Layer button or New Group button in the Layers panel to add a layer below the currently selected layer.

  2. Set layer options, and click OK:

    Name

    Specifies a name for the layer or group.

    Use Previous Layer to Create Clipping Mask

    This option is not available for groups. (See Mask layers with clipping masks.)

    Color

    Assigns a color to the layer or group in the Layers panel.

    Mode

    Specifies a blending mode for the layer or group. (See Blending modes.)

    Opacity

    Specifies an opacity level for the layer or group.

    Fill With Mode-Neutral Color

    Fills the layer with a preset, neutral color.

    Note:

    To add currently selected layers to a new group, choose Layer > Group Layers, or Shift-click the New Group button at the bottom of the Layers panel.

Create a layer from an existing file

  1. Drag the file icon from Windows or Mac OS onto an open image in Photoshop.

  2. Move, scale, or rotate the imported image. (See Place a file in Photoshop.)

  3. Press Enter or Return.

    By default, Photoshop creates a Smart Object layer. To create standard layers from dragged files, deselect Place Or Drag Raster Images As Smart Objects in the General preferences.

    Note:

    If the placed file is a multilayer image, a flattened version appears on the new layer. To instead copy separate layers, duplicate them in another image. (See Duplicate layers.)

Create a layer with effects from another layer

  1. Select the existing layer in the Layers panel.

  2. Drag the layer to the Create A New Layer button at the bottom of the Layers panel. The newly created layer contains all the effects of the existing one.

Convert a selection into a new layer

  1. Make a selection.

  2. Do one of the following:

    • Choose Layer > New > Layer Via Copy to copy the selection into a new layer.

    • Choose Layer > New > Layer Via Cut to cut the selection and paste it into a new layer.

    Note:

    You must rasterize Smart Objects or shape layers to enable these commands.

View layers and groups within a group

  • Do one of the following to open the group:
    • Click the triangle to the left of the folder icon .

    • Right-click (Windows) or Control-click (Mac OS) the triangle to the left of the folder icon and choose Open This Group.

    • Alt-click (Windows) or Option-click (Mac OS) the triangle to open or close a group and the groups nested within it.

Show or hide a layer, group, or style

Showing or hiding layers, groups, or styles lets you isolate or view only certain portions of your image for easy editing.

  • Do one of the following in the Layers panel:
    • Click the eye icon  next to a layer, group, or layer effect to hide its content in the document window. Click in the column again to redisplay the content. To view the eye icon for styles and effects, click the Reveal Effects In panel icon .

    • Choose Show Layers or Hide Layers from the Layers menu.

    • Alt-click (Windows) or Option-click (Mac OS) an eye icon  to display only the contents of that layer or group. Photoshop remembers the visibility states of all layers before hiding them. If you don’t change the visibility of any other layer, Alt-clicking (Windows) or Option-clicking (Mac OS) the same eye icon restores the original visibility settings.

    • Drag through the eye column to change the visibility of multiple items in the Layers panel.

    Note:

    Only visible layers are printed.

Copy/paste layers

You can now copy and paste layers in Photoshop—inside a document and between documents. Depending on your color management settings and the color profile associated with the file (or imported data), Photoshop may prompt you for directions to handle color information in the imported data.

Caution:

When you paste a layer between documents with different resolutions, the pasted layer retains its pixel dimensions. This behavior can make the pasted portion appear out of proportion to the new image. Use the Image Size command to make the source and destination images the same resolution before copying and pasting, or use the Free Transform command to resize the pasted content.

Copy-paste commands

Copy

(Edit > Copy or Cmd/Ctrl+C) Copies the selected layers

Paste

(Edit > Paste or Cmd/Ctrl+V) Pastes the copied layers into the chosen document in the center of that document. Pasting creates a duplicate layer, including all bitmap and vector masks, and layer effects.

Paste In Place

(Edit > Paste Special > Paste In Place or Cmd/Ctrl+Shift+V) Pastes the copied layers into the targeted document in a position relative to its position in the original document. For example, a layer containing content from the bottom-right corner of a large document pastes into the new document in the bottom-right corner. In all cases, Photoshop tries to keep at least some piece of the pasted layers visible in the destination document, so that you can reposition it as desired.

Note:

If you copy a layer and then create a new document, you can make use of the Clipboard option in the New Document dialog. Choosing this option creates a new document the size of the layers you’ve copied. You can then easily paste your copied layers into the new document

Note:

Cut is grayed out when you have a layer or layers selected. Delete layers directly in the Layers panel.

Considerations for copy/pasting layers containing paths

Copy behaviors

  • If you copy a layer that contains paths—i.e. a Shape layer—but no paths are selected, then the layer is copied to the clipboard. Pasting creates a duplicate shape layer, including all bitmap and vector masks, and layer effects.
  • If you copy a layer that contains paths—i.e. a Shape layer—and the paths are selected on canvas, then the path is copied to the clipboard. 
  • If you copy a layer with a vector mask, but the vector mask is not selected, then all layer data is copied to the clipboard. Pasting creates a duplicate layer, including all bitmap and vector masks, and layer effects.
  • If you copy a layer with a vector mask, and the vector mask is selected, then the path data is copied to the clipboard. Pasting depends on the context.

Paste behaviors

  • If you select a layer that contains no paths—for example, a bitmap layer, pasting the path data creates a new vector mask.
  • If you select a layer that contains paths—for example, a Shape layer—but no paths are selected, then pasting replaces the current Shape in the layer.
  • If you select a Shape layer and select the path, then pasting pastes the path data into the existing Shape layer, combining it with the existing path.
  • If you select a layer with a vector mask, but the vector mask is not selected, then pasting path data replaces the Vector Mask path.
  • If you select a layer with a vector mask, and the vector mask is selected, then pasting pastes the path data into the vector mask, combining it with the existing path.

Copy Merged

This command makes a merged copy of all the visible layers in the selected area.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy