Curves overview

In the Curves adjustment, you adjust points throughout an image’s tonal range. Initially, the image’s tonality is represented as a straight diagonal line on a graph. When adjusting an RGB image, the upper-right area of the graph represents the highlights and the lower-left area represents the shadows. The horizontal axis of the graph represents the input levels (original image values) and the vertical axis represents the output levels (new adjusted values). As you add control points to the line and move them, the shape of the curve changes, reflecting your image adjustments. The steeper sections of the curve represent areas of higher contrast while flatter sections represent areas of lower contrast.

You can save Curves adjustment settings as presets. See Save adjustment settings and Reapply adjustment settings.

Note:

The Curves adjustment can also be applied to CMYK, LAB, or Grayscale images. For CMYK images, the graph displays percentages of ink/pigment. For LAB and Grayscale images, the graph displays light values.

Photoshop Curves option
Curves options in the Properties panel

A. On-image adjustment tool B. Sample in image to set black point. C. Sample in image to set gray point. D. Sample in image to set white point. E. Edit points to modify the curve. F. Draw to modify the curve. G. Curves presets menu H. Set black point.  I. Set gray point. J. Set white point. K. Show clipping. 

Video tutorial: Increase midtone contrast with curves

Video tutorial: Increase midtone contrast with curves
lynda.com

Adjust image color and tone with Curves

Moving a point in the top portion of the curve adjusts the highlights. Moving a point in the center of the curve adjusts the midtones, and moving a point in the bottom section of the curve adjusts the shadows. To darken highlights, move a point near the top of the curve downward. Moving a point either down or to the right maps the Input value to a lower Output value, and the image darkens. To lighten the shadows, move a point near the bottom of the curve upward. Moving a point either up or to the left maps a lower Input value to a higher Output value, and the image lightens.

  1. To apply a Curves adjustment, do one of the following:

    • Click the Curves icon  in the Adjustments panel.
    • Choose Layer > New Adjustment Layer > Curves. Click OK in the New Layer dialog box.

    Note:

    Choosing Image > Adjustments > Curves applies the adjustment directly to the image layer and discards image information.

  2. (Optional) To adjust the color balance, in the Properties panel, choose the channel you want to adjust from the menu to the left of the Auto button.

  3. In the Properties panel, do any of the following:

    • Click directly on the curve line and then drag the control point to adjust a tonal area.
    • Select the On-image adjustment tool and then drag in the area of the image you want to adjust.
    • Select the On-image adjustment tool and click the tonal areas in the image that you want to adjust. This places control points along the curve line.
    • Choose a preset from the Preset menu.

    Dragging a control point up or down lightens or darkens the tonal area you’re adjusting. Dragging a control point left or right increases or decreases the contrast. You can add up to 14 control points to the curve. To remove a control point, drag it off the graph. As you adjust the tonality, the graph continues displaying the original diagonal baseline and image histogram as references. These options can be turned off, see Set Curves Display Options.

  4. (Optional) Do any of the following to modify the adjustment:

    • Add more points directly to the curve to adjust different tonal areas.
    • Click the On-image adjustment tool in other areas of the image, and drag up or down.
    • Move the Set Black and White Point sliders or use the Eyedropper tools to specify the darkest and lightest values in the image.
    • Click a point on the curve, and enter values in the Input and Output text boxes.
    • Select the pencil icon and draw a new curve over the existing one. When you have finished, click the Smooth the Curve Values icon or to smooth the curve you drew. Clicking more than once continues to smooth the curve further.

    Points on the curve remain anchored until you move them. You can make an adjustment in one tonal area without affecting other areas.

Photoshop On-image adjustment tool
Clicking the On-image adjustment tool in the image adds control points to the curve. Moving the control points adjusts the tonality of the image.

Removing control points from a curve

To remove a control point, do any of the following:

  • Drag the control point off the graph.
  • Select the control point and press Delete.
  • Ctrl-click (Windows) or Command-click (Mac OS) the control point.

 

Set Curve display options

You can control the curve grid display using the Curve display options.

  1. Apply a Curves adjustment.

  2. In the Properties panel, choose Curves Display Options from the panel menu.

    Note:

    If you chose Image > Adjustments > Curves, expand the Curve Display Options in the Curves dialog box.

  3. In the Curves Display Options dialog box, select any of the following:

    Light (0-255)  Displays the intensity values for RGB images in a range from 0 to 255, with black (0) at the lower-left corner.
    Pigment/Ink %  Displays the percentages for CMYK images are displayed in a range from 0 to 100, with highlights (0%) at the lower-left corner.
    Simple Grid  Displays gridlines in 25% increments.
    Detailed Grid  Displays gridlines in 10% increments.
    Show Channel Overlays  Displays color channel curves superimposed on the composite curve.
    Histogram  Displays a histogram of the original image tonal values behind the graph.
    Baseline  Displays the original image color and tonality as a 45-degree angle line for reference,
    Intersection Line  Displays horizontal and vertical lines to help you align control points as your drag them relative to the histogram or grid.

    Note:

    To change the gridline increment, Alt-click (Windows) or Option-click (Mac OS) the grid.

Apply an Auto correction in Curves

  • Click Auto in the Properties panel.

Auto applies an automatic color correction using the current default setting. To change the default setting, choose Auto Options from the Properties panel menu and set the options in the Auto Color Correction Options dialog box. You can apply an Auto Color, Auto Contrast, or Auto Tone correction to an image. For more information on these options, see Set Auto adjustment options.

Set black and white points using the black point and white point sliders

When applying a Curves adjustment, use the black and white sliders to quickly set the black and white points (pure black and pure white values) in the image.

  1. Drag the black and white point sliders to any point along the horizontal axis. Note that the Input value changes as your drag.

  2. To preview clipping as you adjust black and white points, do one of the following:

    • Hold down Alt (Windows) or Option (Mac OS).
    • Choose Show Clipping For Black/White Points from the panel menu.

Add contrast to the midtones of a photo with Curves

If the image uses the full tonal range, but needs midtone contrast, Click the Curves icon  in the Adjustments panel. Drag the curve into an S shape.

Photoshop Increasing slope in the curve
Increasing the slope in the middle of the curve increases contrast in the midtones.

Keyboard shortcuts: Curves

You can use these keyboard shortcuts for Curves:

  • To set a point on the curve for the selected color in each color component channel (but not in the composite channel), Shift+Ctrl-click (Windows) or Shift+Command-click (Mac OS) in the image.

  • To select multiple points, Shift-click points on the curve. Selected points are filled with black.

  • To deselect all points on the curve, click in the grid, or press Ctrl‑D (Windows) or Command-D (Mac OS).

  • To select the next higher point on the curve, press the plus key; to select the next lowest, press the minus key.

  • To move selected points on the curve, press the arrow keys.

  • (Curves dialog box) To set a point on the curve for the current channel, Ctrl-click (Windows) or Command-click (Mac OS) in the image.

Note:

If you’re instead using the Curves adjustment, simply click in the image with the On-image adjustment tool .

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy