About metadata

Metadata is a set of standardized information about a file, such as author name, resolution, color space, copyright, and keywords applied to it. For example, most digital cameras attach some basic information to an image file, such as height, width, file format, and time the image was taken. You can use metadata to streamline your workflow and organize your files.

About the XMP standard

Metadata information is stored using the Extensible Metadata Platform (XMP) standard, on which Adobe Bridge, Adobe Illustrator, Adobe InDesign, and Adobe Photoshop are built. Adjustments made to images with Photoshop® Camera Raw are stored as XMP metadata. XMP is built on XML, and in most cases the metadata is stored in the file. If it isn’t possible to store the information in the file, metadata is stored in a separate file called a sidecar file. XMP facilitates the exchange of metadata between Adobe applications and across publishing workflows. For example, you can save metadata from one file as a template, and then import the metadata into other files.

Metadata that is stored in other formats, such as Exif, IPTC (IIM), GPS, and TIFF, is synchronized and described with XMP so that it can be more easily viewed and managed. Other applications and features (for example, Adobe Drive) also use XMP to communicate and store information such as version comments, which you can search using Adobe Bridge.

In most cases, the metadata remains with the file even when the file format changes (for example, from PSD to JPG). Metadata also remains when files are placed in an Adobe document or project.


If you’re a C++ or Java developer, use the XMP Toolkit SDK to customize the processing and exchange of metadata. If you’re an Adobe Flash or Flex developer, use the XMP File Info SDK to customize the File Info dialog box. For more information, visit the Adobe website.

Work with metadata in Adobe Bridge and Adobe Creative Suite components

Many of the powerful Adobe Bridge features that allow you to organize, search, and keep track of your files and versions depend on XMP metadata in your files. Adobe Bridge provides two ways of working with metadata: through the Metadata panel and through the File Info dialog box.

In some cases, multiple views exist for the same metadata property. For example, a property may be labeled Author in one view and Creator in another, but both refer to the same underlying property. Even if you customize these views for specific workflows, they remain standardized through XMP.


You can attach notes to an image in Photoshop. This is useful for associating review comments, production notes, or other information with the image. Notes appear as small non-printable icons on the image. They are associated with a location on the image rather than with a layer. You can hide or show notes, or open notes to view or edit their contents.

Add notes

You can add notes anywhere on your Photoshop image canvas. When you create a note, an icon appears on the image.

  1. Select the Note tool in the toolbox. (If the tool isn’t visible, hold down the Eyedropper.)
  2. In the Options bar, enter or specify the following as needed:


    Specifies the note author’s name.


    Selects the color for the note icon. Clicking the color box opens the Adobe Color Picker so you can select a color.

  3. Click where you want to place the note.
  4. The cursor will automatically be active

Show or hide notes

To show or hide notes, do one of the following:

  • Choose View > Show > Notes.

  • Choose View > Extras. This command also shows or hides grids, guides, selection edges, target paths, and slices.

Open and edit notes

  • Using the Note tool, double-click the note icon in the image. The text editing area appears in the Notes panel.
  • Choose Window > Notes to display the Notes panel, and click the back and forward arrows to toggle through all notes in the active image.

Import notes from a flattened PDF version of a multilayer image

When you open a PDF file, Photoshop automatically imports any notes it contains. You may want to import notes separately, however, if they were added to a flattened PDF version of a multilayer image. This approach lets reviewers who lack Photoshop provide comments, while letting you view comments in the context of the multilayer design.

  1. Choose File > Import > Notes.

  2. Select a PDF or FDF file that contains notes, and then click Load.

The annotations appear in the locations where they were saved in the source document.

Delete notes

  • Select the Note tool, and then do either of the following:

    • To delete an individual note, click it in the image, and then click the Delete Note icon  in the Notes panel.

    • To delete all notes, click Clear All in the options bar.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy