User Guide Cancel

Work with Photoshop files in InDesign

  1. Photoshop User Guide
  2. Introduction to Photoshop
    1. Dream it. Make it.
    2. What's new in Photoshop
    3. Edit your first photo
    4. Create documents
    5. Photoshop | Common Questions
    6. Photoshop system requirements
    7. Migrate presets, actions, and settings
    8. Get to know Photoshop
  3. Photoshop and other Adobe products and services
    1. Work with Illustrator artwork in Photoshop
    2. Work with Photoshop files in InDesign
    3. Substance 3D Materials for Photoshop
    4. Photoshop and Adobe Stock
    5. Use the Capture in-app extension in Photoshop
    6. Creative Cloud Libraries
    7. Creative Cloud Libraries in Photoshop
    8. Use the Touch Bar with Photoshop
    9. Grid and guides
    10. Creating actions
    11. Undo and history
  4. Photoshop on the iPad
    1. Photoshop on the iPad | Common questions
    2. Get to know the workspace
    3. System requirements | Photoshop on the iPad
    4. Create, open, and export documents
    5. Add photos
    6. Work with layers
    7. Draw and paint with brushes
    8. Make selections and add masks
    9. Retouch your composites
    10. Work with adjustment layers
    11. Adjust the tonality of your composite with Curves
    12. Apply transform operations
    13. Crop and rotate your composites
    14. Rotate, pan, zoom, and reset the canvas
    15. Work with Type layers
    16. Work with Photoshop and Lightroom
    17. Get missing fonts in Photoshop on the iPad
    18. Japanese Text in Photoshop on the iPad
    19. Manage app settings
    20. Touch shortcuts and gestures
    21. Keyboard shortcuts
    22. Edit your image size
    23. Livestream as you create in Photoshop on the iPad
    24. Correct imperfections with the Healing Brush
    25. Create brushes in Capture and use them in Photoshop
    26. Work with Camera Raw files
    27. Create and work with Smart Objects
    28. Adjust exposure in your images with Dodge and Burn
  5. Photoshop on the web beta
    1. Common questions | Photoshop on the web beta 
    2. Introduction to the workspace
    3. System requirements | Photoshop on the web beta
    4. Keyboard shortcuts | Photoshop on the web beta
    5. Supported file types | Photoshop on the web beta
    6. Open and work with cloud documents
    7. Collaborate with stakeholders
    8. Apply limited edits to your cloud documents
  6. Cloud documents
    1. Photoshop cloud documents | Common questions
    2. Photoshop cloud documents | Workflow questions
    3. Manage and work with cloud documents in Photoshop
    4. Upgrade cloud storage for Photoshop
    5. Unable to create or save a cloud document
    6. Solve Photoshop cloud document errors
    7. Collect cloud document sync logs
    8. Share access and edit your cloud documents
    9. Share files and comment in-app
  7. Workspace
    1. Workspace basics
    2. Preferences
    3. Learn faster with the Photoshop Discover Panel
    4. Create documents
    5. Place files
    6. Default keyboard shortcuts
    7. Customize keyboard shortcuts
    8. Tool galleries
    9. Performance preferences
    10. Use tools
    11. Presets
    12. Grid and guides
    13. Touch gestures
    14. Use the Touch Bar with Photoshop
    15. Touch capabilities and customizable workspaces
    16. Technology previews
    17. Metadata and notes
    18. Touch capabilities and customizable workspaces
    19. Place Photoshop images in other applications
    20. Rulers
    21. Show or hide non-printing Extras
    22. Specify columns for an image
    23. Undo and history
    24. Panels and menus
    25. Position elements with snapping
    26. Position with the Ruler tool
  8. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Device Preview
    4. Copy CSS from layers
    5. Slice web pages
    6. HTML options for slices
    7. Modify slice layout
    8. Work with web graphics
    9. Create web photo galleries
  9. Image and color basics
    1. How to resize images
    2. Work with raster and vector images
    3. Image size and resolution
    4. Acquire images from cameras and scanners
    5. Create, open, and import images
    6. View images
    7. Invalid JPEG Marker error | Opening images
    8. Viewing multiple images
    9. Customize color pickers and swatches
    10. High dynamic range images
    11. Match colors in your image
    12. Convert between color modes
    13. Color modes
    14. Erase parts of an image
    15. Blending modes
    16. Choose colors
    17. Customize indexed color tables
    18. Image information
    19. Distort filters are unavailable
    20. About color
    21. Color and monochrome adjustments using channels
    22. Choose colors in the Color and Swatches panels
    23. Sample
    24. Color mode or Image mode
    25. Color cast
    26. Add a conditional mode change to an action
    27. Add swatches from HTML CSS and SVG
    28. Bit depth and preferences
  10. Layers
    1. Layer basics
    2. Nondestructive editing
    3. Create and manage layers and groups
    4. Select, group, and link layers
    5. Place images into frames
    6. Layer opacity and blending
    7. Mask layers
    8. Apply Smart Filters
    9. Layer comps
    10. Move, stack, and lock layers
    11. Mask layers with vector masks
    12. Manage layers and groups
    13. Layer effects and styles
    14. Edit layer masks
    15. Extract assets
    16. Reveal layers with clipping masks
    17. Generate image assets from layers
    18. Work with Smart Objects
    19. Blending modes
    20. Combine multiple images into a group portrait
    21. Combine images with Auto-Blend Layers
    22. Align and distribute layers
    23. Copy CSS from layers
    24. Load selections from a layer or layer mask's boundaries
    25. Knockout to reveal content from other layers
    26. Layer
    27. Flattening
    28. Composite
    29. Background
  11. Selections
    1. Select and Mask workspace
    2. Make quick selections
    3. Get started with selections
    4. Select with the marquee tools
    5. Select with the lasso tools
    6. Select a color range in an image
    7. Adjust pixel selections
    8. Convert between paths and selection borders
    9. Channel basics
    10. Move, copy, and delete selected pixels
    11. Create a temporary quick mask
    12. Save selections and alpha channel masks
    13. Select the image areas in focus
    14. Duplicate, split, and merge channels
    15. Channel calculations
    16. Selection
    17. Bounding box
  12. Image adjustments
    1. Perspective warp
    2. Reduce camera shake blurring
    3. Healing brush examples
    4. Export color lookup tables
    5. Adjust image sharpness and blur
    6. Understand color adjustments
    7. Apply a Brightness/Contrast adjustment
    8. Adjust shadow and highlight detail
    9. Levels adjustment
    10. Adjust hue and saturation
    11. Adjust vibrance
    12. Adjust color saturation in image areas
    13. Make quick tonal adjustments
    14. Apply special color effects to images
    15. Enhance your image with color balance adjustments
    16. High dynamic range images
    17. View histograms and pixel values
    18. Match colors in your image
    19. How to crop and straighten photos
    20. Convert a color image to black and white
    21. Adjustment and fill layers
    22. Curves adjustment
    23. Blending modes
    24. Target images for press
    25. Adjust color and tone with Levels and Curves eyedroppers
    26. Adjust HDR exposure and toning
    27. Filter
    28. Blur
    29. Dodge or burn image areas
    30. Make selective color adjustments
    31. Replace object colors
  13. Adobe Camera Raw
    1. Camera Raw system requirements
    2. What's new in Camera Raw
    3. Introduction to Camera Raw
    4. Create panoramas
    5. Supported lenses
    6. Vignette, grain, and dehaze effects in Camera Raw
    7. Default keyboard shortcuts
    8. Automatic perspective correction in Camera Raw
    9. How to make non-destructive edits in Camera Raw
    10. Radial Filter in Camera Raw
    11. Manage Camera Raw settings
    12. Open, process, and save images in Camera Raw
    13. Repair images with the Enhanced Spot Removal tool in Camera Raw
    14. Rotate, crop, and adjust images
    15. Adjust color rendering in Camera Raw
    16. Feature summary | Adobe Camera Raw | 2018 releases
    17. New features summary
    18. Process versions in Camera Raw
    19. Make local adjustments in Camera Raw
  14. Image repair and restoration
    1. Remove objects from your photos with Content-Aware Fill
    2. Content-Aware Patch and Move
    3. Retouch and repair photos
    4. Correct image distortion and noise
    5. Basic troubleshooting steps to fix most issues
  15. Image transformations
    1. Transform objects
    2. Adjust crop, rotation, and canvas size
    3. How to crop and straighten photos
    4. Create and edit panoramic images
    5. Warp images, shapes, and paths
    6. Vanishing Point
    7. Use the Liquify filter
    8. Content-aware scaling
    9. Transform images, shapes, and paths
    10. Warp
    11. Transform
    12. Panorama
  16. Drawing and painting
    1. Paint symmetrical patterns
    2. Draw rectangles and modify stroke options
    3. About drawing
    4. Draw and edit shapes
    5. Painting tools
    6. Create and modify brushes
    7. Blending modes
    8. Add color to paths
    9. Edit paths
    10. Paint with the Mixer Brush
    11. Brush presets
    12. Gradients
    13. Gradient interpolation
    14. Fill and stroke selections, layers, and paths
    15. Draw with the Pen tools
    16. Create patterns
    17. Generate a pattern using the Pattern Maker
    18. Manage paths
    19. Manage pattern libraries and presets
    20. Draw or paint with a graphics tablet
    21. Create textured brushes
    22. Add dynamic elements to brushes
    23. Gradient
    24. Paint stylized strokes with the Art History Brush
    25. Paint with a pattern
    26. Sync presets on multiple devices
  17. Text
    1. Add and edit the text
    2. Unified Text Engine
    3. Work with OpenType SVG fonts
    4. Format characters
    5. Format paragraphs
    6. How to create type effects
    7. Edit text
    8. Line and character spacing
    9. Arabic and Hebrew type
    10. Fonts
    11. Troubleshoot fonts
    12. Asian type
    13. Create type
    14. Text Engine error using Type tool in Photoshop | Windows 8
  18. Video and animation
    1. Video editing in Photoshop
    2. Edit video and animation layers
    3. Video and animation overview
    4. Preview video and animations
    5. Paint frames in video layers
    6. Import video files and image sequences
    7. Create frame animations
    8. Creative Cloud 3D Animation (Preview)
    9. Create timeline animations
    10. Create images for video
  19. Filters and effects
    1. Use the Liquify filter
    2. Use the Blur Gallery
    3. Filter basics
    4. Filter effects reference
    5. Add Lighting Effects
    6. Use the Adaptive Wide Angle filter
    7. Use the Oil Paint filter
    8. Layer effects and styles
    9. Apply specific filters
    10. Smudge image areas
  20. Saving and exporting
    1. Save your files in Photoshop
    2. Export your files in Photoshop
    3. Supported file formats
    4. Save files in graphics formats
    5. Move designs between Photoshop and Illustrator
    6. Save and export video and animations
    7. Save PDF files
    8. Digimarc copyright protection
  21. Printing
    1. Print 3D objects
    2. Print from Photoshop
    3. Print with color management
    4. Contact Sheets and PDF Presentations
    5. Print photos in a picture package layout
    6. Print spot colors
    7. Duotones
    8. Print images to a commercial printing press
    9. Improve color prints from Photoshop
    10. Troubleshoot printing problems | Photoshop
  22. Automation
    1. Creating actions
    2. Create data-driven graphics
    3. Scripting
    4. Process a batch of files
    5. Play and manage actions
    6. Add conditional actions
    7. About actions and the Actions panel
    8. Record tools in actions
    9. Add a conditional mode change to an action
    10. Photoshop UI toolkit for plug-ins and scripts
  23. Color Management
    1. Understanding color management
    2. Keeping colors consistent
    3. Color settings
    4. Work with color profiles
    5. Color-managing documents for online viewing
    6. Color-managing documents when printing
    7. Color-managing imported images
    8. Proofing colors
  24. Content authenticity
    1. Learn about content credentials
    2. Identity and provenance for NFTs
    3. Connect accounts for creative attribution
  25. 3D and technical imaging
    1. Photoshop 3D | Common questions around discontinued 3D features
    2. Creative Cloud 3D Animation (Preview)
    3. Print 3D objects
    4. 3D painting
    5. 3D panel enhancements | Photoshop
    6. Essential 3D concepts and tools
    7. 3D rendering and saving
    8. Create 3D objects and animations
    9. Image stacks
    10. 3D workflow
    11. Measurement
    12. DICOM files
    13. Photoshop and MATLAB
    14. Count objects in an image
    15. Combine and convert 3D objects
    16. 3D texture editing
    17. Adjust HDR exposure and toning
    18. 3D panel settings

Find answers to common questions when importing Photoshop assets in InDesign.

Things to know when moving files to InDesign

Try the following workflows that suit your design objectives:

Workflow How To Achieve
Adjust layer visibility Adjust the visibility of top-level layers while placing a file or using the Object Layer Options dialog box. View the desired comp if your Photoshop file contains layer comps. Click Layer comps in Photoshop to learn more. 
Remove background or wrap text
Use paths, masks, and alpha channels in a Photoshop file to remove backgrounds or wrap text around graphics when importing in InDesign. Click Masks and alpha channels in Photoshop and Alpha channels in InDesign to learn more. 
Assign a color profile
Import a Photoshop file with an embedded ICC color management profile for InDesign to detect if color management is active. To override the profile in InDesign, use the Import Options dialog box or assign a different color profile. Click Work with color profiles in Photoshop and Manage colors in InDesign to learn more. 
See spot colors See spot-color channels in Photoshop files as spot colors in the InDesign Swatches panel. Click Spot color channels in Photoshop to learn more. 
Preview your files

See the screen resolution version of your Photoshop files in the layout, even though the actual graphic file may be linked or embedded. See Image size and resolution in Photoshop and Link or embed graphic files in InDesign to learn more. 

Import Photoshop files to InDesign

The Place command is most frequently used to import Photoshop files to InDesign. Click Place graphics in InDesign to learn more about adding files to your InDesign document. 

  1. Select the frame

    From InDesign, select the frame if you are importing into or replacing an existing frame.

    If you are importing a graphic without a frame, ensure that nothing in the document is selected. Click Frames and objects in InDesign to learn more about importing graphics without a frame. 

  2. Place the file

    • Choose File > Place from the InDesign menu and select your file.
    • When selecting multiple files to place, you’ll be able to position or size the selected files one at a time.
    • If the new image doesn’t fit the frame, select Object > Fitting  to fit the graphic into the frame. Click Place Photoshop files in InDesign to learn more. 
    Choose File > Place to place Photoshop file in InDesign
    Choose File > Place to place Photoshop file in InDesign

You can also drag and drop Photoshop files to InDesign and maintain their attributes and editing capabilities. 

Use layer comps in Photoshop to improve InDesign workflows

Layer comps (or compositions) are a neat way to create, manage, and view multiple versions of your layouts or content in one Photoshop file. They reduce the need for redundant layers when importing a Photoshop file to InDesign.

You can save more than one design idea using layer comps.

Layer comps in a Photoshop file
Layer comps in a Photoshop file

Layer comps are the snapshot of a state of the Layers panel and record layer visibility, layer position, layer appearance, and layer comp selection. 

With layer comps, you can experiment with layer styles, visibility, opacity, colors, effects, and placement using attributes and states while toggling between layers in the same Photoshop file. Click Layer comps to learn more about using them in Photoshop. 

When you import this file to InDesign, you can choose from different states in the Layer Comp dropdown menu, instead of having to adjust the visibility of layers. This way you can import only one file and use layer comps as part of the file.

Avoid Photoshop files from looking pixelated in InDesign

To avoid your Photoshop file from getting pixelated in InDesign, go to File > Place to select the file, instead of simply copying and pasting it.

Also, make sure you choose the right display settings to view files at full resolution in InDesign. (Click Graphics display to learn more about controlling graphics display performance.)

Note:

High Quality Display is checked by default in the View > Display Performance menu. 

Choose the right display settings in InDesign to view images at full resolution
Choose the right display settings in InDesign to view images at full resolution

Prevent oversaturation of colors when placing images from Photoshop to InDesign

To prevent your Photoshop image from looking oversaturated in Indesign, ensure your color profiles match between both the applications (tagged images). Go to Edit > Color Settings to adjust settings for both. 

Access color profiles in Photoshop by going to Edit > Color Settings
Access color profiles in Photoshop by going to Edit > Color Settings

Use your CMYK image in an InDesign document created with the default North American General Purpose Color Settings. The color settings set US Web Coated SWOP as the assigned CMYK profile and the policy is set to ignore linked profiles. 

Use Assign Profile to tag your images with specific profiles or untag them by removing the profiles.

Assign Profile (Edit Menu > Assign Profile) in Photoshop
Assign Profile (Edit Menu > Assign Profile) in Photoshop

Select a different profile and assign it without converting colors to the profile space. This can change the appearance of the colors as displayed on your monitor.

Click Work with color profiles to learn more about assigning or removing a color profile in Photoshop and InDesign. 

Got a question or an idea?

Ask the Community

If you have a question to ask or an idea to share, come and participate in the Adobe Photoshop community and Adobe InDesign community. We'd love to hear from you!

Adobe logo

Sign in to your account