User Guide Cancel

Manage layers and layer groups

  1. Photoshop User Guide
  2. Introduction to Photoshop
    1. Dream it. Make it.
    2. What's new in Photoshop
    3. Edit your first photo
    4. Create documents
    5. Photoshop | Common Questions
    6. Photoshop system requirements
    7. Migrate presets, actions, and settings
    8. Get to know Photoshop
  3. Photoshop and other Adobe products and services
    1. Work with Illustrator artwork in Photoshop
    2. Work with Photoshop files in InDesign
    3. Substance 3D Materials for Photoshop
    4. Photoshop and Adobe Stock
    5. Use the Capture in-app extension in Photoshop
    6. Creative Cloud Libraries
    7. Creative Cloud Libraries in Photoshop
    8. Use the Touch Bar with Photoshop
    9. Grid and guides
    10. Creating actions
    11. Undo and history
  4. Photoshop on the iPad
    1. Photoshop on the iPad | Common questions
    2. Get to know the workspace
    3. System requirements | Photoshop on the iPad
    4. Create, open, and export documents
    5. Add photos
    6. Work with layers
    7. Draw and paint with brushes
    8. Make selections and add masks
    9. Retouch your composites
    10. Work with adjustment layers
    11. Adjust the tonality of your composite with Curves
    12. Apply transform operations
    13. Crop and rotate your composites
    14. Rotate, pan, zoom, and reset the canvas
    15. Work with Type layers
    16. Work with Photoshop and Lightroom
    17. Get missing fonts in Photoshop on the iPad
    18. Japanese Text in Photoshop on the iPad
    19. Manage app settings
    20. Touch shortcuts and gestures
    21. Keyboard shortcuts
    22. Edit your image size
    23. Livestream as you create in Photoshop on the iPad
    24. Correct imperfections with the Healing Brush
    25. Create brushes in Capture and use them in Photoshop
    26. Work with Camera Raw files
    27. Create and work with Smart Objects
    28. Adjust exposure in your images with Dodge and Burn
  5. Photoshop on the web beta
    1. Common questions | Photoshop on the web beta 
    2. Introduction to the workspace
    3. System requirements | Photoshop on the web beta
    4. Keyboard shortcuts | Photoshop on the web beta
    5. Supported file types | Photoshop on the web beta
    6. Open and work with cloud documents
    7. Collaborate with stakeholders
    8. Apply limited edits to your cloud documents
  6. Cloud documents
    1. Photoshop cloud documents | Common questions
    2. Photoshop cloud documents | Workflow questions
    3. Manage and work with cloud documents in Photoshop
    4. Upgrade cloud storage for Photoshop
    5. Unable to create or save a cloud document
    6. Solve Photoshop cloud document errors
    7. Collect cloud document sync logs
    8. Share access and edit your cloud documents
    9. Share files and comment in-app
  7. Workspace
    1. Workspace basics
    2. Preferences
    3. Learn faster with the Photoshop Discover Panel
    4. Create documents
    5. Place files
    6. Default keyboard shortcuts
    7. Customize keyboard shortcuts
    8. Tool galleries
    9. Performance preferences
    10. Use tools
    11. Presets
    12. Grid and guides
    13. Touch gestures
    14. Use the Touch Bar with Photoshop
    15. Touch capabilities and customizable workspaces
    16. Technology previews
    17. Metadata and notes
    18. Touch capabilities and customizable workspaces
    19. Place Photoshop images in other applications
    20. Rulers
    21. Show or hide non-printing Extras
    22. Specify columns for an image
    23. Undo and history
    24. Panels and menus
    25. Position elements with snapping
    26. Position with the Ruler tool
  8. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Device Preview
    4. Copy CSS from layers
    5. Slice web pages
    6. HTML options for slices
    7. Modify slice layout
    8. Work with web graphics
    9. Create web photo galleries
  9. Image and color basics
    1. How to resize images
    2. Work with raster and vector images
    3. Image size and resolution
    4. Acquire images from cameras and scanners
    5. Create, open, and import images
    6. View images
    7. Invalid JPEG Marker error | Opening images
    8. Viewing multiple images
    9. Customize color pickers and swatches
    10. High dynamic range images
    11. Match colors in your image
    12. Convert between color modes
    13. Color modes
    14. Erase parts of an image
    15. Blending modes
    16. Choose colors
    17. Customize indexed color tables
    18. Image information
    19. Distort filters are unavailable
    20. About color
    21. Color and monochrome adjustments using channels
    22. Choose colors in the Color and Swatches panels
    23. Sample
    24. Color mode or Image mode
    25. Color cast
    26. Add a conditional mode change to an action
    27. Add swatches from HTML CSS and SVG
    28. Bit depth and preferences
  10. Layers
    1. Layer basics
    2. Nondestructive editing
    3. Create and manage layers and groups
    4. Select, group, and link layers
    5. Place images into frames
    6. Layer opacity and blending
    7. Mask layers
    8. Apply Smart Filters
    9. Layer comps
    10. Move, stack, and lock layers
    11. Mask layers with vector masks
    12. Manage layers and groups
    13. Layer effects and styles
    14. Edit layer masks
    15. Extract assets
    16. Reveal layers with clipping masks
    17. Generate image assets from layers
    18. Work with Smart Objects
    19. Blending modes
    20. Combine multiple images into a group portrait
    21. Combine images with Auto-Blend Layers
    22. Align and distribute layers
    23. Copy CSS from layers
    24. Load selections from a layer or layer mask's boundaries
    25. Knockout to reveal content from other layers
    26. Layer
    27. Flattening
    28. Composite
    29. Background
  11. Selections
    1. Select and Mask workspace
    2. Make quick selections
    3. Get started with selections
    4. Select with the marquee tools
    5. Select with the lasso tools
    6. Select a color range in an image
    7. Adjust pixel selections
    8. Convert between paths and selection borders
    9. Channel basics
    10. Move, copy, and delete selected pixels
    11. Create a temporary quick mask
    12. Save selections and alpha channel masks
    13. Select the image areas in focus
    14. Duplicate, split, and merge channels
    15. Channel calculations
    16. Selection
    17. Bounding box
  12. Image adjustments
    1. Perspective warp
    2. Reduce camera shake blurring
    3. Healing brush examples
    4. Export color lookup tables
    5. Adjust image sharpness and blur
    6. Understand color adjustments
    7. Apply a Brightness/Contrast adjustment
    8. Adjust shadow and highlight detail
    9. Levels adjustment
    10. Adjust hue and saturation
    11. Adjust vibrance
    12. Adjust color saturation in image areas
    13. Make quick tonal adjustments
    14. Apply special color effects to images
    15. Enhance your image with color balance adjustments
    16. High dynamic range images
    17. View histograms and pixel values
    18. Match colors in your image
    19. How to crop and straighten photos
    20. Convert a color image to black and white
    21. Adjustment and fill layers
    22. Curves adjustment
    23. Blending modes
    24. Target images for press
    25. Adjust color and tone with Levels and Curves eyedroppers
    26. Adjust HDR exposure and toning
    27. Filter
    28. Blur
    29. Dodge or burn image areas
    30. Make selective color adjustments
    31. Replace object colors
  13. Adobe Camera Raw
    1. Camera Raw system requirements
    2. What's new in Camera Raw
    3. Introduction to Camera Raw
    4. Create panoramas
    5. Supported lenses
    6. Vignette, grain, and dehaze effects in Camera Raw
    7. Default keyboard shortcuts
    8. Automatic perspective correction in Camera Raw
    9. How to make non-destructive edits in Camera Raw
    10. Radial Filter in Camera Raw
    11. Manage Camera Raw settings
    12. Open, process, and save images in Camera Raw
    13. Repair images with the Enhanced Spot Removal tool in Camera Raw
    14. Rotate, crop, and adjust images
    15. Adjust color rendering in Camera Raw
    16. Feature summary | Adobe Camera Raw | 2018 releases
    17. New features summary
    18. Process versions in Camera Raw
    19. Make local adjustments in Camera Raw
  14. Image repair and restoration
    1. Remove objects from your photos with Content-Aware Fill
    2. Content-Aware Patch and Move
    3. Retouch and repair photos
    4. Correct image distortion and noise
    5. Basic troubleshooting steps to fix most issues
  15. Image transformations
    1. Transform objects
    2. Adjust crop, rotation, and canvas size
    3. How to crop and straighten photos
    4. Create and edit panoramic images
    5. Warp images, shapes, and paths
    6. Vanishing Point
    7. Use the Liquify filter
    8. Content-aware scaling
    9. Transform images, shapes, and paths
    10. Warp
    11. Transform
    12. Panorama
  16. Drawing and painting
    1. Paint symmetrical patterns
    2. Draw rectangles and modify stroke options
    3. About drawing
    4. Draw and edit shapes
    5. Painting tools
    6. Create and modify brushes
    7. Blending modes
    8. Add color to paths
    9. Edit paths
    10. Paint with the Mixer Brush
    11. Brush presets
    12. Gradients
    13. Gradient interpolation
    14. Fill and stroke selections, layers, and paths
    15. Draw with the Pen tools
    16. Create patterns
    17. Generate a pattern using the Pattern Maker
    18. Manage paths
    19. Manage pattern libraries and presets
    20. Draw or paint with a graphics tablet
    21. Create textured brushes
    22. Add dynamic elements to brushes
    23. Gradient
    24. Paint stylized strokes with the Art History Brush
    25. Paint with a pattern
    26. Sync presets on multiple devices
  17. Text
    1. Add and edit the text
    2. Unified Text Engine
    3. Work with OpenType SVG fonts
    4. Format characters
    5. Format paragraphs
    6. How to create type effects
    7. Edit text
    8. Line and character spacing
    9. Arabic and Hebrew type
    10. Fonts
    11. Troubleshoot fonts
    12. Asian type
    13. Create type
    14. Text Engine error using Type tool in Photoshop | Windows 8
  18. Video and animation
    1. Video editing in Photoshop
    2. Edit video and animation layers
    3. Video and animation overview
    4. Preview video and animations
    5. Paint frames in video layers
    6. Import video files and image sequences
    7. Create frame animations
    8. Creative Cloud 3D Animation (Preview)
    9. Create timeline animations
    10. Create images for video
  19. Filters and effects
    1. Use the Liquify filter
    2. Use the Blur Gallery
    3. Filter basics
    4. Filter effects reference
    5. Add Lighting Effects
    6. Use the Adaptive Wide Angle filter
    7. Use the Oil Paint filter
    8. Layer effects and styles
    9. Apply specific filters
    10. Smudge image areas
  20. Saving and exporting
    1. Save your files in Photoshop
    2. Export your files in Photoshop
    3. Supported file formats
    4. Save files in graphics formats
    5. Move designs between Photoshop and Illustrator
    6. Save and export video and animations
    7. Save PDF files
    8. Digimarc copyright protection
  21. Printing
    1. Print 3D objects
    2. Print from Photoshop
    3. Print with color management
    4. Contact Sheets and PDF Presentations
    5. Print photos in a picture package layout
    6. Print spot colors
    7. Duotones
    8. Print images to a commercial printing press
    9. Improve color prints from Photoshop
    10. Troubleshoot printing problems | Photoshop
  22. Automation
    1. Creating actions
    2. Create data-driven graphics
    3. Scripting
    4. Process a batch of files
    5. Play and manage actions
    6. Add conditional actions
    7. About actions and the Actions panel
    8. Record tools in actions
    9. Add a conditional mode change to an action
    10. Photoshop UI toolkit for plug-ins and scripts
  23. Color Management
    1. Understanding color management
    2. Keeping colors consistent
    3. Color settings
    4. Work with color profiles
    5. Color-managing documents for online viewing
    6. Color-managing documents when printing
    7. Color-managing imported images
    8. Proofing colors
  24. Content authenticity
    1. Learn about content credentials
    2. Identity and provenance for NFTs
    3. Connect accounts for creative attribution
  25. 3D and technical imaging
    1. Photoshop 3D | Common questions around discontinued 3D features
    2. Creative Cloud 3D Animation (Preview)
    3. Print 3D objects
    4. 3D painting
    5. 3D panel enhancements | Photoshop
    6. Essential 3D concepts and tools
    7. 3D rendering and saving
    8. Create 3D objects and animations
    9. Image stacks
    10. 3D workflow
    11. Measurement
    12. DICOM files
    13. Photoshop and MATLAB
    14. Count objects in an image
    15. Combine and convert 3D objects
    16. 3D texture editing
    17. Adjust HDR exposure and toning
    18. 3D panel settings

Learn how to manage layers, layer groups, and layer effects in a Photoshop document to keep your project organized.

Read the full article. Start with selecting any of these topics to learn more:

Rename layers

As you add layers or layer groups to an image, it’s helpful to give them names that reflect their content. Descriptive names make layers easy to identify in the Layers panel.

Do one of the following:
  • Double-click the layer name or group name in the Layers panel and enter a new name. Press Enter (Windows) or Return (macOS).
  • Select the layer/group and then follow these steps:
    • Choose Layer > Rename Layer or Layer > Rename Group.
    • Enter a new name for the layer/group in the Layers panel.
    • Press Enter (Windows) or Return (macOS).

Delete layers

Deleting the layers you no longer need reduces the size of your image file. To quickly delete empty layers, choose File > Scripts > Delete All Empty Layers.

To delete layers or layer groups having edits, follow the steps below:

  1. Select one or more layers or groups from the Layers panel.
  2. Do one of the following:
    • To delete with a confirmation message, click the Delete icon . Alternatively, choose Layers > Delete > Layer or Delete Layer or Delete Group from the Layers panel menu.
    • To delete the layer or group without confirmation, drag it to the Delete icon , Alt-click (Windows) or Option-click (macOS) the Delete icon, or press the Delete key.
    • To delete hidden layers, choose Layers > Delete > Hidden Layers.
    Note:

    To delete linked layers, select a linked layer, choose Layer > Select Linked Layers, and then delete the layers.

Export layers

You can export all layers or visible layers to separate files.

Choose File > Scripts > Export Layers To Files.

Assign colors to layers

Color coding layers and groups helps you locate related layers in the Layers panel. Simply right-click the layer or group and select a color.

Rasterize layers

You cannot use the painting tools or filters on layers that contain vector data (such as type layers, shape layers, vector masks, or Smart Objects) and generated data (such as fill layers). However, you can rasterize these layers to convert their contents into a flat, raster image.

Once your layer is rasterized, you cannot edit them earlier because they are now converted to pixel-based layers. It's recommended to duplicate your layer and apply rasterization so that you can always go back to the original if necessary. To rasterize a vector layer or a Smart object, you can simply select a vector-based layer or a Smart Object and then choose Layer > Rasterize > Layer or Layer > Rasterize > All Layers to rasterize all layers in your document.

Select the layers you want to rasterize, choose Layer > Rasterize, and then choose an option from the submenu:

Type

Rasterizes the type on a type layer. It does not rasterize any other vector data on the layer.

Shape

Rasterizes a shape layer.

Fill Content

Rasterizes the fill of a shape layer, leaving the vector mask.

Vector Mask

Rasterizes the vector mask on a layer, turning it into a layer mask.

Smart Object

Converts a Smart Object into a raster layer.

Video

Rasterizes the current video frame to an image layer.

3D (Extended only)

Rasterizes the current view of 3D data into a flat raster layer.

Layer

Rasterizes all vector data on the selected layers.

All Layers

Rasterizes all layers that contain vector and generated data.

Note:

To rasterize linked layers, select a linked layer, choose Layer > Select Linked Layers, and then rasterize the selected layers.

  Discontinuation of 3D features in Photoshop

Photoshop’s 3D features will be removed in future updates. Users working with 3D are encouraged to explore Adobe’s new Substance 3D collection, which represents the next generation of 3D tools from Adobe. Additional details on the discontinuation of Photoshop’s 3D features can be found here: Photoshop 3D | Common questions on discontinued 3D features.

Merge layers

When you have finalized the content of layers, you can merge them to reduce the size of your image files. When you merge layers, the data on the top layers replaces any data it overlaps on the lower layers. The intersection of all transparent areas in the merged layers remains transparent.

When you save a merged document, you cannot revert back to the unmerged state; the layers are permanently merged.

With Photoshop, you can apply any of the following merge operations on layers:

  • Merge down: To merge two adjacent visible layers where the bottom layer is a pixel layer, select the top layer in the Layers panel and then choose Layer > Merge Down, or choose Merge Down from the Layers panel’s menu, or press Cmd+E (macOS)/ Ctrl+E (Windows). Following this, Photoshop merges all top layers into the bottom pixel layer. You'll always need a pixel layer at the bottom of your layers to use the merge commands. 
  • Merge visible: To simply merge a selected few layers in your document, you can hide the layers you don’t want to combine and select a pixel layer as your base. Then, go to Layer > Merge Visible, or choose Merge Visible from the Layers panel’s menu, or press Shift+Cmd+E (macOS)/ Shift+Ctrl+E (Windows).
  • Merge active: Select all the layers you want to merge whether they are vector or pixel layers, and go to Layer > Merge Layers, or choose Merge Layers from the Layers panel’s menu, or press Cmd+E (macOS)/ Ctrl+E (Windows).
  • Merge linked: To merge linked layers together, select the linked layers by choosing Layer > Select Linked Layers, or choosing Select Linked Layers from the Layers panel’s menu, and then opting for the steps listed for merging active layers above.
Note:

You cannot use an adjustment or fill layer as the target layer for a merge.

Merge layers in a clipping mask

  1. Hide any layers that you do not want to merge.
  2. Select the base layer in the clipping mask. The base layer must be a raster layer.
  3. Choose Merge Clipping Mask from the Layers menu or the Layers panel menu.

For more information on clipping masks, see Mask layers with clipping masks.

Stamp multiple layers or linked layers

In addition to merging layers, you can also stamp them. Stamping allows you to merge the contents of more than one layer into a target layer while leaving the other layers intact. When you stamp multiple selected layers or linked layers, Photoshop creates a new layer containing the merged content.

You can prefer to use stamping when you want to edit multiple layers with the same tools but only one layer at a time. Stamping combines the selected layers into a new layer, leaving the original layers as is.

You can work with the following stamping options:

  • Stamp active layers: Select the layers that you want to stamp and then press Opt+Cmd+E (macOS)/ Alt+Ctrl+E (Windows).
  • Stamp visible: You can disable the layers that you do not wish to stamp by turning off their visibility in the Layers panel and then pressing Shift+Opt+Cmd+E (macOS)/ Shift+Alt+Ctrl+E (Windows). Also, you can hold Opt (macOS)/ Alt (Windows) as you select Merge Visible from the Layers panel’s menu to merge them into a new layer.

Flatten layers

Flattening reduces file size by merging all visible layers into the background and discarding hidden layers. Any transparent areas that remain are filled with white. When you save a flattened image, you cannot revert to the unflattened state as the layers get permanently merged.

You can work with any of the following flattening options:

  • Flatten Image: To flatten your entire Photoshop file, go to Layer > Flatten Image or select Flatten Image from the Layers panel’s menu.
  • Flatten All Layer Effects: To flatten only the layer styles instead of the entire image file, select File > Scripts > Flatten All Layer Effects. This makes the layer styles combine with the layer they are attached to. On applying any layer styles to vector layers like Type or Shape layers, the layer styles will get rasterized.
  • Flatten All Masks: To permanently apply masks to their associated layers, select File > Scripts > Flatten All Masks.

The image on the left shows the Layers panel (with three layers) and file size before flattening. The image on the right shows the Layers panel after flattening.

Note:

Converting an image between some color modes flattens the file. Save a copy of your file with all layers intact if you want to edit the original image after the conversion.


Buy Adobe Photoshop or start a Free Trial.​

Adobe logo

Sign in to your account