Dreamweaver içinde CSS ön işlemci dosyalarıyla çalışmayı ve onları derlemeyi öğrenin.

CSS ön işlemcileri önceden işlenmiş dilde yazılan kodu en bilinen CSS'ye derler. Önceden işlenmiş dil CSS'yi programlama diline daha yakın bir düzeye çıkarır.

Özellikle ön işlemciler; değişkenleri, karma kullanımları, işlevleri ve CSS'de mümkün olmayan daha birçok
tekniği kullanmanıza olanak tanır. CSS ön işlemcilerini kullanarak her şeyi aynı anda tanımlayabilir ve sürdürülebilir, tema oluşturulabilir ve genişletilebilir CSS'ler elde etmenize olanak tanıyacak şekilde defalarca tekrar kullanabilirsiniz.

Dreamweaver en popüler CSS ön işlemcileri olan Sass ve Less'i destekler ve ayrıca Dreamweaver Sass dosyalarını derlemek için Compass ve Bourbon çerçevelerini de destekler.

Less, JavaScript tabanlı iken Sass, Ruby tabanlıdır ancak dosyaları CSS'ye derlemek için bu diller hakkında herhangi bir şey bilmenize veya komut satırını kullanmanıza gerek yoktur. Bu dosyaları yüklediğinizde, düzenlediğinizde veya kaydettiğinizde Dreamweaver less.js JavaScript kitaplığını kullanarak onları CSS'ye otomatik derler.

Dreamweaver'ın CSS ön işlemcilerini kullanma yöntemi

Dreamweaver'ın CSS ön işlemcilerini kullanma yöntemi, bir site tanımlayıp tanımlamadığınıza göre değişir. Bir site sahibi olmak size Dreamweaver içinde CSS ön işlemcisi tercihlerini belirlemekle birlikte Compass ve Bourbon çerçevelerini kullanma özgürlüğü sunacağından Adobe bir site tanımlanmasını önermektedir.

Tanımlı bir siteniz varsa, siteye özel CSS ön işlemcisi tercihlerini belirleyerek Dreamweaver içinde CSS ön işlemcilerinin çalışma yöntemini özelleştirebilirsiniz.

Siteye özel CSS ön işlemcisi tercihlerini ayarlayarak site bazında derleme seçeneklerini belirleyebilirsiniz. Her site için Sass ve CSS dosyalarının konumuyla birlikte ön işlemci seçeneklerini de özelleştirebilirsiniz.

Bir site tanımladığınızda, Dreamweaver kendi içinde Sass çerçevelerini (Compass, Bourbon, Bourbon Neat ve Bourbon öğeleri) kullanmanıza olanak tanır.

Tanımlı bir siteniz yoksa, bu durumda Sass ve Less dosyalarınızı el ile derlemeyi tercih edebilirsiniz. Ancak Compass ve Bourbon çerçeveleri desteği bulunmamaktadır.

Dreamweaver'da CSS ön işlemcileri nasıl kullanılır?

CSS ön işlemcileri kullanıldığında gerçekleştirilen görevlerin üst düzeyli bir iş akışı şu şekildedir:

  1. Dreamweaver'da bir site tanımlayın. Derlemeye çalıştığınız Sass veya Less dosyasının site kök klasörüne eklendiğinden emin olun. Daha önce bir site tanımladıysanız ve Sass/Less dosyası sitenin kök dizinine eklenmişse, bir sonraki adıma geçin. Bir Dreamweaver sitesi kurma hakkında daha fazla bilgi için bkz. Dreamweaver siteleri hakkında.
  2. CSS ön işlemcileri tercihlerini (oluşturulan CSS dosyalarının konumunu tanımlama gibi) ayarlama. Bu tercihler siteye özeldir. Daha fazla bilgi için bkz. Siteye özel CSS ön işlemcisi tercihlerini ayarlama.
  3. Compass veya Bourbon gibi özel çerçeveler kullanmak istiyorsanız bu çerçevelerin ayarlarını belirleyebilirsiniz. Daha fazla bilgi için bkz. Compass çerçevesi kullanma veya Bourbon çerçevesi kullanma.
  4. Otomatik derlemeyi ayarlayın veya Sass ve Less dosyalarını el ile derleyin. Daha fazla bilgi için bkz. CSS ön işlemcisi dosyalarını derleme.

CSS ön işlemcisi tercihlerini ayarlama

Site > Siteleri Yönet iletişim kutusunu kullanarak CSS ön işlemcilerinin siteye özel tercihlerini ayarlayabilirsiniz.

CSS ön işlemcisi tercihlerini siteye özel tutarak, CSS ön işlemcilerinizi site bazında yönetebilir ve böylelikle siteler arasında her geçiş yaptığınızda tercihleri güncellemek zorunda kalmadan her bir sitenin CSS ön işlemcisi üzerinde hakimiyet kurabilirsiniz.

Genel CSS ön işlemcisi ayarlarını belirleme

Aşağıdaki genel CSS ön işlemcisi ayarlarını Siteler > Siteleri Yönet > CSS Ön İşlemcileri iletişim kutusunda belirleyebilirsiniz.

Genel CSS ön işlemcisi ayarları
Genel CSS ön işlemcisi ayarları

Dosya Kaydedilirken Otomatik Derlemeyi Etkinleştir

CSS ön işlemcilerinin otomatik derlenmesini etkinleştirmek için bu onay kutusunu işaretleyin. Bu seçeneği belirlerseniz Sass, Less veya SCSS dosyanızı kaydettiğinizde Dreamweaver otomatik olarak bir CSS dosyası oluşturur. Bu seçenek belirlenmezse, her değişiklik yaptığınızda dosyaları el ile derlemek zorunda kalırsınız.

Less seçenekleri

Kesin Hesaplamaya İzin Ver

Yalnızca parantez içindeki hesaplamaları yapar. Örneğin, (100pks/25pks) başarılı bir şekilde işlenir ancak %20 + %10 (parantezler olmadan) işlenmez. Bu seçenek devre dışı bırakıldığında dosyadaki tüm hesaplamalar yapılır.

Kesin Birimlere İzin Ver

Hesaplamanın ardından CSS'de tahmin edilen bir birimin çıktısını oluşturur. Örneğin, 5pks * 2pks derlendiğinde 10pks2 değil, 10pks elde edilir.

Bu seçenek devre dışı bırakıldığında, hesaplamalar yapılırken Less çıktı birimi tahmin etmeye çalışır.

Bu örnekte CSS aşağıdaki gibi oluşturulur:

.class {
  property: 1px * 2px;
}

Bu örnekte, tahmin doğru değildir (bir uzunlukla çarpılan bir uzunluk bir alan verir ancak CSS alanların belirtilmesini desteklemez). Buradaki varsayıma göre kullanıcı değerlerden birinin bir uzunluk birimi değil bir değer olmasını istemiş ve Dreamweaver 10px sonucunu getirmiştir.

Kesin birimler açıkken, oluşturulan bu CSS'nin bir hata olduğu kabul edilir.

URL'leri Göreceli URL Olarak Yeniden Yaz

İçe aktarılan dosyalardaki URL'leri daima temel içe aktarılan dosyayla göreceli olacak şekilde yeniden yazar. Yani, bir Less dosyası bir görüntüye tekabül eden başka bir Less dosyasını içe aktarırsa derlenmiş CSS'de göreceli URL gösterilir.

Kaynak eşlemesi oluştur

Kaynak eşleme oluşturur (Sass ve Less gibi üst düzeyli dillerle derlendikleri alt düzeyli dil arasındaki boşluğu kapatan CSS benzeri dosya).

Sass/SCSS seçenekleri

Çıktı Dosyası Stili

CSS çıktı dosyasının stilini belirtir:

  • Yuvalanmış - Derlenmiş CSS'yi iyi bilinen, modüler yapıda formatlar.
  • Kompakt - Derlenmiş CSS'yi Yuvalanmış veya Genişletilmiş yapılara göre daha az yer kaplayan Kompakt bir yapıda formatlar.
  • Sıkıştırılmış - CSS çıktısını düz bir yapıda oluşturur.
  • Genişletilmiş - CSS'yi her özellik ve kural bir satır alacak şekilde genişletilmiş bir yapıda oluşturur. Özellikler kurallar içinde girintilenir ancak kurallar hiçbir şekilde girintilenmez.

Kaynak Yorumları Oluştur

Çıktı CSS dosyasında, CSS kodunu oluşturulduğu satırla eşleyen yorumlar oluşturur.

Kaynak eşlemesi oluştur

Kaynak eşleme oluşturur (Sass ve Less gibi üst düzeyli dillerle derlendikleri alt düzeyli dil arasındaki boşluğu kapatan CSS benzeri dosya).

CSS kaynağı ve çıktısı tercihlerini ayarlama

Yoldaki bir Sass/LESS dosyası harici bir düzenleyici ile değiştirildiğinde Dreamweaver tarafından izlenip otomatik derlemenin başlatılacağı yeri ve oluşturulan CSS dosyalarının yerleştirileceği konumu tanımlayabilirsiniz.

Kaynak ve çıktı CSS ön işlemcisi ayarları
Kaynak ve çıktı CSS ön işlemcisi ayarları

Aşağıdaki kaynak ve çıktı CSS ön işlemcisi ayarlarını Siteler > Siteleri Yönet iletişim kutusunda belirleyebilirsiniz.

CSS Çıktısı

Oluşturulan CSS çıktı dosyasının konumunu belirtin.

Kaynakla aynı klasöre

CSS dosyalarının kaynak Sass ve Less dosyalarıyla aynı klasöre kaydedilmesini istiyorsanız bu seçeneği belirleyin.

Çıktı klasörünü tanımla

Bu seçeneği belirleyin ve oluşturulan CSS dosyalarını kaydetmek istediğiniz bir klasörü belirtin.

Giriş yolu parçasını değiştir

Bu seçenek, From ve To dizelerini kullanarak yolun bir bölümünü değiştirmenize olanak tanır.

Örneğin, From: scss ve To:css ayarında çıktı dosyası css yolundaki SCSS'yi değiştirdikten sonra aynı ağaç yapısına yerleştirilir.

Kaynak Klasör

İzlenmesi gereken site kökü içindeki alt klasörü belirtin. Genellikle bu alt klasör tüm SCSS veya LESS dosyalarınızı içerir.

Genel ayarlar bölümünde Derlemeyi etkinleştirdiyseniz, bu klasördeki herhangi bir dosya dışarıdan veya Dreamweaver içinden değiştirildiğinde Dreamweaver, CSS Ön İşlemcisini otomatik olarak başlatır.

Compass çerçevesini kullanma

Compass, Sass kullanarak CSS3 stil sayfaları oluşturmanızı sağlayan bir açık kaynak CSS Tasarım Çerçevesidir.

Dreamweaver, Compass'a destek sunar. Stil sayfalarını Compass kullanarak oluşturursanız, bu durumda bu stil sayfalarını derleyebilir ve CSS dosyalarını Dreamweaver içinden oluşturabilirsiniz.

  1. Compass dosyalarını yükleme.

    Compass sisteminizde yüklü değilse Dreamweaver içinden yükleyebilirsiniz.

    Site Kurulumu iletişim kutusunda CSS Ön İşlemcileri > Compass seçeneğini belirleyin. Compass Kullan seçeneğini belirleyip ardından Dosyaları Yükle'yi tıklatın.

    Compass dosyalarını yükleme
    Compass dosyalarını yükleme

    Tüm Compass dosyaları ve *.rb yapılandırma dosyası site klasörünüze yüklenir ve bunları Dosyalar panelinde görebilirsiniz.

    Yüklü Compass dosyaları
    Yüklü Compass dosyaları

  2. Mevcut bir Ruby tabanlı yapılandırma dosyasını belirtme

    Makinelerinizde Compass yüklüyse ve Compass *.rb dosyası kurulmuşsa, Dreamweaver Site Kurulumu iletişim kutusundan geçerli site kökü içindeki Compass*.rb dosyasına giden yolu belirtin.

    1. Site Kurulumu iletişim kutusunda CSS Ön İşlemcileri > Compass seçeneğini belirleyin.
    2. Compass Kullan onay kutusunu işaretleyin.
    3. Ruby tabanlı yapılandırma dosyasını belirtmeyi tıklatın ve dosya konumuna gidin. Tamamlandığında Kaydet'i tıklatın.
    Mevcut bir Ruby tabanlı yapılandırma dosyasını belirtme
    Mevcut bir Ruby tabanlı yapılandırma dosyasını belirtme

    Not:

    Bu dosya sitenizin kök klasöründe bulunmalıdır.

  3. Yapılandırma seçeneklerini el ile belirleme

    Mevcut bir yapılandırma seçeneğiniz yoksa, bunları el ile belirlemeyi tercih edebilirsiniz.

    1. Site Kurulumu iletişim kutusunda CSS Ön İşlemcileri > Compass seçeneğini belirleyin.
    2. Compass Kullan onay kutusunu işaretleyin.
    3. Yapılandırma Seçeneklerini El ile Belirlemeyi tıklatın. Aşağıdaki yapılandırma seçeneklerini belirleyin ve Kaydet'i tıklatın.

    Aşağıdaki alanlar otomatik olarak doldurulur, ancak bunları gereksinimlerinize göre değiştirebilirsiniz:

    Not:

    Bu seçeneklerde seçili tüm yollar site kökü içinde olmalıdır.

    HTTP Yolu

    Web sunucusu içinde çalışılırken projenin yolu. Varsayılan olarak "/".

    Görüntüler Dizini

    Görüntülerin tutulduğu dizin. project_path ile ilişkilidir.

    Oluşturulan Görüntüler Dizini

    Oluşturulan görüntülerin tutulduğu dizin. project_path ile ilişkilidir. Varsayılan olarak images_dir değeridir.

    Fontlar Dizini

    Font dosyalarının tutulduğu dizin.

    Göreceli Varlıklar

    Compass yardımcı işlevlerinin oluşturulan CSS'den varlıklara göreceli URL'ler mi yoksa bu varlık türünün http yolunu kullanarak mutlak URL'ler mi oluşturması gerektiğini belirtir.

  4. Siteler > Siteleri Yönet > CSS Ön İşlemcileri iletişim kutusunda Dosya Kaydedilirken Otomatik Derlemeyi Etkinleştir'i seçtiyseniz, değişiklikleri Sass dosyalarınıza her kaydettiğinizde Dreamweaver bir CSS dosyası oluşturur. Ayrıca bu değişiklikleri tarayıcınızın penceresinde gerçek zamanlı olarak önizleyebilirsiniz. Değişikliklerinizi tarayıcıda gerçek zamanlı olarak önizleme hakkında daha fazla bilgi için bkz. Gerçek zamanlı önizleme.

    Otomatik derleme istemiyorsanız, aşağıdakilerden birini yaparak CSS dosyasını el ile derleyebilirsiniz:

    • Dosyalar panelinde Sass, Less veya SCSS dosyasını sağ tıklatın ve Derle'yi tıklatın.
    • Geçerli dosyayı derlemek için Araçlar > Derle'yi tıklatın.
  5. Ardından derlenen CSS dosyanızı sitenizdeki HTML dosyalarına ekleyebilirsiniz. Daha fazla bilgi için bkz. Harici bir CSS stil sayfasına bağ oluşturma.

Bourbon çerçevesini kullanma

Dreamweaver, Bourbon ürün ailesini destekler. Stil sayfalarını Bourbon kullanarak oluşturursanız, bu durumda bu stil sayfalarını derleyebilir ve CSS dosyalarını Dreamweaver içinden oluşturabilirsiniz.

Desteklenen Bourbon çeşitleri şunlardır:

  • Bourbon - Sass için basit ve hafif bir karışım kitaplığı
  • Bourbon Neat - Sass ve Bourbon için hafif bir semantik ızgara çerçevesi
  • Bourbon Bitters - Bourbon projeleri için iskele stilleri, değişkenler ve yapı

Şunlardan birini kodunuza ekleyerek Bourbon çerçevesini içe aktarabilirsiniz:

  • @import "bourbon" - Bourbon'u içe aktarmak için
  • @import “neat” – Bourbon Neat'i içe aktarmak için
  • @import “base” – Bourbon Bitter'i içe aktarmak için

Ardından Dreamweaver ön işlemci dosyalarını derlerken Bourbon'un önceden paketlenmiş sürümünü kullanır.

Alternatif olarak, başka Dreamweaver güncellemelerinin derleme iş akışlarınızı etkilememesi için sitenize Bourbon çerçeve dosyalarını yükleyebilirsiniz. Bourbon çerçeve dosyaları, sitenize kopyalanır ve çerçeveyi içe aktaran dosyalardan herhangi biri için derleme başlatıldığında bu çerçeve kullanılır.

Bourbon, Bourbon Neat veya Bourbon Bitters dosyalarını yükleme

Bourbon veya çeşitlerini yüklemek için:

  1. Site Kurulumu iletişim kutusunda, CSS Ön İşlemcileri > Bourbon, Bourbon Neat veya Bourbon Bitters seçeneğini belirleyin.

  2. Dosyaları siteniz içinde belirtilen site kök klasörü konumuna yüklemek için Dosyaları Yükle'yi tıklatın.

    Bourbon dosyalarını yükleme
    Bourbon dosyalarını yükleme

    Tüm Bourbon dosyaları site klasörünüze yüklenir ve bunları Dosyalar panelinde görebilirsiniz.

    Yüklü Bourbon dosyaları
    Yüklü Bourbon dosyaları

    Bir hata varsa, hatalar Çıktı panelinde (Pencere > Sonuçlar > Çıktı) görüntülenir ve durum çubuğu simgesi kırmızıya dönüşür.

CSS ön işlemcisi dosyalarını derleme

CSS ön işlemcisi dosyalarını şu yöntemlerden birini kullanarak etkinleştirebilirsiniz:

CSS ön işlemcisi dosyalarını otomatik derlemeyi ayarlama

Bir Sass veya Less dosyasında yapılan değişiklikleri eşdeğeri olan CSS'ye otomatik derlemek için Dreamweaver içinden seçenekleri ayarlayabilirsiniz. Oluşturulan CSS'yi depolamak istediğiniz konumları (site kökünde) belirtebilirsiniz.

  1. Site Kurulumu iletişim kutusunda CSS Ön İşlemcileri > Genel > Dosya Kaydedilirken Otomatik Derlemeyi Etkinleştir seçeneğini belirleyin.

    Otomatik derlemeyi etkinleştirme
    Otomatik derlemeyi etkinleştirme

  2. Site Kurulumu iletişim kutusunda CSS Ön İşlemcileri > Kaynak ve Çıktı seçeneğini belirleyin.

  3. Kaynak ve Çıktı iletişim kutusunda, oluşturulan CSS dosyalarınızı kaydetmek istediğiniz konumları belirtin. Aşağıdaki seçeneklerden birini tercih edebilirsiniz:

    Kaynakla aynı klasöre

    CSS dosyalarının kaynak Sass ve Less dosyalarıyla aynı klasöre kaydedilmesini istiyorsanız bu seçeneği belirleyin.

    Çıktı klasörünü tanımla

    Bu seçeneği belirleyin ve oluşturulan CSS dosyalarını kaydetmek istediğiniz bir klasörü belirtin.

    Giriş yolu parçasını değiştir

    Bu seçenek, From ve To dizelerini kullanarak yolun bir bölümünü değiştirmenize olanak tanır.

  4. Dreamweaver tarafından “izlenmesi” gereken Sass veya Less dosyalarının bulunduğu klasörü belirtin.

    Bu izlenen klasör içindeki dosyalardan herhangi biri üzerinde değişiklik yaparsanız, dosyaları kaydetmenizin ardından Dreamweaver tarafından otomatik olarak derlenirler.

    Kaynak ve çıktı CSS ön işlemcisi ayarları
    Kaynak ve çıktı CSS ön işlemcisi ayarları

    Not:

    Dreamweaver dışında değişiklik yapsanız bile (örneğin bir metin düzenleyicisi kullanarak) Dreamweaver bu dosyaları izler ve derler.

Başarılı bir derlemenin ardından Çıktı panelinde (Pencere > Sonuçlar > Çıktı) bir mesaj görüntülenir ve durum çubuğundaki durum simgesi yeşil <icon> olarak görüntülenir. Panelde başarı mesajını çift tıklatarak derlenen CSS'yi açabilirsiniz.

Herhangi bir hata bulunursa CSS başarılı bir şekilde derlenmemiştir. Durum simgesi kırmızı <icon> olarak görünür, Çıktı panelinde tüm hatalar ve uyarılar listelenir. Bu paneldeki bir hata mesajını çift tıklatarak koddaki hatalı satıra hızlı bir şekilde atlayabilirsiniz. CSS dosyası tüm hatalar çözümleninceye kadar başarılı bir şekilde derlenmez.

Not:

Çıktı paneli genellikle çalışma alanının alt kısmına sabitlenmiştir. Panel kapanırsa Pencere > Çıktı paneli seçeneğini kullanarak paneli açabilirsiniz.

Durum simgesi kırmızı görünürken Çıktı panelinin durumunu da değiştirebilirsiniz (göster/gizle).

Derlenmiş CSS dosyasını aldıktan sonra web sayfanız ile stil sayfası arasında bağ oluşturabilirsiniz. CSS ön işlemcilerinde herhangi bir değişiklik yaptığınızda karşılık gelen derlenmiş CSS dosyaları otomatik olarak güncelleştirilir. Web sayfası da Canlı Görünüm'de otomatik olarak yenilenir.

Web sayfanızı stil sayfasına bağlama hakkında daha fazla bilgi için bkz. Harici bir CSS stil sayfasına bağ oluşturma.

CSS Ön İşlemcisi dosyasını el ile derleme

Bazı durumlarda (örneğin, bir Dreamweaver sitesi tanımlamadıysanız), bir CSS ön işlemci dosyasını el ile derlemek isteyebilirsiniz.

Bu gibi durumlarda, Site Ayarları iletişim kutusunun CSS Ön İşlemcileri > Genel panelinde, Dosya Kaydedilirken Otomatik Derlemeyi Etkinleştir seçeneğini devre dışı bırakın.

CSS ön işlemcisini el ile derlemek için Dosyalar panelinde dosyayı sağ tıklatın ve sonra Derle'yi tıklatın.

Dosyalar panelinden CSS ön işlemcisi dosyalarını el ile derleme
Dosyalar panelinden CSS ön işlemcisi dosyalarını el ile derleme

Geçerli dosyayı derlemek için Araçlar > Derle'yi de tıklatabilirsiniz.

Bu çalışma Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License kapsamında lisanslanmıştır  Creative Commons şartları, Twitter™ ve Facebook sitelerinde paylaşılanları kapsamaz.

Yasal Uyarılar   |   Çevrimiçi Gizlilik İlkesi