Dreamweaver'ın Parçacıklar panelini kullanarak parçacıklar oluşturmayı ve kodunuzu farklı Dreamweaver sitelerinde yeniden kullanmayı öğrenin.

Kod bloklarını birçok kez yazdığınızı fark ettiyseniz kod yazma işlemini hızlandırmak için kod parçacıklarını kullanabilirsiniz. Kodu bir kez yazıp bir parçacık olarak kaydedin ve ardından birden çok yerde kullanmak için Parçacıklar paneline giderek bu kodu çift tıklatın.

Parçacıklar panelini kullanarak oluşturduğunuz parçacıklar, siteye özel değildir ve diğer sitelerde tekrar kullanılabilir. Ayrıca, senkronizasyon ayarlarını kullanarak parçacıkları farklı cihazlarda ve Dreamweaver'ın farklı sürümlerinde de kullanabilirsiniz.

Dreamweaver, birden çok kod parçacığı ile birlikte sunulur. Ancak kendi kod parçacıklarınızı da oluşturup kaydedebilirsiniz.

Bir parçacığı en iyi şekilde nasıl kullanabilirsiniz?

İş akışınızda parçacıkları nerede kullanabileceğinizi anlamak için aşağıdaki kullanım durumlarına göz atın:

  • İster belli tasarım standartlarını takip eden bir kuruluşta çalışın, ister birden çok projeyi yürüten bir serbest çalışan olun; her iki senaryoda da bu yaygın kod bölümlerini parçacık olarak kaydederek ve ardından parçacıkları kodunuza ekleyerek tasarım bütünlüğüne ulaşmak için kod parçacıklarını kullanabilirsiniz.
  • Bazı kodlama standartlarını tanımlamanız, korumanız ve yerine getirmeniz gerekirse kod parçacıkları çok faydalı olacaktır.
  • Bir web sayfasında dinamik öğelerin kodlarını el ile yazmak oldukça fazla zaman alabilir. Parçacıklar panelinin Responsive_Design_Snippets bölümünden veya Bootstrap'ten bazı parçacıkları kullanın (örneğin, bir dinamik tablo kodu parçacığı). Tek bir tıklatmaya bu dinamik tablo için neredeyse 20 satırlık kod girdiniz.
    Tabloyu gerektiği şekilde düzenleyin. Sütunları veya satırları birleştirebilir, sütun ya da satır ekleyebilir, istediğiniz şekilde düzenleme yapabilir ve ardından kodu seçip yeni bir kod parçacığı olarak kaydederek oluşturduğunuz diğer sayfaların tümünde tekrar kullanabilirsiniz. Kod parçacıkları oluşturma hakkında daha fazla bilgi için bkz. Parçacık oluşturma.
  • JavaScript davranışları, CSS efektleri ve CSS stilleri de kodun yeniden kullanımı için mükemmel birer adaydır.

Parçacıklar paneli

Dreamweaver uygulamasında, kod parçacıklarını Parçacıklar panelini kullanarak yönetebilirsiniz (Pencere > Parçacıklar).

Parçacıklar paneli, kod bölümlerinin bir koleksiyonu gibidir.

Dreamweaver'da Parçacıklar paneli
Dreamweaver'da Parçacıklar paneli

Parçacıklar panelinde yapabilecekleriniz

Parçacıklar panelini kullanarak aşağıdaki görevleri gerçekleştirebilirsiniz.

Parçacık ekleme

Kod parçacığına gitmek için klasörleri genişletin ve kod parçacığını çift tıklatın veya parçacığı imleç konumuna eklemek için Ekle simgesini tıklatın. Mevcut metni bir kod parçacığının içine sarmak için metni seçin, ardından parçacığı ekleyin. Metin, kod parçacığının içine sarılır. Daha fazla bilgi için bkz. Parçacık ekleme.

Parçacık Klasörü Oluşturma

Sezgisel bir adlandırma yöntemiyle parçacıklarınızı klasörlere yerleştirerek yönetin. Bir parçacık klasörü oluşturmak için Yeni Klasör simgesini tıklatın. Seçilen bir düğüm içerisinde yeni parçacık klasörü oluşturulur. Parçacık klasörünün konumunu değiştirmek için klasörü istediğiniz konuma sürükleyin. Daha fazla bilgi için bkz. Parçacık klasörü oluşturma

Parçacık oluşturma

Önceden paketlenen parçacıkları kullanın ve kendi kod parçacıklarınızı oluşturmak için bunları düzenleyin. Alternatif olarak, en başından kendi parçacıklarınızı oluşturup bunları daha sonra yeniden kullanmak üzere Parçacıklar paneline kaydedin. Daha fazla bilgi için bkz. Parçacık oluşturma.

Parçacık düzenleme

Varolan bir parçacığı düzenlemek için, parçacığı seçip Düzenle simgesini tıklatın. Daha fazla bilgi için bkz. Parçacık düzenleme.

Parçacık silme

Artık ihtiyacınız olmayan parçacıkları silin. Bir parçacığı silmek için parçacığı seçip Sil simgesini tıklatın.

Parçacıkları yeniden adlandırma

Bir parçacığı yeniden adlandırmak için bağlam menüsünü açmak üzere parçacığı sağ tıklatın. Parçacığı yeniden adlandır seçeneğini belirledikten sonra yeni parçacık adını yazın.

Tetikleyici tuşlarını ekleme/düzenleme

Tetikleyici tuşları, Parçacıklar panelinde belirli bir parçacığa gidip parçacığı eklemek yerine yazabileceğiniz kısa ve sezgisel kodlar oluşturmanıza olanak sağlar. Tetikleyici tuşlarını tanımladıysanız imlecinizi kodda gerekli noktaya yerleştirin. Ardından tetikleyici tuş metnini yazın ve sekmeye basın. Kod parçacığı kodunuza eklenir. Daha fazla bilgi için bkz. Tetikleyici tuşları ekleme ve tetikleyici tuşlarını kullanarak parçacık ekleme.

Parçacık ekleme

Kod parçacıklarınızı kodunuzda imlecin durduğu yere ekleyebilirsiniz.

  1. İmleci, kod parçacığını eklemek istediğiniz ekleme noktasına getirin.

  2. Parçacıklar panelinde (Pencere > Parçacıklar) parçacığı çift tıklatın veya Parçacıklar panelinin alt kısmındaki Ekle simgesini tıklatın.

    Ayrıca parçacığı sağ tıklatabilir (Windows) veya Control tuşunu basılı tutup tıklatabilir (Macintosh) ve açılır menüden Ekle'yi seçebilirsiniz.

Not:

Tetikleyici tuşlarını tanımladıysanız imlecinizi kodda gerekli noktaya yerleştirin. Ardından tetikleyici tuş metnini yazın ve sekmeye basın. Kod parçacığı kodunuza eklenir. Daha fazla bilgi için bkz. Tetikleyici tuşları ekleme ve tetikleyici tuşlarını kullanarak parçacık ekleme.

Not:

Kod parçacığının nasıl göründüğünü görmek için tasarım görünümünde bir parçacık ekleyin.

Parçacık oluşturma

  1. Parçacıklar panelinde, panelin altındaki Yeni Parçacık simgesini tıklatın.

  2. Parçacık için bir ad girin.

    Not:

    Parçacık adları, dosya adlarında eğik çizgiler (/ veya \), özel karakterler ya da çift tırnak işareti (“) gibi geçersiz olan karakterleri içeremez.

  3. (İsteğe bağlı) Parçacığın metin açıklamasını girin.

    Metin açıklaması, diğer ekip üyelerinin parçacığı tanımlamasını ve kullanmasını daha kolay hale getirir.

    Yeterli bir açıklama ile kod parçacığı oluşturma, parçacığın daha sonraki kullanımlar için kolayca tanımlanmasını sağlar
    Yeterli bir açıklama ile kod parçacığı oluşturma, parçacığın daha sonraki kullanımlar için kolayca tanımlanmasını sağlar

    Not:

    Ayrıca parçacıkları kodunuza eklemek için tetikleyici tuşları da oluşturabilirsiniz. Daha fazla bilgi için bkz. Tetikleyici tuşları ekleme ve tetikleyici tuşlarını kullanarak parçacık ekleme.

  4. Tamam'ı tıklatın.

Parçacık düzenleme

Mevcut parçacıkta değişiklikler yapmak için şunları yapabilirsiniz:

  • Parçacığı Düzenle iletişim kutusunu açmak için parçacığı sağ tıklatın
  • Parçacığı seçin ve panelin alt kısmındaki Parçacığı Düzenle simgesini tıklatın

Parçacığı düzenlediğinizde, bu parçacığın belgedeki var olan örnekleri güncellenmez.

Parçacık iletişim kutusundaki tüm alanları düzenleyebilirsiniz (Adı, Açıklama, tetikleyici tuş ve kod gibi).

Parçacık klasörü oluşturma

  1. Parçacıklar panelinde, panelin altındaki Yeni Parçacık Klasörü simgesini tıklatın.

  2. Parçacıkları, isteğinize göre yeni klasöre veya diğer klasörlere sürükleyin.

Tetikleyici tuşları ekleme ve tetikleyici tuşlarını kullanarak parçacık ekleme

Hızlıca kod parçacıkları eklemek için tetikleyici tuşlarını kullanın.

Öncelikle tetikleyici tuşlarını sık kullandığınız tüm parçacıklara atayın. Ardından Kod görünümünde, Tetikleyici tuş metnini yazın ve sekmeye basın. Dreamweaver, parçacığı imleç konumuna ekler.

  1. Parçacıklar panelinde sağ tıklatın (Windows) veya Control tuşuna basılı tutup tıklatın (Macintosh) ve Tetikleyici Tuş Ekle seçeneğini belirleyin.

    Parçacıklar panelinde Tetikleyici Tuş Ekle'yi seçin
    Parçacıklar panelinde Tetikleyici Tuş Ekle'yi seçin
  2. Tetikleyici tuş alanına gerekli metni girin.

    Aşağıdaki görüntüde, hatırlamayı kolaylaştırmak için mailto bağı oluşturma kod parçacığı, mailto öğesinin tetikleyici tuşuna atanmıştır. Basit, kısa ve sezgisel tetikleyici tuşları seçtiğinizden emin olun.

    Tetikleyici Tuş alanına metin girin
    Tetikleyici Tuş alanına metin girin

    Not:

    Tetikleyici tuşlar herhangi bir özel karakter içeremez (alt çizgi hariç). Buna ek olarak, aynı tetikleyici tuş iki farklı parçacık için kullanılamaz.

  3. Tetikleyici tuşları kullanarak kodunuza parçacık eklemek için tetikleyici metnini yazın (Kod görünümünde) ve parçacığı kodunuza eklemek için sekmeye basın.

Birden fazla cihaz arasında parçacıkları dağıtma

Dreamweaver'ın bulut senkronizasyonu özelliği, parçacıkları iki makine arasında senkronize etmenize yardımcı olur.

Dreamweaver'ın bir örneği kullanılarak oluşturulan parçacıkları Dreamweaver çalıştıran başka bir makineye (örneğin, Dreamweaver'ın ofis ve ev kurulumları) uyarlamak için Dreamweaver'ın senkronizasyon ayarlarını kullanın. 

Ayarları senkronize etmek için:

  1. Düzen > Tercihler'i tıklatın.

  2. Ayarları Senkronize Et bölümünde Ayarları Şimdi Senkronize Et'i tıklatın.

    Ayarlar buluta kaydedilir. Dreamweaver'ı bir sonraki başlatmanızda bu ayarlar içe aktarılır. Yerel ayarlar, buluttan içe aktarılan ayarlar tarafından geçersiz kılınır.

    Parçacıklarınız ve diğer tüm tercih ayarlarınız senkronize edilir.

    Senkronizasyon ayarları hakkında daha fazla bilgi için bkz. Dreamweaver ayarlarını Creative Cloud ile senkronize etme.

Not:

Ayarları senkronize etme işlemini sık sık gerçekleştiriyorsanız Tercih panelinde yer alan Ayarları Senkronize Et bölümünde Otomatik Senkronizasyonu Etkinleştir seçeneğini tıklatarak otomatik senkronizasyonu etkinleştirin. Ayarlarda yaptığınız her değişiklik otomatik olarak buluta kaydedilir.

Bu çalışma Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License kapsamında lisanslanmıştır  Creative Commons şartları, Twitter™ ve Facebook sitelerinde paylaşılanları kapsamaz.

Yasal Uyarılar   |   Çevrimiçi Gizlilik İlkesi