Kullanıcı Kılavuzu İptal

Dreamweaver'da Git'i kullanma

  1. Dreamweaver Kullanıcı Kılavuzu
  2. Giriş
    1. Dinamik web tasarımı hakkında temel bilgiler
    2. Dreamweaver'daki yenilikler
    3. Dreamweaver ile web geliştirme - Genel bakış
    4. Dreamweaver / Yaygın Sorular
    5. Klavye kısayolları
    6. Dreamweaver sistem gereksinimleri
    7. Özellik özeti
  3. Dreamweaver ve Creative Cloud
    1. Dreamweaver ayarlarını Creative Cloud ile senkronize etme
    2. Dreamweaver'da Creative Cloud Libraries
    3. Dreamweaver'da Photoshop dosyalarını kullanma
    4. Adobe Animate ve Dreamweaver ile çalışma
    5. Web için en iyileştirilmiş SVG dosyalarını Libraries'den ayıklama
  4. Dreamweaver çalışma alanları ve görünümleri
    1. Dreamweaver çalışma alanı
    2. Dreamweaver çalışma alanını görsel geliştirme açısından en iyileştirme
    3. Dosya adına veya içeriğe göre dosya arama | Mac OS
  5. Site kurma
    1. Dreamweaver siteleri hakkında
    2. Sitenizin yerel bir sürümünü kurma
    3. Yayımlama sunucusuna bağlanma
    4. Test sunucusu kurma
    5. Dreamweaver site ayarlarını içe ve dışa aktarma
    6. Mevcut web sitelerini uzak sunucudan yerel site köküne getirme
    7. Dreamweaver'daki erişilebilirlik özellikleri
    8. Gelişmiş ayarlar
    9. Dosya aktarmak için site tercihlerini ayarlama
    10. Dreamweaver'da proxy sunucu ayarlarını belirtme
    11. Dreamweaver ayarlarını Creative Cloud ile senkronize etme
    12. Dreamweaver'da Git'i kullanma
  6. Dosyaları yönetme
    1. Dosyaları oluşturma ve açma
    2. Dosyaları ve klasörleri yönetme
    3. Sunucunuzdan dosya alma ve dosyaları sunucunuza koyma
    4. Dosyaları teslim etme ve teslim alma
    5. Dosyaları senkronize etme
    6. Dosyaları farklılıklar açısından karşılaştırma
    7. Dreamweaver sitenizde dosya ve klasör perdeleme
    8. Dreamweaver siteleri için Tasarım Notları'nı etkinleştirme
    9. Olası Gatekeeper zaafını önleme
  7. Mizanpaj ve tasarım
    1. Mizanpaj için görsel yardımcılar kullanma
    2. Sayfanızın mizanpajını hazırlamak için CSS'yi kullanma hakkında
    3. Bootstrap kullanarak dinamik web siteleri tasarlama
    4. Dreamweaver'da ortam sorguları oluşturma ve kullanma
    5. Tablolara sahip içerik sunma
    6. Renkler
    7. Değişken ızgara mizanpajlarını kullanarak dinamik tasarım
    8. Dreamweaver'da Extract
  8. CSS
    1. Basamaklı Stil Sayfaları'nı anlama
    2. CSS Tasarımcısı'nı kullanarak sayfa mizanpajını yapma
    3. Dreamweaver'da CSS ön işlemcilerini kullanma
    4. Dreamweaver'da CSS Stili tercihlerini ayarlama
    5. Dreamweaver'da CSS kurallarını taşıma
    6. Dreamweaver'da satır içi CSS'yi CSS kuralına dönüştürme
    7. Div etiketleriyle çalışma
    8. Arka plana degradeler uygulama
    9. Dreamweaver'da CSS3 geçiş efektleri oluşturma ve düzenleme
    10. Kodu formatlama
  9. Sayfa içeriği ve varlıklar
    1. Sayfa özelliklerini ayarlama
    2. CSS başlığı özelliklerini ve CSS bağ özelliklerini ayarlama
    3. Metinle çalışma
    4. Metni, etiketleri ve nitelikleri bulma ve değiştirme
    5. DOM paneli
    6. Canlı Görünüm'de düzenleme
    7. Dreamweaver'da belgeleri kodlama
    8. Belge penceresinde öğe seçme ve görüntüleme
    9. Özellik denetiminde metin özelliklerini belirleme
    10. Web sayfası üzerinde yazım denetimi gerçekleştirme
    11. Dreamweaver'da yatay cetveller kullanma
    12. Dreamweaver'da font birleşimlerini ekleme ve değiştirme
    13. Varlıklarla çalışma
    14. Dreamweaver'da tarih ekleme ve güncelleştirme
    15. Dreamweaver'da sık kullanılan varlıklar oluşturma ve yönetme
    16. Dreamweaver'da görüntü ekleme ve düzenleme
    17. Medya nesneleri ekleme
    18. Dreamweaver'da video ekleme
    19. HTML5 video ekleme
    20. SWF dosyaları ekleme
    21. Ses efektleri ekleme
    22. Dreamweaver'da HTML5 ses ekleme
    23. Kitaplık öğeleriyle çalışma
    24. Dreamweaver'da Arapça ve İbranice metin kullanma
  10. Bağlama ve gezinme
    1. Bağlama ve gezinme hakkında
    2. Bağ oluşturma
    3. Görüntü eşlemeleri
    4. Bağlantı sorunlarını giderme
  11. jQuery bileşenleri ve efektleri
    1. Dreamweaver'da jQuery UI ve Mobile bileşenlerini kullanma
    2. Dreamweaver'da jQuery efektlerini kullanma
  12. Web sitelerini kodlama
    1. Dreamweaver'da kod yazma hakkında
    2. Dreamweaver'da kodlama ortamı
    3. Kodlama tercihlerini ayarlama
    4. Kod rengini özelleştirme
    5. Kod yazma ve düzenleme
    6. Kod ipuçları verme ve kod tamamlama
    7. Kodu daraltma ve genişletme
    8. Parçacıklar ile kodu tekrar kullanma
    9. Lint kodu
    10. Kodu en iyileştirme
    11. Tasarım görünümünde kod düzenleme
    12. Sayfaların başlık içeriğiyle çalışma
    13. Dreamweaver'da sunucu tarafı içerikleri ekleme
    14. Dreamweaver'da etiket kitaplıkları kullanma
    15. Dreamweaver'a özel etiketleri içe aktarma
    16. JavaScript davranışlarını kullanma (genel talimatlar)
    17. Yerleşik JavaScript davranışları uygulama
    18. XML ve XSLT hakkında
    19. Dreamweaver uygulamasında sunucu tarafı XSL dönüşümleri gerçekleştirme
    20. Dreamweaver uygulamasında istemci tarafı XSL dönüşümleri gerçekleştirme
    21. Dreamweaver'da XSLT için karakter varlıkları ekleme
    22. Kodu formatlama
  13. Ürünler arası iş akışları
    1. Dreamweaver uzantılarını yükleme ve kullanma
    2. Dreamweaver uygulama içi güncelleştirmeleri
    3. Dreamweaver'da Microsoft Office belgeleri ekleme (yalnızca Windows)
    4. Fireworks ve Dreamweaver ile çalışma
    5. Contribute ile Dreamweaver sitelerindeki içeriği düzenleme
    6. Dreamweaver-Business Catalyst entegrasyonu
    7. Kişiselleştirilmiş e-posta kampanyaları oluşturma
  14. Şablonlar
    1. Dreamweaver şablonları hakkında
    2. Şablonları ve şablon tabanlı belgeleri tanıma
    3. Dreamweaver şablonu oluşturma
    4. Şablonlarda düzenlenebilir bölgeler oluşturma
    5. Dreamweaver'da yinelenen bölgeler ve tablolar oluşturma
    6. Şablonlarda isteğe bağlı bölgeler kullanma
    7. Dreamweaver'da düzenlenebilir etiket niteliklerini tanımlama
    8. Dreamweaver uygulamasında yuvalanmış şablonlar oluşturma
    9. Şablonları düzenleme, güncelleştirme ve silme
    10. Dreamweaver'da xml içeriğini dışa ve içe aktarma
    11. Mevcut bir belgenin şablonunu uygulama veya kaldırma
    12. Dreamweaver şablonlarındaki içerikleri düzenleme
    13. Dreamweaver'daki şablon etiketleri için sözdizimi kuralları
    14. Şablon bölgeleri için vurgulama tercihlerini belirleme
    15. Dreamweaver'da şablon kullanmanın avantajları
  15. Mobil ve çoklu ekran
    1. Ortam sorguları oluşturma
    2. Mobil cihazlar için sayfa yönlendirmesini değiştirme
    3. Dreamweaver kullanarak mobil cihazlar için web uygulamaları oluşturma
  16. Dinamik siteler, sayfalar ve web formları
    1. Web uygulamalarını anlama
    2. Bilgisayarınızı uygulama geliştirme için ayarlama
    3. Veritabanı bağlantılarında sorun giderme
    4. Dreamweaver uygulamasında bağlantı komut dosyalarını kaldırma
    5. Dinamik sayfalar tasarlama
    6. Dinamik içerik kaynaklarına genel bakış
    7. Dinamik içerik kaynaklarını tanımlama
    8. Sayfalara dinamik içerik ekleme
    9. Dreamweaver'da dinamik içeriği değiştirme
    10. Veritabanı kayıtlarını görüntüleme
    11. Dreamweaver'da canlı veri sağlama ve ilgili sorunları giderme
    12. Dreamweaver'da özel sunucu davranışı ekleme
    13. Dreamweaver ile form oluşturma
    14. Kullanıcılardan bilgi toplamak için formları kullanma
    15. Dreamweaver'da ColdFusion formları oluşturma ve etkinleştirme
    16. Web formları oluşturma
    17. Form öğeleri için geliştirilmiş HTML5 desteği
    18. Dreamweaver uygulamasını kullanarak bir form geliştirme
  17. Uygulamaları görsel olarak oluşturma
    1. Dreamweaver'da kalıp ve ayrıntı sayfaları oluşturma
    2. Arama ve sonuç sayfaları oluşturma
    3. Kayıt ekleme sayfası oluşturma
    4. Dreamweaver'da güncelleme kaydı sayfası oluşturma
    5. Dreamweaver'da kayıt silme sayfaları oluşturma
    6. Dreamweaver'da veritabanını değiştirmek için ASP komutları kullanma
    7. Kayıt sayfası oluşturma
    8. Oturum açma sayfası oluşturma
    9. Yalnızca yetkili kullanıcıların erişebileceği bir sayfa oluşturma
    10. Dreamweaver ile ColdFusion'daki klasörlerin güvenliğini sağlama
    11. Dreamweaver'da ColdFusion bileşenleri kullanma
  18. Web sitelerini test etme, önizleme ve yayımlama
    1. Sayfaları önizleme
    2. Dreamweaver web sayfalarını birden fazla cihazda önizleme
    3. Dreamweaver sitenizi test etme

 

Dreamweaver'da dosyalarınızı ve kaynak kodunu yönetmek için Git'i kullanmayı öğrenmek isterseniz bu makaleyi okuyun.

Dreamweaver, kaynak kodunu yönetmek için açık kaynaklı dağıtılan bir sürüm denetimi sistemi olan Git'i destekler. Git'in Dreamweaver ile entegrasyonuyla birlikte kodunuz üzerinde bağımsız olarak herhangi bir yerden çalışabilir ve değişikliklerinizi daha sonra merkezi bir Git deposunda birleştirebilirsiniz. Git, bir dosyada yapılan tüm değişiklikleri izlemenize yardımcı olur ve önceki sürümlere dönmenize olanak tanır.

Ayrıca, Git kolayca dallar oluşturmanızı ve dalları korumanızı sağladığından Git depoları ekip olarak çalıştığınızda da kullanışlıdır. Örneğin, siteniz için bir tasarım değişikliği üzerinde çalışmak isteyen bir tasarımcı olabilirsiniz. Aynı zamanda, başka bir ekip üyesi de aynı site için bir değişiklik isteğinde bulunursa Git'i kullanarak her ikiniz de bağımsız olarak çalışabilirsiniz. Bu durumda, ikiniz de ayrı ayrı bir dal oluşturabilir ve değişikliklerinizi ilgili yerel deponuzda yapabilirsiniz. Yerel depo, kaynakta yaptığınız tüm değişikliklerin tam geçmişini içerir. İstediğiniz zaman çalışmanıza ara verip değişikliklerinizi merkezi depo ile birleştirebilirsiniz. Birleştirme işlemi merkezi deponun her zaman değişikliklerinizi içeren en güncel koda sahip olmasını sağlar.

Dreamweaver'da Git'i kullanmaya başlamayı öğrenmek için okumaya devam edin.

Dreamweaver'da Git'i kullanmaya başlama

Yeni bir Git kullanıcıysanız öncelikle bir Git istemcisi indirmeniz ve bir Git hesabı oluşturmanız gerekir. Git istemcisi, Git'i doğrudan Dreamweaver içinden kullanabilmeniz için gereklidir.

Zaten Git hesabı olan bir kullanıcıysanız hesabınıza giriş yapın. Sisteminize Git istemcisini indirdiğinizden emin olun. 

Dreamweaver'da Git'i kullanmaya başlamak için aşağıdaki adımları gerçekleştirin:

  1. İşletim Sisteminize uygun Git istemcisini indirin.

  2. Git istemciniz için bir hesap oluşturun.

    Zaten bir Git hesabınız varsa Git istemcinize giriş yapmak için oturum açma bilgilerinizi sağlayın.

Git Paneli

Git istemcisini varsayılan yapılandırma ayarlarıyla yüklemeniz önerilir. Böylece Dreamweaver, çalıştırılabilir dosyanın yolunu otomatik olarak seçer.

Bundan sonra, Dreamweaver'ı başlatabilir ve sitenizi bir Git deposuyla ilişkilendirebilirsiniz.

Dreamweaver, Git işlemlerini Git paneli aracılığıyla (Pencere > Git) destekler. Dreamweaver kullanıcısı olarak Yürüt, Gönder, Al, Çek gibi yaygın Git işlemlerini gerçekleştirmek için bu paneli kullanabilirsiniz.

Not:

Bu paneli Dreamweaver'da yalnızca Git istemcisini bilgisayarınıza indirdikten sonra görüntüleyebilirsiniz.

Dreamweaver CC'deki Git paneli
Dreamweaver'daki Git paneli

A. Yürüt B. Tüm uzak içerikleri al ve sayaçları sıfırla C. Git Al D. Git Gönder E. Depo geçmişini göster F. Dosya geçmişini göster G. Etiket oluştur H. Bash/terminal konsolunu aç I. Diğer eylemler J. Arama K. Fark L. Dosyayı geri al 

Sitenizi Git ile ilişkilendirme

Dreamweaver'da Git'i kullanmaya başlamak için öncelikle Dreamweaver sitenizi bir Git deposuyla ilişkilendirmeniz gerekir. Git deposu, dosya değişikliklerini izlemenize yardımcı olmak için oluşturduğunuz bir klasör gibidir. Bilgisayarınızda dilediğiniz kadar Git deposuna sahip olabilirsiniz. Sisteminizdeki her depo bağımsızdır. Diğer bir deyişle, bir Git deposuna kaydedilen değişiklikler başka bir deponun içeriğini etkilemez.

Web sitenizi bir depoyla ilişkilendirmek için bir depo oluşturabilir veya mevcut bir depoyu klonlayabilirsiniz. Yeni bir depo başlattığınızda veya oluşturduğunuzda geçerli çalışma dizininizde bir .gitignore dosyasıyla birlikte boş bir Git deposu oluşturulur.

Ancak mevcut bir Git deposunu klonladığınızda ana deponuzdaki tüm dosyalar yerel sisteminize klonlanır.

Git deposu başlatma veya depo klonlama için okumaya devam edin.

Git deposu başlatma

Dreamweaver'da Git ile çalışmaya başladığınızda ilk adım bir depo oluşturmaktır. Siteniz için bir Git deposu başlattığınızda, Dreamweaver sitenizle ilişkili dosyaları ekleyebileceğiniz bir Git deposu oluşturursunuz.

  1. Dreamweaver kullanıcısı olarak yeni bir sitede çalışmaya başlayabilirsiniz. Alternatif olarak, bir Git deposu ile ilişkilendirmek istediğiniz mevcut bir siteyi de kullanabilirsiniz. Her iki durumda da bir Git deposu başlatmak için bu yordamı uygulayın.

    • Yeni bir Dreamweaver sitesini ilişkilendirmek için Site > Yeni Site'yi tıklatın.
    • Mevcut bir Dreamweaver sitesini ilişkilendirmek için Site > Siteleri Yönet'i tıklatın. Siteleri Yönet iletişim kutusundan, bir Git deposuyla ilişkilendirmek istediğiniz siteyi çift tıklatın.
  2. Yeni bir site oluşturuyorsanız site için bir ad belirtin.

    Sitenizle ilişkili dosyaların yer aldığı bir klasörünüz varsa Yerel Site Klasörü alanından bu klasörü işaretleyin.

    Yeni Dreamweaver sitenizin adını ve klasör konumunu belirtin.
    Yeni Dreamweaver sitenizin adını ve klasör konumunu belirtin.

    Yeni sitenizi mevcut bir Git deposuyla ilişkilendirmek isterseniz Yerel Site Klasörü ayarının uygun Git deposunu işaret ettiğinden emin olun.

  3. Bu Siteyle Bir Git Deposu'nu İlişkilendir onay kutusunu seçin. Ardından, Git Deposu Olarak Başlat seçeneğini belirleyin.

    Dreamweaver'da bir Git deposunu başlatma
    Yeni Dreamweaver siteniz için bir Git deposu başlatma

  4. Kaydet'i tıklatın.

    Yerel klasörünüzdeki dosyalar artık Dosyalar panelinde (Git Görünümü) görünür. Dosyalar, izlenmeyen durumdadır. Diğer bir deyişle bu dosyalar henüz Git deponuzda yürütülmemiştir.

    Dosyalarınız üzerinde çalışmaya devam edebilir ve dosyalarınızı daha sonra yürütebilirsiniz. Aksi durumda, Git panelini (Pencere > Git) açıp dosyalarınızı deponuza yürütebilirsiniz. Git'te dosyaları yürütmeyi öğrenmek için bkz. Değişiklikleri izleme ve uygulama.

Mevcut bir depoyu klonlama

Github veya Bitbucket ya da başka bir popüler barındırma hizmetinde barındırılan mevcut bir Git deposuyla zaten çalışıyorsanız bu depoyu Dreamweaver içinden klonlamak için aşağıdaki yordamı gerçekleştirebilirsiniz. Mevcut bir depoyu klonladığınızda, yerel sisteminizde hedef deponun bir kopyasını oluşturursunuz.

  1. Site > Yeni Site'yi tıklatın.

  2. Site Ayarları iletişim kutusundan, Bu Siteyle Bir Git Deposu'nu İlişkilendir onay kutusunu seçin. Ardından, Şu URL'yi Kullanarak Mevcut Git Deposu'nu Klonla: seçeneğini belirleyin.

  3. Klonlamak istediğiniz deponun URL'sini girin.

    Girdiğiniz hedef deponun https URL'sinin geçerli olduğundan emin olun. URL'nin geçerli olup olmadığını test etmek için bu iletişim kutusundaki Test Et düğmesini tıklatın. Geçersiz URL, klonlama ve Git Çek ya da Git Al gibi eylemleri gerçekleştirirken hatalara neden olur.

    Dreamweaver içinden Git deposunu klonlama
    Dreamweaver içinden Git deposunu klonlama

    Not:

    Parola gerektiren bir SSH anahtarı kullanarak bir URL'yi klonlamak şu anda Dreamweaver'da desteklenmemektedir. Kullanıcı adı ve şifre alanları devre dışı bırakılır.

  4. Girdiğiniz kimlik bilgilerini kaydetmek için Kimlik Bilgilerini Kaydet onay kutusunu işaretleyin. Bu işlem sayesinde, Git Gönder veya Al gibi bir uzak eylemi her gerçekleştirdiğinizde kimlik bilgilerinizi girmek zorunda kalmazsınız.

  5. Kaydet'i tıklatın.

    Depoyu klonladıktan sonra kaynak deponun yerel bir kopyası oluşturulur. Yerel dosyaları Dreamweaver içinden görüntüleyebilir ve düzenleyebilirsiniz.

    Orijinal deponun klonladığınız sıradaki anlık görüntüsü sağ üst köşedeki Git paneli > Kaynak bölümünde gösterilir.

    Git panelindeki kaynak depoya dikkat edin
    Git panelindeki kaynak depoya dikkat edin

Git'i sürüm denetimi için kullanma

Dreamweaver sitenizi bir Git deposuyla ilişkilendikten sonra Git'te dosyaları Dosyalar panelinden (Git görünümü) görüntüleyebilirsiniz. Git, yerel deponuzdaki dosyaları şu şekilde sınıflandırır:

  • İzlenmeyen dosyalar: Git deposunda bir kez dahi yürütmediğiniz dosyalar. Git deposu başlattıktan sonra, siz onları yürütene kadar dosyalar izlenmez.
  • Değiştirilmeyen dosyalar: Değiştirilmemiş dosyalardır.
  • Değiştirilen dosyalar: Düzenlenmiş dosyalardır.
  • Hazırlanan dosyalar: Değiştirilen ve yürütülmeye hazır dosyalardır.

Git'i kullanarak, dosyalardaki değişiklikleri izleyebilirsiniz. Yerel sisteminizdeki dosyaları değiştirdiğinizde bu dosyalar, Dosyalar panelinde farklı bir renkte görünür. Dosyayı çift tıklatıp Kod Görünümü'nde açtığınızda, değiştirilen satırlarda sütun aralığı işaretini de görebilirsiniz. Değişiklikleri eşitlemek için, değiştirilen dosyalarınızı Git'te yürütmeye başlayabilirsiniz.

Dosyalarınızı yürüttüğünüzde Git, her yürütme için günlük mesajları girmenize ve fark özelliğini kullanarak değişiklikleri gözden geçirmenize olanak tanır. Ayrıca sürüm geçmişini her dosya için ve deponun tamamı için görebilirsiniz.

Dreamweaver içinden düzenlemelerinizi izlemeyi ve Git'te değişikliklerinizi uygulamayı öğrenmek için okumaya devam edin.

Git'te düzenlemeleri izleme

Dreamweaver'daki Dosyalar panelinde, FTP görünümünden Git görünümüne geçiş yapmanızı sağlayan Git simgesine dikkat edin. Git görünümüne geçiş yapmak için Git simgesini tıklatın.

Git deposu başlattıysanız ve dosyalarınızı henüz yürütmediyseniz dosyalar izlenmeyen öğeler olarak kalır. Ancak deponuzu başlattıktan sonra dosyalarınızı yürüttüyseniz Git bu dosyaları tanır.

Dosyalar panelinde izlenmeyen dosyaları görüntüleme
Dosyalar panelinde izlenmeyen dosyaları görüntüleme

Git deposuna yürütüldükten sonra dosyalar
Git tarafından tanınan yürütülen dosyaları görüntüleme

Tüm dosyalarınızı başka bir depodan klonladıysanız dosyalar yine Git tarafından tanınır.

Bir dosyayı değiştirip Kaydet'i tıklattığınızda, Dosyalar paneli değiştirilen dosyaları farklı bir renkte görüntüler. Kod Görünümü'nde değişiklikleri tam olarak görüntülemek için değiştirilen dosyayı çift tıklatın.

Kod Görünümü'ndeki sütun aralığı işaretine dikkat edin
Kod Görünümü'ndeki sütun aralığı işaretine dikkat edin

Sütun aralığı işareti değişikliklerin yapıldığı satırları belirtir. Yeşil renkli sütun aralığı işaretleri eklenen yeni kodu gösterir. Sarı renkli sütun aralığı işareti değiştirilen kodu gösterir. Kırmızı vurgu içindeki beyaz renkli sütun aralığı işareti ise silinen bir kod satırını gösterir.

Sütun aralığı işareti, Dreamweaver'da kod içindeki değişiklikleri belirtir
Sütun aralığı işareti, kod içindeki değişiklikleri belirtir

Sarı renkli sütun aralığı işaretini tıklattığınızda uygulama kod içindeki değişiklikleri görüntüler. Silinen kod satırı kırmızı renkle görüntülenirken yeni eklenen kod yeşil renkle görüntülenir.

Silinen kod satırlarının sol köşesinde bir R simgesi bulunduğuna dikkat edin. Silinen kodu tekrar dosyanıza eklemek için R simgesini tıklatın.

Silinen kodu Dreamweaver Git'e eklemek için R simgesini tıklatın
Silinen kodu eklemek için R simgesini tıklatın

Farkı görüntülemek ve değişikliklerinizi Git deposuna yürütmeden önce gözden geçirmek için sütun aralığı işaretlerini kullanın.

Değiştirilen dosyalardaki farkı görüntüleme

Git panelini açtığınızda, değiştirilen dosyaların listesini görebilirsiniz. Bu listede bir dosyayı tıklatabilir ve önceki yürütmeden sonra dosyada yapılan değişiklikleri (farkı) görüntüleyebilirsiniz. Dosyadaki farkı görüntülemek için Git panelinde aşağıdakilerden birini yapın:

  • Dosya düzeyindeki düzenlemeleri görüntülemek için her dosyayı tek tek tıklatın. Kırmızı vurgular önceki sürümü gösterirken yeşil vurgular da şimdi yaptığınız değişikliği gösterir.
  • Farkı görüntülemek istediğiniz dosyayı seçin.  simgesini (Fark simgesi) tıklatın. Değişikliklerin kırmızı ve yeşil olarak vurgulandığı Git Farkı iletişim kutusu görünür.
Değiştirilen dosyalardaki farkı görüntüleme
Değiştirilen dosyalardaki farkı görüntüleme

Değişiklikleri uygulama

Yerel deponuzdaki tüm değişiklikleri kaydetmek için dosyalarınızda yapılan değişiklikleri uygulamanız gerekir. Git'te değişikliklerinizi uygulamak için:
  1. Git panelinde, Yürüt işlemini gerçekleştirmek istediğiniz dosyayı veya dosyaları seçin.

    Yerel Git deponuzda değişiklikleri uygulama
    Yerel Git deponuzda değişiklikleri uygulama

  2.  simgesini (Yürüt simgesi) tıklatın.

    Yürüt'ü tıklattığınızda sistem, Git Yürüt iletişim kutusunu görüntüler. Bu iletişim kutusunda, değişiklikleri olan dosyalar görüntülenir.

    Dosyaları yürüt işlemine devam etmeden önce dosyaları tek tek tıklatarak değişiklikleri görüntüleyebilirsiniz.

  3. Dosyaları yürütmek için mesaj kutusuna bir yürütme mesajı girin ve Tamam'ı tıklatın.

    Dosyalar yürütüldükten sonra Git panelinden de temizlenir.

    Yaptığınız değişiklikleri Git'te uygulama
    Yaptığınız değişiklikleri Git'te uygulama

Değişiklikleri geri alma

Değişikliklerinizi zaten uyguladıysanız ve bir dosyanın önceki sürümüne dönmek istiyorsanız aşağıdaki işlemi gerçekleştirin:

  1. Git panelinde, geri almak istediğiniz dosyayı veya dosyaları seçin.

  2. Git panelindeki sandviç simgesini tıklatın ve Son Yürütmeden Sonraki Değişiklikleri Geri Al seçeneğini belirleyin.

    Dosyanın önceki sürümü yerel deponuza geri yüklenir. Geri yüklenen dosyaları Dosyalar panelinden görüntüleyebilirsiniz.

    Dosyaları yürüttükten sonra değişiklikleri geri alma
    Dosyaları yürüttükten sonra değişiklikleri geri alma

    Not:

    Dosyaya yürütme işleminden sonra geri dönmek istiyorsanız dosyayı en az iki kez yürütmüş olmanız gerekir.

  3. Yürüt işleminden önceki değişiklikleri geri almak için şu adımları gerçekleştirin:

    Dosyanızı yürütmeden önce dosyanın en son yürütülen sürümünü korumak istiyorsanız:

    1. Git panelinde, korumak istediğiniz dosyayı ve ardından Yenile simgesini tıklatın.
    2. Onay iletişim kutusundan, Tamam'ı tıklatın.

    Seçtiğiniz dosya, değiştirilen dosyalar listesinden temizlenir ve dosyanın önceki sürümü geri yüklenir.

    Git'te değişiklikleri uygulamadan önceki dosyaya geri dönme
    Değişiklikleri uygulamadan önceki dosyaya geri dönme

Etiketler oluşturma

Git'te değişiklikleri her uyguladığınızda etiketler oluşturabilirsiniz. Etiketleri, önemli yürütme işlemlerini işaretlemek için kullanabilirsiniz. Örneğin, müşteriniz tarafından istenen önemli bir değişiklik için bir dosya teslim edebilirsiniz. Etiketler, belirli bir yürütme işlemi için işaretçi işlevi görür.

  1. Etiket oluşturmak için Git panelinde  simgesini (Etiket Oluştur simgesi) tıklatın.

  2. Etiket Oluştur iletişim kutusundan, etiketiniz için bir ad belirtin. Tamam'ı tıklatın.

    Yürütme işleminiz için bir etiket oluşturma
    Yürütme işleminiz için bir etiket oluşturma

    Oluşturduğunuz etiket, yürütme işleminiz ile ilişkilendirilir.

    Yürütme işlemi gerçekleştirdikten sonra bir etiket oluşturursanız etiket otomatik olarak en son yürütme işleminizle ilişkilendirilir.

Dosya geçmişini görüntüleme

Git'te her dosya yürütme işlemi gerçekleştirdiğinizde, yürütme işleminin ayrıntılarını ve dosya geçmişini görüntüleyebilirsiniz. Bu özellik, önemli yürütme işlemlerini ve yürütme işlemleriyle ilişkili etiketleri belirlemenize yardımcı olur.

  1. Git panelinde aşağıdakilerden birini yapın:
  • Gerekli dosyayı seçin ve  simgesini (Dosya Geçmişini Göster simgesini) tıklatın.
  • Dosyalar panelinden dosyayı sağ tıklatın ve Dosya Geçmişi seçeneğini belirleyin.

Sistem, seçili dosyanın Git Dosya Geçmişi'ni görüntüler. Ayrıca bu dosya için yürütme işleminin ayrıntılarını da aynı iletişim kutusundan görüntüleyebilirsiniz.

Git'te dosya geçmişini görüntüleme
Git'te dosya geçmişini görüntüleme

Depo geçmişini görüntüleme

Git'te bir dosyanın geçmişini görüntülemenin dışında, yaptığınız değişiklikleri de depo düzeyinde görüntüleyebilirsiniz. Depo düzeyinde yapılan tüm değişiklikleri ve yürütme işlemlerini görüntüleyebilirsiniz. Depo geçmişini görüntülemek için şu adımları gerçekleştirin:

  1. Git panelinden, Depo Geçmişini Göster simgesini tıklatın. Sistem, tüm yürütme işlemlerin ayrıntılarıyla birlikte Git Deposu Geçmişi'ni görüntüler.

  2. Yürütme mesajını ve dosyaların yürütüldüğü tarih ile saati görüntüleyebilirsiniz. Ayrıca bir yürütme işlemiyle ilişkili etiketleri ve dosyaları yürüten kullanıcının ayrıntılarını da görüntüleyebilirsiniz.

  3. Depo geçmişi genellikle depo düzeyinde yürütülmüş olan dosyaların listesini belirtir. Dosyaları tek tek tıklatarak dosya düzeyinde değişiklik geçmişini görüntüleyebilirsiniz.

Git'i iş birliği için kullanma

Git'in en belirgin özelliklerinden biri dallardır. Git dalı, çoğu sürüm denetimi sisteminden farklı olarak tüm ilişkili dosyalarınızın veya kodunuzun herhangi bir satırıyla eşitlenebilir. Deponuzun varsayılan olarak “ana” adlı bir dalı vardır. Ana dal, ana veya kesin daldır. Ana daldan alt dallar oluşturabilir ve her bir dalda düzenlemeler yapabilirsiniz.

Ayrıca üst dalın bir kopyasını oluşturmak için başka bir daldan bir dal da oluşturabilirsiniz. Aynı Git deposundaki her iki dal üzerinde ayrı ayrı çalışabilirsiniz. Örneğin, siteniz için bir dalda yeni bir özellik üzerinde çalışırken diğer dalda bazı değişiklik taleplerini karşılayabilirsiniz.

Ayrıca Git, geçerli bir dalınızdaki değişiklikleri bir hedef dala dahil etmek isterseniz dalları birleştirmenize olanak tanır. Bu iki dalı birleştirdiğinizde her iki dal da bağımsız olarak var olmaya devam eder. Üst ve hedef dallarla çalışmaya devam edebilirsiniz.

Dreamweaver'da geliştiriciler ve tasarımcılar bir site için birlikte çalıştığında her kullanıcı ana dalın bir alt dalını oluşturabilir ve bağımsız olarak değişiklik yapabilir. Her gerektiğinde, değişikliklerini kolayca bir başka dal ile birleştirebilir ve her iki dal ile çalışmaya devam edebilirler.

Git'te dal oluşturma ve dalları yönetme ile ilgili daha fazla bilgi edinmek için aşağıdaki bölümleri okuyun:

Git'te dallar oluşturma

  1. Dosyalar panelinden, tüm dalları listeleyen açılır listeyi seçin.

  2. Dalları Yönet'i tıklatın.

    Git'te bir dal oluşturma
    Git'te bir dal oluşturma

  3. Dalları Yönet iletişim kutusunun sol alt köşesindeki + simgesini tıklatın.

    Dalları Yönet iletişim kutusunun alt kısmındaki artı simgesini tıklatın
    Dalları Yönet iletişim kutusunun alt kısmındaki artı simgesini tıklatın

  4. Yeni Dal Oluştur iletişim kutusunda, kopyasını oluşturmak istediğiniz kaynak dalı seçin.

    Bu, oluşturmakta olduğunuz ilk dal ise kaynak dal ana dalınız olur.

    Kaynak dalı seçme
    Kaynak dalı seçme

  5. Yeni Dal Adı alanında, yeni dal için bir ad belirtin.

  6. Tamam'ı tıklatın.

Dalları birleştirme

  1. Dosyalar panelinden, tüm dallarınızı listeleyen açılır listeyi seçin.

  2. Dalları Yönet'i tıklatın. Dalları Yönet iletişim kutusundan, birleştirmek istediğiniz dalı seçin.

  3. İletişim kutusunun alt kısmındaki  simgesini (Dalı Birleştir simgesini) tıklatın.

  4. Dalı Birleştir iletişim kutusundan, Hedef dal'ı seçin. Bu dal, dalınızı birleştirmek istediğiniz hedef depodur.

    İsteğe bağlı olarak, bu birleştirme işlemiyle ilişkili bir mesaj yazın.

  5. Tamam'ı tıklatarak dalınızı hedefinizle birleştirin.

    Git'te dalları birleştirme
    Git'te dalları birleştirme

    Bir yürütmeden gelen dosya değişiklikleri başka bir daldan gelen değişikliklerle çakışırsa birleştirme işlemi durdurulur. Sistem, çakışmaya neden olan dosyalarla birlikte bir çakışma mesajı görüntüler.

    Git panelinde çakışma olan dosyalar da görüntülenir. Çakışmanın olduğunu gösteren simgeye dikkat edin.

    Birleştirme sırasında bir çakışma olan dosyaların olduğu Git paneli
    Birleştirme sırasında bir çakışma olan dosyaların olduğu Git paneli

    Birleştirme işlemine devam etmek için öncelikle çakışmayı çözümlemeniz gerekir. Yeni Taban seçeneğini kullanabilir veya hızlı ileri yok seçeneğini kullanarak birleştirme işlemine devam edebilirsiniz.

  6. Birleştirme çakışmasıyla karşılaşırsanız aşağıdaki seçeneklerden birini tercih edin:

    • Yeni Taban kullan: Yeni taban seçeneğini belirlediğinizde, geçerli değişiklikleriniz hedef dalınızdaki çakışmalara uygulanır. Yeni tabanı seçip Tamam'ı tıklattıktan sonra Git panelini açarak henüz yürütülmemiş olan dosyaları görüntüleyin. Böylece yeni tabanı iptal etmeyi veya yeniden başlatmayı seçebilirsiniz. Yeni tabanı iptal ettiğinizde, yeni taban işlemi durdurulur ve hedef dalda herhangi bir değişiklik yapılmaz. Yeni tabanı yeniden başlattığınızda, değişiklikleriniz hedef dalda görülen çakışmalarda atlanır.
    • Birleştirme işlemi hızlı ileri olarak çözülse bile bir birleştirme yürütmesi oluştur: Yürütme işleminizi, dalınız ile hedef dal arasında çakışmalar görülse de birleştirebilirsiniz. Bu durumda birleştirme işlemi, değişiklikleriniz hedef daldaki değişiklikler geçersiz kılınarak gerçekleştirilir.

    Git'te yeni taban ile ilgili daha fazla bilgi edinmek için bkz. Git Yeniden Temellendirme.

Uzak depolar ile çalışma

Git'te uzak depolar, bir projenin başka bir ağda barındırılan sürümleridir. Uzak depolara, depo ile bir bağlantı oluşturarak erişebilirsiniz. Uzak depoda belirtilen erişim haklarına bağlı olarak, bu depoya salt okunur erişiminiz veya yazma erişiminiz olabilir.

Uzak depolar, ekip halinde çalışırken diğer depolarla veri gönderip almanıza yardımcı olur. Dreamweaver Git panelinden bir uzak bağlantı oluşturabilir ve Çek, Git Gönder, Git Al ve Uzaktan Yenile gibi çeşitli Git işlemlerini gerçekleştirebilirsiniz.

Uzak depolar oluşturma ve yönetme hakkında bilgi edinmek için aşağıdaki yordamları okumaya devam edin.

Uzak depo ekleme

Dosyaları ve çalışmanızın ilerleme durumunu paylaşıp başka bir ağda barındırılan proje dosyalarınıza erişmek için bir uzak depo ekleyebilirsiniz. Uzak depo ekleyerek hedef depoyla bir uzak bağlantı kurarsınız. Dreamweaver, Git panelinden uzak depolar oluşturmanıza olanak tanır.

Uzak depo eklemeden önce diğer depoda genel ayarlarının etkinleştirildiğinden emin olun.

  1. Git panelinden, Uzak İçerik Oluştur'u tıklatın.

  2. Uzak depo için bir ad belirleyin.

  3. URL'yi ve uzak deponun kimlik bilgilerini girin.

    Uzak depo eklerken geçerli bir URL girdiğinizden emin olmak için URL'yi girdikten sonra Test'i tıklatın. Test'i tıklattığınızda URL'nin geçerliliği test edilir.

    Bu test, kimlik bilgilerini doğrulamak için kullanılamaz.

    Dreamweaver'da bir uzak depo ekleme
    Uzak depo ekleme

    Dikkat:

    Geçerli bir URL veya kimlik bilgileri girmezseniz Git Al, Git Gönder, Çek vb. işlemleri gerçekleştirirken hatalarla karşılaşırsınız.

  4. Tamam'ı tıklatın.

    Uzak depoyu eklediğinizde, Git panelinin üst kısmındaki açılır listede görürsünüz. Ayrıca uzaktan Git Al, Git Gönder, Çek işlemlerini gerçekleştirmek ve sayaçları yenilemek için daha fazla simge görürsünüz.

    Git'te uzak depolar ekleme
    Git'te uzak depolar ekleme

Uzak depoları yönetme

Uzak depoyu ekledikten ve bir bağlantı kurduktan sonra dosyaları uzak depodan yerel deponuza çekebilir ve alabilirsiniz. Ayrıca uzak depoya dosyalar da gönderebilirsiniz. Ancak ilk kez bir Git Gönder işlemi gerçekleştirmeden önce ilk olarak uzak depodan dosyaları çekmeniz gerekir.

Dosyalarınızı göndermeyi denemeden önce yerel deponuzdaki tüm dosyalarınızı yürütmeyi unutmayın. Yerel deponuzda hazırlanan dosyalar varsa Git Gönder işlemi başarısız olur. 

Dreamweaver içinden aşağıdaki Git işlemlerini gerçekleştirebilirsiniz:

Tümünü çek

Tüm uzak bağlantılarınızdan bütün dosyaları çekmek için  simgesini tıklatın. Git Gönder veya Git Al işlemi gerçekleştirmeden önce bir Git Çek işlemi gerçekleştirmeniz önerilir. Bu işlem yalnızca uzak sunucudan dosyaları çeker ve yerel deponuzu değiştirmez.

Uzak depodan dosya alma

Tek bir depodan veya bir depo grubundan değişiklikleri alabilirsiniz. Git Al simgesini tıklattığınızda sistem, çeşitli seçenekler ile Git Al iletişim kutusunu görüntüler.

  1. Uzak depodan değiştirilen dosyaları almak ve değişiklikleri yerel deponuzla birleştirmek için Git panelinden  simgesini (Git Al simgesini) tıklatın.

  2. Git Al iletişim kutusundan izleme dalını seçin. Geçerli daldan veya başka bir daldan değişiklikleri almak isteyip istemediğinizi belirtin ve alma ayarlarını yapın.

    Uzak depolardan bir Git Al işlemi gerçekleştirme
    Uzak depolardan bir Git Al işlemi gerçekleştirme

  3. Varsayılan olarak, Varsayılan birleştirme işlemi seçilidir. Bu durumda, uzak sunucudan dosyalar yerel deponuza alınır ve değişiklikler yerel deponuzla birleştirilir.

  4. Ayrıca aşağıdaki seçeneklerden birini de tercih edebilirsiniz:

    • Elle birleştirmekten kaçın: Dosyaların elle birleştirilmesini devre dışı bırakmak için bu seçeneği belirleyin.
    • Yürütme olmadan birleştir: Uzak depoya hazırlanan dosyalarınızı yürütmeden bile birleştirmeye devam etmek için bu seçeneği belirleyin.
    • Yeni taban kullan: Yeni taban gerçekleştirmek için bu seçeneği belirleyin. Yeni taban kullandığınızda geçerli dalınızdaki değişiklikler alınır ve dosyaları almakta olduğunuz dalın geçmişine uygulanır. Dalınızın en son yürütülen geçmişi yeniden yazılır. Dosyaların sürümleri, dosyaları almakta olduğunuz hedef daldaki sürümlerle eşleşir. Yeniden Temellendirme dalınız için temiz bir Git geçmişi oluştursa da Yeni taban kullan seçeneğini belirlerken dikkatli olmalısınız.
    • Yazılımdan sıfırlama kullan: Sıfırlama veya yazılımdan sıfırlama gerçekleştirmek için bu seçeneği belirleyin. Dosyaları uzak bir depodan ilk kez alırken Yazılımdan sıfırlama kullan seçeneğini belirleyebilirsiniz. Bu durumda, uzak depo yerel deponuzun tüm değişiklikleri aldığı ana depo işlevi görür. Ancak yerel deponuzdaki değişiklikler korunur. Git, uzak depoda bulunmayan ancak yerel deponuzda bulunan dosyaları tanımaz. Yazılımdan sıfırlama gerçekleştirdikten sonra bu dosyalar, silinmiş dosyalar olarak görüntülenir. Bu dosyaları yerel deponuzda korumayı seçerseniz uzak değişiklikler kaybolur.
    Dikkat:

    Yazılımdan sıfırlamayla devam ederseniz tanınmayan dosyalarınız silinir.

Dosyaları uzak depoya gönderme

Uzak depolarla bağlantı kurduktan sonra, değiştirilen dosyaları değiştirdiğinizde veya yürüttüğünüzde Git bu değişiklikleri kaydeder. Git panelindeki Git Gönder simgesi değiştirilmiş dosyaların sayısını hemen görüntüler. Bu dosyalar artık uzak depoya gönderilebilir.

Git Gönder işlemi gerçekleştirdiğinizde, yerel depoda yaptığınız yürütme işlemleri uzak depoya gönderilir.

Dosyalarınızı Dreamweaver içinden göndermek için:

  1. Git panelinden, Git Gönder simgesini tıklatın.

    Sistem, Git Gönder iletişim kutusunu görüntüler. Yürütme işlemlerinizi geçerli izleme dalına veya belirleyeceğiniz başka bir dala gönderebilirsiniz.

    Yerel yürütmeleri uzak bir Git deposuna gönderme
    Yerel yürütmeleri uzak bir Git deposuna gönderme

  2. Ayrıca bu iletişim kutusundan gönderme ayarlarını da ayarlayabilirsiniz. Varsayılan Gönderme İşlemi seçeneği varsayılan olarak seçilidir.

  3. Ayrıca şu seçenekleri de belirleyebilirsiniz:

    • Göndermeye Zorla: Değişikliklerinizi olası çakışmalara rağmen uzak depoya zorla göndermek için bu seçeneği belirleyin.
    • Uzak dalı sil: Mevcut uzak dalı silmek ve yerel dosyalarınızı uzak depoya göndermek için bu seçeneği belirleyin.
  4. İsteğe bağlı olarak, etiketlerinizi uzak depoya göndermek için Etiketleri Gönder onay kutusunu işaretleyin.

  5. Tamam'ı tıklatın.

    Yerel yürütmeleriniz ile uzak depoya yaptığınız yürütmeler arasında çakışmalar varsa öncelikle çakışmaları çözümlemeniz önerilir. Böylece değişikliklerinizi gönderebilirsiniz.

    Bunu yapmak için, öncelikle uzak depodan değişiklikleri almanız, çakışmaları çözümlemeniz ve ardından dosyaları çakışma olmadan göndermeniz gerekir.

Git panelinde dosya arama

Git panelindeki Arama çubuğu, dosya adını kullanarak dosya aramanıza olanak tanır. Bu özellik temel olarak sitenizle ilişkili çok sayıda dosyanız olduğunda kullanışlıdır.

Dosya aramak için dosya adını Arama çubuğuna yazmanız yeterlidir. Arama sorgunuzu içeren dosya ya da dosyalar hemen görüntülenir.

Yoksayma listesine dosya ekleme

Git'in bir dosya üzerinde işlem yapmasını istemediğinizde dosyayı .gitignore klasörüne ekleyebilirsiniz. Böylece yürüt, gönder ve al işlemlerinden birini her gerçekleştirdiğinizde Git bu klasörü yoksayar. Deponuzu klonlayan diğer kullanıcıların .gitignore klasörünüzdeki dosyalardan haberdar olması için .gitignore dosyasını deponuza yürütmeniz gerekir.

.gitignore klasörüne dosya eklemek için Dreamweaver'da Dosyalar paneline gidin. Git'in yoksaymasını istediğiniz dosyayı seçip sağ tıklatın ve Git > .gitignore Konumuna Ekle'yi seçin.

.gitignore klasörüne dosya ekleme
.gitignore klasörüne dosya ekleme

Dilediğiniz zaman bir dosyayı .gitignore klasöründen kaldırmak isterseniz dosyayı Dosyalar panelinden seçin. Sağ tıklatın ve Git > .gitignore Konumundan Kaldır'ı seçin.

.gitignore dosyasını değiştirdikten sonra yerel ve uzak depolara yürüttüğünüzden emin olun.

Git'e komut satırından erişme

Bu makalenin önceki bölümlerinde bir Git deposunu sitenizle ilişkilendirmek, uzak bağlantıları oluşturmak ve yönetmek, dosyaları bir depoya göndermek veya bir depodan dosya almak gibi görevleri gerçekleştirmek için Git panelini (Kullanıcı Arabirimi) kullanmayı öğrendiniz. Git komutlarını kullanarak aşağıdaki işlemleri ve daha fazlasını da gerçekleştirebilirsiniz.

Terminali kullanarak herhangi bir Git işlemi gerçekleştirmek için aşağıdakilerden birini yapın:

  • Pencere > Git'i tıklatın ve Bash/Terminal Konsolunu Aç simgesini tıklatın.
  • Dosyalar panelinden, Git Görünümü'ne geçin. Depolar açılır listesinin yanındaki Git Terminalini Aç simgesini tıklatın.

Yaygın git komutlarını görüntülemek için bkz. Git İpuçları

Not:

Göndermeden sonra git saklama ve birleştirme yürütmeleri gibi bazı eylemler şu anda yalnızca komut satırından gerçekleştirilebilir.

Komut satırından Git deposu başlatma gibi belirli eylemler gerçekleştirdiğinizde, bu eylemler Dreamweaver arabiriminde de yansıtılır.

Ancak dosyaları Dreamweaver uygulaması kapalıyken komut satırını kullanarak da değiştirebilirsiniz. Bu durumda, Dreamweaver'ı bir sonraki başlatışınızda aşağıdaki mesajı görürsünüz:

Dosyalar CLI kullanılarak değiştirildiğinde görüntülenen mesaj
Dosyalar CLI kullanılarak değiştirildiğinde görüntülenen mesaj

Dreamweaver'da Git tercihlerini ayarlama

Dreamweaver'daki Git tercihleri, Dreamweaver'da Git'i kullanmak için bazı ayarları tanımlamanıza olanak tanır. Tercihler iletişim kutusunu kullanarak terminal yolu ya da zaman aşımı ayarları gibi Git tercihlerini ayarlayabilirsiniz.

  1. Düzen > Tercihler seçeneğini belirleyin.

  2. Tercihler iletişim kutusundan, Git'i seçin.

  3. Git Tercihleri iletişim kutusundan aşağıdaki seçenekleri belirleyin:

    • Git yürütülebilir dosyası yolu: Git istemcinizin .exe dosyası. Yürütülebilir dosyanız başka bir konuma kaydedilmişse Git .exe dosyasını kaydettiğiniz konuma gidin.
    • Varsayılan Git İşlemi Zaman Aşımı: Tüm uzak Git işlemleri için zaman aşımını saniye cinsinden belirtir.
    • Terminal Yolu: Git terminalini açmak ve kullanmak için yürütülebilir dosyanın tam yolu.
    • Komut Bağımsız Değişkenleri: Git komutlarınız için varsa komut bağımsız değişkenlerini sağlar.
    Dreamweaver'da Git tercihlerini ayarlama
    Dreamweaver'da Git tercihlerini ayarlama

  4. Ayarlarınızı kaydetmek için Uygula'yı tıklatın.

Not:

Güncellenen tercihlerinizin etkin olması için Dreamweaver uygulamasını yeniden başlatın.

Adobe logosu

Hesabınıza giriş yapın