Informazioni sui pulsanti

I pulsanti vengono generalmente associati ai moduli, ma possono essere aggiunti a qualsiasi documento. Consentono di aprire un file, di riprodurre clip audio o di filmati, inviare dati a un server Web e di svolgere numerose altre funzioni. Prima di scegliere il metodo migliore per attivare un’azione, tenere presente che i pulsanti offrono funzionalità che i link e i segnalibri non sono in grado di offrire:

  • I pulsanti possono attivare una singola azione o una serie di azioni.

  • Possono modificare l’aspetto in risposta ad azioni del mouse.

  • Possono essere copiati con facilità su più pagine del documento.

  • Le azioni del mouse possono attivare diverse azioni dei pulsanti. Ad esempio, Mouse premuto (un clic), Mouse rilasciato (rilascio dopo un clic), Mouse dentro (spostamento del puntatore sul pulsante) e Mouse fuori (allontanamento del puntatore dal pulsante) consentono tutte di attivare un’azione differente per lo stesso pulsante.

    I pulsanti consentono agli utenti di avviare un’azione nei documenti PDF in modo semplice e intuitivo. Possono presentare una combinazione di etichette ed icone che consentono agli utenti di eseguire una serie di azioni o eventi utilizzando diversi movimenti del mouse. È possibile, ad esempio, creare pulsanti con l’etichetta “Riproduci”, “Pausa” e “Interrompi”, corredati dall’icona appropriata. Dopodiché vengono impostate le azioni associate a tali pulsanti per riprodurre, sospendere e terminare un filmato. Le combinazioni delle modalità di funzionamento del mouse per un pulsante sono innumerevoli ed è possibile specificarne un numero indefinito.

Aggiungere un pulsante a un modulo PDF di Acrobat DC

  1. Accertarsi che sia attiva la modalità di modifica scegliendo Strumenti > Prepara modulo, quindi selezionare Pulsante nella barra degli strumenti. Il cursore si trasforma in puntatore a croce.

  2. Fare clic nel punto della pagina nel quale si desidera aggiungere il pulsante per creare un pulsante di dimensioni predefinite. Per creare un pulsante di dimensioni personalizzate, trascinare un rettangolo per definire le dimensioni desiderate del pulsante.
  3. Fare doppio clic sul campo pulsante, quindi specificare un nome, il testo di descrizione comandi e altre proprietà comuni.
  4. Fare clic sulla scheda Aspetto, quindi specificare le opzioni per definire l’aspetto del pulsante sulla pagina. Tenere presente che, se si seleziona un colore di sfondo, non sarà possibile vedere eventuali immagini sottostanti il pulsante. Le opzioni del testo influiscono sull’etichetta specificata nella scheda Opzioni, non sul nome del pulsante indicato nella scheda Generali.

    Nota:

    Se le opzioni lingue destra-sinistra nel pannello Internazionale della finestra di dialogo Preferenze sono selezionate, la scheda Aspetto include opzioni per la modifica dello stile delle cifre e la direzione del testo per i pulsanti.

  5. Fare clic sulla scheda Opzioni e selezionare le opzioni per definire l’aspetto di etichette e icone sul pulsante.
  6. Fare clic sulla scheda Azioni. Specificare le opzioni per definire l’azione che segue il clic sul pulsante, ad esempio il passaggio a una pagina differente o la riproduzione di un clip multimediale.
  7. Fare clic su Chiudi.

    Nota:

    Se si crea un insieme di pulsanti, è possibile agganciare l’oggetto alle linee della griglia o guide.

  8. Per visualizzare in anteprima e verificare il funzionamento del pulsante, fare clic su Anteprima nella parte all'estremità destra della barra degli strumenti. Al termine, è possibile fare clic su Modifica per tornare allo strumento Prepara modulo, oppure fare clic sull'icona a croce nella parte all'estremità destra della barra degli strumenti per chiuderlo.

Aggiungere un pulsante di invio

Quando si distribuisce un modulo, Acrobat DC esegue automaticamente alcune verifiche; se non viene trovato un pulsante di invio, viene aggiunto un pulsante Invia modulo alla barra dei messaggi del documento, per consentire agli utenti di rispedire i moduli completati. Se non si desidera utilizzare il pulsante Invia modulo creato da Acrobat DC, è possibile aggiungere un pulsante di invio personalizzato.

  1. Se non è attiva la modalità di modifica dei moduli, scegliere Strumenti > Prepara modulo.

  2. Utilizzare lo strumento Pulsante  e trascinarlo sull’area in cui si desidera visualizzare il pulsante a comparsa. Fare doppio clic sul pulsante e impostare le opzioni nelle schede Generali e Opzioni.

  3. Nella scheda Opzioni, scegliere un’opzione nel menu Layout per l’etichetta del pulsante, l’immagine dell’icona o entrambe. Effettuare una delle seguenti operazioni:

    • Digitare il testo nella casella Etichetta per identificare il pulsante come pulsante di invio.

    • Fare clic su Scegli icona, quindi digitare il percorso di un file di immagine oppure fare clic su Sfoglia per individuare il file di immagine da utilizzare.

  4. Nella scheda Azioni, scegliere Invia modulo dal menu Seleziona azione, quindi fare clic su Aggiungi.

  5. Nella finestra di dialogo Inoltra selezioni modulo, effettuare una delle seguenti operazioni:
    • Per raccogliere i dati del modulo su un server, digitare la posizione in Immettere un URL per questo link. Ad esempio, http://www.[dominio]/[cartella]/[sottocartella]/ per un indirizzo Internet oppure \\[server]\[cartella]\[sottocartella]\ per un percorso di rete locale.

    • Per raccogliere i dati del modulo come allegati di una e-mail, digitare mailto: seguito dall’indirizzo e-mail. Ad esempio, digitare mailto:nessuno@adobe.com.

  6. Selezionare le opzioni per Formato di esportazione, Selezione campo e Opzioni data, quindi fare clic su OK.

  7. Fare clic su Chiudi.

  8. Per visualizzare in anteprima e verificare il funzionamento del pulsante, fare clic su Anteprima nella parte all'estremità destra della barra degli strumenti. Al termine, è possibile fare clic su Modifica per tornare allo strumento Prepara modulo, oppure fare clic sull'icona a croce nella parte all'estremità destra della barra degli strumenti per chiuderlo.

Nota:

Se i dati vengono restituiti in formato FDF o XFDF, l’URL del server deve terminare con il suffisso #FDF, ad esempio http://nomeserver/cgi-bin/nomescript#FDF.

Opzioni Inoltra selezioni modulo

Le seguenti opzioni si trovano nella finestra di dialogo Inoltra selezioni modulo:

Immettere un URL per questo link

Specificare l’URL per raccogliere i dati del modulo.

FDF

Restituisce l’input dell’utente senza rinviare il file PDF sottostante. È possibile selezionare le opzioni per includere dati del campo, Commenti e Modifiche incrementali al PDF.

Nota:

la selezione dell’opzione per le modifiche incrementali risulta utile per ricevere firme digitali che possano venire facilmente lette e ricostruite da un server.

HTML

Restituisce il modulo in formato Hypertext Markup Language.

XFDF

Restituisce l’input dell’utente sotto forma di file XML. È possibile includere i commenti unitamente ai dati del campo oppure solo i dati del campo.

PDF

Restituisce l’intero file PDF con l’input dell’utente.

Selezione campo

Specifica i campi che vengono restituiti. Per ricevere solo alcuni dei dati del campo completato, selezionare Solo questi, fare clic su Seleziona campi, quindi selezionare i campi da includere o escludere nella finestra di dialogo Selezione campo.

Ad esempio, è possibile utilizzare questa opzione per escludere alcuni campi calcolati o duplicati visualizzati nel modulo per agevolare il lavoro dell’utente, ma che non aggiungono informazioni nuove.

Opzioni data

Standardizza il formato delle date inserite dall’utente.

Come cambiare l’aspetto dei pulsanti

Un pulsante può contenere un’etichetta, un’icona o entrambe. È possibile modificare l’aspetto del pulsante in ogni stato del mouse (Rilasciato, Premuto e Rollover). Ad esempio, è possibile creare un pulsante che presenta l’etichetta “Home Page”, che diventa invece “Fare clic per tornare alla pagina iniziale” quando il puntatore viene spostato sul pulsante.

È possibile creare icone dei pulsanti da qualsiasi formato di file visualizzabile in Acrobat DC, tra cui PDF, JPEG, GIF e altri formati grafici. Per qualsiasi formato selezionato, viene utilizzata la pagina intera. Pertanto, se si desidera utilizzare solo una parte della pagina come icona, è necessario ritagliare l’immagine o la pagina prima di completare la procedura. Le dimensioni di pagina PDF minime utilizzabili sono di 2,54 x 2,54 cm (1 x 1 pollici). Se l’icona visualizzata deve essere di dimensioni inferiori a cm 2,54 x 2,54, ridimensionarla per adattarla al riquadro disegnato con lo strumento Pulsante. La selezione di Avanzate nella scheda Opzioni della finestra di dialogo Proprietà pulsante consente di determinare in che modo l’icona di un pulsante viene ridimensionata per adattarsi al pulsante che la contiene.

Layout dei pulsanti
Layout dei pulsanti

A. Solo etichetta B. Solo icona C. Icona sopra, testo sotto D. Etichetta sopra, icona sotto E. Icona a sinistra, etichetta a destra F. Etichetta a sinistra, icona a destra G. Etichetta sull’icona 

Modificare un pulsante

  1. Se non è attiva la modalità di modifica dei moduli, scegliere Strumenti > Prepara modulo.

  2. Selezionare il campo Pulsante, quindi effettuare una delle seguenti operazioni:
    • Per modificare le proprietà per il campo pulsante, fare doppio clic sul pulsante.

    • Per modificare l’aspetto dei pulsanti, utilizzare le opzioni dell’aspetto nella scheda Aspetto della finestra di dialogo Proprietà pulsante.

    • Per allineare, centrare o distribuire il pulsante con altri campi modulo oppure per ridimensionare o duplicare il pulsante, fare clic con il pulsante destro del mouse su di esso, quindi scegliere un’opzione dal menu contestuale.

  3. Chiudere tutte le finestre di dialogo aperte, se presenti. Fare clic sull'icona a croce nella parte all'estremità destra della barra degli strumenti per chiudere lo strumento Prepara modulo.

Specificare le proprietà di visualizzazione dei pulsanti Acrobat

  1. Se non è attiva la modalità di modifica dei moduli, scegliere Strumenti > Prepara modulo.

  2. Fare doppio clic su un pulsante esistente, quindi fare clic sulla scheda Opzioni nella finestra di dialogo Proprietà pulsante.
  3. Nella casella Layout, scegliere il tipo di visualizzazione dell’etichetta desiderato. Per informazioni su come ridimensionare le icone dei pulsanti, seguire la procedura descritta di seguito.
  4. Nella casella Comportamento, specificare la visualizzazione del pulsante quando viene fatto clic su di esso.
  5. Per definire l’etichetta o l’icona visualizzata sul pulsante, scegliere una delle seguenti procedure:
    • Se l’opzione dell’etichetta viene selezionata dal menu Layout, digitare il testo desiderato nella casella Etichetta.

    • Se un’opzione dell’icona viene selezionata dal menu Layout, fare clic su Scegli icona, quindi su Sfoglia e selezionare il file. Fare clic su Cancella per rimuovere l’icona selezionata.

  6. Chiudere tutte le finestre di dialogo aperte, se presenti. Fare clic sull'icona a croce nella parte all'estremità destra della barra degli strumenti per chiudere lo strumento Prepara modulo.

Opzioni di funzionamento dei pulsanti

Nessuna

L’aspetto del pulsante non viene modificato.

Premuto

Specifica l’aspetto degli stati Rilasciato, Premuto e Rollover del mouse. Selezionare un’opzione in Stato, quindi specificare un’opzione dell’etichetta o dell’icona:

Rilasciato

Determina l’aspetto del pulsante quando non viene fatto clic sul pulsante del mouse.

Premuto

Determina l’aspetto del pulsante quando viene fatto clic sul pulsante, ma prima del rilascio.

Rollover

Determina l’aspetto del pulsante quando si mantiene il puntatore sul pulsante.

Contorno

Consente di evidenziare il contorno del pulsante.

Inverti

Consente di invertire le ombre scure e chiare del pulsante.

Ridimensionare e posizionare i pulsanti

  1. Se non è attiva la modalità di modifica dei moduli, scegliere Strumenti > Prepara modulo.

  2. Fare doppio clic su un pulsante esistente per aprire la finestra di dialogo Proprietà pulsante.
  3. Fare clic sulla scheda Opzioni, selezionare una delle opzioni delle icone dal menu Layout, quindi fare clic su Avanzate.

    Nota:

    Se dal menu Layout viene selezionata l’opzione Solo etichetta, il pulsante Avanzate non è disponibile.

  4. Selezionare un’opzione dal menu Quando applicare la scala:

    Sempre

    Consente di ridimensionare l’icona indipendentemente dalle sue dimensioni in base alle dimensioni del pulsante.

    Mai

    Consente di conservare le dimensioni originali dell’icona, che viene però tagliata dal bordo del pulsante se troppo grande. Se è selezionata l’opzione Mai, le opzioni di ridimensionamento non sono disponibili.

    L’icona è troppo grande

    Ridimensiona l’icona solo se più grande rispetto al pulsante.

    L’icona è troppo piccola

    Ridimensiona l’icona solo se più piccola rispetto al pulsante.

  5. Dal menu Scala, scegliere se ridimensionare o meno l’icona in modo proporzionale. Se l’icona non viene ridimensionata in modo proporzionale, è possibile che risulti inclinata.

  6. Per fare in modo che i lati superiore e inferiore o sinistro e destro dell’icona siano allineati ai margini del pulsante, selezionare Adatta ai bordi.

  7. Per definire la posizione esatta dell’icona nel pulsante, utilizzare le frecce cursore. La posizione dell’icona viene definita in base alla percentuale di spazio lasciato tra l’icona e il limite sinistro del campo e tra l’icona e il limite inferiore del campo. L’impostazione predefinita (50, 50) consente di collocare l’icona al centro del campo. È possibile fare clic su Reimposta per ripristinare l’impostazione predefinita in qualsiasi momento.

  8. Fare clic su OK, quindi su Chiudi.

  9. Per visualizzare in anteprima e verificare il funzionamento del pulsante, fare clic su Anteprima nella parte all'estremità destra della barra degli strumenti. Al termine, è possibile fare clic su Modifica per tornare allo strumento Prepara modulo, oppure fare clic sull'icona a croce nella parte all'estremità destra della barra degli strumenti per chiuderlo.

Nascondere un pulsante Acrobat DC tranne che durante il rollover

In alcuni casi, è possibile rendere invisibile l’area del pulsante fino a quando non viene attraversata dal puntatore. Mostrando e nascondendo alternativamente un pulsante, è possibile creare effetti visivi interessanti all’interno dei documenti. Ad esempio, quando il puntatore viene spostato su una città riportata in una cartina geografica, è possibile che venga visualizzata una cartina dettagliata della città, che sparisce quando il puntatore viene allontanato da quel punto.

Come visualizzare e nascondere icone
Come visualizzare e nascondere icone

A. Il puntatore non si trova sull’area del pulsante B. Il puntatore viene posizionato sull’area del pulsante C. Il puntatore viene allontanato dall’area del pulsante 
  1. Se non è attiva la modalità di modifica dei moduli, scegliere Strumenti > Prepara modulo.

  2. Utilizzare lo strumento Pulsante  e trascinarlo sull’area in cui si desidera visualizzare il pulsante a comparsa. Ad esempio, se il file PDF contiene una cartina geografica della Francia, eseguire il trascinamento sull’area in cui si desidera che compaia una cartina dettagliata di Parigi.

  3. Fare doppio clic sul pulsante, quindi clic sulla scheda Opzioni e scegliere Solo icona dal menu Layout.

  4. Scegliere Premuto dal menu Comportamento, quindi scegliere Rollover dall’elenco Stato.

  5. Fare clic su Scegli icona, quindi su Sfoglia. Scegliere il tipo di file da Tipo file, selezionare il percorso del file di immagine, quindi fare doppio clic sul file. In questo esempio viene selezionata una cartina geografica di Parigi. Fare clic su OK per accettare come pulsante l’immagine di esempio visualizzata.

  6. Fare clic sulla scheda Aspetto. Se necessario, deselezionare Colore bordo e Colore di riempimento e fare clic su Chiudi.

  7. Se è attiva la modalità di modifica, fare clic su Anteprima. Il campo dell’immagine definito verrà visualizzato durante il rollover del cursore sull’area del pulsante e scomparirà quando il cursore viene allontanato.

    Nota:

    Se si desidera che l’immagine sia più grande dell’area di rollover o che si trovi in una posizione diversa rispetto al pulsante grafico a comparsa, utilizzare l’azione Mostra/nascondi campo. Innanzitutto, è necessario specificare un’icona per il pulsante che verrà mostrato o nascosto. Dopodiché, è necessario creare un secondo pulsante che agisca da area sensibile al rollover del mouse. L’assegnazione di un’icona al secondo pulsante non è obbligatoria. La scheda Azioni viene utilizzata invece per mostrare il primo pulsante quando il puntatore viene posizionato sul secondo pulsante e per nasconderlo quando viene allontanato.

  8. Al termine, è possibile fare clic su Modifica per tornare allo strumento Prepara modulo, oppure fare clic sull'icona a croce nella parte all'estremità destra della barra degli strumenti per chiuderlo.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online