What's covered
Learn what you can do to make Illustrator speedy and efficient on Mac OS X.
On this page

    Several factors affect how quickly and efficiently Adobe Illustrator performs, for example, operating system and hardware configuration, your workflow, options you select. If you notice Illustrator running more slowly than usual, there are several techniques you can try to optimize not only Illustrator performance, but performance of your other apps as well.

    An improvement in performance is more noticeable when you work with large files.

    Before you begin

    Before working through the tasks below, make sure you have the latest version of Illustrator or any updates to the version you are using. Software updates often include performance-related fixes or enhancements.

    If you're using Illustrator CC, you can update Illustrator via the Creative Cloud desktop application.

    Optimize Mac OS X

    Configuring your operating system to run efficiently increases the amount of memory available to apps, which helps them run smoothly. Try these techniques to optimize Mac OS X and improve Illustrator performance.

    Every font you have installed increases the amount of RAM Mac OS X uses. Install only the fonts you need, to improve system performance and the performance of apps that access fonts. Use a font management utility to help you manage many fonts.


    Non-PostScript printer drivers can conflict with Illustrator. Therefore, Adobe recommends that you set a PostScript printer driver as the default printer in Mac OS.

    Step 1. Set a PostScript printer as the default printer

    Note:

    To complete this procedure, make sure that a PostScript printer is connected to your computer directly or via a network.

    1. (Mac OS X v10.4 and later) From the Apple menu, choose System Preferences, then click Printers & Scanners.

      (Mac OS X v10.3 and later) In the Finder, choose Applications, then open the Utilities folder. Double-click Printer Setup Utility.

      (Mac OS X v10.2.8 and earlier) In the Finder, choose Applications, then open the Utilities folder. Double-click Print Center .

    2. (Mac OS X v10.4 or later) If a PostScript printer isn't listed, click +, navigate to a PostScript printer, and click Add.

      (Mac OS X v10.3 or earlier) If a PostScript printer isn't listed, click Add Printer, navigate to a PostScript printer, and click Add.

    3. (Mac OS X v10.4 or later) Select a PostScript printer from Default printer pop up menu.

      (Mac OS X v10.3 or earlier) Select a PostScript printer, and then choose Printers > Make Default.

    Step 2. Configure Illustrator to print to a non-default printer

    1. Open any document in Illustrator, and choose File > Print.

    2. In the Print dialog box, choose Adobe PostScript File or the name of the printer from the Printer menu.

       

    3. Click Save.


    Optimize hardware configuration

    The hardware you use affects Illustrator performance: the faster the processor or hard drive, the faster Illustrator can process information. Other hardware enhancements, such as installing additional RAM, using a multiprocessor system, or optimizing and defragmenting drives, can also improve performance. Here are some tasks you can try to optimize hardware configuration and improve Illustrator performance.

    The speed of your computer's Central Processing Unit (CPU) affects the speed of Illustrator. Because Illustrator manipulates large quantities of data and performs many calculations, its speed depends on the processor's speed. Consider using a computer with a faster processor.


    If Illustrator has insufficient RAM, it uses hard disk space (i.e., a scratch disk) to process information. Illustrator is fastest when it can process information in memory, without using a hard disk.


    Here are a few ways to optimize disk space:

    • Check your hard disk for errors or defragment files with a third-party disk utility (e.g., Norton Utilities). If you're running Mac OS X, the drive shouldn't need to be defragmented but may need to repaired with a third-party disk utility.
    • Save your files to drives with faster access speeds. For example, use an internal hard drive rather than a network server (network drive) or external drive.
    • If you want to save a file to a network or external drive, first save the file to an internal hard drive. Then close the file and use the Finder to copy it to the network or external drive. Or you can save the file to the network using Adobe Version Cue (CS4 only).

    Use Illustrator features effectively

    The way you work in Illustrator, especially the way you view artwork, can affect Illustrator performance. Here are some ways to use Illustrator features that can help keep Illustrator running smoothly.

    Outline View hides paint attributes, displaying the artwork as unfilled paths. Working in Outline View can speed the display of complex artwork, such as objects containing gradients or patterns. Outline View can also make it easier to edit objects hidden behind other filled objects.

    To display an Illustrator document in Outline View, choose View > Outline.


    You can create custom views of your document. Custom views enable you to quickly change the view mode, magnification, scroll position, and layer options.

    To create a custom view of an Illustrator document, set the view attributes you want to save. Then choose View > New View and enter a name in the New View dialog box. The custom view appears in the View menu.


    Use the Hand tool to specify the quality and speed of the display of an Illustrator document.

    To specify display quality, choose Edit > Preferences > Units & Display Performance. Drag the Hand Tool slider to the left to improve display quality when you use the Hand tool. Move it to the right to improve speed.


    You can change the resolution of raster effects to optimize Illustrator performance.

    To change the resolution of raster effects, choose Effect > Document Raster Effects Settings, choose one fo the following from the Resolution drop down list:

    • If you are editing files, click Screen. Illustrator uses a resolution of 72 ppi for raster effects, increasing display speed.
    • If you are printing files, click High. Illustrator uses a resolution of 300 ppi for raster effects, decreasing printing speed, but increasing print quality.

    Then, click OK.


    Illustrator redraws the screen faster when you hide layers that contain complex artwork or high-resolution bitmap images.

    To hide a layer, click the eye icon to the left of the layer name, clear Show Layer, and then click OK. To hide all but the selected layer, Alt-click the eye icon.

    The Layers panel can display thumbnails for top-level layers, nested layers, groups, and objects. To reduce the number of thumbnails so Illustrator redraws the screen faster, choose Panel Options from the Layers panel menu, then reduce the number of thumbnails.

    • To remove all thumbnails from the Layers panel, select Small in the Row Size section, and then click OK.
    • To remove thumbnails for specific elements in the Layers panel, deselect Layers, Groups, or Objects in the Thumbnails section, and click OK.

    Overprint Preview provides an “ink preview” that approximates how blending, transparency, and overprinting appear in color-separated output. To enhance performance, avoid using Overprint Preview.

    To enable and disable Overprint Preview, choose View > Overprint Preview.


    Artboards represent the regions that can contain printable artwork. To optimize performance, consider deleting unused or unnecessary Artboards.

    To manage your Artboards, choose Window > Artboards. Then, select an artboard you want to remove, and click Delete.


    When you work with an embedded bitmap image and your system doesn't have enough RAM, Illustrator uses hard disk space as a scratch disk. It takes longer to access information on a hard disk than in memory. Therefore, using a portion of the hard disk as virtual memory can decrease performance. If you need more memory to work in Illustrator, try adding more RAM.

    By default, Illustrator uses the system drive as its primary scratch disk. Change the Illustrator primary scratch disk setting to your fastest hard drive.

    To change the scratch disk preference, do the following:

    1. Choose Illustrator > Preferences > Plug-ins & Scratch Disk.

    2. Choose a hard disk from the Primary pop-up menu. If you intend to work with large images and have more than one hard disk, choose another disk from the Secondary pop-up menu.
    3. Click OK and restart Illustrator.


    Illustrator Document Profiles contain the default patterns, gradients, graph designs, colors, color libraries, and brushes that appear in new Illustrator documents. These files also determine zoom level, window size, viewing preferences, and scroll position for new documents. Minimize the file size of new documents by removing unnecessary swatches and brushes from Illustrator new document profiles.

    For instructions on creating custom document profiles, see Startup Profiles: A great tool to customize your new documents.

     


    Templates let you create new documents that share common settings and design elements. You can minimize the file size of new documents by removing unnecessary swatches, symbols, graphic styles, and brushes from templates.

    For instructions on creating template files, see Files and templates.


    Embedded bitmap images (for example, TIFF, BMP, or Photoshop EPS) can dramatically increase the size of an Illustrator document, causing slower performance. To improve performance, enable the Link option when you place a bitmap image. The Link option references the placed image on the hard disk.

    • Go to File > Place. In the Place dialog box, choose Link.

    If a service bureau requires embedded images, then save a copy of the files. Choose Include Linked Files in the Illustrator Native Format Options or EPS Format Options dialog box.


    If a document contains linked EPS images that have high-resolution previews, Illustrator redraws the screen slower as you edit artwork. To enable Illustrator to redraw the screen more quickly, use low-resolution EPS previews. Do the following:

    1. Choose Illustrator > Preferences > File Handling & Clipboard.

    2. Select Use Low Resolution Proxy For Linked EPS and click OK.


    The Links Panel Options dialog box includes a Show DCS Transparency Interactions option. If this option is selected, the Links panel displays a yellow icon to identify linked DCS EPS graphics that are transparent or overlap transparent objects. Because this option forces Illustrator to regularly determine if linked EPS files interact with transparency, it can reduce performance.

    To disable the Show Transparency Interactions option, do the following:

    1. Select Window > Links. From the Links panel menu, choose Panel Options.

    2. Clear Show DCS Transparency Interactions and click OK.


    The Navigator panel displays a thumbnail view of your current artwork for easy navigation. The processing time required to update the thumbnail each time you change the document depends on the complexity of your artwork. To improve screen redraw speed and performance in a complex document, hide the Navigator panel.

    • Under the Window menu, deselect Navigator.

    You can set up custom views to more efficiently zoom to particular areas of your document.


    The Anti-alias Artwork option smoothes text and graphics by blending the color of an object's edge pixels with the color of adjacent pixels. However, this process can cause slow screen redraw. To disable this
    option, do the following:

    1. Choose Illustrator > Preferences > General.

    2. Clear Anti-aliased Artwork and click OK.


    The Simplify command reduces the amount of anchor points in paths and path shapes, reducing file size and increasing performance. To apply the Simplify command, select the desired path or object, then choose Object > Path > Simplify.

    For more information on the Simplify command, see Editing paths.


    Smart Guides allow you to create, align, edit, and transform Illustrator objects relative to other objects. If you have many objects in your artwork, Illustrator requires more time to display Smart Guides.

    • To disable Smart Guides, click the View menu, and deselect Smart Guides.

    Find out more information about Smart Guides.


    Bristle Brush strokes are made up of several overlapping, filled transparent paths. These paths, like any other filled path in Illustrator, interact with the paint of other objects, including other Bristle Brush paths.

    Test and experiment with Bristle Brushes and paint rendition before embarking on large-scale artwork. Changing brush attributes and reapplying them renders all used brushes over again.

    Tip:

    It's important to save a copy of your original artwork before rasterizing the content.

    When using Bristle Brushes you can reduce the complexity and file size of your document by doing the following:

    • Rasterize some Bristle Brush paths.

    If the artwork contains a large number (>30) of Bristle Brushes, reduce the complexity and number of the Bristle Brush paths. Select the Bristle Brush paths and choose Object > Rasterize.

    • Disable the PDF capabilities.

    By default Illustrator saves the PDF data that enables Illustrator (*ai) files to be compatible with other Adobe apps. Choose File > Save (or Save As) and deselect Create PDF Compatible File.


     
    Back to top