دليل المستخدم إلغاء

الربط

  1. دليل مستخدم Dreamweaver
  2. مقدمة
    1. أساسيات تصميم الويب التفاعلي
    2. الجديد في Dreamweaver
    3. تطوير الويب باستخدام Dreamweaver - نظرة عامة
    4. Dreamweaver | الأسئلة الشائعة
    5. اختصارات لوحة المفاتيح‬‏‫
    6. متطلبات النظام لبرنامج Dreamweaver
    7. ملخص الميزات
  3. Dreamweaver وCreative Cloud
    1. مزامنة إعدادات Dreamweaver مع Creative Cloud
    2. مكتبات Creative Cloud في Dreamweaver
    3. استخدام ملفات Photoshop في Dreamweaver
    4. العمل باستخدام Adobe Animate وDreamweaver
    5. استخراج ملفات SVG المحسّنة من المكتبات
  4. مساحات عمل Dreamweaver وطرق عرضه
    1. مساحة عمل Dreamweaver
    2. تحسين مساحة عمل Dreamweaver للتطوير المرئي
    3. البحث عن الملفات استنادًا إلى اسم الملف أو المحتوى | Mac OS
  5. إعداد المواقع
    1. حول مواقع Dreamweaver
    2. إعداد إصدار محلي من موقعك
    3. الاتصال بخادم نشر
    4. إعداد خادم اختبار
    5. استيراد إعدادات موقع Dreamweaver وتصديرها
    6. إحضار مواقع ويب موجودة من خادم بعيد إلى جذر موقع الويب المحلي
    7. ميزات الوصول في Dreamweaver
    8. الإعدادات المتقدمة
    9. تعيين تفضيلات الموقع لنقل الملفات
    10. تحديد إعدادات خادم الوكيل في Dreamweaver
    11. مزامنة إعدادات Dreamweaver مع Creative Cloud
    12. استخدام Git في Dreamweaver
  6. إدارة الملفات
    1. إنشاء الملفات وفتحها
    2. إدارة الملفات والمجلدات
    3. إحضار الملفات من الخادم ووضعها فيه
    4. سحب الملفات وإيداعها
    5. مزامنة الملفات
    6. مقارنة الملفات لمعرفة الاختلافات
    7. حماية ملفات ومجلدات في موقع Dreamweaver
    8. تمكين Design Notes لمواقع Dreamweaver وتعطيلها
    9. منع الاستغلال المحتمل لـ Gatekeeper
  7. التخطيط والتصميم
    1. استخدام الأدوات المساعدة المرئية للتخطيط
    2. حول استخدام CSS لتخطيط صفحاتك
    3. تصميم مواقع ويب تفاعلية باستخدام Bootstrap
    4. إنشاء استعلامات الوسائط واستخدامها في Dreamweaver
    5. عرض المحتوى باستخدام الجداول
    6. الألوان
    7. تصميم استجابة باستخدام مخططات الشبكة المرنة
    8. ميزة Extract في Dreamweaver
  8. CSS
    1. فهم أوراق الأنماط المتتالية
    2. تخطيط الصفحات باستخدام CSS Designer
    3. استخدام معالجات CSS الأولية في Dreamweaver
    4. كيفية تعيين تفضيلات أنماط CSS في Dreamweaver
    5. نقل قواعد CSS في Dreamweaver
    6. تحويل CSS مضمنة إلى قاعدة CSS في Dreamweaver
    7. استخدام علامات div
    8. تطبيق تدرجات على الخلفية
    9. إنشاء تأثيرات CSS3 الانتقالية وتحريرها في Dreamweaver
    10. تنسيق التعليمات البرمجية
  9. محتويات الصفحة وأصولها
    1. تعيين خصائص الصفحة
    2. تعيين خصائص عناوين CSS وخصائص ارتباطات CSS
    3. استخدام النص
    4. البحث عن النص والعلامات والسمات واستبدالها
    5. لوحة DOM
    6. التحرير في Live View
    7. ترميز المستندات في Dreamweaver
    8. تحديد العناصر وعرضها في النافذة Document
    9. تعيين خصائص النص في عارض الخصائص
    10. إجراء التدقيق الإملائي لصفحة ويب
    11. استخدام القواعد الأفقية في Dreamweaver
    12. إضافة مجموعات الخطوط وتعديلها في Dreamweaver
    13. استخدام الأصول
    14. إدراج التواريخ وتحديثها في Dreamweaver
    15. إنشاء الأصول المفضلة وإدارتها في Dreamweaver
    16. إدراج الصور وتحريرها في Dreamweaver
    17. إضافة كائنات وسائط
    18. إضافة مقاطع الفيديو في Dreamweaver
    19. إدراج فيديو HTML5
    20. إدراج ملفات SWF
    21. إضافة تأثيرات صوتية
    22. إدراج صوت HTML5 في Dreamweaver
    23. العمل باستخدام عناصر المكتبة
    24. استخدام النصوص العربية والعبرية في Dreamweaver
  10. الربط والتنقل
    1. حول الربط والتنقل
    2. الربط
    3. مخططات الصور
    4. استكشاف أخطاء الارتباطات وحلها
  11. عناصر واجهة jQuery وتأثيراتها
    1. استخدام عناصر واجهة مستخدم jQuery UI والجوال في Dreamweaver
    2. استخدام تأثيرات jQuery في Dreamweaver
  12. كتابة التعليمات البرمجية لمواقع الويب
    1. حول كتابة التعليمات البرمجية في Dreamweaver
    2. بيئة كتابة التعليمات البرمجية في Dreamweaver
    3. تعيين تفضيلات التعليمات البرمجية
    4. تخصيص ألوان التعليمات البرمجية
    5. كتابة تعليمة برمجية وتحريرها
    6. تلميحات التعليمات البرمجية وإكمال التعليمات البرمجية
    7. طي التعليمات البرمجية وتوسيعها
    8. إعادة استخدام التعليمات البرمجية مع أجزاء التعليمات البرمجية
    9. فحص التعليمات البرمجية
    10. تحسين التعليمة البرمجية
    11. تحرير التعليمة البرمجية في طريقة العرض Design
    12. العمل باستخدام محتوى العنوان للصفحات
    13. إدراج تضمينات على جانب الخادم في Dreamweaver
    14. استخدام مكتبات العلامات في Dreamweaver
    15. استيراد علامات مخصصة إلى Dreamweaver
    16. استخدام سلوكيات JavaScript (إرشادات عامة)
    17. تطبيق سلوكيات JavaScript المضمنة
    18. نبذة عن لغتي XML وXSLT
    19. تنفيذ تحويلات XSL على جانب الخادم في Dreamweaver
    20. تنفيذ تحويلات XSL على جانب العميل في Dreamweaver
    21. إضافة كيانات أحرف لـ XSLT في Dreamweaver
    22. تنسيق التعليمات البرمجية
  13. عمليات سير العمل على مستوى المنتجات
    1. تثبيت الملحقات واستخدامها في Dreamweaver
    2. التحديثات من داخل التطبيق في Dreamweaver
    3. إدراج مستندات Microsoft Office في Dreamweaver ‏(Windows فقط)
    4. استخدام Fireworks وDreamweaver
    5. تحرير المحتوى في مواقع Dreamweaver باستخدام Contribute
    6. تكامل Dreamweaver مع تطبيق Business Catalyst
    7. إنشاء حملات إعلانية خاصة عبر البريد الإلكتروني
  14. القوالب
    1. حول قوالب Dreamweaver
    2. التعرف على القوالب والمستندات القائمة على القوالب
    3. إنشاء قالب Dreamweaver
    4. إنشاء مناطق قابلة للتحرير في القوالب
    5. إنشاء مناطق وجداول التكرار في Dreamweaver
    6. استخدام المناطق الاختيارية في القوالب
    7. تحديد سمات العلامات القابلة للتحرير في Dreamweaver
    8. كيفية إنشاء قوالب متداخلة في Dreamweaver
    9. تحرير القوالب وتحديثها وحذفها
    10. تصدير محتوى xml واستيراده في Dreamweaver
    11. تطبيق أو إزالة قالب من مستند موجود
    12. تحرير المحتوى في قوالب Dreamweaver
    13. قواعد بناء الجملة لعلامات القوالب في Dreamweaver
    14. تعيين تفضيلات التمييز لمناطق القالب
    15. فوائد استخدام القوالب في Dreamweaver
  15. شاشات الهاتف المحمول والشاشات المتعددة
    1. إنشاء استعلامات الوسائط
    2. تغيير اتجاه الصفحة للأجهزة الجوالة
    3. إنشاء تطبيقات الويب للأجهزة الجوالة باستخدام Dreamweaver
  16. المواقع والصفحات ونماذج الويب الديناميكية
    1. فهم تطبيقات الويب
    2. إعداد الكمبيوتر لتطوير التطبيقات
    3. استكشاف أخطاء اتصالات قاعدة البيانات وحلها
    4. إزالة برامج الاتصال النصية في Dreamweaver
    5. تصميم صفحات ديناميكية
    6. نظرة عامة على مصادر المحتوى الديناميكي
    7. تعريف مصادر المحتوى الديناميكي
    8. إضافة محتوى ديناميكي إلى الصفحات
    9. تغيير المحتوى الديناميكي في Dreamweaver
    10. عرض سجلات قاعدة البيانات
    11. توفير البيانات المباشرة واستكشاف أخطائها وحلها في Dreamweaver
    12. إضافة سلوكيات خادم مخصصة في Dreamweaver
    13. إنشاء النماذج باستخدام Dreamweaver
    14. استخدام النماذج لجمع معلومات من المستخدمين
    15. إنشاء نماذج ColdFusion وتمكينها في Dreamweaver
    16. إنشاء نماذج الويب
    17. دعم HTML5 محسّن لعناصر النماذج
    18. تطوير نموذج باستخدام Dreamweaver
  17. إنشاء التطبيقات مرئيًا
    1. إنشاء صفحات رئيسية وصفحات تفاصيل في Dreamweaver
    2. إنشاء صفحات البحث والنتائج
    3. إنشاء صفحة إدراج سجل
    4. إنشاء صفحة تحديث سجل في Dreamweaver
    5. إنشاء صفحات حذف سجل في Dreamweaver
    6. استخدام أوامر ASP لتعديل قاعدة البيانات في Dreamweaver
    7. إنشاء صفحة تسجيل
    8. إنشاء صفحة تسجيل دخول
    9. إنشاء صفحة يمكن للمستخدمين المخولين فقط الوصول إليها
    10. تأمين المجلدات في Coldfusion باستخدام Dreamweaver
    11. استخدام مكونات ColdFusion في Dreamweaver
  18. اختبار مواقع الويب ومعاينتها ونشرها
    1. معاينة الصفحات
    2. معاينة صفحات ويب Dreamweaver على أجهزة متعددة
    3. اختبار موقع Dreamweaver
  19. استكشاف الأخطاء وإصلاحها
    1. المشكلات التي تم إصلاحها
    2. المشكلات المعروفة

 

 

تعلم كيفية إعداد التنقل بين صفحات الويب الخاصة بك. اربط بين الملفات والوثائق، واختبر الارتباطات وغيرها وحدّثها في Dreamweaver.

قبل إنشاء ارتباط، تأكد من فهم طريقة عمل المسارات المطلقة، والنسبية للمستندات، والنسبية لجذر الموقع. يمكنك إنشاء أنواع متعددة من الارتباطات في مستند:

  • ارتباط إلى مستند آخر أو إلى ملف، مثل ملف رسومات، أو ملف أفلام، أو ملف بتنسيق PDF، أو ملف صوت.
  • ارتباط ارتساء مسمى، ينتقل إلى موقع معين في مستند.

  • ارتباط بريد إلكتروني، يقوم بإنشاء رسالة بريد إلكتروني فارغة جديدة تحمل عنوان المستلم مسبقًا.

  • ارتباطات فارغة وارتباطات برامج نصية، يمكنك استخدامها لإرفاق سلوكيات بكائن أو لإنشاء ارتباط يقوم بتنفيذ تعليمات برمجية بلغة JavaScript.

يمكنك استخدام عارض الخصائص والأيقونة Point-To-File لإنشاء ارتباطات من صورة، أو كائن، أو نص إلى مستند أو ملف آخر.

يقوم Dreamweaver بإنشاء الارتباطات إلى صفحات أخرى في الموقع الخاص بك باستخدام مسارات نسبية للمستندات. يمكنك كذلك إصدار أوامر لبرنامج Dreamweaver لإنشاء ارتباطات جديدة باستخدام مسارات نسبية لجذر الموقع.

قم دومًا بحفظ ملف جديد قبل إنشاء مسار نسبي للمستندات، حيث لا يعد المسار النسبي للمستندات صالحًا دون نقطة بداية محددة. في حالة إنشاء مسار نسبي للمستندات قبل حفظ الملف، يستخدم Dreamweaver بصفة مؤقتة مسارًا مطلقًا يبدأ بـ file:// إلى أن يتم حفظ الملف؛ وعند حفظ الملف، يقوم Dreamweaver بتحويل المسار file:// إلى مسار نسبي.

يمكنك إرفاق سلوك بأي ارتباط في مستند. فكّر في استخدام السلوكيات التالية عند إدراج عناصر مرتبطة في المستندات:

Set Text Of Status Bar

يقوم بتحديد نص الرسالة وعرضها في شريط الحالة بالركن السفلي الأيسر من نافذة المستعرض. على سبيل المثال، يمكنك استخدام هذا السلوك لوصف وجهة ارتباط في شريط الحالة بدلاً من إظهار عنوان URL المرتبط به.

Open Browser Window

يقوم بفتح URL في نافذة جديدة. يمكنك تحديد خصائص النافذة الجديدة، بما في ذلك الاسم، والحجم، والسمات الخاصة بها (ما إذا كان يمكن تغيير حجمها، أو لها شريط قوائم، وما إلى ذلك).

Jump Menu

يقوم بتحرير قائمة انتقال. يمكنك تغيير القائمة، أو تحديد ملف مرتبط مختلف، أو تغيير موقع المستعرض الذي يفتح فيه المستند المرتبط.

يمكنك استخدام أيقونة مجلد عارض الخصائص أو المربع Link لإنشاء ارتباطات من صورة، أو كائن، أو نص إلى مستند أو ملف آخر.

  1. حدد نصًا أو صورة في طريقة العرض Design بالنافذة Document.
  2. افتح عارض الخصائص (Window > Properties) وقم بأحد الإجراءات التالية:
    • انقر فوق أيقونة المجلد  الموجودة على يمين المربع Link للاستعراض إلى ملف وتحديده.

      يظهر المسار إلى المستند المرتبط في المربع URL. استخدم القائمة المنبثقة Relative To في مربع الحوار Select HTML File لجعل المسار نسبيًا للمستندات أو نسبيًا للجذر، ثم انقر فوق OK. ينطبق نوع المسار الذي تقوم بتحديده على الارتباط الحالي فقط. (يمكنك تغيير الإعداد الافتراضي للمربع Relative To بالنسبة للموقع.)

    • اكتب المسار واسم الملف للمستند في المربع Link.

      للارتباط بمستند في الموقع لديك، أدخل مسارًا نسبيًا للمستندات أو نسبيًا لجذر الموقع. للارتباط بمستند خارج الموقع لديك، أدخل مسارًا مطلقًا يشتمل على البروتوكول (مثل http://). يمكنك استخدام هذا الأسلوب لإدخال ارتباط لملف لم يتم إنشاؤه بعد.

  3. من القائمة المنسدلة Target، حدد موقعًا لفتح المستند فيه.

    • يقوم _blank بتحميل المستند المرتبط في نافذة مستعرض جديدة غير مسماة.
    • _parent يقوم بتحميل المستند المرتبط في الإطار الأصل أو النافذة الأصل للإطار الذي يحتوي على الارتباط. إذا كان الإطار الذي يحتوي على الارتباط غير متداخل، يتم تحميل المستند المرتبط في نافذة المستعرض الكاملة.
    • يقوم _self بتحميل المستند المرتبط في نفس الإطار أو النافذة الموجود بها الارتباط. وهذا الهدف هو الإعداد الافتراضي، لذا لا تحتاج عادة إلى تحديده.
    • يقوم _top بتحميل المستند المرتبط في نافذة المستعرض الكاملة، وبالتالي تتم إزالة جميع الإطارات.
    • يقوم _new بتحميل الملف المرتبط في نافذة جديدة.
  1. حدد نصًا أو صورة في طريقة العرض Design بالنافذة Document.
  2. يمكنك إنشاء ارتباط بإحدى طريقتين:
    • اسحب أيقونة Point-To-File  (أيقونة الهدف) إلى يمين المربع Link في عارض الخصائص وقم بالتأشير إلى نقطة ارتساء مرئية في المستند الحالي، أو نقطة ارتساء مرئية في مستند مفتوح آخر، أو عنصر يتسم بمعرف فريد معين له، أو مستند في اللوحة Files.

    • اسحب مع الضغط على المفتاح Shift من التحديد وقم بالتأشير إلى نقطة ارتساء مرئية في المستند الحالي، أو نقطة ارتساء مرئية في مستند مفتوح آخر، أو عنصر يتسم بمعرف فريد معين له، أو مستند في اللوحة Files.

    يمكنك الارتباط بمستند مفتوح آخر فقط إذا لم تكن المستندات الخاصة بك في وضع التكبير في المستند Document. لإجراء تجانب للمستندات، حدد Window > Arrange > Cascade أو Window > Arrange > Tile. عند التأشير إلى مستند مفتوح، ينتقل هذا المستند إلى مقدمة الشاشة لديك أثناء إجرائك للتحديد.

يتيح لك الأمر Hyperlink إنشاء ارتباط نصي إلى صورة، أو كائن، أو إلى مستند أو ملف آخر.

  1. ضع نقطة الإدراج في المستند في الموضع الذي تريد ظهور الارتباط به.
  2. قم بأحد الإجراءات التالية لعرض مربع الحوار Hyperlink:

    • حدد Insert > Hyperlink.

    • في الفئة Common باللوحة Insert، انقر فوق الزر Hyperlink.

  3. في حقل Text، أدخل نص الارتباط.
    من قائمة Link المنسدلة، حدد اسم الملف للارتباط به. يمكنك أيضًا النقر فوق أيقونة المجلد للاستعراض إلى الملف الذي تريد الارتباط به.

  4. من القائمة المنبثقة Target، حدد النافذة التي يجب فتح الملف فيها أو اكتب اسمها.

    تظهر أسماء جميع الإطارات التي قمت بتسميتها في المستند الحالي في القائمة المنبثقة. في حالة تحديد إطار غير موجود، تفتح الصفحة المرتبطة في نافذة جديدة تحتوي على الاسم الذي قمت بتحديده. يمكنك كذلك التحديد من أسماء الأهداف المحجوزة التالية:

    • يقوم _blank بتحميل الملف المرتبط في نافذة مستعرض جديدة غير مسماة.
    • يقوم _parent بتحميل الملف المرتبط في مجموعة الإطارات الأصل أو نافذة الإطار الذي يحتوي على الارتباط. إذا كان الإطار الذي يحتوي على الارتباط غير متداخل، فسيتم تحميل الملف المرتبط في نافذة المستعرض الكاملة.
    • _self يقوم بتحميل الملف المرتبط في نفس إطار أو نافذة الارتباط. وهذا الهدف هو الإعداد الافتراضي، لذا لا تحتاج عادة إلى تحديده.
    • يقوم _top بتحميل الملف المرتبط في نافذة المستعرض الكاملة، وبالتالي إزالة كافة الإطارات.
    • يقوم _new بتحميل الملف المرتبط في نافذة جديدة.
  5. في المربع Tab Index، أدخل رقمًا لترتيب علامات التبويب.
  6. في المربع Title، أدخل عنوانًا للارتباط.
  7. في المربع Access Key، أدخل بديلاً للوحة المفاتيح (حرفًا واحدًا) لتحديد الارتباط في المستعرض.
  8. انقر فوق OK.

يمكنك إدراج ارتباط إلى مستند Microsoft Word أو Excel في صفحة موجودة.

  1. في طريقة العرض Design، افتح الصفحة في الموضع الذي تريد ظهور الارتباط به.

  2. اسحب الملف من موقعه الحالي إلى صفحة Dreamweaver مع وضع الارتباط حيثما تريد. يظهر مربع الحوار Insert Document.

  3. حدد Create A Link، ثم انقر فوق OK.

    إذا كان المستند الذي تقوم بإضافة ارتباط به واقعًا خارج المجلد الجذر لموقعك، فسوف يطالبك Dreamweaver بنسخ المستند في جذر الموقع.

    بعد نسخ المستند إلى المجلد الجذر للموقع، سوف تتأكد من أن المستند سيكون متوفرًا عند نشر موقع الويب.

  4. عند تحميل صفحتك على خادم الويب، تأكد من تحميل ملف Word أو Excel أيضًا. تحتوي صفحتك الآن على ارتباط إلى مستند Word أو Excel. ويكون نص الارتباط هو اسم الملف المرتبط، ويمكنك تغيير نص الارتباط في النافذة Document إذا أردت.

افتراضيًا، يقوم Dreamweaver بإنشاء ارتباطات إلى صفحات أخرى في الموقع لديك باستخدام المسارات النسبية للمستندات. لاستخدام مسار نسبي لجذر الموقع بدلاً من ذلك، يجب أولاً تعريف مجلد محلي في Dreamweaver عبر اختيار مجلد جذر محلي لكي يكون بديلاً لجذر المستند على الخادم. يستخدم Dreamweaver هذا المجلد لتحديد المسارات النسبية لجذر الموقع إلى الملفات.

  1. حدد Site > Manage Sites.
  2. في مربع الحوار Manage Sites، انقر نقرًا مزدوجًا فوق الموقع في القائمة.
  3. في مربع الحوار Site Setup، قم بتوسيع Advanced Settings وحدد الفئة Local Info.
  4. قم بتعيين المسار النسبي للارتباطات الجديدة عبر تحديد الخيار Document أو Site Root.

    لن يؤدي تغيير هذا الإعداد إلى تحويل مسار الارتباطات الحالية بعد النقر فوق OK. ينطبق هذا الإعداد على الارتباطات الجديدة التي تقوم بإنشائها باستخدام Dreamweaver فقط.

  5. انقر فوق Save.

    ينطبق إعداد المسار الجديد على الموقع الحالي فقط.

يمكنك استخدام عارض الخصائص للارتباط بجزء معين من مستند عبر إنشاء نقاط ارتساء مسماة أولاً. تتيح لك نقاط الارتساء المسماة تعيين علامات في مستند، يتم إدراجها غالبًا بموضوع معين أو بأعلى المستند. يمكنك بعد ذلك إنشاء ارتباطات إلى نقاط الارتساء المسماة هذه، تقوم بنقل الزائر سريعًا إلى الموضع المحدد.

يعد إنشاء ارتباط إلى نقطة ارتساء مسماة عملية مكونة من خطوتين. أولاً، يجب إنشاء نقطة ارتساء مسماة، ثم إنشاء ارتباط إلى نقطة الارتساء المسماة.

إنشاء نقطة ارتساء

  1. في نافذة Document حدد عنصرًا وقم بتمييزه لتعيينه كنقطة ارتساء.

  2. افتح عارض الخصائص وتحقق مما إذا كان العنصر المحدد له معرف أم لا. إذا كان الحقل فارغًا، فأضف معرفًا. على سبيل المثال، Anchor.

    إنشاء نقطة ارتساء
    إنشاء نقطة ارتساء

    بعد إضافة المعرف، لاحظ التغييرات في التعليمات البرمجية. يتم إدراج id="<ID name>" في التعليمات البرمجية عند تحديدك.

    معرف نقطة الارتساء في التعليمات البرمجية
    إضافة أدوات إرساء لعمل الارتباطات

  1. في طريقة العرض Design بالنافذة Document، حدد نصًا أو صورة لإنشاء ارتباط منها.
  2. في المربع Link في عارض الخصائص، اكتب علامة رقم (#) واسم نقطة الارتساء. على سبيل المثال، للارتباط بنقطة ارتساء باسم “top” في المستند الحالي، اكتب #top. للارتباط بنقطة ارتساء باسم "top" في مستند مختلف بنفس المجلد، اكتب filename.html#top.
    ملاحظة:

    أسماء نقاط الارتساء حساسة لحالة الأحرف.

  1. افتح المستند الذي يحتوي على نقطة الارتساء المسماة.
    ملاحظة:

    إذا كنت لا تشاهد نقطة الارتساء، فمن طريقة عرض Design حدد View > Design View Options > Visual Aids > Invisible Elements لجعل أدوات الإرساء مرئية.

  2. في طريقة العرض Design بالنافذة Document، حدد نصًا أو صورة تريد الارتباط منها. (إذا كان ذلك مستند مفتوح آخر، يجب التبديل إليه.)
  3. قم بأحد الإجراءات التالية:
    • انقر فوق أيقونة Point-To-File  (أيقونة الهدف) إلى يمين المربع Link في عارض الخصائص واسحبه إلى نقطة الارتساء التي تريد الارتباط بها: نقطة ارتساء داخل نفس المستند أو نقطة ارتساء في مستند مفتوح آخر.

    • اسحب مع الضغط على المفتاح Shift في النافذة Document من النص أو الصورة المحددة إلى نقطة الارتساء التي تريد الارتباط بها: نقطة ارتساء داخل نفس المستند أو نقطة ارتساء في مستند مفتوح آخر.

يفتح ارتباط البريد الإلكتروني نافذة رسالة فارغة جديدة (باستخدام برنامج البريد المقترن بمستعرض المستخدم) عند النقر فوقه. في نافذة رسالة البريد الإلكتروني، يتم تحديث المربع To تلقائيًا بالعنوان المحدد في ارتباط البريد الإلكتروني.

  1. في طريقة العرض Design بالنافذة Document، ضع نقطة الإدراج في الموضع الذي تريد ظهور ارتباط البريد الإلكتروني به، أو حدد النص أو الصورة التي تريد ظهورها كارتباط البريد الإلكتروني.
  2. قم بأحد الإجراءات التالية لإدراج الارتباط:
    • حدد Insert > Email Link.

    • في الفئة Common باللوحة Insert، انقر فوق الزر Email Link.

  3. في المربع Text، اكتب النص الأساسي لرسالة البريد الإلكتروني أو قم بتحريره.
  4. في المربع Email، اكتب عنوان البريد الإلكتروني، ثم انقر فوق OK.
  1. حدد نصًا أو صورة في طريقة العرض Design بالنافذة Document.
  2. في المربع Link بعارض الخصائص، اكتب mailto: متبوعة بعنوان البريد الإلكتروني.

    لا تكتب أي مسافات بين علامة النقطتين وعنوان البريد الإلكتروني.

التعبئة التلقائية لسطر الموضوع في بريد إلكتروني

  1. قم بإنشاء ارتباط بريد إلكتروني باستخدام عارض الخصائص على النحو المفصّل أعلاه.
  2. في المربع Link بعارض الخصائص، قم بإضافة ?subject= بعد البريد الإلكتروني، ثم اكتب موضوعًا بعد علامة المساواة. لا تكتب أي مسافات بين علامة الاستفهام ونهاية عنوان البريد الإلكتروني.

    يظهر الإدخال الكامل بالشكل التالي:

    mailto:someone@yoursite.com?subject=Mail from Our Site

الارتباط الفارغ هو ارتباط بلا تعيين. استخدم الارتباطات الفارغة لإرفاق سلوكيات بالكائنات أو النصوص بالصفحة. على سبيل المثال، يمكنك إرفاق سلوك بارتباط فارغ لكي يقوم بتبديل صورة أو عرض عنصر ذي تعيين مطلق للموضع (عنصر AP) عند تحريك المؤشر فوق الارتباط.

تقوم ارتباطات البرامج النصية بتنفيذ تعليمات برمجية بلغة JavaScript أو استدعاء وظيفة JavaScript وتعد مفيدة لمنح الزائرين معلومات إضافية حول عنصر معين دون مغادرة صفحة الويب الحالية. يمكن كذلك استخدام ارتباطات البرامج النصية لتنفيذ عمليات حسابية، أو التحقق من صحة النماذج، أو تنفيذ مهام معالجة أخرى عند قيام الزائر بالنقر فوق عنصر معين.

  1. حدد نصًا، أو صورة، أو كائنًا في طريقة العرض Design بالنافذة Document.
  2. في عارض الخصائص، اكتب javascript:; (الكلمة javascript،) متبوعة بفاصلة، تليها فاصلة منقوطة) في المربع Link.
  1. حدد نصًا، أو صورة، أو كائنًا في طريقة العرض Design بالنافذة Document.
  2. في المربع Link بعارض الخصائص، اكتب javascript:; متبوعة بتعليمات برمجية بلغة JavaScript أو وظيفة استدعاء. (لا تكتب مسافة بين الفاصلة والتعليمات البرمجية أو وظيفة الاستدعاء.)

يستطيع Dreamweaver تحديث ارتباطات من مستند وإليه عند نقل المستند أو إعادة تسميته في موقع محلي. تعمل هذه الميزة بشكل أفضل عند تخزين الموقع بأكمله (أو جزء كامل ذاتي الاحتواء منه) على القرص المحلي لديك. لا يقوم Dreamweaver بتغيير الملفات في المجلد البعيد إلى أن تقوم بوضع الملفات المحلية على الخادم البعيد أو إيداعها به.

لتسريع عملية التحديث، يستطيع Dreamweaver إنشاء ملف تخزين مؤقت يتم تخزين معلومات به حول جميع الارتباطات الموجودة في المجلد المحلي لديك. يتم تحديث ملف التخزين المؤقت بصورة غير مرئية أثناء إضافة الارتباطات، أو تغييرها، أو حذفها بالموقع المحلي لديك.

  1. حدد Edit > Preferences (في نظام التشغيل Windows) أو Dreamweaver > Preferences (في نظام التشغيل Macintosh).
  2. في مربع الحوار Preferences، حدد General من قائمة الفئات الموجودة إلى اليسار.
  3. في الجزء Document Options بالتفضيلات General، حدد خيارًا من القائمة المنبثقة Update Links When Moving Files.

    Always

    يقوم تلقائيًا بتحديث جميع الارتباطات من مستند محدد وإليه عند نقل المستند أو إعادة تسميته.

    Never

    لا يقوم تلقائيًا بتحديث جميع الارتباطات من مستند محدد وإليه عند نقل المستند أو إعادة تسميته.

    Prompt

    يعرض مربع حوار يسرد جميع الملفات التي تتأثر بالتغيير. انقر فوق Update لتحديث الارتباطات الموجودة في هذه الملفات، أو انقر فوق Don’t Update لترك الملفات دون تغيير.

  4. انقر فوق OK.

إنشاء ملف تخزين مؤقت للموقع الخاص بك

  1. حدد Site > Manage Sites.
  2. حدد موقعًا، ثم انقر فوق Edit.
  3. في مربع الحوار Site Setup، قم بتوسيع Advanced Settings وحدد الفئة Local Info.
  4. في الفئة Local Info، حدد Enable Cache.

    في المرة الأولى التي تقوم فيها بتغيير ارتباطات إلى الملفات الموجودة في المجلد المحلي لديك أو حذفها بعد تشغيل Dreamweaver، يطالبك Dreamweaver بتحميل ذاكرة التخزين المؤقت. في حالة النقر فوق Yes، يقوم Dreamweaver بتحميل ذاكرة التخزين المؤقت وتحديث جميع الارتباطات إلى الملف الذي قمت بتغييره للتو. في حالة النقر فوق No، يتم تسجيل التغيير في ذاكرة التخزين المؤقت، ولكن لا يقوم Dreamweaver بتحميل ذاكرة التخزين المؤقت أو تحديث الارتباطات.

    قد يستغرق تحميل ذاكرة التخزين المؤقت بالمواقع الكبيرة بضع دقائق لأنه يلزم أن يحدد Dreamweaver ما إذا كانت ذاكرة التخزين المؤقت محدثة عبر مقارنة الطوابع الزمنية للملفات الموجودة على الموقع المحلي بتلك المسجلة في ذاكرة التخزين المؤقت. إذا لم تقم بتغيير أي ملفات خارج Dreamweaver، يمكنك النقر بأمان فوق الزر Stop عند ظهوره.

إعادة إنشاء ذاكرة التخزين المؤقت

  1. في اللوحة Files، حدد Site > Advanced > Recreate Site Cache.

بالإضافة إلى قيام Dreamweaver بتحديث الارتباطات تلقائيًا عند نقل ملف أو إعادة تسميته، يمكنك تغيير جميع الارتباطات (بما في ذلك ارتباطات البريد الإلكتروني، وارتباطات بروتوكول FTP، والارتباطات الفارغة، وارتباطات البرامج النصية) يدويًا بحيث تشير إلى موقع آخر.

يفيد هذا الخيار في حالة الرغبة في حذف ملف ترتبط به ملفات أخرى، ولكن يمكنك استخدامه لأغراض أخرى. على سبيل المثال، بافتراض ربط العبارة "أفلام هذا الشهر" بـ /movies/july.html عبر أنحاء الموقع لديك. اعتبارًا من الأول من شهر أغسطس، ستقوم بتغيير هذه الارتباطات بحيث تشير إلى /movies/august.html.

  1. حدد ملفًا في طريقة العرض Local باللوحة Files.
    ملاحظة:

    إذا كنت تقوم بتغيير ارتباط بريد إلكتروني، أو ارتباط بروتوكول FTP، أو ارتباط فارغ، أو ارتباط برامج نصية، لا يلزم تحديد ملف.

  2. حدد Site > Site Options > Change Link Sitewide.

  3. قم بإكمال الخيارات التالية في مربع الحوار Change Link Sitewide.

    Change All Links To

    انقر فوق أيقونة المجلد  للاستعراض إلى ملف الهدف الذي تريد إلغاء الارتباط منه وتحديده. إذا كنت تقوم بتغيير ارتباط بريد إلكتروني، أو ارتباط بروتوكول FTP، أو ارتباط فارغ، أو ارتباط برامج نصية، اكتب النص الكامل للارتباط الذي تقوم بتغييره.

    Into Links to

    انقر فوق أيقونة المجلد  للاستعراض إلى الملف الجديد الذي تريد الارتباط به وتحديده. إذا كنت تقوم بتغيير ارتباط بريد إلكتروني، أو ارتباط بروتوكول FTP، أو ارتباط فارغ، أو ارتباط برامج نصية، اكتب النص الكامل للارتباط البديل.

  4. انقر فوق OK.

    يقوم Dreamweaver بتحديث أي مستندات مرتبطة بالملف المحدد، وجعلها تشير إلى الملف الجديد، باستخدام تنسيق المسار المستخدم بالفعل في المستند (على سبيل المثال، إذا كان المسار القديم نسبيًا للمستندات، يكون المسار الجديد نسبيًا للمستندات كذلك).

    بعد تغيير ارتباط على مستوى الموقع، يصبح الملف المحدد معزولاً (أي لا تشير إليه أي ملفات على القرص المحلي لديك). يمكنك حذف الملف بأمان دون تقطيع أي ارتباطات في موقع Dreamweaver المحلي الخاص بك.

    ملاحظة:

    ونظرًا لأن هذه التغييرات تحدث محليًا، يجب حذف الملف المعزول المناظر الموجود في المجلد البعيد يدويًا ووضع أي ملفات تم تغيير الارتباطات بها أو إيداعها؛ وإلا فلن يتمكن زائرو الموقع الخاص بك من مشاهدة التغييرات.

لا تكون الارتباطات نشطة في Dreamweaver، أي، يتعذر فتح مستند مرتبط عبر النقر فوق الارتباط في النافذة Document.

  1. قم بأحد الإجراءات التالية:
    • انقر بزر الماوس الأيمن فوق الارتباط وحدد Open Linked Page.

    • اضغط على المفتاح Control (في نظام التشغيل Windows) أو المفتاح Command (في نظام التشغيل Macintosh)، ثم انقر نقرًا مزدوجًا فوق الارتباط.

    ملاحظة:

    يجب أن يوجد المستند المرتبط على القرص المحلي لديك.

 Adobe

احصل على مساعدة بشكل أسرع وأسهل

مستخدم جديد؟

Adobe MAX 2024

Adobe MAX
مؤتمر الإبداع

في الفترة من 14 إلى 16 أكتوبر في ميامي بيتش وعبر الإنترنت

Adobe MAX

مؤتمر الإبداع

في الفترة من 14 إلى 16 أكتوبر في ميامي بيتش وعبر الإنترنت

Adobe MAX 2024

Adobe MAX
مؤتمر الإبداع

في الفترة من 14 إلى 16 أكتوبر في ميامي بيتش وعبر الإنترنت

Adobe MAX

مؤتمر الإبداع

في الفترة من 14 إلى 16 أكتوبر في ميامي بيتش وعبر الإنترنت