دليل المستخدم إلغاء

استخدام الأدوات المساعدة المرئية للتخطيط

  1. دليل مستخدم Dreamweaver
  2. مقدمة
    1. أساسيات تصميم الويب التفاعلي
    2. الجديد في Dreamweaver
    3. تطوير الويب باستخدام Dreamweaver - نظرة عامة
    4. Dreamweaver | الأسئلة الشائعة
    5. اختصارات لوحة المفاتيح‬‏‫
    6. متطلبات النظام لبرنامج Dreamweaver
    7. ملخص الميزات
  3. Dreamweaver وCreative Cloud
    1. مزامنة إعدادات Dreamweaver مع Creative Cloud
    2. مكتبات Creative Cloud في Dreamweaver
    3. استخدام ملفات Photoshop في Dreamweaver
    4. العمل باستخدام Adobe Animate وDreamweaver
    5. استخراج ملفات SVG المحسّنة من المكتبات
  4. مساحات عمل Dreamweaver وطرق عرضه
    1. مساحة عمل Dreamweaver
    2. تحسين مساحة عمل Dreamweaver للتطوير المرئي
    3. البحث عن الملفات استنادًا إلى اسم الملف أو المحتوى | Mac OS
  5. إعداد المواقع
    1. حول مواقع Dreamweaver
    2. إعداد إصدار محلي من موقعك
    3. الاتصال بخادم نشر
    4. إعداد خادم اختبار
    5. استيراد إعدادات موقع Dreamweaver وتصديرها
    6. إحضار مواقع ويب موجودة من خادم بعيد إلى جذر موقع الويب المحلي
    7. ميزات الوصول في Dreamweaver
    8. الإعدادات المتقدمة
    9. تعيين تفضيلات الموقع لنقل الملفات
    10. تحديد إعدادات خادم الوكيل في Dreamweaver
    11. مزامنة إعدادات Dreamweaver مع Creative Cloud
    12. استخدام Git في Dreamweaver
  6. إدارة الملفات
    1. إنشاء الملفات وفتحها
    2. إدارة الملفات والمجلدات
    3. إحضار الملفات من الخادم ووضعها فيه
    4. سحب الملفات وإيداعها
    5. مزامنة الملفات
    6. مقارنة الملفات لمعرفة الاختلافات
    7. حماية ملفات ومجلدات في موقع Dreamweaver
    8. تمكين Design Notes لمواقع Dreamweaver وتعطيلها
    9. منع الاستغلال المحتمل لـ Gatekeeper
  7. التخطيط والتصميم
    1. استخدام الأدوات المساعدة المرئية للتخطيط
    2. حول استخدام CSS لتخطيط صفحاتك
    3. تصميم مواقع ويب تفاعلية باستخدام Bootstrap
    4. إنشاء استعلامات الوسائط واستخدامها في Dreamweaver
    5. عرض المحتوى باستخدام الجداول
    6. الألوان
    7. تصميم استجابة باستخدام مخططات الشبكة المرنة
    8. ميزة Extract في Dreamweaver
  8. CSS
    1. فهم أوراق الأنماط المتتالية
    2. تخطيط الصفحات باستخدام CSS Designer
    3. استخدام معالجات CSS الأولية في Dreamweaver
    4. كيفية تعيين تفضيلات أنماط CSS في Dreamweaver
    5. نقل قواعد CSS في Dreamweaver
    6. تحويل CSS مضمنة إلى قاعدة CSS في Dreamweaver
    7. استخدام علامات div
    8. تطبيق تدرجات على الخلفية
    9. إنشاء تأثيرات CSS3 الانتقالية وتحريرها في Dreamweaver
    10. تنسيق التعليمات البرمجية
  9. محتويات الصفحة وأصولها
    1. تعيين خصائص الصفحة
    2. تعيين خصائص عناوين CSS وخصائص ارتباطات CSS
    3. استخدام النص
    4. البحث عن النص والعلامات والسمات واستبدالها
    5. لوحة DOM
    6. التحرير في Live View
    7. ترميز المستندات في Dreamweaver
    8. تحديد العناصر وعرضها في النافذة Document
    9. تعيين خصائص النص في عارض الخصائص
    10. إجراء التدقيق الإملائي لصفحة ويب
    11. استخدام القواعد الأفقية في Dreamweaver
    12. إضافة مجموعات الخطوط وتعديلها في Dreamweaver
    13. استخدام الأصول
    14. إدراج التواريخ وتحديثها في Dreamweaver
    15. إنشاء الأصول المفضلة وإدارتها في Dreamweaver
    16. إدراج الصور وتحريرها في Dreamweaver
    17. إضافة كائنات وسائط
    18. إضافة مقاطع الفيديو في Dreamweaver
    19. إدراج فيديو HTML5
    20. إدراج ملفات SWF
    21. إضافة تأثيرات صوتية
    22. إدراج صوت HTML5 في Dreamweaver
    23. العمل باستخدام عناصر المكتبة
    24. استخدام النصوص العربية والعبرية في Dreamweaver
  10. الربط والتنقل
    1. حول الربط والتنقل
    2. الربط
    3. مخططات الصور
    4. استكشاف أخطاء الارتباطات وحلها
  11. عناصر واجهة jQuery وتأثيراتها
    1. استخدام عناصر واجهة مستخدم jQuery UI والجوال في Dreamweaver
    2. استخدام تأثيرات jQuery في Dreamweaver
  12. كتابة التعليمات البرمجية لمواقع الويب
    1. حول كتابة التعليمات البرمجية في Dreamweaver
    2. بيئة كتابة التعليمات البرمجية في Dreamweaver
    3. تعيين تفضيلات التعليمات البرمجية
    4. تخصيص ألوان التعليمات البرمجية
    5. كتابة تعليمة برمجية وتحريرها
    6. تلميحات التعليمات البرمجية وإكمال التعليمات البرمجية
    7. طي التعليمات البرمجية وتوسيعها
    8. إعادة استخدام التعليمات البرمجية مع أجزاء التعليمات البرمجية
    9. فحص التعليمات البرمجية
    10. تحسين التعليمة البرمجية
    11. تحرير التعليمة البرمجية في طريقة العرض Design
    12. العمل باستخدام محتوى العنوان للصفحات
    13. إدراج تضمينات على جانب الخادم في Dreamweaver
    14. استخدام مكتبات العلامات في Dreamweaver
    15. استيراد علامات مخصصة إلى Dreamweaver
    16. استخدام سلوكيات JavaScript (إرشادات عامة)
    17. تطبيق سلوكيات JavaScript المضمنة
    18. نبذة عن لغتي XML وXSLT
    19. تنفيذ تحويلات XSL على جانب الخادم في Dreamweaver
    20. تنفيذ تحويلات XSL على جانب العميل في Dreamweaver
    21. إضافة كيانات أحرف لـ XSLT في Dreamweaver
    22. تنسيق التعليمات البرمجية
  13. عمليات سير العمل على مستوى المنتجات
    1. تثبيت الملحقات واستخدامها في Dreamweaver
    2. التحديثات من داخل التطبيق في Dreamweaver
    3. إدراج مستندات Microsoft Office في Dreamweaver ‏(Windows فقط)
    4. استخدام Fireworks وDreamweaver
    5. تحرير المحتوى في مواقع Dreamweaver باستخدام Contribute
    6. تكامل Dreamweaver مع تطبيق Business Catalyst
    7. إنشاء حملات إعلانية خاصة عبر البريد الإلكتروني
  14. القوالب
    1. حول قوالب Dreamweaver
    2. التعرف على القوالب والمستندات القائمة على القوالب
    3. إنشاء قالب Dreamweaver
    4. إنشاء مناطق قابلة للتحرير في القوالب
    5. إنشاء مناطق وجداول التكرار في Dreamweaver
    6. استخدام المناطق الاختيارية في القوالب
    7. تحديد سمات العلامات القابلة للتحرير في Dreamweaver
    8. كيفية إنشاء قوالب متداخلة في Dreamweaver
    9. تحرير القوالب وتحديثها وحذفها
    10. تصدير محتوى xml واستيراده في Dreamweaver
    11. تطبيق أو إزالة قالب من مستند موجود
    12. تحرير المحتوى في قوالب Dreamweaver
    13. قواعد بناء الجملة لعلامات القوالب في Dreamweaver
    14. تعيين تفضيلات التمييز لمناطق القالب
    15. فوائد استخدام القوالب في Dreamweaver
  15. شاشات الهاتف المحمول والشاشات المتعددة
    1. إنشاء استعلامات الوسائط
    2. تغيير اتجاه الصفحة للأجهزة الجوالة
    3. إنشاء تطبيقات الويب للأجهزة الجوالة باستخدام Dreamweaver
  16. المواقع والصفحات ونماذج الويب الديناميكية
    1. فهم تطبيقات الويب
    2. إعداد الكمبيوتر لتطوير التطبيقات
    3. استكشاف أخطاء اتصالات قاعدة البيانات وحلها
    4. إزالة برامج الاتصال النصية في Dreamweaver
    5. تصميم صفحات ديناميكية
    6. نظرة عامة على مصادر المحتوى الديناميكي
    7. تعريف مصادر المحتوى الديناميكي
    8. إضافة محتوى ديناميكي إلى الصفحات
    9. تغيير المحتوى الديناميكي في Dreamweaver
    10. عرض سجلات قاعدة البيانات
    11. توفير البيانات المباشرة واستكشاف أخطائها وحلها في Dreamweaver
    12. إضافة سلوكيات خادم مخصصة في Dreamweaver
    13. إنشاء النماذج باستخدام Dreamweaver
    14. استخدام النماذج لجمع معلومات من المستخدمين
    15. إنشاء نماذج ColdFusion وتمكينها في Dreamweaver
    16. إنشاء نماذج الويب
    17. دعم HTML5 محسّن لعناصر النماذج
    18. تطوير نموذج باستخدام Dreamweaver
  17. إنشاء التطبيقات مرئيًا
    1. إنشاء صفحات رئيسية وصفحات تفاصيل في Dreamweaver
    2. إنشاء صفحات البحث والنتائج
    3. إنشاء صفحة إدراج سجل
    4. إنشاء صفحة تحديث سجل في Dreamweaver
    5. إنشاء صفحات حذف سجل في Dreamweaver
    6. استخدام أوامر ASP لتعديل قاعدة البيانات في Dreamweaver
    7. إنشاء صفحة تسجيل
    8. إنشاء صفحة تسجيل دخول
    9. إنشاء صفحة يمكن للمستخدمين المخولين فقط الوصول إليها
    10. تأمين المجلدات في Coldfusion باستخدام Dreamweaver
    11. استخدام مكونات ColdFusion في Dreamweaver
  18. اختبار مواقع الويب ومعاينتها ونشرها
    1. معاينة الصفحات
    2. معاينة صفحات ويب Dreamweaver على أجهزة متعددة
    3. اختبار موقع Dreamweaver

 

استخدم الوسائل المساعدة المرئية للتخطيط في Dreamweaver، بما في ذلك مسطرات الضبط وأدلة تخطيط الضبط، واستخدام الأدلة مع القوالب واستخدام شبكة تخطيطات، واستخدام صورة متابعة.

تعيين المساطر

تساعدك المساطر على قياس وتنظيم ووضع خطط لتخطيطك. يمكن أن تظهر على الحدود اليسرى والعلوية من الصفحة، مميزة بوحدات البكسل والبوصات والسنتيمترات.

  • لتبديل تشغيل المساطر وإيقافها، حدد View > Design View Options > Rules > Show/Hide.
  • لتغيير الأصل، اسحب أيقونة أصل المسطرة  (في الركن العلوي الأيسر من طريقة العرض Design بالنافذة Document) في أي مكان من الصفحة.
  • لإعادة تعيين الأصل إلى موقعه الافتراضي، حدد View > Design View Options >Rulers > Reset Origin.
  • لتغيير وحدة القياس، حدد View > Rulers، ثم حدد Pixels أو Inches أو Centimeters.

قم بتعيين أدلة التخطيط

تعد الأدلة أسطر تسحبها إلى المستند من المساطر. فهي تساعدك على وضع ومحاذاة الكائنات بشكل أكثر دقة. يمكنك أيضًا قياس حجم عناصر الصفحة أو محاكاة الطيات (المناطق المرئية) من مستعرضات الويب.

للمساعدة في محاذاة العناصر، يمكنك محاذاة العناصر بالأدلة، أو محاذاة الأدلة بالعناصر. (يجب أن توضع العناصر بصورة تامة بالترتيب لسمة المحاذاة لكي تعمل). يمكنك أيضًا قفل الأدلة لمنع نقلها بصورة عرضية بواسطة مستخدم آخر.

قم بإنشاء دليل أفقي أو رأسي

  1. اسحب من المسطرة المطابقة.
  2. ضع الدليل في النافذة Document، وحرر زر الماوس (إعادة وضع الدليل بسحبه مرة أخرى).
    ملاحظة:

    افتراضيًا، يتم تسجيل الأدلة باعتبارها مقاييس بالبكسل من الجانب العلوي أو السفلي للمستند، ويتم عرضها نسبيًا لأصل المسطرة. لتسجيل الدليل كنسبة مئوية، اضغط المفتاح Shift أثناء إنشاء أو نقل الدليل.

إظهار أو إخفاء الأدلة

  1. حدد View > Guides > Show Guides.

محاذاة العناصر إلى الأدلة

  • لمحاذاة الأدلة إلى العناصر، حدد View > Design View Options > Guides > Snap to Guides.
  • لمحاذاة الأدلة إلى العناصر، حدد View > Design View Options > Guides > Guides Snap to Elements.
ملاحظة:

عند تغيير حجم العناصر، مثل العناصر ذات التعيين المطلق للموضع (عناصر AP) والجداول والصور يتم محاذاة العناصر التي تم تغيير حجمها إلى الأدلة.

تأمين أو قفل كل الأدلة

حدد View > Design View Options > Guides > Lock Guides.

عرض ونقل دليل إلى موضع محدد

  1. ضع مؤشر الماوس فوق الدليل لعرض موضعه.
  2. انقر نقرًا مزدوجًا فوق الدليل.
  3. أدخل الموضع الجديد في مربع الحوار Move Guide، ثم انقر فوق OK.

عرض المسافة بين الأدلة

اضغط على المفتاح Control (في نظام التشغيل Windows) أو المفتاح Command (في نظام التشغيل Macintosh)، ثم ضع مؤشر الماوس في أي مكان بين الدليلين.
ملاحظة:

تعد وحدة القياس هي نفس وحدة القياس المستخدمة للمساطر.

محاكاة الطية (المنطقة المرئية) من مستعرض الويب

حدد View > Design View Options > Guides، ثم حدد حجم مستعرض معد مسبقًا من القائمة.

أزل دليلاً

اسحب الدليل خارج المستند.

تغيير إعدادات الدليل

  1. حدد View > Design View Options > Guides > Edit Guides، ثم قم بتعيين الخيارات التالية، ثم انقر فوق OK.

    Guide color

    يحدد لون سطور الدليل. انقر فوق حامل اللون، ثم حدد لونًا من منتقي الألوان أو اكتب رقم سداسي عشري في مربع النص.

    Distance Color

    يحدد لون السطور التي تظهر كمؤشر مسافة عندما تضع مؤشر الماوس بين الأدلة. انقر فوق حامل اللون، ثم حدد لونًا من منتقي الألوان أو اكتب رقم سداسي عشري في مربع النص.

    Show Guides

    تجعل الأدلة ظاهرة في طريقة العرض Design.

    Snap to Guides

    تحاذي عناصر الصفحة بالأدلة عندما تحرك العناصر حول الصفحة.

    Lock Guides

    قفل الأدلة في مكانها.

    Guides Snap to Elements

    يحاذي الأدلة إلى العناصر على الصفحة حينما تقوم بسحب الأدلة.

    Clear All

    مسح كل الأدلة من الصفحة.

استخدام الأدلة مع القوالب

عندما تتم إضافة أدلة إلى قالب Dreamweaver، كل مثيلات القالب ترث الأدلة. ومع ذلك، تتم معاملة الأدلة في مثيلات القالب باعتبارها مناطق قابلة للتحرير، وبالتالي يمكنك تعديلها. تتم استعادة الأدلة المعدّلة في مثيلات القالب إلى موقعها الأصلي حينما يتم تحديث المثيل بالقالب الأصلي.

يمكنك إضافة أدلتك الخاصة إلى مثيلات القالب. ولا تتم الكتابة فوق الأدلة التي تتم إضافتها بهذه الطريقة عندما يتم تحديث مثيل القالب بالقالب الأصلي.

استخدام شبكة التخطيط

وتعرض هذه الشبكة نظامًا من الأسطر الأفقية والعمودية في النافذة Document. وهو مفيد لوضع الكائنات بدقة. يمكنك جعل عناصر الصفحة ذات التعيين المطلق للمواضع تحاذي الشبكة حينما تحركها، وأن تغير الشبكة أو تتحكم في سلوك المحاذاة بتحديد إعدادات الشبكة. تعمل المحاذاة سواءً كانت ظاهرة أم لا.

إظهار أو إخفاء الشبكة

حدد View > Design View Options > Grid > Show Grid.

إتاحة الانطباق أو تعطيله

حدد View > Design View Options > Grid > Snap to Grid.

تغيير إعدادات الشبكة

  1. حدد View > Design View Options > Grid > Grid Settings.

  2. قم بتعيين أي من الخيارات التالية، ثم انقر فوق OK لتطبيق التغييرات.

    Color

    يحدد لون سطور الشبكة. انقر فوق حامل اللون، ثم حدد لونًا من منتقي الألوان أو اكتب رقم سداسي عشري في مربع النص.

    Show Grid

    تجعل الشبكة ظاهرة في طريقة العرض Design.

    Snap to Grid

    تحاذي عناصر الصفحة بسطور الشبكة.

    Spacing

    تتحكم في مدى التباعد بين سطور الشبكة. أدخل رقمًا، وحدد Pixels أو Inches أو Centimeters من القائمة.

    Display

    يحدد ما إذا كانت سطور الشبكة تظهر كسطور أو نقاط.

    ملاحظة:

    إذا لم يتم تحديد Show Grid، لا تظهر الشبكة في المستند ولا تكون أي تغييرات مرئية.

Use a tracing image

يمكنك استخدام صورة تتبع كدليل لإعادة إنشاء تصميم صفحة تم إنشاؤها في التطبيقات الرسومية مثل Adobe Freehand أو Fireworks.

صورة التتبع هي صورة JPEG أو GIF أو PNG يتم وضعها في خلفية نافذة Document. يمكنك إخفاء الصورة وتعيين معدل الشفافية لها وتغيير موضعها.

تكون صورة التتبع ظاهرة فقط في Dreamweaver؛ وتكون غير ظاهرة عندما تعرض الصفحة في مستعرض. عندما تكون صورة التتبع معروضة، تكون صورة الخلفية الحقيقية بالصفحة ولونها غير ظاهرين في النافذة Document، وستكون صورة الخلفية ولونها ظاهرين عند عرض الصفحة في مستعرض.

ضع صورة تتبع في النافذة Document.

  1. قم بأحد الإجراءات التالية:
    • حدد View > Design View Options > Tracing Image > Load.

    • حدد File > Page Properties، ثم في فئة Tracing Image، انقر فوق Browse (بجوار مربع نص Tracing Image).

  2. انتقل إلى ملف الصورة ثم انقر فوق OK.

  3. في مربع الحوار Page Properties، حدد شفافية الصورة عن طريق سحب منزلق Image Transparency، ثم انقر فوق OK.

    للتبديل لصورة تتبع مختلفة أو لتغيير شفافية صورة التتبع الحالية في أي وقت، حدد File > Page Properties.

عرض أو إخفاء صورة التتبع

حدد View > Design View Options >Tracing Image > Show.

تغيير موضع صورة تتبع

  1. حدد View > Design View Options > Tracing Image > Adjust Position.

    • لتحديد موضع صورة التتبع بدقة، أدخل قيم الإحداثيات في مربعات النصوص X وY.

    • لنقل الصورة بمقدار بكسل واحد في المرة الواحدة، استخدم مفاتيح الأسهم.

    • لنقل الصورة بمقدار 5 بيكسل في المرة الواحدة، اضغط المفتاح Shift ومفاتيح الأسهم.

قم بإعادة تعيين موضع صورة التتبع

  1. حدد View > Design View Options > Tracing Image > Reset Position.

    تعود صورة التتبع إلى الزاوية العليا اليسرى من النافذة Document (0,0).

محاذاة صورة التتبع إلى عنصر محدد

  1. حدد عنصرًا في النافذة Document.
  2. حدد View > Design View Options > Tracing Image > Align with Selection.

    تتم محاذاة الزاوية العليا اليسرى من صورة التتبع مع الزاوية العليا اليسرى من العنصر المحدد.

شعار Adobe

تسجيل الدخول إلى حسابك