Руководство пользователя Отмена

Объединение данных с помощью панели «Переменные»

  1. Руководство пользователя Illustrator
  2. Основы работы с Illustrator
    1. Введение в Illustrator
      1. Новые возможности в приложении Illustrator
      2. Часто задаваемые вопросы
      3. Системные требования Illustrator
      4. Illustrator для Apple Silicon
    2. Рабочая среда
      1. Основные сведения о рабочей среде
      2. Ускоренное обучение благодаря панели «Обзор» в Illustrator
      3. Создание документов
      4. Панель инструментов
      5. Комбинации клавиш по умолчанию
      6. Настройка комбинаций клавиш
      7. Общие сведения о монтажных областях
      8. Управление монтажными областями
      9. Настройка рабочей среды
      10. Панель свойств
      11. Установка параметров
      12. Рабочая среда «Сенсорное управление»
      13. Поддержка Microsoft Surface Dial в Illustrator
      14. Отмена изменений и управление историей дизайна
      15. Поворот вида
      16. Линейки, сетки и направляющие
      17. Специальные возможности в Illustrator
      18. Безопасный режим
      19. Просмотр графических объектов
      20. Работа в Illustrator с использованием Touch Bar
      21. Файлы и шаблоны
    3. Инструменты в Illustrator
      1. Краткий обзор инструментов
      2. Выбор инструментов
        1. Выделение
        2. Частичное выделение
        3. Групповое выделение
        4. Волшебная палочка
        5. Лассо
        6. Монтажная область
      3. Инструменты для навигации
        1. Рука
        2. Поворот вида
        3. Масштаб
      4. Инструменты рисования
        1. Градиент
        2. Сетка
        3. Создание фигур
      5. Текстовые инструменты
        1. Текст
        2. Текст по контуру
        3. Текст по вертикали
      6. Инструменты рисования
        1. Перо
        2. Добавление опорной точки
        3. Удаление опорной точки
        4. Опорная точка
        5. Кривизна
        6. Отрезок линии
        7. Прямоугольник
        8. Прямоугольник со скругленными углами
        9. Эллипс
        10. Многоугольник
        11. Звезда
        12. Кисть
        13. Кисть-клякса
        14. Карандаш
        15. Формирователь
        16. Фрагмент
      7. Инструменты модификации
        1. Поворот
        2. Отражение
        3. Масштаб
        4. Искривление
        5. Ширина
        6. Свободное трансформирование
        7. Пипетка
        8. Смешивание
        9. Ластик
        10. Ножницы
        11. Размер
    4. Генеративный ИИ (недоступно на территории континентального Китая)
      1. Создание векторной графики с помощью текстового запроса
      2. Перекрашивание векторной графики с помощью текстового запроса
    5. Быстрые действия
      1. Ретротекст
      2. Светящийся неоновый текст
      3. Старомодный текст
      4. Перекрашивание
      5. Преобразование эскиза в векторный формат
  3. Веб-версия Illustrator (Beta)
    1. Обзор веб-версии Illustrator (Beta)
    2. Часто задаваемые вопросы о веб-версии Illustrator (Beta)
    3. Часто задаваемые вопросы по устранению неполадок
    4. Комбинации клавиш для веб-версии Illustrator (Beta)
    5. Создание и объединение фигур в веб-версии
    6. Добавление и редактирование текста в веб-версии
    7. Применение цветов и градиентов в веб-версии
    8. Рисование и редактирование контуров в веб-версии
    9. Работа с облачными документами в веб-версии
    10. Приглашение соавторов для редактирования в веб-версии
  4. Illustrator на iPad
    1. Представляем Illustrator на iPad
      1. Обзор по Illustrator на iPad
      2. Ответы на часто задаваемые вопросы по Illustrator на iPad
      3. Системные требования | Illustrator на iPad
      4. Что можно и нельзя делать в Illustrator на iPad
    2. Рабочая среда
      1. Рабочая среда Illustrator на iPad
      2. Сенсорные ярлыки и жесты
      3. Комбинации клавиш для Illustrator на iPad
      4. Управление настройками приложения
    3. Документы
      1. Работа с документами в Illustrator на iPad
      2. Импорт документов Photoshop и Fresco
    4. Выбор и упорядочение объектов
      1. Создание повторяющихся объектов
      2. Объекты с переходами
    5. Рисование
      1. Создание и изменение контуров
      2. Рисование и редактирование фигур
    6. Текст
      1. Работа с текстом и шрифтами
      2. Создание текстовых надписей по контуру
      3. Добавление собственных шрифтов
    7. Работа с изображениями
      1. Векторизация растровых изображений
    8. Цвет
      1. Применение цветов и градиентов
  5. Облачные документы
    1. Основы работы
      1. Работа с облачными документами Illustrator
      2. Общий доступ к облачным документам Illustrator и совместная работа над ними
      3. Публикация документов для проверки
      4. Обновление облачного хранилища для Adobe Illustrator
      5. Облачные документы в Illustrator | Часто задаваемые вопросы
    2. Устранение неполадок
      1. Устранение неполадок с созданием или сохранением облачных документов в Illustrator
      2. Устранение неполадок с облачными документами в Illustrator
  6. Добавление и редактирование содержимого
    1. Рисование и размеры
      1. Основы рисования
      2. Редактирование контуров
      3. Рисование графического объекта с точностью на уровне пикселов
      4. Рисование с помощью инструментов «Перо», «Кривизна» и «Карандаш»
      5. Рисование простых линий и фигур
      6. Рисование прямоугольных и полярных сеток
      7. Создание и редактирование бликов
      8. Трассировка изображения
      9. Упрощение контура
      10. Инструменты для работы с символами и наборы символов
      11. Корректировка сегментов контура
      12. Создание цветка в пять простых шагов
      13. Создание и редактирование сетки перспективы
      14. Рисование и изменение объектов на сетке перспективы
      15. Использование объектов в качестве символов для повторного применения
      16. Рисование контуров, выровненных по пикселам, при создании проектов для Интернета
      17. Определение и построение размеров
    2. 3D-объекты и материалы
      1. Подробнее о 3D-эффектах в Illustrator
      2. Создание трехмерной графики
      3. Проецирование рисунка на трехмерные объекты
      4. Создание трехмерного текста
      5. Создание трехмерных объектов
    3. Цвет
      1. О цвете
      2. Выбор цветов
      3. Использование и создание цветовых образцов
      4. Коррекция цвета
      5. Панель «Темы Adobe Color»
      6. Цветовые группы (гармонии)
      7. Панель «Темы Color»
      8. Перекрашивание графического объекта
    4. Раскрашивание
      1. О раскрашивании
      2. Раскрашивание с помощью заливок и обводок
      3. Группы с быстрой заливкой
      4. Градиенты
      5. Кисти
      6. Прозрачность и режимы наложения
      7. Применение обводок к объектам
      8. Создание и редактирование узоров
      9. Сетки
      10. Узоры
    5. Выбор и упорядочение объектов
      1. Выделение объектов
      2. Слои
      3. Группировка и разбор объектов
      4. Перемещение, выравнивание и распределение объектов
      5. Размещение объектов    
      6. Блокировка, скрытие и удаление объектов
      7. Копирование и дублирование объектов
      8. Поворот и отражение объектов
      9. Переплетение объектов
      10. Создание реалистичных макетов графики
    6. Перерисовка объектов
      1. Кадрирование изображений
      2. Трансформирование объектов
      3. Объединение объектов
      4. Вырезание, разделение и обрезка объектов
      5. Марионеточная деформация
      6. Масштабирование, наклон и искажение объектов
      7. Объекты с переходами
      8. Перерисовка с помощью оболочек
      9. Перерисовка объектов с эффектами
      10. Создание фигур с помощью инструментов «Мастер фигур» и «Создание фигур»
      11. Работа с динамическими углами
      12. Улучшенные процессы перерисовки с поддержкой сенсорного ввода
      13. Редактирование обтравочных масок
      14. Динамические фигуры
      15. Создание фигур с помощью инструмента «Создание фигур»
      16. Глобальное изменение
    7. Текст
      1. Дополнение текстовых и рабочих объектов типами объектов
      2. Создание маркированного и нумерованного списков
      3. Управление текстовой областью
      4. Шрифты и оформление
      5. Преобразование текста в изображениях в редактируемый текст
      6. Применение базового форматирования к тексту
      7. Применение расширенного форматирования к тексту
      8. Импорт и экспорт текста
      9. Форматирование абзацев
      10. Специальные символы
      11. Создание текста по контуру
      12. Стили символов и абзацев
      13. Табуляция
      14. Поиск отсутствующих шрифтов (технологический процесс Typekit)
      15. Шрифт для арабского языка и иврита
      16. Шрифты | Часто задаваемые вопросы и советы по устранению проблем
      17. Создание эффекта 3D-текста
      18. Творческий подход к оформлению
      19. Масштабирование и поворот текста
      20. Интерлиньяж и межбуквенные интервалы
      21. Расстановка переносов и переходы на новую строку
      22. Проверка орфографии и языковые словари
      23. Форматирование азиатских символов
      24. Компоновщики для азиатской письменности
      25. Создание текстовых проектов с переходами между объектами
      26. Создание текстового плаката с помощью трассировки изображения
    8. Создание специальных эффектов
      1. Работа с эффектами
      2. Стили графики
      3. Атрибуты оформления
      4. Создание эскизов и мозаики
      5. Тени, свечения и растушевка
      6. Обзор эффектов
    9. Веб-графика
      1. Лучшие методы создания веб-графики
      2. Диаграммы
      3. SVG
      4. Фрагменты и карты изображений
  7. Импорт, экспорт и сохранение
    1. Импорт
      1. Помещение нескольких файлов в документ
      2. Управление связанными и встроенными файлами
      3. Сведения о связях
      4. Извлечение изображений
      5. Импорт графического объекта из Photoshop
      6. Импорт растровых изображений
      7. Импорт файлов Adobe PDF
      8. Импорт файлов EPS, DCS и AutoCAD
    2. Библиотеки Creative Cloud Libraries в Illustrator 
      1. Библиотеки Creative Cloud Libraries в Illustrator
    3. Диалоговое окно «Сохранить»
      1. Сохранение иллюстраций
    4. Экспорт
      1. Использование графического объекта Illustrator в Photoshop
      2. Экспорт иллюстрации
      3. Сбор ресурсов и их массовый экспорт
      4. Упаковка файлов
      5. Создание файлов Adobe PDF
      6. Извлечение CSS | Illustrator CC
      7. Параметры Adobe PDF
      8. Палитра «Информация о документе»
  8. Печать
    1. Подготовка к печати
      1. Настройка документов для печати
      2. Изменение размера и ориентации страницы
      3. Задание меток обреза для обрезки и выравнивания
      4. Начало работы с большим холстом
    2. Печать
      1. Наложение
      2. Печать с управлением цветами
      3. Печать PostScript
      4. Стили печати
      5. Метки и выпуск за обрез
      6. Печать и сохранение прозрачных графических объектов
      7. Треппинг
      8. Печать цветоделенных форм
      9. Печать градиентов, сеток и наложения цветов
      10. Наложение белого
  9. Автоматизация задач
    1. Объединение данных с помощью панели «Переменные»
    2. Автоматизация с использованием сценариев
    3. Автоматизация с использованием операций
  10. Устранение неполадок 
    1. Известные проблемы
    2. Сбои
    3. Восстановление файлов после сбоя
    4. Проблемы с файлами
    5. Поддерживаемые форматы файлов
    6. Проблемы с драйвером ГП
    7. Проблемы устройств Wacom
    8. Проблемы с файлами DLL
    9. Проблемы с памятью
    10. Проблемы с файлом настроек
    11. Проблемы со шрифтами
    12. Проблемы с принтером
    13. Как поделиться отчетом о сбое с Adobe
    14. Повышение производительности Illustrator

Объедините документ Illustrator с файлом источника данных (файл CSV или XML) с помощью панели Переменные, чтобы создать несколько вариантов графического объекта. Вы можете изменять имена участников мероприятия на бейджах или менять изображения на веб-баннерах и открытках без необходимости переделывать всю работу целиком. Разработайте один проект и затем мгновенно создавайте производные от него, импортируя имена или изображения из файла источника данных.

Создание вариантов шаблонов для различных проектов (печатные постеры, веб-баннеры, бейджи) с помощью панели «Переменные»

Прежде чем продолжить

Все, что необходимо для объединения данных, — это файл источника данных и целевой документ. 

  • Файл источника данных содержит сведения, которые различаются в разных экземплярах целевого документа, например имена, фотографии и адреса получателей в стандартном письме. Файл источника данных может быть файлом данных с разделителями в виде запятой (comma-delimited file, .csv) или файлом с расширяемым языком разметки (extensible markup language, .xml). 
  • Целевой документ — это документ Illustrator, в котором содержится графический объект для использования в качестве шаблона. Этот документ содержит местозаполнитель поля данных, а также элементы, которые при любом изменении объединенного документа остаются без изменений.

Доступ к функции объединения данных

К функции объединения данных можно получить доступ с панели «Переменные» в Illustrator (Окно > Переменные). На панели перечислены тип и название каждой переменной в документе. Если переменная привязана к объекту, то в столбце «Объекты» отображается название связанного объекта в том виде, в каком оно появляется на палитре «Слои». Можно сортировать строки, нажимая элементы в строке заголовка: по названиям переменных, по названиям объектов или по типам переменных.

Палитра «Переменные»

A. Набор данных B. Меню палитры C. Переключение между наборами данных D. Название связанного объекта E. Название переменной F. Тип переменной G. Блокировка переменных H. Кнопка «Сделать объект динамическим» I. Кнопка «Сделать видимость динамической» J. Отмена привязки переменных K. Создание переменных L. Удаление переменных 

Краткая инструкция по объединению данных

  1. Создайте документ Illustrator для использования в качестве шаблона.

  2. Подготовьте файл источника данных в формате CSV или XML. Дополнительные сведения представлены в разделе Подготовка файла источника данных.

  3. Импортируйте файл источника данных в Illustrator с помощью панели «Переменные». Дополнительные сведения представлены в разделе Импорт файла источника данных.

  4. Привяжите переменную к объекту в шаблоне. Дополнительные сведения представлены в разделе Привязка переменных к объектам.

  5. Перед экспортом всех файлов предварительно просмотрите документ с каждым набором данных. Дополнительные сведения представлены в разделе Предварительный просмотр документа с каждым набором данных.

  6. Экспортируйте пакет файлов из данных с помощью панели «Операции» в Illustrator. Дополнительные сведения представлены в разделе Экспорт файлов с помощью панели «Операции».

Подготовка файла источника данных

Файлы источника данных должны являться файлами данных с разделителями в виде запятой (comma-delimited file, .csv) или файлами с расширяемым языком разметки (extensible markup language, .xml).

Подготовка файлов источника данных в формате CSV

В файле с разделителями в виде запятой (.csv) записи разделяются абзацами, а поля — запятыми или символами табуляции. Файл источника данных может также содержать текст или пути к изображениям на диске. Перед импортом файла CSV выполните представленные ниже действия. Это позволит Illustrator идентифицировать тип переменной.

  1. Откройте электронную таблицу.

  2. В первой строке таблицы укажите название поля данных. Затем выполните следующие действия:

    • В начале названия поля введите символ «@» для вставки текста или путей, указывающих на файлы изображений. Символ «@» необходим только в первой строке; последующие строки должны содержать пути к изображению.
    • Аналогичным образом, в начале названия поля введите символ «%» для диаграмм и «#» для видимости.
    • Чтобы определить видимость объекта, укажите значение «истина» или «ложь» для каждого поля данных.
    Примечание.
    • Названия полей данных в электронной таблице не должны содержать пробелы. Например, можно указать поле данных Название_компании, но не Название компании
    • Пути, указывающие на файлы изображений и файлы диаграмм, не должны содержать пробелы. Например, путь к файлу изображения должен быть указан как C:\Фотографии\БиллТакер, а не C:\Фотографии\Билл Такер.
    • Все файлы диаграмм, связанные в вашем файле источника данных, должны быть сохранены как файлы с разделителями в виде запятой (comma-delimited file, .csv).
    • При появлении сообщения об ошибке во время ввода символа «@» в начале поля введите апостроф (') перед символом «@» (например, '@Фотографии) для разрешения такой записи. В некоторых приложениях (например, в Microsoft Excel) символ «@» зарезервирован для обозначения функций.

    (Windows) Пример ссылок на изображения и диаграммы в файле источника данных

    Название

    Возраст

    @Фотографии

    %Диаграммы

    #Видимость

    Билл Такер

    36

    c:\Фотографии\БиллТакер.jpg

    C:\Фотографии\БиллТакер.csv

    Истина

    Дат Нгуен

    53

    C:\Документы\дат.jpg

    C:\Документы\дат.csv

    Истина

    Мария Руис

    26

    C:\Фотографии\Руис.jpg

    C:\Фотографии\Руис.csv

    Ложь

    (macOS) Пример ссылок на изображения и диаграммы в файле источника данных

    Название

    Возраст

    @Фотографии

    %Диаграммы

    #Видимость

    Билл Такер

    36

    /Пользователи/фотографии/БиллТакер.jpg

    /Пользователи/фотографии/БиллТакер.csv

    Истина

    Дат Нгуен

    53

    /Пользователи/семья/фотографии/дат.jpg

    /Пользователи/семья/фотографии/дат.csv

    Истина

    Мария Руис

    26

    /Пользователи/alpha/фотографии/Руис.jpg

    /Пользователи/alpha/фотографии/Руис.csv

    Ложь

  3. Введите данные в электронную таблицу.

  4. Выполните одно из действий, описанных ниже:

    • Сохраните электронные таблицы, созданные с помощью последней версии Microsoft Excel (выпуск 2016 года), в следующих файловых форматах:
      • CSV (разделители - запятые) (*.csv)
      • CSV (MS-DOS) (*.csv)
    • Сохраните электронные таблицы, созданные с помощью Apple Numbers, в формате CSV с кодировкой Юникод (UTF-8).
    Примечание.

    В настоящее время файлы CSV, экспортированные в указанные выше форматы, поддерживаются в Illustrator. Другие файловые форматы CSV (например, Macintosh Comma Separated (.csv)) не поддерживаются процессом объединения данных.

Подготовка файла XML

  1. Определите переменную в документе. Дополнительные сведения представлены в разделе Привязка переменных к объектам.

  2. Нажмите кнопку Захватить набор данных  в палитре Переменные.

  3. После создания необходимого количества наборов данных выберите Сохранить библиотеку переменных в меню панели Переменные, чтобы сохранить наборы данных как файл XML. Укажите название и расположение файла и нажмите кнопку Сохранить.

    Экспорт созданных в Illustrator переменных в формат XML

  4. Теперь отредактируйте файл XML в приложении для редактирования текста (например, Notepad++ (Windows) или TextWrangler (macOS)), чтобы добавить наборы данных в файл.

    Пример: редактирование файла XML с помощью приложения для редактирования текста

    A. Замена пути к изображению B. Замена строки текста  

  5. Выберите Загрузить библиотеку переменных в меню панели Переменные, чтобы импортировать файл XML в Illustrator. Выберите файл XML и нажмите Открыть.

    Импорт переменных в Illustrator

Импорт файла источника данных

Чтобы привязать переменные к нужным данным, импортируйте источник данных на панели «Переменные». Для одного документа может быть выбран только один источник данных.

  1. Выберите Окно > Переменные.

  2. В палитре Переменные нажмите кнопку Импорт.

  3. В диалоговом окне Загрузить библиотеку переменных выберите файл источника данных в формате CSV или XML, затем нажмите кнопку Открыть.

  4. Позже вы можете изменить, переименовать или удалить набор данных. Для этого выберите нужный набор данных в раскрывающемся меню Набор данных и измените его параметры.

    • Выберите набор данных в списке Набор данных в палитре Переменные для переключения между наборами данных. Вы также можете нажать кнопку Предыдущий набор данных  или Следующий набор данных.
    • Чтобы применить данные монтажной области к текущему набору данных, выберите Обновить набор данных в меню панели Переменные.
    • Чтобы переименовать набор данных, отредактируйте текст непосредственно в текстовом поле Набор данных. Также можно дважды щелкнуть слова Набор данных (слева от текстового поля Набор данных), ввести новое название и нажать кнопку ОК.
    • Чтобы удалить набор данных, нажмите значок Удалить. Также можно выбрать Удалить набор данных в меню панели Переменные.
    Примечание.

    Файлы CSV (UTF-8 с разделителями-запятыми), содержащие двухбайтовые символы и созданные с помощью Excel, нельзя импортировать с помощью панели «Переменные». Если открыть тот же файл в текстовом формате, а затем сохранить его в формате CSV с кодировкой UTF-8, файл будет импортирован правильно.

Привязка переменных к объектам

Переменные используются для определения изменяемых элементов в шаблоне. Можно определить переменные четырех типов: «Видимость», «Текстовая строка», «Связанный файл» и «Данные диаграмм». Тип переменной указывает, какие атрибуты объекта являются изменяемыми (динамическими). На панели перечислены тип и название каждой переменной в документе. Если переменная привязана к объекту, то в столбце «Объекты» отображается название связанного объекта в том виде, в каком оно появляется на палитре «Слои».

Тип переменной

Значок, указывающий на тип переменной

Определение

Переменные «Видимость»

Отображение и скрытие иллюстрации.

Переменные «Текстовая строка»

Замена строки текста.

Переменные «Связанный файл»

Замена объекта в монтажной области объектом из другого файла.

Переменные «Данные диаграмм»

Замена значений на диаграмме.

Переменная «Без типа» (несвязанная)

Несвязанная с объектом переменная.

Чтобы определить переменные в Illustrator, выполните следующие действия:

  1. Выделите объект.

  2. На панели Переменные (Окно > Переменные) выберите переменную, для которой требуется создать привязку.

  3.  Нажмите кнопку Сделать объект динамическим, чтобы связать объект с переменной.

Чтобы создать переменную, не привязывая ее к объекту, выполните следующие действия:

  1. Нажмите кнопку Создать переменную  в палитре Переменные.

  2. Чтобы связать объект с этой переменной, выберите объект и переменную и нажмите кнопку Сделать видимость динамической  или Сделать объект динамическим .

Примечание.

Названия переменных не поддерживают суррогатные пары и четырехбайтовые символы. Если вы используете эти символы в названии переменной, будет отображено сообщение об ошибке.

Работа с переменными

На палитре «Переменные» можно изменить название или тип переменной, отменить ее привязку и заблокировать переменную.

Отмена привязки приводит к разрыву связи между переменной и ее объектом. Блокирование переменных исключает возможность создавать и удалять переменные, а также изменять их параметры. Однако можно привязать объекты к заблокированным переменным и отменить их привязку.

Изменение названия и типа переменной

  1. Выделите переменную на палитре Переменные и выберите в меню палитры Параметры переменной.

Отмена привязки переменной

  1. Нажмите кнопку Отменить привязку переменной  в палитре Переменные.

Блокирование или разблокирование всех переменных в документе

  1. Нажмите кнопку Заблокировать переменные  или Разблокировать переменные в палитре Переменные.

Удаление переменных

Удалите переменную, чтобы удалить ее с палитры Переменные. Если происходит удаление переменной, которая привязана к объекту, то объект становится статическим (при условии, что он не привязан также к переменной другого типа).

  1. Выделите переменную, которую необходимо удалить.

  2. Выберите любой из следующих параметров:

    • Нажмите кнопку Удалить переменную  в палитре Переменные.

    • Чтобы удалить переменную без необходимости подтверждения, перетащите ее на кнопку Удалить переменную .

Редактирование динамических объектов

Изменение данных, относящихся к переменной, происходит в результате редактирования объекта, к которому она привязана. Например, во время работы с переменной Видимость состояние видимости объекта изменяется на палитре Слои. Редактирование динамических объектов позволяет создавать многочисленные наборы данных для использования в шаблоне.

  1. Выберите динамический объект в монтажной области или выполните одно из действий, описанных ниже, чтобы автоматически выбрать динамический объект:

    • В палитре Переменные щелкните переменную, удерживая нажатой клавишу Alt (в Windows) или Option (в macOS).

    • Выделите переменную на палитре Переменные и в меню палитры Переменные выберите Выбрать объект-привязку.

    • Выберите Все связанные объекты в меню палитры Переменные, чтобы выбрать все динамические объекты.

  2. Отредактируйте данные, относящиеся к объекту, следующим образом:

    • Отредактируйте текстовую строку в монтажной области.

    • Замените изображение с помощью палитры Ссылки или команды Файл > Поместить для связанных файлов.

    • Отредактируйте данные для диаграмм в диалоговом окне Данные диаграмм.

    • Для всех объектов с динамически определяемой видимостью измените состояние видимости для объекта на палитре Слои.

Идентификация динамических объектов с использованием идентификаторов XML

На палитре «Переменные» отображаются названия динамических объектов по мере их появления на палитре «Слои». Если сохранить шаблон в формате SVG для использования с другими продуктами Adobe, названия объектов должны соответствовать соглашениям об именовании XML. Например, названия XML должны начинаться с буквы, символа подчеркивания или двоеточия и не могут содержать пробелы.

Программа Illustrator автоматически присваивает допустимый идентификатор XML каждому динамическому объекту, создаваемому пользователем. Для просмотра, редактирования и экспорта названий объектов с использованием идентификаторов XML выберите «Редактирование» > «Установки» > «Единицы измерения» (Windows) или «Illustrator» > «Установки» > «Единицы измерения» (Mac OS) и выберите параметр «Цифровое удостоверение XML».

Просмотр документа с каждым набором данных

Перед тем как экспортировать все файлы, можно просмотреть документы, чтобы увидеть, как они будут выглядеть в готовом виде. С помощью кнопок со стрелками рядом с полем «Набор данных» на панели «Переменные» можно выбрать и предварительно просмотреть нужный набор данных в документе.

Экспорт файлов с помощью панели «Операции»

После определения переменных и одного или нескольких наборов данных можно в пакетном режиме вывести иллюстрации, применив значения набора данных. Выполните следующие действия:

  1. С помощью панели «Операции» (Окно > Операции) можно записать операцию для сохранения документа в нужном формате. Дополнительная информация представлена в разделе Автоматизация с использованием операций.

  2. Выберите Пакетная обработка в меню панели «Операции», затем выберите операцию, созданную в предыдущем шаге.

  3. В поле «Источник» выберите Наборы данных, чтобы воспроизвести операцию для каждого набора данных в текущем файле.

  4. С помощью параметра Назначение укажите, что требуется сделать с обрабатываемыми файлами. Можно оставить файлы открытыми без сохранения изменений (значение «Нет»), сохранить и закрыть файл в его текущем расположении (значение «Сохранить и закрыть») или сохранить файлы в другом месте (значение «Папка»).

    В зависимости от значения параметра Назначение можно задавать дополнительные параметры для сохранения файлов. Дополнительные сведения представлены в разделе Выполнение операции для пакета файлов.

  5. Нажмите ОК.

Сохранение шаблона для объединения данных

При определении переменных в документе Illustrator создается шаблон для объединения данных. Можно сохранить этот шаблон в формате SVG для использования с другими продуктами Adobe, такими как Adobe® Graphics Server. Например, разработчик, работающий с сервером Adobe Graphics Server, может связать переменные из файла SVG прямо с базой данных или другим источником данных.

  1. Выберите Файл > Сохранить как, введите название файла, выберите SVG в качестве формата файла и нажмите кнопку Сохранить.

  2. Нажмите кнопку Больше параметров и выберите Включить данные Adobe Graphics Server. Этот параметр включает всю информацию, необходимую для подстановки переменных в файл SVG.

  3. Нажмите кнопку ОК.

Возникли проблемы при импорте файла CSV?

Если при передаче файла источника данных CSV отобразится сообщение об ошибке Входящая библиотека переменных недействительна, проверьте, что выполнены следующие условия:

  • Файл CSV не пуст.
  • Электронные таблицы, созданные с помощью последней версии Microsoft Excel, сохранены как CSV (файлы с разделителями в виде запятой) (*.csv) или CSV (MS-DOS) (*.csv) , а те, что созданы с помощью Apple Numbers, сохранены в формате CSV с кодировкой Юникод (UTF-8). Файлы источника данных, сохраненные в любом другом формате (например, Macintosh Comma Separated (*.csv)), не поддерживаются процессом объединения данных.
  • Для всех столбцов указаны названия полей данных. Например, Illustrator отображает сообщение об ошибке, когда столбец в файле источника данных содержит данные, а название поля данных не указано.
  • В файле источника данных нет пустого столбца между столбцами с данными. Например, Illustrator отображает сообщение о ошибке, когда столбцы B и D в файле источника данных содержат данные, а столбец C пуст.
Пример: ошибки при настройке файла источника CSV для объединения данных

A. В столбце нет названия поля данных B. Пустой столбец между заполненными столбцами 

  • Названия полей данных в электронной таблице не содержат пробелы.
  • Пути к файлам изображений или диаграмм в файле источника не содержат пробелы.
  • Файлы диаграмм, связанные в вашем файле источника данных, сохранены как файлы с разделителями в виде запятой (comma-delimited file, .csv).

связанные ресурсы

Обращайтесь к нам

Мы будем рады узнать ваше мнение. Поделитесь своими мыслями с сообществом Adobe Illustrator

 Adobe

Получайте помощь быстрее и проще

Новый пользователь?

Adobe MAX 2024

Adobe MAX
— творческая конференция

С 14 по 16 октября очно в Майами-Бич и онлайн

Adobe MAX

Творческая конференция

С 14 по 16 октября очно в Майами-Бич и онлайн

Adobe MAX 2024

Adobe MAX
— творческая конференция

С 14 по 16 октября очно в Майами-Бич и онлайн

Adobe MAX

Творческая конференция

С 14 по 16 октября очно в Майами-Бич и онлайн