Photoshop 工作區域
在相同畫布上適用於不同裝置的工作區域

如果您是網頁或 UX 設計人員,您會發現自己所設計的網站或應用程式有適用於多種裝置的傾向。工作區域可讓您在無限的畫布上配置不同裝置和螢幕的設計,進而協助您簡化設計程序。在建立工作區域時,您可以選擇多種不同的預設大小,或是定義您自己的自訂工作區域大小。

即使您的設計通常僅止於一個螢幕大小,工作區域仍有其用處。例如,在設計網站時,您可以使用工作區域,以並排方式和在環境中檢視不同頁面的設計。

註解:

工作區域已針對 RGB 色彩模式與進階 GPU 繪圖模式進行最佳化調整。

那麼,工作區域究竟是什麼?

您可以將工作區域視為特殊類型的圖層群組。工作區域會將任何內含成份的內容剪裁至其邊界。工作區域中的成份階層會連同圖層和圖層群組顯示在「圖層」面板中。工作區域可包含圖層和圖層群組,但不可包含其他工作區域。

在視覺上,工作區域可做為文件內的個別畫布。文件中任何未包含在工作區域內的圖層都會分類在「圖層」面板的最上方,且不會有任何工作區域加以剪裁。

工作區域偏好設定

若要自訂工作區域外觀,請選取「偏好設定 > 介面 > 外觀 > 工作區域」。您可選擇選取工作區域調合邊緣顏色,然後顯示或隱藏工作區域邊界。

Photoshop 工作區域偏好設定

建立工作區域文件

  1. 在 Photoshop 中,選取「檔案 > 新增」。
  2. 在「新增」對話框中,指定文件的名稱。例如 iPhone 網站
  3. 從「文件類型」蹦現式選單中,選取「工作區域」。
  4. 從超過 35 個「工作區域大小」預設集中選取其中之一。
Photoshop 工作區域大小
工作區域大小預設集的多種選擇

  1. 開始將您的設計成份增加至工作區域。您可以將智慧型物件、圖層、圖層群組等項目增加至工作區域。

將現有文件轉換成工作區域文件

如果您有標準 Photoshop 文件,您可以將其快速轉換成工作區域文件。

  1. 在文件中選取一或多個圖層群組或圖層。
  2. 在選取範圍上按一下滑鼠右鍵,然後選擇「來自圖層的工作區域」或「來自群組的工作區域」。

將工作區域增加至目前的文件

  1. 在「工具」面板中按一下  圖示,以選取「工作區域」工具。
  1. 在畫布上繪製工作區域。
  2. 視需要重新調整工作區域的大小。在工具選項列中,從「大小」蹦現式選單中選取預設大小。或者,您可以保留工作區域的自訂大小。
Photoshop 重新調整工作區域的大小
重新調整工作區域的大小

  1. 將工作區域重新命名為您想要的名稱。執行下列動作:
    1. 在選取工作區域後,選取「圖層 > 重新命名工作區域」。
    2. 輸入工作區域的新名稱,然後按 Return。
  2. 開始將您的設計成份增加至工作區域。您可以將智慧型物件、圖層、圖層群組等項目增加至工作區域。

迅速地將工作區域新增至文件

在文件中按一下目前顯示於工作區域旁的「+」圖示,您便可以將工作區域新增至文件。「+」圖示會顯示於畫布可容納額外工作區域的地方。若要同時複製工作區域及其內容,請按住 Option/Alt 鍵並按一下加號 (+) 圖示。

  1. 選取工作區域。
  2. 按一下工作區域旁的「+」圖示。Photoshop 會依照「+」圖示的方向,將工作區域新增至文件。
Photoshop 以加號圖示新增工作區域
以加號圖示新增工作區域

註解:

按住 Option/Alt 鍵並按一下加號 (+) 圖示,可同時複製目前選取的工作區域及其內容。已將新工作區域新增至您所按的「+」圖示方向。

使用工作區域

設定工作區域背景

在工作區域的「屬性」面板 (「視窗 > 屬性」) 中,設定「工作區域背景顏色」欄位的所需值。您也可以將工作區域背景設為透明。

設定工作區域背景

在工作區域之間移動成份

直接將成份從一個工作區域拖曳至版面上的另一個工作區域。當您在工作區域間移動成份時,Photoshop 會嘗試將其定位在相同位置上,該位置與位於工作區域左上角的尺標原點相對。

當您將成份增加/移動至工作區域時,新的成分會移至該工作區域的「圖層」面板 Z 軸順序頂端。

您也可以將未包含在任何工作區域中的圖層/成份與現有工作區域分組在一起。您只須將畫布上的成份拖曳到目標工作區域即可。或者,您可以在「圖層」面板中將其移至目標工作區域中。

複製圖層或圖層群組

在含有工作區域的文件中複製圖層或圖層群組時,您可以選擇要在其中放置拷貝圖層的工作區域。

複製圖層: 選擇要在其中放置拷貝圖層的工作區域

移動

在選取「工作區域」或「移動」工具後,按一下工作區域的標籤,以選取該工作區域。現在,將其移至畫布上的適當位置。

調整大小

在選取「工作區域」或「移動」工具後,按一下工作區域的標籤,以選取該工作區域。現在,從工具選項列中,選取工作區域新的預設「大小」。

如果您想要將工作區域重新調整為自訂大小,請直接使用控點重新調整其邊界。

格點

選取工作區域,然候選取「檢視 > 顯示 > 格點」,即可檢視工作區域中的格點。

參考線

選取工作區域,將參考線從尺標拖曳到畫布。參考線現在會隨著工作區域移動。您也可以複製帶有指定參考線的工作區域,將相同參考線指定至複製的工作區域。或者,您可以選取「檢視 > 新增參考線配置」,將參考線指定至想要的工作區域。若要設定參考線可見度選項,請選取「檢視 > 顯示」

Photoshop 新增參考線配置
(左) 新增參考線配置 | (右) 參考線可見度選項

查看工作區域屬性

選取工作區域,然後選取「視窗 > 屬性」,以快速查看其主要屬性。您也可以在「屬性」面板內重新調整工作區域的大小。

在選取工作區域時,工作區域屬性也會顯示在工具選項列中。

Photoshop 工作區域屬性面板
工作區域「屬性」面板

顯示工作區域名稱

若要顯示/隱藏工作區域名稱,請選取「檢視 > 顯示 > 工作區域名稱」。工作區域名稱長度會自動截斷成工作區域的寬度。

依工作區域篩選圖層

在「搜尋」快顯功能表的「圖層」面板中,選取「工作區域」。選擇工作區域或任何工作區域中的圖層。「圖層」面板檢視目前僅限選取的工作區域。若要返回完整的「圖層」面板檢視,請取消選取所有圖層,或選取工作區域外的項目。

防止自動嵌套進出工作區域

將插圖中的鎖定指定至工作區域,藉此禁止進出工作區域的自動嵌套行為,或指定至工作區域中的特定圖層,以禁止特定圖層的自動嵌套。若要回復一般自動嵌套行為,請移除所有工作區域或圖層的自動嵌套鎖定。

Photoshop 防止自動嵌套進或出工作區域

工作區域位置鎖定

選取工作區域並指定位置鎖定。工作區域現在固定在畫布上的位置,但您仍可新增元素、在內部移動元素,並如往常一樣移除元素。

Photoshop 鎖定位置

重新命名

在「圖層」面板中按兩下工作區域名稱,然後輸入新名稱。或者,您可以使用「圖層 > 重新命名工作區域」指令。

分解工作區域

您可以將工作區域快速分解成其組成成份。在選取工作區域後,選取「圖層 > 解散工作區域群組」。工作區域會進行分解,且其組成成份全都會在「圖層」面板中往上移動一個層級。如果分解或解散群組的是文件中的最後一個工作區域,該文件將會成為無工作區域的文件。

轉存工作區域

將工作區域轉存為影像資產

您可以直接從「圖層」面板,將工作區域轉存為 JPEG、GIF、PNG、PNG-8 或 SVG 影像資產。

如需詳細資訊,請參閱轉存工作區域和圖層

將工作區域轉存為 PDF

您可以將工作區域轉存為 PDF 文件。請依照下列步驟執行:

  1. 在 Photoshop 中,選取「檔案 > 轉存 > 工作區域轉存 PDF」。
  2. 在「工作區域轉存 PDF」對話框中,執行下列作業:
    • 選擇要儲存所產生 PDF 文件的目的地/位置。
    • 指定所產生 PDF 文件的檔案名稱字首。例如,Campaign_insurance
    • 指定僅轉存工作區域中的內容,或是轉存與工作區域重疊之區域中的內容。
    • 指定要轉存所有工作區域,或是僅轉存目前選取的工作區域。
    • 指定是否也要將工作區域背景與工作區域一同轉存。
    • 指定要在目前文件中,產生一份所有工作區域的 PDF,或是依每個工作區域各產生一份 PDF 文件。如果選擇產生多份 PDF 文件,則所有的文件皆會採用您稍早指定的檔案名稱字首。
    • 指定轉存 PDF 文件的編碼: ZIPJPEG。如果選擇 JPEG,也請指定「品質」設定 (0-12)。
    • 指定是否要在轉存的 PDF 文件中包含國際色彩協會 (ICC) 描述檔。ICC 描述檔包含描述色彩輸入或輸出裝置的資料。
    • 指定是否也要將工作區域名稱與轉存的工作區域一同轉存。選取這項設定時,您也可以指定自訂字體、字體大小、字體顏色和版面延伸色彩。
  3. 按一下「執行」。Photoshop 隨即產生 PDF 文件。

將工作區域轉存為檔案

您可以將工作區域轉存為個別檔案。請依照下列步驟執行:

  1. 在 Photoshop 中,選取「檔案 > 轉存 > 工作區域轉存檔案」
  2. 「工作區域轉存檔案」對話框中,執行下列動作:
    • 選擇要儲存所產生檔案的目的地。
    • 指定檔案名稱字首。
    • 指定僅要轉存工作區域內容,或是要包含重疊區域。
    • 指定要轉存所有工作區域,或是僅轉存目前選取的工作區域。
    • 指定是否也要將工作區域背景與工作區域一同轉存。
    • 選擇想要轉存的檔案類型。您可以選擇轉存為 BMP、JPEG、PDF、PSD、Targa、TIFF、PNG-8 或 PNG-24。
    • 指定已選取之檔案類型的轉存選項。
      • 指定是否也要將工作區域名稱與轉存的工作區域一同轉存。選取這項設定時,您也可以指定自訂字體、字體大小、字體顏色和版面延伸色彩。
  3. 按一下「執行」。Photoshop 隨即以選定格式將工作區域轉存為檔案。

裝置預視和 Preview CC 搭配應用程式

Photoshop 在目標裝置上預視設計

使用 Photoshop 中的「裝置預視」功能和 Preview CC 搭配應用程式,可讓您在目標 iOS 裝置上快速預視設計。Preview CC 可透過 USB 埠或 Wi-Fi 連接到 Photoshop,並演算您的設計的即時預視。您對設計所做的任何變更都會自動傳送至裝置,讓您可加以預視。

對於含有工作區域的文件,「裝置預視」會使工作區域的大小和位置符合連接之 iOS 裝置的大小,而嘗試為您顯示正確的工作區域。您也可以使用導覽列來預視裝置上的特定工作區域,或是依照工作區域在 Photoshop「圖層」面板中列出的順序來瀏覽工作區域。

如需「裝置預視」和 Preview CC 的詳細資訊,請參閱:

常見問題解答

我是否可在工作區域內增加另一個工作區域?

否。目前並不支援工作區域嵌套。

工作區域是一種圖層嗎?

您可以將工作區域視為特殊類型的圖層群組。工作區域會列示在 Photoshop「圖層」面板中,如同圖層和圖層群組一樣。

我是否可從標準 Photoshop 文件建立工作區域?

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策