Publiceren voor Adobe AIR voor desktop

  1. Adobe Animate-handboek
  2. Inleiding tot Animate
    1. Nieuw in Animate
    2. Visuele verklarende woordenlijst
    3. Systeemvereisten voor Animate
    4. Animate-sneltoetsen
    5. Werken met meerdere bestandstypen in Animate
  3. Animatie
    1. Grondbeginselen voor animaties in Animate
    2. Frames en hoofdframes gebruiken in Animate
    3. Frame-voor-frame-animaties in Animate
    4. Werken met klassieke tween-animaties in Animate
    5. De tool Penseel
    6. Hulplijnen voor bewegingen
    7. Bewegings-tween en ActionScript 3.0
    8. Informatie over animaties met bewegings-tween
    9. Animaties met bewegings-tweens
    10. Een animatie met bewegings-tween maken
    11. Eigenschapshoofdframes gebruiken
    12. Een positie animeren met een tween
    13. Bewegings-tweens bewerken in de Bewegingseditor
    14. Het bewegingspad van een tween-animatie bewerken
    15. Bewegings-tweens manipuleren
    16. Aangepaste versnellingen toevoegen
    17. Voorinstellingen voor beweging maken en toepassen
    18. Animatietween-reeksen instellen
    19. Werken met als XML-bestanden opgeslagen bewegings-tweens
    20. Bewegings-tweens en klassieke tweens
    21. Vormen tweenen
    22. De tool Bone-animatie gebruiken in Animate
    23. Werken met structuren voor personages in Animate
    24. Maskeerlagen gebruiken in Adobe Animate
    25. Werken met scènes in Animate
  4. Interactiviteit
    1. Knoppen maken met Animate
    2. Animate-projecten converteren naar andere documentindelingen
    3. HTML5 Canvas-documenten maken en publiceren in Animate
    4. Interactiviteit toevoegen met codefragmenten in Animate
    5. Aangepaste HTML5-componenten maken
    6. Componenten in HTML5 Canvas gebruiken
    7. Maken van aangepaste componenten: Voorbeelden
    8. Codefragmenten voor aangepaste componenten
    9. Tips en trucs: Adverteren met Animate
    10. Ontwerp en publicatie van virtual reality
  5. Werkruimte en workflow
    1. Penselen maken en beheren
    2. Google-lettertypen gebruiken in HTML5 Canvas-documenten
    3. Creative Cloud Libraries en Adobe Animate gebruiken
    4. Het werkgebied en het deelvenster Tools voor Animate gebruiken
    5. Workflow en werkruimte in Animate
    6. Weblettertypen gebruiken in HTML5 Canvas-documenten
    7. Tijdlijnen en ActionScript
    8. Werken met meerdere tijdlijnen
    9. Voorkeuren instellen
    10. Deelvensters voor ontwerp in Animate gebruiken
    11. Tijdlijnlagen maken met Animate
    12. Animaties exporteren voor mobiele apps en game-engines
    13. Objecten verplaatsen en kopiëren
    14. Sjablonen
    15. Zoeken en vervangen in Animate
    16. Ongedaan maken, Opnieuw en het deelvenster Historie
    17. Sneltoetsen
    18. De tijdlijn gebruiken in Animate
    19. HTML-extensies maken
    20. Optimalisatieopties voor afbeeldingen en geanimeerde GIF-bestanden
    21. Exportinstellingen voor afbeeldingen en GIF-bestanden
    22. Deelvenster Elementen in Animate
  6. Multimedia en video
    1. Grafische objecten transformeren en combineren in Animate
    2. Symboolinstanties maken in Animate en ermee werken
    3. Afbeeldingen overtrekken
    4. Geluid gebruiken in Adobe Animate
    5. SVG-bestanden exporteren
    6. Videobestanden maken voor gebruik in Animate
    7. Een video toevoegen in Animate
    8. Werken met videoactiepunten
    9. Objecten tekenen en maken met Animate
    10. Lijnen en vormen omvormen
    11. Streken, verlopen en vullingen met Animate CC
    12. Werken met Adobe Premiere Pro en After Effects
    13. Deelvensters voor kleuren in Animate CC
    14. Flash CS6-bestanden openen met Animate
    15. Werken met klassieke tekst in Animate
    16. Illustraties opnemen in Animate
    17. Geïmporteerde bitmaps in Animate
    18. 3D-afbeeldingen
    19. Werken met symbolen in Animate
    20. Lijnen en vormen tekenen met Adobe Animate
    21. Werken met bibliotheken in Animate
    22. Geluiden exporteren
    23. Objecten selecteren in Animate CC
    24. Werken met Illustrator AI-bestanden in Animate
    25. Patronen toepassen met het sproeipenseel
    26. Overvloeimodi toepassen
    27. Objecten rangschikken
    28. Taken automatiseren met het menu Opdrachten
    29. Meertalige tekst
    30. De camera gebruiken in Animate
    31. Animate gebruiken met Adobe Scout
    32. Werken met Fireworks-bestanden
    33. Grafische filters
    34. Geluid en ActionScript
    35. Tekenvoorkeuren
    36. Tekenen met de pen
  7. Platforms
    1. Animate-projecten converteren naar andere documentindelingen
    2. Ondersteuning voor aangepaste platforms
    3. HTML5 Canvas-documenten maken en publiceren in Animate
    4. Een WebGL-document maken en publiceren
    5. Toepassingen verpakken voor AIR voor iOS
    6. AIR voor Android-toepassingen publiceren
    7. Publiceren voor Adobe AIR voor desktop
    8. Publicatie-instellingen voor ActionScript
    9. Tips en trucs: ActionScript organiseren in een toepassing
    10. ActionScript gebruiken met Animate
    11. Tips en trucs: Richtlijnen voor toegankelijkheid
    12. Toegankelijkheid in de Animate-werkruimte
    13. Scripts schrijven en beheren
    14. Ondersteuning voor aangepaste platforms inschakelen
    15. Overzicht van ondersteuning voor aangepaste platforms
    16. Toegankelijke inhoud maken
    17. Werken met plug-in voor ondersteuning voor aangepaste platforms
    18. Foutopsporing in ActionScript 3.0
    19. Ondersteuning voor aangepaste platforms inschakelen
  8. Exporteren en publiceren
    1. Bestanden exporteren uit Animate CC
    2. OAM-publicatie
    3. SVG-bestanden exporteren
    4. Afbeeldingen en video's exporteren met Animate
    5. AS3-documenten publiceren
    6. Animaties exporteren voor mobiele apps en game-engines
    7. Geluiden exporteren
    8. QuickTime-videobestanden exporteren
    9. Afspelen van externe video met ActionScript beheren
    10. Tips en trucs: Tips voor het maken van inhoud voor mobiele apparaten
    11. Tips en trucs: Videoconventies
    12. Tips en trucs: Richtlijnen voor het ontwerpen van SWF-toepassingen
    13. Tips en trucs: Structuur geven aan FLA-bestanden
    14. Beste werkwijzen voor het optimaliseren van FLA-bestanden voor Animate
    15. Publicatie-instellingen voor ActionScript
    16. Publicatie-instellingen opgeven voor Animate
    17. Projectorbestanden exporteren
    18. Afbeeldingen en geanimeerde GIF-bestanden exporteren
    19. HTML-publicatiesjablonen
    20. Werken met Adobe Premiere Pro en After Effects
    21. Snel uw animaties delen en publiceren

Informatie over Adobe AIR

Adobe® AIR™ is een runtime voor verschillende besturingssystemen waarmee u uw bestaande webontwikkelingsvaardigheden (Adobe® Animate®, Adobe® Flex™, Adobe® Flash Builder™ HTML, JavaScript®, Ajax) kunt gebruiken om RIA's (Rich Internet Applications) op het bureaublad te ontwikkelen en te gebruiken. Met AIR kunt u werken in een bekende omgeving zodat u het gereedschap en de methodes kunt gebruiken waarmee u het liefst werkt, en met de ondersteuning van Animate, Flex, HTML, JavaScript en Ajax ontwikkelt u de kennis die het meest voldoet aan u wensen en behoeften.

Gebruikers werken op dezelfde manier met AIR-toepassingen als met eigen bureaubladtoepassingen. De runtime wordt eenmaal op de computer van de gebruiker geïnstalleerd, en daarna worden AIR-toepassingen geïnstalleerd en uitgevoerd net als elke andere desktoptoepassing. De runtime biedt een consistent platform voor meerdere besturingssystemen en een kader voor de implementatie van toepassingen waarbij de functionaliteit op verschillende desktops gegarandeerd constant is, zodat deze niet voor elke browser hoeft te worden getest. In plaats van te ontwikkelen voor een specifiek besturingssysteem, richt u zich op de runtime.

AIR zorgt voor een volledig andere manier waarop toepassingen kunnen worden gemaakt, geïmplementeerd en ervaren. U hebt meer creatieve controle en kunt uw Animate-, Flex-, HTML- en Ajax-toepassingen uitbreiden naar het bureaublad zonder dat u traditionele technologieën voor ontwikkeling voor bureaubladen hoeft aan te leren.

Zie AIR-systeemvereisten voor informatie over de hardware- en softwarevereisten voor AIR-toepassingen voor desktops en mobiele apparatuur.

Zie Adobe AIR-toepassingen bouwen voor de volledige informatie over het ontwikkelen van Adobe AIR™-toepassingen.

Een Adobe AIR-bestand maken

U kunt Adobe AIR Animate-documenten maken via het Animate-welkomstscherm of met de opdracht Bestand > Nieuwe opdracht. U kunt ook een ActionScript® 3.0 Animate-bestand maken en dit in een Adobe AIR-bestand omzetten via het dialoogvenster Publicatie-instellingen.

U kunt als volgt een Adobe AIR-bestand maken:

  • Start Animate. Het welkomstscherm verschijnt. Als u Animate al hebt gestart, sluit u alle geopende documenten om terug te keren naar het welkomstscherm. Selecteer Adobe AIR 2 (CS5) of AIR (CS5.5) in het welkomstscherm.

    Opmerking: Als u het Animate-welkomstscherm hebt uitgeschakeld, kunt u het scherm opnieuw weergeven door Bewerken > Voorkeuren te selecteren en Welkomstscherm te selecteren in het pop-upmenu Bij starten in de categorie Algemeen.

  • Kies Bestand > Nieuw > Geavanceerd in de tabbladen boven aan het scherm en selecteer Adobe AIR 2 (CS5) of AIR (CS5.5) en klik op OK.

Template_air
Sjabloon Air

  • Open een bestaand Animate-bestand en converteer het bestand naar een AIR-bestand door Adobe AIR te kiezen vanuit het Player-menu op het tabblad Animate van het dialoogvenster Publicatie-instellingen (Bestand > Publicatie-instellingen).
Opmerking:

Als u een Flash CS5 AIR-bestand opslaat met de Flash CS4-bestandsindeling, moet u de Player-versie handmatig instellen op AIR 1.5 in het dialoogvenster Publicatie-instellingen wanneer u het bestand wilt openen in Flash CS4 (alleen Flash CS5). Flash CS4 ondersteunt alleen publiceren naar AIR 1.5.

Een Adobe AIR-toepassing bekijken of publiceren

U kunt een voorvertoning van een AIR SWF-bestand bekijken zoals dit in een AIR-toepassingsvenster zal worden weergegeven. Voorvertoningen zijn nuttig als u wilt zien hoe de zichtbare aspecten van de toepassing eruit zien zonder dat u de toepassing hoeft te verpakken en te installeren.

  1. Controleer of u de doelinstelling op het tabblad Animate van het dialoogvenster Publicatie-instellingen hebt ingesteld op Adobe AIR.

  2. Selecteer Besturing > Film testen > Testen of druk op Ctrl+Enter.

Als u geen toepassingsinstellingen hebt opgegeven via het dialoogvenster AIR - Instellingen voor toepassing en installer, genereert Animate een standaardtoepassingsbeschrijvingsbestand (swfname-app.xml) in dezelfde map waarin het SWF-bestand is opgeslagen. Wanneer u wel toepassingsinstellingen hebt opgegeven via het dialoogvenster AIR - Instellingen voor toepassing en installer, zijn die instellingen in het toepassingsbeschrijvingsbestand opgenomen.

U kunt als volgt een AIR-bestand publiceren:

  • Klik op de knop Publiceren in het dialoogvenster Publicatie-instellingen.

  • Klik op de knop Publiceren in het dialoogvenster AIR - Instellingen voor toepassing en installer.

  • Selecteer Bestand > Publiceren.

  • Selecteer Bestand > Voorvertoning publiceren.

Als u een AIR-bestand publiceert, maakt Animate een SWF-bestand en een beschrijvingsbestand voor een XML-toepassing en verpakt kopieën van beide, samen met andere bestanden die u eventueel aan uw toepassing hebt toegevoegd, in een AIR-installerbestand (swfname.air).

Opmerking:

(Alleen Windows) Het publiceren van een AIR-toepassing mislukt als de bestandsnaam niet-Engelse tekens bevat.

AIR-toepassings- en -installerbestanden maken

Nadat u klaar bent met de ontwikkeling van uw toepassing, geeft u de instellingen op voor de beschrijvings- en installerbestanden voor AIR-toepassingen die nodig zijn om deze te kunnen gebruiken. Animate maakt de beschrijvings- en installerbestanden samen met het SWF-bestand wanneer u een AIR-bestand publiceert.

U geeft de instellingen voor deze bestanden op in het dialoogvenster AIR - Instellingen voor toepassing en installer. Zodra u een AIR-bestand hebt gemaakt, kan dit dialoogvenster worden geopend vanuit de Eigenschapcontrole voor documenten of de knop Instellingen in het tabblad Animate van het dialoogvenster Publicatie-instellingen.

Adobe AIR-toepassings- en -installerbestanden maken

  1. Open in Animate het FLA-bestand of de set bestanden waaruit uw Adobe AIR-toepassing bestaat.

  2. Sla het Adobe AIR FLA-bestand op voordat u het dialoogvenster AIR-instellingen opent.

  3. Selecteer Bestand > AIR 2-instellingen.

  4. Voer de vereiste gegevens in het dialoogvenster AIR-instellingen in en klik vervolgens op Publiceren.

    Wanneer u op de knop Publiceren klikt, worden de volgende bestanden ingepakt: het SWF-bestand, het toepassingsbeschrijvingsbestand, de toepassingspictogrambestanden en de bestanden die worden vermeld in het tekstvenster Opgenomen bestanden. Wanneer u nog geen digitaal certificaat hebt gemaakt, wordt het dialoogvenster Digitale handtekening in Animate weergegeven wanneer u op de knop Publiceren klikt.

Het dialoogvenster AIR - Instellingen voor toepassing en installer bevat 4 tabbladen: Algemeen, Handtekening, Pictogrammen en Geavanceerd. Zie de volgende secties voor meer informatie over deze instellingen.

Algemene instellingen

Het tabblad Algemeen van het dialoogvenster AIR - Instellingen voor toepassing en installer bevat de volgende opties:

Uitvoerbestand

De naam en locatie van het AIR-bestand die moeten worden gemaakt wanneer u de opdracht Publiceren gebruikt.

Uitvoeren als

Het type pakket dat wordt gemaakt.

  • AIR-pakket - er wordt een standaard AIR-installatiebestand gemaakt dat ervan uitgaat dat de AIR-runtime afzonderlijk kan worden gedownload tijdens de installatie of dat deze al is geïnstalleerd op het doelapparaat.
  • Mac-installatieprogramma - maakt een volledig Macintosh-installatiebestand.
  • Toepassing met ingesloten runtime - maakt een AIR-installatiebestand dat de AIR-runtime bevat, zodat de gebruiker verder niets hoeft te downloaden.

Windows Installer

Selecteer deze optie om een specifiek Windows-installatiebestand (.exe) te maken in plaats van een platformonafhankelijk AIR-installatiebestand (.air).

Naam

De naam van het hoofdbestand van de toepassing. Wordt standaard ingesteld op de naam van het FLA-bestand.

Versie

Optioneel. Geeft een versienummer voor de toepassing op. Heeft als standaardwaarde 1,0.

Toepassings-id

Identificeert uw toepassing met een unieke id. U kunt de standaard-id zo nodig wijzigen. Gebruik geen spaties of speciale tekens in de id. De enige geldige tekens zijn 0-9, a-z, A-Z, . (punt) en - (afbreekstreepje), van 1 tot 212 tekens lang. Wordt standaard ingesteld op com.adobe.example.toepassingsnaam.

Beschrijving

Optioneel. Hiermee kunt u een beschrijving van de toepassing invoeren, die in het installervenster wordt weergegeven wanneer de gebruiker de toepassing installeert. Is standaard leeg.

Copyright

Optioneel. Hier kunt u een auteursrechtbericht invoeren. Is standaard leeg.

Vensterstijl

Hiermee kunt u opgeven welke vensterstijl (of chroom) u voor de gebruikersinterface wilt gebruiken wanneer de gebruiker de toepassing op zijn of haar computer uitvoert. U kunt Standaardchroom opgeven (de standaardinstelling). Dit verwijst naar de standaard visuele vensterstijl die door het besturingssysteem wordt gebruikt. U kunt ook Aangepast chroom (ondoorzichtig) of Aangepast chroom (doorzichtig) opgeven. Selecteer Geen als u de toepassing zonder standaardchroom wilt weergeven. Standaardchroom omringt de toepassing met de standaardvensterbesturingselementen van het besturingssysteem. Met Aangepast chroom (ondoorzichtig) verwijdert u het standaardchroom en kunt u uw eigen chroom voor de toepassing maken. (U maakt het aangepaste chroom rechtstreeks in het FLA-bestand.) Aangepast chroom (doorzichtig) lijkt op Aangepast chroom (ondoorzichtig), maar hierbij worden mogelijkheden voor doorzichtigheid toegevoegd aan de randen van de pagina. Hierdoor kunt u toepassingsvensters maken die niet vierkant of rechthoekig van vorm zijn.

Rendermodus

Hier kunt u de methode opgeven waarmee de AIR-runtime grafische inhoud rendert. U kunt de volgende opties kiezen:

  • Automatisch - de snelste renderingmethode op het hostapparaat wordt automatisch gedetecteerd en gebruikt.
  • CPU - de CPU wordt gebruikt.
  • Direct - rendering wordt uitgevoerd aan de hand van Stage3D. Dit is de snelst mogelijke renderingmethode.

Zie Niet ondersteunde chipsets en stuurprogramma's voor Stage3D | Flash Player 11, AIR 3 voor een lijst met processors die geen ondersteuning bieden voor de modus Direct.


Profielen

De profielen die moeten worden opgenomen wanneer u het AIR-bestand maakt. Als u voor uw AIR-toepassing één specifiek profiel wilt gebruiken, heft u de selectie van de andere profielen op. 

Opgenomen bestanden

Geeft aan welke extra bestanden en mappen u in het toepassingspakket moet opnemen. Klik op de plus-knop (+) om bestanden toe te voegen; klik op de mapknop om mappen toe te voegen. Als u een bestand of map uit de lijst wilt verwijderen, selecteert u het bestand/de map en klikt u vervolgens op de min-knop (-).

Het toepassingsbeschrijvingsbestand en het hoofd-SWF-bestand worden automatisch aan de pakketlijst toegevoegd. De pakketlijst geeft deze bestanden zelfs weer wanneer u het Adobe AIR FLA-bestand nog niet hebt gepubliceerd. De pakketlijst geeft de bestanden en mappen in een platte structuur weer. Bestanden in een map worden niet vermeld en volledige padnamen voor bestanden worden weergegeven maar zo nodig ingekort.

Als u native AIR-extensiebestanden hebt toegevoegd aan het ActionScript-bibliotheekpad, worden deze bestanden ook in de lijst vermeld.

Pictogrambestanden worden niet in de lijst opgenomen. Wanneer de bestanden worden verpakt, kopieert Animate pictogrambestanden naar een tijdelijke map die relatief is ten opzichte van de locatie van het SWF-bestand. Animate verwijdert de map nadat het verpakken is voltooid.

Handtekeninginstellingen

Op het tabblad Handtekening van het dialoogvenster AIR - Instellingen voor toepassing en installer kunt u een certificaat voor het ondertekenen van code voor uw toepassing opgeven.

Zie De toepassing ondertekenen en Een AIR-bestand digitaal ondertekenen voor meer informatie.

Pictograminstellingen

Op het tabblad Pictogrammen van het dialoogvenster AIR - Instellingen voor toepassing en installer kunt u een pictogram voor de toepassing opgeven. Het pictogram wordt weergegeven nadat u de toepassing hebt geïnstalleerd en deze uitvoert in de Adobe AIR runtime. U kunt vier verschillende grootten voor het pictogram opgeven (128, 48, 32 en 16 pixels) om rekening te houden met de verschillende weergaven van het pictogram. Het pictogram kan bijvoorbeeld in miniatuur- en detailweergave of in weergaven naast elkaar worden getoond in de browser. Het kan ook als bureaubladpictogram en in de titelbalk van het AIR-toepassingsvenster of op andere locaties worden weergegeven.

Als u geen specifiek pictogrambestand opgeeft, wordt standaard een voorbeeld-AIR-toepassingspictogram gebruikt (alleen Flash CS5).

Als u een pictogram wilt opgeven, klikt u boven aan het tabblad Pictogrammen op een pictogram en gaat u naar het bestand dat u voor die grootte wilt gebruiken. De bestanden moeten de PNG-indeling (Portable Network Graphics) hebben.

Als u een afbeelding opgeeft, moet deze een exacte grootte hebben (128x128, 48x48, 32x32 of 16x16). Als u voor een bepaald pictogramformaat geen afbeelding opgeeft, schaalt Adobe AIR een van de opgegeven afbeeldingen om de ontbrekende pictogramafbeelding te maken.

Geavanceerde instellingen

Op het tabblad Geavanceerd kunt u extra instellingen voor het toepassingsbeschrijvingsbestand opgeven.

U kunt de gekoppelde bestandstypen opgeven die de AIR-toepassing moet kunnen verwerken. Als u bijvoorbeeld wilt dat uw toepassing de voornaamste toepassing is voor het afhandelen van HTML-bestanden, zou u dat moeten opgeven in het tekstveld Gekoppelde bestandstypen.

U kunt ook instellingen opgeven voor de volgende aspecten van de toepassing:

  • De grootte en plaatsing van het beginvenster

  • De map waarin de toepassing wordt geïnstalleerd

  • De map in menu Start waarin de toepassing moet worden geplaatst

Het dialoogvenster heeft de volgende opties:

Gekoppelde bestandstypen

Hiermee kunt u gekoppelde bestandstypes opgeven die de AIR-toepassing zal verwerken. Klik op de plus-knop (+) om een nieuw bestandstype aan het tekstvak toe te voegen. Wanneer u op de plus-knop klikt, wordt het dialoogvenster Instellingen voor bestandstypen weergegeven. Wanneer u op de min-knop (-) klikt, wordt een geselecteerd item uit het tekstvak verwijderd. Wanneer u op de potloodknop klikt, wordt het dialoogvenster Instellingen voor bestandstypen weergegeven. Daar kunt u een item bewerken dat u in het tekstvak hebt geselecteerd. De min-knop en de potloodknop zijn standaard gedimd. Wanneer u een item in het tekstvak selecteert, worden de min-knop en de potloodknop geactiveerd, zodat u het item kunt verwijderen of bewerken. De standaardwaarde in het tekstvak is Geen.

Begininstellingen voor venster

Hiermee kunt u instellingen voor grootte en plaatsing opgeven voor het eerste venster van de toepassing.

  • Breedte: geeft de beginbreedte van het venster op, in pixels. De waarde is standaard leeg.

  • Hoogte: geeft de beginhoogte van het venster op, in pixels. De waarde is standaard leeg.

  • X: geeft de horizontale beginpositie van het venster op, in pixels. De waarde is standaard leeg.

  • Y: geeft de verticale beginpositie van het venster op, in pixels. De waarde is standaard leeg.

  • Maximumbreedte en Maximumhoogte: geeft de maximumgrootte van het venster op, in pixels. Deze waarden zijn standaard leeg.

  • Minimumbreedte en Minimumhoogte: geeft de minimumgrootte van het venster op, in pixels. Deze waarden zijn standaard leeg.

  • Maximaliseerbaar: hiermee kunt u opgeven of de gebruiker het venster kan maximaliseren. Deze optie is standaard geselecteerd (of true).

  • Minimaliseerbaar: hiermee kunt u opgeven of de gebruiker het venster kan minimaliseren. Deze optie is standaard geselecteerd (of true).

  • Formaat aanpasbaar: hiermee kunt u opgeven of de gebruiker het formaat van het venster kan aanpassen. Wanneer deze optie niet is geselecteerd, zijn Maximumbreedte, Maximumhoogte, Minimumbreedte en Minimumhoogte gedimd. Deze optie is standaard geselecteerd (of true).

  • Zichtbaar: hiermee kunt u opgeven of het toepassingsvenster in eerste instantie zichtbaar is. Deze optie is standaard geselecteerd (of true).

Overige instellingen

Hiermee kunt u de volgende aanvullende informatie opgeven over de installatie.

  • Installatiemap: geeft de map op waarin de toepassing wordt geïnstalleerd.

  • Map in menu Start (alleen Windows): geeft de naam op van de map in menu Start voor de toepassing.

  • Aangepaste UI voor updates gebruiken geeft op wat er gebeurt wanneer een gebruiker een AIR-installerbestand opent voor een toepassing die al is geïnstalleerd. AIR geeft standaard een dialoogvenster weer waarmee de gebruiker de geïnstalleerde versie kan bijwerken naar de versie in het AIR-bestand. Als u niet wilt dat de gebruiker deze keuze heeft en de toepassing de updates volledig wilt laten bepalen, selecteert u deze optie. Wanneer u deze optie selecteert, wordt het standaardgedrag overschreven en kan de toepassing de eigen updates uitvoeren.

Taalinstellingen

In het deelvenster Talen kunt u de talen selecteren waaraan u uw toepassing wilt koppelen in de app-winkel of in Marketplace. Wanneer u een taal selecteert, kunnen gebruikers van besturingssystemen in de desbetreffende taal uw toepassing downloaden. Deze taalinstellingen verschaffen verder geen vertaling van de gebruikersinterface van uw toepassing.

Als er geen taal wordt geselecteerd, wordt de toepassing gepubliceerd met ondersteuning voor alle talen. Het is dan dus niet nodig elke taal te selecteren. De vermelde talen zijn de talen die worden ondersteund door Adobe AIR. Het is mogelijk dat Android ondersteuning biedt voor andere talen.

Instellingen voor bestandstypen

In Animate wordt het dialoogvenster Instellingen voor bestandstypen weergegeven wanneer u op de plusknop (+) of de potloodknop klikt in het gedeelte Gekoppelde bestandstypen van het tabblad Geavanceerde instellingen om gekoppelde bestandstypen voor de AIR-toepassing toe te voegen of te bewerken.

De enige twee verplichte velden in dit dialoogvenster zijn Naam en Extensie. Wanneer u op OK klikt en een van deze velden is leeg, wordt een foutdialoogvenster weergegeven in Animate.

U kunt de volgende instellingen voor een gekoppeld bestandstype opgeven:

Naam

De naam van het bestandstype (bijvoorbeeld Hypertext Markup Language, Tekstbestand of Voorbeeld).

Extensie

De extensie van de bestandsnaam (bijvoorbeeld html, txt of xmpl), maximaal 39 alfanumerieke tekens zonder accent (A-Za-z0-9) en zonder een voorlooppunt.

Beschrijving

Optioneel. Een beschrijving van het bestandstype (bijvoorbeeld Adobe Video File).

Inhoudstype

Optioneel. Geeft het MIME-type voor het bestand op.

Instellingen voor bestandstypepictogrammen

Optioneel. Hiermee kunt u een pictogram opgeven dat aan het bestandstype wordt gekoppeld. U kunt vier verschillende grootten voor het pictogram opgeven (128x128, 48x48, 32x32 en 16x16 pixels) om rekening te houden met de verschillende weergaven van het pictogram. Het pictogram kan bijvoorbeeld in miniatuur- en detailweergave of in weergaven naast elkaar worden getoond in de browser. Wanneer u een afbeelding opgeeft, moet deze de grootte hebben die u opgeeft. Wanneer u geen bestand opgeeft voor een bepaalde grootte, gebruikt AIR de afbeelding met de dichtstbijzijnde grootte om deze passend te schalen. Als u een pictogram wilt opgeven, klikt u op de map voor elke pictogramgrootte en selecteert u het pictogrambestand dat u wilt gebruiken. U kunt ook het pad en de bestandsnaam ervan invoeren in het tekstvak naast de vraag. Het pictogrambestand moet de PNG-indeling hebben. Nadat een nieuw bestandstype is gemaakt, wordt het weergegeven in de keuzelijst Bestandstype in het dialoogvenster Geavanceerde instellingen.

Fout bij maken toepassings- en installerbestanden

De toepassings- en installerbestanden kunnen in de volgende gevallen niet worden gemaakt:

  • De id-tekenreeks van de toepassing heeft een onjuiste lengte of bevat ongeldige tekens. De id-string van de toepassing kan 1 tot 212 tekens lang zijn en mag de volgende tekens bevatten: 0-9, a-z, A-Z, . (punt), - (afbreekstreepje).

  • Bestanden in de lijst Toegevoegde bestanden bestaan niet.

  • De grootten van aangepaste pictogrambestanden zijn onjuist.

  • De AIR-doelmap heeft geen schrijftoegang.

  • U hebt de toepassing niet ondertekend of u hebt niet aangegeven dat het een Adobe AIRI-toepassing betreft die later moet worden ondertekend.

De toepassing ondertekenen

Alle Adobe AIR-toepassingen moeten worden ondertekend om op een ander systeem te worden geïnstalleerd. Animate biedt echter de mogelijkheid ongetekende Adobe AIR-installerbestanden te maken, zodat de toepassing later kan worden ondertekend. Deze ongetekende Adobe AIR-installerbestanden worden een AIRI-pakket (AIR Intermediate) genoemd. Deze mogelijkheid voorziet in gevallen waarin het certificaat zich op een andere computer bevindt of wanneer het ondertekenen apart van de toepassingsontwikkeling wordt afgehandeld.

Een Adobe AIR-toepassing ondertekenen met een vooraf gekocht digitaal certificaat van een basiscertificeringsinstantie

  1. Kies Bestand > AIR 2-instellingen en klik op het tabblad Handtekening.

    Dit tabblad bevat twee keuzerondjes waarmee u ofwel uw Adobe AIR-toepassing kunt ondertekenen met een digitaal certificaat ofwel een AIRI-pakket kunt voorbereiden. Wanneer u de AIR-toepassing ondertekent, kunt u een digitaal certificaat gebruiken dat is verleend door een basiscertificeringsinstantie of een niet-geautoriseerd certificaat maken. Een niet-geautoriseerd certificaat is gemakkelijk te maken, maar is niet zo betrouwbaar als een certificaat dat is toegewezen door een basiscertificeringsinstantie.

  2. Selecteer een certificaatbestand in het pop-upmenu of klik op de knop Bladeren om een certificaatbestand te zoeken.

  3. Selecteer het certificaat.

  4. Voer een wachtwoord in.

  5. Klik op OK.

Zie Een AIR-bestand digitaal ondertekenen voor meer informatie over het digitaal ondertekenen van uw AIR-toepassing.

Een niet-geautoriseerd digitaal certificaat maken

  1. Klik op de knop Maken. Het dialoogvenster Niet-geautoriseerd digitaal certificaat wordt geopend.

  2. Voer de velden Naam van uitgever, Organisatie-eenheid, Naam van organisatie, Land, Wachtwoord en Wachtwoord bevestigen in. Bij Land kunt u een optie uit het menu kiezen of een landcode van twee letters invoeren die niet in het menu voorkomt. Voor een lijst met geldige landcodes raadpleegt u http://www.iso.org/iso/country_codes.

  3. Geeft het type certificaat op.

    De optie Type verwijst naar het beveiligingsniveau van het certificaat. 1024-RSA gebruikt een 1024-bits sleutel (minder veilig); 2048-RSA gebruikt een 2048-bits sleutel (veiliger). De standaardinstelling 2048-RSA. 

    Opmerking:

    In Animate worden 1024 RSA-certificaten alleen ondersteund tot versie 2017.2. Klik hier voor meer informatie over de oplossing. 

  4. Sla de informatie op in een certificaatbestand met Opslaan als, of door op de knop Bladeren te klikken en naar een maplocatie te bladeren.

  5. Klik op OK.

  6. Voer in het dialoogvenster Digitale handtekening het wachtwoord in dat u in de tweede stap van deze procedure hebt toegewezen en klik op OK.

Als u wilt dat Animate het wachtwoord onthoudt dat u voor deze sessie hebt gebruikt, klikt u op Wachtwoord onthouden gedurende deze sessie.

Wanneer de optie Tijdstempel niet is geselecteerd wanneer u op OK klikt, wordt een dialoogvenster weergegeven met de waarschuwing dat de toepassing niet kan worden geïnstalleerd wanneer het digitale certificaat verloopt. Wanneer u in het waarschuwingsvenster op Ja klikt, wordt tijdstempeling uitgeschakeld. Wanneer u op Nee klikt, wordt de optie Tijdstempel automatisch geselecteerd en wordt tijdstempeling ingeschakeld.

Zie Een AIR-bestand digitaal ondertekenen voor meer informatie over het maken van een niet-geautoriseerd digitaal certificaat.

U kunt ook een AIRI-toepassing (AIR Intermediate) maken zonder digitale handtekening. Een gebruiker kan de toepassing echter pas op een computer installeren nadat u een digitale handtekening hebt toegevoegd.

AIRI-pakket voorbereiden op ondertekening

  1. Selecteer op het tabblad Handtekening de optie AIRI-bestand (AIR Intermediate) voorbereiden op ondertekening en klik op OK.

    Wanneer u ervoor kiest een AIRI-pakket voor te bereiden op ondertekening, verandert de status van de digitale handtekening en verandert de knop Instellen in de knop Wijzigen.

Als u ervoor kiest de toepassing later te ondertekenen, moet u vanaf de opdrachtregel de AIR Developer Tool gebruiken, die bij Animate en de AIR SDK wordt geleverd. Zie Adobe AIR-toepassingen bouwen voor meer informatie.

URL van tijdstempelserver

Animate ondersteunt de nieuwste tijdstempelserver, alsook een optie om een URL toe te voegen voor een aangepaste tijdstempelserver. 

Een versie van de SDK van AIR toevoegen of verwijderen

U kunt nieuwe releases en aangepaste versies van de SDK van AIR toevoegen aan Animate. Als de nieuwe SDK is toegevoegd, wordt deze vermeld in de lijst met doelspelers in de publicatie-instellingen.

Een nieuwe versie van de SDK toevoegen:

  1. Download de map van de nieuwe SDK van AIR.
  2. In Animate kiest u Help > AIR SDK beheren.
  3. Klik op de plus-knop (+) in het dialoogvenster AIR SDK beheren en blader naar de nieuwe map voor SDK van AIR. Klik op OK.
  4. Klik op OK in het dialoogvenster AIR SDK beheren.

De nieuwe SDK wordt vermeld in de lijst met doelspelers in de publicatie-instellingen. De laagst mogelijke SDK-versie dient hoger te zijn dan de versie die bij Animate is geleverd.

Een versie van de SDK verwijderen:

  1. In Animate kiest u Help > AIR SDK beheren.
  2. Selecteer in het dialoogvenster AIR SDK beheren de SDK die u wilt verwijderen.
  3. Klik op de min-knop (-). Klik op OK.
Adobe-logo

Aanmelden bij je account