Werken met bibliotheken

De bibliotheek in een Animate-document slaat media-elementen op die u maakt in de Animate-ontwerpomgeving of die u importeert voor gebruik in het document. U kunt vectorafbeeldingen van tekst rechtstreeks in Animate importeren en u kunt vectorafbeeldingen, bitmaps, video en geluid importeren en symbolen maken. Een symbool is een afbeelding, knop, filmclip of tekst die u maakt en meerdere keren kunt hergebruiken. U kunt ActionScript ook gebruiken om inhoud van media dynamisch aan een document toe te voegen.

De bibliotheek kan ook componenten bevatten die u aan het document hebt toegevoegd. Componenten kunnen gecompileerde clips of op MovieClip gebaseerde componenten zijn.

Wanneer u in Animate werkt, kunt u de bibliotheek van een Animate-document openen om de items in de bibliotheek van dat bestand beschikbaar te maken voor het huidige document. U kunt in de bibliotheek zoeken naar symbolen op basis van hun namen of hun ActionScript-koppelingsnamen.

U kunt permanente bibliotheken in de Animate-toepassing maken die altijd beschikbaar zijn wanneer u Animate start. Animate bevat ook enkele voorbeeldbibliotheken met knoppen, afbeeldingen, filmclips en geluiden.

U kunt elementen van een bibliotheek als een SWF-bestand naar een URL exporteren om een gezamenlijke bibliotheek bij uitvoering te maken. Hiermee kunt u een koppeling maken naar de elementen van de bibliotheek uit Animate-documenten die symbolen importeert op basis van delen bij uitvoering.

Het deelvenster Bibliotheek (Venster > Bibliotheek) geeft een keuzelijst weer met de namen van alle items in de bibliotheek; hiermee kunt u de elementen bekijken en organiseren. Een pictogram naast de naam van een item in het deelvenster Bibliotheek geeft het bestandstype van het item weer.

Opmerking:

Het is niet meer mogelijk objecten van het werkgebied naar het deelvenster Bibliotheek te slepen en ze om te zetten in een symbool. Deze functie werkt niet meer in Animate CC.

Het slepen van objecten naar het werkgebied via twee niet-gekoppelde documenten is verouderd. Deze functie werkt niet meer in Animate CC.

Bibliotheek openen in een ander Animate-bestand

  1. Selecteer in het huidige document Bestand > Importeren > Externe bibliotheek openen.
  2. Navigeer naar het Animate-bestand waarvan u de bibliotheek wilt openen en klik op Openen.

    De geselecteerde bibliotheek van het bestand wordt in het huidige document geopend; de bestandsnaam wordt aan de bovenkant van het deelvenster Bibliotheek weergegeven. Sleep de items naar het huidige deelvenster Bibliotheek van het document of naar het werkgebied om items uit de geselecteerde bibliotheek van het bestand in het huidige document te gebruiken.

Grootte van deelvenster Bibliotheek wijzigen

  1. Ga als volgt te werk:
    • Sleep de rechterbenedenhoek van het deelvenster.

    • Klik op de knop Groot om het deelvenster Bibliotheek zodanig te vergroten dat alle kolommen worden weergegeven.

    • Klik op de knop Klein om de breedte van het deelvenster Bibliotheek te verkleinen.

Breedte van kolommen wijzigen

  1. Positioneer de aanwijzer tussen de kolomkoppen en sleep om de grootte te wijzigen.

Werken met mappen in het deelvenster Bibliotheek

U kunt items in het deelvenster Bibliotheek via de mappen ordenen. Wanneer u een nieuw symbool maakt, wordt het in de geselecteerde map opgeslagen. Als er geen map is geselecteerd, wordt het symbool in de map op het bovenste niveau van de bibliotheek opgeslagen.

Animate importeert geanimeerde GIF-bestanden bovendien in een gestructureerde manier door ze in een afzonderlijke map te plaatsen onder de hoofdmap van de bibliotheek en door alle gekoppelde bitmaps een naam te geven die is gebaseerd op hun volgorde. 

Nieuwe map maken

  1. Klik op het pictogram van de knop Nieuwe map onder aan het deelvenster Bibliotheek.

Map openen of sluiten

  1. Dubbelklik op de map of selecteer de map en selecteer vervolgens Map uitvouwen of Map samenvouwen met het optiemenu van het deelvenster Bibliotheek.

Alle mappen openen of sluiten

  1. Selecteer Alle mappen uitvouwen of Alle mappen samenvouwen met het optiemenu van het deelvenster Bibliotheek.

Item tussen mappen verplaatsen

  1. Sleep het item van een map naar een andere map.

    Als er al een item met dezelfde naam op de nieuwe locatie is, vraagt Animate u dit bestand te vervangen door het bestand dat u wilt verplaatsen.

Items sorteren in het deelvenster Bibliotheek

Kolommen in het deelvenster Bibliotheek bevatten de naam van een item, het type, het aantal keer dat het item in het bestand is gebruikt, de status van de koppeling en de id (als het item aan een gezamenlijke bibliotheek is gekoppeld of als het voor ActionScript is geëxporteerd) en de datum waarop het item voor het laatst is gewijzigd.

U kunt items in elke kolom in het deelvenster Bibliotheek alfanumeriek sorteren. Items worden binnen mappen gesorteerd.

De geanimeerde GIF-bestanden worden tijdens het importeren netjes ingedeeld in een afzonderlijke map onder de hoofdmap van de bibliotheek. Alle gekoppelde bitmaps krijgen een naam die is gebaseerd op hun volgorde. 

  1. Klik op de kolomkop om die kolom te sorteren. Klik op de driehoekknop rechts van de kolomkop om de sorteervolgorde om te draaien.

Conflicten tussen bibliotheekelementen

Wanneer u een bibliotheekelement importeert in of kopieert naar een document dat al een ander element met dezelfde naam bevat, kunt u opgeven of het bestaande element door het nieuwe item moet worden vervangen. Deze optie is beschikbaar bij alle methoden voor het importeren of kopiëren van bibliotheekelementen.

Het dialoogvenster Bibliotheekconflict oplossen wordt weergegeven wanneer u probeert elementen te plaatsen die conflicteren met bestaande elementen in een document. Er is sprake van een conflict wanneer u een element vanuit een brondocument kopieert dat al bestaat in het doeldocument en de elementen verschillende wijzigingsdatums hebben. U kunt naamgevingsconflicten voorkomen door uw elementen in mappen te ordenen in de bibliotheek van uw document. Het dialoogvenster wordt ook weergegeven wanneer u een symbool of een component in het werkgebied van uw document plakt en u al een kopie van het symbool of de component hebt met een andere wijzigingsdatum.

Wanneer u ervoor kiest de bestaande elementen niet te vervangen, probeert Animate het bestaande element te gebruiken in plaats van het conflicterende element dat u plakt. Wanneer u bijvoorbeeld een symbool met de naam Symbool 1 kopieert en plakt in het werkgebied van een document dat al een symbool met de naam Symbool 1 bevat, maakt Animate een instantie van het bestaande Symbool 1.

Wanneer u ervoor kiest de bestaande elementen te vervangen, vervangt Animate de bestaande elementen (en alle instanties ervan) door de nieuwe elementen met dezelfde naam. Wanneer u het importeren of kopiëren annuleert, wordt de bewerking geannuleerd voor alle elementen (niet alleen de elementen in het doeldocument die conflicteren).

U kunt alleen identieke bibliotheekelementtypen vervangen. Met andere woorden, u kunt een geluid met de naam Test niet vervangen door een bitmap met de naam Test. In een dergelijk geval worden de nieuwe elementen aan de bibliotheek toegevoegd met het woord Kopie in de naam.

Opmerking:

het vervangen van bibliotheekitems met deze methode kan niet ongedaan worden gemaakt. Maak een back-up van uw FLA-bestand voordat u complexe plakbewerkingen gaat uitvoeren die het vervangen van conflicterende bibliotheekelementen omvatten.

Wanneer het dialoogvenster Bibliotheekconflict oplossen wordt weergegeven als u bibliotheekelementen in een document importeert of kopieert, moet u het naamgevingsconflict oplossen.

Naamgevingsconflicten tussen bibliotheekelementen oplossen

  1. Voer een van de volgende handelingen uit in het dialoogvenster Bibliotheekconflict oplossen:

    • Klik op Bestaande items niet vervangen wanneer u de bestaande elementen in het doeldocument wilt behouden.

    • Klik op Bestaande items vervangen wanneer u de bestaande elementen en de instanties ervan wilt vervangen door de nieuwe elementen met dezelfde naam.

Werken met bibliotheekitems

Wanneer u een item in het deelvenster Bibliotheek selecteert, wordt een miniatuur van het item aan de bovenkant van het deelvenster Bibliotheek weergegeven. Als het geselecteerde item een animatie of een geluidsbestand is, kunt u de knop Afspelen in het voorbeeldvenster van de bibliotheek of de Bediening gebruiken om het item voor te vertonen.

Bibliotheekitems zoeken op basis van hun koppelingsnaam

In het bibliotheekzoekvenster kunt u zoeken naar symbolen op basis van hun naam of hun ActionScript-koppelingsnaam.

  • Als u wilt zoeken naar een bibliotheekitem, typt u de eerste paar letters van de symboolnaam of van de ActionScript-koppelingsnaam van het bibliotheekitem. Terwijl u typt, wordt een lijst met overeenkomende symbolen weergegeven in het deelvenster Bibliotheek.

Bibliotheekitem gebruiken in het huidige document

  1. Sleep het item van de bibliotheek naar het werkgebied.

    Het item wordt aan de huidige laag toegevoegd.

Object op werkgebied omzetten in een symbool in de bibliotheek

  1. Selecteer een object op een werkgebied, klik met de rechtermuisknop en selecteer Omzetten in symbool.

Bibliotheekitem in het huidige document gebruiken in een ander document

  1. Sleep het item van het deelvenster Bibliotheek of het werkgebied naar het deelvenster Bibliotheek of het werkgebied of een ander document.

Bibliotheekitems kopiëren uit een ander document

  1. Selecteer het document dat de items van de bibliotheek bevat.
  2. Selecteer de bibliotheekitems in het deelvenster Bibliotheek.
  3. Selecteer Bewerken > Kopiëren.
  4. Selecteer het document waarnaar u de bibliotheekitems wilt kopiëren.
  5. Selecteer het deelvenster Bibliotheek van dat document.
  6. Selecteer Bewerken > Plakken.

Bibliotheekitem bewerken

  1. Selecteer het item in het deelvenster Bibliotheek.
  2. Selecteer een van de volgende opties in het optiemenu voor het deelvenster Bibliotheek:
    • Als u een item in Animate wilt bewerken, selecteert u Bewerken.

    • Als u een item in een andere toepassing wilt bewerken, selecteert u Bewerken met en selecteert u een externe toepassing.

Opmerking:

Wanneer u een ondersteunde externe editor start, opent Animate het oorspronkelijke geïmporteerde document.

Naam bibliotheekitem wijzigen

Als u de naam van een item in de bibliotheek of van een geïmporteerd bestand wijzigt, wordt hierdoor niet de bestandsnaam gewijzigd.

  1. Ga als volgt te werk:
    • Dubbelklik op de naam van het item.

    • Selecteer het item en selecteer Naam wijzigen in het optiemenu voor het deelvenster Bibliotheek.

    • Klik met de rechtermuisknop (Windows) of houd de Control-toets ingedrukt en klik (Macintosh) op het item en selecteer Naam wijzigen in het contextmenu.

  2. Voer een nieuwe naam in het vak in.

Bibliotheekitem verwijderen

Wanneer u een item uit de bibliotheek verwijdert, worden ook alle instanties of representaties van dat item in het document verwijderd.

  1. Selecteer het item en klik op het prullenbakpictogram onder aan het deelvenster Bibliotheek.

Naar ongebruikte bibliotheekitems zoeken

Als u het document wilt ordenen, kunt u naar ongebruikte bibliotheekitems zoeken en ze verwijderen.

Opmerking:

Het is niet noodzakelijk ongebruikte bibliotheekitems te verwijderen om de bestandsgrootte van een Animate-document te verkleinen, omdat ongebruikte bibliotheekitems niet in het SWF-bestand worden opgenomen. Items die zijn gekoppeld voor exporteren worden echter wel in het SWF-bestand opgenomen.

  1. Ga als volgt te werk:
    • Selecteer Ongebruikte items in het optiemenu voor het deelvenster Bibliotheek.

    • Sorteer bibliotheekitems in de kolom Telling; dit geeft aan dat een item in gebruik is.

Geïmporteerde bestanden in de bibliotheek bijwerken

Als u een externe editor gebruikt om bestanden aan te passen die u in Animate hebt geïmporteerd, zoals bitmaps of geluidsbestanden, kunt u de bestanden in Animate bijwerken zonder ze opnieuw te importeren. U kunt ook symbolen bijwerken die u uit externe Animate-documenten hebt geïmporteerd. Als u een geïmporteerd bestand bijwerkt wordt de inhoud vervangen door de inhoud van het externe bestand.

Opmerking: U kunt de geanimeerde GIF-bestanden die zijn geïmporteerd vinden in een afzonderlijke map onder de hoofdmap van de bibliotheek. Alle gekoppelde bitmaps hebben een naam gekregen die is gebaseerd op hun volgorde. 

  1. Selecteer het geïmporteerde bestand in het deelvenster Bibliotheek.
  2. Selecteer Bijwerken in het optiemenu voor het deelvenster Bibliotheek.

Bibliotheekelementen kopiëren tussen documenten

U kunt bibliotheekelementen op een aantal manieren vanuit een brondocument kopiëren naar een doeldocument. Ook kunt u symbolen tussen documenten als gezamenlijke bibliotheekelementen delen tijdens het ontwerpen of bij uitvoering.

Wanneer u probeert elementen te kopiëren die dezelfde naam hebben als elementen in het doeldocument, kunt u in het dialoogvenster Bibliotheekconflict oplossen aangeven of u de bestaande elementen wilt overschrijven of wilt behouden en nieuwe elementen met aangepaste namen wilt toevoegen. U kunt bibliotheekelementen in mappen ordenen om het optreden naamconflicten bij het kopiëren van elementen tussen documenten te minimaliseren.

Bibliotheekelement kopiëren met kopiëren en plakken

  1. Selecteer het element in het werkgebied in het brondocument.

  2. Selecteer Bewerken > Kopiëren.

  3. Maak het doeldocument tot actief document.

  4. Plaats de aanwijzer in het werkgebied en selecteer Bewerken > In midden plakken om het element in het midden van het zichtbare plakbord te plakken. Selecteer Bewerken > Op plaats plakken om het element op dezelfde locatie als in het brondocument te plaatsen.

Bibliotheekelement kopiëren door te slepen

  1. Open het doeldocument, selecteer het element in het deelvenster Bibliotheek in het brondocument en sleep het element vervolgens naar het deelvenster Bibliotheek in het doeldocument.

Bibliotheekelement kopiëren door de bibliotheek van het brondocument in het doeldocument te openen

  1. Maak het doeldocument actief en selecteer Bestand > Importeren > Externe bibliotheek openen.

  2. Selecteer het brondocument en klik op Openen.

  3. Sleep een element van de bibliotheek van het brondocument naar het werkgebied of naar de bibliotheek van het doeldocument.

Dit werk is gelicentieerd onder de Creative Commons Naamsvermelding/Niet-commercieel/Gelijk delen 3.0 Unported-licentie  De voorwaarden van Creative Commons zijn niet van toepassing op Twitter™- en Facebook-berichten.

Juridische kennisgevingen   |   Online privacybeleid